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CHAPTER 1:

Welcome to Magento!
Magento Enterprise Edition empowers you to create rich, differentiated consumer
experiences that maximize revenue and help you achieve the highest levels of success.
Here are a few ways it can help you drive revenue, and save time and money:

l Instant access to robust enterprise features. No other platform provides the variety
of built-in tools and features, at any price point.

l Operate more efficiently. An intuitive platform that is easy to set up, implement,
and manage by non-technical resources—or even by yourself.

l Unparalleled flexibility and control. Whether you’re refreshing your brand or scaling
up your business, invest in a platform that integrates with your existing business
systems to support your business as it grows.

Magento Enterprise Edition is the only eCommerce solution that delivers enterprise-
class capabilities and performance at the most compelling lowest total cost of
ownership, with flexibility and scalability to support your aggressive business goals.

Magento Enterprise Edition
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Resources
Magento provides a wealth of business and technical resources, self-help tools, and services
to help you succeed. Our team is here to help you plan, build, and optimize your online
channel.

For an overview of the resources available to you, see the video, “Getting to Know Your
Support Resources” in the Resources for Merchants section of your Magento account.

Product Documentation

Whether you’re amerchant, designer, developer, or
all of the above, this is where you’ll gain a deeper
insight into how you can leverage the power of
Magento to grow your business.

Security Center

Join Magento‘s Security Alert Registry to get the
latest information on all potential vulnerabilities. See
also: Security Best Practices.

Commerce Resources

Gain access to expert insight and online business
resources to help develop and improve your store.
Ebooks, Magento white papers,and webinars.

http://enterprise.magento.com/resources/technical
http://magento.com/security
http://magento.com/resources/business
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Forums

TheMagento forums provide access to a network of
dedicatedMagento enthusiasts who share tips,
tricks and support.

Blog

Check out theMagento blog for the latest
information about new features, trends, best
practices, upcoming events, andmore!

Subscribe to our feed to have the blog delivered to
your desktop or smart phone.

Webinars

Expand your horizons! Register to attend the
upcomingMagento webinar, or catch up on
previous, archived webinars.

Help & Support

Our expert tech support team is here to help you
with a wide variety of technical support issues,
including basic design and store configuration.

5Magento Enterprise Edition User Guide, Version 1.14.2.1
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Training & Certification

Magento has training courses for every role,
includingmarketers, product managers, designers
and developers. Magento U courses provide
practical, hands-on exercises that help students
learn quickly.

Partners

Need help to set up or fine-tune your store?
Magento’s certified developers and consultants are
experts in store setup, design, integration and
marketing. Find a certified expert and jumpstart your
business today!

Expert Consulting Services

Magento’s Expert Consulting Group (ECG) helps
Magento Enterprisemerchants and Solution
Partners maximize their success. Our experts offer
comprehensive analysis and best practice
recommendations, from architecture planning
through post-deployment.

http://magento.com/training/overview
http://magento.com/partners/overview
http://www.magentocommerce.com/consulting/
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Join the Conversation!
Keep up with the latest news from the ecosystem, and connect with other merchants and
developers on social media networks.

Facebook

Find out what’s happening,
and join the discussion on our Facebook page!

Twitter

Follow us on Twitter
and hear the latest news!

YouTube

Learn while you watch videos on our YouTube
channel!

7Magento Enterprise Edition User Guide, Version 1.14.2.1
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LinkedIn

Join aMagento group on LinkedIn.

Meetup

Find aMagentoMeetup near you!

http://www.linkedin.com/groups?home=&gid=146360&trk=anet_ug_hm
http://www.meetup.com/find?allMeetups=false&keywords=Magento&radius=Infinity&userFreeform=San+Jose%2C+CA&mcId=z95101&mcName=San+Jose%2C+CA&sort=default
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CHAPTER 2:

About This Release
We are pleased to bring to you Magento Enterprise Edition, 1.14.2.1, which includes
several previously released security patches, performance updates, and new mobile app
development resources. To learn more, see the Release Notes in the appendix of this
guide.

Magento Home

http://enterprise.magento.com/
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System Requirements
STANDARD SYSTEM REQUIREMENTS

Environment LAMP (Linux, Apache, MySQL, and PHP) or LNMP stack

Operating System Linux x 86, x86-64

Web Server Apache 2.2.x
Apache 2.0.x
Apache 1.3.x
Nginx 1.7.x (for CE1.7 or EE 1.12 or greater)

Server Hosting l Ability to run scheduled jobs (crontab) with PHP 5.

l Ability to override options in .htaccess files.

PHP PHP 5.5
PHP 5.2.13 - 5.3.x, 5.4.x with patch.
Required extensions:

PDO_MySQL
simplexml
mcrypt
hash
GD

DOM
iconv
curl

SOAP (forWebservices API)

Additional configuration:
safe_mode off

memory_limit no less than 256MB (512MB recommended)

Database MySQL 5.6 (Oracle or Percona)

SSL A valid security certificate is required for HTTPS. Self-signed
certificates are not supported.
We recommend if possible to run both the storefront and Admin on
HTTPS.

Browsers Microsoft Internet Explorer 7 or later
Mozilla Firefox 3.5 or later
Apple Safari 5 or later (for Mac only)
Google Chrome 7 or later
Adobe Flash plug-in should be installed

https://www.magentocommerce.com/download
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STANDARD SYSTEM REQUIREMENTS

Supported Technologies

Redis Redis can be used for session or cache storage.
redis-server version 2.6.9 or later
phpredis version 2.2.2 or later

Memcached Memcached can be used for session or cache storage.

Installing Magento
Magento Enterprise Edition is typically installed by an IT department or independent
professional. To find a qualified service provider, see our list of Solutions Partners.

To learn more about installing or upgrading Magento, see the “Upgrading Magento
Enterprise” document that you received when you purchased Magento Enterprise Edition.
For the most up-to-date information on updates, changes, new features, bug fixes, and
other important information about each version of Magento Enterprise Edition, see the
Release Notes in the Appendix of this guide.
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Prelaunch Checklist
After you complete the design, development, and testing of your store, check the following
configuration settings to make sure everything is correct before the store “goes live.”

General Settings
Website Restrictions
Make sure that access to the website is not restricted.

Unsecure URL
Verify that the Base URL for the storefront is correct for the live environment.

Secure URL
Before launching your store, install a 100% Signed and Trusted Security Certificate
for the server that is using a Secure Base URL.

Store Email Addresses
Complete all the email addresses that are used to send and receive email
notifications, such as new orders, invoices, shipments, credit memos, product price
alerts, newsletters, and so on. Make sure that each field contains a valid business
email address.

Sales Settings
Sales Document Setup
Make sure that your invoices and packing slips include the correct business
information and reflect your brand.

Taxes
Make sure that taxes are properly configured according to your business tax rules
and local requirements.

ShippingMethods
Enable all carriers and shippingmethods to be used by the company.
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Google API
Magento is integrated with Google API to allow your business to useGoogle
Merchant Center, Google Analytics, Google Sitemap, andGoogle Shopping. Make
sure to set up aGoogleMerchant Account, and then verify and claim your website
URL.

PayPal
If you plan to offer your customers the convenience of paying with PayPal, open a
PayPal Merchant Account, and set up a payment method. Run some test
transactions in Sandbox Mode before the store goes live.

Payment Methods
Enable the payment methods that you plan to use, andmake sure that they are
properly configured. Check the order status settings, accepted currency, allowed
countries, and so on.

System Settings
Cron
Cron jobs are used to process email, catalog price rules, newsletters, customer
alerts, Google sitemaps, update currency rates, the cleaning of database logs, and
so onMake sure that Cron jobs are set to run at the appropriate time interval, in
minutes.

Log Cleaning
Log cleaningmust be enabled tomake sure that the database log tables are
periodically cleaned. If you do not set this to clear your database log_ tables, your
database can grow very large when the store has a full traffic load. Set the number of
days the log is saved according to your needs and server capacity.

Transactional Emails
Update the default email templates to reflect your brand. Make sure to update the
configuration if you create new templates.
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CHAPTER 3:

Your Magento Account
You can find the information related to the products and services you have signed up
to receive, as well as your contact and billing information in the dashboard of your
Magento account. Your Magento account has a separate login from your store, and can
be accessed from either the Magento website or from your store’s Admin.

Your Magento Account
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To log in to your Magento account:

1. Navigate to the Magento site: http://www.magento.com

2. In the upper-right corner, click the My Account link.

3. Enter your First Name, Last Name, Email Address. Then, take a moment to share the
functions your company primarily performs, and your role.

4. Enter your User Name or Email , and Password. Then, click the Submit button. Your
account dashboard appears.

Log In to Your Account
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Sharing Your Account
Your Magento account contains information that can help trusted employees and service
providers manage your site. As the primary account holder, you can grant either full or
limited access to other Magento account holders. For example, you might want to give
someone the ability to open a support ticket or download resources.

When your account is shared, all sensitive information, such as your billing history or
credit card information, remains protected. It is not shared at any time with other users.

For a demonstration of shared accounts, see the video, “Giving and Getting Shared Access”
in the “Resources for Merchants” section of your Magento account.

Shared Account Access

All actions taken by users who have shared access to your account are your sole responsibility.
Magento Inc. is not responsible for any actions taken by users to whom you grant shared
account access.

To set up a shared account:

1. If the person that you want to give shared access doesn’t have an account, have them
create an account from the Magento site.

Then, ask them to provide you with the following information from their account:

Magento Account ID The Magento account ID is in the upper-left corner of the
account dashboard, under “My Account.”

Email address The email address can be found under Account Settings.

2. Log in to your Magento account.

17Magento Enterprise Edition User Guide, Version 1.14.2.1
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3. In the panel on the left, select Shared Access. Then, click Add New User.

4. In the New User Information section, enter the Acct ID and Email address from the new
user’s Magento account.

5. In the Shared Information section, do the following:

a. Enter a Sharename to identify the shared account. The Sharename appears as an
option in the Switch Accounts list, and is also the title of the shared account page.
Choose a name that identifies the account owner. For example, “Jane’s Account.”

b. To share your contact information with the new user, select the checkbox next to each
item you want to share:

l Your Email

l Your Phone

New User and Shared Information

6. Under Grant Account Permissions to the New User, select the checkbox of each account
component that you want to share.

Grant Permission

7. When complete, click the Create Shared Access button.

You are notified when the new role is saved, and an email invitation is sent to the new user
with instructions to access the shared account. In your account, the new user appears in
the Manage Users & Permissions section of the Shared Access page.
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Create Shared Access

To access a shared account:

1. When you receive an invitation to a shared account, the first thing you must do is log in to
your own Magento account.

2. In the upper-right corner, set Switch Accounts to the shared account.

The shared account displays a welcome message and contact information. The panel on the
left includes only the items that you have permission to use.

Switch Accounts

3. When you are ready to return to your own account, set Switch Accounts to “My Account.”
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CHAPTER 4:

Quick Tour
This quick tour follows the customer-decision journey that leads to a purchase on an
eCommerce site powered by Magento Enterprise Edition. Each item is linked to a topic
in this guide, where you can learn more about the subject. You can also follow along on
your computer with the sample data.

Free Demo



Storefront Demo CHAPTER 4:  Quick Tour

Storefront Demo
For the storefront example, we’ll use Madison Island, a fictional fashion website that we
created to highlight some of Magento’s key features and functionality.

To sign up for a demo store:

1. On the Magento site, click the Free Demo button at the top of the page.

2. Complete the registration form, and click the Send Request button.

You will receive your login instructions and credentials by email.

Madison Island Storefront
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Demo Store Admin
During this walk through of Magento Enterprise, we’ll switch between the storefront and
the Admin. To follow along, you can open one browser tab to the demo Magento store, and
another to the store Admin. If your Admin access times out after a period of keyboard
inactivity, simply log in again and you’ll be back on track.

Admin Login

To log in to the admin:

1. In the email you received, click the URL for the store Admin.

2. Enter your User Name and Password. Then, click the Login button.

The Dashboard is the first page that appears when you log in to the Admin. It’s a hub of
important information about the health of your eCommerce site, and includes snapshots of
Lifetime Sales, Average Orders, Top Search Terms, Best Sellers, Most Viewed Items, and
more.

Admin with Dashboard
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Customer Journey
Attract New Customers

Magento Enterprise Edition includes SEO
functionality out of the box. Improve your search
ranking and attract themost visitors to your site.

Engage Your Customers

Design your site with predesigned templates, or
create a custom design of your own, and give your
customers tools to help them find what they want
faster.

Increase AOV

Increase average order value with relevant, targeted
promotions and product suggestions that encourage
your customers to shopmore.
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Moment of Purchase

Give your customers a faster and easier way to
check out. Calculate shipping and taxes
automatically, and integratemultiple payment
methods all on a single page.

Customer Retention

Create andmanage newsletters, promotions,
customer rewards to keep your customers coming
back for more.

Loyalty & Advocacy

Encourage customers to write product reviews,
create wishlists, and join customer rewards
programs. This will strengthen your relationship with
your customers, who in return, will speak positively
of your business to friends and family.
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Attract NewCustomers
Magento Enterprise Edition makes it easy to create a “search engine friendly” website to
help the right customers find your store.

Search Engine Optimization

Magento offers powerful, native capabilities to streamline Search Engine Optimization
(SEO) practices for content and site exposure that are integrated with the Admin, and tied
directly into the user experience.

CustomURLs

Custom URLs are short, clean, and easy to remember. You can also autogenerate search-
friendly URLs to streamline your purchase path.

Meta Data

Improve your search engine rankings by choosing specific criteria that helps search engines
to find and index your products more easily. Meta data can be entered for product,
category, and content pages.

Sitemap

Link to a sitemap from the footer of your store to give customers an overview of the catalog
structure, with links to all categories and products in the store. You can also easily
integrate your store with Google Sitemap.

Analytics

In addition to monitoring your site from the Admin dashboard, you can integrate third-
party analytics tools such as Google Analytics, for detailed statistics on traffic and sales.
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Engage Your Customers
Magento Enterprise Edition makes it easy to create a customized, engaging site experience.
Encourage your customers to spend more time exploring your site, and give them the tools
to make it easy to find what they want faster.

Content Management System

Magento’s robust CMS software systemmakes it
easy to store pages or parts of pages that you can
use in your store. It’s so intuitive that someone
without a technology background canmanage site
content easily.

Design & Theme

Control the visual elements of your store with a
collection of templates and skin files. You can apply
these visual elements to all pages in your store,
giving your store a cohesive look and feel.

Staging Environment

After you have designed or added new features to
your site, test features and plug-ins before they go
live on a password-protected private staging
environment.
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Multiple Stores, Sites & Views

Control the look and feel of multiple sites, introduce
new market and languages, and track analytics from
a single Admin. All without purchasing additional
licenses.

Multiple Devices

Magento’s powerful features make it easy to create
storefronts optimized for iPhone, Android, andMobile
Opera browsers to help you engage consumers with
mobile eCommerce now and into the future.

Rewards & Loyalty

Give your best customers VIP treatment. Offer
exclusive access toMember Only sales or private
sales to increase brand loyalty.

Gift Registries

Your customers can create gift registries for special
occasions and send invitations to purchase items
from the gift registry. Magento keeps track of all
items purchased and the quantities remaining.
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Private Sales

Private sales are a great way to leverage your
customer base to generate buzz and new leads, or to
offload surplus inventory. Create limited-time sale or
a private sale for members only.

Shopping Tools

Your store includes a set of shopping tools that
create opportunities for your customers to interact
and share the experience with friends.

Sophisticated Search

Filter product by price, manufacturer, or any other
criteria to reduce the time to purchase. Performance
and search quality are improved with features like
spelling, synonyms, stop words, and weighted
attributes.
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Increase AverageOrder Value (AOV)
Magento Enterprise Edition provides a range of merchandising tools and other tools to help
you tailor the shopping experience to your customers. This encourages your customers to
put more items in their shopping carts and to spend more money.

Targeted Promotions

Magento's rule-based engine lets you segment
customers dynamically and build segments based on
specific characteristics such as customer address,
order history, shopping cart content, andmuchmore.

Coupons

Create limited-time offers and coupons that
customers can scan with their phone and apply to a
purchase.

Product Suggestions

Another way to increase AOV is to cross-sell and
upsell products related to customer searches.
Manage specific product suggestions easily by using
a condition-based tool to administer rules.
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Email Reminders

Send automated reminder emails to customers who
have added items to their carts or wishlists, but
haven’t made a purchase. A variety of triggers can
launch automated emails, including total cart value,
quantity, items in the cart, andmore.

Full-Page Caching

Enhance performance by caching primary pages.
Caching pages improves server response times,
reduces load, and increases sustainable traffic.

You can use tags to define which components to
cache, so only relevant pages are cached as updates
take place. It also has the ability to identify and
differentiate visitors from shoppers.

Sales Order Archiving

Archiving orders frees resources and improves
performance when sales reps are assisting
customers with orders.

31Magento Enterprise Edition User Guide, Version 1.14.2.1



Customer Journey CHAPTER 4:  Quick Tour

32 Magento Enterprise Edition User Guide, Version 1.14.2.1

User Permissions & Roles

Restrict access to data in the Admin on a “need to
know” basis. Createmultiple Admin roles with
privileges for prices and promotions. Track and
review all activity at a granular level for specific
stores and websites.

Index Management

Automatic reindexing takes place whenever prices
change, shopping carts are updated, or new
categories created. Reindexing is a background
process that does not interfere with store operations.

Moment of Purchase
Now that you’ve given your customer an engaging shopping experience, make it easy for
them to complete their purchases. Magento helps you streamline the checkout process and
boost conversion rates.

Order Processing

Magento supports a complete order processing workflow that makes it easy to track the
status of orders and monitor communication between sales reps and customers.

Shipping Labels

Merchants have complete control over package characteristics such as weight and size.
When creating shipping labels, shipping rate and barcode information originates directly
from the shipping carrier and can be provided for single or multiple orders at once.

Multiple Shipping Options

Magento supports a variety of shipping methods so you can give your customers a choice
at checkout. Customers can see a real-time estimate of shipping charges right from the
shopping cart.
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Multiple Payment Options

Magento Enterprise Edition supports the payment methods and currencies needed for
global commerce. You can choose the ones you want to offer, and at checkout, your
customers can choose the ones they prefer.

PayPal Merchant Solutions

It's easy to integrate a PayPal Payments account to provide your customers faster, more
secure checkout options.

Payment Bridge

This secure payment application is PA-DSS compliant, and makes it easier to meet PCI
compliance and to industry standards for security. Magento Secure Payment Bridge is
installed separately from Magento Enterprise Edition.

Assisted Shopping

Assisted shopping makes it easy to create orders on behalf of customers. Customer service
reps have access to shopping cart contents, and can move items from wishlists to the
shopping cart, order by SKU, apply coupon codes, and more.

Security

Whether an order is fulfilled online or over the phone, Magento provides enterprise-level
security and peace of mind. Magento offers CAPTCHA and SSL encryption, with best-in-
breed encryption and hashing algorithms to protect the security of the system.
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Customer Retention
Magento makes it easy for you to get repeat business and build brand loyalty. Magento
gives you total control and flexibility over creating and revising goodies like rewards
programs, custom coupons and automated emails to keep your customers coming back
again and again.

RMA

Customers can submit requests for Return
Merchandise Authorization from your store. You can
create shipment orders in a carrier system, and print
shipping labels with RMA numbers.

Store Credits

Keep customers loyal and happy by issuing refunds
as store credits or virtual gift cards. This ensures that
themoney they spend stays with you and your
merchandise.

Reward Points

Drive customer engagement with reward programs
with award points based on a range of transactions
and customer behaviors. Base redemption on a
variety of factors, such as balance, customer history,
and conversion rates.
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CustomCoupons

Use customer segmentation to create coupons for
use on—or off—your site. Create coupons for social
media or email campaigns. You can also create
unique coupon codes, and design them the way you
like.

Newsletters

Stay in touch with current customers who have opted
to receive newsletters. You can create as many
newsletter templates as you want.

Target Shopping History

Encourage customers tomake return purchases with
targeted promotions based on their shopping history.
With theMagento platform, you can easily build
segments based on your customer base.
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Loyalty & Advocacy
Give customers a direct connection to your brand by allowing them to create customer
accounts where they can see their purchase history, rewards, store credits, and newsletters.
Make it easy for customers to create wishlists and guest registries to attract new customers.
Use ratings and reviews to give new customers objective product opinions and return
customers a sense of community. These features turn customer satisfaction into one of the
most powerful and cost-efficient marketing tools at your disposal.

Dashboard Snapshots

Knowing what’s of interest on your site is crucial to maximize your marketing budget. Use
this information to determine what you should cross- and up-sell to loyal customers, or
which products to put on sale.

Customer Accounts

Opening as account provides customers with a personalized shopping experience that they
can share with their friends. Customers can save their shopping preferences, and manage
their own store billing and shipping information.

Advocacy Tools

Customers who share wishlists and gift registries with family and friends are making a
powerful endorsement of your brand. Customers create these personalized lists from
products they choose. When shared by email or RSS feed, these simple lists are powerful
advocacy tools.

Reviews & Ratings

Product reviews give your customers a way to engage with your brand while fostering a
sense of community. You can curate your reviews with tools to help you edit and approve
comments for inappropriate content before they go live.
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Success!
Opening your Magento store for business requires your attention in the following areas.
While there are virtually any number of customizations you can make to the storefront and
Admin, you can use each link in this is list as a place to start.

Implementation

If you need help setting up your store, you can
choose from our vast network of Magento Solutions
Partners.

Design

You can design your own home page or work with an
experiencedMagento designer or Solutions Partner
to customize your site.

Product Catalog

Configure products, create categories, import
existing product catalogs, and leverage APIs or third-
party datamanagement solutions.
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Payment Methods

Magento supports a wide variety of payment
methods, services, and gateways that you can offer
for your customers’ convenience.

Shipping Methods

Magento shippingmethods are easy to set up and
give you the ability to connect with carriers who can
ship your products all over the world.

Taxes

Manage your taxes with our native tools, or add third-
party extensions fromMagento Connect.

Thanks for your order!

Magento can help you build relationships with your
customers, to bring them back to your store, again
and again.



Basic Configuration



In this section…

Store Admin

Store Details

Websites, Stores & Views

Industry Compliance



41Magento Enterprise Edition User Guide, Version 1.14.2.1

CHAPTER 5:

Store Admin
Your store Admin is the password-protected back office where you can set up products,
promotions, manage orders, and perform other administrative tasks. This chapter
provides a high-level overview of management tasks and tools that you might use on a
daily basis, including:

l Admin Login

l Message Inbox

l Admin Menu

l Admin Tools

Store Admin
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Admin Login
All of the basic configuration tasks are performed in the Magento backend, which is referred
to in this guide as your store Admin.

Admin Login

To log in to your store admin:

1. For a new Magento installation, do the following:

a. On the last page of the Magento Installation Wizard, click the Go to Backend button.

b. In the address bar of your browser, enter the URL that you specified in the Magento
Installation Wizard, followed by the “/admin” suffix. If you specified a different suffix
for the Admin during the installation, use that instead. Most Admin URLs looks like
this:

http://www.mystore.com/admin

2. To use the Magento EE Demo Store, enter the following URL:

http://enterprise-admin.user.magentotrial.com/admin/

You can bookmark the Admin Login page for easy access.

3. Do one of the following:

l Enter the User Name and Password that was specified during the Magento installation.

l For the Magento Enterprise Demo Store, use the following login credentials:

User Name: admin

Password: 123123a

4. Click the Login button.
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Message Inbox
Your store has an inbox for the messages received from Magento. The messages are rated by
importance, and might refer to updates, patches, new releases, scheduled maintenance,
upcoming events, and more. Any message that is considered to be of major importance
appears in a pop-up window when you log into your store. You can manage your message
inbox much as you would manage your email. Check it often to stay up-to-date on the
latest information from Magento!

Incoming Message

To manage incoming messages:

1. When the Incoming Messages box appears, do one of the following:

l Click the Read Details link for more information.

l Click the Close box to remove the popup and continue.

A Latest Message notice also appears to the left, just below the header of your store. As
with the popup box, you can click the Read Details link for more information.
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Message Notifications Below Header

2. To read your messages, click Go to messages inbox.

The messages in your inbox are marked by severity, with the most recent at the top.

3. After reading a message, you can apply any of the following actions to the message:

l For more information, click the Read Details link.

l To keep the message, click the Mark As Read link.

l To delete the message from your inbox, click the Remove link.

Messages Inbox
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To apply an action to multiple messages:

1. On the Admin menu, select System > Notifications.

2. In your message inbox, do one of the following:

l Select the checkbox at the beginning of each message you want to manage.

l Click one of the group selection options above the list to select multiple messages.

3. When the messages that you want to manage are selected, set Actions to one of the
following:

l Mark as Read

l Remove

4. Click the Submit button to complete the process.

Messages Inbox

Message Importance

SEVERITY COLOR DESCRIPTION

Critical Red Indicates an important, time-sensitivemessage.

Major Orange The default message severity level.

Notice Green Indicates that a routine operation has taken place.
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Notification Setup
You can specify how often the Inbox is updated from one to twenty-four hours. If the
Admin has a secure URL, you must set the notifications to be delivered over HTTPS.

To configure Admin notifications:

1. On the Admin menu, select System > Configuration.

2. In the panel on the left, under Advanced, select System.

3. Click to expand the Notifications section, and do the following:

a. If the store Admin runs over a secure URL, set Use HTTPS to Get Feed to “Yes.”

b. Set Update Frequency to how often you want to receive updates. You can select a time
interval from one- to twenty-four hours.

Notifications

4. When complete, click the Save Config button.

http://merch.docs.magento.com/ee/user_guide/Magento_Enterprise_Edition_User_Guide.html#configuration/advanced/system.html#Notifications


CHAPTER 5:  Store Admin Admin Menu

Admin Menu
All of the tools you need to manage the operation and maintenance of your store are
available in the admin menu.

Dashboard

The Dashboard gives you a quick overview of the
sales and customer activity in your store. It is usually
the first page that appears when you log in to the
admin.

Sales

The Sales menu is where you can find everything
related to processing an order, including current and
past orders, invoices, shipments, credit memos,
terms and conditions, and taxes.

Catalog

The Catalogmenu controls everything related to your
product catalog, including products, categories,
attributes, URL rewrites, search terms and indexing,
product reviews, tags, andGoogle Sitemap.
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Customers

The Customers menu is where you canmanage
customer accounts, groups and segments,
invitations to events, gift registries, gift cards, and
rewards. You can even see which customers are
online at themoment.

Promotions

The Promotions menu is where you set up catalog
and shopping cart price rules, coupons, promotional
banners, and automated email reminder rules. Rules
trigger actions when conditions aremet.

Newsletter

The Newsletter menu contains the tools you need to
publish newsletters andmanage your list of
subscribers.

CMS

The CMS menu is where you create andmanage
content for your store. You can even create a
hierarchy of pages with version control and
navigation. Other types of content you can create
include static blocks, banners, “widgets,” and polls.



CHAPTER 5:  Store Admin Admin Menu

Reports

The Reports menu provides a broad selection of
reports that give you insight into every aspect of your
store, including sales, shopping cart, invitations,
products, customers, tags, reviews, and search
terms.

System

The Systemmenu includes tools to configure and
maintain every aspect of your store. In addition, you
can install extensions andmanageWeb Services for
integration with other applications.
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Admin Tools
The Admin includes many lists of data for products, orders, customers, search terms,
pages, blocks, banners, and so on. Each list has the same set of tools for finding records,
pagination, sorting, filtering, selecting, and applying actions to records.

Global Search

The Global Search box can be used to find any value in the database, including product,
customer, and order records.

Sorting

The header of each column can be used to sort the list in ascending or descending order.

Filters

The filters in the header of each column can be used to limit the list to specific values.
Some filters have additional options that can be selected from a list box, and for others, you
can simply type the value you want to find.

Pagination

The pagination controls are used to view the additional pages of results.

Selection

The Selection controls above the column headers have links to Select All, Unselect All,
Select Visible, and Unselect Visible

Actions

The Action control applies an operation to any record with a checkmark in the first column.
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Global Record Search
The global search box is located in the Admin header, and can be used to find any record in
the database. The results can include customers, products, orders, or any related attribute.

Global Record Search

To search records globally:

1. Type the first few letters of what you are looking for into the global search box.

2. In the list of closely matching items, click the one that you want to find.
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List Controls
Many pages in the Admin have a list of records that is displayed in a grid, with controls at
the top of each column. The controls can be used to sort the list in ascending, or
descending order, based on the values in the column. In addition, you can enter a value at
the top of the column to filter the list.

Sort Controls

To sort a list:

1. In the upper-left corner, set Choose the Store View to the define the scope of the data to
be retrieved.

2. Click the column name of any header. The arrow indicates the current order as either
ascending or descending.

3. Use the pagination controls to view additional pages in the collection.

To set the pagination controls:

1. Set View to the number of records that you want to view per page.

2. In the Page box, enter the page number you want to view, or click the arrow button to
advance to the next or previous, page.
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Pagination Controls

To filter the data:

1. In the box below the column header, either enter or select the value you want to find.

2. Click the Search button.

Filter Controls
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Actions Control
When working with lists of data, you can use the Actions control to apply an operation to a
single record, or to multiple records. The Actions control lists the operations that can be
applied to the selected records. For example, while working in the Manage Products list,
you can select multiple products, and use the Actions control to change their status from
“Disabled” to “Enabled,” update attributes, or delete them from the database.

The selection of available actions varies by list, and the action selected. For example, when
changing the status of a group of records, a Status box with additional options appears
next to the Actions control.

Applying an Action to Selected Records

Step 1: Select Records

The checkbox in the first column identifies each record that is a target for the action. The
search filters can be used to narrow the list to the records you want to target for the action.
Do the following:

1. Select the checkbox of each record that is targeted for the action. Or, uise the selection links
above the list to the left, to select groups of records. Options include:

l Select All / Unselect All

l Select Visible / Unselect Visible

2. If needed, set the search filters at the top of the columns to list the records you want to
include.

3. In the first column, set the checkbox state to list “Any” record, or only those that match, or
do not match the filter settings.
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Step 2: Apply an Action to Selected Records

1. Set the Actions control to the operation you want to apply.

Example: Update Attributes

1. In the list, select the checkbox of each record to be updated.

2. Set the Actions control to “Update Attributes,” and click the Submit button.

The Update Attributes page lists all the available attributes, organized by group in the
panel on the left.

Update Attributes

3. Select the Change checkbox next to each attribute, and make the necessary changes.

4. Click the Save button to update the attributes for the group of selected records.

5. Click the Submit button.

Checkbox States

STATE DESCRIPTION

Any Lists all records, regardless of checkbox status.

Yes Lists only records with the checkbox selected.

No Lists only records without the checkbox selected.
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CHAPTER 6:

Store Details
The basic information for your store includes the store name and address, telephone
number and email address, that appear on email messages, invoices, and other
communications sent to your customers. In this chapter, you will configure the
following information:

l Store Information

l Store Locale

l Countries Options

l State Options

l Shipping Settings

l Store Email Addresses

l Contact Us
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Store Information
The Store Information section of the configuration provides the basic information that
appears on sales documents and other communications.

To enter the store information:

1. On the Admin menu, select System > Configuration.

2. In the panel on the left, under General, select Store Information. Then, do the following:

a. Enter the Store Name as you want it to appear in all communications.

b. Enter the Store Contact Telephone number, formatted as you want it to appear in all
communications.

c. Select the Country where your business is located.

d. If applicable, enter the Value Added Tax number of your store. To verify the number,
click the Validate VAT Number button.

e. In the text box, enter your Store Contact Address as you want it to appear on sales
documents.

3. When complete, click the Save Config button.

Store Information
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Locale Options
The locale determines the language, country, tax rate, and other settings used throughout a
store. The locale options configure the time zone and language of each store, and identify
the days of your work week in the area.

Locale Options

To set the locale of a store:

1. On the Admin menu, select System > Configuration.

2. In the panel on the left under General, click to expand the Locale Options section.

3. Select your Timezone from the list. Then, do the following:

a. Set Locale to the store language.

b. Set First Day of the Week to the day that is considered to be the first day of the week
in your area.

c. In theWeekend Days list, select the days which fall on a weekend in your area. (To
select multiple options, hold down the Ctrl (PC) or Command (Mac) key.)

4. When complete, click the Save Config button.
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State Options
In many countries, the state, province, or region is a required part of a postal address. The
information is used for shipping and billing information, to calculate tax rates, and so on.
For countries where it is not required, the field can be omitted entirely from the address, or
included as an optional field.

Because standard address formats vary from one country to another, you can also edit the
address template that determines how the information appears on invoices, packing slips,
and shipping labels.

States Options

To set up the state options:

1. On the Admin menu, select System > Configuration.

2. Click to expand the States Options section, and do the following:

3. In the State is required for list, select each country where you want State / Province to be a
required entry. To select multiple options, hold down the Ctrl (PC) or Command (Mac) key.

4. Set Display not required State to one of the following:

Yes In countries where the state field is not required, the field is included in the form
as an optional entry.

No In countries where the state field is not required, the field is omitted from the
form.

5. When complete, click the Save Config button.
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Countries Options
The Countries Options establish the country where your business is located, and the
countries from which you accept payment.

Countries Options

To set the country options for your store:

1. From the Admin menu, select System > Configuration.

2. Click to expand the Countries Options section. Then, do the following:

a. Set Default Country to the country where your business is located.

b. In the Allow Countries list, select each country from which you accept orders. By
default, all countries in the list are selected. To select multiple countries, hold down
the Ctrl (PC) or Command (Mac) key.

c. In the Postal Code is Optional list, select each country where you conduct business
that does not require a ZIP or postal code to be included as part of the street address.

d. In the European Union Countries list, select each country in the EU where you
conduct business. By default, all EU countries are selected.

3. When complete, click the Save Config button.
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Currency
Magento Enterprise Edition gives you the ability to accept currencies from more than two
hundred countries around the world.

Setting Up Currency Rates

The Currency Rate configuration defines the base
currency of your store, and the currencies that you
accept as payment.

Currency Symbols

Currency symbols appear in product prices and sales
documents such as orders and invoices.

Updating Currency Rates

Currency rates can be updatedmanually or imported
into your store as needed, or according to a
predefined schedule.
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Basic Shipping Settings
Shipping Settings

The Shipping Settings establish the point of origin for
all shipments made from your store or warehouse,
and also your preference for managing orders that
are shipped tomultiple addresses.

Shipping Methods

Magento supports a wide range of built-in shipping
methods, including Flat Rate, Free Shipping, Table
Rates, and real-time online rates.

Shipping Carriers

If you have a commercial account with a supported
carrier, you can offer your customers the
convenience of real-time shipping rates, package
tracking, and labels.

Shipping Labels

You can easily create shipping labels for new and
existing orders from the Admin of your store. Labels
can be produced at the time a shipment is created, or
at a later time. Shipping labels are stored in PDF
format and are downloaded to your computer.
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Store Email Addresses
You can have up to five different email addresses to represent distinct functions or
departments for each store or view. In addition to the following predefined email identities,
there are two custom identities that you can set up according to your needs.

l General Contact

l Sales Representative

l Customer Support

Each identity and its associated email address can be associated with specific automated
email messages and appear as the sender of email messages that are sent from your store.

Store Email Addresses
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Step 1: Set Up the Email Addresses for Your Domain

Before you can configure email addresses for the store, each must be set up as a valid email
address for your domain. Follow the instructions from your server administrator or email
hosting provider to create the email address you need.

Step 2: Configure the Email Addresses for Your Store

1. On the Admin menu, select System > Configuration.

2. In the panel on the left under General, select Store Email Addresses. Then, do the
following:

a. Click to expand the General Contact section.

b. If you have multiple stores or views, set the Current Configuration Scope in the
upper-left corner to identify the store or view where the configuration applies. Then,
clear the checkbox after each field so new values can be entered.

General Contact

c. In the Sender Name field, type the name of the person that you to appear as the
sender of all email messages that are associated with the General Contact.

d. In the Sender Email field, type the associated email address.

3. Repeat this process for any other email addresses that you plan to use.

4. When complete, click the Save Config button.

Step 3: Update the Sales Email Configuration as Needed

If you use custom email addresses, make sure to update the configuration of any related
email messages, so the correct identity appears as the sender.

1. In the Configuration panel on the left, under Sales, select Sales Email.

2. Click to expand each section, and make sure that the correct store email is selected as the
sender of the message.

3. When complete, click the Save Config button.
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Contact Us
The Contact Us link in the footer of each page is an easy way for customers to keep in touch
with you. The form is enabled by default, and can be configured to send inquiries to a
specific email address and replies from a specific store identity.

Contact Us
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To configure the Contact Us form:

1. On the Admin menu, select System > Configuration.

2. In the panel on the left under General, click Contacts.

3. If you need to enable the Contact Us form, click to expand the Contact Us section. Then,
set Enable Contact Us to “Yes.”

Contact Us

4. Click to expand the Email Options section. Then, do the following:

Email Options

a. In the Send Emails To field, enter the email address where the form information is to
be sent.

b. Set Email Sender to the store identity you want to use for any replies sent in response
to inquiries you receive.

c. Select the Email Template used to format the data sent from the form.

5. When complete, click the Save Config button.
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CHAPTER 7:

Websites, Stores & Views
When Magento is installed, a main website, default store, and store view are created.
You can create as many additional websites, stores, and store views as you need.
Within each website, you can have multiple stores, and within each store, separate
views. The term hierarchy1 refers to the organization of websites, stores, and views in
a Magento installation.

Websites

A Magento Enterprise store with the sample data
installed has a “MainWebsite,” and a “Private
Sales Website.” You can set up as many
websites as you need, each with its own domain.

Stores

A single website can havemultiple stores—all
managed from the same Admin. Each store can
have a different mainmenu, product selection,
and appearance.

Store Views

Store views are usually used to present the store
in different languages, although they can be used
for other purposes, as well. Customers use the
language chooser in the header to change the
store view.

1The orgnaization of websites, stores, and views in a Magento installation.
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Setting Up Store Hierarchy
Before you begin, carefully plan your store hierarchy in advance because it is referred to
throughout the configuration. Each store can have a separate root category, which makes it
possible to have an entirely different set of navigation for each store.

Manage Stores

To set up a new website:

1. On the Admin menu, select System > Manage Stores.

2. From Manage Stores, click the Create Website button. Then, do the following:

Website Information

a. Enter the Name of the website. The name is for internal reference, and can be the
domain, or anything else to distinguish it from other sites. For example: Private Sales.

b. Enter a Code in lowercase characters that will be used on the server to point to the
domain. For example: private. The code must begin with a lowercase character, and
can include any other combination of letters, numbers, and underscore (_) character.

c. (Optional) Enter a Sort Order number to determine the sequence in which this site is
listed with other sites. Enter a zero to make this site appear at the top of the list.

d. (Optional) Set Default Store to the name of the primary store that is associated with
this website.

e. (Optional) To make this website the default for your hierarchy, select the Set as
Default checkbox.

3. When complete, click the Save Website button.
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To set up a new store:

1. Before you begin, set up the root category that will be used for this store.

2. On the Admin menu, select System > Manage Stores.

3. From Manage Stores, click the Create Store button. Then, do the following:

New Store

a. Set Website to the site that is the parent of this store.

b. Enter a Name for the store. The name is for internal reference to distinguish it from
other stores in the hierarchy. For example: Private Sales Store.

c. Set Root Category to the root category that will be used for the main navigation of the
store. The root category can be the same as used for other stores, or unique to this
store. For example: Private Sales Root.

d. (Optional) Set Default Store View to the view that you want to appear when someone
visits the store. All other views are selected from the chooser in the header. For
example: English Private Sales View.

4. When complete, click Save Store.

To set up a new store view:

1. On the Admin menu, select System > Manage Stores.

2. From Manage Stores, click the Create Store View button. Then, do the following:

Store View Information
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a. Set Store to the parent store of this view.

b. Enter a Name for this store view. The name appears in the “language chooser” in the
header of the store. For example: French.

c. Enter a Code in lowercase characters to identify the view. For example: privatesales.fr.

d. To activate the view, set Status to “Enabled.”

e. (Optional) Enter a Sort Order number to determine the sequence in which this view is
listed with other views.

3. When complete, click the Save Store View button.

Configuration Scope
If your Magento installation has multiple websites, stores, or views, you can set the scope
of a configuration parameter to apply to a specific part of your installation. The Current
Configuration Scope box in the upper-left corner of the Admin workspace determines the
scope of the current settings. By default, the configuration scope is set to “Default Config.”
For Admin users with restricted access, the list includes only the areas where the user is
granted permission to access.

The configuration scope applies to products categories, attributes, customer management
setting, and so on. The scope of each item appears in brackets after the field to indicate the
range of the setting.

Current Configuration Scope
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If your installation includes multiple websites, stores or views, you should always set the
scope to identify where you want the settings to apply. The possible settings are: [STORE],
[WEBSITE], and [GLOBAL].

Any item with the scope of [STORE] can be set differently for each view. For example,
because the scope of a product name and description is [STORE], the fields can have a
different value for each language. However, some configuration settings—such as postal
code—are [GLOBAL] because the same setting applies throughout the system. The
[WEBSITE] scope also applies to the entire site, including all views.

To set the configuration scope:
Before making a configuration setting that applies only to a specific website, store, or view,
do the following:

1. On the Admin menu, select System > Configuration.

2. In the panel on the left, select the page with the configuration settings you want to change.
If necessary, click to expand the section to be configured. Then, do the following:

a. In the upper-left corner of a configuration page, set Current Configuration Scope to
the website, store, or view where the configuration applies.

A checkbox appears after each field, and sometimes additional fields become available.

b. Clear the Use Default checkbox that is after the field that you want to edit. Then, enter
the new value.

c. Repeat this process for every field that needs to be updated on the page.

3. When complete, click the Save Config button.

SCOPE DESCRIPTION

Store The setting is limited to the store view, which is often used to
display a store in multiple languages.

Website The setting is limited to the website.

Global The setting applies to the entire installation.

Scope Settings
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Adding a Language
Most of the text that appears to be hard-coded on pages throughout your store can be
instantly changed to a different language by changing the locale of the view. Changing the
locale doesn’t actually translate the text word-for-word, but simply references a different
translation table that provides the interface text that appears throughout the store. The
text that can be changed includes navigational titles, labels, buttons, and links such as “My
Cart” and “My Account.”

There is a wide selection of language packs available on Magento Connect. You can also use
the Inline Translation tool to touch up any remaining interface text that was not translated
for the locale, or to fine-tune the translated text.

After changing the language of the locale, the remaining content that you have created,
including product names and descriptions, categories, CMS pages, blocks, and polls must
be translated separately for each store view.

Language Packs on Magento Connect

Step 1: Install a Language Pack

1. Log in to your Magento account.

2. Go to Magento Connect, and find the language pack that you want to download. Read the
terms of the license, and click the checkbox to proceed.

3. Click the Install Now button. Then, do the following:

a. Click the Get the Extension Key button.

b. Click the Select button. Then, copy the license key.

4. Return to the Admin of your store. Then on the Admin menu, select System > Magento
Connect > Magento Connect Manager.

http://www.magentocommerce.com/magento-connect/
http://www.magentocommerce.com/magento-connect/
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5. When prompted, log in to Magento Connect Manager. Then, do the following:

a. In the Install New Extensions section, paste your extension key.

b. Click the Install button. The language pack you have chosen appears below.

Install Language Pack

c. When ready to begin, click the Proceed button.

You can follow the progress in the output frame. During the installation, the language
pack is uploaded to the following folder on your server:

[magento]/app/locale

Output Frame

6. To return to your store, click the Return to Admin link at the top of the page.
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Step 2: Create a Store View for the Language

1. On the Admin menu, select System > Manage Stores.

2. From Manage Stores, click the Create Store View button. Then, do the following:

New Store View

a. Select the Store that is the parent of the view.

b. Enter a Name for the store view. For example: Spanish.

This is the name that appears in the “language chooser” in the header.

c. Enter a Code in lowercase characters to identify the view. For example: spanish.

d. To activate the view, set Status to “Enabled.”

e. (Optional) Enter a Sort Order number to determine the sequence in which this view is
listed with other views.

3. When complete, click the Save Store View button.
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Step 3: Change the Locale of the Store View

1. On the Admin menu, select System > Configuration.

1. In the upper-left corner, set Current Configuration Scope to the store view.

2. Click to expand the Locale Options section. Then, do the following:

a. To the right of the Locale field, clear the Use Website checkbox.

b. Set Locale to the language that you want to assign to the view.

If there are several variations of the language available, make sure to select the one
that matches the language pack that is installed. For example, the Spanish language
pack that is downloaded in this example works only when the locale is set to “Spanish
(Spain).” You will need a different language pack to support the regional variations of
other countries.

Change the Locale

3. When complete, click the Save Config button.
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Store URLs
The URLs that are associated with your store were configured during the initial installation
of Magento. The Web access options include both secure and unsecure URLs, and indicate
if a security certificate is available.

Magento uses variables to define internal links in relation to the base URL, which makes it
possible to move an entire store from one URL to another without having to update the
internal links.

By default, the landing page for the base URL is “cms,” which indicates a page from
Magento’s content management system. You can also use a different type of landing page,
such as a blog. For example, if a blog is installed on the server at magento/blog, enter you
can enter the folder name “blog” as a relative path to the selection of pages. To learn more,
see: Default Pages.

Web Access Options
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Secure and Unsecure URLs
Each website in a Magento installation has a base URL that is assigned to the storefront
and to the Admin. If you have a security certificate for your domain, you can configure
either, or both base URLs to operate over a securely encrypted SSL channel. Unsecure base
URLs begin with “http,” and secure base URLs begin with “https.”

Unsecure Base URL http://www.yourdomain.com/magento/

Secure Base URL https://www.yourdomain.com/magento/

URL with IP address http://10.9.220.154/magento/

If Magento was installed before you registered a domain, the base URL might include the IP
address of the server. If you don’t yet have security certificate, the store will not be able to
switch to secure URLs (https) for transactions that normally take place over the secure
socket layer (SSL). These configuration settings can be updated later to reflect the values
you need before the store “goes live.”

Important! Do not change the Admin URL from the default in the Base URL configuration. To
change the Admin URL or path, see: Using a Custom Admin URL.

To configure the unsecure base URL:

1. On the Admin menu, select System > Configuration.

2. In the panel on the left, under General, select Web.

3. Click to expand the Unsecure section. Then, do the following:

4. Enter the unsecure (http) Base URL for your store. Make sure to end the URL with a
forward slash.

Unsecure
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For a typical installation, you do not need to update the paths for the skin, media, and
JavaScript files. Be careful not to change the markup tags in the other fields in the section.

5. If you do not plan to use a secure base URL for the Admin, do the following:

a. Click to expand the Secure section.

b. Enter your unsecure (http) Base URL. The URL should be the same in both the Secure
and Unsecure sections.

6. When complete, click the Save Config button.

To configure the secure base URL:

If your domain has a valid security certificate, you can configure the URLs for either the
storefront and Admin—or both—to run over a secure (https) channel.

1. Click to expand the Unsecure section. Then, do the following:

a. To use a secure (https) for the storefront, enter the Base URL, followed by a forward
slash.

Typically, you will not need to update the paths for the skin, media, and JavaScript
files. Be careful not to change the markup tags in the other fields in the section.

b. If you want to run the entire storefront over a secure (https) channel, set Use Secure
URLs in Frontend to “Yes.”

c. If you want to run the entire Admin over a secure (https) channel, set Use Secure
URLs in Admin to “Yes.”

Secure

2. When complete, click the Save Config button.
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Using a Custom Admin URL
In a typical Magento installation, the Admin URL and path is immediately below the
Magento base URL. The path to the store Admin is one directory below the root. Although
it is possible to change the Admin URL and path to another location, any mistake made
might remove your access to the Admin, which can only be corrected from the server.

As a precaution, do not try to change the Admin URL by yourself, unless you know how to edit
configuration files on the server.

http://yourdomain.com/magento/

Default Base URL

http://yourdomain.com/magento/admin

Default Admin URL and Path

Method 1: Change from the Magento Admin:

1. On the Admin menu, select System > Configure.

2. In the panel on the left under Advanced, select Admin.

3. Click to expand the Admin Base URL section, and do the following:

a. Set Use Custom Admin URL to “Yes.” Then, enter the Custom Admin URL in the
following format:

http://yourdomain.com/magento/

Important! The Admin URL must be in the same Magento installation, and have the same
document root as the storefront.

b. Set Custom Admin Path to “Yes.” Then, enter the name of the Custom Admin Path in
the following format:

backend

Admin Base URL
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4. When complete, click the Save Config button.

After the changes are saved, you must log in to the Admin using the new Admin URL and
path.

Method 2: Change from the Server Command Line

1. Open the app/etc/local.xml file in a text editor, and change the name of the [admin]
path. Make sure to use only lowercase characters. Then, save the file.

On the server, the admin path is located in the app/etc/local.xml file. Look for the
<adminhtml> argument in the <admin> section:

# <frontName><![CDATA[admin]]></frontName>

Default Admin Path

# <frontName><![CDATA[backend]]></frontName>

New Admin Path

2. Do one of the following methods to clear the Magento cache:

l On the Admin menu, select System > Cache Management. Then, click the Flush
Magento Cache button.

l On the server, navigate to the var/cache folder, and delete the contents of the cache
folder.
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CHAPTER 8:

Industry Compliance
Magento Enterprise Edition offers a range of security and privacy capabilities that meet
legal requirements and industry guidelines for online merchants. Some are mandated
by the payment card industry, and others are required by law, depending on your
location.

Topics in this chapter include:

l PCI Compliance

l Privacy Policy

l Cookie Law

You will learn about PCI compliance, and the importance of establishing procedures to
protect payment information. You will also learn how to bring your store into
compliance with the Cookie Law, which is a requirement in some countries, and
considered a “best practice” in others. In addition, you will learn how to customize and
maintain a privacy policy for your store.
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PCI Compliance Guidelines
The Payment Card Industry (PCI) has established a set of requirements for businesses that
accept payment by credit card over the Internet. In addition to the need to maintain a
secure hosting environment, there are additional requirements that merchants must meet
to ensure the privacy of cardholder data. Every merchant who handles customer credit card
information is required by the Payment Card Industry to conduct business within the
following guidelines:

Install andmaintain a firewall configuration to protect cardholder data.

Do not use vendor-supplied defaults for system passwords and other security
parameters.

Protect stored cardholder data.

Encrypt transmission of cardholder data across open, public networks.

Use and regularly update antivirus software.

Develop andmaintain secure systems and applications.

Restrict access to cardholder data by business need to know.

Assign a unique ID to each person with computer access.

Restrict physical access to cardholder data.

Track andmonitor all access to network resources and cardholder data.

Regularly test security systems and processes.

Maintain a policy that addresses information security.

As your business grows, you may be required to file a compliance report on an annual
basis. PCI reporting requirements increase in proportion to merchant level, but are waived
for businesses that process fewer than 20,000 credit card transactions per year. To learn
more, visit the PCI Security Standards Council website.

https://www.pcisecuritystandards.org/index.php
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Privacy Policy
Your store includes a sample privacy policy that must be updated with your own
information. Your privacy policy should describe the type of information that your
company collects, and how it is used. It should also list the filenames of cookies that are
placed on the computers of people who visit your store. Any additional cookies that are
associated with third-party extensions and add-ons should be included in the list. For a
complete list of the cookies used by Magento, see Cookie Restriction Mode.

If you change the URL key of the privacy policy, you must also create a custom URL
redirect to reroute traffic to the new URL key.

Privacy Policy

To edit your privacy policy:

1. On the Admin menu, select CMS > Pages > Manage Content.

2. Find the privacy policy in the list, and click to open the page.

3. In the panel on the left, click Content.

4. To work in WYSIWYG mode, click the Show/Hide Editor button.

5. Make the necessary changes to the content.

6. When complete, click the Save Page button.
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Cookie Law Compliance
Cookies are small files that are saved to the computer of each visitor to your site, and used
as temporary holding places for information. Information that is saved in cookies is used to
personalize the shopping experience, link visitors to their shopping carts, measure traffic
patterns, and improve the effectiveness of promotions.

To keep pace with legislation in many countries regarding the use of cookies, Magento
offers merchants a choice of methods for obtaining customer consent.

Implied Consent

Using cookies with implied consent is the method that is currently the most widely
adopted in the UK. Implied consent means that visitors to your store have a clear
understanding that cookies are a necessary part of operations, and by using your site, have
indirectly granted permission to use them.

The key to gaining implied consent is to provide enough information for a visitor to make
an informed decision. Many stores display a message at the top of all standard pages that
provides a brief overview of how cookies are used, with a link to the store’s privacy policy.
The privacy policy should describe the type of information that your store collects, and how
it is used.

Expressed Consent

Operating your store in “cookie restriction mode” requires visitors to express their consent
before any cookies can be saved to their computers. Unless consent is granted, many
features of your store will be unavailable.
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Cookie RestrictionMode
Operating your store in “Cookie Restriction Mode” requires that visitors express their
consent before cookies can be saved to their computers. Unless consent is granted, many
features of your store become unavailable.

Cookie Restriction Notice

If Google Analytics is available for your store, it can be invoked only after the visitor has
granted permission to use cookies. For more information, see Google’s cookie usage
documentation.

When Cookie Restriction Mode is enabled, visitors to your store are notified that cookies are
required for full-featured operations. They are then referred to your privacy policy for more
information, and encouraged to grant consent by clicking the Allow button. The message
disappears after the visitor click the Allow button. The Cookie Restriction Mode message
resides in a CMS static block, and can be edited to suit your voice and style.

Your privacy policy should include the name of your store and contact information, and
explain the purpose of each cookie that is used by your store. See the end of this topic for a
complete list of the cookies used.

If you change the URL key of the privacy policy, you must also create a custom URL
redirect to reroute traffic to the new URL key. Otherwise, the link in the Cookie Restriction
Mode message will return “404 Page Not Found.”
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Step 1: Enable Cookie Restriction Mode

1. On the Admin menu, select System > Configuration. Then in the panel on the left, under
General, click Web.

2. Click to expand the Session Cookie Management section, and do the following:

Session Cookie Management

a. Enter the Cookie Lifetime in seconds.

b. If you want to make cookies available to other folders, enter the Cookie Path. To make
the cookies available anywhere in the site, enter a forward slash.

c. To make the cookies available to a subdomain, enter the subdomain name in the
Cookie Domain field. (subdomain.yourdomain.com) To make cookies available to all
subdomains, enter the domain name preceded by a period. (.yourdomain.com)

d. To prevent scripting languages such as JavaScript from gaining access to cookies, set
Use HTTP Only to “Yes.”

e. Set Cookie Restriction Mode to “Yes.”

Important! If you disable cookies, you should also disable Full-Page Caching to ensure
that no customer-related information is saved.

3. When complete, click the Save Config button.

Step 2: Edit the Cookie Restriction Message

1. On the Admin menu, select CMS > Static Blocks.

2. Find the Cookie Restriction Notice, and click to open the block. Then, do the following:

http://merch.docs.magento.com/ee/user_guide/Magento_Enterprise_Edition_User_Guide.html#configuration/general/web.html%23Session_Cookie_Management
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Editing the Cookie Restriction Notice

a. Select each Store View where the notice should appear.

b. Set Status to “Enabled.”

c. In the Content box, edit the message as needed.

3. When complete, click the Save Block button.

Step 3: Update Your Privacy Policy

1. On the Admin menu, select CMS > Pages > Manage Content.

2. Find your Privacy Policy in the list, and click to open the page.

3. In the panel on the left, click Content. If necessary, click the Show/Hide Editor button to
work in WYSIWYG mode.

4. Update your privacy policy to describe the information that your company collects, and
how it is used. You can include the information from the tables at the end of this topic.

5. When complete, click the Save Page button.
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Cookie Reference

COOKIE NAME COOKIE DESCRIPTION

USER_ALLOWED_SAVE_
COOKIE

Indicates if a customer is allowed to use cookies.

external_no_cache A flag that indicates if caching is disabled.

persistent_
shopping_cart

The session key.

Stf If product links were sent to friends, stores the timestamps in the
format: $timeStamp1, $timestamp2, …, $timestampN

pollN A poll ID that indicates if a vote has occurred.

frontend Session ID

guest-view Allows guests to edit their orders.

Magento Standard Cookies

COOKIE NAME COOKIE DESCRIPTION

CUSTOMER Hashed value of a customer ID in the format: customer_
$customerId

CUSTOMER_INFO Hashed value of a customer group ID in the format: customer_
group_$customerGroupId

NEWMESSAGE Indicates if a new message has been received.

CART Hashed value of a quote ID in the format: $quoteId

COMPARE The product IDs added to product compare in the format:
$productId 1, $productId 2, …, productId N

POLL The ID of a recently-voted poll.

RECENTLYCOMPARED The product IDs of recently compared products in the format:
$productId 1, $productId 2, …, productId N

WISHLIST A hashed list of products added toWishlist in the format:
$productId 1_$productId 2_ …, _productId N

Magento Cookies Used with Full Page Cache



CHAPTER 8:  Industry Compliance Cookie Law Compliance

COOKIE NAME COOKIE DESCRIPTION

WISHLIST_CNT A hashed number of items in the customer's Wishlist in the
format: wishlist_item_count_$productCount

CUSTOMER_AUTH Indicates if a customer is logged in. A hashed value in the format:
customer_logged_in_0|1

CATEGORY_INFO Stores category information so pages can loadmore quickly.

LAST_CATEGORY Recently visited category ID in the format: $categoryID

VIEWED_PRODUCT_IDS Recently viewed product IDs in the format: $productId 1,
$productId 2, …, productId N

currency The code for the currency selected by a customer ('USD', 'UAH',
'GBP', etc.)

store The store view code.

NO_CACHE Indicates if the cache is allowed to be used.

LAST_PRODUCT The product ID of the last product viewed.

Magento Cookies Used with Full Page Cache (cont.)

COOKIE DESCRIPTION

_utma Distinguishes users and sessions.

_utmb Determines new sessions/visits.

_utmc Determines if the user was in a new session/visit.

_utmz Stores the traffic source or campaign that explains how the user
reached your site.

Google Analytics Cookies
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CHAPTER 9:

Navigation
The term navigation1 refers to methods shoppers use to move from one page to
another in your store. The main menu, or top navigation of your store is primarily a list
of categories. The category structure of your catalog is the main way people find
products in your catalog. You will also find categories in the breadcrumb2 trail that
runs across the top of most pages, and in the layered navigation that appears on the
left side of some two- or three-column pages. These are all examples of how categories
can be used to navigate throughout your store.

For a product to be visible in your store, it must be assigned to at least one category.
Each category can have a dedicated landing page with an image, static block, a
description, and list of products. You can also create special designs for category pages
that become active for a specific period of time such as for a holiday season or
promotion.

Categories in Main Menu

1The primary group of web page links that a customer uses to navigate around the website; the navigation
links to the most important categories or pages on an online store.
2A navigation aid that helps the user to keep track of their location within your store.
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Top Navigation
The main menu of your store displays the selection of categories that are available in your
catalog. You can think of the top navigation as different departments in your store. A top-
level category serves as a landing page for all the subcategories below. The position and
presentation of the top navigation might vary by theme, but the way it works is the same.

Main Menu

The first level of categories below the root typically appear as options in the main menu.
Below that, you can have as many additional subcategories as needed. The category
structure of your catalog can influence how well your site is indexed by search engines. The
deeper a category, the less likely it is to be thoroughly indexed. As a general rule, anywhere
between one and three levels is considered to be the best. You can set the maximum
number of levels that are available in your top navigation in the system configuration.
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Breadcrumb Trail
A breadcrumb trail is a set of links that shows where you are in relation to other pages in
the store. You can click any link in the breadcrumb trail to return to a previous page. Here’s
an example of a breadcrumb trail from the Magento Demo Store:

HOME / ACCESSORIES / JEWELRY / PEARL STUD EARRINGS

The breadcrumb trail can be configured to appear on CMS content pages, as well as catalog
pages. The format and position of the breadcrumb trail varies by theme, but it is usually
located in the upper-left, just below the header.

Breadcrumb Trail

To add breadcrumbs to CMS pages:

1. On the Admin menu, select System > Configuration.

2. In the Configuration panel on the left, under General, select Web. Then, do the following:

a. Click to expand the Default Pages section.

b. Set Show Breadcrumbs for CMS Pages to “Yes.”

3. When complete, click the Save Config button.

Default Pages
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Product List Configuration
Product listings can be configured to set the default format as either a list or grid,
determine how many products appear per page, and which attribute is used to sort the list.
Each product list has the following page controls that can be used to sort the products, and
change the format of the list.

View As Displays the list in either a Grid or List format.

Sort By Changes the sort order of the list.

Products in Grid Format

To configure product listings:

1. On the Admin menu, select System > Configuration.

2. In the panel on the left, under Catalog, select Catalog.

3. Click to expand the Frontend section.

4. Set the default List Mode to one of the following:

l Grid Only

l List Only

l Grid (default) / List

l List (default / Grid

Then, do the following:
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a. In the Products per Page on Grid Allowed Values field, enter the number of products
that you want to appear per page when shown in grid format. To enter a selection of
values, separate each number by a comma.

b. In the Products per Page on Grid Default Value field, enter the default number of
products to appear in the grid per page.

c. In the Products per Page on List Allowed Values field, enter the number of products
that you want to appear per page when shown in list format. To enter a selection of
values, separate each number by a comma.

d. In the Products per page on List Default Value field, enter the default number of
products that appear in the list, per page.

Frontend

5. To give customers the option to list all products, set Allow All Products on Page to “Yes.”

6. Set Product Listing Sorted by to the default attribute that is initially used to sort the list.

7. If using a flat catalog, do the following:

a. To display a flat category listing of products, set Use Flat Catalog Category to “Yes.”

b. To display a flat product listing, set Use Flat Catalog Product to “Yes.”

8. If you want to allow dynamic references to media assets in category and product URLs, set
Allow Dynamic Media URLs in Products and Categories to “Yes.”

9. When complete, click the Save Config button.
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Pagination Controls
The Pagination settings control the format of the pagination links in product listings. You
can set the number of links that appear in the control, and configure the Next and Previous
links. For the following pagination links to appear, there must be more products in the list
than are allowed per page in the catalog configuration.

Show per Page Determines how many products appear per page.

Pagination Links Navigation links to other pages.

Pagination Links

To configure pagination controls:

1. On the Admin menu, select System > Configuration.

2. In the panel on the left under General, select Design.

3. Click to expand the Pagination section. Then, do the following:

a. In the Pagination Frame field, enter the number of links that you want to appear in
the control.

b. In the Pagination Frame Skip field, enter the number of links to skip ahead to display
the next set of links in the control.

For example, if the pagination frame has five links, and you want to jump to the next
five links, how many links do you want to skip ahead? If you set this to four, then the
last link from the previous set will be the first link in the next set.
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Pagination

c. In the Anchor Text for Previous field, enter the text that you want to appear for the
Previous link. Leave blank to use the default arrow.

d. In the Anchor Text for Next field, enter the text that you want to appear for the Next
link. Leave blank to use the default arrow.

4. When complete, click the Save Config button.
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Layered Navigation
Layered navigation makes it easy to find products based on category, price range, or any
other available attribute. Layered navigation usually appears in the left column of search
results and category pages and sometimes on the home page. The standard layered
navigation includes a “Shop By” list of categories and price range. You can configure the
way layered navigation appears in your store, including the product count and price range.

Layered Navigation by Category and Price

To set up layered navigation:

1. On the Admin menu, select System Configuration.

2. In the Configuration panel on the left, under Catalog, select Catalog.

3. Click to expand the Layered Navigation section. Then, do the following:

Layered Navigation
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a. To display the results after each attribute, set Display Product Count to “Yes.”

b. Set Price Navigation Step Calculation to one of the following:

l Automatic

l Manual

c. For a manual calculation, enter a number in the Default Price Navigation Step field to
determine how the price ranges are grouped. For example, if you enter 100, the prices
appear in groups of 100.

Manual Price Navigation Step

4. When complete, click the Save Config button.

Filterable Attributes
Layered navigation can be used to search for products by category or by attribute. For
example, when a shopper chooses the Apparel/Shoes category from the top navigation, the
initial results include all products in the shoes category. The list can be filtered further by
choosing a specific color or size, or by specifying values for both color and size. For an
attribute to be included in layered navigation, its property settings must be set to make it
filterable.

Anchor categories can be set to appear in an additional section that filters the list by
attribute value. The attribute section appears only if a category is set to “Is Anchor.” Each
attribute can be configured to display the number of matching records found.

The attribute properties, combined with the product properties, determine which attributes
can be used as filters for layered navigation. Only those with the catalog input type of
Dropdown, Multiple Select or Price can be used as filterable attributes.
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Filterable Attributes In Layered Navigation

Step 1: Set the Attribute Properties

1. On the Admin menu, select Catalog > Attributes > Manage Attributes.

2. Click to open the attribute in edit mode, and do the following:

a. Scroll down to the Frontend Properties section, and set Use In Layered Navigation to
one of the following:

l Filterable (with results)

l Filterable (no results)

b. Set Use In Search Results Layered Navigation to “Yes.”

Step 2: Make the Category an Anchor

1. On the Admin menu, select Catalog > Manage Categories.

2. In the Categories panel on the left, click to open the category.

3. On the Display Settings tab, set Is Anchor to “Yes.”

4. Click the Save Category button.

To test the setting, go to your store and select the category in the top navigation. The
selection of filterable attributes for the products in the category appears in the layered
navigation.
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Price Navigation
Price navigation can be used to distribute products by price range in layered navigation.
You can also split each range in intervals. There are several ways to calculate price
navigation:

l Automatic (Equalize Price Ranges)

l Automatic (Equalize Product Counts)

l Manual

With the first two methods, the navigation steps are calculated automatically. The manual
method lets you specify a division limit for price intervals. The following example shows
the difference between price navigation steps of 10 and 100.

Iterative splitting is a technique that provides the best distribution of products among price
ranges. With iterative splitting, after a customer chooses to view the $0.00-$99 range, the
customer can drill-down through several sub-ranges of prices. Price-range splitting stops
when the number of products reaches the threshold set by the Interval Division Limit.

Example: Price Navigation Steps of 10 and 100

PRICE STEP BY 10 PRICE STEP BY 100

$20.00 - $29.99 (1)
$30.00 - $39.99 (2)
$70.00 - $79.99 (1)
$100.00 - $109.99 (1)
$120.00 - $129.99 (2)
$150.00 - $159.99 (1)
$180.00 - $189.99 (1)
$420.00 - $429.99 (1)
$440.00 - $449.99 (1)
$710.00 and above (1)

$0.00 - $99.99 (4)
$100 - $199.99 (5)
$400.00 - $499.99 (2)
$700.00 and above (1)
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To configure price layered navigation:

1. On the Admin menu, select System > Configuration. Then in the panel on the left, under
Catalog, select Catalog.

2. In the upper-left corner, set Current Configuration Scope to the store view to be
configured.

3. Click to expand the Layered Navigation section.

4. If you want to display the number of products in parentheses after each filtered item, set
Display Product Count to “Yes.”

5. Set Price Navigation Steps Calculation to one of the following methods:

Method 1: Automatic (Equalize Price Ranges)

Set Price Navigation Steps Calculation to “Automatic (Equalize Price Ranges.)” This
setting uses the existing price layered navigation algorithm, and is similar to the
Automatic option in earlier versions of Magento.

Layered Navigation

Method 2: Automatic (Equalize Product Counts)

1. Set Price Navigation Steps Calculation to “Automatic (Equalize Price Ranges).”

2. Set Display Price Interval as One Price to “Yes” if you want to display a single price
when multiple products with the same price.

3. In the Interval Division Limit field, enter the threshold for a number of products
within a price range. The range cannot be further split beyond this limit. The default
value is 9.

Automatic (Equalize Product Counts)
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Method 3: Manual

1. Set Price Navigation Steps Calculation to “Manual.”

2. Enter a value to determine the Default Price Navigation Step.

3. Enter the Maximum Number of Price Intervals allowed, up to 100.

Manual

6. When complete, click the Save Config button.
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CHAPTER 10:

Categories
Every product in your catalog must be assigned to at least one category. Before you add
products to your catalog, you must first establish the basic category structure of your
catalog. The number of subcategory levels that you can have in the top navigation is set
in the system configuration.

Categories in Main Menu



Category Levels CHAPTER 10:  Categories

110 Magento Enterprise Edition User Guide, Version 1.14.2.1

Category Levels
The number of subcategory levels that you can have in the top navigation is set in the
system configuration. By default, there is no limit to the number of levels of subcategories
you can set up. In the following image, the Home & Decor category has a depth of two
levels.

Subcategory Levels

To set the depth of the top navigation:

1. On the Admin menu, select System > Configuration.

2. In the panel on the left, under Catalog, select Catalog.

3. Click to expand the Category Top Navigation section.

Category Top Navigation

4. To place a limit on the number of subcategories that can be used in the top navigation,
enter the number in the Maximal Depth field.

The default Maximal Depth value is 0, which does not limit the number of subcategory
levels you can have.

5. When complete, click the Save Config button.
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Creating Categories
When working in the Admin, the category structure is like an upside-down tree, with the
root at the top. Each section of the tree can be expanded and collapsed. Any disabled or
hidden categories are grayed out.

Category Structure

Step 1: Create a Category

1. On the Admin menu, select Catalog > Manage Categories.

2. Before you begin, set Choose Store View to the store or view. By default, the scope of the
category configuration is set to “All Store Views.”

3. In the category tree, click the category that is to be the parent of the new category. The
parent is the level just above the new category.

If you’re starting from the beginning without any data, there might be only two categories
in the list: “Default Category,” which is the root, and an “Example Category.”

4. Click the Add Subcategory button.
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Category Tree

Step 2: Complete the General Information

1. In the General Information section, do the following:

a. (Required) Type the Name of the category.

b. (Required) To enable the category, set Is Active to “Yes.”

c. You can enter a URL Key for the category, or let the system automatically create one
that is based on the category name.

2. If supported by your theme, you can display a Thumbnail image in the main menu for
each category. Click the Choose File button and select the image to upload.

3. In the Description box, enter a paragraph or two of descriptive text for the category
landing page.

4. To display an Image at the top of the category landing page, click the Choose File button
and select the image to upload.

5. Complete the category meta data:

l Page Title

l Meta Keywords

l Meta Description

6. (Required) To include the category in the main menu, set Include in Navigation Menu to
“Yes.”

7. Click the Save Category button. Then, take note of the following:
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l The new category now appears in the tree. If it’s not in the correct position, you can
drag it to another location in the tree.

l In addition to the category name, it has an ID number shown in parentheses, just after
the name at the top of the page.

l A URL Key that is based on the category name has been generated for the category.

Category URL Key

Step 3: Complete the Display Settings

You can configure the category landing page to display both a static block and product list,
or one or the other. A static block can provide additional information, including text,
images, and even embedded video.

Display Settings

1. On the Display Settings tab, do the following:

a. Set Display Mode to one of the following:

l Products Only

l Static Block Only

l Static Block and Products

b. If applicable, set CMS Block to the static block that you want to appear on the
category page.

c. If you want this category page to display the “Filter by Attribute” section of layered
navigation, set Is Anchor to “Yes.”
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d. Clear the checkbox under Default Product Listing Sort By. Then select one of the
available values to sort the list. By default, all available attributes are listed. The
default values typically include:

l Best Value

l Name

l Price

2. When complete, click the Save Category button.

Modifying Categories
After a category is established, it can be edited, moved to another position in the category
tree, or deleted from the catalog. However, if your catalog is live, you should consider how
the change might impact any existing links to products in the category. For example, if
your product URLs include the category path, and the category name is changed, any
existing links to products in the category will be broken. To avoid this problem, you can
configure your catalog to automatically create a permanent redirect if the URL key changes.
You can also use the URL Redirect tool to redirect traffic from an old URL to a new one.

To move a category:

1. On the Admin menu, select Catalog > Manage Categories.

2. To move a category, simply drag-and-drop it to a new location. Category order changes are
saved automatically.

To delete a category:

1. On the Admin menu, select Catalog > Manage Categories.

2. Click to select the category you want to delete.

A deleted category cannot be restored, so make sure that you have selected the correct
category before proceeding.

3. Click the Delete Category button to save your changes.
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Root Categories
The catalog structure is like an upside-down tree, with the root on top. All categories in
your catalog are nested below the root. Because the root category is the highest level of the
catalog, your store can have only one root category active at a time. You can, however,
create additional root categories for alternate catalog structures, different stores, and views.
The root category is not visible to customers in the store, and does not have a URL key.

Root Categories

Step 1: Create a New Root Category

1. On the Admin menu, select Catalog > Manage Categories.

2. In the upper-left of the Manage Categories page, click the Add Root Category button.
Then, do the following:

a. Enter a Name for the root category.

b. Set Is Active to “Yes.”

c. Click the Choose File to upload a Thumbnail Image for the root category.

d. Enter a Description of the root category.

e. Click the Choose File button to upload an Image to the root category.

f. Complete the following meta data:

l Page Title

l Meta Keywords

l Meta Description
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g. If you want this root category to be in the main menu, set Include in Navigation
Menu to “Yes.”

3. Click the Display Settings tab. Then, set Is Anchor to “Yes.”

4. When complete, click the Save Category button.

Step 2: Add Subcategories to the New Root

1. From the Categories page, click the General tab.

2. In the category tree on the left, click to select the new root category you created in the last
step.

3. Click the Add Subcategory button.

4. Give the subcategory a Name, and set Is Active to “Yes.”

5. Click the Save Category button.

6. Repeat this process to create as many subcategories as you need.

Step 3: Apply the New Root Category to Your Store

1. On the Admin menu, select System > Manage Stores.

2. On the Manage Stores page, under Store Name, click the Main Store link.

3. Change Root Category to the new root category.

4. Click the Save Store button.
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Hidden Categories
There are many ways to use hidden categories. You might want to create additional
category levels for your own internal purposes, but show only the higher-level categories to
your customers. Or, you might want to link to a category that is not included in the
navigation menu.

To create hidden categories:

1. On the Admin menu, select Catalog > Manage Categories.

2. In the Categories panel on the left, select the category you want to exclude from the
navigation.

3. On the General Information tab, do the following:

a. Set Is Active to “No.”

b. Set Include in Navigation Menu to “No.”

4. On the Display Settings tab, set Is Anchor to “No.”

5. Although the category is hidden, you can still create additional subcategories beneath it,
and make them active. Complete the following settings for each hidden subcategory:

a. On the General Information tab, set Is Active to “Yes.”

b. On the Display Settings tab, set Is Anchor to “Yes.”

As active categories, you can now link to them from other places in your store, but they will
not appear in the navigation menu.

6. When complete, click the Save Category button.
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General Information
On the General Information tab, complete the basic information about the category you are
creating or editing. You can enter keywords to improve the way the category is indexed by
search engines, create a URL key for the category, and activate or deactivate the category.

General Information
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FIELD SCOPE DESCRIPTION

Name Store View (Required) The category name appears in the
navigation, and also in the URL key of the
category page and associated product pages.

Is Active Store View (Required) Tomake this category available,
select “Yes.” Options include: Yes / No

URL Key Store View The URL Key is a relative path to the category,
and is automatically generated when the category
is saved. The URL Key must be all lower-case
characters, with no spaces. As a best practice,
each word is separated by a hyphen. If you edit
the default URL key, a custom redirect is created
automatically. A root category does not have a
URL key.

Thumbnail Image Store View If supported by your theme, a thumbnail image
can be associated with each category and appear
as part of the option in themainmenu of the store.

Description Store View The category description, if used, appears below
the category image- and before the product list.

Image Store View The category image, if used, appears at the top of
the category page, before the description and
product list.
As an alternative, you can display a CMS static
block in place of the description and image. (See
Category Display Settings.)

Page Title Store View The category page title appears in the browser tab
and title bar. As a best practice, the title should be
not more than twelve words in length, and should
include a combination of primary and secondary
keywords.

Meta Keywords Store View Keywords are used by some search engines. You
can use a keyword search tool to identify high-
value keywords that relate to your category. A
general rule is to use nomore than thirty
keywords, or 180 characters. Avoid repeats, and
empty words such as “a,” “an,” “or” and “that.”

Field Descriptions
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FIELD SCOPE DESCRIPTION

Meta Description Store View Enter a description of the category, using
approximately twenty-five words or 150
characters.

Include in Navigation
Menu

Store View (Required) Determines if the category is included
in themainmenu. Options include:

Yes To include this category in the top
navigation, select “Yes.”

No Hides the category, although still
active. Hidden categories appear
in layered navigation, but not the
mainmenu.

Field Descriptions (cont.)

Display Settings
The Display Settings determine which content elements appear on a category page and the
order that products are listed. You can enable CMS blocks, set the anchor status of the
category, and manage sorting options from this page.

Display Settings
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FIELD SCOPE DESCRIPTION

Display Mode Store View Determines the content elements displayed on
the category page. Options include:
Products Only
Static Block Only
Static Block and Products

CMS Block Store View To display a CMS static block at the top of the
category page, select the name of the block from
the list.

Is Anchor Global When set to “Yes,” includes the “filter by attribute”
section in the layered navigation. Options
include: Yes / No

Available Product Listing
Sort By

Store View (Required) The default values are Value, Name,
and Price. To customize the sorting option, clear
the Use All Available Attributes checkbox and
select the attributes you want to use. You can
define and add attributes as needed.

Default Product Listing
Sort By

Store View (Required) To define the default “Sort By” option,
clear the “Use Config Settings” checkbox and
select an attribute.

Layered Navigation Price
Step

Store View By default, Magento displays the price range in
increments of 10, 100, and 1000, depending on
the products in the list. To change the Price Step
range, clear the “Use Config Settings” checkbox.

Field Descriptions
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Custom Design
The Custom Design tab gives you control over the look and feel of a category and all
assigned product pages, including the content blocks and page layout. You can customize a
category page its assigned products for a promotion or to differentiate the category from
others and increase sales. For example, you might develop distinctive design for a brand or
special line of products.

Custom Design

To create a custom category design:

1. If the parent category of the selected category has already been customized and you want to
use same settings, set Use Parent Category Settings to “Yes.”

2. To apply the custom design to all the products assigned to the category, set Apply to
Products to “Yes.” Otherwise, the customization applies to only the category page.

3. To apply a different theme to the category, select the theme you want to use from the
Custom Theme list.

4. To apply the category design to a specific range of time, click the calendar to select both the
Active From and Active To dates. Otherwise, the design will take effect when you save the
changes to the category.

5. Click the Save Category button to save your changes.
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FIELD SCOPE DESCRIPTION

Use Parent Category
Settings

Store View Inherits the design settings from the parent
category. Options: Yes / No

Apply to Products Store View Applies custom settings to all products in the
category. Options: Yes / No

Custom Theme Store View Specifies a custom theme to be used for a period
of time.

Active From Store View Determines the beginning date of the period of
time when a custom theme is active.

Active To Store View Determines the end date of the period of time
when a custom theme is active.

Page Layout Store View Applies a different layout to the category page.
Options:

No layout updates This option is preselected
by default and does not
apply layout changes to
the category page.

Empty This option lets you
define your own page
layout.(Requires an
understanding of XML.)

1 column Applies a one-column
layout to the category
page.

2 columns with left
bar

Applies a two-column
layout with a left sidebar
to the category page.

2 columns with
right bar

Applies a two-column
layout with a right sidebar
to the category page.

3 columns Applies a three-column
layout to the category
page.

Custom Layout Update Store View You can further customize the theme by making
layout updates in XML code.

Field Descriptions
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Category Products
The Category Products tab lists the products that are currently assigned to the category.
From the list, you can easily add and remove products from the category.

Category Products

To assign products to a category:

1. From the category record, click the Category Products tab. Then, do the following:

a. Use the filters and checkbox control to find the products you want to assign:

l To display all products assigned to the category, set the checkbox control to “Yes.”

l To display all products not assigned to the category, set the checkbox control to
“No.”

l To display all products, set the checkbox control to “Any.”

b. Press the Search button.

c. To list all products again, click the Reset Filter button.

2. Select the checkbox of each product you want to assign to the category.

3. When complete, click the Save Category button.
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Category Permissions
Category permissions allow you to control access by customer group. After completing the
general category permission settings, you can fine-tune the permissions for each category.

To define category permissions:

1. On the Admin menu, select Catalog > Categories > Manage Categories.

2. In the category tree, click to select the category.

3. Click the Category Permissions tab. Then, click the New Permission button and do the
following:

Add New Permission

a. Select theWebsite where the permission applies.

b. Select the Customer Group to which the permission applies.

c. Under Browsing Category, choose one of the following options:
Allow Allows products in the category to be browsed.

Deny Does not permit the category to be browsed.

Use Parent Applies the parent category permissions.

d. Under Display Product Prices, choose one of the following options:
Allow Displays category prices.

Deny Does not display category prices.

Use Parent Applies the parent category permissions.

e. Under Add to Cart, choose one of the following options:
Allow Allows products in the category to be placed in the shopping cart.

Deny Does not allow products from the category in the shopping cart.

Use Parent Applies the parent category permissions.

4. To add more permissions, click the New Permission button and repeat the process.

5. When complete, click the Save Category button.
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Category Permission Setup
Category permissions can be used to control access to the category based on customer
group. Before assigning permissions to a specific category, you must configure category
permissions for your store.

To set up category permissions:

1. On the Admin menu, select System > Configuration.

2. In the panel on the left, under Catalog, select Catalog. Click to expand the Category
Permissions section, and do the following:

Category Permissions

3. To activate category permissions, set Enable to “Yes.” By default, this will apply the
restrictions to all categories.

4. Set Allow Browsing Category to one of the following:

l To grant everyone permission to browse the category, select “Yes, for Everyone.”

l To grant permission to only members of specific customer groups, select “Yes for
Specified Groups.” Then, select each group that has permission to browse the category.

l To deny access to the category and redirect to another page, select “No, Redirect to
Landing Page.” When prompted, select the page that you want visitors to see instead of
the category page.

5. Set Display Product Prices to one of the following:

l To grant everyone permission to see product prices, select “Yes, for everyone.”

l To grant permission to only members of specific customer groups, select “Yes for
Specified Groups.” Then, select each group that has permission to view product prices.

l To turn off the display of product prices for the category, select “No.”

6. Set Allow Adding to Cart to one of the following:

http://merch.docs.magento.com/ee/user_guide/Magento_Enterprise_Edition_User_Guide.html#configuration/catalog/catalog.html%23Category_Permissions
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l To grant everyone permission to add products from the category to their shopping carts,
select “Yes, for everyone.”

l To grant permission to only members of specific customer groups to add products from
the category to their shopping carts, select “Yes for Specified Groups.” Then, select each
group that has permission to purchase the products.

l To prevent everyone from adding products in the category to their shopping carts, select
“No.”

7. To prevent members of specific customer groups from searching the catalog, select each
group in the Disallow Catalog Search list.

8. When complete, click the Save Config button.

FIELD SCOPE DESCRIPTION

Enable Global Activates category restrictions. By default, using
this feature restricts all categories. Options
include: Yes / No

Allow Browsing Category Website Options include:

Yes, for Everyone Allows all visitors and
customers to the browse
the category.

Yes, for Specified
Customer Groups

Allows only members of
selected customer groups
to browse the category.

No, Redirect to
Landing Page

Denies access to the
category and redirects to
the selected page.

Display Product Prices Website Controls the display of product prices for the
category. Options include:

Yes, for Everyone Allows everyone to see
the price of products in
the category.

Yes, for Specified
Customer Groups

Allows only members of
selected customer groups
to see the price of
products in the category.

Field Descriptions
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FIELD SCOPE DESCRIPTION

No Turns off the display of
product prices for the
category.

Allow Adding to Cart Website Determines who can purchase products from the
category. Options include:

Yes, for Everyone Allows everyone to place
products from the
category into their
shopping carts.

Yes, for Specified
Customer Groups

Allows only members of
selected customer groups
to place products from the
category into their
shopping carts.

No Does not allow anyone to
place products from the
category into their
shopping carts.

Disallow Catalog Search
by

Website Identifies the customer groups that are not
allowed to search for products in the category.

Field Descriptions (cont.)
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CHAPTER 11:

Managing Attributes
Attributes are the building blocks of your product catalog, and describe specific
characteristics of a product. Here are a few ways you can use attributes to enhance the
shopping experience:

l Input controls for product options

l Provide additional information on product pages

l Search parameters

l In product comparison reports

l As layered navigation “Shop By” parameters

l In catalog and shopping cart price rules

Each attribute contains a value that describes a characteristic of a product, such as
“color” or “fabric.” The “color” attribute with the “dropdown” input type might contain
many values, although only a few apply to any given product. Because a single
attribute can be used with multiple products, your store needs to have only one
attribute for color. You can create as many attributes as you need, and assign the most
common value as the default, to make it easy for your customers to select the option.

The attributes that make up a product are combined into an attribute set, which is
used as template to create new products. The attribute set determines which fields are
included in a product, and how they are grouped in the Product Information panel.
Magento has a default attribute set with a standard selection of product attributes such
as Name, Price, Description, and so on. If you want to keep it simple, you can use the
default attribute set for your entire catalog.
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Attribute Input Types
When viewed from the Admin, attributes are the fields that you complete when you create a
product. The input type that is assigned to an attribute determines the type of data that
can be entered and the format of the field or input control. To the customer, attributes
provide information about the product, and are the options and data entry fields that must
be completed to purchase a product.

INPUT TYPE DESCRIPTION

Text Field A single line input field for text.

Text Area A multiple-line input field for entering paragraphs of text such as a
product description. You can use theWYSIWYGEditor to format
the text with HTML tags, or type the tags directly into the text.

Date Contain date values. Dates can be selected from a popup
calendar, or drop-down list. Depending on the configuration,a
date can be typed directly into the field, selected from a popup
calendar, or drop-down list.

Yes / No Displays a drop-downwith predefined options of “Yes” and “No.”

Dropdown Displays a drop-down list of values. Only one item can be
selected at a time. The Dropdown input type is a key component
of configurable products.

Multiple Select Displays a drop-down list of values. To select more than one
option, hold the Ctrl key down and click each item.

Price Used to create price fields in addition to the predefined attributes,
Price, Special Price, Tier Price and Cost. The currency used is
determined by your system configuration.

Media Image Gives you the ability to associate an image with a product, that is
something other than a product image. For example, youmight
include the product logo, care instructions, or an image of the
ingredients from a food label. When you add amedia image
attribute to the attribute set of a product, it becomes an additional
image type, along with Base, Small, and Thumbnail. Themedia
image attribute can be excluded from the thumbnail gallery, but is
still available to be used.

Fixed Product Tax Lets you define FPT rates based on the requirements of your
locale. To learnmore, see: General Tax Settings.

Input Types
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Date & TimeCustom Options
The format of date and time fields can be customized, and you can choose the input
control. Dates values can be selected from a drop-down list, or from a popup JavaScript
calendar. The following page has an example of each type of date input control.

Date Input Controls

To format date/time fields:

1. On the Admin menu, select System > Configuration.

2. In the panel on the left, under Catalog, select Catalog.

3. Click to expand the Date & Time Custom Options section. Then, do the following:

Date & Time Custom Options

131Magento Enterprise Edition User Guide, Version 1.14.2.1



Attribute Input Types CHAPTER 11:  Managing Attributes

132 Magento Enterprise Edition User Guide, Version 1.14.2.1

a. To display the JavaScript calendar as an input control for date fields, set Use
JavaScript Calendar to “Yes.”

b. To establish the Date Fields Order, set each to one of the following:

l Month

l Day

l Year

c. Set your preferred Time Format to one of the following:

l 12h AM/PM

l 24h

d. To set the Year Range for the drop-down year values, enter the year in YYYY format to
establish the beginning and ending from and to dates.

If left blank, the field defaults to the current year.

4. When complete, click the Save Config button.
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Creating Attributes
The properties of an attribute determine how it can be used in your catalog and how it
appears throughout your store. In addition to the basic properties, there are additional
properties for drop-down and multiple-select input types, their values, and associated
labels. The title, or label, identifies the attribute in the Admin and your storefront. If your
store is available in multiple languages, you can enter a different translated label for each
language.

Attributes can be created using the Manage Attributes tool, and also from inside a product
record.

Manage Attributes

Step 1: Define the Attribute Properties

1. On the Admin menu, select Catalog > Attributes > Manage Attributes. Then, click the Add
Attribute button.

2. In the Attribute Properties section, complete the following required (*) properties:

a. Enter a unique Attribute Code to identify the attribute internally. The code should be
all lowercase characters without spaces.

b. In the Apply To list, choose each product type that is associated with the attribute.
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Attribute Properties

3. Complete the remaining Attribute Properties as needed.

a. Set Scope to the indicate where the attribute will be available.

b. Set Catalog Input Type for Store Owner to the type of input control used by the store
administrator during data entry.

c. To prevent duplicate values from being entered in this field, set Unique Value to “Yes.”

d. To require that a value must be entered in the field before the record can be saved, set
Values Required to “Yes.”

e. To run a validity test of data entered into the field, set Input Validation for Store
Owner to the type of data the attribute should contain.

4. In the Frontend Properties section, complete as many of the settings as needed.

Frontend Properties
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Step 2: Define the Label and Values

1. In the Attribute Information panel on the left, select Manage Label / Options. Then, do the
following:

a. In the Manage Titles section, under Admin, enter a descriptive label to identify the
field during data entry.

b. The next column determines how the label appears in your storefront. You can leave
the box blank to use the Admin label as the default.

c. If your store is available in multiple languages, enter a translated label into each box,
as needed.

2. For drop-down or multiple-select input types, do the following:

a. In the Manage Options section, click the Add Option button.

b. In the new row, under Admin, type the value you want to use in your store's Admin.

c. Enter the value you want your customers to see. (Leave blank to use the Admin value
as the default.)

d. If applicable, enter a translated value for each language supported.

e. Enter a number to determine the Position of this value in relation to other options in
the list.

f. Select Is Default to automatically select this value.

g. Repeat these steps for each value you want to add to the list.

Manage Label / Options for Dropdown Input Type

3. When complete, click the Save Attribute button.

The attribute appears in the Manage Attributes list, sorted in alphabetical order by
Attribute Code. Use the Page controls to view each page of the list.
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Deleting Attributes
If you created sample data while setting up your store, it is possible that you now have
some attributes that aren’t needed for your catalog. When an attribute is deleted, it is
removed from any related products and attribute sets. System attributes are part of the core
functionality of your store and cannot be deleted.

To delete an attribute:

1. On the Admin menu, select Catalog > Attributes > Manage Attributes.

2. In the list, find the attribute and click to open the record.

3. Click the Delete Attribute button.

4. When prompted to confirm, click OK.

Creating an Attribute Set
One of the first steps when creating a product is to choose the attribute set that is used as a
template for the product record. The attribute set determines the fields that are available
during data entry, and the values that appear to the customer.

Manage Attribute Sets

Your store comes with an initial attribute set called “default” which contains a set of
commonly-used attributes. If you would like to add only a small number of attributes, you
can add them to the default attribute set. However, if you sell products that require specific
types of information, such as cameras, it might be better to create a dedicated attribute set
that includes the special attributes (fields) needed to describe the product.

A single attribute can be used by as many different attribute sets as is necessary. For
example, the attribute “color” can be included in an attribute set for clothing, paint, or for
any number of different products.
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To create an attribute set:

1. On the Admin menu, select Catalog > Attributes > Manage Attribute Sets.

2. Click the Add New Set button. Then, do the following:

Edit Set Name

a. Enter a Name for the attribute set.

b. In the Based On field, select another attribute set from which this attribute set is to
inherit attributes. This option enables you to reuse the attributes already defined in a
set to build other attribute sets. The simple option is to leave the Default option that
appears in this field.

3. Click the Save Attribute Set button. The next page displays the following:

l The top left of the page shows the name of the attribute set defined earlier. You have the
option to edit the name because this value is for internal use.

l The center of the page shows a hierarchical tree representing Groups for attributes.

l The right side of the page shows a list of defined attributes that are not assigned to this
attribute set.

4. Select the attribute to be assigned to this Group by dragging them from the Unassigned
Attributes area on the right into the relevant Group in the middle of the page.

System Attributes are marked with a dot and cannot be removed from the Groups list.
However, you can drag them to another Group in the attribute set.

5. When the attribute set is complete, click the Save Attribute Set button.
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Edit Attribute Set

To create a new attribute group:

1. In the Groups section of the attribute set, click the Add New button.

2. Enter a Name for the new group, and click OK.

3. Do either of the following:

l Drag Unassigned Attributes to the new group.

l Drag attributes from any other group to the new group.

The new group becomes a section in the Product Information panel for any product that is
based on this attribute set.
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Attribute Quick Reference
Product Type Properties

PROPERTY DESCRIPTION

Apply To Identifies the product types that can use the attribute. Visibility
must be set to include the catalog.

Use to Create
Configurable Product

Identifies an attribute that is used to create a drop-down list of
options for a configurable product.

Data Entry Properties

PROPERTY DESCRIPTION

Default Value Displays a common entry as a starting value.

Unique Value Prevents duplicate values from being entered.

Values Required Requires a value to be entered before the record can be saved.

Input Validation Performs a validation check of the data, based on data type, or
format.

Search and Navigation Properties

PROPERTY DESCRIPTION

Use in Quick Search Lets customers use the Search box to find items based on the
value of the attribute.

Use in Advanced Search Includes the attribute as a field on the Advanced Search form.

Use in Layered Navigation Includes the attribute in the layered navigation that is displayed
for category lists.

Use in Search Results
Layered Navigation

Includes the attribute in the layered navigation that is displayed
for search results lists.

Position Determines the position of the attribute when listed with others in
the layered navigation list.

Use in Product Listing (Depending on theme) Includes the attribute in the product
listing.

Use for Sorting in Product
Listing

(Depending on theme) Includes this attribute as an option in the
Sort By list, which can be used to sort a product list.
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Rules and Comparison Properties

PROPERTY DESCRIPTION

Comparable on Front-end Includes the attribute in the Compare Products report.

Use for PromoRule
Conditions

Allows the attribute to be used as the basis of a condition that
triggers a promotional Price Rule or Shopping Cart rule.

Presentation Properties

PROPERTY DESCRIPTION

Visible on Product View
Page

Includes the attribute on the Additional Information tab of the
product view page.

Allow HTML Tags on
Frontend

Permits text fields and areas to bemanually tagged with HTML.

EnableWYSIWYGEditor Makes theWYSIWYGEditor available for tagging a text field or
text area with HTML.
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Attribute Properties
The Attribute Properties define the individual characteristics that determine how an
attribute can be used in the product catalog.

Attribute Properties

PROPERTY DESCRIPTION

Attribute Code (Required) A unique identifier for internal use. The Attribute Code
must begin with a letter, but can include a combination of
lowercase letters (a-z) and numbers (0-9). The codemust be less
than thirty characters in length and cannot include any special
characters or spaces, although an underscore (_) can be used to
indicate a space.

Scope Limits the use of an attribute to a specific store view or website.
Options include: Store View / Website / Global

Catalog Input Type for
Store Owner

Determines the data type and input control that is used to
manage the product from the store Admin. Options include:

Text Field A single line input field for text.

Text Area A multiple-line input field that can display
paragraphs of text formatted with HTML.

Date An input field for date values. The date
can be typed directly into the field, or
selected from a list or calendar.

Yes/No A drop-down list with predefined options
of “Yes” and “No.”

Property Descriptions

141Magento Enterprise Edition User Guide, Version 1.14.2.1



Attribute Properties CHAPTER 11:  Managing Attributes

142 Magento Enterprise Edition User Guide, Version 1.14.2.1

PROPERTY DESCRIPTION

Dropdown A drop-down list of configurable options,
from which only one can be selected.

Multiple Select Displays a drop-down list of configurable
options. To select more than one option,
hold down the Ctrl key and click each
item.

Price An input type that can be used to create
price fields in addition to the predefined
attributes: Price, Special Price, Tier
Price and Cost.

Media Image An additional image that can be included
in the attribute set of a product.

Fixed Product Tax An input type that gives you the ability to
define FPT rates based on the
requirements of your locale.

Default Value Assigns a starting value to the attribute to help during data entry.
To assign a default value for Multiple Select or Dropdown input
types, see: Creating Attributes.

A default value cannot be set for Multiple Select, Dropdown, or
Fixed Product Tax input types.

Unique Value To prevent duplicate values in a data entry field, set Unique
Value to “Yes.” Options include: Yes / No

Values Required To require that a value to be entered in this field before the record
can be saved, set Values Required to “Yes.” Options
include: Yes / No

Input Validation for Store
Owner

Performs a validation check of the data entered in the field,
based on the following options:
None
Decimal Number
Integer Number
Email
URL
Letters

Property Descriptions (cont.)
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PROPERTY DESCRIPTION

Letters (a-z, A-Z) or Numbers (0-9)

Apply To (Required) Identifies the product types to which this attribute
applies. Options include:
All Product Types
Selected Product Types
Simple Product
Grouped Product
Configurable Product
Virtual Product
Bundle Product
Downloadable Product
Gift Card

Use to Create
Configurable Product

(Dropdown input type only) Select “Yes” if this attribute will be
used to create a drop-down list for a configurable product.
Options include: Yes / No

Property Descriptions (cont.)
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Attribute Frontend Properties
The Frontend Properties determine how an attribute can be used in your store. You can
specify how attributes are used in search, layered navigation, product comparisons, price
rules, and sorting. For text attributes, you can enable the WYSIWYG editor and specify if
HTML tags can be used to format the value.

Frontend Properties

PROPERTY DESCRIPTION

Use in Quick Search Select “Yes” if you want people to be able to search the catalog
based on the value of this attribute. Options include: Yes / No

SearchWeight (Solr Only) Assign a value from 1 – 5 to weight the search.

Use in Advanced Search Gives shoppers the ability to enter their search criteria through a
form. Options include: Yes / No

Using too many attributes can slow down search.

Comparable on Front-end Select “Yes” to include this attribute as a row in the Compare
Products report. Options include: Yes / No

Use In Layered Navigation (Dropdown, Multiple Select and Price input types only) Includes
the attribute as a filter in the “Shop By” section of layered
navigation. Options include:

Property Descriptions
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PROPERTY DESCRIPTION

No The attribute is not used in layered
navigation.

Filterable (with
results)

Lists only products that match the filter
value.

Filterable (no
results)

Lists all attribute values, even those that
do not apply to any product in the list.
Layered navigation appears on a
category page only if there are filterable
attributes available.

Use In Search Results
Layered Navigation

To include the attribute in the layered navigation for search
results, select “Yes.” Options include: Yes / No

Use for PromoRule
Conditions

Tomake the attribute available for use in price rules, select
“Yes.” Options include: Yes / No

Position Determines the position of the attribute in layered navigation in
relation to other filterable attributes.

EnableWYSIWYG (Text Area input type only) To display the editor when entering or
editing the attribute value, select “Yes.” The editor can be used to
format field descriptions with HTML tags. Options include:
Yes / No

Allow HTML Tags on
Frontend

(Text Field and Text Area input types only) To be able to format
the attribute value with HTML tags, select “Yes.” Options
include: Yes / No

Visible on Product View
Page on Front-end

(Simple and virtual products only) To include the attribute on the
Additional Information tab of the product page, select “Yes.”
Options include: Yes / No

Used in Product Listing Depending on the theme, includes the attribute in the product
summary that appears in catalog listings, and alsomakes the
attribute available for use in smart category rules. Options
include: Yes / No

Used for Sorting in Product
Listing

Depending on theme, includes the attribute as a “Sort By” option
for catalog listings. Options include: Yes / No

Property Descriptions (cont.)
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Notes
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CHAPTER 12:

Flat Catalog
Magento typically stores catalog data in multiple tables, based on the Entity-Attribute-
Value (EAV1) model. Because attributes are stored in many tables, SQL queries are
sometimes long and complex.

In contrast, a flat catalog creates new tables on the fly, where each row contains all the
necessary data about a product or category. The flat catalog is updated automatically—
either every minute, or according to your cron job. Flat catalog indexing also applies to
catalog and shopping cart price rules. A catalog with as many as 500,000 SKUs can be
indexed quickly as a flat catalog.

Before you enable a flat catalog for a live store, make sure to first test the configuration in a
development environment.

1Entity Attribute Value
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Setting Up a Flat Catalog
Before you enable a flat catalog for a live store, make sure to test the configuration in a
development environment.

Use Flat Catalog

Step 1: Enable Flat Catalog

1. On the Admin menu, select System > Configuration.

2. In the panel on the left, under Catalog, select Catalog.

3. Click to expand the Frontend section. Then, do the following:

a. Set Use Flat Catalog Category to “Yes.”

b. Set Use Flat Catalog Product to “Yes.”

4. When complete, click the Save Config button.

5. When prompted to refresh the Page Cache, click the Cache Management link in the
message at the top of the workspace and follow the instructions.

http://merch.docs.magento.com/ee/user_guide/Magento_Enterprise_Edition_User_Guide.html#configuration/catalog/catalog.html%23Frontend
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Step 2: Verify the Results

Method 1: Verify the Results for a Single Product

1. Open one browser tab to the store Admin, and log in as an administrator.

2. On a second browser tab, navigate to your store’s home page.

3. On the Admin menu, select Catalog > Manage Products. Then, do the following:

a. Choose a product to modify. Then, click to open the product in edit mode.

b. On the General tab, in the Name field, add the text “_DEMO” to the product name.

4. Click the Save button.

5. In your store, search for the product you edited, and browse to its assigned category.

If necessary, refresh the page to see the result of the change you made. The change occurs
either within the minute or according to your cron job schedule.

Method 2: Verify the Results for Multiple Products

1. On a second browser tab, navigate to your store’s home page.

2. On the Admin menu, select Catalog > Categories > Manage Categories.

3. In the upper-left corner, set Current Configuration Scope to one of the following:

l All Store Views

l A specific store view

4. In the panel on the left, select an existing category. Click the Add Subcategory button,
and do the following:

a. In the Name field, enter “Demo Category.”

b. Set Is Active to “Yes.”

c. Click the Save Category button.
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New Subcategory

d. Click the Category Products tab. Then, click the Reset Filter button to display all
products.

e. Select the checkbox of several products to add them to the new category. Then, click
the Save Category button.

Category Products

5. In your store, locate the category you created.

If necessary, refresh the page to see the result of the change you made. The change occurs
either within the minute or according to your cron job schedule.
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CHAPTER 13:

Creating Products
Choosing a product type is one of the first things you must do to create a new product.
In this chapter, you will learn how to create a product of each type. To learn more
about all the available options, see Product Information.

If you are just starting out, you can create a few sample products, and experiment with
each type. Before building your catalog, make sure to read Navigation by Category and
Catalog URL Options. This material will give you a good understanding of the
relationship between your store navigation, the categories in your catalog.

Topics in this chapter include:

l Product Types

l Simple Product

l Grouped Product

l Configurable Product

l Virtual Product

l Bundle Product

l Downloadable Product

l Gift Card
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Product Types
Simple Product

A simple product is a physical item with a single
SKU. Simple products have a variety of pricing and
of input controls whichmakes it possible to sell
variations of the product. Simple products can be
used in association with grouped, bundle, and
configurable products.

Grouped Product

A grouped product presents multiple, standalone
products as a group. You can offer variations of a
single product, or group them for a promotion. The
products can be purchased separately, or as a group.

Configurable Product

A configurable product appears to be a single product
with lists of options for each variation. However,
each option represents a separate, simple product
with a distinct SKU, whichmakes it possible to track
inventory for each variation.

Virtual Product

Virtual products do not have a physical presence,
and are typically used for such things as services,
warranties, and subscriptions. Virtual products can
be used in association with grouped and bundle
products.
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Bundle Product

A bundle product let customers “build their own” from
an assortment of options. The bundle could be a gift
basket, computer, or anything else that can be
customized. Each item in the bundle is a separate,
standalone product.

Downloadable Product

A digitally downloadable product that consists of one
or more files that are downloaded. The files can
reside on your server or be provided as URLs to any
other server.

Gift Card Product

There are three kinds of gift cards: virtual gift cards
are sent by email, physical gift cards are shipped to
the recipient, and combined gift cards are a
combination of the two. Each has a unique code,
which is redeemed during checkout. Gift cards can
be used in association with grouped products.
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Simple Product
One of the keys to harnessing the power of product types is learning how and when to use a
simple, standalone product. Simple products can be sold individually, or as part of a
grouped, configurable, or bundle product. A simple product with multiple, custom options
is sometimes referred to as a composite product1.

Simple Product

Creating a Simple Product
The following instructions take you through the process of creating a simple product with
the basic fields. Each required field is marked in the Admin with a red asterisk (*). After
you complete the required settings and save the product, you can add images and complete
the remaining product information as needed.

Process Overview:
Step 1: Choose the Attribute Set
Step 2: Complete the Basic Information
Step 3: Complete the Remaining Product Information

1Any product type that offers customers a choice of options.
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Step 1: Choose the Attribute Set

The first step is to choose the attribute set, which is used as a template for the product
record. The product in this example is based on the Default attribute set, which includes a
standard of set of fields that can be used for most products.

1. On the Admin menu, go to Catalog > Manage Products.

2. In the upper-right corner of the Manage Products page, click the Add Product button.

3. In the Create Product Settings section, do the following:

a. Accept the “default” Attribute Set, or select another.

b. Set Product Type to “Simple.”

c. Click the Continue button.

Step 2: Complete the Basic Information

The basic set of required fields must be completed before the product record can be saved.
The Product Information panel groups related fields by topic and the required fields are
marked with a red asterisk (*).

1. In the Product Information panel, select General. Then, complete the required fields as
follows:

a. Enter the product Name as you want it to appear in all catalog listings.

b. In the Description box, enter the main description that will appear on the Product
Detail page.

c. Enter a Short Description of the product.

d. Assign a unique SKU for the product.

e. Enter theWeight of the product, which is used to calculate shipping.

f. Set Status to “Enabled.”

g. Set Visibility to “Catalog, Search.”

2. In the Product Information panel, select Prices. Then, complete the required fields as
follows:

a. Enter the Price that you will charge for the product.

b. Set Tax Class to the appropriate tax classification for the product.

3. In the Product Information panel, select Inventory. Then, do the following:
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a. If you do not need to keep track of inventory for the product, set Manage Stock to
“No.”

b. If you want to keep track of inventory, set Manage Stock to “Yes.” Then, do the
following:

l In the Qty field, type the quantity of the item that is currently in stock.

l Set Stock Availability to “In Stock.”

4. To be visible in your catalog, the product must be assigned to a category. To assign the
product to a category, do the following:

a. In the Product Information panel, select Categories.

b. In the category tree, click to expand the section where the item belongs.

c. Select the checkbox of each category where you want the product to appear.

5. If your Magento installation has multiple websites, the product must be assigned to each
one where the product is available for sale. (This option appears only if multiple websites
exist in the store hierarchy.) To configure the scope of the product, do the following:

a. In the Product Information panel, select Websites.

b. On the Websites tab, select the checkbox of each website where the product is available
for sale.

6. After completing these steps, click the Save and Continue button.

At this point, the product should be visible on the assigned category page of your catalog.
Until the product image is uploaded, a placeholder appears in its place.

Step 3: Complete the Remaining Product Information

Although not required, there is still more product information to complete. At the very
least, you will want to upload product images and complete the meta data. In addition,
you can create additional custom options.

Things to Remember

A simple product can have custom options with a variety of input controls, which
makes it possible to sell many product variations from a single SKU.

Custom options are not tracked as separate inventory items.

A simple product that is included in a configurable, or bundle product type cannot
have custom options.
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Grouped Product
A grouped product is made up of multiple, standalone products that are presented as a
group. You can offer variations of a single product, or group them by season or theme to
create a coordinated set. Each product can be purchased separately, or as part of the group.

Grouped Product

Creating aGrouped Product
The following instructions take you through the process of creating a grouped product with
the basic fields. Each required field is marked in the Admin with a red asterisk (*). After
you complete the required settings and save the product, you can add images and complete
the remaining product information, as needed.

Process Overview:
Step 1: Create the Grouped Product
Step 2: Add the Associated Products
Step 3: Configure the Shopping Cart Thumbnails
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Step 1: Create the Grouped Product

The first step is to choose the attribute set, which is used as a template for the product
record. The product in this example is based on the Default attribute set, which includes a
standard of set of fields that can be used for most products.

1. On the Admin menu, select Catalog > Manage Products. Then, click the Add Product
button.

2. In the Create Product Settings section, select the Attribute Set you want to use as a
template for the product.

3. Set Product Type to "Grouped Product," and click the Continue button.

4. Complete the main configuration settings as you would for a simple product, with the
following exceptions:

l A grouped product does not have price options because the price of each item in the
group originates from the associated product.

l You can set quantity increments and stock availability for the group as a whole, but the
inventory of individual items is managed by the associated products.

5. Click the Save and Continue button.

Step 2: Add the Associated Products

1. In the Product Information panel on the left, select the associated products.

If you need help finding the products, use the filter controls at the top of a column.

2. Select the checkbox of each product you want to include in the group.

3. Click the Save button to save your changes.

Step 3: Configure the Shopping Cart Thumbnails

1. On the Admin menu, select System > Configuration.

2. In the Configuration panel on the left, under Sales, select Checkout.

3. Click to expand the Shopping Cart section. Then, set Grouped Product Image to one of
the following:

l Product Thumbnail Itself

l Parent Product Thumbnail
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Shopping Cart

4. Click the Save Config button to save the setting.

Things to Remember

A grouped product is essentially a collection of simple associated products.

Simple and virtual products associated with a grouped product cannot have custom
options.

Each item purchased appears individually in the shopping cart.

The thumbnail image in the shopping cart can be set to display the image from the
grouped product record, or from the associated product.
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Configurable Product
A configurable product looks like a single product with drop-down lists of options for each
variation. However, each option is actually a separate simple product with a unique SKU,
which makes it possible to track inventory for each product variation. You could achieve a
similar effect by using a simple product with custom options, but without the ability to
track inventory for each variation.

Although a configurable product uses more SKUs, and may initially take a little longer to
set up, it can save you time in the long run. If you plan to grow your business, the
configurable product type is a better choice.

Configurable Product

After the configurable product is set up, you have the option to replace the drop-down lists
with swatches. Swatches are often used to show colors, patterns, and textures.
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Creating a Configurable Product
The following instructions take you through the process of creating a configurable product
with the basic fields. Each required field is marked in the Admin with a red asterisk (*).
After you complete the required settings and save the product, you can add images and
complete the remaining product information, as needed.

Process Overview:
Step 1: Create Attributes for Drop-downOptions
Step 2: Create the Attribute Set
Step 3: Create the Configurable Product
Step 4: Add the Associated Products
Step 5: Make Any Necessary Price Adjustments
Step 6: Configure the Shopping Cart Thumbnails

Step 1: Create Attributes for Drop-Down Options

Create an attribute for each drop-down list of options that you want to include in the
configurable product. If the attribute already exists and has the correct properties, you can
add it to the attribute set in the next step. To learn more, see: Creating Attributes.

PROPERTY SETTING

Scope Global

Catalog Input Type for Store
Owner

Dropdown

Apply to Configurable Product or All Product Types

Use to Create Configurable
Product

Yes

Required Attribute Properties

Step 2: Create the Attribute Set

1. On the Admin menu, select Catalog > Attributes > Manage Attribute Sets. Then, click the
Add New Set button.

2. Assign a Name to the attribute set.

3. In the Based On list, select an existing attribute set, such as “Default,” to use as a
template. Then, click the Save Attribute Set button.
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4. Starting from the list of Unassigned Attributes, drag and drop each attribute you want to
include in the product to the center column. You can arrange them in any order.

5. To group the attributes in their own section of the Product Information panel, do the
following:

a. In the Groups section, click the Add New button.

If prompted by your browser, select “Temporarily Allow Scripted Windows” to continue.
Then, click the Add New button again.

b. When prompted, enter a Name for the new group. Then, click the OK button.

The new group appears at the bottom of the Groups column.

c. Drag and drop each attribute that you created for the dropdown options to group
where you want them to appear.

6. Click the Save Attribute Set button.

7. When prompted to update your cache and index, click the links in each message and
follow the instructions.

Step 3: Create the Configurable Product

1. On the Admin menu, select Catalog > Manage Products. Then, click the Add Product
button.

2. In the Create Product Settings section, do the following:

a. Select the Attribute Set that you created for the product.

b. Set Product Type to “Configurable Product,” and click the Continue button.

3. In the Select Configurable Attributes section, select the checkbox of each attribute that you
want to include in the product. Then, click the Continue button.

4. Complete the Product Information as you would for a simple product, with the exception
of the following fields:

l On the Prices tab, the Price is a required field, but is used as a default price. The price
of each individual associated product can be adjusted accordingly.

l On the Inventory tab, Manage Stock is set to “No” by default, because inventory is
managed for each associated product.

5. When complete, click the Save and Continue Edit button.
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Step 4: Add the Associated Products

Process Overview:
Method 1: Quick Simple Product Creation
Method 2: Create Empty
Method 3: Copy from Configurable

1. In the panel on the left, select the last option, Associated Products.

2. Then, use one of the following methods to add the associated products.

Method 1: Quick Simple Product Creation

This method automatically creates the associated products and optionally, assigns a Name
and SKU to each one.

1. In the Quick Simple Product Creation section, make sure that the Autogenerate
checkbox is selected for both Name and SKU. This optional setting adds the name
and SKU from each associated product to those of the configurable product. Then,
complete these fields as follows:

a. Enter theWeight.

b. Set Status to “Enabled.”

c. Set Visibility to “Not Visible Individually.”

2. To complete the fields for the drop-down lists, do the following:

a. Select the value you need from each list to create the first product.

b. Enter the Qty, and set Stock Availability to “In Stock.”

c. Click the Quick Create button to create the associated product record.

Repeat this step for the values needed for each associated product. As each associated
products is created, it is added to the list at the bottom of the page.

Method 2: Create Simple Associated Product

This method opens a blank Product Information form, which you can complete for each
associated product.

1. In the Create Simple Associated Product section, click the Create Empty button. A
pop-up window with a blank Product Information form appears.

2. Complete the required fields as you would for any simple product.

3. Click the Save button to add the associated product.
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Method 3: Copy from Configurable

This method opens a Product Information form that contains the values already entered
for the configurable product. The only fields that need to be completed are the Name, SKU,
and values for each drop-down list.

1. In the Create Simple Associated Product section, click the Copy From Configurable
button. A pop-up window with the basic Product Information from the configurable
product appears.

2. Complete the following required fields:

l SKU

l Weight

3. Complete the fields with values for each drop-down list.

4. Click the Save button to add the associated product to the configurable product
record.

Step 5: Make Any Necessary Price Adjustments

Use the Super Products Attributes Configuration section to make price adjustments to a
specific associated product. The adjustment can be entered as a fixed value or percentage,
and is made in relation to the price of the configurable product.

Step 6: Configure the Shopping Cart Thumbnails

1. On the Admin menu, select System > Configuration.

2. In the panel on the left, under Sales, select Checkout.

3. Click to expand the Shopping Cart section. Then, set Configurable Product Image to one
of the following:

l Product Thumbnail Itself

l Parent Product Thumbnail

Shopping Cart

4. Click the Save Config button to save the setting.
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Things to Remember

A configurable product allows the shopper to select options from drop-down lists.
Each option is actually a separate, simple product.

The drop-down list values are based on attributes that must be set up in advance with
required settings. The attribute Scopemust be set to “Global,” and Use to Create
Configurable Product must be “True.” The drop-down attributes must be included in an
attribute set, which is then used as a template for the configurable product.

Swatches can be used instead of drop-down lists for product variations.

The simple products associated with a configurable product cannot include custom
variants or options, andmust be based on the same attribute set that is used to create
the configurable product. The associated products can be generated automatically
from inside with configurable product record.

The thumbnail image in the shopping cart can be set to display the image from the
configurable product record, or from the associated product.
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Virtual Product
Although virtual products are not physical in nature, they do represent something that can
be sold, such as a membership, service, warranty, or subscription. Virtual products can be
sold individually, or included as part of the following product types:

l Grouped Product

l Bundle Product

The process of creating a virtual product and a simple product is nearly the same.
However, because a virtual product is not shipped, there is no Weight field or option to
include a gift card.

Virtual Product

Creating a Virtual Product
The following instructions take you through the process of creating a virtual product with
the basic fields. Each required field is marked in the Admin panel with a red asterisk (*).
After you complete the required settings and save the product, you can complete the
remaining product information as needed.

Process Overview:
Step 1: Choose the Attribute Set
Step 2: Complete the Required Fields
Step 3: Complete the Remaining Product Information
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Step 1: Choose the Attribute Set

1. On the Admin menu, select Catalog > Manage Products.

2. In the upper-right corner of the Manage Products page, click the Add Product button.

3. In the Create Product Settings section, do the following:

a. Accept the “default” Attribute Set, or select another.

b. Set Product Type to “Virtual Product.”

c. Click the Continue button.

Step 2: Complete the Required Fields

The panel on the left groups related fields by topic, according to the attribute set. All
required fields are marked with a red asterisk (*).

1. On the General tab, complete the required fields as follows:

a. Type the product Name as you want it to appear in all catalog listings.

b. In the Description box, enter the main description that will appear on the product
view page.

c. Enter a Short Description of the product.

d. Assign a unique SKU to the product.

e. Set Status to “Enabled.”

f. Set Tax Class to the appropriate setting for your area.

g. Set Visibility to “Catalog, Search.”

2. On the Prices tab, enter the Price you intend to charge for the product or service.

3. If you’re not going to manage your inventory, you can skip this section. Otherwise,
complete the required fields on the Inventory tab as follows:

a. Under Manage Stock, clear the Use Config Settings checkbox. Then, set Manage
Stock to “Yes.”

b. In the Qty field, enter the quantity of the item currently in stock.

c. Set Stock Availability to “In Stock.”

4. If applicable, on theWebsite tab, select the checkbox for the website where the product or
service will be available for sale.

5. On the Categories tab, assign the product to the appropriate categories, as follows:
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a. In the Product Category tree, click to expand the section where the item belongs.

b. Select the checkbox to assign the product to each category where you want the product
to be listed in the catalog.

6. When the required fields are complete, click the Save and Continue button.

Step 3: Complete the Remaining Product Information

You have now completed the required fields. The next step is to complete the rest of the
product information as needed for this product. The meta information and product images
are a good place to start.

Things to Remember

Virtual products can be used for anything that is not physical in nature, such as
services, subscriptions, and warranties.

Virtual products aremuch like simple products, but without theWeight and Allow Gift
Message fields.

Shipping Options appear during checkout only if there is also a physical product in the
cart.
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Bundle Product
A bundle is a “build your own,” customizable product. Each item in a bundle can be based
on one of the following product types:

l Simple Product

l Virtual Product

Bundle Product

Creating a Bundle Product
The following instructions take you through the process of creating a bundle product with
the basic fields. Each required field is marked with a red asterisk (*). After you complete the
required settings and save the product, you can complete the remaining Product
Information as needed.

Process Overview:
Step 1: Create the Bundle Product
Step 2: Complete the Product Information
Step 3: Add Bundle Items
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Step 1: Create the Bundle Product

1. On the Admin menu, select Catalog > Manage Products. Then, click the Add Product
button.

2. In the Create Product Settings section, select the Attribute Set for the product.

3. In the Create Product Settings section, do the following:

a. Accept the “default” Attribute Set, or select another.

b. Set Product Type to “Bundle Product.” Then, click the Continue button.

Create Product Settings

Step 2: Complete the Product Information

1. Complete the product information as you would for a simple product, with the exception of
the following fields:

2. On the General tab, set both the SKU and Weight fields to one of the following:

l Dynamic

l Fixed

If using a Fixed value, enter the actual value in the field to the right.

Dynamic SKU and Weight

3. On the Prices tab, set Price to one of the following:

l Dynamic

l Fixed

If using a Fixed value, enter the actual value in the field to the right.
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Dynamic Price

4. Then, set the Price View to one of the following:

l As Low as

l Price Range

5. Click the Save and Continue Edit button.

Step 3: Add Bundle Items

1. In the Product Information panel on the left, select the last option, Bundle Items.

2. Then in the Shipment section, set Ship Bundle Items to one of the following:

l Together

l Separately

Shipment

3. In the Bundle Items section, click the Add New Option button.

4. In the Default Title box, enter a label for the bundle item, as you want it to appear on the
Customize Product page. Then, do the following:

Bundle Items
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a. Set Input Type to one of the following:

l Drop-down

l Radio Buttons

l Checkbox

l Multiple Select

b. Set Is Required as needed.

c. In the Position field, enter the order that you want this item listed in relation to other
items included in the bundle.

5. Click the Add Selection button. Then, do the following:

Select Products

a. Click the Reset Filter button to display the list of products.

b. Select the checkbox of each product that you want to include in this item.

c. In the Qty to Add column, enter the quantity of each item to be included.

6. Click the Add Selected Product(s) to Option button.

7. When the items appear in the Bundle Items list, do the following:

Bundle Items



CHAPTER 13:  Creating Products Bundle Product

a. Set User Defined Qty to one of the following:

Yes Displays an input box so the customer can change the quantity.

No Prevents the customer from changing the default quantity.

b. Enter a number in the Position column of each item to determine its place in relation
to other items.

c. To make an item the default selection, select the Default option of the item to be pre-
selected in the form.

8. Repeat steps 3-7 for each bundle item you want to include.

9. When complete, click the Save button to save the bundle product.

FIELD DESCRIPTION

SKU Determines if each item is assigned a variable, dynamic SKU, or if a
fixed SKU is used for the bundle. Options include: Fixed / Dynamic.

Weight Specifies the weight is calculated based on the items selected, or is a
fixed weight for the entire bundle. Options include: Fixed / Dynamic.

Price View Determines if the price is shown as a range, from the least expensive
component to themost expensive (Price Range), or the least expensive
shown (As Low As). Options include: Price Range / As Low As.

Ship Bundle Items Specifies if individual items can be shipped separately.

Field Descriptions

Things to Remember

Bundle items can be simple or virtual products, but without custom options.

The Price View can be set to a price range or “As Low As.”

The SKU andWeight of a bundle product can be set to either “Fixed” or “Dynamic.”

TheQuantity can be set to a preset or user-defined value.

Items can be shipped together or separately.
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Downloadable Product
A downloadable product can be anything that you can deliver as a file, such as an eBook,
music, video, software application, or an update. You can offer an album for sale, and sell
each song individually. You can also use a downloadable product to deliver an electronic
version of your product catalog.

Because the actual download doesn’t become available until after the purchase, you can
provide samples, such as an excerpt from a book or a clip from an audio file, that the
customer can try from the product page.

Download with Sample

Downloadable products can be configured to require that the customer log in to an account
to receive the link, or can be sent by email and shared with others. The status of the order
before the download becomes available, default values, and other delivery options are set in
the configuration.

The files for download can be either uploaded to your server, or linked to on a different
server on the Internet.

Downloadable product file names can include letters and numbers. You can to use either a dash
or underscore character to represent a space between words. Any invalid characters in the file
name are replaced with an underscore.
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Creating a Downloadable Product
The following instructions take you through the process of creating a downloadable product
with the basic fields. Each required field is marked in the Admin with a red asterisk (*).
After you complete the required settings and save the product, you can add images and
complete the remaining product information as needed.

Process Overview:
Step 1: Choose the Attribute Set
Step 2: Complete the Basic Product Information
Step 3: Complete the Download Information
Step 4: Complete the Samples Information
Step 5: Complete the Remaining Product Information

Step 1: Choose the Attribute Set

The first step is to choose the attribute set, which is used as a template for the product
record. The product in this example is based on the Default attribute set, which includes a
standard of set of fields that can be used for most products.

1. On the Admin menu, go to Catalog > Manage Products.

2. In the upper-right corner of the Manage Products page, click the Add Product button.

3. In the Create Product Settings section, do the following:

a. Attribute Set is currently set to “Default.” You can leave it as it is, or select another.

b. Set Product Type to “Downloadable Product,” and click the Continue button.

Create Product Settings

Step 2: Complete the Basic Product Information

The basic set of required fields must be completed before the product record can be saved.
The Product Information panel groups related fields by topic and the required fields are
marked with a red asterisk (*).

1. In the Product Information panel, select General. Then, do the following:

a. Enter the product Name as you want it to appear in all catalog listings.

b. In the Description box, enter the main description for the Product Detail page.
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c. Enter a Short Description of the product.

d. Assign a unique SKU for the product.

e. Set Status to “Enabled.”

f. Set Visibility to “Catalog, Search.”

2. In the Product Information panel, select Prices. Then, complete the required fields as
follows:

a. Enter the Price that you will charge for the product.

The price entered becomes the base price of the download and is listed in the catalog
before the customer selects items for download. Any additional price that is associated
with an individual download is added to the base price.

b. Set Tax Class to the appropriate tax classification for the product.

3. In the Product Information panel, select Inventory. Then, do the following:

a. To not keep track of inventory for the product, set Manage Stock to “No.”

b. If you do need to keep track of inventory, set Manage Stock to “Yes.” Then, do the
following:

l Set Manage Stock to “Yes.”

l In the Qty field, type the quantity of the item that is currently in stock.

l Set Stock Availability to “In Stock.”

4. In the Product Information panel, select Categories. Then, do the following:

a. In the category tree, click to expand the section where the item belongs.

b. Select the checkbox of each additional category where you want the product to appear.

5. To make the product available on multiple websites, it must be assigned to each one. (This
option appears only if you have multiple websites.) To configure the scope of the product,
do the following:

a. In the Product Information panel, select Websites.

b. Select the checkbox of each website where the product will be available for sale.

6. After completing these steps, click the Save and Continue Edit button.

Step 3: Complete the Download Information

1. In the Product Information panel, select Downloadable Information.

2. In the Links section, do the following:
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a. Enter a Title for the list of downloadable products.

b. Set Links can be purchased separately to one of the following:

l If you want to offer multiple download links, such as to sell individual songs on an
album, select “Yes.”

l To offer a single download of this item, select “No.”

3. Click the Add New Row button, and do the following:

a. Enter the Title and Price of the download.

b. To limit the number of downloads per customer, enter the Max number of downloads.
To allow unlimited downloads, select the Unlimited checkbox.

c. Set Sharable to your preference.

l Select “No” to require that customers log in to their accounts to access the download
link.

l Select “Yes” to send the link by email, which customers can then share with others.

4. Under Sample, use one of the following methods to deliver a sample of the downloadable
product.

l Select the File option. Then, click the Browse button, and select the sample file to
upload to the server.

l Select the URL option. Then, paste the full URL of the sample file.

5. Under File, use one of the following methods to deliver the actual downloadable product.

l Select the File option. Then, click the Browse button, and select the file to upload.

l Select the URL option. Then, paste the full URL of the file that is available for
download.

6. In the Sort Order field, enter a number to indicate the sequence that this download will be
listed with other downloads on the product page.

7. To add another download, click the Add New Row button, and repeat the process.

Links
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8. When complete, if uploading files to the server, click the Upload Files button.

9. Click the Save and Continue Edit button.

Step 4: Complete the Samples Information

1. Click to expand the Samples section.

2. Enter a Title for the section of samples on the product page.

3. Click the Add New Row button. Then, do one of the following:

l Select the File option. Then, click the Browse button, and select the sample file to
upload.

l Select the URL option. Then, paste the full URL of the sample file.

Add New Sample

4. To add a new row, click the Add New Row button, and repeat the process.

5. When complete, click the Save button.

6. When prompted to refresh the index and cache, click the links in the message at the top of
the workspace, and follow the instructions.

At this point, the product should be visible on the assigned category page of your catalog.
Until a product image is uploaded, a placeholder appears in its place.

Step 5: Complete the Remaining Product Information

Although not required, there is other product information to complete. At the very least,
you will want to upload product images and complete the meta data.
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Things to Remember

Downloadable products can be uploaded to the server, or linked to from another
server on the Internet.

You can determine the number of times a customer can download a product.

Customers can be required to log in before going through checkout.

Downloads can be delivered for orders in a “Pending” or “Invoiced” state.

Downloadable Product Options
The configuration settings determine guest checkout, default values, and delivery options
for downloadable products.

Downloadable Product Options

To configure downloadable products:

1. On the Admin menu, select System > Configure.

2. In the panel on the left, under Catalog, select Catalog.

3. Click to expand the Downloadable Product Options section. Then, do the following:

a. To determine the status an order must have to access available downloads, set Order
Item Status to Enable Downloads to one of the following:

l Pending

l Invoiced

b. Enter the Default Maximum Number of Downloads that a customer can purchase in a
single order.
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c. To determine if customers must log in to their accounts to access the download link,
set Shareable to one of the following:

Yes Allows the link to be sent by email, which can then be shared with
others.

No Prevents gues purchases by requiring customers to log in to their
accounts to access the download link.

d. Enter a Default Sample Title to be used for all downloadable files.

e. Enter a Default Link Title to be used for all download links.

f. If you want download links to open in a new window, set Open Links in New Window
to “Yes.”

g. To specify how the download link is delivered, set Use Content Disposition to one of
the following:

Attachment Delivers the download link as an email attachment.

Inline Delivers the download link as an inline link on a web page.

h. To require that guests who purchase downloadable products create an account to
complete the checkout process, set Disable Guest Checkout if Cart Contains
Downloaded Items to “Yes.”

4. When complete, click the Save Config button.
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Gift Card
There are three kinds of gift card products: virtual gift cards sent by email, physical gift
cards, which can be shipped to the recipient, and a combination of the two. Each gift card
has a unique code, which can be redeemed by only one customer during checkout. A code
pool must be established before gift cards can be sold.

Physical Gift Card

Virtual

The gift card is sent to the recipient by email. The order requires an email address for the
recipient. A shipping address is not necessary.

Physical

The gift card is shipped to recipient’s address, which is required during the purchase of the
gift card.

Combined

The gift card is shipped and emailed to the recipient. The recipient’s email and shipping
address is required to purchase the gift card.
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Gift CardWorkflow
Gift card accounts can be redeemed in the shopping cart, similar to the way a coupon is
applied to an order. There is a block with a data entry field for entering the gift card code,
with a button that applies it to the items in the cart. In addition, customers can check their
gift card status and the remaining balance in their gift card accounts.

Purchasing a Gift Card

Multiple gift card accounts can be applied to a shopping cart. Each time a gift card is
applied, the amount appears in the order totals block, and is subtracted from the grand
total. The full balance of each gift card is subtracted from the shopping cart total. Multiple
gift cards are applied in ascending order. Accounts with the smallest remaining balances
are applied first, until the customer runs out of cards, or until the grand total is zero. If the
grand total is zero, the last account applied to the cart receives a partial deduction, and
any cards that have not applied to the cart will not receive a deduction. The actual
deductions occur only once the order is placed.

The price of a gift card can be configured at the time of purchase. Depending on the price
configuration, there will be either a drop-down list of price options, a field, or a
combination of the two. All amounts are displayed in the currency used in the store, but
the actual amount of the gift card is converted to the base currency after it is added to the
cart.

The customer enters the Sender Name (and Sender Email for a virtual or combined gift
card) and Recipient Name (and the Recipient Email for a virtual or combined gift card). If
the customer is logged in, the Sender Name (and Sender Email, if applicable) is entered
automatically from information in the customer’s account. Depending on how the gift card
is configured, there may also be a Message text area.
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If multiple gift cards are purchased in one order, and the type is virtual or combined, all
the corresponding gift card codes are sent to the recipient in one email.

For all gift card types, the generated account codes will be shown in the order information
page in the admin. This allows you to retrieve the code to place it on the physical gift card,
if necessary.

If an order with a gift card product is canceled or refunded, you must manually cancel the
gift card account. You can either delete the account entirely, or deactivate it.

Creating aGift Card
The following instructions take you through the process of creating a gift card with the
required fields. Each required field is marked with a red asterisk (*). After you complete the
required settings and save the product, you can add images and complete the remaining
product information, as needed.

Process Overview:
Step 1: Create the Gift Card Product
Step 2: Set Up theGift Card Pricing
Step 3: Complete the Gift Card Information

Step 1: Create the Gift Card Product

1. On the Admin menu, select Catalog > Manage Products. Then, click the Add Product
button.

2. In the Create Product Settings section, select the Attribute Set you want to use as a
template for the product.

3. In the Create Product Settings section, do the following:

a. Accept the “default” Attribute Set, or select another.

b. Set Product Type to “Gift Card.”

c. Click the Continue button.

4. You can complete most of the Product Information as you would for a simple product.

5. Click the Save and Continue button.
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Step 2: Set Up the Gift Card Pricing

1. In the panel on the left, click Prices.

2. To add predefined gift card prices, click the Add Amount button. Then, enter a price of the
gift card as the Amount.

Repeat this step to add more pricing options.

3. Set Allow Open Amount to one of the following:

No Requires customers to select a predefined gift card amount.

Yes Allows customers to enter their own gift card amount. If using an open
amount, complete the following to specify the minimum and maximum
amounts allowed:

Open Amount Min Value

Open Amount Max Value

4. Click the Save button.

Step 3: Complete the Gift Card Information

1. In the panel on the left, select Gift Card Information.

2. Set Card Type to one of the following:

l Virtual

l Physical

l Combined

3. Specify whether the value of the gift card Is Redeemable. If so, the amount can be
transferred to store credit upon creation.

4. Set Lifetime (days) to the number of days remaining before the gift card expires. If you do
not want to set a limit for the lifetime of the card, leave this field blank.

5. Set Allow Gift Message to “Yes,” if you want the customer who purchases the Gift Card to
be able to include a message for the recipient. A gift message can be included for both
virtual (emailed) and physical (shipped) gift cards.

6. Set Email Template to the template that you want to use for the notification email that is
sent when a gift card account is created.

7. Click the Save button.
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Things to Remember

A “code pool” of unique numbers must be generated before a gift card can be offered
for sale.

The three types of gift cards are: Virtual, Physical, and Combined.

Gift cards can be set to “Redeemable” or “Non-Redeemable.”

The lifetime of a gift card can be unlimited, or set to a number of days.

The value of a gift card can be set to a fixed amount, or set to an open amount with a
minimum andmaximum value.

A gift card account for the customer can be created when the order is placed, or at the
time of invoice.

Gift Card Accounts
A gift card account is automatically created for each Gift Card that is purchased. The value
of the gift card can then be applied toward the purchase of a product in your store. You can
also create gift card accounts from the Admin.

Gift Card Accounts
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To create a gift card account:

1. On the Admin menu, select Customers > Gift Card Accounts.

2. In the upper-right corner, click the Add Gift Card Account button.

3. In the Information section, make sure that Active is set to “Yes.”

This field determines if the balance of the account can be redeemed before checkout, and if
the balance can be transferred to the customer's store credit.

Information

4. If applicable, set Website to the website where this gift card account can be used.

5. Enter the starting Balance of the gift card account.

6. Enter the Expiration Date for the gift card. If left blank, the gift card account will not
expire.

7. In the Gift Card Account panel on the left, click Send Gift Card. Then, do the following:

Send Gift Card

a. In the Recipient Email field, enter the email address where email notification of this
gift card account is sent. This field is optional, and no email is sent if blank.

b. In the Recipient Name field, enter the name of the person who will receive the gift
card message.

c. Set Send Email from the Following Store View to the language store view that is
associated with the gift card.

8. Do one of the following:

l If no recipient has been added, click the Save button to save the gift card.

l Click the Save & Send Email button to save the changes and send the gift card by email
to the recipient.
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Gift Card Account Settings
Use the System Configuration Gift Card settings to establish the default settings for all gift
cards sold through your store. The code pool is a pre-generated set of unique gift card codes
in a specific format. Codes from the code pool are used each time a gift card account is
created. It is the responsibility of the administrator to ensure that there are enough codes
available for the gift cards. Make sure to generate a code pool before offering gift cards for
sale. By default, Magento generates 1,000 codes. A new pool is not generated if there are
still unused codes available.

Gift Card Account General Settings

To establish the gift card code pool:

1. On the Admin menu, select System > Configuration.

2. In the Configuration panel on the left, under Sales, select Gift Cards.

3. Click to expand the Gift Card Account General Settings section.

4. Complete the code format fields according to your preference.

5. When you are ready, click the Generate button to create the new code pool.

When complete, the message, “New code pool was generated” appears.

To configure your store to sell gift cards:

1. On the Admin menu, select System > Configuration.

2. In the Configuration panel on the left, under Sales, select Gift Cards.

3. Click to expand the Gift Card Email Settings. Then do the following:
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a. Set Gift Card Notification Email Sender to the email identity that you want to appear
as the sender of gift card notifications sent from your store.

b. Set Gift Card Notification Email Template to the template you want to use for the
email notifications.

Gift Card Email Settings

4. Click to expand the Email Sent from Gift Card Account Management section. Then, do
the following:

a. Set Gift Card Email Sender to the identity that you want to appear as the sender of
gift cards from your store.

b. Set Gift Card Template to the template you want to use for the gift card.

Email Sent from Gift Card Account Management
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5. Click to expand the Gift Card General Settings section. Then, set the following fields to the
default values that you want to use for gift card purchases:

a. If you want the customer to be able to redeem the value on the card for cash, set
Redeemable to “Yes.”

b. In the Lifetime (days) field, enter the number of days before the card expires. Leave the
field blank if there is no expiration date.

Depending on your location,it may be illegal for gift cards to have expiration dates. Check
your local laws before setting a lifetime for your gift cards.

c. If you want the customer to have the option to enter a message with the gift card, set
Allow Gift Message to “Yes.” Then in the Gift Message Maximum Length field, enter
the number of characters available for a gift message.

d. Set Generate Gift Card Account when Orders Item is to one of the following:

Ordered The gift card account is created when the order is placed.

Invoiced The gift card account is created after payment is captured and
the order is invoiced.

Gift Card General Settings

6. When complete, click the Save Config button.
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CHAPTER 14:

Product Images
Using images of consistent quality, size, and proportion gives your product catalog a
professional look with commercial appeal. If you have a large catalog with several
images per product, you can easily have hundreds, if not thousands of product images
to manage. Before you get started, it’s a good idea to establish a naming convention for
your image files, and organize them so you can find the originals if you ever need them.

The Images tab in the Product Information panel is used to upload and manage
individual images for the current product. You can upload multiple images for each
product, with different images for each website or store view. However, if you have a
large quantity of images to manage, it is more efficient to import, rather than upload
each one individually. To learn more, see: Importing Product Images.

Product Images
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Thumbnail Gallery
The thumbnail gallery on the product page can be used to display multiple images of the
product. Although the position of the gallery varies by theme, it is usually just below the
main image on the product page. When a thumbnail is clicked, the image appears, by
default in a popup window that allows you to browse through the images.

Thumbnail Gallery Popup
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Light Boxes and Sliders
Many stores use a third-party light box or slider to display product images in a more
elegant fashion. Typically with a light box, whenever a thumbnail image is clicked, it
replaces the main image on the page. You can use the left and right arrows in the light box
to browse through the images, or click a thumbnail to view a specific image. When zoom is
activated, you can click the main image and move the cursor around to magnify different
parts of the image. The magnified selection appears to the right of the image.

Zoom
Magento displays a magnified portion of the image on mouseover, provided that you have
uploaded a larger image that can be used to zoom in for a closer look.

Zoom
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Image Size and Type
As a best practice, you should standardize the size of your images so they appear at the
highest possible resolution. A single product image can be displayed in several different
sizes throughout your catalog. In addition to the main image on the product page, are
smaller images and thumbnails.

Image types are used in different places in your catalog. If you have only one product
image, you can use the same image for each type. If you do not assign an image to each
type, a placeholder image is used to mark its place in the catalog.

To configure product images:

1. On the Admin menu, select System > Configuration.

2. In the panel on the left, under Catalog, select Catalog.

3. Click to expand the Product Image section. Then, do the following:

a. In the Base Image Width field, enter the maximum width that the base image is to be
rendered.

b. In the Small Image Width field, enter the maximum width that the small image is to
be rendered.

Product Image

4. When complete, click the Save Config button.

http://merch.docs.magento.com/ee/user_guide/Magento_Enterprise_Edition_User_Guide.html#configuration/catalog/catalog.html%23Product_Image


CHAPTER 14:  Product Images Image Size and Type

IMAGE TYPE DESCRIPTION

Thumbnail Thumbnail images appear in the thumbnail gallery, shopping cart,
and in some blocks such as Related Items. Example size:
50 x 50 pixels

Small Image The small image is used for the product images in listings on
category and search results pages, and to display the product
images needed for sections such as for Up-sells, Cross-sells,
and the New Products List. Example size:
470 x 470 pixels

Base Image The base image is themain image on the product detail page.
Image zoom is activated if you upload an image that is larger
image than the image container. Example sizes:
470 x 470 pixels (without Zoom)
1100 x 1100 pixels (with Zoom)

Media Image (Optional) A media image you the ability to associate additional
images with a product, that are other than a product image. For
example, youmight include the product logo, care instructions, or
an image of the ingredients from a food label.
If you add amedia image attribute to the attribute set of a
product, it is listed as an additional image type, along with Base,
Small, and Thumbnail. You can set it to "Exclude" so it doesn't
appear in the gallery.

Image Types
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Adding Product Images
The Images tab is used to upload and manage images for a single product. You can upload
multiple images for the product, and maintain different images for each website or store
view. However, if you have many images to manage, you might prefer to import them,
rather than upload product images individually. Because Magento does not convert image
file formats, any file conversion that is necessary must take place before the files are
uploaded or imported.

Adding Product Images

To add product images:

1. If the images are to be used for only a specific store view, set Choose Store View in the
upper-left corner to identify the view where the images will be used.

2. In the panel on the left, click Images.

3. Click the Browse Files button, and select the product images files you want to upload to
your store.

4. Click the Upload Files button to upload the selected images to your store. Then, for each
image, do the following:

a. Enter a descriptive Label for the image. This text appears on mouseover and can
improve indexing by search engines.

b. If using multiple images, enter a numeric value in the Sort Order field to determine
the sequence in which they appear in the thumbnail gallery.
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c. To prevent an image from being included in the thumbnail gallery, click the Exclude
checkbox. For example, if the product has only one image, there’s no reason to include
it in the gallery.

d. To delete any image, select the Remove checkbox.

5. When complete, click the Save and Continue Edit button.

To add images to the gallery:

Follow the same process for adding a new product image. For best results, gallery image
files should be the same size and proportion as the main product image.

FIELD SCOPE DESCRIPTION

Image Onmouseover, a thumbnail of each uploaded
image appears.

Label The descriptive “Alt” text that appears on
mouseover. Including a label for each image
improves indexing by search engines, and
accessibility for people who use screen readers.

Sort Order Determines the order in which images are
displayed in the gallery.

Thumbnail Store View A very small image that appears in the shopping
cart and in some blocks, such as Related Items.

Small Image Store View Appears in product listings on the category and
search results pages, and also used in additional
sections such as Up-sells, Cross-sells, and the
New Products List.

Base Image Store View Themain image on the product page. If a very
large image is uploaded, it can be used to produce
themagnified area displayed during image zoom.

Media Image Store View (Optional) TheMedia Image appears only if an
attribute of theMedia Image type is included in the
attribute set.

Exclude Select the Exclude checkbox to prevent the
image from being listed in the thumbnail gallery.

Remove Select the Remove checkbox to delete the image.
All selected images are deleted when the product
record is saved.

Field Descriptions
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Placeholders
Magento uses a temporary image as a placeholder until permanent product images are
available. The initial placeholder image is the Magento logo, which you can replace with
placeholder images of your own design.

Product Placeholder Image

To upload placeholder images:

1. On the Admin menu, select System > Configuration.

2. In the Configuration panel on the left, under Catalog, select Catalog.

3. Click to expand the Product Image Placeholders section. Then, do the following:

a. For each image type, click the Browse button to upload the placeholder image you
want to use for the Base Image, Small Image, and Thumbnail images. If you like, you
can use the same image for each type.

b. When complete, click the Save Config button.

Product Image Placeholders
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Watermarks
If you have gone to the expense of creating your own original product images, there is not
much you can do to prevent unscrupulous competitors from stealing them with the click of
a mouse. However, you can place a watermark on each image to identify it as your property
and make it a less convenient target. The watermark file can be either a .jpg (jpeg), .gif, or
.png image.

Example: Watermark Positions

The watermark used in the following examples is a .png file 470 x 470 pixels square, with
a black logo and transparent background. The size and opacity were later adjusted to 100 x
100 pixels at 10% using the watermark configuration settings in the Admin panel. You can
experiment with different watermark settings until you find the look you want.

None Tile Top Left Top Right

Bottom Left Bottom Right Center Stretch
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To place watermarks on product images:

1. On the Admin menu, select System > Configuration.

2. In the Configuration panel on the left, under General, select Design.

3. Click to expand the Product Image Watermarks section. Then, complete the following
steps for the Base, Small, and Thumbnail images:

a. Enter theWatermark Default Size, in pixels. For example: 200 x 300

b. Enter theWatermark Opacity, as a percentage. For example: .40

c. Click the Browse button and select the image file to upload.

d. Set Watermark Position to your preference.

4. When complete, click the Save Config button.

Product Image Watermarks
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Shopping Cart Thumbnails
The thumbnail images in the shopping cart give customers a quick overview of each item.
However, for products with multiple options, the standard product image may not match
the actual item purchased. If the customer purchased a pair of red shoes, ideally, the
thumbnail in the shopping cart should show the product in the same color.

Thumbnails for grouped and configurable products can display either the image from the
“parent” or associated “child” product in the current store view.

Shopping Cart Thumbnail

To configure shopping cart thumbnails:

1. On the Admin menu, select System > Configuration.

2. In the Configuration panel on the left, under Sales, select Checkout.

3. Click to expand the Shopping Cart section, do the following:

Shopping Cart

a. Set Grouped Product Image to one of the following:
l Product Thumbnail Itself

l Parent Product Thumbnail

b. Set Configurable Product Image to one of the following:
l Product Thumbnail Itself

l Parent Product Thumbnail

4. When complete, click the Save Config button.
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CHAPTER 15:

Swatches
Swatches provide an alternate way to display the selection of options for configurable
products. Rather than choosing an option from a drop-down list, customers can make
their selection by clicking a swatch. Configurable swatches can be used on the product
page, product list, and in layered navigation.

Color and Size Swatches on Product Page

In this chapter, you will learn how to use swatches to make the presentation of
configurable products more appealing and informative.

l How Swatches are Used

l Swatch Configuration

l Adding New Attribute Values

l Preparing Swatch Images

l Uploading Swatch Images

l Swatch Images Cache
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Swatch Workflow
On the product page, swatches can be used to indicate the combinations of color and size
that are currently available. Any option that is not available is crossed out. In the following
example. the pistachio loafer is available only is size 8, so the rest of the sizes are crossed
out. You can click each color swatch to see the available sizes, and click each size swatch to
see the available colors. When a swatch is selected, the value appears in the input field,
and the selected swatch is outlined as the current selection.

Unavailable Size Swatches Crossed Out

Swatches can be set up to display the corresponding product image when the swatch is
clicked. For example, from the product list or product page, you can click the swatch to
change the color of the main image.

Text-Based Swatches
If there isn’t an image available for a swatch, the attribute value appears as text. A text-
based swatch is like a button with a text label, and behaves in the same way as a swatch
with an image. In the following example, the color swatches are identified with a text label
for the color name, just as the shoe size swatches have a text label for the size. If the size
attribute values were “Small,” “Medium,” and “Large,” rather than numbers, then that text
would appear in the swatches instead.

Text-Based Color and Size Swatches
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Swatches in Layered Navigation
Swatches can also be used in layered navigation, if the Use in Layered Navigation property
of the corresponding attribute is set to “Yes.” The following example shows both text-based
and color image swatches in layered navigation.

Color Swatches in Layered Navigation and Product List

Swatch Configuration
This discussion begins with the understanding that you already have configurable products
in your catalog. If you do not have working configurable products, you will need to set
them up to continue.

General Settings

Step 1: Complete the Configuration

1. On the Admin menu, select System > Configuration.

2. In the panel on the left, under Catalog, select Configurable Swatches.

3. Click to expand the General Settings section. Then, do the following:
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a. Set Enabled to “Yes.”

b. In the list of Products Attributes to Show as Swatches in Product Detail, select each
attribute whose values you want to appear as a swatch.

The list includes only the attributes that can be used to create configurable products.
The attribute must be the Dropdown type, and Use to Create Configurable Product
must be set to “Yes.”

c. Select the Product Attribute to Use for Swatches in Product Listing.

Because of the limited space in the product listing, only one attribute can chosen to
appear as a swatch in the product list.

4. To set the size of the swatches used on the product detail page, do the following:

a. Click to expand the Swatch Dimensions on Product Detail Page section.

b. Enter theWidth and Height in pixels.

Just for reference, the swatches in the product page examples in this guide are 35
pixels square.

Swatch Dimensions on Product Detail Page

5. To set the size of the swatches used in the product listing, do the following:

a. Click to expand the Swatch Dimensions in Product Listing section.

b. Enter theWidth and Height in pixels.

Swatch Dimensions in Product Listing

6. To set the size of the swatches used in layered navigation, do the following:

a. Click to expand the Swatch Dimensions in Layered Navigation section.

b. Enter theWidth and Height in pixels.
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Swatch Dimensions in Layered Navigation

7. When complete, click the Save Config button.

8. If prompted that the cache needs to be refreshed, click the Cache Management link in the
message at the top of the workspace. Select the checkbox of each invalid cache. Then, with
the Actions control set to “Refresh,” click the Submit button.

While you’re in Cache Management, notice the Flush Swatch Images Cache button in the
Additional Cache Management section at the bottom of the page. If you ever need to
update or replace existing swatches, this is how you can clear all cached swatches.

Step 2: Test the Swatches in Your Store

1. Verify that the swatches work correctly from your storefront. Even without any swatch
images, the text-based swatches should appear in the store, and work correctly.

2. If any drop-down options from the configurable product are missing from layered
navigation, do the following:

l Verify that the attribute frontend property, Use in Layered Navigation is set to “Yes.”

l Return to Cache Management and click the Flush Magento Cache button.
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Adding NewAttribute Values
As you add products to your catalog, you will need to update the attribute values that
correspond to each swatch. For example, if you sell clothing, you will need to add new
colors to the color attribute to match the products. You can add as many values as you
need to any attribute that is represented by a swatch. We use color as an example, but the
process is the same for any attribute you might use.

Add New Color Value

To add new colors:

1. On the Admin menu, select Catalog > Attributes > Manage Attributes.

2. In the list, open the color attribute in edit mode.

3. In the panel on the left, click Manage Label / Options. Then, do the following:

a. In the list under Manage Options, click the Add Option button.

b. Under Admin, enter the names of the color as you want it to appear when working
from the Admin. Then, enter the name of the color for each language supported, as you
want it to appear in the storefront.

c. To determine the order in which the colors appear, enter a number in the position
column.

d. Repeat this process for as many colors as you need.

4. Click the Save Attribute button.

5. When prompted to refresh the cache, click the Cache Management link. Then, refresh any
cache that is invalid.
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Preparing Swatch Images
A swatch image can provide an accurate representation of color, and also illustrate a
pattern or texture. There are two different methods you can use to create swatches for your
products. You can use either method, or a combination of both.

l The default method is to create global swatches that represent a plain color, and upload
them to Media Storage.

l You can also create custom swatches that illustrate a fabric or texture, and upload them
to a specific product.

The size of the swatch that is set in the configuration, and the size of the uploaded image
determine the level of detail that can be seen in the swatch. To show a pattern clearly,
make sure that the image is large enough to capture the essence of the design. To show a
fabric weave, texture, or grain of leather, capture the image at as high a resolution as
possible, and crop the image as close to the display size of the swatch as possible. Any
reduction in size makes the detail harder to see.

Capture Swatch from Product Image

To capture a swatch, you can open the main product image in a photo editor, and crop a
section from the image. You can also use the eyedropper tool to pick up the exact color you
need, and fill the swatch with the selected color. If you have the product available, you can
take a photograph of the fabric with your camera. The swatches below were captured from
the side of a shoe in the main product image.

Swatch Samples
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Uploading Swatch Images
The swatches folder in Media Storage is the most common place where uploaded swatch
images are stored. Swatch images that are uploaded to Media Storage are globally available
and can be used by any product. The name of each uploaded image file must exactly match
the attribute value that it represents. In this example, each file name is a color.

Swatches in Media Storage

Swatches can also be associated with a specific product, and uploaded directly to the
product’s thumbnail gallery. Swatches that are uploaded directly to a product do not
appear in the gallery or in layered navigation. However, in some cases, there are
advantages to using this method. It is also the recommended method for languages with a
non-Latin character set, such as Arabic, Chinese, Cyrillic, or Japanese.

The system uses a “fall back” method to locate swatches. It looks first to see if there are any
swatches associated with the product image. If it doesn’t find a swatch, it then looks in
Media Storage.

Method 1: Upload Swatches to Media Storage

Before uploading swatch images, make sure that the file names exactly match the
corresponding attribute values. For example, if you upload a file named “gray.png,” it will
match the attribute value “Gray,” but not “Grey.” File names are converted to lowercase. In
addition, any characters other than a-z and 0-9 are replaced with a hyphen. Therefore, the
swatch name “Royal Blue” becomes “royal-blue.” If you have access to the server, swatch
files can be uploaded to the following location:

[Magento install directory]/media/wysiwyg/swatches
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1. On the Admin menu, select CMS > Pages > Manage Content.

2. In the list, click to open any page in edit mode.

The purpose of this step is to launch the editor. Media Storage can be accessed from any
place the editor is used.

3. In the panel on the left, select Content.

4. From the editor, click the Insert Image button. In the directory tree on the left, click the
swatches folder, and do the following:

a. Click the Browse button, and locate the swatch image that you want to upload.

You can upload individual images, or multiple images at the same time.

b. Click the Upload Files button to copy the file to Media Storage.

Newly uploaded images appear at the bottom of the list.

Uploading Multiple Swatches

5. When you are done, click the Close button in the upper-left corner of the Media Storage
window. Then, click the Back button to exit the editor.

6. If prompted to refresh the cache, click the Cache Management link in the message at the
top of the workspace, and refresh any cache that is invalid.

7. Go to your storefront to verify that the swatches work correctly. The text-based swatches
should now be replaced with the swatch images that you uploaded.

8. If any options from the configurable product are missing from layered navigation, return to
Cache Management and click the Flush Magento Cache button.
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Method 2: Upload Swatches as Product Images

This method can be used for swatch images that are associated with a specific product.
Swatches uploaded with this method take precedence over those in Media Storage.

1. On the Admin menu, select Catalog > Manage Products.

2. Find the product the configurable product in the list, and open the record in edit mode.

3. If the image is for a specific store view, set Choose Store View to the store view where the
images will be used.

4. In the panel on the left, click Images. Then, do the following:

a. Click the Browse Files button, and select the product images files you want to upload
to your store. Then, click the Upload Files button to upload the selected images to
your store.

Product Swatch with Label

b. Enter a Label for each swatch image uploaded, in the following format: color name,
followed by a hyphen, and the word “swatch.” This label identifies the image as a
swatch that is associated with this specific variation of the product.

color-swatch

Do not select any of the remaining options. It is not necessary to select the Exclude
checkbox, because by default, Swatch images do not appear in the thumbnail gallery.

5. When complete, click the Save button.
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6. When prompted to clear the cache, click the Cache Management link in the message at the
top of the workspace, and refresh any cache that is invalid.

Setting Up Dynamic Images
Dynamic images change when the corresponding swatch is clicked, and can be used on the
product and product listing pages. The easiest way to understand this is to see how the
products are set up.

Swatches

With this technique, each associated product must have an image that depicts the
variation, even if the products are different sizes of the same color. These are the images
that appear dynamically when the swatch is clicked. As with all swatch images, the
dynamic image does not appear in the thumbnail gallery.

Method 1: Upload Images to Configurable Product

When you view this product in the store and click a swatch, the corresponding product
appears as the main product image. You can click any swatch to change the image. Also,
notice in the example below that the fourth swatch is a miniature version of the Royal Blue
product image. Because there isn’t a Royal Blue swatch available, the fall-back method
used the product image with the “Royal Blue” label.

Dynamic Product Image
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1. Each associated simple product has a single product image that depicts the variation.
Because these images are not swatches, they do not need the “-swatch” suffix. The product
variations used in this example are labeled “Royal Blue,” “Pink,” and “Red.”

Image Uploaded to Associated Simple Product

2. The Color attribute for each variation is set to the correct color.

Set Value of Color Attribute

3. In addition to the standard product images, images for each product variation are also
uploaded to the configurable product, and given labels that exactly match the
corresponding color attribute values. No options are selected for the product variations.
Although these images are not swatches, they will be used if no other swatch is available.
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Images Uploaded to Configurable Product

Method 2: Upload Swatches to Configurable Product

This method features custom swatches that are uploaded to the configurable product. Each
associated product has a product image that depicts the variation. When you click each
swatch, the corresponding product image appears.
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Dynamic Image

1. An image is uploaded to each associated product that shows the product variation.

Image Uploaded to Associated Simple Product

2. The Color attribute of the product variation is set to the correct color.

Set Value of Color Attribute
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3. In addition to the standard product images, a complete set of the swatch images is
uploaded to the configurable product, and labeled as a swatch for each variation. In this
example, the swatches are named:

l Royal Blue-swatch

l Charcoal-swatch

l Red-swatch

l Khaki-swatch

Images Uploaded to Configurable Product
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Swatch Localization
If you use a language other than English for attribute values, it is recommended that you
upload swatch images to each configurable product record, rather than upload the images
to Media Storage. Swatch image file names that are uploaded to Media Storage are also
used as CSS classes, and can only include the characters a-z, A-Z, and 0-9. Characters from
non-Latin alphabets, such as Arabic, Chinese, Cyrillic, and Japanese are not recognized by
the system.

English as Primary Language
By default, the same swatch image can be used for all languages. The easiest way to
localize a swatch is to simply translate the attribute label that appears in the store.
However, if the translated labels include accented characters, see the next section.

The system uses a simple fallback strategy to locate a suitable swatch. The system looks
first for a swatch image that is based on the current language. If no image is found, the
system looks next for an attribute label that is associated with the configurable product
option.

Using Manage Attribute / Labels, you can enter a translated label for each language
supported. For example, the label for the color value “Red” would be entered as “Rot” for
German. The following table shows the relationship between the attribute label, the product
image label, and the image file name:

ATTRIBUTE LABEL IMAGE LABEL IMAGE FILE NAME

Red Red-swatch media/wysiwyg/swatches/red.png

Rot Rot-swatch media/wysiwyg/swatches/rot.png

Other Primary Languages
If possible, we recommend that you upload swatch images from the Magento Admin, which
allows you to use any character in the image file name. However, if either of the following is
true, you must upload swatches directly to the server:

l If you use a language other than English and the translated labels have Latin characters
with diacritics (that is, accented characters)

l Your localized images have names that do not transliterate from UTF-8 to ASCII using
PHP.

Swatch images are located on the server in the following directory:
media/wysiwyg/swatches/. If you choose to upload images directly to the server, you
must understand how attribute labels are converted to image names.
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1. The label is transliterated from UTF-8 to ASCII.

a. If the label contains Latin characters with diacritics, many of the characters are
transliterated to ASCII. For example, Ô is converted to ^O.

b. If the label cannot be transliterated into ASCII, no swatch images can be uploaded
from media/wysiwyg/swatches/. Languages with characters that cannot be
transliterated include Cyrillic, Chinese, Japanese, and Arabic.

c. If the language contains characters that cannot be transliterated to ASCII, do one of
the following:

l Upload all swatch images to each configurable product

l In the Admin, change the attribute values to English as the primary language, and
set up the swatch files in English.

2. The label is converted to lowercase.

3. Any characters other than 0-9 and a-z are replaced with the dash character (-).

LABEL CONVERTS TO

Königsblau media/wysiwyg/swatches/k-onigsblau.png

Weiß media/wysiwyg/swatches/weiss.png

красный (No transliteration is possible, and no image is uploaded.)

Label Conversion Examples

CHARACTER TRANSLITERATION REPLACEMENT

French

À `A -a

Â ^A -a

Æ AE ae

Ä "A -a

Ç C c

É 'E -e

È `E -e

Ê ^E -e

Common Transliteration Values
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CHARACTER TRANSLITERATION REPLACEMENT

Ë "E -e

Î ^I -i

Ï "I -i

Ô ^O -o

Œ OE oe

Ö "O -o

Ù `U -u

Û ^U -u

Ü "U -u

Ÿ "Y -y

German

Ä "A -a

Ö "O -o

Ü "U -u

ß ss ss

Spanish

Ñ ~N -n

Á 'A -a

É 'E -e

Í 'I -i

Ó 'O -o

Ú 'U -u

Common Transliteration Values (cont.)
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Clearing the Cache
Swatch images are resized and cached before they are used. Swatch images are stored on
the server in the Magento installation directory, at the following location:

[Magento install directory]/media/catalog/swatches/

Whenever changes are made to existing swatch images, the swatch cache must be flushed
before the changes can be seen in the store.

To flush the swatch cache:

1. On the Admin menu, select System > Cache Management.

2. In the Additional Cache Management Section, click the Flush Swatch Images Cache
button.

Flush Swatch Images Cache
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Notes
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CHAPTER 16:

Product Pricing
Magento Enterprise Edition supports a number of pricing options that you can use for
promotions, and to meet minimum advertised price requirements.

Topics in this chapter include:

l Prices

l Special Price

l Tier Price

l Package Price

l Minimum Advertised Price

l Product Group Price
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Prices
The Prices tab is used to establish the pricing structure that is associated with a product.
Options include special and tier pricing, and manufacturer’s suggested retail price. The
price that the customer ultimately pays can be influenced by a number of factors,
including:

Regular Price The regular price is determined by teh value assigned to the price
attribute, which corresponds to the Price field on the Prices tab.

Promotional Price A promotional price is determined by a catalog price rule, or by any
of the following attributes:

special_price

group_price

tier_price

Prices

FIELD SCOPE DESCRIPTION

Price Global The retail price of the product.

Group Price Global Sets up promotional prices for specific customer
groups within the selected website.

Special Price Website To offer a Special Price, enter a discounted price
and complete the date range fields to establish
when the promotion goes into effect.
When available, the retail price is crossed out and
the special price appears below in a large, bold
font.

Field Descriptions
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FIELD SCOPE DESCRIPTION

Special Price From Date Website Sets the beginning date for the range of time the
Special Price is offered.

Special Price To Date Website Sets the ending date for the range of time the
Special Price is offered.

Tier Price Website Tier pricing is used to offer a quantity discount.
The discount can be applied to specific customer
groups within the selected website.

Apply MAP Website When applied, hides the actual product price from
the customer. Options include: Yes / No / Use
Config

Display Actual Price Website Determines when the customer can see the
actual product price. Options include:

In Cart Displays the actual
product price in the
shopping cart.

Before Order
Confirmation

Displays the actual
product price only at the
end of the checkout
process, just before the
order is confirmed.

OnGesture Displays the actual
product price

Use Config Displays the actual price
according to the
configuration setting.

Manufacturer’s Suggested
Retail Price

Global The retail price as suggested by themanufacturer
(MSRP).

Tax Class Website (Required) Determines the tax class associated
with the product. Options include:

Field Descriptions (cont.)

225Magento Enterprise Edition User Guide, Version 1.14.2.1



Prices CHAPTER 16:  Product Pricing

226 Magento Enterprise Edition User Guide, Version 1.14.2.1

FIELD SCOPE DESCRIPTION

None The item is not subject to
tax.

Default The item is subject to the
tax rules associated with
the “default” tax class.

Taxable Goods The item is subject to the
tax rules associated with
the “Taxable Goods” tax
class.

Themanner in which product taxes are calculated
is determined by the configuration of your store.

Field Descriptions (cont.)
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Special Price
To offer a Special Price, enter a discounted price and complete the date range fields to
establish when the promotion goes into effect. On both the catalog list and product pages,
the regular price is crossed out, and the Special Price appears in bold red.

Special Pricing

To display a special price:

1. In the Product Information panel on the left, select Prices.

2. Enter the amount of the Special Price.

3. Complete the Special Price From Date and Special Price To Date to define the period of
time that the special price is in effect. You can pick the dates from the Calendar to the
right of each field.

4. Click the Save button to save your changes.

5. When prompted to update the cache and indexes, follow the instructions at the top of the
page.
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Tier Price
Tier pricing lets you offer a quantity discount from oth the catalog list and product detail
pages. The discount can be applied to a specific store view or customer group.

Tier Price “As Low as”

l On the catalog page, the product price includes the words, “As Low As: $110.49”

l On the product page, the calculated quantity discount has the message:

Buy 2 for $__._ each and save _%
Buy 4 for $__._. each and save _%

The prices in the storefront take precedence from the highest to the lowest quantity.
Therefore, if you have a tier for the quantity 5 and one for the quantity 10 and a customer
adds 5, 6, 7, 8 or 9 items to the shopping cart, then the customer gets the discounted price
that you specified for the quantity 5 tier. As soon as the customer adds the 10th item, the
discounted price specified for the quantity 10 tier supersedes the quantity 5 tier and that
discounted price (of 10) applies instead.

To display a tier price:

1. In the Product Information panel on the left, select Prices.

2. In the Tier Price section, click the Add Tier button. Then, do the following:
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Tier Price

a. Select theWebsite to which the tier pricing applies.

b. Select the Customer Group for whom the tier pricing is available.

To apply a tier to multiple groups, but not all groups, create multiple tiers, each with
the same Qty and Price information and select a different customer group for each.

c. In the Qty field, enter the quantity that must be ordered to receive the discount.

d. In the Price field, enter the adjusted price of the item.

3. When complete, click the Save button.

4. When you are prompted to update the cache and indexes, follow the instructions in the
message at the top of the workspace.
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Quantity Increments Packaging
Unlike a unit price, a package price refers to multiple items of the same product that are
packaged together and sold as a single unit. A six-pack of soft drinks is an example of
package pricing.

To sell multiple products as a package:

1. On the Admin menu, select Catalog > Manage Products.

2. In the list, click to select the product you want to sell as a package.

3. In the panel on the left, select Inventory. Then, do the following:

a. Set Qty for Item’s Status to Become Out of Stock to the lowest inventory threshold for
this item. (If necessary, clear the Use Config Settings checkbox.)

The number should be a multiple of the number of items in the package. For example,
for a six-pack, the threshold might be 6, 12, 18, and so on.

b. Set Enable Qty Increments to “Yes.”

c. Set Qty Increments to the number of units included in the package. For example, 6.

4. When complete, click the Save Config button.
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Minimum Advertised Price
Merchants are sometimes prohibited from displaying a price that is lower than the
manufacturer’s suggested retail price (MSRP). Magento’s Minimum Advertised Price (MAP)
gives you the ability to remain in compliance with the manufacturer’s requirements while
offering your customers a better price. Because requirements differ from one manufacturer
to another, you can configure your store to prevent the display of your actual price on
pages where it is not allowed to appear according to the terms of the manufacturer.

“Click for Price” Gesture with Popup

MAPLogic
For products that allow configuration from the storefront, with prices that depend on a
selected option, (such as custom options, or simple products with their own SKUs and
stock management), the following logic is implemented:

l MAP applies to the main price; prices of the options, bundle items, and associated
products (which add or subtract from the main price) are displayed normally.

l If a product does not have a main price, and its price is derived from the prices of
associated products (such as with a grouped product), the MAP settings of the
associated products are used.

The MAP application logic for other price settings is as follows:

l If tier pricing is set, the tier price appears according to the Display Actual Price setting.

l If a special price is set, it is considered to be the actual price for MAP.

In the order management and customer management tools, as well as in the reports
sections of the Admin, only the actual price appears.
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If a product added to the shopping cart has MSRP specified, the price will not be crossed-out in
the mini shopping cart or in the shopping cart.

PRODUCT TYPE DESCRIPTION

Simple, Virtual The actual price does not automatically appear on catalog list
and product pages, but is included only according to the Display
Actual Price setting. Custom option prices appear normally.

Grouped The prices of associated simple products do not automatically
appear on catalog list and product pages, but are included only
according to the Display Actual Price setting.

Configurable The actual price does not automatically appear on catalog list
and product pages, but is included only according to the Display
Actual Price setting. Option prices appear normally.

Bundle with fixed price The actual price does not automatically appear on catalog pages,
but is included only according to the Display Actual Price setting.
The prices of bundle items appear normally.

MAP is not available for bundled products with dynamic pricing.

Downloadable The actual price does not automatically appear on catalog list
and product pages, but is included only according to the Display
Actual Price setting. The price associated with each download
link appears normally.

Using MAP with Product Types

PRICE SETTING DESCRIPTION

Tier Price If tier pricing is set, the tier pricingmessage is not displayed in
the catalog. On the product page a notification is displayed that
indicates that the price can be lower when orderingmore than a
certain quantity, but the discount is displayed in percentages
only. For associated products of a grouped product, the
discounts are not displayed on the product page.
The tier price is shown according to the Display Actual Price
setting.

Special Price If the Special price is specified, the special price is displayed
according to the Display Actual Price setting.

Using MAP with Price Settings
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MAPConfiguration
MAP can be configured at both the global and product levels. There are a variety of
configuration options that you can use to remain in compliance with the terms of your
agreement with the manufacturer, while still offering your customers a better price. Your
store’s MAP settings can be applied to all products in your catalog or configured for only
specific products.

Map Settings on Prices Tab

On the global level, you can enable/disable the functionality, apply it to all products, define
how the actual price is displayed, and edit the text of the MAP related messages and
information tips that appear in the store. When MAP is enabled globally, product-level
MAP settings become available. For a product you can choose to apply MAP, specify the
MSRP, and define how the actual price is displayed. Product-level MAP settings override
the global MAP settings.
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Minimum Advertised Price

To configure MAP globally:

1. On the Admin menu, select System > Configuration.

2. In the upper-right corner, set Current Configuration Scope to the website where the
configuration applies.

3. In the panel on the left, under Sales, select Sales. Then, click to expand the Minimum
Advertised Price section, and do the following:

4. To activate MAP, set Enable MAP to “Yes.”

a. Set Apply MAP (Default Value) to one of the following:

l To apply MAP to certain products, select “No.”

l To apply MAP by default to all products and hide all prices throughout the site,
select “Yes.”

b. To determine when and where you want your actual price to be visible to the
customer, set Display Actual Price to one of the following:

l In Cart

l Before Order Confirmation

l On Gesture (on click)

5. When complete, click the Save Config button.

http://merch.docs.magento.com/ee/user_guide/Magento_Enterprise_Edition_User_Guide.html#configuration/sales/sales.html%23Minimum_Advertised_Price
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To configure MAP for a specific product:

1. On the Admin menu, select System > Configuration.

2. In the Configuration panel on the left, under Sales, click to expand the Minimum
Advertised Price section. Then, do the following:

a. Set Enable MAP to “Yes.”

b. Set Apply MAP (Default Value) to “No.”

c. Complete the remaining settings as needed. Then, click the Save Config button.

3. Select Catalog > Manage Products, and open the product record.

4. In the Product Information panel on the left, selectPrices. Then, do the following:

a. Enter your Price that is lower than the manufacturer’s minimum advertised price.

b. Set Apply MAP to “Yes.”

c. Set Display Actual Price according to your preference.

d. Enter the Manufacturer’s Suggested Retail Price.

5. When complete, click the Save button.

Product Group Price
Product Group Price enables you to set promotional prices for different customer groups at
the product level. Group price can be used with the following product types:

l Simple

l Configurable

l Virtual

l Bundle

l Downloadable

For bundle products, the group price is specified as a discount percentage. If bundle items
have their own group prices set for the same customer group, then the discount specified
for the whole bundle product applies to the group prices.

For the Grouped and Gift Card product types, the Group Price is not applied, even if these
product types are selected in the Apply To field of the group_price attribute. In this case,
for Grouped products, the Group Price field does not appear on the Prices page in Product
Information. For Gift Card products, the Group Price field appears, but is not used.
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Product Group Price Setup
The display of group prices in the store follows the general logic used for Magento pricing.
If, in addition to the regular price, a product has promotional price(s), the lowest price
appears in the storefront. If a product custom option has price set as a percentage, then the
lowest promotional price is used as base for the calculation. The same logic applies when
the associated products (the options) of a configurable product have prices set as a
percentage.

Examples: Promotional Prices in Storefront

The following table illustrates how the minimum promotional price logic is implemented.
The table provides several examples, but does not include all possible combinations of
promotional price settings.

ADMIN PRICE PRICE IN STOREFRONT

Price = $4
Special Price = $5
Tier Price = $3

For customers from the tier price group(s): $ 4
As low as: $3
For customers from other groups: $4

Price = $5
Special Price = $3
Tier Price = $4

For all customers:
Regular Price: $5
Special Price: $3

Price = $5
Special Price = $3
Tier Price = $4
Price after a catalog price
rule applied = $2

For customers from the catalog price rule group:
Regular Price: $5
Special Price: $2
For customers from other groups:
Regular Price: $5
Special Price: $3

Price = $5
Special Price = $4
Group Price = $3

For customers from the price group:
Regular Price: $5
Special Price: $3
For customers from other groups:
Regular Price: $5
Special Price: $4

Important!When a group price is set for a product, then the catalog price rules for the
corresponding customer groups are applied to the group price, not to the regular price.



CHAPTER 16:  Product Pricing Product Group Price

To set up a group price for a product:

1. On the Admin menu, select Catalog > Manage Products. Then in the list, click to open the
product in edit mode.

2. In the panel on the left, click Prices. Then, do the following:

a. In the Group Price field, click the Add Group Price button.

b. Select the target Customer Group and enter the product Price for the group. The
Website column defines the scope of the Group Price field.

3. When complete, click the Save button.

Group Price Attribute
The group_price attribute gives you the ability to offer a different price to members of a
customer group for any product type that is specified in the attribute’s Apply To property.

Attribute Properties

To set up a group price:

1. On the Admin menu, select Catalog > Manage Products. Then, open the product in edit
mode.

2. In the panel on the left, select Prices. Then, do the following:
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Group Price

a. Under Group Price, click the Add Group Price button.

b. Select theWebsite to determine the scope of the setting.

c. Choose the Customer Group that is eligible for the group price.

d. Enter the Price of the product for members of the selected group.

3. When complete, click the Save button.
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CHAPTER 17:

Inventory
Managing stock creates opportunities for customer engagement by displaying stock
availability messages in your store, and giving your customers the opportunity to
receive product alerts. Even if your store doesn’t have a large inventory of products,
your customers can benefit from the way you manage your inventory.

Inventory settings can be made for the catalog as a whole, and fine tuned for each
individual product. In addition to controlling stock levels, the inventory settings
determine how backorders and returned items are managed.

If your needs are simple, you might choose not to manage inventory at all. However,
inventory management is more than just keeping track of how many products you have
on hand.

Topics in this chapter:

l Inventory Configuration

l Managing Stock

l Stock Availability Messages

l Out of Stock Threshold

l Product Alerts
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Inventory Configuration
The Product Stock Options configuration determines the default inventory settings for
products in your catalog. This configuration applies to individual line items in the cart,
rather than to the cart as a whole. Most of the settings can be overridden at the product
level.

Product Stock Options

To configure the default inventory settings:

1. On the Admin menu, select System > Configuration.

2. In the panel on the left under Catalog, select Inventory. Click to expand the Product Stock
Options section, and do the following:

a. Set Manage Stock to one of the following:

Yes Activates full inventory control to keep track of the number of items
currently in stock.

No Does not keep track of the number of items currently in stock.

b. Set Backorders to one of the following:

No Backorders Does not accept backorders when product is out of stock.

Allow Qty Below 0 Accepts backorders when the quantity falls below zero.

Allow Qty Below 0 and
Notify Customer

Accepts backorders when the quantity falls below zero,
but notifies customers that orders can still be placed.

c. In the Maximum Qty Allowed in Shopping Cart field, enter the default maximum
quantity of any product that a customer can place into the shopping cart.

http://merch.docs.magento.com/ee/user_guide/Magento_Enterprise_Edition_User_Guide.html#configuration/catalog/inventory.html%23Product_Stock_Options
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d. In the Qty for Item’s Status to Become Out of Stock field, enter the stock level that
indicates a product to be out of stock.

3. At the Minimum Qty Allowed in Shopping Cart field, click the Add Minimum Qty button.
Then, do the following:

a. Select the Customer Group.

b. Enter the default Minimum Quantity for members of the group.

Repeat these steps as needed.

4. In the Notify for Quantity Below field, enter the stock level that triggers a notification to be
sent that a product has fallen below the threshold.

5. If you want to sell product packaged as multiples—such as a six-pack—set Enable Qty
Increments to “Yes.” Then, enter the number of Qty Increments to be sold together as a
package.

6. If you want to return any item that appears on a credit memo back to inventory, set
Automatically Return Credit Memo Item to Stock to “Yes.”

7. When complete, click the Save Config button.

Managing Stock
Each product in your catalog has both a short and long version of the Inventory options,
depending on whether you need to manage inventory for the product. To take full
advantage of Magento’s advanced inventory management capabilities, Manage Stock must
be enabled.

To set up a simple catalog without stock management, complete the Inventory short form.
For full inventory management, complete the long form. The initial values reflect the
default Product Stock Options set in the configuration.

Inventory (Short Form)
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To set up a product without stock management:

1. On the Admin menu, select Catalog > Manage Products. Then, open the product in edit
mode.

2. In the panel on the left, under Catalog, select Inventory. Click to expand the Product
Stock Options section.

3. To change the default setting of any field, first clear the Use Config Settings checkbox.
Then, do the following:

a. Set Manage Stock to “No.”

b. In the Minimum Qty Allowed in Shopping Cart field, enter the minimum quantity of
the product that a customer can place into the shopping cart.

c. In the Maximum Qty Allowed in Shopping Cart field, enter the maximum quantity of
the product that a customer can place into the shopping cart.

d. If you want to sell this product packaged in multiples, such as a six-pack, set Enable
Qty Increments to “Yes.”

4. When complete, click the Save Config button.

To set up a product with full inventory control:

1. On the Admin menu, select Catalog > Manage Products. Then, open the product in edit
mode.

2. In the panel on the left, under Catalog, select Inventory. Click to expand the Product
Stock Options section.

3. If necessary, clear the checkbox below the Manage Stock field. Then, set Manage Stock to
“Yes.”
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Inventory (Long Form)

4. To change the default setting of any field, first clear the Use Config Settings checkbox.
Then, do the following:

a. In the Qty field, type the number of units you currently have in stock.

b. In the Qty For Item’s Status to become Out of Stock field, enter the stock level that
indicates the item is considered to be out of stock.

c. In the Minimum Qty Allowed in Shopping Cart field, enter the default maximum
quantity of any product that a customer can place into the shopping cart.

d. In the Maximum Qty Allowed in Shopping Cart field, enter the default maximum
quantity of any product that a customer can place into the shopping cart.

e. If the quantify of the product is indicated with decimal precision, set Qty Uses
Decimals to “Yes.”

l If the product can be shipped in separate boxes, set Can be divided into Multiple
Boxes for Shipping to “Yes.”

f. Set Backorders to one of the following:

No Backorders Does not accept backorders when product is out of
stock.

Allow Qty Below 0 Accepts backorders when the quantity falls below zero.

Allow Qty Below 0 and
Notify Customer

Accepts backorders when the quantity falls below zero,
but notifies customers that orders can still be placed.

g. In the Notify for Quantity Below field, enter the stock level that triggers a notification
to be sent that a product has fallen below the threshold.
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h. If you want to sell product packaged as multiples—such as a six-pack—set Enable Qty
Increments to “Yes.” Then in the Qty Increments field, enter the number of products
that are packaged together.

i. Set Stock Availability to one of the following:

In Stock Makes the product available for purchase.

Out of Stock Unless Backorders are activated, prevents the product from
being available for purchase and removes the listing from the
catalog.

5. When complete, click the Save button.

FIELD SCOPE DESCRIPTION

Manage Stock Global Determines if you use full inventory control to
manage the items in your catalog. Options
include:

Yes Activates full inventory control to
keep track of the number of items
currently in stock. (To change the
setting, clear the Use Config
Settings checkbox and select
“Yes.”)

No Does not keep track of the number
of items currently in stock. (This is
the default setting.)

Qty Global (Required) The quantity of the item in stock.

Qty For Item’s Status to
becomeOut of Stock

Global Specifies the stock level at which the product is
considered to be out of stock.

MinimumQty Allowed in
Shopping Cart

Global Determines theminimum amount of this item that
is available for purchase. By default, theminimum
quantity is set to 1.

MaximumQty Allowed in
Shopping Cart

Global Determines themaximum number of this item that
can be purchased in a single order. By default, the
maximum quantity is set to 1000.

Field Descriptions
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FIELD SCOPE DESCRIPTION

Qty Uses Decimals Global Determines if customers can use a decimal value
rather than a whole number when entering the
quantity ordered. Options include:

Yes Permits values to be entered as
decimals, rather than whole
numbers, which is suitable for
products sold by weight, volume or
length.

No Quantity values must be entered
as whole numbers.

Can be divided into
Multiple Boxes for
Shipping

Global Determines if parts of the product can shipped
separately.
Options include: Yes / No

Backorders Global Determines how your storemanages backorders.
A backorder does not change the processing
status of the order. Funds are still authorized or
captured immediately when the order is placed,
regardless of whether the product is in stock.
When the product becomes available, it will be
shipped. Options include:

No Backorders Does not accept
backorders when product
is out of stock

Allow Qty Below 0 Accepts backorders
when the quantity falls
below zero.

Allow Qty Below 0
and Notify
Customer

Accepts backorders
when the quantity falls
below zero, but notifies
customers that orders
can still be placed.

Notify for Quantity Below Global Sends a notification to you when the quantity in
stock falls below this number.

Enable Qty Increments Global Allows the product to be sold in quantity
increments.

Field Descriptions (cont.)
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FIELD SCOPE DESCRIPTION

Qty Increments Global Specifies the number of products that are
packaged together.

Stock Availability Global Determines the current availability of the product.
Options include:

In Stock Makes the product
available for purchase.

Out of Stock Unless Backorders are
activated, prevents the
product from being
available for purchase
and removes the listing
from the catalog.

Field Descriptions (cont.)
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Stock Availability
You can define an inventory level that becomes the threshold to determine when an item
needs to be reordered. The out of stock threshold can be set to any number greater than
zero.

“In Stock” Message on Product Page

Another way you can use the stock availability threshold is to manage products that are in
high demand. If you want to capture new customers, rather than sell to high-quantity
buyers, you can set a maximum quantity to prevent a single buyer from taking out your
entire inventory.

Your catalog can be configured to display the availability of each item as “In Stock” or “Out
of Stock” on the product page. The configuration setting applies to the catalog as a whole,
and the message changes according to the stock status of the product. There are several
display variations possible, including how “out of stock” products are managed in the
catalog and search results lists.
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Process Overview:
Step 1: Configure Inventory Stock Options
Step 2: Set Product to Manage Stock
Step 3: Set “Out of Stock” Threshold

Step 1: Configure Inventory Stock Options

1. On the Admin menu, select System > Configuration.

2. In the Configuration panel on the left, under Catalog, select Inventory.

3. Click to expand the Stock Options section. Then, do the following:

Stock Options

a. To configure how “out of stock” products are handled in the category and search
results lists, set Display Out of Stock Products to one of the following:

Yes Includes “out of stock” products on catalog pages.

No Omits “out of stock” products from catalog pages.

b. To configure the stock availability message on the product page, set Display products
availability in stock in the frontend to one of the following:

Yes Displays an availability message indicating the product stock status.

No Does not display an availability message.

4. Click the Save Config button to save the setting.

http://merch.docs.magento.com/ee/user_guide/Magento_Enterprise_Edition_User_Guide.html#configuration/catalog/inventory.html%23Stock_Options
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Step 2: Set Product to Manage Stock

1. On the Admin menu, select Catalog > Manage Products.

2. In the list, click to open the product. Then in the Product Information panel on the left,
select Inventory.

3. If necessary, clear the Use Config Settings checkbox, and set Manage Stock to “Yes.”
Then, complete the inventory settings as needed.

4. Make sure that Stock Availability is set to “In Stock.”

5. Click the Save button to save the product settings.

Step 3: Set "Out of Stock" Threshold

1. On the Inventory tab, set the Qty for Item’s Status to Become Out of Stock to a value
above zero.

2. To set the quantity of the product that is allowed in the cart, set the following fields to the
appropriate values for your product, store, and strategy:

l Minimum Quantity Allowed in Shopping Cart

l Maximum Quantity Allowed in Shopping Cart

3. To be notified when stock drops below the threshold, clear the Use Config Settings
checkbox. Then, set Notify for Quantity Below to a number to establish the threshold. The
default the value is 1.

If you need time to restock your inventory, you can use this value to indicate when it is
time to replenish.
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Message Scenarios
You can use a combination of configuration settings to control stock availability messages
on product pages and in listings of products on catalog pages.

“In Stock” Message

Product Page
There are several variations of messaging available for the product page, depending on the
combination of Manage Stock and Stock Availability settings.

“Out of Stock” Message
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Example 1: Show Availability Message

Scenario 1: This combination of settings causes the availability message to appear on the
product page, according to the stock availability of each product.

STOCK OPTIONS MESSAGE

Display product availability in stock in the frontend: Yes

Product Inventory

Manage Stock Yes

Stock Availability In Stock
Out of Stock

“Availability: In
Stock”
“Availability: Out
of Stock”

Scenario 2:When stock is not managed for a product, this combination of settings can be
used to display the availability message on the product page.

STOCK OPTIONS MESSAGE

Display product availability in stock in the frontend: Yes

Product Inventory

Manage Stock No “Availability: In
Stock”
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Example 2: Hide Availability Message

Scenario 1: This combination of configuration and product settings prevents the
availability message from appearing on the product page.

STOCK OPTIONS MESSAGE

Display product availability in stock in the frontend: No

Product Inventory

Manage Stock Yes

Stock Availability In Stock
Out of Stock

None
None

Scenario 2:When stock is not managed for a product, this combination of configuration
and product settings prevents the availability message from appearing on the product
page.

STOCK OPTIONS MESSAGE

Display product availability in stock in the frontend: No

Product Inventory

Manage Stock No None
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Catalog Page
The following display options are possible for the category and search results lists,
depending on the product availability and configuration settings.

“Out of Stock” Message on Category Page

Example 1: Show Product with “Out of Stock Message”

This combination of configuration settings includes out of stock products in the category
and search results lists, and displays an “out of stock” message.

STOCK OPTIONS MESSAGE

Display Out of Stock Products
Display product availability in stock in the frontend

Yes
Yes “Out of stock”

Display Out of Stock Products Yes

Display product availability in stock in the frontend No None

253Magento Enterprise Edition User Guide, Version 1.14.2.1



Stock Availability CHAPTER 17:  Inventory

254 Magento Enterprise Edition User Guide, Version 1.14.2.1

Example 2: Show Product without “Out of Stock Message”

This combination of configuration settings includes out of stock products in the category
and search results lists, but does not display a message.

STOCK OPTIONS MESSAGE

Display Out of Stock Products
Display product availability in stock in the frontend

Yes
No

None

Example 3: Hide Product Until Back in Stock

This configuration setting omits out of stock products entirely from the category and
search results lists, until they are back in stock.

STOCK OPTIONS MESSAGE

Display Out of Stock Products No None

Out of Stock Threshold
You can define an inventory level that becomes the threshold to determine when an item
needs to be reordered. The out of stock threshold is set to a number above zero.

To set the out of stock threshold:

1. In the Product Information panel, select Inventory.

2. Set the Qty for Item’s Status to Become Out of Stock to a value above zero.

To change the quantity allowed in cart:

This option is helpful for products in high demand. If you want to capture a larger number
of new customers rather than selling high volumes to high-quantity buyers, you can set a
maximum quantity to prevent a high-quantity buyer from taking out your entire inventory.

1. In the Product Information panel, select Inventory.

2. Change the Minimum and Maximum Quantity Allowed in Shopping Cart fields to
appropriate values for your product, store, and strategy.

To be notified when stock drops below threshold:

1. In the Product Information panel, select Inventory.

2. Clear the Use Config Settings checkbox, and set Notify for Quantity Below to indicate the
level when you want to be notified. By default, the value is set to 1.
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Product Alerts
You can enable your customers to subscribe to two types of customer alerts by email: price
change alerts and in-stock alerts. For each alert type, choose whether to enable users to
subscribe to it, and select the email template to use. Also, select a sender display name,
which applies to both alert types.

Sign Up for Price Alert

The price change alert creates a Sign up for price alert link on every product page.
Customers can click the link to subscribe to alerts related to the product. Whenever the
price changes, or the product goes on special, the customer receives an email alert.

The in-stock alert creates a link called “Sign up to get notified when this product is back in
stock” for every product that is out of stock. Customers can click the link to subscribe to the
alert. When the product is back in stock, customers receive email notification that the
product is available. Products with alerts have a Product Alerts tab in the Product
Information panel that lists the customers who have subscribed to an alert.

To set up product alerts:

1. On the Admin menu, select System > Configuration.

2. In the panel on the left, under Catalog, select Catalog.

3. Click to expand the Product Alerts section, and do the following:
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a. To offer price change alerts to your customers, set Allow Alert When Product Price
Changes to “Yes.”

Product Alerts

b. Set Price Alert Email Template to the template that you want to use for the price alert
notifications.

c. To offer alerts when out-of-stock products become available again, set Allow Alert
When Product Comes Back in Stock to “Yes.”

The “Sign up to get notified when this product is back in stock” message appears only when
Inventory Stock Options - Display Out of Stock Products is set to “Yes.”

d. Set Stock Alert Email Template to the template that you want to use for product stock
alerts.

e. Set Alert Email Sender to the store contact that you want to appear as the sender of
the email alert.

4. When complete, click the Save Config button.

http://merch.docs.magento.com/ee/user_guide/Magento_Enterprise_Edition_User_Guide.html#configuration/catalog/catalog.html%23Product_Alerts
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Scheduling Product Alerts
These settings enable you to select how often Magento checks for changes that require alerts
to be sent. Additionally, you can select the recipient, sender, and template for emails that
are sent if the sending of alerts fails.

Product Alert Run Settings

To schedule product alerts:

1. On the Admin menu, select System > Configuration.

2. In the panel on the left, under Catalog, select Catalog.

3. Click to expand the Product Alerts Run Settings section. Then, do the following:

a. To determine how often product alerts are sent, set Frequency to one of the following:

l Day

l Week

l Month

b. To determine the time of day product alerts are sent, set Start Time to the hour,
minute, and second.

c. In the Error Email Recipient field, enter the email of the person to be contacted if an
error occurs.

d. In the Error Email Sender field, select the store identity that appears as the sender of
the error notification.

e. Set Error Email Template to the transactional email template to be used for the error
notification.

4. When complete, click the Save Config button.
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Managing Stock for Configurable Products
By default, Manage Stock is turned off for a configurable product, because the inventory is
managed through each associated product. However, at times it may be necessary to apply
inventory settings to a configurable product as a whole, such as to set quantity increments
and change the stock availability.

To enable quantity increments:

1. On the Inventory tab of the configurable product, clear the Use Config Settings checkbox,
and set Manage Stock to “Yes.” The Enable Qty Increments field appears.

2. To sell the product in quantity increments, do the following:

a. Below the Enable Qty Increments field, clear the Use Config Settings checkbox. Then,
set Enable Qty Increments to “Yes.”

b. In the Qty Increments field, enter the number of products that you want to sell
together as a single batch.

To set product as “Out of Stock:”

1. On the Inventory tab of the configurable product, clear the Use Config Settings checkbox,
and set Manage Stock to “Yes.” The Stock Availability field appears.

2. To temporarily remove the product from sale, set Stock Availability to “Out of Stock.”

3. When you are ready to offer the product for sale, set Stock Availability to “In Stock.”
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CHAPTER 18:

Product Information
The Product Information panel provides access to the full range of settings which make
up a product record. The information in this section can be used for reference when
creating a product of any type.

The selection of Product Information tabs, and the organization of the fields on each
page is determined by the attribute set that was used to create the product. As a result,
some fields in your product might differ from what is shown in the examples.

Product Information
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General
Use the General tab to enter information about the product. In addition to providing basic
information about the product, this section determines the product's visibility in the
catalog and search.

General

BUTTON DESCRIPTION

Create New Attribute Gives you the ability to create a new attribute while working in
product edit mode. Although you can save the new attribute, it is
not automatically included in the attribute set that is associated
with the current product.

WYSIWYGEditor Opens the editor so you can format the description fields with
HTML. The frontend properties of the description attributes must
set to allow HTML.

Button Descriptions
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FIELD SCOPE DESCRIPTION

Name Store View (Required) The name of the product you want to
appear in catalog. The name is also used to auto-
generate the URL Key.

Description Store View (Required) Themain product description that
appears on the product page.
The text should be plain ASCII text. HTML tags
can be used to format the description if permitted
by the attribute properties.
Do not paste text directly from aword processor,
because the text might include print control codes
that will not render correctly. To strip out any
control codes, save the file as a .txt file before
copying and pasting te text into the product
description.

Short Description Store View (Required) Depending on the theme, the Short
Descriptionmight appear on catalog pages.
Because of its length, it is often used for RSS
feeds.

SKU Global (Required) The Stock Keeping Unit is a unique
identifier for each individual product or service
provided.

Weight Global (Required) The weight of the product is a decimal
value used for shipping calculations, and refers to
the standardmeasurement system used by
shipping carriers in your locale. In the United
States, weight is measured in pounds and
ounces, whereas countries on themetric system
measure weight in grams and kilograms.

Set Product as New from
Date

Website Sets the beginning date for the range of time the
product is featured in the “New Product” block on
the Home page. The date can be typed directly
into the box, or selected from the calendar.

Set Product as New to
Date

Website Sets the ending date for the range of time the
product is featured in the “New Product” block on
the Home page.

Field Descriptions
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FIELD SCOPE DESCRIPTION

Status Website (Required) The Status indicates when the product
is ready to be offered for sale in your store.
Options include: Enabled / Disabled.

URL Key Store View The URL Key determines the online address of
the product. It is added to the base URL of the
store, and appears in the address bar of a
browser.
The URL Key should be all lowercase characters,
with hyphens instead of spaces. Magento initially
creates a default, “search engine friendly” URL,
based on the product name.
Do not type the suffix .html in the URL Key,
because use of the suffix is controlled by your
store configuration. To learnmore, see , SEO
URLOptions.

Visibility Store View (Required) Determines the level of visibility the
product has throughout the store. Options include:

Not Visible
Individually

The product may be
associated with a one-to-
many product, but is not
listed in the catalog.

Catalog The product appears in
the catalog listing, but is
not included in Search
results.

Search The product appears in
search results, but is not
listed in the catalog.

Catalog, Search The product is listed in
the catalog and search
results.

Country of Manufacture Website Select themanufacturer of the product. To add
new options to the list, seeManage
Label / Options.

Enable RMA Website Determines if ReturnMerchandise Authorization
is available for the product. Options include: Yes /
No / Use Config

Field Descriptions (cont.)
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Product Meta Information
Your product meta data is the first level of contact with potential customers who are
searching for a product. The title and description are selling tools that will either help to
motivate a visitor to click your link or not. It is wise to use a descriptive title and a
description that includes relevant words that a potential customer might search.

The information is read by search engines that index your site. Although Google no longer
places a value on meta keywords, other search engines continue to use the information. It’s
a good practice to incorporate high-value keywords in your product titles and related
content.

Meta Information

FIELD SCOPE DESCRIPTION

Meta Title Store View The title appears in the title bar and tab of your
browser, and is also used as the title on a search
engine results page (SERP1).

Meta Keywords Store View Enter relevant keywords for the product. Consider
using keywords that customers may use to find
the product.

Meta Description Store View Write a few sentences to describe the product.
Though not visible to the customer, some search
engines include themeta description on the
search results page.

Field Descriptions

1Search Engine Results Page
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Recurring Profile
Recurring Profiles are most often used for subscriptions or products with installment
payment plans. When such a product is purchased from your store, the customer is
redirected to a third-party payment system. The customer enters into a recurring payment
agreement to authorize the payment system to charge the customer account according to
the recurring profile settings. When a customer purchases a product with recurring
payments, the profile parameters specified from Magento are transferred to the payment
system. Magento supports recurring profiles for items paid with PayPal Express Checkout.

For example, to set up a product with monthly subscription payments, the following
parameters are specified in the recurring profile of the product. The customer is charged by
the payment system once a month, for a year.

Billing Period Unit: Month

Billing Frequency: 1

Maximum Billing Cycles: 12

You can also set up a trial period where the customer pays a special, introductory price for
a period of time. When the trial ends, the customer is charged the regular amount.

Creating a recurring profile for a product does not create additional sales orders.

In the third-party payment system, a recurring profile is an accounting record that
captures payments on a regular basis and according to the payment schedule defined in the
recurring profile. A recurring profile submits the information about the frequency of a
payment being initiated to the payment system.

The Recurring Profile tab appears by default for simple and virtual products. However you
can configure it to become available for other product types by changing the Apply To
property of the recurring_profile attribute. To learn more about recurring profiles, see:
Working with Recurring Profiles in the knowledge base.

To set up a recurring profile:

1. On the Admin menu, select Catalog > Manage Products. Find the product in the list, and
click to open it in edit mode.

2. In the panel on the left, select Recurring Profile.

3. Set Enable Recurring Profile to “Yes.” The section expands to include additional options.

http://www.magentocommerce.com/knowledge-base/entry/working-with-recurring-profiles/
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Recurring Profile

4. In the Schedule section, do the following:

Schedule

a. To let the customer determine the starting date for the payments, set Customer Can
Define Start Date to “Yes.”

b. In the Schedule Description field, enter a brief description of the recurring payment.
The description is used as the name of the recurring payment on the Review
Information page.

c. In the Maximum Payment Failures filed, enter the number of times payment can fail
before the recurring profile is suspended.

d. To automatically initiate a payment transactoin at the end of the next billing cycle, set
Auto Bill on Next Cycle to “Yes.”

5. In the Billing section, do the following:

Billing

a. Set Billing Period Unit to the period of time that defines the billing cycle.

b. Set Billing Frequency to how often a payment transaction is initiated during the
billing cycle.
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c. In the Maximum Billing Cycles field, enter the maximum number of payments
allowed for the recurring profile. If left blank, the the customer will continue to be
charged until the recurring profile is canceled.

6. In the Trial Period section, do the following:

Trial Period

a. Set Trial Billing Period Unit to the period of time that defines the billing cycle during
the trial period.

b. Set Trial Billing Period Frequency to how often a payment transaction is initiated
during the trial billing cycle.

c. In the Trial Billing Period Cycles field, enter the maximum number of payments
allowed during the trial period.

d. In the Trial Billing Amount field, enter the product price during the trial period.

The trial billing period parameters are optional, but if specified, make sure that all fields are
complete. Otherwise, the payment system will not authorize the payment.

7. In the Initial Fees section, do the following:

Initial Fees

a. In the Initial Fees field, enter the amount that the customer is charged at the time of
purchase. The initial fee is paid only once during the life of a subscription.

b. To cancel if the initial payment fails, set Allow Initial Fee Failure to “Yes.” If set to
“No,” the initial fee is added to the customer’s outstanding amount and is charged by
the payment system as soon as the customer account has a sufficient amount.

8. When complete, click the Save button.
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FIELD SCOPE DESCRIPTION

SCHEDULE

Customer Can Define
Start Date

Global Determines if the customer can set the starting
date for the payments. Options include:

Yes Displays the Recurring Profile
Start Date as an option on the
product page.

No The customer cannot set the start
date.

Schedule Description Global A brief description of the recurring payment. The
description appears as the name of the recurring
payment on the review information page of the
payment system. If left empty, the name of the
selected product appears as the name of the
recurring profile.

Maximum Payment
Failures

Global Determines the number of failed scheduled
payments before the recurring profile is
automatically be suspended.

Auto Bill on Next Cycle Global Determines if the payment system automatically
initiates a payment transaction after the regular
billing cycle.
In the event of a number of payment failures and
the customer has an outstanding amount, the
customer is charged in the next billing cycle.
Options: Yes / No

BILLING

Billing Period Unit Global Determines the period of time included in a
subscription billing cycle, and how frequently a
payment transaction is initiated. Options include:
Day
Week
TwoWeeks
Month
Year

Field Descriptions
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FIELD SCOPE DESCRIPTION

Billing Frequency Global Determines how often within the billing period a
payment transaction is initiated for the recurring
profile.

Maximum Billing Cycles Global Limits the number of payments that can bemade
during a billing cycle. If you do not specify the
maximum of billing cycles, the recurring profile
remains permanently active and the customer is
charged by the payment system until the recurring
profile is suspended or canceled.

TRIAL PERIOD

Trial Billing Period Unit Global Determines the period of time included in a trial
subscription billing cycle, and how frequently a
payment transaction is initiated. Options include:
Day
Week
TwoWeeks
Month
Year

Trial Billing Frequency Global Determines how often during the billing period a
payment transaction is initiated for the recurring
profile.

Maximum Trial Billing
Cycles

Global Limits the number of recurring payments that can
bemade during a trial billing cycle.

Trial Billing Amount Global The price of the product during the trial period.

Field Descriptions (cont.)
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FIELD SCOPE DESCRIPTION

INITIAL FEES

Initial Fee Global The amount the customer is charged at the time of
purchase. The initial fee is paid only once during
the life of a subscription.

Allow Initial Fee Failure Global Determines if the payment profile is suspended if
the initial fee payment fails. In case the field is set
to No, Options include:

Yes The payment profile is suspended
if the initial fee fails.

No The initial fee is added to the
customer’s outstanding amount
and is charged by the payment
system as soon as the customer
account has the sufficient amount.

Field Descriptions (cont.)
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Design
The Design page gives you the ability to apply a different theme to the product page, and
make updates to the XML code that controls the page layout.

Design

FIELD SCOPE DESCRIPTION

Custom Theme Store View To apply a custom theme, select the one you
want from the list of available themes.

Active From Store View If applying a custom theme for a period of time,
enter the beginning date, or select the date from
the Calendar.

Active To Store View If applying a custom theme for a period of time,
enter the ending date, or select the date from the
Calendar.

Custom Layout Update Store View You can further customize the themewith XML
coding.

Page Layout Store View To apply a different layout to the product page,
select one of the following:

No layout updates (Default) Does not apply
any layout changes.

Empty For custom layouts, such
as a 4-column page.
Requires an
understanding of XML.

Field Descriptions
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FIELD SCOPE DESCRIPTION

1 column Applies the 1-column
layout.

2 columns with left
bar

Applies the 2 column
layout.

2 columns with
right bar

Applies the 2-columns
with right bar layout.

3 columns Applies the 3 column
layout.

Display product options in Store View Determines the place on the page where the
product options appear. Options include: Product
Info Column / Block after Info Column

Field Descriptions (cont.)

Gift Options
Gift Options determine if customers have the option to add a gift message and to gift wrap
the product during checkout. To configure gift options for the store, see: Gift Options
Configuration.

To set up gift options for a product:

1. On the Admin menu, select Catalog > Manage Products. Then, click to open the product
in edit mode.

2. In the panel on the left, select Gift Options. Then, do the following:

Gift Options

a. To allow the customer to enter a gift message, set Allow Gift Message to “Yes.”

b. To offer gift wrapping for this product, set Allow Gift Wrapping to “Yes.”

c. To charge for gift wrapping, enter the amount in the Price for Gift Wrapping field, as a
decimal, without the currency symbol.

3. When complete, click the Save button.
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FIELD SCOPE DESCRIPTION

Allow Gift Message Global Determines if a gift message is available for the
product. Options include: Yes / No

Allow Gift Wrapping Store View Determines if gift wrapping is available for the
product. Options include: Yes / No

Price for Gift Wrapping Global Determines if there is an additional charge to gift
wrap the product. Enter the price without a
currency symbol.

Field Descriptions

Websites
If your Magento installation has multiple websites, stores, or views, you can set the scope
of a configuration setting, product, category, or attribute to apply to a specific website,
store, or store view. To learn more, see: Websites, Stores & Views.

Websites

To assign a product to a store view:

1. In the Product Information panel on the left, select Websites.

2. Select the checkbox for each store view where the product is offered for sale.

3. When complete, click the Save button.
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Product Categories
Every product in your catalog must be assigned to at least one category. Before you can
add products to your catalog, you must first establish its basic category structure. A
product cannot be saved until after it has been assigned to at least one category.

Product Categories

To set up the product categories:

1. In the Product Information panel on the left, select Categories.

2. In the category tree, select the checkbox of each category to which you want to associate the
product. Click the plus [+] icon to show any available subcategories.

A single product can be assigned to more than one category.

3. When complete, click the Save button.
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Related Products
Related products are meant to be purchased in addition to the item the customer is
viewing. Simply click the checkbox of a product to place it in the shopping cart. The
placement of the Related Products block varies according to theme and page layout. In the
example below, it appears at the bottom of the Product View page. With a 2 column layout,
the Related Product block often appears in the right column.

Related Products
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To set up related products:

1. In the Product Information panel on the left, click Related Products.

2. Click the Reset Filter button in the upper-right to list all the available products, or use the
search filters at the top of each column to find specific products.

3. In the list, select the checkbox in the first column of any product you want to feature as a
related product.

Select Related Products

4. When complete, click the Save button.
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Up-sells
Up-sell products are items that your customer might prefer instead of the product currently
viewed. An item offered as an up-sell might be of a higher quality, more popular, or have
better profit margin. Up-sell products appear on the product page, under a heading such
as, “You may also like.”

Up-Sells on Product Page

To select up-sell products:

1. In the Product Information panel, select Up-sells.

2. Click the Reset Filter button in the upper-right to list all the available products, or use the
search filters at the top of each column to find specific products.

3. In the list, select the checkbox in the first column of any product you want to feature as an
up-sell.

4. When complete, click the Save button.
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Cross-sells
Cross-sell products are similar to impulse purchases positioned next to the cash register in
the checkout line of a grocery store. Products offered as a cross-sell appear on the shopping
cart page, just before the customer begins the checkout process.

Cross-sells Offered During Checkout

To set up cross-sell products:

1. In the Product Information panel on the left, click Cross-sells.

2. Click the Reset Filter button in the upper-right to list all the available products, or use the
search filters at the top of each column to find specific products.

3. In the list, select the checkbox in the first column of any product you want to feature as a
cross-sell.

Cross-Sell Product

4. When complete, click the Save button.
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Custom Options
Custom options are an easy way to offer a selection of product variations that do not rely
on attributes. The limitations are that you cannot track inventory based on any variation,
and that a product with custom options cannot be used with a configurable, grouped, or
bundle product. Custom options are a good solution if your inventory needs are simple.

Custom Options on Product Page

To create custom options:

1. On the Admin menu, select Catalog > Manage Products.

2. In the list, open the product record in edit mode.

3. In the panel on the left, select Custom Options.

4. In the upper-right corner, click the Add New Option button. Then, do the following:

a. In the Title field, enter a name for the property.

b. Set the Input Type you want to use for data entry.

c. Set Is Required to “Yes” if the option must be selected before the product can be
purchased.

d. In the Sort Order field, enter a number to indicate the order of this item in the list of
options. Enter the number 1 to display this option first.
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Custom Options

5. Click the Add New Row button. Then, complete the following:

Add New Row

a. In the Title field, enter a name for this option.

b. In the Price field, enter any markup or markdown from the base product price that
applies to this option.

c. Set Price Type to one of the following:

Fixed The price of the variation differs from the price of the base
product by a fixed monetary amount, such as $1.

Percentage The price of the variation differs from the price of the base
product by a percentage, such as 10%.

d. Enter a SKU to identify the option. The option SKU is added as a suffix to the SKU of
the product record.

e. In the Sort Order field, enter a number to indicate the order of this item in the list of
options. Enter the number 1 to display this option first.

6. When complete, click the Save button.
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Translating Products
If your store has multiple views in different languages, the same products are available in
each store view. You can use the same basic product information, such as SKU, price, and
inventory level, regardless of language. Then, translate only the product name, description
fields, and meta data as needed for each language.

Change the Product Scope to Store View

Step 1: Translate Product Fields

1. On the Admin menu, select Catalog > Manage Products.

2. In the list, find the product and click Edit to open.

3. In the upper-left corner set Choose Store View to the view where the changes you make
will be visible. When prompted to confirm, click OK.

Only fields with a scope of [STORE VIEW] can be edited separately for each view or
language.

4. For each field to be edited, do the following:

a. Clear the Use Default Value checkbox to the right of the field.

b. Either paste or type the translated text into the field.

5. When complete, click the Save button.
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Step 2: Translate Field Labels

1. On the Admin menu, select Catalog > Attributes.

2. In the list, find the attribute and click to open in edit mode.

3. In the panel on the left, select Manage Label / Options.

4. In the Manage Titles section, enter the translated label text for each store view.

Enter Translated Labels

5. When complete, click the Save Attribute button.
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CHAPTER 19:

Storefront Search Tools
Research shows that people who use search are more likely to make a purchase than
those who rely on navigation alone. In fact, according to some studies, people who use
search are nearly twice as likely to make a purchase.

Magento Enterprise Edition has a powerful search engine that you can use as is, or
enhance to make even more effective. In this chapter , we will examine the search tools
that are available to your customers while shopping in your store, including:

l Quick Search

l Advanced Search

l Search Results

In addition, Magento’s layered navigation gives your customers the ability to filter
product options by price, manufacturer, or any other criteria to reduce the time it takes
to make a purchase.
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Quick Search
The Quick Search box in the upper-right corner helps visitors find products in your catalog.
The search text can be the full or partial product name, or any other word or phrase that
describes the product.

To use quick search:

1. Type the first few letters of what you are looking for into the search box.

2. Press either the Enter key or the button to the right of the search box to retrieve a list of
matching products from the catalog.

Quick Search
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Advanced Search
Advanced Search lets shoppers search through your catalog by entering values into a form.
Because the form contains multiple fields, a single search can include several parameters.
The result of the search is a list of the products that match the search criteria. A link to
Advanced Search is in the footer of your store.

Advanced Search

Each field in the form corresponds to an attribute from your product catalog. You can
determine which fields to include by setting the attribute frontend properties to “Include in
Advanced Search.”

As a best practice, you should include only the fields that your customers are most likely to
use to find a product, because too many can slow down the search.

To use advanced search:

1. In the footer of the store, click the Advanced Search link.

2. In the Search Settings form, enter any value you want to match in as many fields as
necessary. You can find records based on a full or partial match.

3. Click the Search button at the bottom to display the results.
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Search Settings

4. If you don’t see what you are looking for in the search results, click Modify your search and
try another combination of values.

Search Results
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Search Results
Search Results include all products that match the parameters entered in the Quick Search
box or the Advanced Search form. Any page in the catalog that lists products has
essentially the same controls. The only difference is that one is the result of a search query,
and the other is the result of navigation.

Search Results with Page Controls

The results can be formatted as either a grid or list, and the records can be sorted by a
selection of attributes. Controls can be used to sort the list and change the format from a
list to a grid. Page links appear when there are more products than can fit on the page, and
allow you to move from one page to the next. Depending on the layout, the left column of
the page might also include layered navigation under the “Shop By” heading, with products
listed by category and attribute.
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Popular Search Terms
The Popular Search Terms pages lists the search terms that have been used by visitors to
your store, and ranks them by popularity. Search terms appear in a “tag cloud” format,
where the size of the text indicates the popularity of the term. The link to the Popular
Search Terms page is located in the footer of your store.

By default, Popular Search Terms is enabled as a search engine optimization tool, but has
no direct connection to the catalog search process. Because the Search Terms page is
indexed by search engines, any terms included on the page will help improve your search
engine ranking and the visibility of your store.

Popular Search Terms
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To configure Popular Search Terms:

1. On the Admin menu, select System > Configuration.

2. In the Configuration panel on the left, under Catalog, select Catalog. Then, do the
following:

a. Click to expand the Search Engine Optimizations section.

b. Set Popular Search Terms to “Enable.”

3. When complete, click the Save Config button.

Search Engine Optimizations
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CHAPTER 20:

Catalog Search Configuration
This chapter explains how to configure Catalog Search for your specific installation. The
available search options depend on the search engine that is used for your Magento
installation. By default, Magento uses MySQL. Follow the instructions that apply to
your system.

MySQL

MySQL is the default search engine used by Magento Enterprise Edition.

Solr

Solr is not included in Magento Enterprise Edition, and must be installed separately. If
your Magento installation uses Solr, there is a slightly different set of configuration
options and features.
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MySQL Search
By adjusting the Catalog Search configuration, you can control the behavior of the search
operations and determine the size of valid query text, and the display of search
recommendations.

To configure catalog search:

1. On the Admin menu, select System > Configuration.

2. In the Configuration panel on the left, under Catalog, select Catalog. Then, click to expand
the Catalog Search section.

Catalog Search (MySql Fulltext)

3. To limit the length and word count of search query text, do the following:

a. Set Minimal Query Length to the minimum number of characters that can be
submitted in a query.

b. Set Maximum Query Length to the maximum number of characters that can be
submitted in a query.

c. Set Maximum Query Words Count to the maximum number of words that can be
submitted in a query.

4. Accept the default Search Engine, “MySql Fulltext.”

5. Set Search Type to one of the following:

Like To perform a search based on individual keywords.

Fulltext To perform a search based on the full text of each attribute, ranked
by relevance.

Combine (Like
and Fulltext)

To perform a search based on a combination of the two types,
matching keywords and taking relevance into consideration.
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6. To limit the number of records that can be used with layered navigation, enter the
maximum number allowed in the Apply Layered Navigation if Search Results are Less
Than field. To allow any number of records, enter 0.

7. To display related search terms as recommendations, set Enable Search
Recommendations to “Yes.” Then, do the following:

a. In the Search Recommendations Count field, enter the maximum number of
recommendations displayed for a search.

b. To show the number of recommendations per term in parentheses after the
recommendation, set Show Results Count for each Recommendation to “Yes.”

8. When complete, click the Save Config button.

Solr Search
Solr is a standalone, enterprise-scale search server that communicates easily with
applications. Because Solr is highly scalable, it is used to power some of the world’s most
high-traffic Internet sites. This guide includes installation instructions for system
administrators, as well configuration instructions and “how to” help for store
administrators. Topics include:

l Solr Server Configuration

l Solr Feature Cmfiguration

For more technical information, see: How to Install and Configure the Solr Search Engine
With Magento Enterprise Edition (EE) 1.x

Solr provides improved search performance and search results relevancy, support for
spelling, synonyms and stop words, and improved layered navigation performance. Solr is
especially recommended for sites with heavy traffic and search loads. Products are added to
the search engine index as each product is saved in the Admin, so the index is kept up to
date without any need for manual intervention.

Magento quick search performed by the Solr search engine includes the following:

l Search terms suggestions based on the corrected customer’s misspelling

l Search results according to the specified weight of an attribute

l Search results for layered navigation

All of the attributes that are available for layered navigation are added to Solr index. As a
result, Solr can also be used to generate the layered navigation. To add these attributes to
Solr search results, the store administrator must enable Solr for catalog navigation.
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Search Suggestions
Solr can be configured to identify misspelled words and offer suggestions. When a customer
makes a spelling mistake, the message, “Did you mean:” appears with a link to a suggested
product. The number of suggestions offered is set in the configuration.

Solr Search Suggestions
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To configure suggestions:

1. On the Admin menu, select System > Configuration.

2. In the panel on the left, under Catalog, select Catalog.

3. Click to expand the Catalog Search section, and do the following:

a. Verify that Search Engine is set to “Solr.”

b. Set Enable Search Suggestions to “Yes.”

c. In the Search Suggestions Count field, enter the number of suggestions to be offered to
the customer. The default value is 2.

d. Set Show Results Count for Each Suggestion to “Yes.” (Depending on the store
theme, this number is usually shown in brackets next to the suggestion.)

4. When complete, click the Save Config button.
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Weighted Search
With Solr enabled, product attributes that are enabled for quick search have an additional
Search Weight parameter. This parameter denotes the priority a specific attribute has in the
Solr search. If Solr is enabled, it is also used for Advanced Search, but the search weight is
not used there in generating search results.

When a customer enters a term in the search field on your web store, one of the parameters
that the Solr search engine takes into account in generating results is the attribute search
weight. Attributes whose search weight is greater will be searched and returned first by Solr.

For example, if there are two attributes in the system, “color” with a search weight of 1 and
“description” with a search weight of 3. When a customer searches for the word “red,” Solr
will return a list of products whose color attribute is red and will not include in the list the
products whose description contains the word “red.” This result happens because the search
weight of the “color” attribute is higher than that of the “description” attribute.

To set the search weight properties of an attribute:

1. On the Admin menu, select Catalog > Attributes > Manage Attributes.

2. Find the attribute in the list, and click to open the record.

3. Scroll down to the Frontend Properties section, and do the following:

a. To include the attribute in Quick Search box queries, set Use in Quick Search to “Yes.”

b. To include the attribute as a field on the Advanced Search form, set Use in Advanced
Search to “Yes.”

c. To establish the search value of the attribute, set Search Weight to a number from 1 to
5, where 1 is the greatest weight, and 5 is the least.

Greater search weights have higher priority in returned results. If no value is specified,
all attributes have a search weight of 1.

4. When complete, click the Save Attribute button.
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Solr Feature Settings
The following instructions show how to configure Solr’s search features, which are
highlighted in the screenshot. After you have the opportunity to test the results, you can
fine-tune the settings over a period of time until you get the results that you want. To learn
about the server configuration settings, see: Installing Solr Search.

Solr Catalog Search (Feature Settings)

299Magento Enterprise Edition User Guide, Version 1.14.2.1

http://merch.docs.magento.com/ee/user_guide/Magento_Enterprise_Edition_User_Guide.html#configuration/catalog/catalog.html%23Catalog_Search_Solr


Solr Search CHAPTER 20:  Catalog Search Configuration

300 Magento Enterprise Edition User Guide, Version 1.14.2.1

To configure Solr search features:

1. On the Admin menu, select System > Configuration.

2. In the Configuration panel on the left, under Catalog, select Catalog. Then, click to expand
the Catalog Search section.

3. Verify that Search Engine is set to “Solr.”

4. To limit the length and word count of search query text, do the following:

a. Set Minimal Query Length to the minimum number of characters that can be
submitted in a query.

b. Set Maximum Query Length to the maximum number of characters that can be
submitted in a query.

c. Set Maximum Query Words Count to the maximum number of words that can be
submitted in a query.

5. To offer search terms as suggestions, do the following:

a. Set Enable Search Suggestions to “Yes.”

b. To display the number of times each suggested term has been used as a search term,
set Show Results Count for Each Suggestion to “Yes.”

6. To display related search terms as recommendations, set Enable Search
Recommendations to “Yes.”

7. When complete, click the Save Config button.

To configure catalog navigation:

1. On the Admin menu, select System > Configuration.

2. In the panel on the left, under Catalog, select Catalog.

3. Click to expand the Catalog Search section, and do the following:

a. Verify that Search Engine is set to “Solr.”

b. Set Enable Solr Engine for Catalog Navigation to “Yes.”

4. When complete, click the Save Config button.
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CHAPTER 21:

Managing Search Terms
You can learn what your customers are looking for by examining their search terms. If
enough people look for a product that you don’t carry, perhaps it’s time to add it to
your catalog. Here are a few ways you can leverage search terms:

Landing Page

The landing page for a search term can be a content page, a category page, a product
detail page, or even a page on a different site.

Suggestions

(Solr Only) If a search returns no results, and there is no alternate landing page for the
term, a selection of closely matching terms can be offered as possible solutions. The
text, “Did you mean:” appears, followed by a list of suggestions.

Recommendations

Recommendations are similar to suggestions, but are drawn from the selection of
related search terms. If a search returns no results, related search terms can be offered
as recommendations.

Synonyms

One way to improve the effectiveness of catalog search is to include different terms that
people may use to describe the same item. You don’t want to lose a sale just because
someone is looking for a “sofa,” and your product is listed as a “couch.” You can
capture a broader range of search terms by entering the words, “sofa” “davenport,” and
“loveseat” as synonyms for “couch,” and direct them to the same landing page.

Misspelled Words

Use search terms to capture common misspellings and redirect them to the appropriate
page. For example, if you sell wrought iron patio furniture, you know that many people
misspell the term as “rod iron,” or even “rot iron.” You can enter each misspelled word
as a search term, and make them synonyms for “wrought iron.” Even though the word
is misspelled, the search will be directed to the page for “wrought iron.”
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Adding Search Terms
As you learn new words that people use to search for products in your catalog, add them to
your search terms list to direct people the closely matching products in your catalog.

General Information

To add a new search term:

1. On the Admin menu, select Catalog > Search Terms.

2. Click the Add New button. Then, do the following:

a. In the General Information section, in the Search Query box, type the word or phrase
that you want to add as a new search term.

b. Select the Store where the search term will be used. If your store is available in
multiple languages, select the applicable store view.

c. If this term is a synonym for another search term, enter the other term in the
Synonym For field. Any search for the synonym will be automatically redirected to the
page for the other term.

d. To redirect the search results to another page in your store, or to another website, type
the full URL of the target page in the Redirect URL field.

e. If you want this term to be available for use as a suggestion whenever a search returns
no results, set Display in Suggested Terms to “Yes.”

3. When complete, click the Save Search button.
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To edit a search term:

1. On the Admin menu, select Catalog > Search Terms.

2. Click the row of any record to open the search term in edit mode.

3. Make the necessary changes.

4. When complete, click the Save Search button.

To delete a search term:

1. In the list, select the checkbox of the term to be deleted.

2. In the upper-right corner of the list, set the Actions control to “Delete.”

3. When complete, click the Submit button.
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Related Search Terms
The Related Search Terms section of a search term record lets you associate other terms
with the search term. You can use the information to keep a running total of how many
people are searching for the same thing. Related search terms can also be offered as
suggestions and recommendations whenever a search returns no results.

Related Search Terms

To set up related search terms:

1. On the Admin menu, select Catalog > Search Terms.

2. In the list, click to open the search term in edit mode.

3. In the Related Search Terms section, do the following:

a. Click the Reset Filter button to generate a list of all search terms.

b. In the first column, select the checkbox of each search term that is related to the term
that is listed in the General Information section of the record. There’s probably more
than one page of search terms. Don’t forget to look at the rest!

c. Click the Save Search button.

d. In the first column, set the Search Filter to “Any.”

4. When complete, click the Search button.
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FIELD DESCRIPTION

Search Query (Required) Contains the actual text that was used as a search
term.

Store (Required) Identifies the store and/or views where the search
term is available.

Number of results (Required) Displays how many products were returned in the
search results since the last time the term was submitted.
Only search terms with results are offered as suggestions.

Number of Uses (Required) Displays the total number of times this term has been
used. This number is used to determine the “Top 5 Search
Terms” section of the Dashboard report.

Synonym For If this term is a synonym for another search term, enter the other
term in this field. Any searches for the synonym will be redirected
to the page for the other term.

Redirect URL Enter the full URL of the page that is displayed when this search
term is used. The Redirect URL can be a product, category, or
content page within your site, or a page on another site.

Display in Suggested
Terms

Determines if this search term is available for use as a
suggestion. For example, youmay deliberately enter a
misspelled word as a search term, but would not want to use the
misspelled word as a suggestion. Options include: Yes / No

Field Descriptions
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Search Recommendations
With search recommendations set up, the store administrator can specify the search
recommendations list for a specific search term. The search engine provides the standard
search results, and also proposes the list of related terms with the search results. Using
search recommendations greatly expands the search results that are available to customers.
Search recommendations are independent of the search engine and can be used with both
MySQL and Solr.

Search Recommendation Settings (MySQL)

For better performance, Magento also splits the searched word combination into separate
words and automatically provides search recommendations for each of them, if these are
available in the system. For example, if a visitor searches for the phrase “hp laptop,” the
search system splits the phrase into two words, “hp” and “laptop,” and provides five search
recommendations for the first term and twelve for the second one.

When search recommendation are enabled and a visitor searches for a term that has search
recommendations, the search results appear as well as any related search terms (the search
recommendations), followed by the number of times the term has been used. Each
recommendation is linked to a catalog page.
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To enable search recommendations:

1. On the Admin menu, select System > Configuration. Then in the panel on the left, under
Catalog, select Catalog.

2. Click to expand the Catalog Search section, and do the following:

a. Set Enable Search Recommendations to one of the following:

Yes If available, uses Solr instead of the default MySQL search to
generate the layered navigation.

No Uses the Magento-native catalog and layered navigation.

b. Set Search Recommendations Count to your preference.

c. Set Show Results Count for Each Recommendation

3. When complete, click the Save Config button.
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CHAPTER 22:

SEO Best Practices
Search engine optimization is the practice of fine-tuning the content and presentation
of a site to improve the way the pages are indexed by search engines. Magento
Enterprise Edition provides a number of tools that you can use to improve the way
search engines index your site.

Topics in this chapter include:

l Meta Information

l Sitemap

l URL Options

l Canonical Meta Tag

l URL Redirects

Commerce Resources

See the latest Magento eBooks to gain access to expert insight and online business
resources to help develop and improve your store.

http://magento.com/resources/business
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Meta Information
Your store is loaded with places where you can enter keyword-rich meta data to improve
the way search engines index your site. While setting up your store, you might have
entered preliminary meta data, with the intention of finishing it later. Over time, you can
fine-tune the meta data to target the buying patterns and preferences of your customers.

Meta Title

Themeta title appears in the title bar and tab of your
browser, and search results listings. Themeta title
should be unique to the page, and less than 70
characters in length.

Meta Keywords

Although some search engines ignoremeta
keywords, others continue to use them. The current
best practice is to incorporate high-value keywords in
themeta title andmeta description.

Meta Description

Meta descriptions provide a brief overview of the
page for search results listings. Ideally, a meta
description should be between 150-160 characters in
length, although the field will accept up to 255
characters.
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Sitemap
The default Magento sitemap has links to every product and category in your store, and
can help improve the way your products are indexed by some search engines. Like a table of
contents, the sitemap also gives visitors a quick overview of the organization of your
catalog. To switch between the category and product lists, click the link on the right. By
default, the footer of your store includes a link to the sitemap.

Sitemap by Categories

The sitemap can be formatted as a nested, tree-like structure, or as a simple list. The
number of lines included per page, and the use of indentation is set in your system
configuration.

Because the Magento sitemap does not include CMS pages, it is not a complete index to the
content on your site. In addition to the default sitemap, it is recommended that you also
generate a Google sitemap that can be used for reference when your site is indexed by
Google.
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To set up the sitemap:

1. On the Admin menu, select System > Configuration. Then in the panel on the left, under
Catalog, select Catalog.

2. Click to expand the Sitemap section. Then, set the following options according to your
preference:

l Use Tree Like Category Sitemap

l Minimum Lines per Page

Sitemap

3. Scroll down the page and click to expand the Search Engine Optimizations section. Then,
set Autogenerated Site Map to “Enable.”

4. When complete, click the Save Config button.

http://merch.docs.magento.com/ee/user_guide/Magento_Enterprise_Edition_User_Guide.html#configuration/catalog/catalog.html%23Sitemap
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Catalog URLs
The URLs that you assign to products and categories play a major role in determining how
well your site is indexed by search engines. Before you start building your catalog is an
ideal time to consider the available options.

Dynamic URL
A dynamic URL is created “on the fly,” and might include a query string with variables for
the product ID, sort order, and the page where the request was made. When a customer
searches for a product in your store, the resulting URL might look something like this:

http://mystore.com/catalogsearch/result/?q=tee+shirt

Static URL
A static URL is a fixed address for a specific page. A static URL can be displayed in a
search-engine friendly format, or one that references products and categories by ID. Search-
engine friendly URLs include words that people might use to look for a product, and are
created by enabling Web Server Rewrites.

http://mystore.com/accessories/eyewear.html

http://mystore.com/catalog/product/view/id/409/s/

chelsea-tee-409/category/16/

URL Key
The URL key is the part of of a static URL that describes the product or category. When
you create a product or category, an initial URL key is automatically generated based on
the name. The URL key should consist of lowercase characters with hyphens to separate
words. A well-designed, “search engine friendly” URL key might include the product name
and key words to improve the way it is indexed by search engines. The URL key can be
configured to create an automatic redirect if the URL key is changed.

Store Code
The store code can be included in the URL. However, it might cause problems if third-party
services, such as PayPal, are configured to work with a URL that does not include the code.
By default, the store code is not included in URLs.
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HTML Suffix
Your catalog can be configured to either include or exclude the .html suffix as part of
category and product URLs. There are various reasons why people might choose to use or
to omit the suffix. Some believe that the suffix no longer serves any useful purpose, and
that pages without a suffix are indexed more effectively by search engines. However, your
company might have a standardized format for URLs, that requires a suffix.

The most important thing to understand is that the suffix is controlled by your system
configuration. Never type the suffix directly into the URL key of a category or product.
(Doing so will result in a double suffix at the end of the URL.) Whether you decide to use
the suffix or not, be consistent and use the same setting for all your product and category
pages. Here are examples of a category URL with, and without, the suffix.

http://mystore.com/accessories/eyewear.html

http://mystore.com/accessories/eyewear/retro-chic-eyeglasses

Category Path
You can configure the URL to either include or exclude the category path. By default, the
category path is included in all category and product pages. The following examples show
the same product URL with, and without, the category path.

http://mystore.com/accessories/eyewear/retro-chic-eyeglasses

http://mystore.com/retro-chic-eyeglasses

To prevent search engines from indexing multiple URLs that lead to the same content, you
can exclude the category path from the URL. Another method is to use a canonical meta
tag to let search engines know which URLs to index, and which to ignore.
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Setting UpCatalog URLs
Catalog URLs play a major role in how well your store is indexed by search engines. All of
the following options use web server rewrites to change the format of the URL.

URL Suffix Determines if a suffix, such as “html” or “htm,” is used for category
URLs. Do not enter a period before the suffix, because it is applied
automatically.

Store Code Inserts the Store Code of the current view in the URL immediately
after the Magento root.

Category Path Determines if category paths are included in product URLs.
However, doing so can impact SEO by creating multiple URLs that
give the appearance of duplicate content.

To configure the URL suffix:

1. On the Admin menu, select System > Configuration.

2. In the panel on the left, under Catalog, select Catalog.

3. Click to expand the Search Engine Optimizations section. Then, do the following:

Search Engine Optimizations
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a. Set Product URL Suffix to “html” or “htm.” Do not include a period before the suffix.

b. Set Category URL Suffix to “html” or “htm.” Do not include a period before the suffix.

c. Set the category path to your preference. To omit the category path from product
URLs, set Use Categories Path for Product URLs to “No.”

4. When complete, click the Save Config button.

5. After the setting is saved, you will be prompted to refresh the cache. Click the Cache
Management link in the message at the top of the workspace. Then, follow the instructions
to refresh the cache.

To configure the store code for URLs:

1. On the Admin menu, select System > Configuration.

2. In the panel on the left under General, select Web. Then, click to expand the URL Options
section.

URL Options

3. Set Add Store Code to your preference.

http://www.yourdomain.com/magento/store-view/index.php/url-identifier

URL with Store Code

http://www.yourdomain.com/magento/index.php/url-identifier

URL without Store Code

4. When complete, click the Save Config button.
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Dynamic Media URLs
A dynamic media URL is a relative reference to an image or other media asset. When
enabled, dynamic media URLs can be used to link directly to assets in media storage, or
even on a CDN. For example, you can use the WYSIWYG Editor to insert an image into a
product description field. As with all markup tags, the code is enclosed in double curly
braces. The format of a dynamic media URL looks like this:

{{media url="path/to/image.jpg"}}

If you prefer to use a static URL, you can change the configuration setting. If dynamic
media URLs are included in your catalog, but later the setting is disabled, each reference in
your catalog will appear as a broken link. However, the links can be restored by again
enabling dynamic media URLs. Using dynamic media URLs can enhance your catalog, but
can also impact the performance of catalog search.

Frontend
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To configure dynamic media URLs:

1. On the Admin menu, select System > Configuration.

2. In the Configuration panel on the left, under Catalog, select Catalog.

3. In the Frontend section, set Allow Dynamic Media URLs in Products and Categories to
either “Yes” or “No.”

4. Click the Save Config button to save the setting.

To use static URLs by default for media files:

By default, images inserted into the catalog from media storage have relative, dynamic
URLs. If you prefer to use a static URL, you can change the configuration setting.

1. On the Admin menu, select System > Configuration.

2. In the Configuration panel on the left, under General, select Content Management.

3. In the WYSIWYG Options section, set Use Static URLs for Media Content in WYSIWYG
for Catalog to “Yes.”

WYSIWYG Options

4. Click the Save Config button to save the setting.
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Duplicate URL Key Priority
The Priority for Duplicated URL Keys option determines which URL “wins” if a user chooses
a link to an allowed duplicate URL key. For example, if a product and category both have a
URL key of shoes, you can choose which URL you prefer the user to see.

Example 1: Valid URLs

Suppose you have the following set of URL keys. All of them are allowed because they're
associated with different entity types.

ENTITY TYPE NAME URL KEY SAMPLE URL

Category shoes shoes http://www.example.com/shoes.html

Product shoes shoes http://www.example.com/shoes.html

Custom URL
Redirect

shoes shoes http://www.example.com/shoes.html

Example 2: Priority Setting

Because all three entities have the same URL, what happens when a store visitor requests
http://www.example.com/shoes.html? If no URL key matches your priority setting,
Magento continues through the priorities in order, until a match is found. CMS URL keys
have the lowest priority.

PRIORITY SETTING RESULT

Default setting:
1. Redirect
2. Category
3. Product

Custom URL Redirect

1. Category
2. Redirect
3. Product

Shoes Category
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To configure URL key priority:

1. On the Admin menu, select System > Configuration.

2. In the panel on the left, under Catalog, select Catalog. Then, click to expand Search
Engine Optimizations.

Search Engine Optimizations

3. Set Priority for Duplicated URL Keys to one of the following:

l Redirect-Category-Product

l Redirect-Product-Category

l Category-Redirect-Product

l Category-Product Redirect

l Product-Redirect-Category

l Product-Category-Redirect

4. When complete, click the Save Config button.

5. When prompted to refresh the cache, click the Cache Management link in the message
above the workspace. Follow the instructions to refresh the cache.
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Canonical Meta Tag
Some search engines penalize websites that have multiple URLs that point to the same
content. The canonical meta tag tells search engines which page to index when multiple
URLs have identical or very similar content. Using the canonical meta tag can improve
your site ranking and aggregate pageviews. The canonical meta tag is placed in the <head>
block of a product or category page. It provides a link to your preferred URL, so search
engines will give it greater weight.

Example 1: Category Path Creates Duplicate URLs

For example, if your catalog is configured to include the category path in product URLs,
your store will generate multiple URLs that point to the same product page.

http://mystore.com/furniture/living-room/microfiber-sofa-sleeper

http://mystore.com/microfiber-sofa-sleeper

Example 2: Category Page Full URL

When canonical meta tags for categories are enabled, the category page of your store
includes a canonical URL to the full category URL:

http://mystore.com/furniture/living-room/microfiber-sofa-sleeper

Example 3: Product Page Full URL

When canonical meta tags for products are enabled, the product page includes a canonical
URL to the domain-name/product-url-key because product URL keys are globally unique.

http://mystore.com/microfiber-sofa-sleeper

If you also include the category path in product URLs, the canonical URL remains domain-
name/product-url-key. However, the product can also be accessed using its full URL,
which includes the category. For example, if the product URL key is microfiber-sofa-sleeper
and is assigned to the Furniture > Living-Room category, the product can be accessed
using either URL.

You can avoid being penalized by search engines by omitting the category from the URL, or
by using the canonical meta tag to direct search engines to index either by product or
category. As a best practice, it is recommended that you enable canonical meta tags for
both categories and products.
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To enable the canonical meta tag:

1. On the Admin menu, select System > Configuration.

2. In the panel on the left, select Catalog. Then, click to expand the Search Engine
Optimizations section.

Search Engine Optimizations

3. To index only pages that have a full category path, do the following:

a. Set Use Canonical Link Meta Tag for Categories to “Yes.”

b. Set Use Canonical Link Meta Tag for Products to “No.”

4. To index only product pages, do the following:

a. Set Use Canonical Link Meta Tag for Products to “Yes.”

b. Set Use Canonical Link Meta Tag for Categories to “No.”

5. When complete, click the Save Config button.
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CHAPTER 23:

URL Redirects
The URL Redirect tool lets you change any URL that is associated with a product,
category, or CMS page. When the redirect goes into effect, any links that point to the
previous URL are redirected to the new address.

The terms rewrite and redirect are often used interchangeably, but refer to slightly
different processes. A URL rewrite changes the way a URL appears in the browser. A
URL redirect, on the other hand, updates the URL that is stored on the server. A URL
redirect can be either temporary or permanent. Your store uses URL redirects to make it
easy for you to create search engine friendly URLs and to preserve existing links.

Create Custom Redirect for Old URL
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Configuring URL Rewrites
URL rewrites make it possible to make “search engine friendly” URLs by adjusting the
format and content. Initially, all Magento URLs include a file called “index.php” that
resides in the root folder. By default, the file name appears in the URL just after the name
of the root folder. When Web Server Rewrites are enabled, the system rewrites the URL to
omit “index.php.” The rewrite has no impact on performance or site rank, and is more of a
usability issue than anything else.

http://www.yourdomain.com/magento/index.php/storeview/url-identifier

URL without Web Server Rewrite

http://www.yourdomain.com/magento/storeview/url-identifier

URL with Web Server Rewrite

To enable URL rewrites:

1. On the Admin menu, select System > Configuration.

2. In the panel on the left under General, select Web.

3. Click to expand the Search Engine Optimization section.

4. Set Use Web Server Rewrites to “Yes.”

Search Engine Optimization

5. When complete, click the Save Config button.
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Automatic Product Redirects
Your store can be configured to automatically generate a permanent redirect whenever the
URL key of a product changes. In the product record, the checkbox below the URL key
indicates if permanent redirects are enabled for your catalog. If your store is already
configured to automatically redirect catalog URLs, making a redirect is as easy as updating
the URL key.

Search Engine Optimizations

To set up automatic redirects:

1. On the Admin menu, select System > Configuration.

2. In the panel on the left, under Catalog, select Catalog.

3. Click to expand the Search Engine Optimizations section. Then, set Create Permanent
Redirect for URLs if URL Key Changed to “Yes.”

4. When complete, click the Save Config button.

To automatically redirect catalog URLs:

1. On the Admin menu, select Catalog > Manage Products.

2. Find the product in the list, and click to open the record.

3. In the URL Key field, do the following:

a. Make sure that the Create Custom Redirect for old URL checkbox is selected. If not,
complete the instructions to enable automatic redirects.

b. Update the URL Key as needed, using all lowercase characters and hyphens instead of
spaces.
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4. When complete, click the Save button.

5. When prompted to refresh the cache and index, click the links in the messages that appear
at the top of the workspace. Follow the instructions.

The permanent redirect is now in effect for the product and any associated category URLs.

6. To view the redirect records, select Catalog > URL Redirects. The most recent custom
redirects are at the top of the list.

Creating URL Redirects
The URL Redirect tool can be used to create product and category redirects, and custom
redirects for any page in your store. When the redirect goes into effect, any existing links
that point to the previous URL are seamlessly redirected to the new address. The following
instructions show how to use the URL Redirect tool to create three different kinds of
redirects:

l Product Redirect

l Category Redirect

l Custom Redirect

All redirects reference a “Target Path” and “Request Path,” as shown in the following
examples. The “Request Path” is the old URL, and the “Target Path” is where you want the
URL to go from now on.

Example 1: Permanent 301

FIELD VALUE

Target Path category-1.html

Request Path catalog/category/id/6

Redirect Type Permanent 301

Example 2: Temporary 302

FIELD VALUE

Target Path catalog/category/id/6

Request Path product.html
http://magentocommerce.com

Redirect Type Temporary 302
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You can use redirects to create additional URLs for items, as a temporary seasonal change,
or as a permanent change. Redirects can be created for any valid path, including CMS
content pages. Internally, the system references products and category by ID. No matter
how often the URL changes, the ID remains the same. Here are some ways you can use
URL redirects:

http://www.example.com/peripherals/ergonomic-keyboard.html

Original URL

http://www.example.com/best-keyboard.html

Additional Product URL

http://www.example.com/all-on-sale.html

http://www.example.com/save-now/spring-sale

Additional Category URL

URL Redirect Management
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FIELD DESCRIPTION

Type Indicates the type of redirect to bemade. The type cannot be
changed after the redirect is created. Options include:
Category
Product
Custom

Request Path The URL of the page that is to be redirected. Depending on your
configuration, the Request Pathmight include the .html suffix
and category. For example:
brandname

brand/brandname

catalog/category/view/id/56

private-sale-shoes/prima-pump.html

brand/brandname.html

A Request Pathmust be unique, and not have been used
previously.If you havemade several attempts to redirect the
same page, you should delete any unsuccessful redirects and
refresh the cache.

Target Path The URL that points to the destination page. The Target Path can
be a different CMS page, or the result of a search. To avoid
getting a 404 "Page Not Found" error, the pathmust exactly
match what the system expects to find. The following examples
are valid target paths:
brandname

brand/brandname

catalog/category/view/id/52

catalogsearch/advanced/result/?brand=brandname

http://magentocommerce.com

Redirect Type Indicates whether the redirect is temporary or permanent.
Options include:
No
Temporary (302)
Permanent (301)

Description Describes the purpose of the redirect. This field is for reference
and is not visible to customers.

Field Descriptions
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Product Redirect
Before you begin, you should know exactly what you want the redirect to accomplish. Just
remember— the “Request Path” is the old URL, and the “Target Path” is where you want the
URL to go from now on.

Product ID

Process Overview:
Step 1: Get the Product ID of the Target URL
Step 2: Create the Product Redirect
Step 3: Refresh the Index
Step 4: Test the Redirected URL

Step 1: Get the Product ID of the Target URL

1. On the Admin menu, select Catalog > Manage Products.

2. Find the product in the list that is the destination of the redirect, and take note of its
product ID.

Step 2: Create the Product Redirect

1. On the Admin menu, select Catalog > URL Redirects.

2. In the upper-right corner, click the Add URL Redirect button.

3. In the Select URL Redirect Type section, set Type to “Product.”
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URL Redirect Type

4. In the list, find the product that you want to redirect, and click to open the record.

5. Scroll down to the bottom of the Select Category tree, and click the Skip Category
Selection button.

6. In the URL Redirect Information section, do the following:

URL Redirect Information

a. If you have multiple stores, set Store to the specific view where the redirect applies.

b. In the Request Path field, enter the old URL key.

To help you enter the correct format, the Target Path initially echoes the Request path
URL by product ID. To redirect the product, simply replace the ID in the URL with the ID of
the target product.

c. In the Target Path field, replace the old product ID with the one of the product that
you want to be the new destination for the URL.

d. Set Redirect Type to one of the following:

l Temporary (302)

l Permanent (301)

e. For your own reference, enter a brief description of the rewrite.

7. When complete, click the Save button.

Your new product redirect now appears at the top of the list of redirects.
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New Product Redirect

Step 3: Refresh the Index

1. On the Admin menu, select System > Index Management.

2. Select the Catalog URL Rewrites checkbox.

3. Set the Actions control to “Reindex Data,” and click the Submit button.

Step 4: Test the Redirected URL

Test the redirected URL from your store, to make sure that it works correctly.
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Category Redirect
Before you begin, you should know exactly where you want the redirect to go. Just
remember— the “Request Path” is the old URL, and the “Target Path” is where you want the
URL to go from now on.

URL Redirect Management

Process Overview:
Step 1: Get the Category ID of the Target URL
Step 2: Create the Category Redirect
Step 3: Refresh the Index
Step 4: Test the Redirected URL

Step 1: Get the Category ID of the Target URL

1. On the Admin menu, select Catalog > Categories > Manage Categories.

2. In the category in the tree, find the target category and click to open the record.

3. Take note of its category ID at the top of the page.
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Category ID

Step 2: Create the Category Redirect

1. On the Admin menu, select Catalog > URL Redirects.

2. In the upper-right corner, click the Add URL Redirect button

3. In the Select URL Redirect Type section, set Type to “Category”

Category URL Redirect

4. In the category tree, click to select the category that is being redirected.

Select Category

5. In the URL Rewrite section, do the following:

a. If you have multiple stores, elect the Store where the redirect applies.

b. In the Request Path field, enter the old URL.
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c. In the Target Path field, enter the new URL.

d. Set Redirect Type to one of the following:

l Temporary (302)

l Permanent (301)

e. For your own reference, enter a brief description of the rewrite.

6. When complete, click the Save button.

URL Redirect Information

Your new category redirect now appears at the top of the list of redirects.

Step 3: Refresh the Index

1. On the Admin menu, select System > Index Management.

2. Select the Catalog URL Rewrites checkbox.

3. Set the Actions control to “Reindex Data,” and click the Submit button.

Step 4: Test the Redirected URL

Test the redirected URL from your store, to make sure that it works correctly. Make sure
that the URL you test goes directly to the category, rather than to a subcategory. For
example:

http://yourstore.com/catalog/category/view/id/56

http://yourstore.com/catalog/category/view/s/my-category/id/56/
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Custom Redirect
You can use a custom redirect to reroute CMS pages, or any other type of page. For
example, if you change the URL key of the privacy policy from privacy-policy-
cookie-restriction-mode to privacy-policy, the link in the cookie restriction mode
message will return “404 - Page Not Found.” To redirect traffic to the new URL key, create a
custom rewrite with the following settings:

ID Path: privacy-policy

Request Path: privacy-policy-cookie-restriction-mode

Target Path: privacy-policy

Redirect: Permanent (301)

Before you begin, figure out the URL keys that you need for the ID Path, Request Path, and
Target Path. Just remember— the “Request Path” is the old URL, and the “ID Path” and
“Target Path” are the new URL.

New Custom Redirect

Process Overview:
Step 1: Get the Unique Identifier of the Page to be Redirected
Step 2: Create the Custom Redirect
Step 3: Refresh the Index
Step 4: Test the Redirected URL

Step 1: Get the Unique Identifier of the Page to the Redirected

The unique identifier of the page to be redirected might be the relative path to a page in
your store, such as: brand/search/result/brandname
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Step 2: Create the Custom Redirect

1. On the Admin menu, select Catalog > URL Redirects.

2. In the upper-right corner, click the Add URL Redirect button.

3. In the Select URL Redirect Type section, set Type to “Custom.”

Custom URL Redirect

4. In the URL Redirect Information section, do the following:

a. If you have multiple stores, select the Store where the redirect applies.

b. In the Request Path field, enter the unique identifier of the original URL. To redirect
any page in your store, enter the relative path to the page. For example:
brand/search/result/brandname

c. In the Target Path field, enter a valid URL for the new destination.

l To redirect to another CMS page in your store, enter the relative path to the page,
without a leading forward slash.

l To redirect to a page on a different site, enter the fully qualified URL of the new
destination. For example:

new-page URL key of target page.

somewhere/new-page Relative path to target page, without leading forward
slash.

http://magento.com Fully-qualified URL of target page on external website.

d. Set Redirect Type to one of the following:

l Temporary (302)

l Permanent (301)

e. For your own reference, enter a brief Description of the rewrite.
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URL Redirect Information

5. When complete, click the Save button. Your new redirect now appears at the top of the list.

6. When prompted that the cache has become invalid, click the link in the message at the top
of the workspace, and follow the instructions to refresh the cache.

Step 3: Refresh the Index

1. On the Admin menu, select System > Index Management.

2. Select the Catalog URL Rewrites checkbox.

3. Set the Actions control to “Reindex Data,” and click the Submit button.

Step 4: Test the Redirected URL

Test the redirected URL from your store to make sure that it works correctly.
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CHAPTER 24:

Promotions
In this chapter, you will learn how to use promotions to offer discounts based on a
variety of conditions. You can send your best customers a coupon for a discount on a
specific product, create a banner that appears only to certain customers, offer free
shipping for purchases over a certain amount, and much more. Promotions can be set
up in advance, so they spring into action whenever the required conditions are met.

Topics in this chapter:

l Visual Merchandiser

l Catalog Price Rules

l Shopping Cart Price Rules

l Product Relations Rules

l Email Reminder Rules

l Customer Segments
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Visual Merchandiser
Visual merchandising1 is a term used in retail to describe the art and science of floor
plan development and the multi-dimensional presentation of products. In your Magento
Enterprise Edition store, you might think of the category-based navigation as the floor
plan, and the multi-dimensional presentation of products as a dynamic selection of
products that changes according to conditions that you specify.

Important! Visual Merchandiser requires Magento Enterprise Edition, version 1.14.1 or greater.
If you need support for any other version of Magento, please contact On Tap.

In this section, you will learn how to use Visual Merchandiser to attract customers and
increase sales. Topics include:

l Visual Merchandiser Configuration

l Category Setup

l Hero Products

l Using the Merchandiser Window

l Automatic Sorting

l Smart Category Rules

l Visual Merchandiser Cache

l Product Cache

l Clone Category IDs

l Mass Product Assignment

1A term used in retail to describe the art and science of floorplan development and the multi-dimensional
presentation of products.

http://www.ontapgroup.com/
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Configuring VisualMerchandiser
The Visual Merchandiser configuration determines the layout of the merchandiser window,
the format of the products in the category, and way updates are managed when smart
category rules dynamically change the selection of products.

Process Overview:
Step 1: Define the Page Layout
Step 2: Set Visibility Options
Step 3: Complete the Smart Category Options
Step 4: Define the Sorting Order

To configure Visual Merchandiser:

1. On the Admin menu, select System > Configuration.

2. In the panel on the left, under Catalog, select Catalog.

3. Click to expand the Visual Merchandising Options section. Then, follow these step to
complete the configuration.

Step 1: Define the Page Layout

1. To determine which attributes appear in the product block, enter the code of each attribute
that you want to include, separated by a comma. By default, the color, name, and price
attributes appear.

2. In the Column count field, enter the number of product blocks that appear on each row of
the merchandiser window. To make the window resemble your storefront, use the same
number of columns that are used to display the product list when viewed as a grid.

3. If you want to include additional images from the gallery for reference, set Show extra
images to “Yes.” When the Max extra images thumbnail field appears, enter the number
of additional images you want to include from the gallery.
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Attributes in Product Block

You can hover over each thumbnail to view a larger image. If you decide that one of the
thumbnails is a better choice, you must open the product in edit mode, and change the
Base Image assignment.

Thumbnail Images and Creation Date

4. To help you decide which products to feature based on the age of each product, set Show
creation date to “Yes.”
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5. Do one of the following to determine how the system manages dynamic page loads:

l If the category has a large number of products, set the Ajax page load threshold to the
maximum number of products that you want the system to manage before triggering
Ajax page loads. Ajax page loads prepares the next batch of product images in advance.
When the customer scrolls down the page, the images appear without delay.

l To disable Ajax page loads, leave the field blank.

Step 2: Set Visibility Options

Depending upon the configuration, products that are set to “Not Visible Individually,” such
as simple products that are associated with a configurable product, and disabled products
can be either grayed out or hidden from view.

Product Visibility Settings

1. For products with a Visibility setting of “Not Visible Individually,” do one of the following:

a. To display a grayed-out image, set Hide not visible products to “No.”

b. To hide the products from view, set Hide not visible products to “Yes.”

2. For products with a Status setting of “Disabled,” do one of the following:

a. To display a grayed-out image, set Hide disabled products to “No.”

b. To hide the products from view, set Hide disabled products to “Yes.”

“Grayed Out” Products
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3. To prevent other administrators from using the Category Products tab to change category
positions, set Hide category position input fields to “Yes.” The input fields in the Position
column disappear and the position of each item is set to zero.

Category Products with Position Input Fields Removed

Step 3: Complete the Smart Category Options

1. To ensure that any smart category rules that are in place remain current, do the following:

a. Set Rebuild on product save to “Yes.”

b. Set Rebuild on category save to “Yes.”

2. To update to categories automatically on schedule, set Rebuild on cron to “Yes.”

To determine the time interval between scheduled updates, set Cron Schedule to indicate
the length of time between updates. The character positions in the cron format represent
the number of minutes, hours, days, weeks, and months between cron updates. The default
interval is set to run every two hours, starting at midnight, as follows:

0 */2 * * *

To override the cron schedule and update the categories immediately, click the Rebuild
Category Products for Smart Categories button.
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Step 4: Define the Sorting Order

1. To determine where new products are added by smart category rules in relation to other
products in the list, set New product handling to one of the following:

l Add to top

l Add to bottom

2. Enter a number in the Minimum stock threshold field to establish a section at the top of a
sorted list that contains products with quantities that are below the threshold.

Products that are in stock, but below the threshold are sorted separately from the rest of
the list, and appear at the top of the list in ascending order. Products with the lowest
quantities in stock have the highest placement in the list.

3. Enter a number of months from 1 – 12 in the Best seller data period field, to determine
the sort order of products based on the monthly aggregation of Bestsellers report data. The
default value is 6.

4. Enter the name of the Color attribute code to use to sort products by color. The default
attribute name is color.

5. On separate lines in the Color order box, enter each color value that you want to use as a
sorting parameter.

Color values are case sensitive, and the spelling must match the value that is entered in
the Manage Labels and Options section of the color attribute.

6. When complete, click the Save Config button.

7. When prompted to refresh the cache, click the Cache Management link. Then, select the
checkbox of each invalid cache, and click Submit.
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Visual Merchandising Options
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Category Options
The position of products in the category can be specified manually by dragging and
dropping products into position in the Visual Merchandiser window, or by applying a
predefined sort order.

The Visual Merchandiser category options can be set up separately for each store view. The
options determine the selection of products, their relative position in the list, and the
attributes that are available for use with smart category rules.

Visual Merchandiser Category Setup

Process Overview:
Step 1: Set the Scope of the Configuration
Step 2: Set Up theOptions
Step 3: Save, Refresh, and Verify
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Step 1: Set the Scope of the Configuration

1. On Admin menu, select Catalog > Manage Categories.

2. To set the scope of the configuration, set Choose Store View in the upper-left corner to the
store view where the settings apply.

3. In the category tree on the left, select the category that you want to edit.

Step 2: Set Up the Options

1. Click the Visual Merchandiser tab.

2. If you want to Only include products matched by rules, select “Yes.” Otherwise, select
“No.” To learn more, see: Smart Category Rules.

3. In the Hero Products field, enter the SKU of each product that you want to appear at the
top of the list. To learn more, see: Hero Products.

4. Set Automatic sort to one of the following:

l None

l Move best sellers to top

l Move low stock to top

l Move out of stock to bottom

l Special price to top

l Special price to bottom

l Newest products first

l Highest margin first

l Sort by color

Automatic sort overrides and resets any drag-and-drop positions that were set manually in
the Visual Merchandiser window.

Visual Merchandiser Options
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Step 3: Save, Refresh, and Verify

1. When complete, click the Save Category button.

2. When prompted to refresh the cache, click the Cache Management link. Then, select the
checkbox of each invalid cache, and click Submit.

3. On the Admin menu, select Catalog > Categories > Manage Categories. Select the
category you were working on, and click the Visual Merchandiser tab to return to the
setup.

4. To test the results, click the Show Visual Merchandiser button.

If the merchandiser window doesn’t appear, it might be minimized. Hover over the browser
icon in the taskbar at the bottom of the screen, and click the thumbnail to open the
merchandiser window.

Show Visual Merchandiser

5. Verify that the product selection, hero products, sorting, and smart category logic work
correctly. If you need to make adjustments, change the settings and try again.

FIELD DESCRIPTION

Only include products
matched by rules

Determines if the list includes only products that arematched by
promotional rules. Options include: Yes / No

Hero Products Identifies “hero” products that always appear at the top of the list.
Enter the SKU of each “hero” product, separated by a comma.

Automatic sort Determines the order that the list is automatically sorted. When a
category is set to automatically sort, any drag-and-drop positions
are reset. Options include:

Field Descriptions
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FIELD DESCRIPTION

None No automatic sorting order is specified.

Move best sellers
to top

Products that appear in the store’s
monthy aggregation of bestsellers
appear at the top of the list.

Move low stock to
top

Products with quantities lower than the
minimum threshold appear at the top of
the list in ascending order. Products with
the lowest quantities appear first.

Move out of stock
to bottom

Products that have reached the out of
stock threshold appear at the bottom of
the list.

Special price to top Products with special prices appear at
the top of the list.

Special price to
bottom

Products with special prices appear at
the bottom of the list.

Newest products
first

Products are sorted by age, with the
newest products at the top of the list.

Highest margin
first

Products with the highest profit margins
appear at the top of the list.

Sort by color Products are sorted by color, based on a
list of colors that you define.

Field Descriptions (cont.)
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Hero Products
Hero products are identified by SKU and appear in a special section at the top of the
merchandiser window. They can be dragged and dropped to new positions only within the
Hero Products section. Unlike other products in the category, hero products do not have
Move to Top and Move to Bottom arrows.

Hero Products in Merchandiser Window
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To assign hero products:

1. On the Visual Merchandiser tab under Options, use one of the following methods do obtain
the SKUs you need.

Method 1: Download the SKUs

1. On the Visual Merchandiser tab, click the Show Visual Merchandiser button.

2. At the top of the merchandiser window, set the Options control to “”Download SKUs.”
Then, click the Submit button.

Download SKUs

3. When prompted to open or save the file, click Open. You now have a list of SKUs in
your spreadsheet that you can use for reference.

Downloaded SKUs
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Method 2: Use the Products Tab

1. Click the Products tab. The SKU column is to the right of the product name.

Category Products Tab

2. Use the filter controls to find the SKUs you need. Then, return to the Virtual
Merchandiser tab.

2. Enter the SKUs in the Hero Products field, separated by commas. The hero products
appear in the order that the SKUs are entered.

3. When complete, click the Save Category button.

4. Click the Visual Merchandiser tab. Then, click the Show Visual Merchandiser button to
see how they look.
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Smart Category Rules
Smart category rules dynamically change the product selection according to a set of
conditions. Each category can have one smart category rule, but a single rule can have
many conditions.

You can show only the products that meet the conditions of the rule, or add them to the
list of products already in the category. For example, you can create a smart category for a
specific brand. Products of the same brand are automatically added, even if they’re not
assigned to the same category. You can add as many conditions to the expression as
needed to describe the products to include.

Each condition has an attribute, value, and logical operator. Only attributes with the “Use
in Product Listing” property set to “Yes” are available for smart category rules. If you want
to use an attribute that is not included in the list, open the attribute in edit mode, and set
“Use in Product Listing” to “Yes.”

Although Date attributes are not supported, you can use the Date Created or Date Modified
attributes to define a date or range of dates. For example, to include only products that
were created during the past week, set Date Created to a value of “<7.”

Add Attribute
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To create a smart rule:

1. From the category’s Visual Merchandiser tab, click the Add Attribute button. Then, do the
following:

a. Select the Attribute you want to base the condition upon.

Attributes Available for Smart Category Rules

b. Enter the Value to be matched.

c. Select the Logic that is needed to form the expression.

2. Repeat this process for each attribute needed to describe the condition(s) to be met. For
example, to match products that were created between 7 and 30 days ago, do the following:

a. Set Date Created to “<30.”

b. Set Logic to “AND.”

c. Set Date Modified to “>7.”

Smart Category Attribute Date Range

3. To limit the product selection to only those that meet the conditions of the rule, set the
Only include products matched by rules option to “Yes.”
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Only Include Products Matched by Rules

4. To select a sort order that is automatically applied as the product selection changes, set
Automatic Sort to one of the following:

l Move out of stock to bottom

l Special price to top

l Special price to bottom

Automatic Sort

5. When complete, click the Save Category button.
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FIELD DESCRIPTION

Attribute Identifies the attributes upon which the logic of the smart
category is based. To includemultiple attributes, click the Add
Attribute button. Options include:

Apply MAP Applies theMinimum Advertised Price to
products in the smart category.

Clone Category
IDs

Gives you the ability to dynamically
include products from another category.
Enter the ID of the category to be cloned
into the Value field. For multiple
categories, separate each ID with a
comma.

Date Created
(days ago)

Includes products that were created
within the number of days specified.

DateModified
(days ago)

Includes products that were updated
within the number of days specified.

Image Label Includes products based on the Image
Label value.

Manufacturer’s
Suggested Retail
Price

Includes products that match theMSRP
value specified.

Name Includes products that match the product
Name value specified.

Price Includes products that match the Price
value specified.

Small Image Includes products that match the Small
Image value specified.

URL Key Includes products that match the URL
Key value specified.

Date Created
(days ago)

Includes products that were created
within the number of days specified.

Status Includes products that match the Status
value specified. Available values:
Enabled / Disabled

Field Descriptions
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FIELD DESCRIPTION

Thumbnail Includes products that match the
Thumbnail value specified.

Thumbnail Label Includes products that match the
Thumbnail Label value specified.

URL Key Includes products that match the URL
Key value specified.

Apply MAP Applies theMinimum Advertised Price to
products in the smart category.

Clone Category
IDs

Gives you the ability to dynamically
include products from another category.
Enter the ID of the category to be cloned
into the Value field. For multiple
categories, separate each ID with a
comma.

Date Created
(days ago)

Includes products that were created
within the number of days specified.

DateModified
(days ago)

Includes products that were updated
within the number of days specified.

Image Label Includes products based on the Image
Label value.

Manufacturer’s
Suggested Retail
Price

Includes products that match theMSRP
value specified.

Name Includes products that match the product
Name value specified.

Price Includes products that match the Price
value specified.

Short Description Includes products that match the Short
Description value specified.

Small Image Includes products that match the Small
Image value specified.

Small Image Label Includes products that match the Small
Image Label value specified.

Field Descriptions (cont.)
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FIELD DESCRIPTION

Special Price Includes products that match the Special
Price value specified.

Status Includes products that match the Status
value specified. Available values:
Enabled / Disabled

Thumbnail Includes products that match the
Thumbnail value specified.

Thumbnail Label Includes products that match the
Thumbnail Label value specified.

URL Key Includes products that match the URL
Key value specified.

Value Specifies the value that the attribute that is needed tomeet the
condition. Unless an operator is specified, the default “equal to”
operator is applied. Operators include:

= Equal to

> Greater than

< Less than

! Not equal to

>= Greater than or equal to

<= Less than or equal to

* Wildcard that can be used tomatch text-
based attributes with multiple values.
For example, *Blazer* matches any
product name that includes the word
Blazer.

Logic Specifies the logical operator that is needed to describemultiple
conditions. Options include: AND / OR

Field Descriptions (cont.)
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Rebuilding Smart Categories
Whenever the attribute values of a product change, the smart rules that are in effect can
alter the position of the SKU in product listings. Based on the value of the attributes, a
product might be included, or excluded from the dynamically-generated list of products
that is assigned to the category.

Because the process is subject to continual change, categories are scheduled to be rebuilt on
an ongoing basis. Changes are queued, and the categories are rebuilt according to cron
schedule. Changes can also be queued whenever a category or product is saved. When
necessary, you can override the scheduled cron job to initiate a rebuild of the category. Due
to the nature of the scheduled task, there might be a delay of about five minutes before the
update is reflected in the storefront.

The Rebuild Visual Merchandiser Categories button in Cache Management can be used at
any time to initiate a rebuild of smart category products. The same override can be initiated
from the Visual Merchandiser configuration.

Rebuild Visual Merchandiser Smart Categories

Method 1: From Cache Management

1. On the Admin menu, select System > Cache Management.

2. On the Cache Storage Management page, under Additional Cache Management, click the
Rebuild Smart Category Products button.
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Method 2: From Visual Merchandiser Configuration

1. On the Admin menu, select System > Configuration.

2. In the panel on the left under Catalog, select Catalog. Then, click to expand the Visual
Merchandising Options section and do the following:

a. Verify that Rebuild on product save is set to “Yes.”

b. Verify that Rebuild on category save is set to “Yes.”

Rebuild on Save

c. Under Cron schedule, click the Rebuild Category Products for Smart Categories
button.

Rebuild Category Products for Smart Categories

3. When complete, click the Save Config button.
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Using theMerchandiser Window
The merchandiser window is where Visual Merchandiser gets its name. Its visual drag-and-
drop interface makes it easy to arrange and rearrange products in any category.

Process Overview:
Step 1: Define the Scope and Product Selection
Step 2: Sort the List
Step 3: Arrange the Products
Step 4: Save Changes and Refresh

Step 1: Define the Scope and Product Selection

1. On Admin menu, select Catalog > Manage Categories.

2. In the category tree on the left, select the category that you want to edit.

3. Click the Visual Merchandiser tab.

4. Click the Show Visual Merchandiser button.

Visual Merchandiser appears in a pop-up window, and lists the products in the category
selected. You can drag the window to another position on the screen, but it cannot be
resized.

If the category was previously set to sort automatically, all product positions are reset
when the Merchandiser window opens.

5. To set the scope of the configuration, set the Storefronts control at the top of the window
to the website or store view where the settings apply.

Set the Configuration Scope
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6. To remove a product from the category, click to select the product. Then, click the Detach
button in the lower-left corner of the product block. The product is removed from the

category, but remains in the catalog. The change does not become permanent until you
click the Save positions button.

Detach Product

Step 2: Sort the List

1. Set the Options control at the top of the window to one of the following:

l Move best sellers to top

l Move low stock to top

l Move out of stock to bottom

l Special price to top

l Special price to bottom

l Newest products first

l Highest margin first

l Sort by color

The selected sort order overrides and resets any drag-and-drop positions that were
manually set.

2. Resort the list as many times as needed while working in the merchandiser window.
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Sort Options

Step 3: Arrange the Products

Method 1: Drag and Drop

Drag and drop cannot be used on hero products, because they have a fixed position at the
top of the list.

1. Click the product you want to move, and hold the mouse button down. To select multiple
products, do either of the following:

l To select a contiguous group of products, hold down the Shift key, and click the first
and last product in the group.

l To select multiple scattered products, hold down the Ctrl key, and click each product.

The header of the selected product(s) turns blue, and the cross hairs cursor appears.

2. Drag the product(s) to the new position, and release the mouse button.
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Drag and Drop Product into Position

Method 2: Move to Top / Bottom

1. To move a product to the top of the list, click the Move Top arrow at the lower-right

corner of the product block.

2. To move a product to the bottom of the list, click the Move Bottom arrow, at the lower-

right corner of the product block.

Step 4: Save Changes and Refresh

1. To save the updated product positions, click the Save Positions button.

2. When prompted to refresh the cache, click the Cache Management link. Then, select the
checkbox of each invalid cache, and click Submit.
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CONTROL DESCRIPTION

Move to Top Moves the selected product(s) to the top of the list.

Move to Bottom Moves the selected product(s) to the bottom of the list.

Detach from
Category

Removes the product from the category. The product remains in
the catalog, but is no longer assigned to the category.

Product Controls

CONTROL DESCRIPTION

Storefronts Sets the scope of themerchandiser window. Select the website
where the settings to apply.

Options The sort options provide several predefined ways to sort the list.
You can reapply a sorting order as needed after you have dragged
and dropped products into new positions. The selected sort order is
reapplied whenever the cron schedule is triggered to update smart
category rules.

Sort Options

Move best sellers
to top

Products that appear in the store’s monthy
aggregation of bestsellers aremoved to the
top of the list.

Move low stock to
top

Products with quantities lower than the
minimum threshold appear at the top of the
list in ascending order. Products with the
lowest quantities appear first.

Move out of stock
to bottom

Products that have reached the out of
stock threshold aremoved to the bottom of
the list.

Special price to top Products with special prices appear at the
top of the list.

Special price to
bottom

Products with special prices appear at the
bottom of the list.

Newest products
first

The newest products appear at the top of
the list.

Window Controls
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CONTROL DESCRIPTION

Highest margin
first

Products with the highest profit margins
appear at the top of the list.

Sort by color Products are sorted by color, based on a
list of colors that you define.

Utilities

Mass Product
Assignment

Assign multiple products to the
category, or remove multiple products
from the category.

Download SKUs Downloads the SKUs in the category to a
CSV file.

Submit Applies the selected option to the products in themerchandiser
window.

Search Locates products in the catalog, based on name or SKU. The
search results appear in a list below the search box. Matching
products that are already in the category can bemoved to the top of
the list. Products that are not in the category can be assigned to the
category.

Save Positions The Save Positions button in the upper-left corner of the
merchandiser window saves any changes made to the category
and product positions.

Window Controls (cont.)
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Product Search
The Search box in the upper-right corner of the merchandiser window can be used to find
products in the catalog, based on name or SKU. For products that are already in the
category, you can move them to the top of the merchandiser list. For products in other
categories, you can add them to the category, so they appear in the merchandiser window.
Even if a product is not yet assigned to a category, you can use Visual Merchandiser to add
the product to a category.

Visual Merchandiser Search

To search for products in the store catalog:

1. In the Search box, do one of the following:

l Enter the Name, or partial name of the product(s) that you want to find.

l Enter the SKU, or partial SKU of the product(s) that you want to find.

2. Click the Search button.

The list of search results appears below. If there are many matches, a vertical scroll bar
appears. Any product that is already in the category is marked with a green Move to Top

arrow. Products in other categories have a green Add to Category button.
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Visual Merchandiser Search Results

3. To move a product in the category to the top of the list, click the Move to Top arrow. The

results show immediately in the merchandiser window.

If you have a large catalog, sometimes moving a product to the top of the list can make it
easier to drag and drop it into another position.

4. To add a product from another category, click the Add to Category button.

The new product appears in the upper-left position of the merchandiser window.

Product Added to Category

5. To save both category assignment and position changes, click the Save Position button.
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Download SKUs
The Download SKUs utility is an easy way to generate a list of all the SKUs in the category.

To download SKUs:
1. On the Visual Merchandiser tab, click the Show Visual Merchandiser button.

2. At the top of the merchandiser window, set the Options control to “”Download SKUs.”
Then, click the Submit button.

Download SKUs

3. When prompted to open or save the file, click Open. You now have a list of SKUs in
your spreadsheet that you can use.

Downloaded SKUs
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Clone Category IDs
When setting up a smart category rule, you can dynamically clone products from multiple
categories, based on category ID.

Clone Category IDs

To clone a category:

1. To determine the category IDs that you need, click the category in the category tree. The
category ID is at the top of the page, in parentheses after the category name.

2. Return to the original category you were working on, and click the Visual Merchandiser
tab.

3. In the Smart Category section, click the Add Attribute button. Then, do the following:

4. Under Attribute, select “Clone category ID.”

5. Under Value, enter the ID of the category you want to clone. To clone multiple categories,
separate each ID with a comma.

6. You can add more conditions as needed, to complete the rule.
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Mass Product Assignment
Visual Merchandiser gives you the ability to assign multiple products to the category, as
well as remove multiple products from the category. This can be a real time saver if you
work with a large number of products.

Mass Product Assignment

To assign multiple products to the category:

1. Before you begin, prepare the list of the SKUs that you want to assign to the category.

2. At the top of the merchandiser window, set the Options control to “Mass Product
Assignment.” Then, click the Submit button.

3. When the box appears, enter each SKU to be assigned on a separate line. The SKUs can be
typed or pasted in to the box.

Enter SKUs to be Assigned
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4. To assign the products to the current category, click the Assign button.

The newly added products appear in upper-left of the merchandiser window.

Multiple Products Added to Category

5. To make the category assignments permanent, click the Save positions button.

To remove multiple products from the category:

1. At the top of the merchandiser window, set the Options control to “Mass Product
Assignment.” Then, click the Submit button.

2. When the box appears, enter each SKU to be removed from the category on a separate line.
The SKUs can be typed or pasted in to the box.

3. Click the Remove Products button.

The products are removed from the merchandiser window.

4. To make the change permanent, click the Save positions button.
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Catalog Price Rules
Catalog price rules can be used to selectively put products on sale under certain conditions.
Catalog price rules do not use coupon codes, because they are triggered before a product is
placed into the shopping cart.

Catalog Rules

Process Overview:
Step 1: Add a New Rule
Step 2: Define the Conditions
Step 3: Define the Actions
Step 4: Add Related Banners
Step 5: Apply the Rule

Step 1: Add a New Rule

1. On the Admin menu, select Promotions > Catalog Price Rules.

2. In the upper-right corner, click the Add New button.

The options in the panel on the left include Rule Information, Conditions, Actions, and
Related Banners.
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Rule Information

3. On the Rule Information page, do the following:

a. Complete the Rule Name and Description fields. These fields are for your internal
reference only.

b. Set Status to “Active.”

c. Select theWebsites where the rule will be available.

d. Select the Customer Groups to which this rule applies.

To select multiple options, hold down the Ctrl key (PC) or Command key (Mac), and click
each option.

e. Set From Date and To Date to define the range of dates when the rule will be in effect.
If you leave the dates blank, the rule is enabled as soon as the price rule is saved.

f. Enter a number to establish the Priority of this rule in relation to other rules.
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Step 2: Define the Conditions

Most of the available conditions are based upon existing attribute values. If you want to
apply the rule to all products, leave the conditions blank.

1. In the panel on the left, select Conditions. The first rule begins:

If ALL of these conditions are TRUE:

The statement has two underlined links, which when clicked, display the options for that
part of the statement. If you save the condition without making additional selections, the
rule will apply to all products.

l Click the ALL link, and select “ALL” or “ANY.”

l Click the TRUE link and select “TRUE” or “FALSE.”

l Leave the condition unchanged to apply the rule to all products.

You can create different conditions by changing the combination of these values.

Condition - Line 1

2. Click the Add button at the beginning of the next line.

a. In the list under Product Attribute, select the attribute that you want to use as the
basis of the condition. For this example, the selected condition is “Attribute Set.”

Condition Line 2, Part 1

For an attribute to appear in the list, it must be configured to be used in promo rule
conditions. To learn more, see: Attribute Frontend Properties.
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The selected condition appears in the statement, followed by two more underlined
links. The statement now says:

If ALL of these conditions are TRUE:

Attribute Set is …

b. Click the is link, and select either “IS” or “IS NOT.”

c. Then, click the ... “more” link, and choose the attribute set upon which the condition
is based.

Condition Line 2, Part 3

The selected item appears in the statement to complete the condition.

If ALL of these conditions are TRUE:

Attribute Set is Eyewear

3. To add another line to the statement, click the Add button, and choose one of the

following:

l Conditions Combination

l Product Attribute

Then, repeat the process until the condition is complete.

If at any time you want to delete part of the statement, click the Delete button at the

end of the line.
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Step 3: Define the Actions

1. In the panel on the left, select Actions.

Actions

2. In the Update Prices Using the Following Conditions section, do the following:

a. Set Apply to one of the following options:

By Percentage of
the Original Price

Discounts item by subtracting a percentage from the original
price. For example:

Enter 10 in Discount Amount for an updated price that is 10%
less than the original price.

By Fixed Amount Discounts item by subtracting a fixed amount from original
price. For example:

Enter 10 in Discount Amount for an updated price that is $10
less than the original price.

To Percentage of
the Original Price

Discounts item by defining the final price based on percentage.
For example:

Enter 10 in Discount Amount for an updated price that is 10%
of the original price.

To Fixed Amount Sets the price to a fixed amount.

b. Do one of the following:

l Enter the Discount Amount.

l To apply the discount amount to associated products, set Enable Discount to
Subproducts to “Yes.” Then, enter the Discount Amount to apply.

3. If you want to stop the processing of other rules after this rule has been applied, set Stop
Further Rules Processing to “Yes.” This safeguard prevents customers from receiving
multiple discounts for the same product.

4. Click the Save and Continue Edit button to save your changes.
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Step 4: Add Related Banners

1. In the panel on the left, select Related Banners.

2. In the list, select the checkbox of each banner that you want to associate with this price
rule.

If your banners don’t appear in the table, click the Reset Filter button to clear the previous
filter rules.

Related Banners

Step 5: Apply the Rule

As new rules are added, the prices and the priorities are recalculated accordingly.

To apply a new rule immediately, do one of the following:

l Click the Save and Apply button.

l From the Catalog Price Rules list, click the Apply Rules button.

When you create a new price rule, it might take an hour or so for it to become available.
Allow enough time for it to get into the system. Then, test the rule to make sure that it
works correctly. Unless otherwise specified, price rules are automatically processed with
other system rules each night.
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Price Rule with Multiple SKUs
A single price rule can be applied to multiple SKUs, which makes it possible to create a
variety of promotions based on a product, brand, or category. In the following illustration,
multiple products are selected for a catalog price rule.

Selecting Multiple SKUs for a Price Rule Condition

To apply a price rule to multiple SKUs:

1. On the Admin menu, select Promotions > Catalog Price Rules.

2. Do one of the following:

l Follow the instructions to create a catalog price rule.

l In the list, click to open the catalog price rule that you want to change.

3. In the panel on the left, select Conditions. Then, do the following:

a. In the first line, set the first parameter to “ANY.”

If ANY of these conditions are TRUE

b. If the price rule doesn't have a line for SKU, Click the Add button at the beginning

of the next line. Then, in the list under Product Attribute, select SKU.



CHAPTER 24:  Promotions Catalog Price Rules

Choose the Condition

c. Click the… “more” link to display more options. Then, click the Chooser button to

display the list of available products.

SKU IS

d. In the list, select the checkbox of each product that you want to include. Then, click
the Select button to add the SKUs to the condition.

Multiple SKUs Added to Condition

4. Complete the rule, including any Actions to be taken when the conditions are met.

5. To apply the rule, click the Save Rule button.

When you create a new price rule, it might take an hour or so for it to become available.
Allow enough time for it to get into the system. Then, test the rule to make sure that it
works correctly. Unless otherwise specified, price rules are automatically processed with
other system rules each night.
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Shopping Cart Price Rules
Shopping cart price rules create discounts for orders at the checkout level, based on a set of
conditions. The discount can be applied automatically when the conditions are met, or be
applied when the customer enters a valid coupon code. When applied, the discount
appears on the shopping cart page under the subtotal.

Once established, the price rule can be used as needed for a season or promotion by
changing its status and date range.

Process Overview:
Step 1: Add a New Rule
Step 2: Define the Conditions
Step 3: Define the Actions
Step 4: Complete the Labels
Step 5: Add Related Banners (Optional)
Step 6: Apply the Rule

Step 1: Add a New Rule

1. On the Admin menu, select Promotions > Shopping Cart Price Rules. Then, click the
Add New Rule button.

Shopping Cart Price Rules
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The options in the panel on the left include Rule Information, Conditions, Actions, Labels,
and Related Banners.

Shopping Cart Price Rule Settings

2. Under General Information, complete the Rule Name and Description. These fields are for
internal reference only.

3. If you want the rule to go into effect immediately, set Status to “Active.”

4. To establish the scope of the rule, do the following:

a. Select theWebsites where the promotion is to be available.

b. Select the Customer Groups to which the promotion applies.

To make the promotion available only to registered customers, do not select the
“NOT LOGGED IN” option.

To select multiple options, hold down the Ctrl key (PC) or Command key (Mac), and
click each option.

5. To associate a coupon with the price rule, set Coupon to “Specific Coupon.” Then, do the
following:

a. Enter a numeric Coupon Code that the customer must enter to receive the discount.

b. To set a limit on the number of times the coupon can be used, complete the following:
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Uses per Coupon Determines how many times the coupon code can be used. If
there is no limit, leave the field blank.

Uses per Customer Determines how many times the coupon code can be used by
the same registered customer who belongs to any of the selected
customer groups. The setting does not apply to guest shoppers
who are members of the NOT LOGGED IN customer group, or
to customers who shop without logging in to their accounts. If
there is no limit, leave the field blank.

6. To define the “good through” date range for the promotion, do the following:

a. Click the Calendar button next to the From Date field, and choose the first date.
The promotion will start at the beginning of that day.

b. Click the Calendar button next to the To Date field, and choose the last date. The
promotion will stop at the end of that day.

7. Enter a number to determine the Priority of this price rule in relation to the Action settings
of other price rules that might be active at the same time. (Number 1 has the highest
priority.)

8. To apply the rule to published listings in RSS feeds, set Public In RSS Feed to “Yes.”

Step 2: Define the Conditions

In this step, the conditions are described that must be met for an order to qualify for the
promotion. The price rule goes into action whenever the set of conditions is met.

1. In the panel on the left, select Conditions. The first rule appears by default, and states:

If ALL of these conditions are TRUE:

The statement has two underlined links which when clicked, display the selection of
options for that part of the statement. You can create different conditions by changing the
combination of these values. Do any of the following:

l Click the ALL link, and select “ALL” or “ANY.”

l Click the TRUE link and select “TRUE” or “FALSE.”

l Leave the condition unchanged to apply the rule to all products.

Condition - Line 1
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2. Click the Add button at the beginning of the next line. Then, choose one of the

following options from the list to describe the condition that you want to set for the rule.

l Product attribute combination

l Products subselection

l Conditions combination

l Cart Attribute

Condition - Line 2, Part 1

Example 1: Regional Price Rule

To create a regional price rule, select one of the following cart attributes:

l Shipping Postcode

l Shipping Region

l Shipping State/Province

l Shipping Country

Example 2: Shopping Cart Totals

To base the condition on shopping cart totals, select one of the following cart attributes:

l Subtotal

l Total Items Quantity

l Total Weight

When you make a selection, the basic structure of the statement appears in the box with
additional links to mark where you can select information. Each underlined word is a
building block that describes a different aspect of the condition.

3. In the list under Product Attribute, select the attribute upon which the condition is based.
For this example, the selected condition is Attribute Set.
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Condition - Line 2, Part 1

For an attribute to appear in the list, its Use for Promo Rules Conditions property must be
set to “Yes.”

The condition appears in the statement, followed by two more underlined links. The
statement now says:

Condition - Line 2, Part 2

If ALL of these conditions are TRUE:

If an item is FOUND in the cart with ALL of these conditions true

Attribute Set is …

4. Click the is link, and select either “IS” or “IS NOT” to describe the condition to be met. In
this example, the options are “IS” and “IS NOT.”

5. Click the ... “more” link, and choose the attribute set upon which the condition is based.
The selected item appears in the statement to complete the condition.

Completed Condition
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If ALL of these conditions are TRUE:

Attribute Set is Electronics

6. If you want to add more conditions, click the Add button. Then, choose one of the

following:

l Conditions Combination

l Product Attribute

Then, repeat the process until the condition is complete.

To delete part of the statement, click the Delete button at the end of the line.

Step 3: Define the Actions

The shopping cart price rule actions describe how prices are updated when the conditions
of the rule are met.

Shopping Cart Price Rule Actions

1. In the panel on the left, select Actions. Then, set Apply to one of the following discount
options:

Percent of product
price discount

Discounts item by subtracting a percentage from the original price.
The discount applies to each qualifying item in the cart. For
example:

Enter 10 in Discount Amount for an updated price that is 10% less
than the original price.

Fixed amount
discount

Discounts item by subtracting a fixed amount from original price.
The discount applies to each qualifying item in the cart. For
example:
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Enter 10 in Discount Amount for an updated price that is $10 less
than the original price.

Fixed amount
discount for whole
cart

Discounts the entire cart by subtracting a percentage from the cart
total. For example:

Enter 10 in Discount Amount to subtract 10% from the cart total.

Buy X get Y free Defines a quantity that the customer must purchase to receive a
quantity for free. (The Discount Amount is Y.)

2. Enter the Discount Amount as a number, without symbols. For example, depending on
the discount option selected, the number 10 might indicate a percentage, a fixed amount,
or a quantity of items.

3. In the Maximum Qty Discount is Applied To field, enter the largest number of the same
product that can qualify for the discount.

4. For a “Buy X Get Y Free” promotion, in the Discount Qty Step (Buy X) field, enter the
number of products that must be purchased to receive the number of free products
represented by “Y.”

5. To include the cost of shipping in the discount, set Apply to Shipping Amount to “Yes,”

6. To determine how free shipping is applied, set Free Shipping to one of the following:

No Free shipping is not available for the promotion.

For matching
items only

Free shipping is available only for specific items in the cart that
match the rule.

For shipment with
matching items

Free shipping is available for the entire cart when a coupon that is
based on the rule is used.

7. Set Stop Further Rules Processing to “Yes” to stop processing other rules as soon as this
one is applied. This safeguard prevents customers from receiving multiple discounts for the
same purchase.

8. To define an additional action that applies to specific items in the cart, only when a
specific set of conditions is met, click the Add button. Then, choose an item from the

following sections in the list:

l Cart item attribute

l Price in cart

l Quantity in cart

l Row total in cart

l Product attribute (from all available in your catalog)

Add as many levels as you need to describe the conditions to be met.
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9. When complete, click the Save Rule button.

Step 4: Complete the Labels

The label appears on the order below the subtotal to identify the discount. You can enter a
default label for all store views, or enter a different label for each view.

1. In the panel on the left, select Labels.

2. In the Default Label section, enter the text for the Default Rule Label for All Store Views.

Default Label

3. In the Store View Specific Labels section, enter the label text for each store view. For
example, if each store view is in a different language, enter the label translation for each
view.

Store View Specific Labels

Step 5: Add Related Banners

Any banners that are associated with the promotion appear in the store when the
conditions of the price rule are met.

1. In the panel on the left, select Related Banners.

2. In the list, select the checkbox of each banner that you want to associate with the price
rule.
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Shopping Cart Price Rule - Related Banners

If your banners don’t appear in the table, click the Reset Filter button to clear the previous
filter rules.

Step 6: Apply the Rule

1. When complete, click the Save Rule button.

2. When you create a new price rule, it might take an hour or so for it to become available.
Allow enough time for it to get into the system. Then, test the rule to make sure that it
works correctly. Unless otherwise specified, price rules are automatically processed with
other system rules each night. As new rules are added, Magento recalculates the prices and
the priorities accordingly.
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FIELD DESCRIPTION

RULE INFORMATION

Rule Name (Required) The name of the rule is for internal reference.

Description A description of the rule should include the purpose of the rule,
and explain how it is used.

Status (Required) Determines if the rule is currently active in the store.
Options include: Active / Inactive

Websites (Required) Identifies the websites where the rule can be used.

Customer Groups (Required) Identifies the customer groups where the rule applies.

Coupon (Required) Indicates if a coupon is associated with the rule.
Options include:

No Coupon No coupon is associated with the rule.

Specific Coupon A specific coupon is associated with the
rule.

Coupon
Code

When prompted,
enter the Coupon
Code that the
customermust enter
to take advantage of
the promotion.

Use Auto
Generation

Select the checkbox
to automatically
generatemultiple
coupon codes which
can be used with the
promotion.

Uses per Coupon The number of times the coupon code can be used.

Field Descriptions
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FIELD DESCRIPTION

Uses per Customer Determines how many times the coupon code can be used by
the same registered customers who belongs to any of the
selected customer groups. The setting does not apply to guest
shoppers who aremembers of the NOT LOGGED IN customer
group, or to customers who shop without logging in to their
accounts. If there is no limit, leave the field blank.

From Date The first date in the “good through” period when the coupon can
be used.

To Date The last date in the “good through” period when the coupon can
be used.

Priority A number that indicates the priority of this rule in relation to
others. The highest priority is number 1.

Public in RSS Feed Determines if the promotion is included in your store’s public
RSS feed. Options include: Yes / No.

ACTIONS

Apply Determines the type of calculation that is applied to the
purchase. Options include:

Percent of product
price discount

Discounts item by subtracting a
percentage from the original price.
For example: Enter 10 in Discount
Amount for an updated price that is 10%
less than the original price.

Fixed amount
discount

Discounts item by subtracting a fixed
amount from original price.
For example: Enter 10 in Discount
Amount for an updated price that is $10
less than the original price.

Fixed amount
discount for whole
cart

Discounts the entire cart by subtracting
a percentage from the cart total.
For example: Enter 10 in Discount
Amount to subtract 10% from the cart
total.

Field Descriptions (cont.)
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FIELD DESCRIPTION

Buy X Get Y Free
(discount amount is
Y)

Defines a quantity that the customer
must purchase to receive a quantity for
free. (The Discount Amount is Y.)

Discount Amount (Required) The amount of discount offered is entered as a
number, without symbols. Depending on the discount option, the
number 10might denote a percentage, fixed amount, or quantity.

MaximumQty Discount is
Applied To

Determines themaximum number of products that the discount
can be applied to in the same purchase.

Discount Qty Step (Buy X) In a “Buy X Get Y Free” promotion, determines the number of
products that must be purchased to receive “Y” free.

Apply to Shipping Amount Determines if the discount can be applied to the cost of shipping.
Options include: Yes / No.

Free Shipping Determines if free shipping is included in the promotion, and if so,
for which items. Options include:

No Free shipping is not available for orders
that qualify for the promotion.

For matching items
only

Free shipping is available only for items
in the cart that qualify for the promotion.

For shipment with
matching items

Free shipping is available for the entire
cart if any item qualifies for the
promotion.

Stop Further Rules
Processing

Determines if additional promotions can be applied to this
purchase. To prevent a single purchase from receivingmultiple
discounts, select “Yes.” Options include: Yes / No

Add Reward Points Determines the number of reward points earned when the rule is
applied.

DEFAULT LABEL

Default Rule Label for All
Store Views

A default label that identifies the discount for all store views.

Store View Specific Labels If applicable, enter a different label to identify the discount for
each store view.

Field Descriptions (cont.)
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Coupon Codes
Coupons codes can be associated with shopping cart price rules to apply a discount when a
set of conditions is met. For example, a coupon code can be created for a specific customer
group, or for anyone who makes a purchase over a certain amount.

In-store Coupon for Mobile Users

Here are a few ways that you can use coupons in your store:

l Email coupons to customers

l Produce printed coupons

l Create in-store coupons for mobile users

Coupon codes can be sent by email, or included in newsletters, catalogs, and
advertisements. You can even create in-store coupons with a quick response code that
shoppers can scan with their smart phones. The QR code links to a page on your site with
more information about the promotion.

To apply the coupon to a purchase, the customer enters the coupon code during checkout
from the shopping cart page of your site, or possibly at the cash register of your “brick and
mortar” store.
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Enter Coupon Code in Shopping Cart

To set up a coupon code:

1. Follow the instructions to create a shopping cart price rule.

2. On the General Information page, do the following:

a. Set Coupon to “Specific Coupon.”

b. Enter a numeric Coupon Code to be used with the promotion. If you want to auto-
generate coupon codes, select the Use Auto Generation checkbox.

c. To limit the number of times the coupon can be used, complete the following:

l Uses per Coupon

l Uses per Customer

If you leave these fields blank, there will be no limit on the number of times the coupon
can be used.

d. To make the coupon valid for a limited period of time, complete the From Date and To
Date fields. To select the date, click the Calendar button next to each field.

If you leave the date range empty, the rule will never expire.
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Price Rule Coupon Code Settings

3. Follow the standard instructions to complete the shopping cart price rule.

Auto-Generated Coupon Codes
Batches of discount coupon codes can be formatted and generated automatically. Coupon
codes can also be exported, and incorporated into other applications. For example, you
might use a series of auto-generated coupon codes to produce printed coupons with unique
codes.

Generated Coupon Codes



CHAPTER 24:  Promotions Shopping Cart Price Rules

To configure auto-generated codes:

1. On the Admin menu, select System > Configuration.

2. In the panel on the left under Customers, select Promotions. Then, click to expand the
Auto Generated Specific Coupon Codes section.

Auto Generated Specific Coupon Codes

3. To create a specific format for your codes, enter the following:

l Code Length

l Code Format

l Code Prefix

l Code Suffix

l Dash Every X Characters

4. When complete, click the Save Config button.

These settings can be overridden from the Shopping Cart Price Rule page.

To generate a batch of coupon codes:

1. On the Admin menu, select Promotions > Shopping Cart Price Rules.

2. Select an existing rule, or create a new one.

3. Set Coupon to “Specific Coupon.” Then, do the following:

a. Select the Use Auto Generation checkbox.

b. Complete the other rule settings as needed.

Important! Shopping cart price rules with auto-generated coupon codes cannot be used in
automated email reminders. If a shopping cart price rule for a “Specific Coupon” is used in
an automated email reminder, it is automatically unassigned when the rule is saved.

4. Click the Save and Continue Editing button.

5. In the panel on the left, select Manage Coupon Codes. Then, do the following:
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a. In the Coupon Qty field, enter the number of codes to be generated.

b. Adjust the code format settings, as needed.

c. Click the Generate button.

The generated coupon codes appear in the list, with the number of times each has been
used.

To delete coupon codes:

1. In the list, select the checkbox of each code that you want to delete.

2. Set the Actions control to “Delete.”

3. Click the Submit button. When prompted, click OK to confirm.

To export coupon codes:

1. In the list of generated codes, use the filter controls at the top of each column to display
the codes that you want to export.

2. Set Export to to the file format that you want to use for the data file.

3. Click the Export button.

Coupon Report
To learn how your coupons are being used, you can run a detailed coupon usage report for
each website, store, or view.

To generate a coupon report:

1. On the Admin menu, select Reports > Sales > Coupons.

2. In the upper-right corner, set Show Report For to define the scope of the report.

3. Set the filters as needed. Then, do one of the following:

l To include coupon codes from all price rules in the report, set Shopping Cart Price Rule
to “Any.”

l To include coupon codes related to specific rules, set Shopping Cart Price Rule to
“Specified.” Then, select the rules that you want to include in the report.

4. When complete, click the Show Report button.
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Coupon Usage Report

Free Shipping Promotion
Free shipping can be offered as a promotion, either with, or without a coupon. A free
shipping coupon, or voucher, can also be applied to customer pick-up orders, so the order
can be invoiced and “shipped” to complete the workflow.

Some shipping carrier configurations give you the ability of offer free shipping based on a
minimum order. To expand upon this basic capability, you can use shopping cart price
rules to create complex conditions based on multiple product attributes, cart contents, and
customer groups.

Process Overview:
Step 1: Enable Free Shipping
Step 2: Create the Shopping Cart Price Rule
Step 3: Test the Rule
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Step 1: Enable Free Shipping

1. Enable the Free Shipping method in the configuration of your store.

2. Complete the free shipping settings for any carrier service that you want to use for free
shipping.

Step 2: Create the Shopping Cart Price Rule

1. On the Admin menu, select Promotions > Shopping Cart Price Rules.

2. Follow the steps below to set up the free shipping promotion that you want to offer.

3. When complete, click the Save Rule button.

When you create a new price rule, it might take an hour or so for it to become available.
Allow enough time for it to get into the system. Then, test the rule to make sure that it
works correctly. Unless otherwise specified, price rules are automatically processed with
other system rules each night.

Free Shipping for Any Order

1. Complete the General Information settings as follows:

a. Enter a Rule Name for internal reference.

b. Set Status to “Active.”

c. Set Website to “Main Website.” (Click to make sure the entry is selected.)

d. Select the Customer Groups to which the rule applies.

e. Do one of the following:

l To offer a free shipping promotion without a coupon, accept the default, “No
Coupon” setting.

l To use a coupon with the price rule, set Coupon to “Specific Coupon.” If necessary,
complete the instructions to set up a coupon.

2. In the panel on the left, select Actions. Then, do the following:

a. Set Apply to “Percent of product price discount.”

b. Set Apply to Shipping Amount to “Yes.”

c. Set Free Shipping to “For shipment with matching items.”
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Price Rule Action

3. In the panel on the left, select Labels. Then, do one of the following:

l Enter a Default Rule Label for All Store Views. This label is visible to the customer.

l If your store is available in multiple stores, enter a label for each view, as needed.

4. When complete, click the Save Rule button.

Free Shipping for Orders Over $Amount

1. Complete the General Information settings as follows:

a. Enter a Rule Name for internal reference.

b. Set Status to “Active.”

c. Set Website to “Main Website.” (Click to make sure the entry is selected.)

d. Select the Customer Groups to which the rule applies.

e. Do one of the following:

l To offer a free shipping promotion without a coupon, accept the default, “No
Coupon” setting.

l To use a coupon with the price rule, set Coupon to “Specific Coupon.” If necessary,
follow the instructions to set up a coupon.

2. In the panel on the left, select Conditions.

3. Click the Add button to insert a condition. Then, do the following:

a. In the list under Cart Attribute, click Subtotal.

b. Click the is link, and select “equals or greater than.”

c. Click the… “more” link, and enter a threshold value for the Subtotal, such as
100, to complete the condition.

4. In the panel on the left, select Actions. Then, do the following:

a. Set Apply to “Percent of product price discount.”
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b. Set Apply to Shipping Amount to “Yes.”

c. Set Free Shipping to “For shipment with matching items.”

5. In the panel on the left, select Labels. Then, do one of the following:

l Enter a Default Rule Label for All Store Views. The label is visible to the customer
during checkout.

l If your store is available in multiple views, enter a label for each view, as needed.

6. When complete, click the Save Rule button.

Step 3: Test the Rule

When you create a new price rule, it might take an hour or so for it to become available.
Allow enough time for it to get into the system. Then, test the rule to make sure that it
works correctly. Unless otherwise specified, price rules are automatically processed with
other system rules each night.

Buy XGet Y Free
This example shows how to set up a shopping cart price rule for a “Buy X, Get Y Free”
promotion. The format of the discount is as follows:

Buy X quantity of product, get Y quantity for free.

Process Overview:
Step 1: Create a Shopping Cart Price Rule
Step 2: Define the Conditions
Step 3: Define the Actions
Step 4: Complete the Label
Step 5: Add Related Banners
Step 6: Apply the Rule

Step 1: Create a Shopping Cart Price Rule

Complete Step 1 of the shopping cart price rule instructions to create a shopping cart rule
with the general information.

Step 2: Define the Conditions

Complete Step 2 of the shopping cart instructions to define the conditions for the price
rule. The conditions can be triggered by purchasing a specific product, making a purchase
of a certain amount, or any other scenario.
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Step 3: Define the Actions

1. In the panel on the left, select Actions. Then, do the following:

Buy X Get Y Free

a. Set Apply to “Buy X get Y free (discount amount is Y).”

b. Set Discount Amount to 1. This is the quantity the customer will receive for free.

c. To limit the number of discounts that can be applied when the condition is met, enter
the number in the Maximum Qty Discount is Applied To field. For example, enter “1”
to discount only one item.

d. In the Discount Qty Step (Buy X) field, enter the quantity that the customer must
purchase to qualify for the discount.

2. Click the Save and Continue Edit button. Then, complete the rest of the rule as needed.

Step 4: Complete the Label

Complete Step 4 of the shopping cart price rule instructions to enter the label that appears
during checkout.

Step 5: Add Related Banners

Complete Step 5 of the shopping cart price rule instructions to associate an existing banner
with the shopping cart rule.

Step 6: Apply the Rule

When complete, click the Save Rule button.

When you create a new price rule, it might take an hour or so for it to become available.
Allow enough time for it to get into the system. Then, test the rule to make sure that it
works correctly. Unless otherwise specified, price rules are automatically processed with
other system rules each night.
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Discount with Minimum Purchase
Shopping cart price rules can be used to offer a percentage discount based on a minimum
purchase. In the following example, a 25% discount is applied to all purchases over
$200.00 in a specific category. The format of the discount is as follows:

X% off all Y (category) over $Z dollars

Process Overview:
Step 1: Create a Shopping Cart Rule
Step 2: Define the Conditions
Step 3: Define the Actions

Step 1: Create a Shopping Cart Rule

Follow the steps to create a shopping cart rule.

Step 2: Define the Conditions

1. In the panel on the left, select Conditions.

2. Click the Add button at the beginning of the next line, and select Product Attribute
Combination.

Product Attribute Combination

3. Click the Add button at the beginning of the next line.

If an Item is FOUND

4. In the list under Product Attribute, click Category.
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Choose Condition to Add

a. Click the… “more” link to display additional options.

Category IS

b. Click the Chooser button to display the available categories. Then in the category

tree, select the checkbox of each category that you want to include.

Category Tree

c. Click the Select button at the end of the line to add the categories to the condition.

407Magento Enterprise Edition User Guide, Version 1.14.2.1



Shopping Cart Price Rules CHAPTER 24:  Promotions

408 Magento Enterprise Edition User Guide, Version 1.14.2.1

Category Condition

5. Click the Add button at the beginning of the next line, and do the following:

a. In the list under Product Attribute, select Price.

b. Click the first underlined option, is. Then in the list, select “equals or greater than.”

Price Equals or Greater Than

c. Click the ... “more” link to display the price field. Then, enter the amount that the
price must be to meet the condition. For example, enter 200.00.

Enter the Price to Complete the Condition

6. Click the Save and Continue Edit button.
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Step 3: Define the Actions

1. In the panel on the left, select Actions. Then, do the following:

Actions

a. Set Apply to “Percent of product price discount.”

b. Enter the Discount Amount. For example, enter 25 for twenty-five percent.

c. If you want to prevent the purchase from qualifying for additional promotions, set
Stop Further Rules Processing to “Yes.”

2. Click the Save and Continue Edit button. Then, complete the rule as needed.
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Product Relations Rules
Product rules give you the ability to target the selection of products that are presented to
customers as related products, up-sells, and cross-sells. Each product rule can be
associated with a customer segment to produce a dynamic display of targeted
merchandising.

The process is similar to setting up a price rule. First, you define the conditions to match,
and then choose the products you want to display. At any given time, there might be a
number of active rules that can be triggered to display related products, up-sells, and cross-
sells. The priority of each rule determines the order in which the block of products appears
on the page.

Manage Product Rules

To create a product relationship rule:

1. On the Admin menu, select Catalog > Rule-Based Product Relations.

2. In the upper-right corner, click the Add Rule button.

General Rule Information

3. Complete the General Information as described in the field descriptions below.
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4. In the panel on the left, select Products to Match. Then, build the condition as you would
for a catalog price rule.

Match Condition

5. In the panel on the left, select Products to Display. Then, build the results condition as
you would for a catalog price rule.

a. To base the result on a price relationship with the matched product, under Product
Special, select Price (percentage).

Special Price Percentage

b. Complete the condition to describe the products that you want to include in the
results. In this example, the matching products must have a higher value than the
original product.

Results Condition

6. When complete, click the Save button.
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FIELD DESCRIPTION

Rule Name A name that identifies the rule for internal use.

Priority Determines the sequence in which the results of the rule appear
when displayed with other sets of results that target the same
place on the page. The value can be set to any whole number,
with the highest priority of 1.
For example, if there aremultiple up-sell rules that apply, the one
with the highest priority appears before the others. The sort order
of the products within each set of results is random.
Any up-sell, cross-sell, and related products that weremanually
configured always appear on the page before any rule-based
product promotions.

Status Controls the active status of the rule. Options include: Active /
Inactive

Apply To Identifies the type of product relationship that is associated with
the rule. Options include:
Related Products
Up-sells
Cross-sells

From Date If the rule is active for a range of time, determines the first date
the rule is active.

To Date If the rule is active for a range of time, determines the last date
the rule is active.

Result Limit Determines the number of products that appear in the results at
one time. Themaximum number is 20. If morematching results
are found, the products rotate through the block each time the
page is refreshed.

Customer Segments Identifies the customer segments to which the rule applies.
Options include: All / Specified

Field Descriptions
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Priority of Rule-Based Product Relations
At any given time, there might be a number of active rules that can be triggered to display
related products, up-sells, and cross-sells. The priority of each rule determines the order in
which the products appear on the page. The value can be set to any whole number, with
one having the highest priority.

The number of product IDs that can be included in a product relations rule is determined
by the Result Limit value, which has a maximum of twenty. The Result Limit value,
combined with the configurable maximum for the specific rule-based product promotion
becomes the “real limit,” and determines the actual number of matching products that can
appear in the list.

[Result Limit] + [Configurable Maximum] = [Real Limit]

For example, suppose you have three rules, with a priority of one, two, and three.

l There are two matching products returned for Rule 1, six matching products for Rule 2,
and twenty matching products for Rule 3.

l In the configuration, the Maximum Number of Products for Related Products List is set
to six.

RULES PRIORITY MATCHING PRODUCTS

Rule 1 1 2

Rule 2 2 6

Rule 3 3 20

If the first rule returns more matching products than allowed by the “configurable
maximum limit,” but less than the “real limit,” the matching products from the other
existing rules are used—in order of priority—until the “real limit” is reached.

By priority, the matching products returned from Rule 1 can be used first to fill all twenty-
six available slots. Because Rule 1 returned only two matching products, there is still room
for twenty-four more. Rule 2 has the next highest priority, and returns six more matching
products. There are now eighteen available slots to be filled. Rule 3 has the next level of
priority, with enough matching products to fill the remaining eighteen slots. When all
available slots are filled, and depending on the rotation mode that is set, the list might be
shuffled, and then reduced to the “configurable maximum limit.” In this case, the
remaining six products appear in the store.
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Configuring Rule-Based Product Relations
The behavior and display of product relationship rules is determined by the configuration
settings. The settings determine how many products that match the rule can be displayed,
and the order in which they appear.

To configure rule-based product relations:

1. On the Admin menu, select System > Configuration. Then in the panel on the left under
Catalog, select Catalog.

2. Click to expand the Rules-Based Product Relations section. Then, do the following:

Rule-Based Product Relations

a. Enter the Maximum Number of Products in the Related Products List.

b. Set Show Related Products to one of the following:

l Both Selected and Rule Based

l Selected Only

l Rule-Based Only

c. Set Rotation Mode for Products in Related Product List to one of the following:

l Do Not Rotate

l Shuffle

3. To complete the cross-sell product settings, do the following:

a. Enter the Maximum Number of Products in the Cross-Sell Product List.

b. Set Show Cross-Sell Products to one of the following:

http://merch.docs.magento.com/ee/user_guide/Magento_Enterprise_Edition_User_Guide.html#configuration/catalog/catalog.html%23Rule_Based_Product_Relations
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l Both Selected and Rule Based

l Selected Only

l Rule-Based Only

c. Set Rotation Mode for Products in Cross-Sell Product List to one of the following:

l Do Not Rotate

l Shuffle

4. To complete the up-sell product settings, do the following:

a. Enter the Maximum Number of Products in the Upsell Product List.

b. Set Show Upsell Products to one of the following:

l Both Selected and Rule Based

l Selected Only

l Rule-Based Only

c. Set Rotation Mode for Products in Upsell Product List to one of the following:

l Do Not Rotate

l Shuffle

5. When complete, click the Save Config button.
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Email Reminder Rules
Automated reminder email rules give you the ability to send email reminders to customers
when a specific set of conditions is met. For example, you might send email reminders to
customers who have added something to their shopping cart or wishlist, but have not yet
made a purchase.

Email reminders can be triggered after a certain number of days have passed since a cart
was abandoned, or for any other condition you want to define, such as total cart value,
quantity, items in cart, and so on.

You can use email reminders to encourage customers to return to your store, and include a
coupon code as an incentive. Coupon codes can be automatically generated for each batch
of email reminders, to give you control over the offers that are associated with each batch.

Email Reminder Rules
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Email Reminder Configuration
Email reminder rules can be configured to be sent at regular intervals by the minute, hour,
or day.

Important! For automated email reminders to be sent as configured, the crontab service (for
UNIX/BSD/Linux ) or the Scheduled Tasks service (for Windows) should be configured to run the
necessary script periodically. For more information, see: How to Set Up a Cron Job.

To configure email reminders:

1. On the Admin menu, select System > Configuration.

2. In the panel on the left, under Customers, select Promotions.

3. Click to expand the Automated Email Reminder Rules section. Then, do the following:

Automated Email Reminder Rules

a. Set Enable Reminder Emails to “Yes.”

b. To set how often Magento checks for new customers who qualify automated email
reminders, set Frequency to one of the following:

l Minute Intervals

l Hourly

l Daily

c. Set the appropriate Interval, based on the Frequency setting.

d. Set Start Time to the hour, minute, and second the email is sent, based on a 24-hour
clock.

e. To limit the number of emails that can be sent in a batch, enter the number in the
Maximum Emails per One Run field.

f. To avoid repeated attempts to send failed email, enter the maximum number of
attempts in the Email Send Failure Threshold field.
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g. Set Reminder Email Sender to the store contact that appears as the sender of the
reminder email.

4. When complete, click the Save Config button.

Creating Email Reminder Rules
Before setting up an automated email reminder rule, make sure that you have a shopping
cart price rule set up that defines the promotion that is being offered. Rule conditions can
be based on shopping cart properties, wishlist properties, or both.

l Wishlist trigger conditions include: the number of days abandoned, sharing, number of
items, and specific items in the wishlist.

l Shopping cart trigger conditions include: the number of days abandoned, if a specific
coupon code has been applied, line items quantity, items quantity, total, if items are
virtual, and specific items in the shopping cart.

To create an email reminder rule:

1. On the Admin menu, select Promotions > Automated Email Reminder Rules.

2. In the upper-right corner, click the Add New Rule button.

General Information

3. Complete the General Information, as shown in the field descriptions section below.
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4. In the panel on the left, select Conditions. The process is similar to building a catalog price
rule. Do the following:

Conditions

a. Click the Add button to display the list of options. Then, choose one of the

following conditions to apply:

l Wishlist

l Shopping Cart

b. Complete the condition to describe the scenario that triggers the reminder email.

Completed Condition

5. In the panel on the left, select Emails and Labels. Then, do the following:

Email Templates

a. Assign an email template to each store to which you have access. Then, select the
email reminder template to use for each.

If you don’t want to send this rule’s reminder email to customers of a store, leave the
value, “Not Selected.”

b. Enter the Rule Title to be used as the default for all stores. The value can be
incorporated into email templates by using the promotion_name variable.
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c. Enter the Rule Description, which is the default for all stores The value can be
incorporated into email templates by using the promotion_description variable.

6. When complete, click the Save button.

FIELD DESCRIPTION

Rule Name The name of the automated reminder rule identifies the rule
internally.

Description A description of the rule for internal reference.

Shopping Cart Price Rule The shopping cart rule that is associated with this email
reminder. Reminder emails can promote a shopping cart price
rule with or without coupon. If a shopping cart price rule includes
an auto-generated coupon, the reminder rule will generate a
random, unique coupon code for each customer.

Assigned toWebsite The websites to receive automated reminder emails based on
this rule.

Status Activates the rule. If status is inactive, then all other settings will
be ignore and the rule will not be triggered.
Options include: Active / Inactive

From Date The starting date for this automated reminder rule. If no date is
specified, the rule becomes active immediately.

To Date The ending date for this automated reminder rule. If no date is
specified, the rule becomes active indefinitely.

Repeat Schedule The number of days before the rule is triggered, and the reminder
email sent again, provided the conditions aremet.
To trigger the rule more than once, enter the number of days
before the next email blast, separated by a comma. For example,
enter “7” to have the rule triggered again seven days later; enter
“7,14” to have the rule triggered in seven days, and again fourteen
days later.

Field Descriptions
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Email Reminder Templates
The default email reminder template can be customized, and additional templates created.
To learn more, see: Customizing Email Templates.

To create a template for email reminders:

1. On the Admin menu, select System > Transactional Emails.

2. Click the Add New Template button.

3. Select the default email template, Rule Reminder. Then, click the Load Template button.

Email Reminder Template

4. Assign a new Template Name, and follow the standard instructions to customize the
template. The following variables are specific to email reminders, and can be incorporated
into the message:

promotion_name

promotion_description

coupon.getCode()

coupon.getUsageLimit()

coupon.getUsagePerCustomer()
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The information in these variables is determined by the automated email reminder rule that
you set up, and by the shopping cart price rule that is associated with the coupon.

5. When complete, click the Save Template button.

Customer Segments
Customer segments allow you to dynamically display content and promotions to specific
customers, based on properties such as customer address, order history, shopping cart
contents, and so on. You can optimize marketing initiatives based on targeted segments by
using shopping cart price rules and banners. You can also generate reports and export the
list of targeted customers.

Because customer segment information is dynamic and is constantly refreshed, customers
can become associated and disassociated from a segment as they shop in your store.

Commerce Resources

See the latest Magento eBooks to gain access to expert insight and online business
resources to help develop and improve your store.

Manage Segments

http://magento.com/resources/business
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Customer Segment Attributes
Customer segments are defined in a manner similar to shopping cart and catalog price
rules. For an attribute to be used in a customer segment condition, the Use for Customer
Segment Conditions property must be set to “Yes.” Customer segment conditions can
incorporate the following attributes:

Customer Address

You can define any of the address fields, such as city or country. Any address in a
customer’s address book can match these conditions for the customer to match. Or, you
can specify that only the default billing or shipping addresses can be used to match a
customer. Customer address attributes are available only for customers who are logged in
to their accounts.

Customer

Miscellaneous customer information can be defined, including Customer Group, name,
email, newsletter subscription status, and Store Credit balance. Customer information is
available only for customers who are logged in to their accounts.

Shopping Cart

Shopping cart properties can be based on either quantity (line items or total quantity) or
the value (grand total, tax, gift card, etc.) of the cart contents.

Products

You can reference products that are currently in the shopping cart or wishlist, or that have
previously been viewed or ordered. You can also set a date range for when this occurred.
The products are defined using product attributes.

Sales

Order characteristics for past orders can be defined based on the billing/shipping address in
the order, the total or average amount or quantity of the orders, or the total number of
orders. You can also set a date range for when this occurred, and the order status of the
orders that match these conditions. Available only for customers who are logged in.
Conditions that are set for shoppers who are not logged in stop working when they log in.
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Creating a Customer Segment
The process of creating a customer segment is similar to building a shopping cart price
rule, except that the options also include customer-specific attributes.

Process Overview:
Step 1: Enable Customer Segments
Step 2: Complete the General Setup
Step 3: Describe the Conditions
Step 4: Generate the List of Matched Customers

Step 1: Enable Customer Segments

1. On the Admin menu, select System > Configuration.

2. In the panel on the left under Customers, select Customer Configuration.

3. Click to expand the Customer Segments section.

4. Set Enable Customer Segment Functionality to “Yes.”

Customer Segments

5. When complete, click the Save Config button.

Step 2: Complete the General Setup

1. On the Admin menu, select Customers > Customer Segments.

2. In the upper-right corner, click the Add Segment button.

3. Complete the General Properties as described in the following field description section.

4. When complete, click the Save and Continue Edit button.
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General Properties

Step 3: Describe the Conditions

1. In the panel on the left, click the Conditions tab.

Conditions

2. To create a condition that targets the Millennium Generation, do the following:

a. Click the Add button to display the list of conditions. Then, in the list under

Customers, select Date of Birth.

b. Click the is link, and select “equals or greater than.”

c. Replace the inserted date with the following: “1977/01/01.”

d. On the next line, click the Add button. Then again, in the list under Customers,

select Date of Birth.

e. Click the is link, and select “equals or less than.”

f. Replace the inserted date with the following: “1994/12/31.”
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Condition for Millennium Generation

3. Click the Save and Continue Edit button.

Step 4: Generate the List of Matched Customers

1. In the panel on the left, select Matched Customers to generate a list of customers who
match the condition.

Millennium Generation Customer Segment

2. When complete, click the Save button.

This customer segment can now be used for targeting promotions, content, and mailings.

FIELD DESCRIPTION

Segment Name A name that identifies the segment for internal reference.

Description A brief description that explains the purpose of the segment for
internal reference.

Assigned toWebsite The single website where the segment can be used.

Field Descriptions
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FIELD DESCRIPTION

Status Activates and deactivates the segment. Any associated price
rules and banners are deactivated when the segment is disabled.
Options include: Active / Inactive.

Apply to Defines the customer types to which the segment is applied. The
selection influences the set of conditions available for creating
the segment. The setting cannot be changed after the segment is
saved. Options include:

Visitors and Registered
Customers

Includes all shoppers, regardless
of whether they are logged in to
an account.

Registered Customers Includes only shoppers who are
logged in to an account

Visitors Includes only shoppers who are
not logged in to an account.

Field Descriptions (cont.)

Target Customer Segments with Price Rules
A customer segment can be targeted by associating it with a shopping cart price rule and
banner.

To associate a segment with a shopping cart price rule:

1. On the Admin menu, select Promotions > Shopping Cart Price Rules.

2. Do one of the following:

l In the upper-right corner, click the Add New Rule button.

l Open an existing rule in edit mode.

3. In the panel on the left, select Conditions. Then, complete the condition as follows:

a. Click the Add button to display the list of conditions. Then in the list, select

Customer Segments.

b. To target a specific segment, click the… “more” link to display additional options.
Then, click the Chooser icon to display the list of customer segments.

c. In the list, select the checkmark of each segment that you want to target in the
condition.
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Choose Customer Segments

4. Click the Select button to place the selected customer segments into the condition.

Completed Condition

5. Complete the rest of the price rule, as needed.

6. When complete, click the Save button.

Target Customer Segments with Banners
A banner can target a specific customer segment, and be incorporated into a shopping cart
price rule. Because customer segments are dynamic, the price rule can adjust to changes in
customer activity.
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Banner

To associate a customer segment with a banner:

1. On the Admin menu, select CMS > Banners. Then, do one of the following:

l In the upper-right corner, click the Add Banner button.

l Open an existing banner in edit mode.

2. Set Specified from the Customer Segments to “Specified.” Then in the list, select each
customer segment that you want to target with the banner.

Customer Segments

3. Make any other changes to the banner, as needed.

4. When complete, click the Save Banner button.
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CHAPTER 25:

Shopping Tools
Your store includes a set of shopping tools that create opportunities for your customers
to engage with your store, and to share the experience with friends.

Topics in this chapter:

l Opportunities to Engage

l Email a Friend

l Polls

l Tags

l Wishlists

l Product Relationships

l Compare Products

l Recently Viewed / Compared Products

l Product Reviews

Commerce Resources

See the latest Magento eBooks to gain access to expert insight and online business
resources to help develop and improve your store.

http://magento.com/resources/business
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Opportunities to Engage
Email a Friend

The Email a Friend link makes it easy for your
customers to share links to products with their
friends.

Polls

The Poll block displays a series of polls or surveys
that you can use to learnmore about your customers.

Tags

Tags help customers organize and remember the
products that they have seen, offer quick navigation,
and help search engines index your store.

Wishlist

TheWishlist block displays the items from the
customer’s wishlist.
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Product Relationships

Products in your catalog can be promoted on other
pages as Up-sells, Cross-sells, and Related
Products.

Compare Products

The Compare Products block lets your customers
quickly compare the features of one product with
another.

Recently Viewed / Compared

The Recently Viewed and Recently Compared
blocks usually appear in the right sidebar of a catalog
page.

Product Reviews

Product reviews help build a sense of community,
and are considered to bemore credible than any
advertisingmoney can buy.
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Email a Friend
The Email a Friend link makes it easy for your customers to share links to products with
their friends. In the Magento demo store, the Email a Friend link appears as an envelope
icon.

The automated message that is sent from your store is referred to as transactional
email1. The message template can be customized for your voice and brand. To prevent
spamming, customers can send only five messages per hour.

Email a Friend

To configure email to a friend:

1. On the Admin menu, select System > Configuration.

2. In the panel on the left, under Catalog, select Email to a Friend.

3. Click to expand the Email Templates section. Then, do the following:

Email Templates

1A notification email sent to the customer when a transaction is processed.

http://merch.docs.magento.com/ee/user_guide/Magento_Enterprise_Edition_User_Guide.html#configuration/catalog/email-to-a-friend.html%23Email_Templates
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a. Set Enabled to “Yes.”

b. Set Select Email Template to the template you want to use as the basis of the
messages.

c. If you want to require that only registered customers can send email to friends, set
Allow for Guests to “No.”

d. In the Max Recipients field, enter the maximum number of friends who can be on the
distribution list for a single message.

e. In the Max Products Sent in One Hour field, enter the maximum number of products
that can be shared by a single user with friends over a one-hour time period.

f. Set Limit Sending By to one of the following methods to identify the sender of emails:

IP Address (Recommended) Identifies the sender by the IP address of the
computer that is used to send the emails.

Cookie (unsafe) Identifies the sender by browser cookie. This method is less
effective because the sender can delete the cookie to bypass the
limit.

4. When complete, click the Save Config button.

To send email to a friend:

1. On a catalog page, click the Email a Friend link. When prompted, either log into your
customer account or register to open an account.

2. Complete the Message and enter the recipient Name and Email Address.

To send the message to more than one person, click the Add Another Recipient link and
complete the information for each person.

3. When ready to send the message, click the Send Email button.

Email a Friend Form
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Polls
Polls make it easy to learn about your customers’ opinions and preferences. The poll
occupies a small amount of space and is usually placed in the right sidebar of a catalog
page. Poll results appear immediately after a response is submitted. If you create multiple
polls, a new poll appears each time the page is refreshed.

Original Poll and Results

To create a poll:

1. On the Admin menu, select CMS > Polls.

2. In the upper-right corner of the Poll Manager, click the Add New Poll button.

3. In the Poll Information section, do the following:

Poll Information

a. Enter the Poll Question.

b. By default, Status is set to “Open.” If you later want to remove the poll from your
store, set Status to “Closed.”

c. Set Visible In to the store view where you want the poll to appear.

4. In the panel on the left, select Poll Answers. Then, for each answer, do the following:
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a. Click the Add New Answer button. Then, do the following:

Assigned Answers

b. In the Answer Title field, enter the answer as you want it to appear in the poll.

c. To weight an answer, enter a number in the Votes Count field. The number will
increment each time a customer chooses the answer.

5. Click the Save Poll button to save your poll.

To edit a poll:

1. From the Poll Manager list, click to open the poll in edit mode. Then, make the necessary
changes.

l To close the poll so that it no longer appears in the store, set Status to “Closed.”

l To see the vote count for each answer, click Poll Answers in the panel on the left.

2. When complete, click the Save Poll button.

Poll Answer Count
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To prevent multiple voting:

You can protect the poll results by preventing people from voting multiple times from the
same computer.

1. On the Admin menu, select System > Configuration.

2. In the Configuration panel on the left, under General, select Web.

3. Click to expand the Polls section, and set Disallow Voting in a Poll Multiple Times from
Same IP Address to “Yes.”

Disallow Voting Multiple Times

4. When complete, click the Save Config button.
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Tags
Tags are one-word descriptors that are used as keywords for your catalog. Tags can be
assigned to products by registered customers who are logged in, and also by guests. Tags
help customers organize and remember the products that they have seen, offer quick
navigation, and help search engines index your store.

Popular Tags

Tags are formatted as a tag cloud, and typically appear in the Popular tags block in the
right sidebar of catalog pages. The size of the text indicates the popularity of the tag. Each
product page has an “Tag this Product” section at the bottom of the page, where shoppers
can enter their own tags. As an incentive, customers can earn reward points for adding tags
to a product. Tags that customers have assigned to a product appear on the Customers
Tagged Product tab in the product record, and includes the tag, the customer name, and
email address.

To add a tag from the store:

1. From any product page, scroll down to Tag this Product at the bottom of the page.

Tag this Product
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2. In the Add a Tag text box, type the tag you want to associate with the product.

l To enter multiple tags, separate each with a blank space.

l To enter a phrase, enclose the text in single quotes.

3. Click the Add Tags button.

The tag will be submitted for review and published on the site when approved.

Products Tagged by Administrators
There’s no reason to wait for customers to tag products. As part of your SEO effort, you can
tag products with high-value keywords as part of your SEO effort. As the store
administrator, you can apply new tags to products, and reuse existing tags.

Products Tagged by Administrators

To add a new tag:

1. On the Admin menu, select Catalog >Tags > All Tags.

2. In the upper-right corner, click the Add New Tag button. Then, do the following:

a. Enter the Tag Name.

b. Set Status to “Approved.”

c. In the Base Popularity field, enter a numeric value to assign a weight to the tag. The
number assigns a base value to the tag and increases its size in the tag cloud.

3. When complete, click the Save Tag button.

To apply an existing tag to specific products:

1. In the Manage Tags list, click to open the tag.

2. Click to expand the Products Tagged by Administrators section. Then, do the following:

a. Click the Reset Filter button to display all product records.

b. Select the checkbox of each product that you want to tag.

3. When complete, click the Save Tag button.

The products now appear in the list of Products Tagged by Administrators.
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Moderating Tags
After a customer submits a product tag, an administrator must approve the tag before it
becomes visible in the store. After a tag has been approved, it can be used for other
products without further approval.

Changing the Status of Pending Tags

Tag Activity
The remaining sections give you a snapshot of the tag activity, including which customers
have used the tag, and products tagged by the store administrator and customers.

Customers Submitted this Tag

You can jump to a specific customer or product by clicking its row in the list.

Products Tagged by Customers
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To approve multiple tags:

1. On the Admin menu, select Catalog >Tags > Pending Tags. Then in the list, click to open
a pending tag.

2. In the list, select the checkbox of each tag that you want to approve.

3. Set the Actions control to “Change Status.” Then, set the Status control to “Approved.”

4. When complete, click the Submit button.

To manage a single tag:

1. On the Admin menu, select Catalog >Tags > Pending Tags. Then in the list, click to open
a pending tag.

Editing a Tag

2. If necessary, you can edit the text as needed. Then, do one of the following:

l To approve and publish the pending tag, set Status to “Approved.”

l To reject the tag, set Status to “Disapproved.”

3. When complete, click the Save Tag button.
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Wishlists
A wishlist is a list of products that registered customers can share with friends or transfer
to their shopping carts at a later date. When wishlists are enabled, the Add to Wishlist link
appears on the category and product pages of your store. Customers can maintain multiple
wishlists, which allows them to:

l Make each wishlist private or public

l Move items between wishlists

l Search for public wishlists of other customers, and purchase items

Depending on the theme, the Add to Wishlist might be a text link or a graphic image. In
the Magento demo store, the link is represented by a heart image. Registered customers can
click the Add to Wishlist link, add the product to the wishlist, and share it with friends.
Wishlists increase customer loyalty and bring new people to your store.

Add to Wishlist Link on Product Page

Shared wishlists are sent from a store email address, but the body of the message contains
a personalized note from the customer. You can customize the email template that is used
for the notification message when wishlists are shared, and choose the store contact that
appears as the sender.

Each wishlist can be maintained in the customer’s account dashboard, where it can be
updated, and used to add products to the shopping cart. When a product with multiple
options is added to a wishlist, any options selected by the customer are included in the
wishlist item description. For example, if the customer adds the same pair of shoes, but in
three different colors, each pair appears as a separate wishlist item. On the other hand, if
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the customer adds the same product to the wishlist multiple times, the product appears in
the wishlist only once, but with an updated quantity that reflects the number of times the
product was added. Customers can update their wishlists from their account dashboard.
However, merchants can also update a customer’s wishlist from the Admin.

Wishlist Configuration
If enabled in your store configuration, customers can maintain multiple wishlists.

General Options

To configure wishlists:

1. On the Admin menu, select System > Configuration.

2. In the Configuration panel on the left, under Customers, select Wishlist.

3. Click to expand the General Options section.

4. Verify that Enabled is set to “Yes.”

5. To give customers the ability to maintain multiple wishlists, do the following:

a. Set Enable Multiple Wishlists to “Yes.”

b. Enter the Number of Multiple Wishlists that each customer can maintain.

If you use multiple wishlists, and later disable the feature, only the default wishlist remains
available to customers. However, the data from any previous multiple wishlists remains
accessible from the store Admin.

6. Click to expand the Share Options section, and do the following:

Share Options

a. Set Email Template to the template to be used for the notification that is sent when a
customer shares a wishlist.

b. Set Email Sender to the store contact that appears as the sender of the notification.
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7. To configure the way wishlists are summarized in customer accounts, click to expand the
My Wishlist Link section. Then, set Display Wishlists Summary to one of the following:

l Display number of items in wishlist

l Display item quantities

My Wishlist Link

8. When complete, click Save Config.

Wishlist SearchWidget
All Wishlists that are set to be public can be found using the Wishlist Search widget. The
widget enables a customer to search by Wishlist owner name or email address. Store
customers can find wishlists that belong to other customers, view them and order products
from them, or add the products to their own wishlists. When items from a customer’s
public wishlist are purchased by another customer, the items are not removed from the
original wishlist.

Shipping addresses are not included in wishlists.

The Wishlist Search widget can be added to any page of your store to make it easy for
customers to search for wishlists. To learn more, see: Widgets.

To add a Wishlist Search widget:

1. On the Admin menu, select CMS > Widgets.

2. In the upper-right corner, click the Add New Widget Instance button. Then, in the Settings
section, do the following:

Settings

a. Set Type to “Wishlist Search.”

b. Set Design Package/Theme to the theme of the store where the wishlist will be added.
Then, click the Continue button.

3. In the panel on the left, select Widget Options. Then, do the following:
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Widget Options

4. Set Quick Search Form Types to one of the following:

All Forms Customers can search by all available parameters.

Wishlist Owner Name
Search

Customers can search for wishlists by owner name.

Wishlist Owner Email
Search

Customers can search for wishlists by owner email address.

5. Configure the remaining widget properties as needed, following the standard instructions.

6. When complete, click the Save button.

Wishlist Reports
A customer Wishlist report includes the following information for each wishlist the
customer has created:

l The date when a product was added

l The customer name

l The wishlist name and status (public or private)

l The product name and SKU

l Customer comments

l Quantity of the product in the Wishlist, quantity currently available in the store, and
the difference between these two values.

You can choose to see a report for the entire website or for an individual store view. The
scope is selected in the Show Report For field. The report can be exported to .csv or Excel
.xml format.

To generate a wishlist report:
On the Admin menu, select Reports > Customers > Customers Wishlist.
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Product Relationships
Products in your catalog can be promoted on other pages by defining the nature of the
relationship between the products. The options available are: Up-sell products, Related
products, and Cross-sell products.

Related Products

Related products aremeant to be purchased in
addition to the item the customer is viewing. They
complement, enhance, or add optional features to the
product.

Up-sells

Up-sell products are items that are similar, but are
perhaps of a higher-quality, more popular, or have a
better profit margin than the item the customer is
considering.

Cross-sells

Cross-sell products are offered on the shopping cart
page as last-minute purchases before the checkout
process begins.
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Compare Products
The Compare Products block usually appears in the far right column, or sidebar of the
category page, and provides a detailed, side-by-side comparison of two or more products.
You can customize the report to include additional attributes or remove ones that you don’t
want to include. In the Magento demo store, the Add to Compare link is represented by an
icon, rather than a link.

Compare Products

To compare products:

1. From your storefront, find the products that you want to compare, and click the Add to
Compare link for each.

2. In the Compare Products block in the right sidebar, click the Compare button. The
Compare Products report opens in a new window.

3. To clear the Compare Products list, click the Clear All link.
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Compare Products Report
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Recently Viewed/Compared Products
The Recently Viewed and Recently Compared blocks usually appear in the right sidebar of a
catalog page. The number of products listed can be set for each website, store, or view.

Recently Viewed

To configure Recently Viewed/Compared Products:

1. On the Admin menu, select System > Configuration.

2. In the panel on the left, under Catalog, select Catalog.

3. Click to expand the Recently Viewed/Compared Products section. Then, do the following:

Recently Viewed/Compared Products

a. Set Show for Current to the website, store, or view where the configuration applies.

b. In the Default Recently Viewed Products Count field, enter the number of recently
viewed products you want to include.

c. In the Default Recently Compared Products Count, enter the number of recently
compared products you want to include.

4. When complete, click the Save Config button.
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Product Reviews
Product reviews help to build a sense of community, and are considered more credible than
any advertising money can buy. In fact, some search engines give sites with product
reviews a higher ranking than those without. For those who find your site by searching for
a specific product, a product review is essentially the landing page of your store. Product
reviews help people find your store, keep them engaged, and often lead to sales.

The configuration determines whether reviews can be submitted by guests, or if customers
must open an account with your store before they can write reviews. Requiring reviewers to
open an account prevents anonymous submissions and improves the quality of reviews.

Add Your Review

Customers can write reviews for any product in your catalog. Reviews can be written from
the product page by clicking the “Add Your Review” link. For products that haven't been
reviewed, the link says, “Be the first to review this product.”

The number of stars indicates the satisfaction rating. Visitors can click the link to read the
reviews and write their own. As an incentive, customers can receive reward points for
submitting a review.

When a review is submitted, it is sent to the Admin for moderation. When approved, the
review is published in your store.
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Writing a Product Review

To configure Product Reviews

1. On the Admin menu, select System > Configuration.

2. In the panel on the left, under Catalog, select Catalog.

3. Click to expand the Product Reviews section.

Product Reviews

4. Set Allow Guests to Write Reviews according to your preference.

5. When complete, click the Save Config button.
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To moderate reviews:

1. On the Admin menu, select Catalog > Reviews and Ratings > Customer Reviews >
Pending Reviews.

Pending Reviews

2. In the list, click a pending review to view the details, and edit if necessary.

3. To approve a pending review, change the Status from “Pending” to “Approved.” To reject a
review, select “Not Approved.”

4. When complete, click the Save Review button.

Custom Ratings
By default, customer can rate the quality, price, and value of a product. In addition, you
can add your own custom ratings that relate to your products and customers. The average
rating for each product appears in catalog lists and on the product page.

Manage Ratings

To create your own ratings:

1. On the Admin menu, select Catalog > Reviews and Ratings > Manage Ratings.

2. In the upper-right corner, click the Add New Rating button.

3. In the Rating Title section, enter the Default Value for the new rating. Then, enter the
translation for each language supported by your store.
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Rating Title

4. In the Rating Visibility section, set Visibility In to the store view where the rating will be
used. (Hold down the Ctrl key to select multiple options.)

5. In the Sort Order field, enter a number to determine the sequence that this rating appears
in the list of ratings.

Rating Visibility

6. When complete, click the Save Rating button.
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Gift Options
At checkout, customers are presented with the available gift options during the
Shipping Method step of the process. If the customer chooses to add gift options, two
groups of checkboxes appear: Gift Options for Entire Order and Gift Options for
Individual Items. If enabled, the Send Gift Receipt and Add Printed Card checkboxes
appear below. Prices for the selected gift wrapping options and the printed card are
shown as individual lines in the order totals during Order Review.

Gift Options During Checkout
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Gift-Related Products & Services
Magento offers a variety of gift-related products and services. Some can be applied to an
individual item or to the entire order. An additional charge can be added to include a
printed card or gift wrapping.

Gift Wrapping

Gift wrapping can be applied to an entire order, or for
specific items in the order during checkout. The price
for gift wrapping an individual item is set in the
product record.

Gift Messages

A gift message or printed card can be added to the
entire order or to specific items in the order during
checkout.

Gift Receipt

During checkout, a gift receipt can be included in the
order by selecting the IncludeGift Receipt checkbox.
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Gift Cards

A gift card is a product that you can offer for sale from
your catalog. The gift card can be physical, virtual, or
a combination of the two. Each gift card has a value
assigned, with a unique code that is entered during
checkout. Each gift card has an associated account
to keep track of the balance.

Gift Registries

Your customers can create gift registries for special
occasions, and invite friends and family to
participate. When items are purchased from the gift
registry, the inventory is updated.
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Gift Options Workflow

Entire Order

When the customer selects the Gift Options for the Entire Order checkbox, the Gift
Wrapping Design and the Gift Message options appear below. The customer can select a
gift wrapping design and write a gift message for the entire order. After the gift wrapping
design is selected, its price and an image preview, if available, appear.

Individual Items

When the customer selects the Gift Options for Individual Items checkbox, the list of
product names appears with the Gift Wrapping Design options for each product. To learn
more, see: Product Gift Options.

Send Gift Receipt

The customer can select the Send Gift Receipt checkbox to send a gift receipt for the order

Add Printed Card

If the customer selects the Add Printed Card checkbox, the card price appears below.
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Gift Options Configuration
The Gift Options configuration determines if customers have the option to add a gift
message and gift wrap during checkout. The gift options must be configured first for the
website, and can then be overridden at the product level.

Gift Options

To enable gift options:

1. On the Admin menu, select System > Configuration. Then in the panel on the left, under
Sales, select Sales.

2. Click to expand the Gift Options section. Then, do the following:

a. Set the following options according to your preference:

l Allow Gift Messages on Order Level

l Allow Gift Messages for Order Items

l Allow Gift Wrapping on Order Level

l Allow Gift Wrapping for Order Items

l Allow Gift Receipt

l Allow Printed Card

b. If applicable, enter the Default Price for Printed Card.

3. When complete, click the Save Config button.

When gift wrapping is enabled, the gift wrapping-related settings become available at the
product level.

Gift Options Tax
Because you can charge customers for gift wrapping and printed cards, you can also specify
a tax class for these items, at either the global or website level. Gift wrapping and printed
gift card prices can be configured to include or exclude tax, or to display both options.
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To assign a tax class to gift options:

1. On the Admin menu, select System > Configuration. Then in the panel on the left, under
Sales, select Tax.

2. Click to expand the Tax Classes section.

Tax Classes

3. Set Tax Class for Gift Option to the applicable tax class.

4. When complete, click the Save Config button.

To configure gift option taxes:

1. On the Admin menu, select System > Configuration. In the panel on the left, under Sales,
select Tax.

2. Click to expand the Orders, Invoices, Credit Memos Display Settings section. Then, do
the following:

Orders, Invoices, Credit Memos Display Settings

a. Set Display Gift Wrapping Prices to one of the following:

l Excluding Tax

l Including Tax

l Including and Excluding Tax

b. Set Display Printed Gift Card Prices to one of the following:

l Excluding Tax

l Including Tax

l Including and Excluding Tax

3. When complete, click the Save Config button.
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Gift MessageModule
The Gift Wrapping module is related to the Gift Message module. If the Gift Message
module is disabled, then the Gift Wrapping module will be disabled too. The result is that
the Gift Options tab will be missing from the product and order pages, the Gift Wrapping
page will not be available in Sales Management, and the Add Gift Options checkbox will
not appear during checkout. If the Gift Message module is disabled on your system, follow
the steps below.

To enable the Gift Message module:

1. On the Admin menu, select System > Configuration.

2. In the panel on the left, under Advanced, select Advanced.

3. Click to expand the Disabled Modules Output section.

4. Find the Mage_GiftMessage module in the list, and change its status to “Enable.”

Mage_GiftMessage

5. When complete, click the Save Config button.
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Gift Wrap
Gift wrapping is available for any product that can be shipped. Gift wrapping can be
offered for individual items or for the entire order. You can charge a separate price for each
gift wrap design, and upload a thumbnail image of the design that appears during
checkout.

Gift Wrapping Design at Checkout

To add new gift wrap designs:

1. On the Admin menu, select Sales > Gift Wrapping.

Manage Gift Wrapping

2. In the upper-right corner, click the Add Gift Wrapping button. Then, do the following:
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New Gift Wrapping

a. Enter a name for the Gift Wrapping Design that will appears with the option during
checkout.

b. Select theWebsites where the gift wrap design will be available.

c. Set Status to “Enabled.”

d. Enter the Price of the gift wrap design.

e. To upload a thumbnail Image of the gift wrapping, click the Choose File button.
Then, select the image file and click the Upload File button.

3. When complete, click the Save button.

To delete gift wrap designs:

Method 1: Delete Single Gift Wrap Design

1. Open the gift wrapping design in edit mode.

2. Click the Delete button. When prompted, click OK to confirm.

Method 2: Delete Multiple Gift Wrap Designs

1. On the Manage Gift Wrapping page, select the checkbox of each gift wrap design that you
want to delete.

2. Set the Actions control to “Delete.”

3. Click the Submit button.
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FIELD SCOPE DESCRIPTION

Gift Wrapping Design Store View The name of the gift wrap option that appears to
customers during checkout. The name can be
different for each store view.

Websites Select the websites where the new gift wrap will
be available.

Status Global Determines if gift wrapping is available. Options
include: Enabled / Disabled.

Price Global Specifies the price of the gift wrap option. This
setting can be overridden by the gift wrap price set
at the product level.

Image Global Uploads a thumbnail image of the gift wrap design
that appears next to the gift wrap option.

Field Descriptions
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Gift Registries
Magento Enterprise Edition gives your customers the ability to create gift registries for
special occasions and to notify their friends and family. Friends and family can
purchase items from the gift registry, and Magento keeps track of all items purchased
and the quantities remaining.

Customers can create gift registries and share them with others. A gift registry owner
can add products to the registry from the customer dashboard. In addition, products
can be transferred from the wishlist or shopping cart. The store administrator can view
and share customer gift registries, add items from the customer’s shopping cart, update
gift registry item quantities, or delete a gift registry.

Gift Registry Workflow

Gift Registry Setup

Enables the gift registry, and sets up the registry types and attributes.

Customer / Gift Registry Owner

Creates the gift registry for an upcoming occasion. Adds items to the registry, and
shares it with friends and family.

Gift Registry Recipient

Receives email notification, and clicks the link to visit the gift registry. Then, places an
order for an item in the gift registry.

Magento

Updates gift registry item counts, and notifies the gift registry owner.
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Using a Gift Registry
The gift registry is included with other useful quick links. In the demo store, the quick links
are in the footer of the store, but the exact position varies by theme. In addition, the
Widget tool can be used to place a gift registry quick search box anywhere in your store.

Gift Registry Search

To access a gift registry, recipients can click the link in the email they receive, or search by
the recipient's name, email, or gift registry ID. Recipients who want to purchase a product
can add the item from the gift registry directly to their shopping carts. When the order is
placed, the gift registry is updated to reflect the purchase.

Wedding Gift Registry
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Gift Registry Configuration
Before you can offer gift registries to your customers, you must enable gift registries and
configure the related email notifications. Magento sends the following email notifications in
response to events in the gift registry workflow.

l When a new gift registry is created, an email is sent to the owner with a link to registry
that can be shared.

l Optionally, the store can send notification to friends and family of the gift registry
owner, with a link to the gift registry.

l The owner is notified when items are purchased from the gift registry, but does not
indicate the purchaser.

Magento has predefined templates for each of these emails that can be modified and
customized as any other email template.

Process Overview:
Step 1: Enable Gift Registries
Step 2: Configure Email Notifications

Step 1: Enable Gift Registries

1. On the Admin menu, select System > Configuration.

2. In the panel on the left, under Customers, select Gift Registry

3. Click to expand the General Options section, and do the following:

General Options

a. Set Enable Gift Registry to “Yes.”

b. In the Max Recipients Limit field, enter the maximum number of people that can be
invited to any registry.

4. When complete, click the Save Config button.

5. When prompted to update the cache, click the link in the message at the top of the
workspace and follow the instructions.

After the cache is refreshed, Gift Registry appears in the Customers menu, and becomes
available to customer accounts.
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Step 2: Configure Email Notifications

1. Click to expand the Owner Notification section, and do the following:

Owner Notification

a. Select the Email Template that is used to notify gift registry owners that their
registries have been created.

b. Select the store identity that appears as the Email Sender of the message.

2. Click to expand the Gift Registry Sharing section, and do the following:

Gift Registry Sharing

a. Select the Email Template that is used to notify gift registry recipients that a registry
has been shared with them.

b. Select the store identify that appears as the Email Sender of the message.

c. Max Emails Allowed to be Sent at One Time

3. Click to expand the Gift Registry Update section, and do the following:

Gift Registry Update

http://merch.docs.magento.com/ee/user_guide/Magento_Enterprise_Edition_User_Guide.html#configuration/customers/gift-registry.html%23Owner_Notification
http://merch.docs.magento.com/ee/user_guide/Magento_Enterprise_Edition_User_Guide.html#configuration/customers/gift-registry.html%23Gift_Registry_Sharing
http://merch.docs.magento.com/ee/user_guide/Magento_Enterprise_Edition_User_Guide.html#configuration/customers/gift-registry.html%23Gift_Registry_Update


CHAPTER 27:  Gift Registries Creating Gift Registries

a. Select the Email Template that is used to notify gift registry owners of changes to the
gift registry.

b. Select the store identify that appears as the Email Sender of the message.

4. When complete, click the Save Config button.

Creating Gift Registries
The gift registry type is the special event that is associated with the gift registry. It can be a
wedding, birthday, anniversary, new baby, or any other special occasion. By default,
Magento provides gift registry types for the following special events:

l Baby Registry

l Birthday

l Wedding

Each gift registry type consists of a number of attributes, which are the data entry fields
that a customer completes to create a gift registry. The attributes can be used to provide
additional information about the gift registry owner, the event, time and location, or any
other information that relates to the gift registry. Depending on the input type, some
attributes have multiple options. For example, the gift registry type “Wedding,” has the
attribute “Role,” with the options, “Bride,” “Groom,” and “Partner.” To learn more about
attributes and input types, see: Managing Attributes.

Process Overview:
Step 1: Set Up theGift Registry Type
Step 2: Define the Gift Registry Attributes

Step 1: Set Up the Gift Registry Type

1. On the Admin menu, select Customers > Gift Registry.

Gift Registry Types

2. In the upper-right corner, click the Add Gift Registry Type button.

3. Under General Information, complete the following:
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General Information

a. Enter a unique Code to identify the gift registry internally. The code must begin with
a lowercase letter. The rest of the code can be any combination of lowercase letters (a-
z), numbers (0-9), and underscore (_).

b. In the Label field, enter a name for the gift registry, as you want it to appear in the
store.

c. In the Sort Order field, enter a number to determine the sequence in which this gift
registry appears when listed with other gift registries that are available in the store.

d. To activate the gift registry, set Is Listed to “Yes.”

Step 2: Define the Gift Registry Attributes

1. In the panel on the left, click Attributes.

Attributes

2. In the panel on the left, click Attributes. Then, click the Add Attribute button.

3. To add a predefined static attribute, do the following:

a. Set Input Type to one of the following:

l Event Date

l Event Country

l Event Location

l Role

b. In the Label field, enter a name for the gift registry, as you want it to appear in the
store.

c. In the Sort Order field, enter a number to determine the sequence in which this gift
registry appears when listed with other gift registries that are available in the store.
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4. Assign a unique Code to identify the gift registry type internally. The first character should
be a lowercase letter. The rest of the code can include lowercase letters(a-z), numbers (0-9)
and the underscore (_) character to separate words.

5. Set Input Type to the type of data and input control you want to use.

6. For attributes of either the Role or Select input type, click the Add New Option button and
do the following:

Add New Option

a. Enter a unique Code to identify the option

b. Enter a Label to identify the data entry field in the store.

c. To preset to the field to a specific value, select the Is Default option.

d. Repeat this process for each new option.

7. Select the Attribute Group where you want the field to appear in the gift registry.

a. Enter the Label that you want to appear next to the field in the store..

b. To require that a value is entered, set Is Required to “Yes.”

c. In the Sort Order field, enter a number to determine the sequence in which this
attribute appears when listed with other attributes in the gift registry.

8. When complete, click the Save button.

471Magento Enterprise Edition User Guide, Version 1.14.2.1



Creating Gift Registries CHAPTER 27:  Gift Registries

472 Magento Enterprise Edition User Guide, Version 1.14.2.1

ATTRIBUTE DESCRIPTION

General Information

Code A unique name to identify the gift registry type internally. The first
character of the codemust be a lowercase letter. The rest of the
code can be any combination of lowercase letters (a-z), numbers
(0-9), and the underscore character (_).

Label The name of the gift registry type that appears in the store.

Sort Order Determines the sequence in which this gift registry type appears
when listed with other types.

Is Listed Determines if the gift registry type is available to customers in
the store. Options include: Yes / No.

Attributes

Code A unique name to identify the attribute internally.The code can
include any combination of lowercase letters (a-z), numbers (0-
9), and the underscore character (_).

Input Type Determines the type of data and input control that is associated
with the attribute, according to type. Options include:

Custom Types

Text Displays the attribute as a text field.

Select Displays the attribute as a drop-down list.

Date Displays the attribute as a date field.

Country Displays the attribute as a drop-down list of
countries. Set Show Region to: Yes / No.

Static Types

Event Date Determines how the date attribute is used in
the store. Options include:

Field Descriptions
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ATTRIBUTE DESCRIPTION

Searchable Determines if the attribute is
available for Advanced
Search. Options include:
Yes / No.

Is Listed Determines if the event is
included in the list of events
that is available in the store.
Options include: Yes / No.

Date
Format

Determines the format of the
event date. Options include:
Short (3/23/2014)
Medium (Mar 23, 1914)
Long (March 23, 1914)
Full (Sunday, March 23,
2014)

Event Country Displays the attribute as a drop-down list of
countries. Set Show Region to: Yes / No.

Event Location The location of the event that is related to the
gift registry.

Role The role that identifies who the gift is for. For
example, "Bride," "Groom," or "Partner."

Attribute Group Select the group where the attribute is listed in the gift registry.
Options Include:

Event
Information

Groups all gift registry attributes that add the
information about the gift registry event, its
time, place, etc.

Gift Registry
Properties

Combines all attributes that add information
directly about the gift registry.

Privacy
Settings

Lists the attributes that add information about
the gift registry event privacy.

Recipients
Information

Groups the attributes that provide information
about the person who creates a gift registry.

Field Descriptions (cont.)
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ATTRIBUTE DESCRIPTION

Label The name that identifies the attribute in the customer's account
dashboard.

Is Required Indicates if the attributes is a required entry. The gift registry
cannot be saved until all required attributes are complete.
Options include: Yes / No.

Sort Order Determines the sequence in which attribute appears when listed
with other attributes.

Field Descriptions (cont.)
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Gift Registry Search Widget
The Widget tool can be used to place a gift registry quick search box anywhere in your
store. You can specify which search options are available to customers, including: name,
email address, and gift registry ID.

Gift Registry Search Widget

After clicking the Search button, the customer is provided with the search results on the
Gift Registry Search page. If the search returns no results, the customer can try searching
again by using the search options on the page. To learn more, see: Widgets.
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To add a gift registry search widget:

1. On the Admin menu, select CMS > Widgets. Then in the upper-right corner, click the Add
New Widget Instance button.

2. In the Settings section, do the following:

Widget Settings

a. Set Type to “Gift Registry Search.”

b. Set Design Package/Theme to the theme that is used by the store.

c. Click the Continue button.

3. In the Frontend Properties section, do the following:

Frontend Properties

a. In theWidget Instance Title field, enter a name to identify the widget internally.

b. Set Assign to Store Views to the store views where you want the widget to be available.

c. Set Sort Order to the sequence in which this widget appears when it appears in the
same location as other widgets.

4. In the Layout Updates section below, click the Add Layout Update button. To specify
where the Gift Registry Search appears in the store, do the following:
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Layout Updates

a. Set Display On to the pages in your store where you want the widget to appear.

b. If applicable, select the Categories where you want the widget to appear.

c. Set Block Reference to the page layout block where you want to place the widget.

5. In the panel on the left, select Widget Options. To specify how visitors to your site can
search for gift registries, select as many of the following that apply:

l All Forms

l Recipient Name Search

l Recipient Email Search

l Gift Registry ID Search

Widget Options

6. When complete, click the Save button.

7. When prompted to refresh the page cache, click the link in the message at the top of the
workspace and follow the instructions.
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FIELD DESCRIPTION

SETTINGS

Type Identifies “Gift Registry Search” as the widget type.

Design Package/Theme The theme that is used by the store where the widget is to be
used.

FRONTEND PROPERTIES

Widget Instance Title The name of the widget to be used for internal reference.

Assign to Store Views Identifies the store views where the widget is to be available.

Sort Order Order in which widget should appear, relative to other elements in
the block in which it appears.

LAYOUT UPDATES

Display On Indicate the specific pages or the types of pages on which the
gift registry search widget should appear.

Categories If applicable, identifies the category pages where the widget will
appear.

Block Reference Indicates the page layout block where the widget will be placed.
The options vary by template and theme.

WIDGET OPTIONS

Quick Search Form Types Specifies the parameters that are included in the gift registry
quick search box. Options include:
All Forms
Recipient Name Search
Recipient Email Search
Gift Registry ID Search

Field Descriptions
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Rewards & Loyalty
The Magento Reward Points System gives you the ability to implement unique
programs that enhance user experience and increase customer loyalty. You can set up
points to be awarded based on a wide range of transaction and customer activities. and
control the point allotment, balance, and expiration. Customers can redeem points
toward purchases, based on the conversion rate that you establish between reward
points and currency. Here are a few examples:

Shopping Cart Price Rules

Points can be rewarded to customers on the basis of a shopping cart rule. They can be
rewarded as the only action of the price rule, or in conjunction with a discount.

Customer Balance

Reward Points balances can be managed by admin users per customer. If enabled in the
storefront, customers can also view the details of their points balance.

Redeeming Points

Points can be redeemed by admin users and (if enabled) customers during the checkout
process. In the Payment Method section, a Use my Reward Points checkbox appears
above the enabled payment methods. The available points and monetary exchange rate
is included. If the available balance is greater than the order grand total, no additional
payment methods is required. The amount of reward points applied to the order
appears with the order totals, subtracted from the grand total, similar to a store credit
or gift cards. If reward points are used in conjunction with store credit or a gift card,
the reward points are deducted first, and the store credit or gift card is deducted if the
order total is greater than the redeemable amount of reward points.

Refunding to Reward Points

Orders placed with reward points can be refunded to the reward points balance up to
the amount redeemed in the order. On the New Credit Memo page, the amount of
points to be applied to the customer’s balance can be entered. By default, the field
contains the full amount of points that were used in the order.
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Reward Point Configuration
The Reward Point configuration settings define the basic operating parameters, including
the lifetime, cap limits, and the presentation of reward points in the store.

Reward Points

Process Overview:
Step 1: Configure the Reward Points
Step 2: Configure Points Earned for Customer Activities
Step 3: Complete the Email Notification Settings
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Step 1: Configure the Reward Points

1. On the Admin menu, select System > Configuration. Then in the panel on the left, under
Customers, select Reward Points.

2. Click to expand the Reward Points section. Then, do the following:

a. To activate reward points, set Enable Reward Points Functionality to “Yes.”

b. To allow customers to earn their own reward points, set Enable Reward Points
Functionality on Frontend to “Yes.”

c. To allow customers to see a detailed history of their rewards, set Customers may see
Reward Point History to “Yes.”

3. Enter the number of points that must accrue before they can be redeemed in the Minimum
Reward Points Balance to Be Able to Redeem field. Leave blank for no minimum. Then,
do the following:

a. Enter the maximum number of points a customer can accrue in the Cap Reward
Points Balance At field. Leave blank for no limit.

b. Enter the number of days before the reward points expire in the Reward Points Expire
in (days) field. Leave blank for no expiration.

c. Set Reward Points Expiry Calculation to one of the following:

Static Determines the remaining lifetime of reward points based on
the number of days set in the configuration. If the expiration
limit in the configuration changes, the expiration date of
existing points does not change.

Dynamic Calculates the number of days left whenever the reward point
balance increases. If the expiration limit in the configuration
changes, the expiration of all existing points are updated
accordingly.

d. If you want to refund available reward points automatically, set Refund Reward
Points Automatically to “Yes.”

e. If you want to automatically deduct reward points from the amount of a refund, set
Deduct Reward Points from Refund Amount Automatically to “Yes.”

4. Set Landing Page to the CMS page that explains your reward points program. Make sure
to update the default Rewards Points page with your own information.

5. When complete, click the Save Config button.
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Step 2: Configure Points Earned for Customer Activities

This section specifies the number of reward points that can be earned for various customer
activities. When points can be earned for completing an action, a message appears to let
customers know how many points they can earn.

1. Click to expand the Actions for Acquiring Reward Points by Customer section. Then, do
the following:

Actions for Acquiring Reward Points by Customer

a. In the Purchase field, enter the number of points earned for placing an order.

b. In the Registration field, enter the number of points earned for opening a customer
account.

c. In the Newsletter Signup field, enter the number of points earned by registered
customers who subscribe to a newsletter.

2. In the Converting Invitation to Customer field, enter the number of points earned by a
customer who sends an invitation, if the recipient then opens a customer account. Then,
do the following:

a. Enter a number in the Invitation to Customer Conversions Quantity Limit field to
limit the number of invitation conversions that can be used to earn points for the
customer who sends the invitation. Leave blank for no limit.

b. In the Invitation Conversion to Order Reward field, enter the number of points earned
by a customer who sends an invitation, and the recipient places an initial order.

3. In the Review Submission field, enter the number of points earned by a customer who
submits a review that is approved for publication. Then, do the following:
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To limit the number of reviews that can be used to earn points per customer, enter the
number in the Rewarded Reviews Submission Quantity Limit field. Leave blank for no
limit.

4. In the New Tag Submission field, enter the number of points earned by the customer
when a submitted tag is approved for publication.

To limit the number of tags that can be used to earn points per customer, enter the number
in the Rewarded Tag Submission Quantity Limit field. Leave blank for no limit.

Step 3: Complete the Email Notification Settings

1. Click to expand the Email Notification Settings section. Then, do the following:

Email Notification Settings

a. Set Email Sender to the store contact that appears as the sender of balance updates
and expiration notifications.

b. If you want to subscribe customers by default to be notified of balance updates and
upcoming expiration dates, set Subscribe Customers by Default to “Yes.”

c. Set Balance Update Email to the template used for the notification that is sent to
customers whenever their point balance is updated.

d. Set Reward Points Expiry Warning Email to the template used for the notification
that is sent to customers when the expiration limit for a batch of points is reached.

e. In the Expiry Warning Before (days) field, enter the number of days before points
expire that notification is sent.

2. When complete, click the Save Config button.
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Reward Exchange Rates
Reward Exchange Rates determine the amount of points that are earned based on the order
amount, as well as the amount of monetary credit that is available when points are
redeemed.

Manage Reward Exchange Rates

Different exchange rates can be applied to different websites and different customer groups.
If multiple exchange rates from different websites and customer groups apply to the same
customer, the following rules of priority apply:

PRIORITY DESCRIPTION

1 Applies to specific website and specific customer group.

2 Applies to all websites and a specific customer group.

3 Applies to a specific website and all customer groups.

4 Applies to all websites and all customer groups.

Exchange Rate Priority

When converting currency to points, the amount of points cannot be divided. Any currency
remainder is rounded down. For example, if $2.00 converts to 10 points, points will be
earned in groups of $2.00. Therefore, a $7.00 order would earn 30 points, and the
remaining $1.00 would be rounded down. The monetary amount of the order is defined as
the amount which the merchant receives, or the grand total minus shipping, tax,
discounts, store credit, and gift cards. The points will be earned the moment when there are
no non-invoiced items in the order (all items are either paid or canceled). If an Admin user
does not want to allow customers to earn Reward Points for canceled orders, those points
can be manually deducted from the Manage Customers page.
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To manage exchange rates:

1. On the Admin menu, select Customers > Reward Exchange Rates. Then. in the upper-
right corner, click the Add New Rate button.

2. In the Reward Exchange Rate Information section, do the following:

Reward Exchange Rate Information

a. Set Website to the sites where the reward exchange rate applies.

b. Set Customer Group to the groups where the reward exchange rate applies.

c. Set Direction to one of the following:

l Points to Currency

l Currency to Points

For either Direction setting, the amount is represented in the base currency of the
website.

3. Enter the Rate values according to the Direction setting.

Points to Currency In the first Rate field, enter the number of points. In the
second Rate field, enter the monetary value of the points.

Currency to Points In the first Rate field, enter the monetary value. In the
second Rate field, enter the number of points that is
represented by the monetary value.

When converting points to currency, the amount of points cannot be divided. For example,
if 10 points converts to $2.00, points must be redeemed in groups of ten. Therefore, 25
points would redeem for $4.00, with 5 points remaining in the customer’s balance.

4. When complete, click the Save button.
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FIELD DESCRIPTION

Website The website(s) where the reward rates apply.

Customer Group The customer group(s) to which the reward rates apply.

Direction Determines which type of transaction the exchange rate define.
Options include:

Points to Currency Defines the number of points that can be
applied as credit towards the amount of
an order.
In the first rate field, enter the number of
points. In the second Rate field, enter
themonetary value of the points.

Currency to Points Defines the amount of an order that can
earn the customer a number of points.
In the first Rate field, enter themonetary
value. In the second Rate field, enter the
number of points represented by the
monetary value.

Field Descriptions

Reward Points in Price Rules
Reward points can be awarded to customers on the basis of a shopping cart rule. The award
of points can be the only action of the price rule, or used in conjunction with a discount.

To add reward points to a price rule:

1. On the Admin menu, select Promotions > Shopping Cart Price Rules. Then, do one of the
following:

l In the list, click to open an existing price rule.

l Click the Add New Rule button.

2. In the panel on the left, select Actions. Then, enter the amount of points in the Add
Reward Points field.

3. Follow the standard instructions to complete the shopping cart price rule.

When the price rule is activated, a message appears in the shopping to let customers know
how many points they can earn by placing the order.
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CHAPTER 29:

Private Sales and Events
Private sales are a great way to leverage your existing customer base to generate buzz
and new leads, or to offload surplus inventory. You can create limited-time sales, limit
sales to specific members, or create a stand-alone private sale page. You can also define
invitations and event details.

Increase brand loyalty and generate a buzz by giving your best customers the VIP
treatment. Offer exclusive access to Member Only sales or private sales to increase
brand loyalty. You can also use these sales to liquidate excess merchandise. Customer
Groups are extremely useful in setting up these types of Members Only and VIP sales.
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Event Components

Categories

Each event is associated with a category from your catalog.

Events

Event sales are based on a starting and ending date. You can display a countdown ticker to
show the time remaining.

Event Widget

When the Event Widget is enabled, it appears on the home page and category pages. It
lists open and upcoming events, sorted by end date. If two or more events share the same
end date, the events are sorted based on the order specified in the configuration.

Customer Groups

Category permissions are based primarily on customer groups.

Category Permissions

Category permissions gives you full control over the specific activities that can take place in
a given category.

Website Restrictions

Prevents public access to the site by redirecting to a landing page, login page, or
registration page.

Invitations

Email messages are sent with a link to create an account in the store. You can restrict the
ability to create an account to only those who receive an invitation.
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Private Sale Website Restrictions
Use the following procedure to restrict access to a private sale event, or to a members only
or B2B website.

Website Restrictions

To set up exclusive access:

1. On the Admin menu, select System > Configuration. In the panel on the left, under
General, select General.

2. Click to expand theWebsite Restrictions section, and do the following:.

a. Set Access Restriction to “Yes.”

b. Set Restriction Mode to one of the following:

l Private Sales: Login Only

l Private Sales: Login and Register

c. Set Startup Page to one of the following:

To login form (302
Found)

Users are redirected to the login form before gaining access to
the site.

To landing page
(302 Found)

Users are redirected to the specified landing page until they log
in.

Important! Be sure to include a link to the login page from the
landing page so customers can log in to access the site.

d. Choose the Landing Page that you want to appear before customers log in to the
private sale site.

e. To let search engine bots and spiders know that the landing page is correct, and that
there are no other pages on the site to index. set HTTP Response to “200 OK”

3. When complete, click the Save Config button.
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Event Ticker
If the Category Page ticker is enabled for an event, the ticker block appears at the top of the
product list. If the Product Page ticker is enabled, the ticker block also appears at the top of
the product page (for products that are associated with the category).

Like the Event Widget, the ticker block displays a countdown ticker for open events, with
the start and end date for upcoming events. If an event is closed, the ticker block will
indicate this (and includes the start and end date, similar to Upcoming events).

Event Ticker

Selling Restrictions
By default, products that appear in upcoming or closed events are not available for general
sale, and the Add to Cart button does not appear on the product list or product page.

To restore the Add to Cart button for a closed event, the event must be deleted. However, if
a product is associated with another category that has no selling restrictions, the Add to
Cart button does appear on the product page. Similarly, the ticker block does not appear on
the product page if the product is associated with another category that has no selling
restrictions.
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Event Configuration
Before you can create an event, you must first complete the basic configuration to enable
events and set up the event sidebar widget.

To enable and configure events:

1. On the Admin menu, select System > Configuration. Then in the panel on the left under
Catalog, select Catalog.

2. Click to expand the Catalog Events section, and do the following:

Catalog Events

a. Set Enable Catalog Events Functionality to “Yes.”

b. Set Enable Catalog Event Widget on the Frontend to “Yes.”

c. Enter the Number of Events to be Displayed in the Event Slider Sidebar Widget. By
default, this value is set to 5.

d. Enter the number of Events to Scroll per Click in Event Slider Sidebar Widget.

3. When complete, click the Save Config button.
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Creating Events
Each event is associated with a category from your catalog, and only one event can be
associated with any given category at a time.

Manage Catalog Events

To create an event:

1. On the Admin menu, select Catalog > Categories > Catalog Events.

2. In the upper-right corner, click the Add Catalog Event button. Then, do the following:

3. In the category tree, select the category that you want to associate with the event.

Because each category can have only one event at a time, any categories that already have
an event are disabled in the category tree.

Category Tree

4. In the Catalog Event Information section, do the following:
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Catalog Event Information

a. Click the calendar button to select the Start Date and time of the event.

b. Click the calendar button to select the End Date and time of the event.

c. To upload an Image for the event widget, click the Choose File button. Then, select
the image file from your directory.

d. In the Sort Order field, enter a number to indicate the sequence in which this event
appears when listed with other events.

e. Select the checkbox of each page that you want to Display Countdown Ticker On.

5. When complete, click the Save button.
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FIELD SCOPE DESCRIPTION

Category Global When creating a new event, this field links back to
the category tree. When editing an event, it links
to the category page related to the event.

Start Date Global The starting date and time of the event in
MMDDYYYY HH;MM format. Click the calendar
button to select the date.

End Date Global The ending date and time of the event in
MMDDYYYY HH;MM format. Click the calendar
button to select the date.

Image Store View Uploads an image for the event widget.

Sort Order Global Determines the sequence in which this event
appears when listed with other events.

Display Countdown Ticker
On

Global Displays the countdown ticker in the header of
each page specified. Options include:
Category Page / Product Page

Status Global Indicates the status of the event based on the
Start Date and End Date range. Status is a read-
only value. Values include:
Open / Closed / Upcoming

Field Descriptions
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Editing Events
Events can be edited from either the Manage Catalog Events page or from the category that
is associated with the event. Whenever a category has an associated event, an Edit Event
button appears in the upper-right corner that takes you to the event information.

Edit Event
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Method 1: Edit Event from Manage Catalog Events

1. On the Admin menu, select Catalog > Categories > Catalog Events.

2. On the Manage Catalog Events page, click to open the event that you want to edit.

3. Make the necessary changes to the event.

Edit Catalog Event

4. When complete, click the Save button.

Method 2: Edit Event from Category

1. On the Admin menu, select Catalog > Categories > Manage Categories.

2. In the category tree on the left, click to select the category. Then in the upper-right corner,
click the Edit Event button.

3. Make the necessary changes to the event.

4. When complete, click the Save button.
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Invitations
When invitations are enabled, customers can send and view invitations from their account
dashboard. The invitation email includes a link to the customer account registration form
in your store. The invitation configuration enables invitations for the store and identifies
the referring customer group. Invitations must be configured before they can be used for an
event.

Invitation Workflow
The customer’s account lists all invitations sent, including the email address of the
recipient, and the current status (Sent, Accepted, or Canceled) on the “My Invitations”
page. It also includes a Send Invitations button, which redirects to the Invitation form that
contains a field for the email address of each recipient. The fields included and message
text box are set up in the configuration. When the Send Invitations button is clicked, the
invitation email is sent to the recipients. If a recipient email belongs to an existing
customer, the invitation email is not sent to the email address, and no record is created in
the system. Customers can also send invitations using the Send Invitations link in the
store header.

To configure invitations:

1. On the Admin menu, select System > Configuration.

2. In the panel on the left, under Customers, select the Invitations.

3. Click to expand the General section. Then, do the following:

General
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a. Set Enable Invitations Functionality to “Yes.”

b. To allow customers to manage invitations from the storefront, set Enable Invitations
on Frontend to “Yes.”

c. Set Referred Customer Group to one of the following:

l Same as Inviter

l Default Customer Group from Configuration

d. Set New Accounts Registration to one of the following:

l By Invitation Only

l Available to All

e. To Allow Customers to Add Custom Message to Invitation Email, select “Yes.”

f. To limit the number of invitations that can be sent at one time, enter the number in
the Max Invitations Allowed to be Sent at One Time field.

4. Click to expand the Email section. Then, do the following:

EmailEmail

a. Select the store identity to be used as the Customer Invitation Email Sender.

b. Select the Customer Invitation Email Template used for invitations sent.

5. When complete, click the Save Config button.
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Invitation Reports

General

This report summarizes invitation information for the designated scope and period of time.
The scope is defined in the Show Report control at the top of the page. There is one line for
each period. A period can be a day, month, or year, and is defined in the Show by control at
the top of the page. The number of periods in the report depends on the date range
designated. For each period, you can see the total number of invitations sent, accepted, and
canceled, as well as the percentage of sent invitations which have been accepted, and the
percentage of sent invitations which have been canceled.

Customers

This report summarizes invitation information by customer for the designated scope and
period of time. The scope is defined in the Show Report control at the top of the page. There
is one line for each period. A period can be a day, month, or uear, and is defined in the
Show by control at the top of the page. The number of periods in the report depends on the
date range designated. For each period, you can see a list of all customers who have sent
invitations, including their ID, name, email, and customer group. Additionally, you can see
the number of invitations they have sent during that period, and the number of invitations
which have been accepted.

Order Conversion Rate

This report summarizes Invitation and sales information for the designated scope and
period of time. The scope is defined in the Show Report control at the top of the page. There
is one line for each period. A period can be a day, month, or year, and is defined with the
Show by control at the top of the page. The number of periods in the report depends on the
date range designated. For each period, you can see the number of invitations which have
been sent, the number of the invitations which have been accepted, the number customers
who have completed an order after accepting an invitation, and the percentage of
invitations sent that led to a completed order.

To view invitation reports:

1. On the Admin menu, select Reports > Invitations.

2. Select the report you want to view. Then, follow the process to generate the report.
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CHAPTER 30:

Newsletters
Publishing a regular newsletter is considered to be one of the most powerful and
affordable marketing tools available. Magento Enterprise Edition gives store
administrators the ability to publish and distribute newsletters to customers who have
registered to receive them, plus all the tools necessary to:

l Promote your newsletter

l Build and manage your list of subscribers

l Develop content

l Maintain an archive of back issues

l Drive traffic to your store



Newsletter Configuration CHAPTER 30:  Newsletters

502 Magento Enterprise Edition User Guide, Version 1.14.2.1

Newsletter Configuration
The first step in creating newsletters is to configure the newsletter settings for your site.
You can require customers to confirm the registration by clicking a confirmation link sent
by email. This technique is called double opt-in1, because customers must confirm twice
that they want to receive a newsletter. This method reduces the number of customers that
might otherwise consider your newsletter as spam.

To configure newsletter settings on your site:

1. On the Admin menu, select System > Configuration.

2. In the panel on the left, under Customers, select Newsletters.

3. Click to expand the Subscription Options section. Then, do the following:

Subscription Options

a. Confirm the email templates and senders of the following email messages sent to
subscribers:

l Success email

l Confirmation email

l Unsubscription email

b. To require people to double-opt in to confirm their subscription, set Need to Confirm
to “Yes.”

c. To allow people who do not have an account with your store to subscribe to the
newsletter, set Allow Guest Subscriptions to “Yes.”

d. When complete, click the Save Config button.

1The process for subscribing email recipients by requiring them to take a secondary step to confirm that they
want to receive emails.
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Newsletter Templates
Before sending a newsletter, create a newsletter template. You can create and save as many
of these as required for any situation, whether it be an annual holiday newsletter or weekly
product updates.

The example newsletter template uses separate templates for the header and footer, and
converts external CSS into inline styles. To learn more, see: Managing Email Templates.

Example Newsletter Template

To create a newsletter template:

1. On the Admin menu, select Newsletter > Newsletter Templates. The page lists the
available newsletter templates. You can edit an existing template or create a new one.

2. To add a new template, click the Add New Template button. Then, do the following:

a. In the Template Name field, specify a unique and indicative name for this template.
This value is not visible for customers.

b. In the Template Subject field, specify the subject of the email to be sent to your
customers.
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c. In the Sender Name and Sender Email fields, specify the name and email of the
sender of the email to be sent to your customers.

d. In the Template Content field, use the WYSIWYG editor to compose the body of the
email. Note that this field is pre-filled with tags showing an unsubscribe link in the
email. We recommend that you do not remove this link so that all emails that are sent
enable your customers to unsubscribe from the newsletter.

e. Click Preview Template, to display the content with the formatting as it will be viewed
by your subscribers.

3. When complete, click the Save Template button.

After the template has been saved, a Save As button appears whenever the template is
opened in edit mode. This gives you the ability to make changes and save it as a new
template, without affecting the original.

Newsletter Queue
A newsletter that has many recipients must be sent in stages. The process of sending the
newsletter is managed by a queue. After you start the queue, Magento sends the emails in
packs.

To ensure delivery of your newsletters, it is recommended that you integrate your Magento
installation with a third-party newsletter provider. These services are “white listed” by
email service providers. Look for newsletter providers in Magento Connect.

To send your newsletter using a queue:

1. On the Admin menu, select Newsletter > Newsletter Templates.

2. Set the Actions control to the relevant template. Then, select Queue Newsletter.

3. In the Queue Date Start field, specify when the newsletter will start being sent.

4. In the Subscribers From field, select one or more store views whose customers this
newsletter will be sent to.

5. Review the template and parameters and then click the Save Newsletter button to schedule
sending the newsletter.
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Newsletter Reports

Newsletter Queue

Shows the newsletter queues that have been defined and indicates their progress in sending
emails.

Newsletter Subscribers

Shows a list of customers that have subscribed to your newsletter. It also enables you to
unsubscribe these customers manually.

Newsletter Problem Reports

Shows a list of errors that have occurred while sending the email. This Report enables you
to remove the incorrect emails from the subscribers list.
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CHAPTER 31:

Sales Channels
Publishing your catalog through multiple channels is an effective way to widen your
distribution without much effort. You can start by syndicating your content with RSS
feeds, and then expand by sending your catalog data to shopping sites and aggregators
and marketplaces.

Topics in this chapter:

l Google Shopping

l RSS Feeds

l Social Media
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Google Shopping
Google Shopping is a Google AdWords service that publishes product feeds from merchant
catalogs. Any Simple product from your catalog can be uploaded to Google Shopping.

Each product attribute is mapped to Google and used as search parameters by customers
who are searching for products. After mapping the product attributes to synchronize with
Google Content attributes, you can publish products from your store on Google Shopping.
To use Google Shopping, you need both a Google Merchant account and a Google AdWords
account. To learn more, visit the Google Ads Shopping page on their site.

The following instructions show how to set Google Content for your store. You might also
find extensions on Magento Connect that streamline the process.

Google Shopping

Process Overview
Step 1: Set Up Your Google Accounts
Step 2: Configure Your Store for Google Shopping
Step 3: Map Your Product Attributes
Step 4: Add Your Google Content Items
Step 5: Manage Your Content

http://www.google.com/shopping
http://www.google.com/ads/shopping/getstarted.html
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Step 1: Set Up Your Google Accounts

1. Visit Google Merchant Center, and sign up for an account. Complete the following steps in
the Beginner’s Guide:

l Open your Merchant account

l Set up your account

l Verify and claim your website URL

Google Merchant Center Help

2. Write down the following information from your Google account:

l Account ID

l Account Login

l Account Password

l Account Type

l Target Country

Step 2: Configure Your Store for Google Shopping

1. Log in to the Admin of your store. Then on the Admin menu, select System >
Configuration. Then in the panel on the left under Sales, select Google API.

2. Click to expand the Google Shopping section, and do the following:
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a. Enter the following information from your Google merchant account:

l Account ID

l Account Login

l Account Password

l Account Type

l Target Country

b. Set Update Google Shopping Item When Product Is Updated to “Yes.”

c. Set Debug to “No.” You can change this setting later, if necessary.

d. Under Destinations, select each place where you want your products to be listed. Each
destination can be set to Default, Required, or Excluded.

l Google Product Search

l Product Ads

l Commerce Search

Default Your updates are submitted using the Google default
settings.

Required The update must be submitted to the required
destination. If the update does not pass Google’s
validation rules, you receive notification of validation
errors, and the update is not submitted to any
destination.

Excluded The update is not submitted to this destination, but
it can still be submitted to other destinations,
depending on the settings.

Google Shopping

3. When complete, click the Save Config button.
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Step 3: Map Your Product Attributes

In this step, you will map your attribute sets to match Google item types and attributes, so
Google can retrieve your product information. During the process, you will add the
attributes you want to upload from your catalog to Google Content.

In addition to the two required attributes, Product Type and Product Condition, it is
recommended that you include the Title, Description and Price in the attribute section. In
addition to these, you should include any other attributes that will help people find the
product. To learn more about mapping different product types, see Google’s Summary of
Attribute Requirements.

REQUIRED RECOMMENDED

Product Type
Condition

Title
Description
Price

Product Attributes

Because Condition is a required field, why not create a drop-down attribute called
“condition” with the values “New” and “Used” before you begin? Then, add it to the
attribute set that you are mapping.

1. On the Admin menu, select Catalog > Google Content > Manage Attributes.

2. Click the Add Attribute Mapping button. Then do the following:

a. Select the Target Country where your business is located.

b. In the Attribute Set list, select the first attribute set you want to map. For example:
Clothing.

Add Attribute Mapping

3. To begin mapping attributes, click the Add New Attribute button. Then do the following:

a. Set Target Country to where the products are available for sale.

b. Choose the first Attribute Set from your catalog that you want to map.

c. Set the Google Product Category to the best match for your catalog’s attribute set.
For example, the closest match for “Clothing” is “Apparel & Accessories.”
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New Attribute Set Mapping

4. When that attribute set is mapped, click the Add New Attribute button to map the
individual attributes. Then, do the following:

a. Select an Attribute from your store. Then, find the Google Content Attribute that is
the best match.

b. Click Add New Attribute to map the next attribute that you want to use.

c. Repeat these steps until you have mapped all the attributes that you need.

Attribute Mapping

5. When complete, click the Save Mapping button.
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Mapping Complete

Step 4: Add Your Google Content Items

After you finish mapping, the next step is to select the products that you want to publish
to Google Content. From this page, you can publish, delete, and synchronize your products
to Google Content. After the products are synchronized, you can view the status and
expiration date of each product, the number of clicks and impressions it has received. 

1. On the Admin menu, select Catalog > Google Content > Manage Items.

2. Use the list and filter controls to find the products that you want. Then, select the
checkbox of each product you want to add to Google Content.

3. When you finish selecting products, set the Actions control to “Add to Google Content.”
Then click the Submit button.
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Add Your Products

Step 5: Manage Your Content

It can take up to twenty-four hours for a product to be published in Google Content, and
products do not immediately appear in the Manage Items list. Changes also can take up to
a day to process. After you make changes, you can synchronize your content Google
Shopping.

After completing the configuration, return to your Google merchant account to make sure
that your products appear. If they don’t appear, make sure that the Country setting in the
upper-right corner is correct.

When your product feed is live, you can view the number of impressions and clicks from
the Manage Items page.
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Setting Up RSS Feeds
RSS (Really Simple Syndication) is an XML-based data format that is used to distribute
information online. Your customers can subscribe to your RSS feeds and be notified of new
products and promotions. RSS Feeds can also be used to publish your product information
to shopping aggregation sites, and can also be included in newsletters.

RSS Feed Configuration

When RSS feeds are enabled, any additions to products, specials, categories, and coupons
in your store are automatically sent to the subscribers of each feed. A link to all the RSS
feeds that you publish is in the footer of your store.

The software that is used to read an RSS feed is called a feed reader1, and allows people
to subscribe to headlines, blogs, podcasts, and much more. Google Reader is one of the
many feed readers which are available online for free.

To set up RSS feeds for your store:

1. From the Admin menu, select System > Configuration.

2. In the upper-right corner, set Current Configuration Scope to the store view where you
want the feeds to be available.

3. In the panel on the left, under Catalog, select RSS Feeds.

4. In the Rss Config section, set Enable RSS to “Enable.” Then, in each section below, set the
feeds that you want to activate to “Enable.”

1Software that is used to read syndicated content from RSS feeds.

515Magento Enterprise Edition User Guide, Version 1.14.2.1



Setting Up RSS Feeds CHAPTER 31:  Sales Channels

516 Magento Enterprise Edition User Guide, Version 1.14.2.1

RSS Config

a. In the Wishlist section, set Enable RSS to “Enable.”

Wishlist

b. In the Catalog section, set any, or all, of the following feeds to “Enable.”

l New Products

l Special Products

l Coupons/Discounts

l Tags Products

l Top Level Category

l Top Level Category

Catalog

c. In the Order section, set Customer Order Status Notification to “Enable.”

Order

5. When complete, click the Save Config button.

http://merch.docs.magento.com/ee/user_guide/Magento_Enterprise_Edition_User_Guide.html#configuration/catalog/rss-feeds.html%23RSS_Config
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RSS FEED DESCRIPTION

Wishlist When enabled, an RSS feed link will be available on top of
customer wishlist pages. Additionally, the wishlist sharing page
will also include a checkbox that lets you add a link to wishlist
RSS feeds on shared wishlists.

New Products The new products RSS feed tracks new products added to the
store catalog and will syndicate them.

Special Products The special products RSS feed will syndicate products with
special pricing.

Coupons / Discounts Any special coupons or discounts generated in your store will be
added to this RSS feed.

Tags Products The tags products RSS feedmanages and syndicates newly
added product tags.

Top Level Category This RSS feed tracks new top level categories, or root level
categories, in your catalog.

Customer Order Status Allows customers to track their order status with an RSS feed.
When enabled, an RSS feed link will appear on the order.

Types of RSS Feeds
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Social Media
There are many social marketing extensions that can be added to your store. To learn more,
visit Magento Connect. Other topics in this section:

l Adding Facebook Plugins

l Facebook Configuration for Developers

l Facebook Open Graph

Social Marketing Extensions

http://www.magentocommerce.com/magento-connect/marketing/social-marketing.html
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Adding Facebook Plugins
Facebook has a number of social plugins that can easily be added to your store. The
following example shows how to add a Like Button to your store.

Facebook Plugins

Process Overview:
Step 1: Get the Button Code
Step 2:Create a Static Block
Step 3: Use aWidget to Place the Block
Step 4: Verify the Placement

Step 1: Get the Button Code

1. On the Facebook site, go to the button setup page.

2. In the URL to Like field, enter the URL of the page in your store that you want people to
Like. For example, enter the URL of your store’s home page. Then, do the following:

a. Choose the Layout for the button.

b. Enter theWidth in pixels that is available on your site for the button and any
associated text message.

c. Set Action Type to one of the following:

l Like

l Recommend
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3. Click the Get Code button to copy the generated code to the clipboard.

Like Button Setup

Step 2: Create a Static Block

1. Return to your store. On the Admin menu, select CMS > Static Blocks.

2. In the upper-right corner, click the Add New Block button. Then, do the following:

a. Enter a descriptive Block Title. For example: Facebook Like Button.

b. Assign a unique Identifier to the block, using all lowercase characters, with
underscores instead of spaces. For example: facebook_like_button.

c. Select the Store View(s) where you want the block to appear.

d. Set Status to “Enabled.”

e. Paste the snippet of code that you copied from Facebook into the Content box.

3. When complete, click the Save Block button.

Step 3: Use a Widget to Place the Block

1. On the Admin menu, select CMS > Widgets.

2. In the upper-right corner, click the Add New Widget Instance button.

3. In the Settings box, do the following:
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Widget Settings

a. Set Type to “CMS Static Block.”

b. Set Design Package/Theme to your current theme.

c. Click the Continue button.

4. In the Frontend Properties box, do the following:

a. Enter theWidget Instance Title to appear in the list of widgets that are available in
your store. For example: Facebook Like Button.

b. If you want the button to appear in all views of your store, set Assign to Store Views
to “All Store Views.”

c. You can leave Sort Order blank for now.

Frontend Properties

5. In the Layout Updates section, click the Add Layout Update button. Then, do the
following:
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Layout Updates

a. Set Display On to “All Pages.”

b. Set Block Reference to the place on the page where you want the button to appear.
For a diagram of block references, see: Standard Block Layout.

In general, either the header or footer are good places for a Like button because it will
appear in the same place on every page of the store. Depending on your store, you
might need to update the Sort Order field to position the button in relation to other
content that is assigned to the same place on the page. You can try several settings to
see what works best.

c. Click Save and Continue Edit.

6. In the panel on the left, select Widget Options. Then, do the following:

a. Click the Select Block button.

Select Block

b. In the list, find the block that you created for the Facebook Like button, and select the
block.

c. When complete, click Save.
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7. When prompted, follow the instructions in the message at the top of the workspace to
update the index and page cache.

Step 4: Verify the Placement

Return to your storefront to make sure that the Facebook Like button is in the right
location. If you want to try a different place, reopen the widget and change the block
reference.

Facebook Configuration
Magento’s Facebook configuration gives developers the ability to integrate custom Facebook
apps with the store.

Step 1: Register as a Facebook Developer

1. Visit the Facebook Developer site and click the Register Now button.

2. Complete the verification steps to register as a developer.

Step 2: Complete the Magento Configuration

1. On the Admin menu, select System > Configuration. Then in the panel on the left under
Social, select Facebook.

2. Click to expand the Facebook Config section. Then, do the following:

Facebook Config

a. Set Enable Facebook on Frontend to “Yes.”

b. Enter the following credentials from your Facebook developer account:

l App Namespace

l App ID

l App Secret

c. Enter the Object Type.

3. Click the Add Action Button. Then, do the following:
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a. Select the type of Action.

b. Enter the Button Title.

c. To display a Facebook FriendBox, set Enable FriendBox to “Yes.”

Facebook Config

d. Enter the maximum number of friends that can be in your FriendBox.

4. When complete, click the Save Config button.

Facebook OpenGraph
The Facebook Open Graph 2.0 extension enables Facebook developers to add custom social
networking buttons to your store. The Facebook Open Graph 2.0 extension is free of charge
and can be downloaded from Magento Connect.

Facebook Open Graph

The extension uses the Facebook Open Graph 2.0 protocol. When the extension is
successfully installed and all configuration is complete, the Facebook buttons appear on
each product page in the store, along with the Facebook blocks that provide information
about other Facebook users and friends who have clicked the social buttons. The
information provided in the blocks depends on the customer who is logged in to Facebook
and whether friends have performed actions with your app, such as clicked a social button.

http://merch.docs.magento.com/ee/user_guide/Magento_Enterprise_Edition_User_Guide.html#configuration/social/facebook.html%23Facebook_Config
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Process Overview:
Step 1: Download and install the extension
Step 2: Create an application on the Facebook Developer site
Step 3: ConfigureMagento

Step 1: Download and Install the Extension

1. Visit Magento Connect, and download the Facebook Open Graph 2.0 extension. Then, copy
the Extension Key to the clipboard.

2. On the Admin menu, select System > Magento Connect > Magento Connect Manager.

3. When prompted, enter your Admin credentials, and click the Log In button.

4. Paste the Extension Key, and click the Install button.

Step 2: Create Application on Facebook Developer Site

The current implementation of the Facebook Open Graph 2.0 extension requires an
application to be created manually on the Facebook Developers site.

1. Navigate to: https://developers.facebook.com/

2. In the main menu, click Apps.

3. Click Create New Application and perform all of the steps of the app creation wizard.

The App Namespace value that you entered will be used in the Magento configuration.

4. In the left column, select Settings > Basic. Under the “Select how your app integrates with
Facebook” heading, select Website. Then in the Site URL field, enter your store address.

Important! Your website and store should have one domain name.

a. For Action Types in the Advanced settings in the Graph API URL field enter own,
want or other action you want to be associated with a social networking button on
your product pages. This title is for internal use.

The dislike action is not supported by Facebook Open Graph 2.0, and cannot be saved.

b. The Object Type you create should have the following Object Properties:
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l URL (page URL)

l Title (product title)

l Image (image URL)

l Description (product description)

l Price

By default, a new Object Type has only the first four properties. To add the Price
property, use the Add Another Property button on the Object Type page.

Step 3: Configure Magento

1. On the Admin menu, select System > Configuration.

2. In the panel on the left, under Social, select Facebook.

3. Set Current Configuration Scope to your website.

4. In the Facebook Config section, do the following:

Facebook Config

a. To display Facebook buttons in the store, set Enable Facebook on Frontend to “Yes.”

b. Enter the App Namespace value of your application. You can find it in the Basic
Settings section of your app on the Facebook Developers site.

c. Specify the App ID and App Secret values of your application. You can find them in
the Basic Settings section of your app on the Facebook Developers site.

d. Enter the Open Graph Type value of your Object Type. To find it on the Facebook
Developers site, open the settings of your application, navigate to Open Graph >
Dashboard, click your object type, and expand the Advanced settings.

On the page header, the system will display the Apps > %Your Facebook Application
Name% > Open Graph > Object Type: %Object name%.

e. To add and configure a button, click Add Action Button and complete the setup for
each button. The action settings can be different for each store view.

http://merch.docs.magento.com/ee/user_guide/Magento_Enterprise_Edition_User_Guide.html#configuration/social/facebook.html%23Facebook_Config
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Facebook Config

Action In the Action column, specify the internal button action title,
for example, own or want. This value should correspond to the
value you have specified in the Graph API URL field on the
Facebook Developers site. The Graph API URL field is available
in the Advanced section of the Action Type settings.

Button Title In the Button Title column, specify the name of the social
networking button as you want it to appear in the frontend.

Enable Friend Box In the Enable FriendBox column decide if you want to display
in the frontend the related Facebook block, which contains the
count and the pictures of friends.

Count Friend Box In the Count in FriendBox column, set the maximum number
of friends that can be displayed in the related Facebook block.
By default, it is set to 3. If you set zero value (0) or leave the
field empty, then the default value is applied.

5. When complete, click Save Config button.

The social network buttons you have created and the corresponding Facebook blocks now
appear on the product pages of your store.
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CHAPTER 32:

Google Tools
Your store includes a number of tools to help optimize your content, analyze your
traffic, and connect your catalog to shopping aggregators and marketplaces.

Topics in this chapter:

l Google Merchant Center

l Google Sitemap

l Google Analytics

Google Merchant Center
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Google Merchant Center
Google Merchant Center helps you manage Google’s shopping tools and services from a
single dashboard. In addition to the following services, you can also link Google Analytics
to your Merchant Center account.

Google Shopping

Google Shopping is a commercial service that helps shoppers find products on Google,
compare products, and connect with merchants.

Product Listing Ads

Your product listings can include rich information, such as product image, price, and
merchant name. Whenever a user enters a search query on Google.com that is relevant to
an item you are trying to sell, Google will automatically show the most relevant products
along with the associated image, price, and product name.

Process Overview:
Step 1: Open aGoogleMerchant Account
Step 2: Verify YourWebsite URL
Step 3: Claim YourWebsite URL

Step 1: Open a Google Merchant Account

1. Visit the Google Merchant Center, and do one of the following:

l If you have a Google account, enter your Email address and password, and click the
Sign In button.

l Click the Sign Up button, and follow the instructions to create an account.

2. In the panel on the left, click to expand Settings, and select General.

http://www.google.com/shopping
https://www.google.com/ads/innovations/productlistingads.html
http://google.com/merchants
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Google Merchant Center Dashboard

3. Enter your Store name and Description.

4. Enter the full Website URL for your store. Depending on your domain, the URL might be
formatted as one of the following:

http://mystore.com

http://www.mystore.com

At this time, your Website URL is unclaimed and unverified.

Website URL Unverified - Unclaimed

5. Complete the remaining General settings information, and Save Changes.
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Step 2: Verify Your Website URL

In this step, you will use Google Webmaster Tools to verify that you have the right to
upload product listings from your store.

1. On a new browser tab, go to Google Webmaster Tools. Then, do the following:

a. Click the Add a Site button. When prompted, enter the URL of your store, and click
Continue.

b. When prompted to verify that you are the owner of the site, click the Alternate
methods tab.

c. Select the HTML tag method, and press Ctrl + C to copy the code.

HTML Meta Tag Code

1. Return to your store's Admin, and select System > Configuration.

2. In the Configuration panel on the left, under General, select Design. Then, do the
following:

a. Click to expand the HTML Head section.

b. Scroll down to the Miscellaneous Scripts box and press Ctrl + V to paste the
verification code from the clipboard.

c. When complete, click the Save Config button.

http://www.google.com/webmasters/tools/
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Paste Google Site Verification Code

3. Return to Google Webmaster Tools, and click the Verify button. When prompted, click
Continue. Your site is now verified.

Google Webmaster Tools - Site Verified
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Step 3: Claim Your Website URL

In this final step, you will establish the connection between your site and your Google
Merchant account.

1. Return to the Google Merchant Center. The General Settings now show that your site is
verified, but not claimed.

Google Merchant Center- Claim this URL

2. Click the Claim this URL link. Your Website URL is now both verified and claimed.

Website URL Verified and Claimed

Now that your site is verified, you can submit a sitemap to Google. You can also set up a
Google Analytics account, and link it to your Merchant Center Dashboard.
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Google Sitemap
Google Sitemap improves the way your store is indexed by their search engine, and is
specifically designed to find pages which might otherwise be overlooked. As with the
standard Magento sitemap, Google Sitemap is an index of all the pages on your site.
However, unlike the Magento sitemap, the Google Sitemap is not visible to customers.

Process Overview:
Step 1: Remove any “robots.txt” Restrictions
Step 2:Generate the Sitemap
Step 3: Submit Your Sitemap to Google
Step 4: Restore Previous “robots.txt” Restrictions

Step 1: Remove any "robots.txt" Restrictions

When first setting up your Google Sitemap, you must provide full access for Google to
index your site. If you have a robots.txt file, make sure that it includes the following
instruction:

User-agent:*

Disallow:

After your sitemap has been successfully submitted to Google, you can restore any
instructions to exclude certain locations of your site. If you have not yet set up a robots.txt
file, you can do so after you finish the sitemap.

Step 2: Generate the Sitemap

1. On the Admin menu, select Catalog > Google Sitemap.

2. In the upper-right corner, click the Add Sitemap button. Then, do the following:

a. In the Filename field, enter “sitemap.xml.”

b. Enter the path on the server to the location of the sitemap. The path must be writable.

l To put the sitemap in a folder, enter the path to the folder:
/sitemaps

l To put the sitemap at the base path of your store, enter a forward slash: /

c. Set Store View to the view where the sitemap will be used.
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Configure Google Sitemap

3. Click the Save & Generate button to create the sitemap.

The sitemap appears in the list, with a link to sitemap.xml file. From here, you can do the
following:

l To view the sitemap, click the hyperlink in the Link for Google column. This is the link
that you will later submit to Google.

l To update the sitemap, click the Generate link.

Step 3: Submit Your Sitemap to Google

1. Go to Google Webmaster Tools and do one of the following:

l Log in to your existing account.

l Create a new account, and log in.

2. Click the Add a Site button.

Add a Site

3. When prompted to enter your store address, enter the full URL of your store. For example:
http://www.mystore.com

4. Click the Continue button.
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5. To verify that you are the owner of the site, click the Alternate Methods tab. Then, choose
one of the following methods:

l Add a DNS record to your domain’s configuration

l Add a meta tag to your site’s home page

To verify your site with a meta tag, do the following:

a. Open two tabs on your browser; one for Google Webmaster Central, and the other that
is logged in to the Admin of your store.

b. Follow the instructions on Webmaster Central to copy the full text of the Google site
verification meta tag.

c. On the Admin menu, select System > Configuration. In the Configuration panel on
the left, under General, click Design.

d. In the HTML Head section, scroll down to Miscellaneous Scripts and paste the site
verification meta tag. Then, click the Save Config button.

e. Return to Google Webmaster Central, and click Verify.

Google Site Verification

6. After your site is verified and appears in your Google dashboard, do the following:

a. Click the name of your store. Then, click the Sitemaps button.

b. In the upper-right corner, click the Add/Test Sitemap button.

7. Return to your store Admin, and copy the path to your Google sitemap. If necessary, log
back in and do the following:
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a. Go to Catalog > Google Sitemap.

b. In the Link for Google column, right-click the link to your sitemap. Then on the
context menu, click Copy Shortcut.

c. Open a text editor and paste the link. Then, copy the part of the link that comes after
the “dot com.” It looks like this:

/media/s4d71280645299/sitemaps/sitemap.xml

8. Return to Google Webmaster Tools and paste the text into the box to complete the
address of your sitemap. Then, click the Submit Sitemap button.

Submit Google Sitemap

9. Make sure that the link to your sitemap is working correctly, and that your Google
dashboard shows the number of pages indexed.

Step 4: Restore Previous "robots.txt" Restrictions

If you changed your robots.txt file to make it fully accessible, you can now restore the
previous instructions to disallow access to certain areas of your site.
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Google SitemapConfiguration
Your Google sitemap should be updated as frequently as the content on your site changes,
which could be daily, weekly, or monthly. The configuration lets you set the frequency and
priority for each type of content separately.

Google Sitemap

Step 1: Complete the Generation Settings

1. On the Admin menu, select System > Configuration.

2. In the panel on the left, under Catalog, select Google Sitemap.

3. Click to expand the Generation Settings section. Then, do the following:

Generation Settings
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a. To activate Google Sitemap, set Enabled to “Yes.”

b. Set Start Time to the hour, minute and second that you want the sitemap to be
updated.

c. Set Frequency to one of the following:

l Daily

l Weekly

l Monthly

d. In the Error Email Recipient field, enter the email address of the person who is to
receive notification if an error occurs during a sitemap update.

e. Set Error Email Sender to the store contact who appears as the sender of the error
notification.

f. Set Error Email Template to the template used for the error notification.

Step 2: Set the Frequency and Priority of Content Updates

1. Click to expand the Categories Options section. Then, do the following:

a. Set Frequency to one of the following:

l Always

l Hourly

l Daily

l Weekly

l Monthly

l Yearly

l Never

b. In the Priority field, enter a value between 0.0 and 1.0. Zero has the lowest priority.

Categories Options

http://merch.docs.magento.com/ee/user_guide/Magento_Enterprise_Edition_User_Guide.html#configuration/catalog/google-sitemap.html%23Categories_Options


CHAPTER 32:  Google Tools Google Sitemap

2. Click to expand the Products Options section. Then, complete the Frequency and Priority
settings as needed.

Products Options

3. Click to expand the CMS Pages Options section. Then, complete the Frequency and
Priority settings as needed.

CMS Pages Options

4. When complete, click the Save Config button.
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Google Tag Manager
Google Tag Manager is a free tool that helps you manage the many tags, or snippets of
code, that are related to marketing campaign events. You can use Google Tag Manager to
add tracking tags to a Magento site for audience measurement, personalization, retargeting,
and search engine marketing. You can add tags on your own, without calling the IT
department to make code changes. Google Tag Manager directly transfers data and events
to Google Analytics Enhanced Ecommerce and other third-party analytics solutions, to
produce a clear picture of how well the site, products, and promotions are performing.

The following instructions walk you through the process of setting up a Google Tag
Manager account, configuring your Magento store, and creating a tag.

Process Overview:
Step 1: Set Up aGoogle TagManager Account
Step 2: Enable Google TagManager
Step 3: Create a Tag
Step 4: Preview and Publish

Step 1: Set Up a Google Tag Manager Account

1. Sign in to your Google account. Then, visit Google Tag Manager, and click the Sign up
now button.

If you have trouble logging in with your browser, either upgrade your browser or tryChrome.

2. Enter a name for your account and click the Next button.

https://www.google.com/tagmanager/
https://www.google.com/chrome/browser/desktop/index.html
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Sign Up for a Google Tag Manager Account

3. To create a tag container for your site, do the following:

a. Enter a Container Name.

b. To choose where the container will reside, click theWeb Pages button.

Container Setup

c. If you have a domain, click the Add Domain button, and enter the URL for your store.
Make sure to select the correct protocol (either http:// or https://) for your storefront.
(If you don’t yet have a domain, you can return to this later.)

d. Select your Country and Time Zone.

543Magento Enterprise Edition User Guide, Version 1.14.2.1



Google Tag Manager CHAPTER 32:  Google Tools

544 Magento Enterprise Edition User Guide, Version 1.14.2.1

e. Click Create an Account and Continue.

Set Up a Container

f. Read the Terms of Service agreement. If you agree to the terms, click I Accept to
continue.

Container Script
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g. A draft of the container script appears in the text box. This code will be added
automatically to the configuration of your store.

h. Click the Add Tags Later button. We’ll return to Tag Manager later to create tags for
your store.

Your Container Dashboard

Step 2: Enable Google Tag Manager

1. Log in to the Admin of your Magento store. Then on the Admin menu, select System >
Configuration.

2. In the panel on the left under Sales, select Google API. Click to expand the Google
Analytics Enhanced Ecommerce section, and do the following:

a. Set Enable to “Yes.”

b. Set Account type to “Google Tag Manager.”

If Google Tag Manager is installed, the Container Id appears automatically.

Google Analytics (with Google Tag Manager)
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c. Verify the following property values:

PROPERTY VALUE

List property for the catalog page Catalog Page

List property for the cross-sell block Cross-sell

List property for the up-sell block Up-sell

List property for the related products
block

Related Products

List property for the search results page Search Results

“Internal Promotions” for promotions field
“Label”

Label

d. When complete, click the Save Config button.

Step 3: Create a Tag

1. Return to your Google Tag Manager account. Then, click the link for the container you
created.

2. In the New Tag box, click Add a new tag.

Google Tag Manager

3. If you have a Google AdWords account, you can create a tag to track conversions. You will
need the following information from your AdWords account:

l Conversion ID

l Conversion Label

https://www.google.com/tagmanager/


CHAPTER 32:  Google Tools Google Tag Manager

If you need help finding this information, visit Google’s support site.

4. From the Google Tag Manager dashboard, click the Google AdWords button. Then, do
the following:

a. Click the title placeholder, and enter a name for the tag.

b. Under Choose Product, click the Google Adwords button.

Choose Product

c. Under Choose a Tag Type, click AdWords Conversion Tracking. Then, click
Continue.

5. Enter the Conversion ID and Conversion Label from your AdWords account. Then, click
Continue.

Configure Tag

6. To create a rule that causes the tag to fire on the conversion page, do the following:
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a. Under Fire On, click the Some Pages button.

b. In the Choose Pages section, complete the following settings:

Name: Enter a name for the page description.

Variable: url

Operation: contains

Value: checkout/success.*

Conversion Page Location

c. Select the green checkbox, and click the Save button. The trigger that you set up
appears as a blue button in the Fire On section.

d. When complete, click the Save Tag button.
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Step 4: Preview and Publish
The next step in the process is to preview the tag. Each time the tag is previewed, a snapshot of
the version is saved. When you are satisfied with the results, go to the version that you want to
use, and click the Publish button.
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FIELD SCOPE DESCRIPTION

Enable Store View Determines if Google Analytics Enhanced
Ecommerce can be used to analyze activity in
your store.
Options include: Yes / No

Account type Store View Determines the Google tracking code that is used
tomonitor store activity and traffic. Options
include:
Universal Analytics
Google Analytics
Google TagManager

Container Id Store View If Google Tagmanager is already installed and
configured for your store, the Container ID
appears automatically in this field.

List property for the
catalog page

Store View Identifies the TagManager property associated
with the catalog page. Default value: Catalog
Page

List property for the cross-
sell block

Store View Identifies the TagManager property associated
with the cross-sell block. Default value:Cross-sell

List property for the up-sell
block

Store View Identifies the TagManager property associated
with the up-sell block. Default value: Up-sell

List property for the related
products block

Store View Identifies the TagManager property associated
with the related products block. Default value:
Related Products

List property for the search
results page

Store View Identifies the TagManager property associated
with the search results page. Default value:
Search Results

“Internal Promotions” for
promotions field “Label”

Store View Identifies the TagManager property associated
with the labels for internal promotions. Default
value: Label

Field Descriptions
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Google Universal Analytics
Google Universal Analytics gives you the ability to define additional custom dimensions
and metrics for tracking. Universal Analytics supports offline and mobile app interactions,
and includes access to ongoing updates. :

Because Google will soon retire their “classic” tracking codes, we encourage you to upgrade
your existing Google Analytics account to Universal Analytics, and also to sign up for a free
Google Tag Manager account.

Step 1: Sign Up and Configure Google Tag Manager

Sign up for a Google Tag Manager account, and complete the Magento configuration.

Step 2: Sign Up or Upgrade to Google Universal Analytics

1. Do one of the following:

l Sign up for a new Google Universal Analytics account.

l Upgrade your classic Google Analytics account to Universal Analytics.

During the first part of the upgrade process, your existing account properties and
tracking code are converted to the Universal Analytics format, but your data and
settings are preserved. In the second part of the process, your tracking code is converted
to the Universal Analytics format. You use Google Tag Manager to complete the second
part of the upgrade.

2. Before beginning the upgrade, visit the Universal Analytics Upgrade Center, and read the
Upgrade Guide. Take note of the Important Considerations section at the bottom of the
page.
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Step 3: Complete the Magento Configuration

1. Return to your store, and log in to the Admin. Then on the Admin menu, select System >
Configuration.

2. In the panel on the left, under Sales, select Google API.

3. Click to expand the Google Analytics section, and do the following:

Google Analytics

a. Set Enable to “Yes.”

b. Do one of the following:

l If you have a Google Tag Manager account, set Account type to “Google Tag
Manager.”

l Otherwise, set Account type to “Universal Analytics.” Then, enter your Universal
Analytics Account Number.

If you have a Google Tag Manager account, your Universal Analytics account
number should appear automatically, along with additional options.

c. To anonymize part of your visitor’s IP address before it is sent to Google, set Enable IP
Anonymization to “Yes.”

According to Google, anonymizing IP addresses can reduce the accuracy of geographic
data in the Analytics report.

4. When complete, click the Save Config button.
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Using Universal Analytics with Enhanced Ecommerce
Enhanced Ecommerce is a plugin for Google Universal Analytics that gives you insight into
the shopping and purchasing behavior of your customers. You can use Enhanced
Ecommerce to produce reports about key customer activities, such as when customers add
items the cart, begin the checkout process, or complete a purchase. You can also identify
and analyze patterns of shoppers who abandon their carts without making a purchase.

The following instructions show how to configure Google Tag Manager with Universal
Analytics to produce Enhanced Ecommerce data and reports. If you are currently using the
classic version of Google Analytics, you must first upgrade to Universal Analytics before
you can use Enhanced Ecommerce.

Tags Fired in Shopping Cart Shown in Debug Mode

Step 1: Sign Up for Google Accounts

1. Sign up for a Google Tag Manager account, and complete the Magento configuration.

2. Sign up for a new Google Universal Analytics account, or upgrade your classic Google
Analytics account to Universal Analytics. Then, complete the Magento configuration.

Step 2: Configure Enhanced Ecommerce

1. Sign in to your Google Universal Analytics account.

2. Create a new property for Enhanced Ecommerce analytics with the following settings:
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SETTING VALUE

ENABLE ECOMMERCE SETTINGS

Status ON

Related Products ON

ENHANCED ECOMMERCE SETTINGS

Enable Enhanced Ecommerce Reporting ON

Checkout Labeling (not required)

Enhanced Ecommerce Property

3. When complete, click Submit.
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Step 3: Create Tags and Triggers

1. Sign in to your Google Tag Manager account, and create the following triggers:

NAME EVENT TYPE FILTER

AddToCart Custom Event

Checkout Custom Event

Checkout only Page View Page URL matches RegEx
/checkout/.*

CheckoutOption Custom Event

gtm.dom Custom Event

ProductClick Custom Event

PromotionClick Custom Event

RemoveFromCart Custom Event

Google Tag Manager Triggers

2. Create the following Universal Analytics tags with the same basic configuration.

NAME TYPE FIRING TRIGGERS

Add to cart tracking Universal Analytics AddToCart

Checkout option tracking Universal Analytics CheckoutOption

Checkout tracking Universal Analytics Checkout

Pageview tracking Universal Analytics gtm.dom

Product client tracking Universal Analytics ProductClick

Promo click tracking Universal Analytics PromotionClick

Remove from cart tracking Universal Analytics RemoveFromCart

Universal Analytics Tags
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SETTING VALUE

Product Google Analytics

Tag Type Universal Analytics

Tracking ID UA-XXX (The tracking ID from your Universal Analytics
account.)

Enable Enhanced
Ecommerce Features

True

Use data layer True

Use Debug version True

Basic Tag Configuration

3. Complete the individual tracking configurations as follows:

a. Enter the following Add to Cart tracking settings:

SETTING VALUE

Track Type Event

Category Ecommerce

Action Add to Cart

Trigger AddToCart

Add to Cart Configuration

b. Enter the following Checkout option tracking settings:

SETTING VALUE

Track Type Event

Category Ecommerce

Action Checkout Option

Trigger CheckoutOption

Checkout Option Configuration

c. Enter the following PageView tracking settings:
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SETTING VALUE

Track Type PageView

Trigger gtm.dom

Page View Configuration

d. Complete the following Product Click tracking configuration:

SETTING VALUE

Track Type Event

Category Ecommerce

Action Product Click

Trigger ProductClick

Product Click Configuration

e. Complete the following Promotion Click tracking configuration:

SETTING VALUE

Track Type Event

Category Ecommerce

Action Promotion Click

Trigger PromotionClick

Promotion Click Configuration

f. Complete the following Remove from Cart tracking configuration:

SETTING VALUE

Track Type Event

Category Ecommerce

Action Remove from Cart

Trigger RemoveFromCart

Remove from Cart Configuration

4. When complete, Preview and Publish the tag.

557Magento Enterprise Edition User Guide, Version 1.14.2.1



Google Universal Analytics CHAPTER 32:  Google Tools

558 Magento Enterprise Edition User Guide, Version 1.14.2.1

Troubleshooting Tools
Both Tag Manager and Universal Analytics have debug modes with a variety of tools that
you can use to troubleshoot your integration.

Preview and Debug

Tag Manager’s debug preview mode shows tags as they are fired and their associated data
layers.

Tags Fired During Checkout

Google Analytics Enhanced Ecommerce makes it possible to send sales data, and
information about product impressions and promotions to the data layer, along with any
Google Analytics pageview or event. You can use the values in the data layer to measure
impressions and analyze customer actions.
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Values in Data Layer

You also can use the JavaScript console in Chrome to see the output of events as it is sent
to Google.

Chrome JavaScript Console
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Google “Classic” Analytics
The following instructions walk you through the process of setting up a basic Google
Analytics account. Because this version of Google Analytics is being discontinued, we
strongly recommend that you install a Google Universal Analytics account instead.

Process Overview:
Step 1: Set Up aGoogleMerchant Account
Step 2: Turn On Ecommerce Tracking
Step 3: Complete theMagento Configuration

Step 1: Set Up a Google Merchant Account

The first step is to establish a Google merchant account, and then verify and claim your
website URL. For detailed instructions, see: Google Merchant Center.

When you sign up for an account, a report appears that shows your new Google Analytics
account number in the following format: UA-XXXXXXX-1. Write this number down,
because it is required to complete the configuration for your store.

Step 2: Turn On Ecommerce Tracking

Ecommerce Tracking lets you see which customers make purchases, and what they buy.

1. Sign in to your Google Analytics account.

2. On the main menu, select Admin.

The options in the Administration section are organized into three columns under Account,
Property, and View. If you have multiple accounts or stores, make sure that the Account
button is set to the correct account, and that the Property button is set to the correct store.

http://www.google.com/analytics/
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Google Analytics Admin

3. In the View column, select the View Settings option.

4. In the panel on the left, select Ecommerce Settings. Then, do the following:

a. Click the Status switch to turn on Ecommerce Tracking. Then, click the Next step
button.

b. Click the Submit button to save the setting. When the Success message appears at the
top of the page, you are done.

Ecommerce Tracking On
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Step 3: Complete the Magento Configuration

1. On the Admin menu, select System > Configuration. Then in the panel on the left, under
Sales, select Google API.

2. Click to expand the Google Analytics section, and do the following:

Google Analytics

a. Set Enable to “Yes.”

b. Set Account Type to “Google Analytics.”

c. Enter the Google Analytics Account Number, or tracking code that you wrote down
when you signed up for the service.

d. To anonymize part of your visitors’ IP address before it is sent to Google, set Enable IP
Anonymization to “Yes.”

According to Google, anonymizing IP addresses can reduce the accuracy of geographic
data in the Analytics report.

3. When complete, click the Save Config button.

http://merch.docs.magento.com/ee/user_guide/Magento_Enterprise_Edition_User_Guide.html#configuration/sales/google-api.html%23Google_Analytics
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CHAPTER 33:

Magento CMS
The old adage, “content is king” is more true now than ever before. The term, content
marketing1 refers to the art of promoting your products or services by providing
valuable information to your customers at no charge. The quality of your content helps
distinguish your store from others, increases your visibility to search engines, and
provides support to your customers. This soft-sell approach is often more effective than
advertising, builds credibility and trust, and can turn your store into a destination.

Your content should reflect the branding of your store, and be delivered with your
distinctive visual presentation and voice to convey your message. Use pictures to tell a
story. Educate, inspire, and entertain. With quality content, sometimes less is more.

Magento Enterprise Edition includes a powerful content management system (CMS)
that you can use to create rich content for your store. In this chapter, you will learn
how to use your store’s CMS tools to create new content, and incorporate existing
content to create a compelling experience that will keep customers coming back.

Topics in this chapter:

l Content Pages

l Page Hierarchy

l Blocks

l Banners

l Widgets

l Variables

l Layout Updates

l Markup Tags

Commerce Resources

See the latest Magento eBooks to gain access to expert insight and online business
resources to help develop and improve your store.

1The art of promoting products or services by providing valuable information at no charge.

http://magento.com/resources/business
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CMS Tools
Pages

Create pages with text, images, blocks, video, and
banners. In addition, you can use the Page
Hierarchy tool to provide structure and navigation
for your growing collection of content.

Static Blocks

The CMS makes it easy to create blocks of content
without writing any code. Blocks can contain text,
images, and even video, and can be assigned to
any part of the page layout.

Banners

Create banners for a promotion that are visible to
certain customer groups, or whenever price rule
conditions and coupons apply.
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Widgets

Use theWidget tool to display dynamic data and
add blocks, banners, and interactive elements most
anywhere in your store.

Polls

Create polls to learn about your customers’ opinions
and preferences. They’re fun to take and see the
results!
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CHAPTER 34:

Content Pages
All content can be viewed in terms of its shelf life, just as any product in a store. Did
you know that the shelf life of social media content is less than twenty-four hours? The
potential shelf life of the content you create can help you decide where to invest your
resources.

Content with a long shelf life is sometimes referred to as evergreen content1.
Examples of evergreen content include customer success stories, "how to" instructions,
and Frequently Asked Questions (FAQ.)

Other content is perishable by nature, such as events, industry news, and press
releases. One way to get more mileage out of perishable content is to use the Page
Hierarchy tool to create an archive of past content. You can organize articles from your
newsletter, press releases, and events by month and year, to show that you are active
and engaged.

Topics in this chapter:

l Creating a Page

l Using the Editor

l Version Control

l Page Hierarchy

1Content with a long shelf life.
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Core Content
The Magento demo store has examples of core content pages to help you get started. Before
launching your store, each page should be updated to reflect your message and brand.

Home

The demo “Home” page includes a banner, an image
carousel, several static blocks with links, and a list of
new products.

About Us

The “About Us” page is an example of page hierarchy
with a content navigationmenu on the left. The page
has an image on the right, and another at the bottom
to indicate the end of the page.

Customer Service

The “Customer Service” page is another node in the
page hierarchy. The two headers on the page have
content that only becomes visible when the header is
clicked.
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Reward Points

The “Reward Points” page is also a node in the page
hierarchy, and explains how the reward program
works, and the exchange rate for reward points.

Privacy Policy

Your store’s “Privacy Policy” page should be updated
with your own information. As a best practice, your
privacy policy should explain to your customers the
type of information that your company collects and
how it is used.

Page Not Found

The “404 Page Not Found” page is named for the
response code that is returned when a page cannot
be found. URL redirects reduce the number of times
that this page appears. However, for those times
when it is necessary, youmight as well take
advantage of the opportunity to offer some links to
products that the customermight find interesting.
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Enable Cookies

The “Enable Cookies” page appears when visitors to
your site do not have cookies enabled in their
browsers. The page provides step-by-step, illustrated
instructions to enable cookies for themost popular
browsers.

Service Unavailable

The “503 Service Unavailable" page is named for the
response code that is returned when the server is
unavailable. This page can be set to appear when
your store is in maintenancemode.
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Default Pages
The Delete Pages configuration determines the landing page that is associated with the
base URL, and the corresponding CMS home page. It also determines which CMS page
appears when a “404 Page Not Found” error occurs, and if a breadcrumb trail appears at
the top of CMS pages.

Default Pages

To configure the default pages:

1. On the Admin menu, select System > Configuration.

2. In the panel on the left under General, select Web.

3. If necessary, set Current Configuration Scope in the upper-left corner to the store view
where the setting applies.

4. Click to expand the Default Pages section. Then, do the following:

a. In the Default Web URL field, enter the relative path to the folder in the Magento
installation that contains the landing page. The default value is “cms.”

For a specific store view, clear theUse Default checkbox next to the Default Web URL
field, and any other default fields to be changed.

b. Set CMS  Home Page to the CMS page to be used as the home page.

c. In the Default No-route URL field, enter the relative path to the folder in the Magento
installation where the page is redirected when a “404 Page Not Found” error occurs.
The default value is “cms/index/noRoute.”

d. Set CMS No Route Page to the CMS page that appears when a “404 Page Not Found”
error occurs.

e. Set CMS No Cookies Page to the CMS page that appears when cookies are disabled in
the browser.

f. If you want a breadcrumb trail to appear at the top of all CMS pages, set Show
Breadcrumbs for CMS Pages to “Yes.”

5. When complete, click the Save Config button.
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Creating a Page
The process of adding a new content page to your store is essentially the same for any type
of page you might want to create. You can include text, images, blocks of content, video,
and banners. In addition, you can use the Page Hierarchy tool to provide structure and
navigation for your growing collection of content.

Don’t forget that most content pages are designed to be read by search engines first, and by
people second. Keep the needs of each of these two very different audiences in mind when
choosing the page title and URL, composing the meta data, and writing the content.

Process Overview:
Step 1: Add a New Page
Step 2: Select the Page Layout
Step 3: Complete the Content
Step 4: Complete theMeta Data
Step 5: Publish the Page

Step 1: Add a New Page

1. On the Admin menu, select CMS > Pages > Manage Content.

2. Click the Add New Page button.

3. In the Page Information section, do the following:

Page Information
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a. Enter a Title for the new page.

b. Enter a URL Key for the page that is based on the Title. It should be all lowercase
characters, with hyphens instead of spaces.

The URL Key is added to the base URL for your store, to create the online address for
the page.

c. In the Store View list, select each view where this page will be available.

d. Set Status to “Disabled.” (This will be changed when the page is ready to publish.)

e. Set Under Version Control to one of the following:

Yes By default, your store keeps a backup of previous versions of each page.
Backup pages are numbered, as,“New Page 1,” “New page 2,” and so on.

No Writes over previous versions of the page. This is the recommended
setting for content that is subject to frequent change.

4. With the required fields complete, click the Save and Continue Edit button.

Step 2: Select the Page Layout

1. In the Page Information panel on the left, select Design.

2. In the Page Layout section, set Layout to one of the following:

l 1 column

l 2 columns with left bar

l 2 columns with right bar

l 3 columns

Page Layout
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Step 3: Complete the Content

1. In the Page Information panel on the left, select Content.

2. In the Content Heading box, type the text you want to appear as the main heading at the
top of the page.

Complete the remaining content, as you want it to appear in the main content column,
according to the page layout selected. The content can include text, images, variables, and
widgets with dynamic data.

3. Click the Show / Hide Editor button to display the WYSIWYG editor. You can format the
text with the toolbar buttons.

WYSIWYG Editor

4. Click the Show / Hide Editor button again to return to the HTML mode. You can work in
either mode that you prefer.

HTML Mode

5. Click the Save and Continue Edit button.
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Step 4: Complete the Meta Data

1. In the panel on the left, select Meta Data.

2. Complete the Keywords and Description for the page. This information is used by search
engines to index the page.

Step 5: Publish the Page

1. In the panel on the left, select Page Information.

2. Set Status to “Published.”

3. If you're just starting out, set Under Version Control to “No.” You can learn how to use
version control later.

4. Click the Save Page button.

When the page is complete, it can be added to the navigation of your store, linked to other
pages, or added as a link in the footer.

Using the Editor
The WYSIWYG editor gives you the ability to enter and format while working in a “What
You See Is What You Get” view of the content. If you prefer to work directly with the
underlying HTML code, you can easily change modes. The editor can be used to create
content for pages, blocks, and product descriptions. When working in the product catalog,
the editor is accessed by clicking the WYSIWYG Editor button.

For a complete list of toolbar buttons, see the Editor Toolbar in the appendix of this guide.

Editor Toolbar
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Inserting a Link
The easiest way to insert a link is to use the Link button in the editor toolbar. It doesn’t
require any knowledge of HTML and the result is the same.

To insert a link:

1. Highlight the text where you want to create the link. Then, in the editor toolbar, click the
Link button.

Insert Link Button

2. In the Link URL field, enter one of the following:

l The URL Key of a page in your store.

l The full URL of an external page to be linked.

3. Set Target to one of the following:

l Open link in the same window

l Open in a new window

4. In the Title field, enter the tooltip text that appears when someone hovers over the link.

5. Click the Insert button to create the link.
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Inserting Images
From the editor, you can insert an online image that resides on another server, or display
an image that has been uploaded to Media Storage.

Media Storage

Method 1: Insert an Image from Media Storage

1. If necessary, click the Show / Hide Editor button to display the code.

2. Position the cursor where you want the code to be inserted. Then, click the Insert Image
button.

3. Select the image that you want to use, and click the Insert File button.

4. To view the image in WYSIWYG mode, click the Show / Hide Editor button.

Method 2: Insert an Image from Another Server

Use this method to insert an image that is available online, but resides on another server.
You must have the full URL of the image to complete the process.

1. Click the Show / Hide Editor button to work in WYSIWYG mode.

2. Position your cursor where you want the image to appear.

3. On the Editor toolbar, click the Insert Image button. Then, do the following:
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Insert Image Button

a. In the Image URL field, paste the full Web address to the image.

b. In the Image Description field, write a brief description of the image.

c. In the Title field, write a relevant title for the image.

4. Click the Insert button to complete the process.

Adding aWidget
The Widget tool can be used to add a variety of content elements to the page, including
links to any content page or node, product, or category. Links can be positioned on the
page by block reference or incorporated directly into CMS content and email templates. You
can create links to the following four types of content:

l CMS Hierarchy Nodes

l CMS Pages

l Catalog Categories

l Catalog Products

Links can be displayed as a block, or used inline and incorporated into existing text. By
default, a link inherits its style from the location (block reference) according to the style
sheet (styles.css) of the theme.

To add a widget to a page:

1. Open the CMS page to be edited.

2. In the panel on the left, select Content. Then, use either of the following methods:

Method 1: WYSIWYGMode

1. Click the Show / Hide Editor button to display the page in WYSIWYG mode.

2. Position the cursor in the text where you want the widget to appear.

3. On the editor toolbar, click the Insert Widget button.

Method 2: HTML Mode

From the HTML editor, click the Insert Widget button.
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3. When prompted, select theWidget Type. This example shows how to insert a link to a
product.

4. You can leave the Anchor Custom Text field empty to use the product name.

5. Enter a Anchor Custom Title for best SEO practice. (The title isn't visible on the page.)

6. Set Template to one of the following:

l To incorporate the link into text, select “Product Link Inline Template.”

l To place the link on a separate line, select “Product Link Block Template.”

Select the Template

7. Click the Select Product button, and do the following:

a. In the tree, navigate to the category you want.

b. In the list, click the product that you want to include in the link.

Select the Product
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c. Click the Insert Widget button to place the link on the page. In the HTML, the link
markup tag appears at the top of the page, enclosed in double curly braces.

d. If needed, use Cut (Ctrl + x) and Paste (Ctrl + v) to position the markup tag in the
code where you want the link to appear.

Widget Link Code

8. Click the Show / Hide Editor button to see the link in WYSIWYG mode.

Now you can continue editing the page, and incorporate the links into the rest of the
content.

Widget Links on CMS Page
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Version Control
Magento’s version control system for CMS pages gives you the ability to create multiple
versions of a page, track the revision history of each, and restore previous versions. You can
separate the ability to create and publish content, based on permissions.

Pages under version control can be edited only from the Versions tab. Unlike other pages,
the Content tab no longer appears in the Page Information panel. However, a link to the
currently published version is included in the Page Information. If the page is not yet
published, and the Status is set to “Disabled,” a link to the version (and revision of the
version), is shown instead. No matter how many page versions and revisions of versions
exist, only one appears in the Manage Content list.

Under Version Control

To enable version control:

1. On the Admin menu, select System > Configuration.

2. In the panel on the left under General, select Content Management.

3. Click to expand the CMS Versioning section.

4. Set CMS Page Default Versioning to “Yes.”

CMS Versioning

5. When complete, click the Save Config button.
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To add version control to a page:

1. On the Admin menu, select CMS > Pages > Manage Content.

2. In the list, click to open the page in edit mode.

3. In the Page Information section, set Under Version Control to “Yes.”

4. Click the Save and Continue Edit button.

5. In the panel on the left, select Versions. Then, do the following:

Versions

a. In the list, click to open the page in edit mode.

b. In the Version Information section, set Access Level to one of the following:

l Private

l Protected

l Public

Version Information

c. If your store Admin has multiple users, select the Owner of the page.

6. To revise a published page, in the panel on the left, select Versions, and edit the content,
as needed.

7. To save the changes as a revision, but without publishing, click the Save Page button. The
revision is added to the list.



CHAPTER 34:  Content Pages Version Control

Version Revisions

8. To publish the changes, click the Publish button.

In the Page Information, the version number of the currently published revision is
incremented to reflect the change.

Make sure that the Status of the page is set to “Published” so the page is visible in the
store. If you need to return to Page Information, click the Back button a couple of times.

Currently Published Revision
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FIELD DESCRIPTION

Page Information

Under Version Control The Under Version Control option is available for every CMS
page. Options include:

Yes Multiple revisions of the page can be created,
published selectively, and restored as
needed.

No Only one version of the page is saved, and
previous versions cannot be restored.

Version Information

Version Label The name of the version is for internal reference, to help you keep
track of different versions. For example, youmight create a
different version of the same page for each season.

Access Level Establishes the permissions necessary to access the version.
Options include:

Private Only the creator of the version can access
the content.

Protected Only Admin users with Publish Revision
permission can access the content.

Public All Admin users with CMS Page permission
can access the content.

Owner By default, the Admin user who created the page. If the access
level is set to “Private,” and the owner is changed, the previous
owner will no longer have access to the content.

Field Descriptions
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Editing a Versioned Page
To access the content section of a versioned page, select the Versions tab in the Page
Information panel. Initially, only one version is listed. When you select that version, you
are redirected to a new page that displays the version options and revision information.
Whenever changes to a revision are saved, a new revision is created. You can also save
changes as a new version.

Revision Information

To edit a versioned page:

1. Do one of the following:

l To edit the currently published version, under Page Information, click the Currently
Published Revision link. The page revision opens in edit mode.

l In the panel on the left, select Versions. Then in the Version Revisions list, click to open
the revision you want to edit.

2. Edit the content as needed.

3. When complete, do one of the following:

l To save a new revision under the same version name, click the Save button.

l To save the revision under a new version name, click the Save In New Version button.
When prompted, enter a name for the revision.

587Magento Enterprise Edition User Guide, Version 1.14.2.1



Translating Pages CHAPTER 34:  Content Pages

588 Magento Enterprise Edition User Guide, Version 1.14.2.1

Translating Pages
If your store has multiple views in different languages, and you have set the locale for each
view to a different language, you now have a partially translated site. The next step is to
create a translated version of each page that is assigned to the store view. In the Manage
Pages list, the Store View column shows the store views where each page is available.

Original “About Us” and Translated Page

To translate a CMS page, you must create a new page that has the same URL Key as the
original, but assigned to the specific store view. Then, update the page with the translated
text. The following instructions show how to create a Spanish translation of the “About Us”
page for the Spanish store view.
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To create a translated page for a view:

1. On the Admin menu, select CMS > Pages.

2. From the Manage Pages list, open the page to be translated and copy the URL Key to the
clipboard. Then, press the Back button to return to the Magage Pages list.

3. Click the Add New Page button. Then, do the following:

a. Enter the translated Page Title.

b. Paste the URL Key that you copied from the original page.

c. In the Store View box, select the store view where the page will be available, which in
this case is “Spanish.”

d. Set Status to “Disabled” until you are ready to publish the page.

e. Leave Under Version Control set to “Yes.”

f. In the panel on the left, select Contents. Then, enter the Content Heading, and paste
the translated text for the page into the text box.

g. On the Design tab, set the column Layout for the page.

h. On the Meta Data tab, enter the translated text for the Keywords and Description.

Translated Page Information

4. If the page is ready to publish, set Status to “Published.”

5. When complete, click the Save Page button.
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6. If prompted to refresh the cache, click the link at the top of the page. Then, refresh any
invalid caches.

7. After the page is published, return to the storefront and select the view from the language
chooser.

Translated Page

Notice that there are still some elements on the page that need to be translated, including
the company footer links block, which on this page appears in the left sidebar, the welcome
message, and product information.
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CHAPTER 35:

Page Hierarchy
Your store’s page hierarchy system gives you the ability to organize your content pages
and add pagination, navigation, and menus. If you publish a large amount of content
on a regular basis, you can use page hierarchy to organize the content and make it easy
for people to find articles of interest.

Topics in this chapter:

l Page Hierarchy Setup

l Adding a Node

Page with Left Navigation
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Page Hierarchy Setup
Page hierarchy can be accessed from an individual CMS page, and also by using the
Manage Page Hierarchy command. The CMS Page Hierarchy configuration settings activate
the page hierarchy system and metadata, and determine the default menu layout.

Manage Hierarchy

The page hierarchy system uses nodes to identify related pieces of content, and to organize
content pages into a parent/child relationship structure. A parent node is like a folder that
can contain child nodes and pages. The relative position of each node and page in the
hierarchy is shown as a tree on the left side of the Manage Pages Hierarchy page. A node
can contain other nodes and content pages, and a single content page can be associated
with multiple nodes and other content pages in a parent/child or neighbor relationship.

To set up page hierarchy:

1. On the Admin menu, select System > Configuration.

2. In the panel on the left, under General, select Content Management.

3. Click to expand the CMS Page Hierarchy section, and make any changes that are
necessary.

CMS Page Hierarchy

4. Click to expand the CMS Versioning section, and make any changes necessary.

5. Click the Save Config button to save your changes.
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Adding a Node
The following example shows how to create a node with simple navigation to content
pages. Although the node does not have a content page associated with it, it does have a
URL Key which can be referenced elsewhere in your site.

For example, you can create a node called “Press Releases” with navigation to individual
press releases. Then, include the link on your “About Us” page. Or how about creating a
node with links to back issues of your newsletter?

Page Hierarchy with Nodes

Process Overview:
Step 1: Create a Node
Step 2: Add Pages to the Node
Step 3: Add Navigation

Step 1: Create a Node

1. On the Admin menu, select CMS > Pages > Manage Hierarchy.

2. Click the Add Node button.

3. In the Page Properties section, type a Title for the node. Then create a suitable URL Key
using all lowercase characters, with hyphens instead of spaces.

4. Click the Save Pages Hierarchy button to save the node. The node appears as a folder in
the tree.

Step 2: Add Pages to the Node

1. In the hierarchy tree, click to open the node.

2. Scroll down to the CMS pages section, and select the checkbox of each page you want to
include.
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3. Click the Add Selected Pages(s) to Tree button. Each selected page appears in the tree
below the node folder.

Step 3: Add Navigation

1. In the tree, click to open the node.

2. In the Pagination Options for Nested Pages section, set Enable Pagination to “Yes.”

3. In the Navigation Menu Options section, and set Enable Navigation Menu to “Yes.”

4. Scroll back up to the Node Properties section, and click the Preview link.

5. Click the Save Pages Hierarchy button to save the settings.
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CHAPTER 36:

Blocks
A block is a modular unit of content that can be positioned most anywhere on the page.
Blocks can be used to display static information such as text, images, and embedded
video, as well as dynamic information.

You can use Magento Enterprise Edition’s content management system to create
custom blocks of content without writing any code. Blocks can contain text, images,
and even video, and can be assigned to any part of the page layout.

In addition, your store includes a selection of built-in blocks that make it easy to add
features and functionality to your store. Some built-in blocks are required components
of your store, while others are shopping tools that can be enabled or disabled according
to your preference. Many of the built-in blocks can be added to your store with the
Widget tool.

Blocks can also be defined and positioned by entering XML code in the Layout Update
box on the target page. Custom CMS blocks can be referenced and positioned without
writing any code by using the Widget tool.

Topics in this chapter:

l Creating a Static Block

l Positioning Blocks by Reference
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Creating a Static Block
Magento gives you the ability to create blocks of content that can be used throughout your
store. Custom, static blocks of content can be added to any page, group of pages, or even to
another block. The carousel image slider on the home page of the demo store is generated
by code that is placed in a static block. The three smaller blocks below are also static
blocks.

Static Blocks on Home Page

To create a block:

1. On the Admin menu, select CMS > Static Blocks.

2. In the upper-right corner, click the Add New Block button. Then, do the following:

a. Assign a descriptive Block Title.

b. Assign a unique Identifier to the block. Use all lowercase characters, with underscores
instead of spaces. The identifier is used for internal reference.

c. Select the Store View(s) where this content block will be visible.

d. Set Status to “Enabled” to make the block visible in the store.

e. Complete the Content for the block. You can use the Editor to format text, create links
and tables, add images, video, and audio.

3. When complete, click the Save Block button.
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General Information

Positioning Blocks by Reference
The code that controls the page layout and placement of blocks is written in XML. You may
have noticed references to XML Page Layout Updates throughout the Admin of your store.
Every product, category, and piece of content—whether it’s a page, block, banner, or app—
has a section where you can update the XML code that controls the positioning of the item.

The selection of available block references that is available varies by page type, and whether
the customer is logged in, or is visiting the as a guest.

The Widget tool makes it easy to position a block at a specific place on the page, and even
for a specific product or category. You can select each option from a list, rather than trying
to remember all of the possible combinations.
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Category and CMS Pages

BLOCK REFERENCE POSITION

Breadcrumbs The navigation aid at the top of many pages that shows your
current location as a link. Any additional content placed in the
Breadcrumbs reference floats to the right of the breadcrumbs, if
displayed.

Left Column Content is added to the left column.

Main Content Area Content is added to themain content area.

My Cart Extra Actions Content appears below the Cart Subtotal in theMy Cart popup
located within the top link.

Navigation Bar Content appears below themain navigation bar.

Page Bottom Content appears at the bottom of the page.

Page Footer Content appears above the footer of the page.

Page Header Content appears below the header of the page.

Page Top Content appears at the top of the page.

Right Column Content appears in the right column.

Store Language Content appears in the upper-left corner of the header.

Block References

Product Page

BLOCK REFERENCE POSITION

Alert URLs Content appears below the title of the product on the product
detail page.

Bottom Block Options
Wrapper

If custom options are added, content appears below the Add to
Cart button.

Breadcrumbs Content appears to the right of breadcrumbs—the navigation aid
that provides links as a path—that’s showcased below the
navigation bar.

Info ColumnOptions
Wrapper

If a custom options are added, content appears to the right. The
same location applies to configurable options.

Block References
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BLOCK REFERENCE POSITION

Left Column Content appears below the left column blocks.

Main Content Area Content appears below themain content area.

My Cart Extra Actions Content appears below the Cart Subtotal in theMy Cart popup
located within the top link.

Navigation Bar Content appears below themain navigation bar.

Page Bottom Content appears at the bottom of the page.

Page Footer Content appears above the footer of the page.

Page Header Content appears below the header of the page.

Page Top Content appears at the top of the page.

PayPal Express Checkout
(Payflow Edition) Shortcut
Wrapper

If the PayPal payment method is enabled, content appears
below the PayPal buy button.

PayPal Express Checkout
Shortcut Wrapper

If the PayPal payment method is enabled, content appears
below the PayPal buy button.

Product Tags List Content appears below the products tag bar.

Product View Extra Hint Content appears below themain top price of the product.

Right Column Content appears below the right column blocks.

Store Language Content appears to the right of the language chooser.

Tags List Before Content appears above the Add Your Tags field.

Block References (cont.)
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CHAPTER 37:

Banners
Banners can be used to display an image or block of content, and appear for a specific
period of time for a promotion. You can create banners that are visible to certain
customer groups, or whenever price rule conditions and coupons apply.

Topics in this chapter:

l Creating a Banner

l Using Banners with Price Rules

When designing banners for your store, you should take into consideration both the
page layout and the theme you are using. Banners are often designed to appear on a
specific page, and area of the page. Although the header and footer are a fixed width,
the width of the content area, and the sidebars, can vary according to theme and page
layout. When designing a banner with graphic images, it is important to understand
the page layout, so you can take advantage of the available space.

Banner on Home Page
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Creating a Banner
A banner can be as simple as an image. or contain a combination of text and code that
triggers an event. After a banner is created, you can use the Widget tool to place it in your
store, and combine it with other banners in a rotating sequence.

To create a banner:

1. On the Admin menu, select CMS > Banners.

2. Click the Add Banner button. Then, do the following:

a. Enter a descriptive Banner Name.

b. Set Active to “Yes.”

c. In the Applies To list, select one of the following:

l Any Banner Type

l Specified Banner Type

This setting determines where in the store the banner can be used. (To select more
than one, hold the Ctrl key down and click each option.)

Banner Properties

d. In the panel on the left, select Content. Then in the Default Content section, enter any
HTML code that is needed for the banner.

e. To insert an image, click the Insert Image button. Then, select the image.

f. To customize the content for a specific store view, clear the Use Default checkbox, and
enter the custom content for the each view.

3. When complete, click the Save Banner button.
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Banner Content with HTML

LOCATION DESCRIPTION

Content Area The width of themain content area varies, depending on the
column layout.

Footer The bottom section of the page contains the footer links and
copyright notice.

Header The top section of the page contains your logo, account links,
search box, and top navigation.

Left Column The left column of a two- or three-column layout.

Right Column The right column of a two-or three-column layout.

Banner Type by Location
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Creating a Banner Rotator
A banner rotator can be used to display a single banner, or multiple banners in a specific
sequence or random order. The next banner in the sequence appears when the page is
refreshed.

As a widget, the banner rotator can be assigned to a specific page, product, or category, and
placed most anywhere in your store. In addition, a banner rotator can be associated with a
specific shopping cart or catalog rule.

As an alternative, you can also use a jQuery slider or carousel that changes images
automatically, like the one on the home page of the Magento demo store. There is a wide
assortment of jQuery sliders available online, and many are free. To add a slider to your
store, first create a static block. Follow the slider instructions to add the jQuery code to the
block. Then, use the Widget tool to place the static block where you want it to appear in
your store.

Process Overview:
Step 1: Create the Individual Banners
Step 2: Create aWidget Instance
Step 3: Configure the Banner Rotator

Step 1: Create the Individual Banners

Create the individual banners that you want to include in the rotator.

Step 2: Create a Widget Instance

Follow the basic steps to create a widget.

l Choose "Banner Rotator" as the type of widget.

l Specify the page and location where it belongs. (See Banner Layout Update Options)

l Choose the template to be used.

Step 3: Configure the Banner Rotator

1. If necessary, select CMS > Widgets, and click to open the banner rotator that you created
in the previous step.

2. In the left panel, click Widget Options to configure the banner. Then, do the following:

a. Set Banners to Display to “Specified Banners.”

b. (Optional) To limit the banner to a certain section of the store, set Restrict by Banner
Types to the section where you want it to appear.

c. In the Rotation Mode list, select one of the following:
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l Do not rotate, display all at once

l One at a time, Random

l One at a time, Series

l One at a time, Shuffle

3. To specify the banners you want to include, do the following:

a. In the Specify Banners section, click the Reset Filter button to list all the available
banners. You can also use the search filters to find the banners you want to include.

b. Select the checkbox of each banner you want to include in the rotator.

c. To set the sequence of each banner in relation to the others, enter a number in the
Position column. If you wan the banner to appear in the first position, enter the
number 1.

4. When complete, click the Save button.

OPTION DESCRIPTION

Display OnCategories Determines the categories where the banner rotator appears.

Anchor Categories Appears only on anchored category
pages listed in the layered navigation.

Non-Anchor
Categories

Appears only on non-anchored category
pages, which are category pages that
are not shown in the layered navigation.

Products Displays the banner rotator for a specific
product, or type of product. Options
include:
All Product Type
Simple Product
Grouped Product
Configurable Product
Bundle Product
Virtual Product
Gift Card

Categories Displays the banner rotator for only the categories selected.

Block Reference Assigns the banner rotator to a specific location by reference.
Options include:

Banner Layout Update Options
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OPTION DESCRIPTION

Breadcrumbs
Left Column
Main Content Area
My Cart Extra
Actions
Navigation Bar
Page Bottom

Page Footer Before
Page Footer Bottom
Page Header
Page Top
Right Column
Store Language

Template Options include:
Banner Block Template
Banner Inline Template

Banner Layout Update Options (cont.)

OPTION DESCRIPTION

Banners to Display Options include:
Specified Banners
Shopping Cart Promotions Related
Catalog Promotions Related

Restrict by Banner Types Limits the banner to a certain section. Options include:
Content Area
Footer
Header
Left Column
Right Column

RotationMode Select the rotationmode for the banners. Options include:

Do not rotate Display one banner after the other, in a
stack where all are visible.

One at a time,
Random

Displays the banners that you specify in
a randomly generated order. Every time
the page is refreshed, a different (and
random) banner appears.

Banner Widget Options



CHAPTER 37:  Banners Using Banners with Price Rules

OPTION DESCRIPTION

One at the time,
Series

Displays the banners that you specify by
the order of their position every time the
page is refreshed.

One at the time,
Shuffle

Displays one banner at a time in a
shuffled position order. This option is
similar to the One at a time, Random
option, except that the same banner
does not repeat back-to-back (unless
you have only one banner).

Specify Banners Select the banners to include from the list of available banners.

Banner Widget Options (cont.)

Using Banners with Price Rules
Any banners you have created can be associated with both catalog and shopping cart price
rules for a promotion. To associate a banner with a price rule, you must first create the
banner and the price rule.

To associate a banner with a price rule:

1. On the Admin menu, select one of the following:

l Promotions > Catalog Price Rules

l Shopping Cart Price Rules

2. In the list, click to open the rule where you want to add the banner. Then, do the following:

a. In the Price Rule panel on the left, select Related Banners.

b. In the list, select the checkbox of each banner that you want to associate with the price
rule.

If your banners don’t appear in the table, click the Reset Filter button to clear filtering rules.

3. When complete, click the Save Rule button.
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CHAPTER 38:

Widgets
A widget is a snippet of code that makes it possible to display a wide range of content
and place it at specific block references in your store. Many widgets display real-time,
dynamic data and create opportunities for your customers to interact with your store.
The Widget tool makes it easy to place existing content such as blocks, banners, and
interactive elements most anywhere in your store. In addition, the widget code that you
generate can be easily incorporated into other content directly from the editor.

You can use widgets to create landing pages for marketing campaigns, display
promotional content at specific locations throughout the store. Widgets can also be
used to add interactive elements and action blocks for external review systems, video
chats, voting, and subscription forms, or to provide navigation elements for tag clouds,
rotating banners, and image sliders.

Topics in this chapter:

l Widget Types

l Creating a Widget

l Static Block Widget

l New Products List

l Banner Rotator

l Order by SKU

l Mini Shopping Cart
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Widget Types

Banner Rotator

Combines an assortment of banners into a single display, which can be set to rotate in a
series, random order, or shuffle. The banner can be configured to appear on a specific page
and location on the page.

CMS Hierarchy Node Link

Displays a link to a selected hierarchy node. Allows you to specify custom text and a link to
the node. When the link is complete, it can be used in content pages and blocks.

CMS Page Link

Displays a link to a selected page. Allows you to specify custom text and title. When the
link is complete, it can be used in content pages and blocks.

CMS Static Block

Displays a block of content at a specific location on a page.

Catalog Category Link

Displays a link to a selected catalog category. Allows you to specify custom text and a title.
Two templates are available: inline and block. When the link is complete, it can be used in
content pages and blocks.

Catalog Events Carousel

Displays a list of upcoming events.

Catalog New Products List

Displays a block of products which have been designated as new, for the duration of time
specified in the product record.

Catalog Product Link

Displays a link to a selected catalog product. Allows you to specify custom text and a title.
Two templates are available: inline and block. When the link is complete, it can be used in
content pages and blocks.
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Event

When the Event Widget is enabled, it appears on the home page and category pages. It
lists open and upcoming events, sorted by end date. If two or more events share the same
end date, the events are sorted based on the order specified in the configuration.

Gift Registry Search

Customers can search for public gift registries by name, or registry ID.

Order by SKU

The Order by SKU widget is a mini order form with two fields: SKU and Qty. It also
contains a link to upload a CSV file with order data from the customer's account
dashboard.

Orders and Returns

The Orders and Returns widget gives customers the ability to submit their own requests for
return merchandise authorization.

Recently Compared Products

Displays the built-in block of recently compared products. You can specify the number of
products included, and format them as a list or product grid.

Recently Viewed Products

Displays the built-in block of recently viewed products. You can specify the number of
products included, and format them as a list or product grid.

Wishlist Search

Displays a form that allows shoppers to search for wishlists.

Mini Shopping Cart

If the store has a responsive theme, the Mini Shopping Cart widget can be used to display
additional information, such as a banner or contact information, in the mini shopping cart.
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Creating a Widget
The process of creating a widget is nearly the same for each type. You can follow the first
part of the instructions, which is the same for all types, and then complete the last part
that is specific to the type of widget you want to create.

Process Overview:
Step 1: Choose theWidget Type
Step 2: Specify Where It Goes
Step 3: Select a Template
Step 4: Complete the Instructions by Type
Step 5: Check It Out!

Step 1: Choose the Widget Type

1. On the Admin menu, select CMS > Widgets.

2. Click the Add New Widget Instance button.

3. In the Settings section, select the Type of widget you want to create. Then, click the
Continue button.

4. In the Frontend Properties section, do the following:

a. In theWidget Instance Title field, enter a descriptive title for the widget. This title is
for internal use only, and won’t be visible to your customers.

b. Enter a number in the Sort Order field to determine the order of the block when listed
with others in the column. The top position is zero.

c. Set Assign to Store Views to “All Store Views,” or to the view where you want the
widget to be available. To select more than one, hold the Ctrl key down and select each
option.

Step 2: Specify Where It Goes

1. In the Layout Updates section, click the Add Layout Update button.

2. Set Display On to the type of category or product page where you want the widget to
appear.

3. In the Block Reference list, select the block or section of your page layout where you want
the widget to appear.
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Step 3: Select a Template

1. Set Template to one of the following:

Block Template Formats the content so it can be placed as standalone unit on the
page.

Inline Template Formats the content so it can be placed inside other content. For
example, a link that goes inside a paragraph of text.

2. Click Save and Continue Edit to save your changes and continue editing.

Step 4: Complete the Instructions by Type

The options for each type vary slightly, but the process is essentially the same.

l Banner Rotator

l CMS Static Block

l Catalog New Products List

l Order by SKU

l Mini Shopping Cart

l And more…

Step 5: Save Your Work and Check It Out!

1. When complete, click the Save button.

2. Follow the links in the message at the top of the workspace to update the index and page
cache.

3. Go to your storefront and see how it looks!
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CMS Static Block Widget
The CMS Static Block widget gives you the ability to place an existing CMS block most
anywhere in your store.

Step 1: Choose the Widget Type

1. On the Admin menu, select CMS > Widgets.

2. Click the Add New Widget Instance button.

3. In the Settings section, set Type to “CMS Static Block.” Then, click the Continue button.

4. In the Frontend Properties section, do the following:

a. In theWidget Instance Title field, enter a descriptive title for the widget. This title is
for internal use only, and is not visible to your customers.

b. Enter a number in the Sort Order field to determine the order of the block when listed
with others in the column. The top position is zero.

c. Set Assign to Store Views to “All Store Views,” or to the view where the app will be
available. To select more than one, hold the Ctrl key down and select each option.

Step 2: Complete the Layout Updates

1. In the Layout Updates section, set Display On to the category, product, or page where you
want the block to appear.

2. To complete the Layout Updates, do the following:

a. Select the Page where you want the block to appear.

b. Select the Block Reference to identify the place on the page where the block will
appear.

c. Accept the default setting for Template, which is set to "CMS Static Block Default
Template."

d. Click Save and Continue Edit.

Step 3: Place the Block

1. In the panel on the left, select Widget Options.

2. Click the Select Block button.

Then in the list, click to select the block you want to place.

3. When complete, click the Save button.

The new widget now appears in the Manage Widget Instances list.
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4. When prompted, follow the instructions at the top of the workspace to update the index
and page cache.

5. Return to your storefront to verify that the block is in the correct location. To move the
block to a different location, you can reopen the widget and try a different page or block
reference.

New Products List
The list of new products is an example of dynamic content, and consists of live data that is
pulled from your product catalog. By default, the “New Products” list includes the first
eight of the most recently added products. However, it can also be configured to include
only products within a specified date range.

New Products List on Home Page

Process Overview:
Step 1: Set the Date Range for Each Product
Step 2: Create aWorking Copy of theWidget
Step 3: Select the Location for the List
Step 4: Configure the List
Step 5: Preview YourWork

615Magento Enterprise Edition User Guide, Version 1.14.2.1



New Products List CHAPTER 38:  Widgets

616 Magento Enterprise Edition User Guide, Version 1.14.2.1

Step 1: Set the Date Range for Each Product

To make a product appear in the list by date range, the dates must be specified in the
product record. The product then appears in the New Products list during the date range
specified.

1. On the Admin menu, select Catalog > Manage Products.

2. Find the product you want to feature, and open the record. Then, do the following:

a. In the Set Product as New From Date field, click the calendar button and select

the first date that you want the product to be featured.

b. In the Set Product as New To Date field, click the calendar button and select the

last date that you want the product to be featured.

"Set Product As New " Date Range

3. When complete, click the Save button.

4. When you are prompted to reindex and refresh the page cache, click the links at the top of
the workspace, and follow the instructions.

The product will appear in the New Products list during this date range. Repeat this step
for each product that you want to feature.

Step 2: Create a Working Copy of the Widget

The code that determines the content of the list and its placement in your store is
generated by the Widget tool. To create your own working copy of the New Products list,
simply save a copy of the existing widget. Your working copy is a new “instance” of the
widget, and any changes you make will not affect the original.
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1. On the Admin menu, select CMS > Widgets.

2. In the upper-right corner, click the Add New Widget Instance button.

3. In the Settings section, do the following:

a. Set Type to “Catalog New Products List.”

b. Select the Design Package/Theme that is used by the store.

4. Then, click the Continue button.

Widget Type

5. In the Frontend Properties section, complete the following fields:

Widget Instance Title Enter a descriptive title for your widget. This title is visible
only from the Admin.

Assign to Store Views Select the store views where the widget will be visible. You
can select a specific store view, or "All Store Views."

Sort Order (Optional) Enter a number to determine the order this items
appears with others in the same part of the page. (0 = first, 1
= second, 3= third, and so on.)

Widget Frontend Properties
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Step 3: Select the Location for the List

1. In the Layout Updates section, click the Add Layout Update button. Then, do the
following:

a. Set Display On to “Specified Page.”

b. Set Page to “CMS Home Page.”

c. Set Block Reference to “Main Content Area.”

d. Set Template to one of the following:

l New Product Lists Templates

l New Products Grid Template

Layout Updates

2. Click the Save and Continue Edit button to save your changes.

Step 4: Configure the List

1. In the panel on the left, select Widget Options.

2. Set Display Products to one of the following:

All Products Lists products in sequence, starting with those most recently added.

New Products Lists only the products which are identified as “New.” A product is
considered to be new during the date range specified in the “Set
Product As New From” date and “Set Product As New To” date.
fields of the product. The list will be blank if the date range expires
and no additional products have been set as "New."

3. Complete the remaining information as follows:

a. To provide navigation control for lists with multiple pages, set Display Page Control
to “Yes.” Then, in the Number of Products per Page field, enter the number of
products you want to appear on each page.

b. Set Number of Products to Display to the number of new products you want to
include in the list. The default setting is 10.
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c. In the Cache Lifetime (Seconds) field, select how often you want to refresh the list of
new products. By default, the cache is set to 86400 seconds, or 24 hours.

Widget Options

4. When complete, click the Save button.

5. When prompted to refresh the cache, click the link in the message at the top of the
workspace, and follow the instructions.

Step 5: Preview Your Work

1. On the Admin menu, select CMS > Pages > Manage Content.

2. Find the published page in the list, where you placed the New Products list. Then, in the
Action column, click the Preview link.
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Order by SKU Widget
The Order by SKU widget is a mini order form with two fields: SKU and Qty. It also
contains a link to upload a csv file with order data from the customer's account dashboard.

Order by SKU Widget

To create an Order by SKU widget:

1. On the Admin menu, select CMS > Widgets. Then, click the Add New Widget Instance
button.

2. In the Settings section, do the following:

Settings

a. Set Type to “Order by SKU” and configure other widget options.

b. Select the Design Package/Theme that will be used with the widget.

c. Click the Continue button.

3. In the Frontend Properties section, do the following:
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Frontend Properties

a. Enter theWidget Instance Title.

b. In the Assign to Store Views list, select each view where the widget will be available.

c. Enter a number in the Sort Order field to indicate the sequence of the Order by SKU
block in relation to other blocks in the column.

4. Click the Add Layout Update button. Then, do the following:

Layout Updates

a. Set Display On to the pages where you want the Order by SKU widget to appear.

b. Select the Categories that you want to be used with the widget.

c. Set Block Reference to the location on the page where you want the widget to appear.

5. In the panel on the left, click Widget Options. Then, do the following:

Widget Options

a. To include a link in the widget, set Display a Link to Loading a Spreadsheet to “Yes.”

b. Enter the Link Text that you want to appear in the link.

6. When complete, click the Save button.
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Mini Shopping Cart Widget
You can use a widget to show relevant information to your customers when the mini
shopping cart is displayed in your store. For example, you might want to display a
promotional banner, or you could provide a phone number or other contact information.

The mini shopping cart widget can be used only with responsive web design themes.

Widget in Mini Shopping Cart

Process Overview:
Step 1: Choose theWidget Type
Step 2: Complete the Layout Updates
Step 3: Place the Block

Step 1: Choose the Widget Type

1. On the Admin menu, select CMS > Widgets.

2. Click the Add New Widget Instance button.

3. In the Settings section, do the following:

a. Set Type to “CMS Static Block.”

b. Set Design Package/Theme to any responsive web design (RWD) theme. You must
select a responsive package/theme to use the mini cart widget.

c. Click the Continue button.
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Widget Settings

4. In the Frontend Properties section, do the following:

a. In theWidget Instance Title field, enter a descriptive title for the widget. This title is
for internal use only, and is not visible to your customers.

b. Enter a number in the Sort Order field to determine the order of the block when listed
with others in the column. The top position is zero.

c. Set Assign to Store Views to “All Store Views,” or to the view where the app will be
available. To select more than one, hold the Ctrl key down and select each option.

Frontend Properties

Step 2: Complete the Layout Updates

1. In the Layout Updates section, set Display On to the category, product, or page where you
want the block to appear.

2. To complete the Layout Updates, do the following:

a. Select the Page where you want the block to appear.

b. Set Block Reference to “Mini-cart promotion block.”

c. Accept the default setting for Template, which is set to “CMS Static Block Default
Template.”

d. Click Save and Continue Edit.

623Magento Enterprise Edition User Guide, Version 1.14.2.1



Mini Shopping Cart Widget CHAPTER 38:  Widgets

624 Magento Enterprise Edition User Guide, Version 1.14.2.1

Step 3: Place the Block

1. In the panel on the left, select Widget Options.

2. Click the Select Block button. Then in the list, click to select the block you want to place.

3. When complete, click the Save button.

The app appears in the Manage Widget Instances list.

4. When prompted, follow the instructions at the top of the workspace to update the index
and page cache.

5. Return to your storefront to verify that the block is in the correct location.
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CHAPTER 39:

Variables
Variables are reusable pieces of information that can be created once and used in
multiple places, such as email templates, blocks, banners, and content pages. Your
Magento store includes a large number of predefined attributes, and also gives you the
ability to create your own custom variables.

Topics in this chapter:

l Predefined Variables

l Custom Variables

Store Contact Information Variables
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Predefined Variables
Predefined variables are easy to add to content pages, blocks, and email templates.

Inserting Predefined Variables

To add a variable to a page:

1. On the Admin menu, select CMS > Pages > Manage Content. Then, click to open the
page.

2. In the Page Information panel on the left, select Content. Then from the editor, do one of
the following:

l Click the Insert Variable button.

l If you prefer to work with the code, click the Show / Hide Editor button.

3. Position the insertion point in the text where you want the variable to appear. Then, click
the Insert Variable button.

4. In the list of available store contact variables, click the one you want to use.

5. When complete, click the Save button.

To add a variable to a block:

1. On the Admin menu, select CMS > Static Block. Then, click to and open the block.

2. From the editor, do one of the following:

l Click the Insert Variable button.

l If you prefer to work with the code, click the Show / Hide Editor button.
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3. Position the insertion point in the text where you want the variable to appear. Then, click
the Insert Variable button.

4. In the list of available variables, click to select the one you want to use.

5. When complete, click the Save Block button.

To add a variable to an email template:

1. On the Admin menu, select System > Transactional Emails.

2. Do one of the following:

l Click to edit a predefined template.

l Click the Add New Template button to create a new one.

3. In the Template Content box, position the insertion point where you want the variable to
appear. Then, click the Insert Variable button.

4. In the list of available variables, click to select the one you want to use. Email templates
have an additional selection of variables.

5. When complete, click the Save Template button.

STORE CONTACT VARIABLES

Store Contact Information
Base Unsecure URL
Base Secure URL
General Contact Name
General Contact Email
Sales Representative Contact Name
Sale Representative Contact Email
Custom 1Contact Name
Custom 1Contact Email
Custom 2Contact Name
Custom 2Contact Email
Store Name
Store Contact Telephone
Store Contact Address

Predefined Variables

627Magento Enterprise Edition User Guide, Version 1.14.2.1



Custom Variables CHAPTER 39:  Variables

628 Magento Enterprise Edition User Guide, Version 1.14.2.1

TEMPLATE VARIABLES

Store Url
Email Logo Image Url
Email Logo Image Alt
Customer Name
Store Name
Customer Account Url
Invoice Id
Order Id
Billing Address
Payment Details
Shipping Address
Shipping Description
Invoice Items Grid
Invoice Comment

Template Variables

Custom Variables
If you know a little basic HTML, you can create custom variables and incorporate them into
pages, blocks, banners, and email templates. When a variable is inserted into HTML, it is
formatted as a markup-tag, and enclosed in double curly braces.

{{CustomVar code= "store_hours"}}

To create a custom variable:

1. On the Admin menu, select System > Custom Variable.

2. Click the Add New Variable button.

3. Enter an identifier in the Variable Code field. Use all lowercase characters, without spaces.

4. Enter a Variable Name, which is used for internal reference. Then, do one of the following:

l In the Variable HTML Value text field, enter any content you want to include, using
basic HTML tags. This option allows you to format the value.

l In the Variable Plain Value field, enter the variable value as plain text.

5. When complete, click the Save button.
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To add a variable to a banner:

1. On the Admin menu, select CMS > Banners. Then, click to open the banner.

2. In the Default Content section, click the Insert Variable button.

3. In the list of available variables, select the one that you want to use..

4. When complete, click the Save Banner button.

To add a variable to an email template:

1. On the Admin menu, select System > Transactional Emails.

2. Do one of the following:

l Click to edit a predefined template.

l Click the Add New Template button to create a new one.

3. In the Template Content box, position the insertion point where you want the variable to
appear. Then, click the Insert Variable button.

4. In the list of available variables, click to select the one you want to use.

5. When complete, click the Save Template button.
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CHAPTER 40:

Markup Tags
A markup tag is a snippet of code that contains a relative reference to an object in your
store, such as a page, block, or image. Markup tags can be incorporated into the HTML
content of CMS pages, blocks, images, and email templates.

Topics in this chapter:

l Markup Tag Syntax

l Using Markup Tags in Links
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Markup Tag Syntax
Markup tags are enclosed in double, curly braces, and can be generated by the Widget tool,
or typed directly into HTML content. For example, rather than hard-coding the full path to
a page, you can use a markup tag to represent the store URL. The markup tags featured in
the following examples include:

Store URL
The Store URL markup tag represents the base URL of your website, and is used as a
substitute for the first part of a full URL, including the domain name. There are two
versions of this markup tag: One that goes directly to your store, and the other with a
forward slash at the end that is used when a path is added.

{{store url='apparel/shoes/womens'}}

Media URL
The dynamic media URL markup tag represents the location and file name of an image
that is stored on a content delivery network (CDN). The tag can be used to place an image
on a page, block, banner, or email template.

{{media url='shoe-sale.jpg'}}

Block ID
The Block ID markup tag is one of the easiest to use, and can be used to place a block
directly on a CMS page, or even nested inside another block. You can use this technique to
modify a block for different promotions or languages. The Block ID markup tag references a
block by its identifier.

{{block id='block-id'}}

Template Tag
A template tag references a PHTML template file, and can be used to display the block on a
CMS page or static block. The code in the following example can be added to a page or
block to display the Contact Us form.

{{block type="core/template" name="contactForm"

template="contacts/form.phtml"}}

“Contact Us” Template Tag
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The code in the next example can be added to a page or block to display the a list of
products in a specific category, by category ID.

{{block type="catalog/product_list" category_id="22"

template="catalog/product/list.phtml"}}

“Category Product List” Template Tag

Non-Inline CSS Tag
Because many email clients do not support CSS, this markup tag provides a way to convert
the CSS styles that are used in email and newsletter templates to inline styles. The tag
references the non_inline_styles variable to point to a CSS file on the server for the styles
to be converted. The styles that are non-inline are copied to the <styles> tag of each
message or newsletter that is sent. This tag can be used only with templates for
transactional email and newsletters. To learn more, see the developer documentation.

{{var non_inline_styles.css}}

Widget Code
The Widget tool can be used to display lists of products, or to insert complex links, such as
one that goes to a specific product page, based on product ID. The code that is generated
includes the block reference, location of the code module, and corresponding PHTML
template. After the code is generated, you can copy and paste it from one place to another.

The code in the following example can be added to a page or block to display the list of
new products.

{{widget type="catalog/product_widget_new"

display_type="new_products" products_count="10"

template="catalog/product/widget/new/content/new_grid.phtml"}}

“New Products Grid” Code

The code in the next example can be added to a page or block to display a link to a specific
product, by product ID.

{{widget type="catalog/product_widget_link" anchor_text="My Product Link"

title="My Product Link"template="catalog/product/widget/link/link_

block.phtml" id_path="product/31"}}

“Link to Product” Code
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Using Markup Tags in Links
You can use markup tags with HTML anchor tags, and link directly to any page in your
store. The link can be incorporated into CMS content, such as a page, static block, banner,
or email template. You can also use this technique to link an image to a specific page.

Process Overview:
Step 1: Identify the Destination URL
Step 2: Add theMarkup to the URL
Step 3: Complete the Anchor Tag

Step 1: Identify the Destination URL

If possible, navigate to the page that you want to link to, and copy the full URL from the
address bar of your browser. The part of the URL that you need comes after the “dot com
forward slash.” Otherwise, copy the URL Key from the CMS page that you want to use as
the link destination.

http://mystore.com/apparel/shoes/womens

http://mystore.com/apparel/shoes/womens.html

Full URL to Category Page

http://mystore.com/apparel/shoes/womens/nine-west-pump

http://mystore.com/apparel/shoes/womens/nine-west-pump.html

Full URL to Product Page

http://mystore.com/about-us

Full URL to CMS Page
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Step 2: Add the Markup to the URL

The Store URL tag represents the base URL of your website, and is used as a substitute for
the “http address” part of the store URL, including the domain name and “dot com.” There
are two versions of the tag, which you can use, depending on the results you want to
achieve.

store direct_url Links directly to a page.

store url Places a forward slash at the end, so additional references
can be appended as a path.

In the following examples, the URL Key is enclosed in single quotes, and the entire markup
tag is enclosed in double curly braces. When used with an anchor tag, the markup tag is
placed inside the double quotes of the anchor. To avoid confusion, you can alternate using
single-and double quotes for each nested set of quotes.

1. If you are starting with a full URL, delete the “http address” part of the URL, up through
and including the “dot.com forward slash.” In its place, type the Store URL markup tag, up
through the opening single quote.

http://mystore.com/apparel/shoes/womens

{{store url='apparel/shoes/womens'}}

Store URL Markup Tag

Otherwise, type the first part of the Store URL markup tag, and paste the URL key or path
that you copied earlier.

{{store url='

{{store url='apparel/shoes/womens'}}

Store URL Markup Tag with URL Key

2. To complete the markup tag, type the closing double quotes and double braces.
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Step 3: Complete the Anchor Tag

1. Wrap the completed markup tag inside an anchor tag, using the markup tag instead of the
target URL. Then, add the link text, and closing anchor tag.

<a href="{{markup tag goes here}}">Link Text</a>

Markup in Anchor Tag

2. Paste the completed anchor tag into the code of any CMS page, block, banner, or email
template, where you want the link to appear.

<a href="{{store url='apparel/shoes'}}">Shoe Sale</a>

Complete Link with Markup
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In this section…

Your Store Design

Page Layout

Layout Updates

Page Setup

Your Store's Theme
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CHAPTER 41:

Your Store Design
Magento provides a variety of easy-to-use design options that you can use to apply
your own customized look-and-feel to your store. To learn more advanced techniques,
such as how to use themes, skins, layouts, and blocks, see the Magento Design Guide.

Magento is an object-oriented environment with pages that are assembled from
separate components. For some, this approach requires a slightly different way of
thinking, because there isn’t a single HTML page that corresponds to any given page.
After you understand the basics, you’ll appreciate working in such a flexible and fluid
environment!

Topics in this chapter:

l Uploading Your Logo

l Uploading a Favicon

l Welcome Message

l Store Demo Notice

l Changing the Copyright Notice

Commerce Resources

See the latest Magento eBooks to gain access to expert insight and online business
resources to help develop and improve your store.

http://www.magentocommerce.com/design_guide
http://magento.com/resources/business


Uploading Your Logo CHAPTER 41:  Your Store Design

640 Magento Enterprise Edition User Guide, Version 1.14.2.1

Uploading Your Logo
The size of the logo in the header is determined by your theme. If your theme has a sample
logo, you can right-click and download the logo to make sure the replacement logo is the
same size.

Logo with Alt Text

The logo image path points to its location on the server. What is actually a long path is
entered as a short path that is relative to the theme. For example:

Actual path: skin/frontend/base/default/images/logo.gif

Relative path: images/logo.gif

The header image filename is hard-coded into some of the theme files. Therefore, if you
change the file name of the logo file, you will also have to make some simple updates to
some source files. For non-programmers, the easiest approach is to use the default
filename, “logo.gif,” and write over the existing file.

To change the logo:

1. On the server, copy your new logo file to the images folder of your theme. For example:

images/media/logo.png

2. On the Admin menu, select System > Configuration. Then in the panel on the left, under
General, select Design.

3. If you have multiple stores or views, set the Current Configuration Scope in the upper-left
corner to the store or view where the configuration applies. Then, clear the checkbox after
each field so new values can be entered.

4. Click to expand the Header section. Then, do the following:

a. If the path or file name has changed, enter it in the Logo Image Src field.

Header

http://merch.docs.magento.com/ee/user_guide/Magento_Enterprise_Edition_User_Guide.html#configuration/general/design.html%23Header
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b. In the Logo Image Alt field, enter the alt text for the image. If the configuration is for
a different language view, enter the alt text in the appropriate language.

c. If your store uses a responsive theme, in the Small Logo Image Src field, enter the
path to a version of the logo that is optimized for small devices.

5. When complete, click the Save Config button.

Uploading a Favicon
Favicon is short for “favorite icon,” and refers to the little icon on the tab of each browser
page. Depending on the browser, the favicon also appears in address bar, just before the
URL.

Favicons are generally 16 x 16 pixels or 32 x 32 pixels in size. Although Magento accepts
.ico, .png, .jpg, .jpeg, .apng, and .svg file types, not all browsers support these formats. The
most widely-supported file format to use for a favicon is .ico. There are many free tools
available online that you can use to generate an .ico image or convert an existing image to
the .ico format.

Favicon in Address Bar

Process Overview:
Step 1: Create a Favicon

Step 2: Upload the Favicon to Your Store

Step 3: Refresh the Cache

Step 1: Create a Favicon

1. Create a 16 x 16 or 32 x 32 graphic image of your logo, using the image editor of your
choice.

2. (Optional) Use one of the available online tools to convert the file to the .ico format. Then,
save the file to your computer.
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Step 2: Upload the Favicon to Your Store

1. On the Admin menu, select System > Configuration.

2. In the panel on the left, under General, select Design. Then, click to expand the HTML
Head section.

3. To upload a favicon, click the Choose File button. Then, select the favicon file that you
prepared.

HTML Head

4. To delete the current favicon, select the Delete Image checkbox.

5. When complete, click the Save Config button.

Step 3: Refresh the Cache

1. As soon as the favicon is uploaded, you are prompted to refresh the cache. Click the Cache
Management link in the message at the top of the workspace.

2. In the list, select the Page Cache checkbox that is marked “Invalidated.”

3. In the upper-right corner, set Actions to “Refresh” and click the Submit button.

4. To view the new favicon, return to your storefront and press F5 to refresh the browser.

http://merch.docs.magento.com/ee/user_guide/Magento_Enterprise_Edition_User_Guide.html#configuration/general/design.html%23HTML_Head
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Changing the Welcome Message
The “Welcome” message in the header of the page expands to include the name of
customers who are logged in. You can change the text for each store or store view.

Welcome Text

To change the welcome message:

1. On the Admin menu, select System > Configuration. Then in the panel on the left, under
General, select Design.

2. If you have multiple stores or views, set the Current Configuration Scope in the upper-left
corner to the store or view where the configuration applies. Then, clear the checkbox after
each field so new values can be entered.

3. Click to expand the Header section.

4. Enter theWelcome Text that you want to appear in the header.

Header

5. When complete, click the Save Config button.

6. When prompted to update the Page Cache, click the Cache Management link at the top of
the workspace. Then, follow the instructions to refresh the cache.
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Store Demo Notice
If you are using a store as a demo, or if it is online but still “under construction,” you can
display a store demo notice at the top of the page. When you are ready to “go live” with the
store, simply remove the message.

Store Demo Notice

To set the store demo notice:

1. On the Admin menu, select System > Configuration. Then in the panel on the left, under
General, select Design.

2. Click to expand the HTML Head section.

3. Scroll down, and set the Display Store Demo Notice as needed.

4. When complete, click the Save Config button.
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Copyright Notice
Your Magento store has a copyright notice in the footer of each page in the storefront, as
well as the Admin. As a best practice, the copyright notice should include the current year,
and identify your company as the legal owner of the site. The &Copy; character code is
used to to insert the copyright symbol, as shown in the following examples:

Copyright &Copy; 2015 Magento, Inc. All rights reserved.

Long Format Example

&Copy; 2015 Magento, Inc. All rights reserved.

Short Format Example

To change the copyright notice:

1. On the Admin menu, select System > Configuration. Then in the panel on the left under
General, select Design.

2. Click to expand the Footer section.

3. In the Copyright box, enter the copyright notice that you want to appear in the footer of
each page. Use the &Copy; character code to insert a copyright symbol.

Footer

4. When complete, click the Save Config button.
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CHAPTER 42:

Page Layout
The layout of each page in your store consists of distinct sections, or containers, that
define the header, footer, and content areas of the page. Depending on the layout, each
page might have one, two, three columns, or more. You can think of the layout as the
“floor plan” of the page.

Content blocks float to fill the available space, according to the section of the page
layout where they are assigned to appear. You will discover that if you change the
layout from a three-column to a two-column layout, the content of the main area
expands to fill the available space, and any blocks that are associated with the unused
side bar seem to disappear. However, if you restore the three-column layout, the blocks
reappear. This fluid approach, or liquid layout, makes it possible to change the page
layout without having to rework the content. If you are used to working with individual
HTML pages, you will discover that this modular, “building block” approach requires a
different way of thinking.

Topics in this chapter:

l Standard Layouts

l Storefront Examples
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Standard Layouts
1 Column

The “1 Column” layout can be used to create a dramatic
home page with a large image or focal point. It’s also a
good choice for a landing page, or any other page that has
a combination of text, images, and video.

2 Columns with Left Bar

The “2 Columns with Left Bar” layout is often used for
pages with navigation on the left, such as a catalog or
search results pages with layered navigation. It is also an
excellent choice for home pages that need additional
navigation or blocks of supporting content on the left.

2 Columns with Right Bar

With a “2 Columns with Right Bar” layout, themain
content area is large enough for an eye-catching image or
banner. This layout is also often used for Product pages
that have blocks of supporting content on the right.
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3 Columns

The “3 Column” layout has a center column that is wide
enough for themain text of the page, with room on each
side for additional navigation and blocks of supporting
content.

Empty

The “Empty” layout can be used to define custom page
layouts. To learnmore, see theMagento Design Guide.
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Storefront Examples
The column dimensions are determined by style sheet of the theme. Some themes apply a
fixed pixel width to the page layout, while others use percentages to make the page respond
to the width of the window or device.

Most desktop themes have a fixed width for the main column, and all activity takes place
within this enclosed area. Depending on your screen resolution, there is empty space on
each side of the main column.

1 Column Layout
The content area of a “1 Column” layout spans the full-width of the main column. This
layout is often used for a home page with a large banner or slider, or pages that require no
navigation, such as a login page, splash page, video, or full-page advertisement.

1 Column Layout
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2 Columns with Left Bar
The content area of this layout is divided into two columns. The main content column
floats to the right, and the side bar floats to the left.

2 Columns Left Bar

2 Columns with Right Bar
This layout is a mirror image of the other two-column layout. This time, the side bar floats
to the right, and the main content column floats to the left.

2 Columns Right Bar
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3 Columns
This layout has a main content area with two side columns. The left side bar and main
column are wrapped together, and float to the left. The other side bar floats to the right.

3 Columns
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Layout Updates
Before you begin working with custom layout updates, it is important to understand how
the pages of your store are constructed, and the difference between the terms layout and
layout update. The term layout1 refers to the visual and structural composition of the
page. However, the term layout update2 refers to a specific set of XML instructions that
determines how the page is constructed.

The XML layout of your Magento Enterprise Edition store is a hierarchical tree of blocks.
Some elements appear on every page, and others appear only on specific pages. You can see
how blocks are referenced by examining the layout update code for your home page. To do
so, simply open your CMS home page in edit mode, and select the Design tab to view the
Page Layout section. Depending on the theme, it might contain instructions to remove
blocks, unset blocks, and add blocks by referencing specific areas of the page layout.

In many cases, the same result can be achieved with a widget. To place a block of content
with a widget, you must identify the page, and location on the page, where you want the
block to appear. You can use a widget to place a block on any generic page of your store,
including the home page and all CMS pages. However, to place a block in the sidebar of a
specific CMS page, you must make a layout update.

Topics in this section:

l Placing a Block

l Controlling Block Order

l Standard Block Layout

l Layout Update Syntax

l Layout Update Examples

l XML Load Sequence

1The visual and structural composition of a page.
2A specific set of XML instructions that determines how the page is constructed.
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Placing a Block with a Layout Update
Blocks can be placed in the left or right column of a specific page by making a layout
update to the XML code. With a few simple changes to the code, you can position the block
in either column, and control its position in relation to other blocks.

As you work with the underlying code, you will encounter slightly different terminology.
For example, the term callout1 is sometimes used to refer to a block that is defined as a
layout update with XML code. The term sidebar2 refers to the left or right columns of the
page layout. For our general discussion, we use the terms block and column. However,
when entering layout update code, make sure to follow the syntax exactly as shown in the
example.

To place a block in a side column:

1. On the Admin menu, select CMS > Pages > Manage Content.

2. Click to open the CMS page. Then, in the panel on the left, select Design.

3. In the Layout Update XML box, enter the code for the right or left sidebar, as shown in
example. Then, do the following:

a. Change the reference name to identify either the “right” or “left” column.

b. Change the block_id to the identifier of the block to be placed.

<reference name="right">

<block type="cms/block" name="right.permanent.callout">

<action method="setBlockId"><block_id>your-block-id</block_id></action>

</block>

</reference>

Code for CMS Block in Side Column

4. When complete, click the Save Page button.

1Sometimes used to describe an XML block of page layout code.
2The right or left column of a two-column page layout.
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Controlling Block Order
To control the order of blocks in an XML layout update, include a “before” or “after”
positioning property in the code. To place a block—either before, or after a specific block—
replace the hyphen with the block identifier, as shown in the following examples:

before="-" Places the block at the top of the sidebar, before other blocks.

after="-" Places the block at the bottom of the sidebar, after other blocks.

<block type="cms/block" before="-" name="left.permanent.callout">

<block type="cms/block" before="some-other-block"

name="left.permanent.callout">

<block type="cms/block" after="-" name="left.permanent.callout">

<block type="cms/block" after="some-other-block"

name="left.permanent.callout">

Code to Position CMS Blocks
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Standard Block Layout
In the following diagram, the block names that can be used to refer to a block in the layout
are black, and the block types, or block class paths, are blue.

Standard Block Layout
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BLOCK TYPE DESCRIPTION

page/html There can be only one block of this type per page. The block
name is "root," and, it is one of the few root blocks in the layout.
You can also create your own block and name it "root," which is
the standard name for blocks of this type.

page/html_head There can be only one “head” block per page, and it is a child of
the root block. This block must not be removed from layout.

page/html_notices There can be only one block of this type per page. The block
name is "global_notices," and it is a child of the root block. If this
block is removed from the layout, the global notices will not
appear on the page.

page/html_header There can be only one block of that type per page. The block
name is "header," and it is a child of the root block. This block
corresponds to the visual header at the top of the page, and
contains several standard blocks. This block must not be
removed.

page/html_wrapper Although included in the default layout, this block is deprecated,
and only is included to ensure backward compatibility. Do not
use blocks of this type.

page/html_breadcrumbs There can be only one block of this type per page. The name of
this block is "breadcrumbs," and it is a child of the header block.
This block displays breadcrumbs for the current page.

page/html_footer There can be only one block of this type per page. The block
name is "footer," and it is a child of the root block. The footer
block corresponds to the visual footer at the bottom of the page,
and contains several standard blocks. This block must not be
removed.

page/template_links There are two blocks of this type in the standard layout. The
"top.links" block is a child of the header block, and corresponds
to the top navigationmenu. The "footer_links" block is a child of
the footer block, and corresponds to the bottom navigationmenu.
It is possible to manipulate the template links, as shown in the
examples.

Block Descriptions
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BLOCK TYPE DESCRIPTION

page/switch There are two blocks of this type in a standard layout. The
"store_language" block is a child of the header block, and
corresponds to the top language switcher. The "store_switcher"
block is a child of the footer block, and corresponds to the bottom
store switcher.

core/messages There are two blocks of this type in a standard layout. The
"global_messages" block displays global messages. The
"messages" block is used to display all other messages. If you
remove these blocks, the customer won't be able to see any
messages.

core/text_list This type of block is widely used throughout Magento, and is
used as a placeholder for rendering children blocks.

core/profiler There is only one instance of this type of block per page. It is
used for the internal Magento profiler, and should not be used for
other purposes.

Layout Update Syntax
Custom layout updates can be applied to product category pages, product pages, and CMS
page to achieve a variety of results, such as:

<block> Create new block.

<reference> Update existing content.

<action> Assign actions to blocks.

<remove> Remove blocks.

Any change made to the layout is applied when the associated entity—which can be either
a product, category, or CMS page—becomes active in the frontend of the store.

Custom layout update instructions consist of well-formed XML tags, without the <?xml
...> declaration and root tag. As with normal XML, every tag must either be empty or
properly closed, as shown in the following examples:

<tag attribute="value" />

<tag attribute="value"> ... </tag>
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<block>
Creates a new block within the current context. Layout block nesting defines the ordering of
block initialization location of the blocks on the page.

NAME VALUE

type * block class path

An identifier of the block class path that corresponds to the class of
the block. See the list of the available block types below.

name * block name identifier

A name that can be used to address the block in which this attribute
is assigned. If you create a new block with the name that is the
same as one of the existing blocks, your newly created block
substitutes the previously existing block. See the list of names of
existing blocks below.

before block name | '-'

Is used to position the block before a block with the name specified
in the value. If "-" value used the block is positioned before all other
sibling blocks.

after block name | '-'

Is used to position the block after a block with the name specified in
the value. If "-" value used the block is positioned after all other
sibling blocks.

template template filename

A template filename used for the specific block type. As you have
no way to see the list of template files, use whatever template
value is demanded for every block type listed below.

as block alias

An alias name by which a template calls the block in which this
attribute is assigned. Sometimes it's necessary to specify the alias
for a specific block type.

Syntax
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<reference>
Changes the context for all included instructions to a previously defined block. An empty
<reference> tag if of no use, because it affects only the instructions which are children.

NAME VALUE

name * block name

A name of a block to reference.

Syntax

<action>
Used to access block API, in other words, call block's public methods. It is used to set up
the execution of a certain method of the block during the block generation. Action child
tags are translated into block method arguments. The list of all available methods depends
on the block implementation (e.g. public method of the block class).

NAME VALUE

method * block method name

A name of the public method of the block class this instruction is
located in that is called during the block generation.

Syntax

<remove>
Removes an existing block from the layout.

NAME VALUE

name * block name

The name of the block to be removed.

Syntax

<extend>
This instruction performs final modifications to blocks which are already part of the layout.
Every attribute in the <block> instruction—except for the block name—is subject for
change. In addition,the special attribute parent can be used to change the parent of the
block. Simply put the name of the new parent block into the <extend> instruction, and the
parent of the block that is referenced will be changed in the layout.
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NAME VALUE

name * block name

The name of any block to be extended.

* any other

Any other attribute specific for the <block> instruction.

parent block name

The name of the block that should become a new parent for the
referenced block.

* Indicates a required value

Syntax

Layout Update Examples
The following blocks types can be manipulated with custom layout instructions. Each
action must be specified using the full syntax of the instruction. In the following examples,
a simplified notation is used to refer to each action, which corresponds to the full syntax of
the instruction.

?

<!-- Action can be specified inside either a <block>

or <reference> instruction. -->

<action method="someActionName">

<arg1>Value 1</arg1>

<arg2>Value 2</arg2>

<!-- -->

<argN>Value N</argN>

</action>

<!-- -->

Full Syntax

?

someActionName($arg1, $arg2, ..., $argN)

 Simplified Syntax
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page/template_links

ACTION DESCRIPTION

addLink($label, $url, $title, $prepare

Adds another link to the end of the list of existing links. Just
specify the $label (link caption), $url (link URL) and
$title (link tooltip), and you'll see a new link in the
corresponding place. The $prepare parameter must be
"true" if you want the URL to be prepared, or converted to
the full URL from the shortened URL. For example, the
newpage becomes BASE_URL/newpage if prepared.

removeLinkByUrl($url) Removes a link from the block by its URL. Note that the
URLmust be properly specified and exactly match
corresponding URL of the link you want to remove.

Syntax

cms/block

ACTION DESCRIPTION

setBlockId($blockId) Specifies the ID of a CMS block, so its content can be
fetched and displayed when the page is rendered.

Syntax

?

<!--...-->

<reference name="content">

<block type="cms/block" name="additional.info" as="additionalInfo">

<action method="setBlockId"><id>additional_info</id></action>

</block>

</reference>

<!-- -->
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core/text
A core/text block can be used to enter free form text directly into the template.

ACTION DESCRIPTION

addText($textContent) Specifies text to be rendered as the block's content. After
the text is specified, the layout update instructions must
continue to be a valid XML statement. If you use HTML
tags as part of the text, it is recommended to use:
<![CDATA[...]]>

Syntax

?

<!--...-->

<reference name="content">

<block type="core/text" name="test.block">

<action method="addText">

<txt><![CDATA[<h2>ATTENTION!</h2><p>Check your options

carefully before you submit.</p>]]></txt>

</action>

</block>

</reference>

<!-- -->

page/html_welcome
This block can be used to duplicate the “Welcome, <USERNAME>!” message that appears in
the header block. When the user is not logged in, the welcome message specified in the
configuration appears.
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XML Load Sequence
For developers, it is important to understand that blocks and layout updates must be
loaded in the correct order, in keeping with the rules of precedence and load sequence1

which determine how the page is rendered. Magento supports the following page layout
scenarios:

Default Layout

The default layout consists of the elements that are visible from every page of the store.
Whether it is a menu item, or a shopping cart block, each item has a handle2 in the
default section of the layout definition.

Specific Pages

The second case allows you to create a different layout for a specific page. The XML layout
for specific pages is constructed in the same sequence that Magento loads modules, and is
determined by the system configuration.

In addition to the instructions in the layout update files that are specific to each module,
you can make a custom layout update that applies to a special case in the backend, that is
merged each time the special case occurs.

1The order scripts are loaded into memory. To work correctly, some scripts must be loaded before others.
2In programming, a name used to reference an object.
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CHAPTER 43:

Page Setup
The main sections of the page are controlled, in part, by a set of standard HTML tags.
Some of these tags control the selection of fonts, color, size, and background colors and
images that appear in each section of the page. Other settings control page elements
such as the logo that appears in the header, and the copyright notice in the footer. The
basic page properties can be set from the Admin.

Topics in this chapter:

l HTML Head

l Page Header

l Page Footer
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HTML Head
The HTML Head section corresponds to the <head> tag of an HTML page and can be
configured for each store view. In addition to meta data for the page title, description, and
keywords, it can include a link to the favicon and scripts. Instructions for search engine
robots and the display of the store demo notice are also configured in this section.

HTML Head

To configure the HTML Head:

1. On the Admin menu, select System > Configuration. Then in the panel on the left, under
General, select Design.

2. For multiple stores or views, set Current Configuration Scope in the upper-left corner to
the store or view where the settings apply. Then, clear the checkbox after each field so new
values can be entered.

3. To see the field descriptions, click the link below the image. Then, update the fields as
needed.

4. When complete, click the Save Config button.

http://merch.docs.magento.com/ee/user_guide/Magento_Enterprise_Edition_User_Guide.html#configuration/general/design.html%23HTML_Head
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Page Header
The Header section identifies the path to the logo file, and specifies the logo alt text and
welcome message.

Header

To configure the header:

1. On the Admin menu, select System > Configuration.

2. In the panel on the left, under General, select Design.

3. Click to expand the Header section, and make any changes necessary. To see the field
descriptions, click the link below the image.

4. When complete, click the Save Config button.
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Page Footer
The Page Footer configuration section is where you can update the copyright notice that
appears at the bottom of the page, and enter miscellaneous scripts.

Footer

To configure the footer:

1. On the Admin menu, select System > Configuration.

2. In the panel on the left, under General, select Design.

3. Click to expand the Footer section, and make any changes necessary. To see the field
descriptions, click the link below the image.

4. When complete, click the Save Config button.

http://merch.docs.magento.com/ee/user_guide/Magento_Enterprise_Edition_User_Guide.html#configuration/general/design.html%23Footer
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CHAPTER 44:

Your Store’s Theme
A theme is a collection of files that determines the visual presentation of your store.
You might think of a theme as the “window dressing” of your store. When you first
install Magento, the design elements of the store are based on the “Default” Theme. In
addition to the initial default theme that comes with your Magento installation, there
is a wide variety of themes that are available “off the shelf” on Magento Connect.
Themes are organized into design packages.

Magento themes include layout files, template files, translation files, and skins. A skin
is a collection of supporting CSS, images, and JavaScript files that together, create the
visual presentation and interactions that your customers experience when they visit
your store. Themes and skins can be modified and customized by a developer or
designer who has knowledge of Magento theme design and access to your server. To
learn more, see the Designer’s Guide to Magento.

Topics in this chapter:

l Design Packages

l Responsive Web Design

l Using the Default Theme

l Installing a New Theme

l Changing UI Text

http://www.magentocommerce.com/design_guide
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Design Packages
A design package is simply a collection of related themes. There can be any number of
design packages installed, but there must always be one that serves as the base package for
the installation. The base package is named “default.”

Each package contains a default theme. In addition, the package might contain any
number of variations of the default theme. Themes contain the files that determine the
visual presentation of each page, and how the elements on the page interact with the user.
Magento themes contain templating information (layout files, template files, theme-specific
translation files) and skinning information (CSS files, images, and theme-specific
JavaScript files). Each theme can belong to only one design package.

Packaging Variations

You can also set up exceptions to dynamically change the package when a specific user
agent, such as a mobile device, tablet, or desktop browser, is detected. Exceptions can also
be applied at the theme level. The names that are used to identify user agents are
constantly evolving, along with the technology. You can search on the Internet for a list of
user agent strings.

For an installation with multiple stores, each store in the hierarchy can have a separate
theme, share the same theme, or a combination of both. The design package and theme can
be assigned at either the website and/or store view level. If you assign a package at the
website level, all stores in the website inherit the package. To override the default package,
you can assign a different package at the store, or store view level. If no additional
packages are available, the system falls back to the default package.
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Before a design package can be assigned, it must be copied to the server. If you purchase
and install a design package or theme from Magento Connect, the necessary files are copied
to your server automatically. However, it might need to update the configuration with the
name of the package, theme, or both. The developer of any design package or theme
typically provides specific configuration instructions.

To assign a design package:

1. On the Admin menu, select System > Configuration.

2. In the panel on the left under General, select Design.

3. Click to expand the Package section. Then, do the following:

a. To assign the package to a specific store view, set the Current Configuration Scope in
the upper-left corner to the store view where the configuration applies. Then, clear the
Use Default checkbox next to the Current Package Name field.

b. Enter the Current Package Name in lower-case characters.

Package

4. To add an exception for a specific user agent, click the Add Exception button. Then, do the
following:

a. In the Matched Expression field, enter the standard name for the user agent to be
matched. For multiple entries, separate each with a vertical bar.

b. In the Value field, enter the name of the package to be used as the exception.

c. Repeat these steps to add as many exceptions as necessary.

Add Exception

5. When complete, click the Save Config button.

6. When prompted to update the cache, click the Cache Management link and follow the
instructions.
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Theme Assets
The assets associated with a theme are organized in the skin folder. JavaScript libraries
which are shared across themes, are placed in the js/ directory at the Magento root.

FILE TYPE DESCRIPTION

CSS Directory that contains the CSS files that control the visual styling that is
associated with the skin. Location on server:
[magento]/skin/frontend/[designPackage]/[theme]/css

Images Directory that contains all images used by the theme, including buttons,
background textures, and so on. Location on server:
[magento]/skin/frontend/[designPackage]/[theme]/images

JS Directory that contains theme-specific JavaScript routines and callable
functions. Location on server:
[magento]/skin/frontend/[designPackage]/[theme]/ja
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CSSSettings
As part of an effort to optimize your site and reduce page load time, you can reduce the
number of separate CSS files by merging them into a single condensed file. If you open a
merged CSS file, you’ll find one continuous stream of text, with line breaks removed.
Because you can’t edit the merged file, it’s best to wait until you are out of the development
mode, and no longer making frequent changes to the CSS.

To merge CSS files:

1. On the Admin menu, select System > Configuration. Then in the panel on the left under
Advanced, select Developer.

2. Click to expand the CSS Settings section.

CSS Settings

3. Set Merge CSS Files to “Yes.”

4. When complete, click the Save Config button.

JavaScript Settings
Multiple JavaScript files can be merged into a single, condensed file to reduce page load
time. If you open a merged JavaScript file, you’ll find one continuous stream of text, with
line breaks removed. If you are finished with the development process, and the code
contains no errors, you might consider merging the files.

To merge JavaScript files:

1. On the Admin menu, select System > Configuration. Then in the panel on the left under
Advanced, select Developer.

2. Click to expand the JavaScript Settings section.

JavaScript Settings

3. Set Merge JavaScript Files to “Yes.”

4. When complete, click the Save Config button.
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Responsive Web Design
Responsive design is an approach to web page creation that flows the page layout to fit the
visitor’s screen size and orientation, and changes the layout accordingly. The Magento
default responsive theme features style sheets that support flexibility for layouts and
images, and helps provide a pleasing experience for site visitors using mobile devices. By
comparison, non-responsive sites or sites not optimized for smaller screens or mobile
devices are often slow or difficult to read, and offer a clunky mobile eCommerce experience.

Responsive Theme on Tablet and Smartphone

Benefits of using the Magento default responsive theme include:

l You can get a tablet and smart phone friendly responsive site in about half the time as
before, speeding time to market and freeing up resources for other projects.

l Your responsive site makes you better able to participate in the fast growing mobile
commerce space, and gives you the ability to create a website that is more easily
adapted to new opportunities and less expensive to maintain. A responsive site also
offers potential search engine optimization (SEO) benefits from using Google’s preferred
approach to mobile-optimizing sites.

l You no longer need to develop separate content per device. The default theme is easy to
customize for simple sites, and provides a powerful starting point for developing themes
for more complex sites.
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Technical Information
Technologies used in Magento’s default responsive theme include Sass/Compass1 and
jQuery2 in noConflict() mode. Additional JavaScript libraries are discussed in more
detail in the Responsive Theme Developer’s Guide.

The responsive theme code is located on the server in the following directories, relative to
your Magento installation:

app/design/frontend/rwd

skin/frontend/rwd

Code Location

Using the Default Theme
The default Magento Enterprise Editiontheme uses Responsive Web Design (RWD)
principles. Responsive web design enables you to use a single theme to present your
storefront to your customers regardless of which device they use. The theme uses modern
technologies and incorporates best practices for mobile site experience.

To view the default theme:

1. On the Admin menu, select System > Configuration.

2. In the panel on the left, under General, select Design.

3. Click to expand the Package section. The new responsive theme is enabled by default. The
default package name is “rwd.”

Package

4. Click to expand the Themes section. The Default field shows the name of the default RWD
theme.

1A CSS pre-compiler that provides organizable, reusable CSS.
2A popular JavaScript library that is often used to create dynamic and responsive effects.
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Themes

5. When complete, click the Save Config button.

Installing a New Theme
Magento Connect contains hundreds of extensions, which as add-ons to Magento, can
extend the functionality or enhance the appearance of your store.

Magento Connect

To install a new theme:

1. Go to Magento Connect.

2. In the upper-right corner, click to extend the All Platforms list, and choose Enterprise

3. You can browse through the available themes based on price or popularity, or do a keyword
search. For more information, click the thumbnail of any theme.

http://merch.docs.magento.com/ee/user_guide/Magento_Enterprise_Edition_User_Guide.html#configuration/general/design.html%23Themes
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4. To get the registration key, you must be a registered Magento Enterprise Edition owner and
be logged into your account. Then, click the Install Now button to get the license key.

Install Now

5. To complete the process, follow the instructions to install an extension from Magento
Connect.

To activate the theme for your store:

1. On the Admin menu, select System > Configuration. In the panel on the left, under
General, select Design.

2. Click to expand the Themes section. Then, do the following:

Themes

3. In the Default field, enter the name of the theme. The name of the Magento demo store
theme is “mds.”

4. If you want to switch to this theme as an alternate when your store is viewed with different
browsers or devices, do the following:
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a. Click the Add Exception button.

The Add Exception button is used to use a different theme for specific browsers. For
example, a theme that is optimized for mobile can be used whenever a mobile device is
detected.

Add Exception

b. In the Matched Expression field, enter the name of the browser or device that triggers
the use of the alternate theme. If there are multiple browsers, separate the name of
each with a vertical bar. For example, because the mobile theme can be used with
multiple devices, you can enter them all in the Match Expression field, as follows:

Android|Blackberry|Googlebot-Mobile|iPhone|iPod|mobi|Palm|Opera

Mini|Windows Mobile

c. In the Value field, enter the name of the theme. In this example, the value is “Mobile.”

5. Click the Save Config button on the top right of the page.

6. Test the new theme from your store. If you installed an exception for different browsers,
view the store with each browser or device.

If the new theme uses a different page layout than your current home page, you might
need to change its page layout setting to match the theme.
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Changing UI Text
You can use the Translate Inline tool to touch up the text in the interface to reflect your
voice and brand. When the Translate Inline mode is activated, all text on the page that can
be edited is outlined in red. It’s easy to edit field labels, messages, and other text that
appears throughout the storefront and Admin. For example, many themes use terminology
such as “My Account,” “My Wishlist,” and “My Dashboard,” to help customers find their
way around. However, you might prefer to simply use the words “Account,” “Wishlist,” and
“Dashboard.”

If your store is available in multiple languages, you can make fine adjustments to the
translated text for the locale. On the server, interface text is maintained in a separate CSV
file for each output block, and is organized by locale. As an alternate approach, rather than
use the Translate Inline tool, you can also edit the CSV files directly on the server.

To use the Translate Inline tool, your browser must allow pop-ups.

Step 1: Add Your IP Address to the Developer Mode Whitelist

To use the Inline Translator without disrupting the shopping experience of customers in
the store, add your IP address to the Developer Client Restrictions whitelist. If you don’t
know your IP address, you can search for it online.

1. On the Admin menu, select System > Configuration. In the panel on the left under
Advanced, select Developer.

2. In the Allow IPs field, enter your IP address. If access is needed from multiple IP
addresses, separate each with a comma.

Developer Client Restrictions

3. When complete, click the Save Config button.
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Step 2: Disable Output Caches

1. On the Admin menu, select System > Cache Management.

2. Select the following checkboxes:

l Blocks HTML output

l Translations

3. Set the Actions control to “Disable.” Then, click the Submit button.

Disable Output Caches

Step 3: Activate the Translate Inline Tool

1. On the Admin menu, select System > Configuration.

2. To work with a specific store view, set Current Configuration Scope to the store view to be
updated.

3. In the panel on the left under Advanced, select Developer.

4. Click to expand the Translate Inline section. Then, do the following:

a. Set Enabled for Frontend to “Yes.”

For a specific store view, you must first clear the Use Website checkbox. The Enabled
for Admin option is not available when editing a store view.

Translate Inline

5. When complete, click the Save Config button.
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Step 4: Update the Text

1. Open your storefront in a browser, and go to the page that you want to edit. If necessary,
select the store view from the language switcher in the upper-left corner.

Each string of text that can be translated is outlined in red. When you hover over any text
box, a book icon appears.

Translatable Text

2. Click the book icon to open the Translation window. Then, do the following:

a. If the change is for a specific store view, select the Store View Specific checkbox.

b. Enter the Custom text.

c. Click the Submit button.

Enter Custom Text

3. To see your changes in the store, press the F5 key to refresh the browser.

4. Repeat this process for any elements in the store to be changed.

Step 5: Restore Original Settings

1. On the Admin menu, select System > Developer.

a. In the panel on the left under Advanced, select Developer.

b. Click to expand the Translate Inline section.

a. Set Enabled for Frontend to “No.”

b. Click the Save Config button.
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2. On the Admin menu, select System > Cache Management. Then, do the following:

a. Select the following checkboxes:

l Blocks HTML output

l Translation

b. Set the Actions control to “Enable.” Then, click the Submit button.

Enable Output Caches



Customers



In this section…

Customer Accounts

Customer Groups

Customer Attributes
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CHAPTER 45:

Customer Accounts
The header of every page in your store extends an invitation for shoppers to “Log in or
register” for an account with your store. You have the option to require that customers
register before making a purchase, or to allow them to make purchases as guests.
Customers who open an account with your store enjoy a range of benefits, including:

Faster Checkout

Registered customers move through checkout faster because much of the information is
already in their accounts.

Ability to Self-Serve

Registered customers can update their information, check the status of orders, and even
reorder from their account dashboard.
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Customer Account Configuration
The customer account settings determine the information that you collect during customer
registration, and the experience customers have during the process.

Topics in this section include:

l Account Scope

l Login Landing Page

l Basic Account Options

l Name and Address Options

l Password Options

Customer Account Scope
The scope of customer accounts can be limited to the website where the account was
created, or shared with all websites and stores in the store hierarchy.

To set the scope of customer accounts:

1. On the Admin menu, select System > Configuration.

2. In the panel on the left, under Customers, select Customer Configuration.

3. Click to expand the Account Sharing Options section.

Account Sharing Options

4. Set Share Customer Accounts to one of the following:

Global To share customer account information with every website and store in
the Magento installation.

Per Website To limit customer account information to the website where the account
was created.

5. When complete, click the Save Config button.
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Login Landing Page
Depending on the configuration, customers can be redirected to their account dashboard, or
continue shopping after they log in to their accounts.

Login Options

To set the login landing page:

1. On the Admin menu, select System > Configuration.

2. In the panel on the left, under Customers, select Customer Configuration.

3. Click to expand the Login Options section.

4. Set Redirect Customer to Account Dashboard after Logging in to one of the following:

Yes The account dashboard appears when customers log in to their accounts.

No Customers can continue shopping after logging in to their accounts.

5. When complete, click the Save Config button.
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Basic Account Options
In the customer configuration, the basic account options are combined with advanced
options related to VAT ID Validation. The following instructions show how to complete
only the basic customer account options, which are highlighted in the following screenshot.
To learn about the advanced options, see: VAT ID Validation.

Create New Account Options

To set up the basic customer account options:

1. On the Admin menu, select System > Configuration.

2. In the panel on the left, under Customers, select Customer Configuration.

3. Click to expand the Create New Account Options section. Then, do the following:

a. Set Default Group to the customer group that is assigned to new customers when an
account is created.

b. Enter the Default Email Domain for the store. For example: mystore.com

c. Set Default Welcome Email to the template that is used for the Welcome email sent to
new customers.

d. Set Email Sender to the store contact that appears as the sender of email.

e. To require that customers must confirm their request to open an account with your
store, set Require Emails Confirmation to “Yes.” Then, set Confirmation Link Email
to the template that is used for the confirmation email.

f. Set Welcome Email to the template that is used for the Welcome message that is sent
after the account is confirmed.

4. When complete, click the Save Config button.
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Name and Address Options
The fields that are included in the customer registration form, and the format of the street
address are set in the Customer Configuration. When all fields are used, the registration
form includes the full name, including the middle initial, with drop-down lists for the
prefix and suffix. The registration form can also include the date of birth, gender, and Tax
ID or VAT number.

To configure the customer name and address fields:

1. On the Admin menu, select System > Configuration.

2. In the panel on the left, under Customer, select Customer Configuration.

3. Click to expand the Name and Address Options section.

Name and Address Options

4. Enter the Number of Lines in a Street Address. If blank, the default is two lines.

5. To include a prefix before the name, do the following:

a. Set Show Prefix to one of the following:

l Optional

l Required

b. In the Prefix Dropdown Options field, enter each prefix that you want to appear in the
list, separated by a semicolon. Place a semicolon before the first value to display an
empty value at the top of the list.

6. To include a suffix after the name, do the following:

a. Set Show Suffix to one of the following:

l Optional

l Required

b. In the Suffix Dropdown Options field, enter each prefix that you want to appear in the
list, separated by a semicolon. Place a semicolon before the first value to display an
empty value at the top of the list.
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7. To include additional fields, do the following:

a. Set Show Date of Birth to “Yes.”

b. Set Show Tax/VAT Number to “Yes.”

c. Set Show Gender to “Yes.”

8. When complete, click the Save Config button.

Password Options
The customer password options determine the email templates that are used when
customers forget their passwords, and the lifetime of the password recovery link. You can
allow customers to change their own passwords, or require that only store administrators
can do so.

To configure customer password options:

1. On the Admin menu, select System > Configuration.

2. In the panel on the left under Customers, select Customer Configuration.

3. Click to expand the Password Options section. Then, do the following.

Password Options

a. Set Forgot Email Template to the template that is used for the email sent to
customers who have forgotten their passwords.

b. Set Remind Email Template to the template that is used when a password hint is sent
to customers.

c. Set Forgot and Remind Email Sender to the store contact that appears as the sender
of the Forgot Email and Remind Email notifications.

d. In the Recovery Link Expiration Period field, enter the number of days before the
password recovery link expires.

e. To require that only the store administrator can change customer passwords, set
Require admin user to change user password to “Yes.”

4. When complete, click the Save Config button.
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Account Dashboard
Customers can access their account dashboard by clicking the “My Account” link in the
header of the store. They can use their account dashboard to view and modify their
information, including past and current addresses, billing and shipping preferences,
newsletter subscriptions, wishlists, and more. They can also view tags and product reviews
they have created while logged in to your store.

Account Dashboard
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Dashboard Sections

Account Information

Customers can update their account information and change their password, as needed.

Address Book

The customer address book includes the default billing and shipping address, and
additional address entries.

My Orders

Displays a list of all customer orders, with a link to each. Any order can be reordered by
simply clicking the Reorder link.

Billing Agreements

Displays a list of any customer billing agreements.

Recurring Profiles

Displays a list of any products that are purchased on a recurring basis, as a subscription.

Order by SKU

A quick order form that allows the customer to order by SKU or import a list of products to
be ordered.

My Product Reviews

Displays a list of all product reviews submitted by the customer, with a link to each.

My Tags

Displays a list of all product tags made by the customer.

Wishlists

Displays a list of the wishlists created by the customer. New wishlists can be created and
shared, and products can be added to the cart.

My Applications

This section is a placeholder for API applications that link the customer account to other
applications or extensions.

http://www.magentocommerce.com/api/rest/authentication/oauth_configuration.html
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Newsletter Subscriptions

Lists all available newsletters. Each newsletter the customer currently subscribes to has a
checkmark.

My Downloadable Products

Lists all downloadable products the customer has purchased, with a link to each.

My Store Credits

Shows the balance and history of the customer’s account.

Gift Cards

The customer can enter a gift card code to check the balance, or redeem the gift card.

Gift Registry

Lists all gift registries created by the customer. Gift registries can be edited, shared, and
deleted.

Reward Points

Shows the balance of reward points, the cash balance, and current exchange rate.

My Returns

Displays a list of any products returned by the customer.

Invites

Displays a list of all invitations sent to events.
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Order by SKU
The Order by SKU tab contains the fields for entering SKUs and quantities, and controls for
loading a .csv file with a list of SKUs. The Order by SKU widget includes the fields for SKUs
and quantities and optionally a link to the Order by SKU tab.

To order by SKU from your customer account:

1. From your Account dashboard, in the panel on the left, select Order by SKU. Then, do the
following:

2. In the Order by SKU block, enter the SKU number and Qty you want to order.

3. To add another item, click the Add Row button.

4. In the Order by SKU block, click the Load a List of SKUs link.

To upload a list of SKUs:

1. Prepare a csv file with the order data. The file can be created in a spreadsheet with the
columns “sku” and “qty.” Then, save the data as a csv file.

2. On the Order by SKU page, click the Choose File button. Then, find the csv file that you
prepared with the order data.

3. Click the Add to Cart button.

Uploading a CSV Data File
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Exception Handling
Products that cannot be added to the shopping cart are listed in a separate section on the
page. Products in this section can be added to cart after the customer completes the
missing information, such the choosing product options, or entering the quantity to be
purchased. A customer can ignore the section with failed products and proceed to checkout
with the products that were successfully added. Any failed products are stored for the
duration of the session.

After a customer specifies SKUs or loads a spreadsheet with SKUs, and chooses to add
them to the shopping cart, all products that can be ordered and do not require additional
configuration are added . All other products are displayed in a separate section with the
heading, “Products Requiring Attention.”

Products Requiring Attention
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The following conditions may interfere with products being added to a cart:

l A product with multiple options, such as a configurable, grouped, bundle, gift card, or
simple product with custom options.

l A product that is out of stock or disabled

l There is not enough quantity in stock and backorders are not allowed

l No product with a specified SKU is found in the catalog

l The quantity specified is less than the minimum allowed in the cart for a product

l The quantity specified is greater than the maximum allowed in the cart for a product

l A product cannot be added because of category permissions settings

l A product is assigned to another website

l A product is configured to be not visible individually

l A product cannot be added because of other errors, such as errors in an installed
extensions or customization

Important!Order by SKU supports ordering by a compound SKU value, consisting from the
system SKU value and a value of the custom option SKU, delimited by the “-” sign. However
such a compound value can be processed correctly only if both the system SKU and custom
option(s) SKU values do not contain a "-" sign. The compound dynamic SKUs of bundle products
are not supported.
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Customer RMA Requests
RMA requests can be created only for an order with a shipment record. Both account-
holding customers and guests can make RMA requests. When the request is saved, it
appears in the My Returns section of the customer account. The request cannot be edited,
but comments can be added. New RMA requests have a status of “Pending.” When the
status changes, it is reflected in the customer’s account.

To access an RMA from a customer account:

1. Log in to the customer account. Then in the panel on the left, select My Orders.

2. Find the order with the items to be returned, and click the View Order link.

3. In the upper-right corner, click the Return link.

Return Link

4. By default, each return product a customer must complete the following fields. To add
more fields, see: RMA Item Attributes.

697Magento Enterprise Edition User Guide, Version 1.14.2.1



Customer RMA Requests CHAPTER 45:  Customer Accounts

698 Magento Enterprise Edition User Guide, Version 1.14.2.1

Quantity to Return The quantity of the product items that a customer wants to
return. For complex products this field does not appear. The
customer specifies the quantity to return for each simple
product in the Item field.

Reason to Return By default, the following values are available: Wrong Color,
Wrong Size, Out of Order, and Other. If Other is selected, the
additional text field appears for specifying the reason.

Desired Resolution The way the customer wants to resolve the situation. By
default, the following values are available: Exchange, Refund,
Store Credit.

Item Condition By default, the following values are available: Unopened,
Opened, and Damaged.

To add more products to the return request, click the Add Item to Return link in the
bottom of the page.

5. When complete, click the Save button to submit the request.

RMA Request



CHAPTER 45:  Customer Accounts Customer Store Credit

Customer Store Credit
The Store Credit section of a customer account shows the current balance, available gift
card balances, and the balance history, if enabled in the configuration.

Customers can apply a gift card balance toward their store credit. There is a link to the Gift
Card tab. (For Virtual or Combined gift cards, the email sent to the recipient also includes
a link to the Gift Card tab). The customer can enter the gift card code, and redeem the gift
card to transfer the balance. For the balance to be transferable, the gift card account must
be set to be redeemable.

Customer Account Store Credit
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CHAPTER 46:

Customer Groups
The customer group determines which discounts are given to a customer, as defined by
price rules, and the tax class that is associated with the group. The default customer
groups are General, Not Logged In, and Wholesale.

In this chapter:

l Creating a Customer Group

Customer Information with Group



Creating a Customer Group CHAPTER 46:  Customer Groups

702 Magento Enterprise Edition User Guide, Version 1.14.2.1

Creating a Customer Group
Customer groups can be referenced in promotional price rules, used to target customer
segments, and associated with specific tax classes. Follow these steps to create the
customer groups you need for your store.

To create a customer group:

1. On the Admin menu, select Customers > Customer Groups.

Add New Customer Group

2. To create a new group, click the Add New Customer Group button. Then, do the following:

a. Enter a unique Group Name to identify the group from the Admin. The name must be
less than 32 characters.

b. Select the Tax Class that applies to the group.

Group Information

3. When complete, click the Save Customer Group button.

To edit a customer group:

1. On the Admin menu, select Customers > Customer Groups.

2. In the list, click to open the customer group record.

3. Make the necessary changes.

4. When complete, click the Save Customer Group button.
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CHAPTER 47:

Customer Attributes
Magento has many built-in customer data fields to support the order, fulfillment and
customer management processes. However, every business is different and sometimes
additional fields are needed. You can create and manage additional customer and
address attributes as needed.

You can add custom attributes to the Account Information, Address Book, and Billing
Information sections of the customer’s account. Customer address attributes can
appear in the Billing Information section during checkout, or when guests register for
an account. You can even create a special account page for guests to use when
registering for a customer account.

Topics in this chapter:

l Custom Customer Attributes

l Address Attributes

l Customer Address Templates
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Custom Customer Attributes
To create a customer attribute, complete the properties that describe how it will be used,
and how it appears in the store. The process is similar to creating a product attribute.

Manage Customer Attributes

To create a custom customer attribute:

1. On the Admin menu, select Customers > Attributes > Manage Customer Attributes.

The list includes both system and custom attributes. System attributes cannot be changed
or deleted.

2. In the upper-right corner, click the Add New Attribute button.

3. Complete the Attribute Properties as described in the Field Descriptions.

Attribute Properties

4. Complete the Frontend Properties as described in the Field Descriptions.
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Frontend Properties

5. In the panel on the left, select Manage Label / Options.

6. In the Manage Titles section, enter a label to identify the field in the form. For multiple
store views, you can enter a different label for each.

Manage Titles

7. The Manage Options section appears if the attribute input type has multiple options. Click
the Add Option button. For each value, do the following:

a. Enter the first value. For multiple views, you can enter a different value for each.

b. If applicable, enter a number to determine the Position of the value in the list.

c. If you want the value to be preselected, select the Is Default option.

Manage Options

8. When complete, click the Save Attribute button.
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FIELD SCOPE DESCRIPTION

ATTRIBUTE PROPERTIES

Attribute Code Global Specify the customer attribute name that will be
used by the system. The namemust be unique
andmust not contain any special characters,
except an underscore, or any spaces.

Input Type Global Specify the way the attribute appears to the
customer in the store. Options include:

Text Field Single line text field. Max
andmin size can be
specified later.

Text Area Multi-line text input area.
Max andmin size can be
specified later.

Multiple Line The number of input lines
to be available for the
customer in the frontend
(cannot exceed 20 lines).

Date The system validates the
customer’s date attribute
input.

Dropdown A drop-down list of
options. To define the
options, see: Manage
Label / Options.

Multiple Select Multi-selectable list of
options. When selected,
the store administrator
needs to create a number
of attribute options on the
Manage Label / Options
tab.

Yes/No Binary/yes-no input field.

Field Descriptions
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FIELD SCOPE DESCRIPTION

File (attachment) Allows files to be
uploaded by the
customer.

Image File Allows images to be
uploaded by the
customer.

Default Value Website Specify a value that will be displayed in the
attribute field in the frontend as a default one.

Input Validation Global Determines how the value entered by the
customer is verified. The system verifies that the
value entered in the attribute field corresponds to
the type of attribute created. Input validation
options available to the store administrator may
vary depending on the attribute input type
selected. Options include:
None
Alphanumeric
Numeric Only
AlphaOnly
URL
Email

Minimum Text Length Global Determines theminimum number of characters
that can be entered in the field. Applies to input
types:
Text Field
Text Area
Multiple Line

Maximum Text Length Global Determines themaximum number of characters
that can be entered in the field. Applies to input
types:
Text Field
Text Area
Multiple Line

Maximum File Size (bytes) Global Determines themaximum size of an attachment
file. Applies to input type: File.

Field Descriptions (cont.)
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FIELD SCOPE DESCRIPTION

File Extensions Global List allowed extensions of files to be attached in
the field. Separatemultiple file extensions with a
comma. Applies to input type: File.

Values Required Website Determines if the attribute is a required field during
data entry. The information cannot be saved until
the required field is complete.

Input/Output Filter Global Choose which filter will be applied to the attribute
during the input and output operations. Filters can
only be applied if the attribute is of Text Field,
Text Area, or Multiple Line input type. The
following options are available:
None
Strip HTML Tags
Escape HTML Entries

Use in Customer Segment Global Determines if the attribute can be used to define a
customer segment for targetedmarketing.
Options include: Yes / No.

FRONTEND PROPERTIES

Show on Frontend Website Determines if the attribute is visible in the store.
Options include: Yes / No.

Sort Order Global Determines the order in which the attribute
appears when listed with other custom attributes.
In the form, system attributes appear first,
followed by the custom attributes.

Forms to Use In Global Choose the forms where the attribute will be used:
Options include:
Customer Checkout Register
Customer Registration
Customer Account Edit
Admin Checkout

Field Descriptions (cont.)
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Customer Address Attributes
Custom address attributes can be set up if you need to provide additional information,
such as an optional email address, Skype account, alternate phone number, building, or
county. The custom attribute can then be incorporated into the address template that is
used to produce sales documents.

The customer VAT ID value is stored in the vat_id customer address attribute. The default
label of this attribute is VAT number. The VAT number field is always present in all
shipping and billing customer addresses when viewed from the Admin, but is not required.

The process for creating a custom address attribute is almost the same as creating a
customer attribute. Customer address attributes can be used in the following forms:

l Customer Registration

l Address Book

l Customer Billing and Shipping Address

Address Templates
You can modify the template that controls the format of customer billing and shipping
addresses that appear on printed invoices, shipments, and refunds, as well as in the
addresses book of the customer account.

If you need to include additional information, you can create custom attributes that are
associated with the customer account and address, and incorporate them into the
template.

Example 1: Text Templates

{{depend address attribute code}} a space, a character, or UI label

{{/depend}};

{{if address attribute code}}{{var address attribute code}} a space, a

character, or UI label

{{/if}}

For Text, Text One Line, HTML and PDF Address Templates

Example 2: JavaScript Template

#{address attribute code} or User Interface label #{address attribute code}

For JavaScript Address Template
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Address Templates

To change the order of address fields:

1. On the Admin menu, select System > Configuration.

2. In the panel on the left, under Customers, select Customer Configuration.

3. Click to expand the Address Templates section. The section includes a separate set of
formatting instructions for each of the following:

l Text

l Text One Line

l HTML

l PDF

l JavaScript Template

4. Edit each template as needed, using the examples for reference.

5. When complete, click the Save Config button.

http://merch.docs.magento.com/ee/user_guide/Magento_Enterprise_Edition_User_Guide.html#configuration/customers/customer-configuration.html%23 Address_Templates
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CHAPTER 48:

Managing Orders
The focus of this chapter is on what happens after a customers places an order, and the
time that the order is delivered. You will learn how to offer shopping cart assistance,
fulfill orders, print invoices, collect payment, process credit memos, manage returns,
and more.

Topics in this chapter:

l Process Overview

l Order Stages

l Assisted Shopping

l Order Fulfillment

l Return Merchandise Authorization

l Store Credit and Refunds

Commerce Resources

See the latest Magento eBooks to gain access to expert insight and online business
resources to help develop and improve your store.

http://magento.com/resources/business
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Process Overview
Order Submitted

During checkout, the customer reviews the order, agrees to the Terms and Conditions, and
clicks the Place Order button. Customers receive a confirmation of their orders, with a link
to their customer account.

Order “Pending"

Before payment is processed the status of a sales order is “Pending.” At this point, the order
can still be canceled.

Payment Received

Depending on the payment method, you, may be notified when the transaction is
authorized and in some cases, processed. The status of the invoice is now “Processing.”

Order Invoiced

Sometimes an order is invoiced before payment is received. In this example, the invoice is
generated and submitted after the credit card payment has been authorized and processed.
After the invoice is generated and submitted, a copy is sent by email to the customer.

Order “Processing”

When the customer logs into his account to check on the order, the status is still
"Processing."

Order Shipped

The shipment is submitted, and packing slips printed. You ship the package, and the
customer is notified by email. Congratulations! You’re in business.
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Order Stages
The Sales menu lists transactions according to where they are in the order workflow. You
might think of each of these as a possible stage in the life of an order.

Orders

When an order is created, either from the storefront or
in the Admin, a sales order is created as a temporary
record of the transaction. Sales orders can be seen
from the Admin by selecting the Orders option from
the Sales menu. Payment has not yet been
processed and the order can still be canceled.

Invoices

An invoice is a record of the receipt of payment for an
order. Creating an invoice converts the temporary
sales order into a permanent record of anOrder,
which can no longer be canceled. Multiple invoices
can be created for a single order, each containing as
much or as few of the purchased products that you
specify. Depending on the payment action, payment
can be automatically captured when the invoice is
generated.

Shipments

A shipment is a record of the products in an order that
have been shipped. As with invoices, multiple
shipments can be associated with a single order,
until all of the products in the order are shipped.
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RMA

A returnmerchandise authorization (RMA) can be
granted to the purchaser of a product who has
requested to return it for a refund or replacement.
Typically the customer contacts themerchant to
request a refund. If approved, a unique RMA number
is assigned to identify the returned product.

Credit Memos

A credit memo is a record of a refund. A product
cannot be refunded until it has been paid (which
means that it has been invoiced). This means that
you are not able to create a credit memo before an
invoice has been created. The credit memo serves
as a record of a refund, but it is not a record of the
actual return of funds to the customer.

Transactions

The Transactions page lists all payment activity that
has taken place between your store and a payment
system, and provides access tomore detailed
information.

Archive

Your store can be configured to archive orders,
invoices, shipments, and credit memos after a set
number of days. Archiving orders on a regular basis
improved performance and keeps your workspace
free of unnecessary information, so you can focus on
current activities.
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Terms and Conditions
When Terms and Conditions is enabled, customers must select a checkbox to verify that
they agree to the terms and conditions of the sale. The Terms and Conditions message and
checkbox appear during Order Review between the Totals section and the Place Order
button. The transaction cannot be finalized until the customer selects the checkbox to agree
to the terms and conditions of the sale.

Terms and Conditions at Checkout

Step 1: Enable Terms and Conditions

1. On the Admin menu, select System > Configuration.

2. In the panel on the left under Sales, select Checkout. Then, click to expand the Checkout
Options section.

Checkout Options
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3. Make sure that Enable Onepage Checkout is set to “Yes.” Otherwise, the Terms and
Conditions checkbox will not appear during checkout.

4. To display the terms and conditions checkbox during checkout, set Enable Terms and
Conditions to “Yes.”

5. When complete, click the Save Config button.

Step 2: Add Your Terms and Conditions

1. On the Admin menu, select Sales > Terms and conditions.

2. In the upper-right corner, click the Add New Condition button.

3. In the Terms and Conditions Information section, complete the following:

Terms and Conditions Information
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a. Enter the Condition Name. The name is for internal reference only.

b. Set Status to “Enabled.”

c. Set Show Content as to one of the following:

Text Displays the terms and conditions content as unformatted text.

HTML Displays the content as HTML.

4. Identify the Store View where the Terms and Conditions will appear.

5. Enter the Checkbox Text that you want to appear as a label with the checkbox. For
example, you could use “I understand and accept these terms and conditions of the sale.”

6. In the Content field, enter the full text of the terms and conditions of the sale.

7. (Optional) Enter the Content Height (css) in pixels, to determine the height of the text box
where the terms and conditions statement appears during checkout. For example, to make
the text box one inch high on a 96 dpi display, enter 96.

8. When complete, click the Save Condition button.
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Setting Up Sales Email
A number of transactional email messages are triggered by events related to an order, and
the configuration is similar for each. You must identify the store contact that appears as
the sender of the message, the email template to be used, and who else is to receive a copy
of the message.

Sales Email Configuration

Step 1: Update the Email Templates

Make sure that you have updated each email template configuration with your store logo,
and have made any other changes necessary to the content of each template to reflect your
store and brand. For a complete list of templates, see: Email Template Reference.

Step 2: Configure Sales Emails

1. On the Admin menu, select System > Configuration.

2. In the panel on the left under Sales, select Sales Emails. Then, do the following:

3. Click to expand the Order section. Then, do the following:

a. Verify that Enabled is set to “Yes.”

b. Set New Order Confirmation Email to the store contact that appears as the sender of
the message.

c. Set New Order Confirmation Template to the template that is used for the email that
is sent to registered customers.

d. Set New Order Confirmation Template for Guest to the template that is used for the
email that is sent to guests who do not have an account with your store.

e. In the Send Order Email Copy To field, enter the email address of anyone who is to
receive a copy of the new order email. If sending a copy to multiple recipients,
separate each address with a comma.

http://merch.docs.magento.com/ee/user_guide/Magento_Enterprise_Edition_User_Guide.html#configuration/sales/sales-emails.html
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f. Set Send Order Email Copy Method to one of the following:

Bcc Sends a “blind courtesy copy” by including the recipient in the
header of the same email that is sent to the customer. The BCC
recipient is not visible to the customer.

Separate Email Sends the copy as a separate email.

Order

4. Click to expand the Order Comments section, and repeat these steps.

5. Complete the configuration in a similar manner for the remaining sales emails:

l Invoice

l Shipment

l Credit Memo

6. When complete, click the Save Config button.
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Notes
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CHAPTER 49:

Assisted Shopping
Customers sometimes need assistance to complete a purchase. Some customers like to
shop online, but would rather the order by phone. While you’re on the phone, the
customer might decides to take advantage of a coupon. To complete the sale, you must
know how to edit the contents of the shopping cart, apply the discount from the
coupon, and complete the order from the Admin—all while the customer is on the
phone. No problem!

You can offer immediate shopping cart assistance to any customer who has registered
for an account with your store. The Manage Shopping Cart tool gives you the ability to
edit the contents of the customer’s shopping cart in real time, from the Admin of your
store. Customer Service reps can see the contents of a customer’s shopping cart while
the customer is on the phone, and the changes can be seen by the customer
immediately when the page is refreshed.

Topics in this chapter:

l View Online Customers

l Update a Shopping Cart

l Create an Order

l Order by SKU

l Create a Customer Account

l Manage Customer Activities

l Persistent Shopping Cart
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View Online Customers
From the Admin, you can see the registered customers who are currently shopping in your
store, and view their activity. To open a customer session, simply click the customer name
in the list. The length of the customer session is set in the configuration and by default, is
fifteen minutes.

Online Customers

To change the duration of online sessions:

1. On the Admin menu, select System > Configuration.

2. In the panel on the left under Customers, select Customer Configuration.

3. Click to expand the Online Customers Options section.

4. In the Online Minutes Interval field, enter the duration of an online customer session in
minutes. If left empty, the session is set to the default of fifteen minutes.

Online Customers Options

5. When complete, click the Save Config button.

http://merch.docs.magento.com/ee/user_guide/Magento_Enterprise_Edition_User_Guide.html#configuration/customers/customer-configuration.html%23Online_Customers_Options
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To view online customers:

1. On the Admin menu, select Customers > Online Customers.

2. In the list, click any record to open the customer information.

The Personal Information section shows the customer’s current online status, and the date,
time and location of the most recent session.

Customer Information
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Update a Shopping Cart
To begin an assisted shopping session, the customer must be logged into the account
dashboard, to make the information available. If the customer doesn’t have an account, you
can create one. What service!

Customer is Online

To offer assisted shopping:

1. On the Admin menu, select Customers > Manage Customers.

2. In the list, click to open the customer record in edit mode. To find a customer record in a
hurry, enter the customer name in the filter control, and click the Search button.

Find Customer Record

When the customer record opens, the first thing you'll notice is that the Last Logged In
value is “(Online).”

3. In the panel on the left, select Shopping Cart.
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4. Click Manage Shopping Cart to enter assisted shopping mode. Then, do any of the
following:

Manage Shopping Cart

To apply a coupon code:

1. In the Apply Coupon Code section, enter the code.

2. Click the Apply button.

To adjust the quantity ordered:

1. In the Qty column of the product to be adjusted, enter the correct amount.

2. Click the Update Items and Qty's button.
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Apply Coupon and Update Qty

To add products to the shopping cart:

1. Click to expand the Products section. In the Qty to Add column, enter the quantity of the
product the customer wants to order.

2. If the product is configurable, click the Configure link. Then, select the options the
customer wants, and click the OK button.

Configure Product Options

To add a product by SKU:

1. Click to expand the Add to Shopping Cart by SKU section.

2. Enter the SKU and Qty to be ordered.



CHAPTER 49:  Assisted Shopping Update a Shopping Cart

To upload multiple products by SKU:

1. Click the Choose File button. The file must contain only the columns "sku" and "qty" in
the header.

2. Select the file to be uploaded from your directory.

Upload SKUs

To transfer products from a wishlist:

1. Click to expand the Wishlist section.

2. By default, it is set to transfer all items in the wishlist. If there are multiple items, select
the checkbox of the items that you do not want to transfer, and set Qty to Add to 0.

Add to Cart from Wishlist

Customer service reps can remove items from a cart by setting the quantity to 0 and
updating the cart. However, only the customer can move items from the cart to the
wishlist or to the product compare list.

3. Follow the same procedure to add items from the remaining sections:

l Products in Comparison List

l Recently Compared Products

l Recently Viewed Products

l Last ordered items

4. When complete, click the Add Selected Products to the Shopping Cart button.

5. Ask the customer to press F5 to refresh the page, so the products appear in the cart.

At this point, the customer can continue shopping and checkout unassisted, or have the
customer service representative create the order.

6. To create an order, click the Create Order button, and follow the normal process to create
an order for the customer.
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Create an Order
For registered customers who need assistance, you can create an entire order directly from
the Admin. The form includes all the information that is needed to complete the checkout
process, along with activity summaries from the customer’s account.

Step 1: Initiate the Order

For existing customers, new orders can be created from the Manage Customer and Sales
Order pages. You can also open new accounts for customers from the Sales Order page.

Method 1: Create Order from Existing Account

1. On the Admin menu, select Customers > Manage Customers. Find the customer in the
list, and open the record in edit mode.

2. Click the Create Order button, and do the following:

a. Complete the order information as you would when going through checkout.

b. To add products from Current Activities, find the product in the list and click the Add
to Order checkbox. Then, click the Update Changes button.

c. To add products from the catalog, click the Add Products link. Then, select the
checkbox of each product to be added, and the Qty to be purchased.

d. If the product has multiple options, click the Configure button. Complete the options
as needed, and click the OK button. Then, click the Add Selected Product(s) to Order
link to update the cart.

e. To override the price of an item, select the Custom Price checkbox. Then, enter the
new price in the box below. Click the Update Items and Qty’s button to update the
cart totals.

f. Complete the following sections, as needed for the order:

l Apply Coupon Codes

l Gift Cards

l Payment Method

l Shipping Method

g. In the Order Comments section, enter any comments that you want to accompany the
order. To include the comments in the email notification that is sent to the customer,
click the Order Comments button.

h. The Email Order Confirmation checkbox is selected by default. If you don’t want to
send an email confirmation to the customer, clear the checkbox.

3. When complete, click the Submit Order button.
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Method 2: Create Order from Sales

1. On the Admin menu, select Sales > Orders.

2. Click the Create New Order button.

3. Do one of the following:

l For registered customers, find the customer in the list and click to open the record.

l For unregistered customers, click the Create New Customer button.

4. Complete the order information as you would if going through the checkout process. For a
new customer account, complete the following sections:

l Account Information

l Billing Address

l Shipping Address

Step 2: Add Products to the Order

Products can be added to the order by selecting each item from the catalog, or by
transferring the information from a previous order, the customer’s wishlist, recently viewed
products, or other activities.

1. Click to the Add Products button.

2. Click the Reset Filter button to list all products. Then, use the filter controls as needed to
find the products to be added. Then, click the Search button.

3. Select the checkbox of each product to be added to the cart. If applicable, enter the Qty to
be purchased.

If the product has multiple options, click the Configure link. Complete the options as
needed and click the OK button.

4. Click the Add Selected Product(s) to Shopping Cart button to update the cart. The
content of the cart appears in the Items Ordered section.

5. To override the price of an item, select the Custom Price checkbox. Then, enter the new
price in the box below. Click the Update Items and Qty’s button to update the cart totals.

6. Complete the following sections, as needed:

l Apply Coupon Codes

l Gift Cards

l Payment Method

l Shipping Method

7. When complete, click the Submit Order button.
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Update anOrder
After a customer has placed an order, it is sometimes necessary to edit the order, place it
on hold, or cancel the order entirely.

When you make changes to an order, the original order is canceled and a new order is
generated. You can, however, make changes to the billing or shipping address without
generating a new order.

To edit an order:

1. On the Admin menu, select Sales > Orders.

2. Select the pending order that you want to edit.

3. Click the Edit button at the top of the screen. When prompted, click OK to continue.

4. Make the necessary changes to the order. For example:

l To change the billing address, click Edit in the Billing Address section, and change the
address.

l To change the shipping address, click Edit in the Shipping Address section, and change
the address.

5. When complete, do one of the following:

l Click Save to save changes made to the billing or shipping address.

l Click Submit Order to save changes, and reprocess the order.

To add gift options:

1. On the Admin menu, select Sales > Orders.

2. Click to open the pending order. Then, click the Edit button at the top of the screen. When
prompted, click OK to continue.

3. In the Items Ordered section, click the Gift Options link for the item you want to edit.
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Adding Gift Options

4. Complete the gift options, and click the OK button.

To place an order on hold:

If the customer’s preferred method of payment is not available, or if the item is temporarily
out of stock, you can put the order on hold.

1. On the Admin menu, select Sales > Orders.

2. In the list, find the pending order that you want to place on hold. Then, click the View
button.

3. Click Hold to place the order on hold.

To return the order to an active state, repeat the process and click Unhold.

To cancel an order:

Canceling an order removes it from the list of pending orders.

1. On the Admin menu, select Sales > Orders.

2. Find the pending order to cancel, and click the Edit link at the end of the row.

3. In the upper-right corner, click the Cancel button to remove this order.
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Order by SKU
Both customers and store administrators can add products to shopping carts and orders by
specifying SKU numbers. Customers can use the Order by SKU widget, or order by SKU
from their accounts.

Order by SKU Widget

To order by SKU from the store:

1. In the Order by SKU block, enter the SKU number and Qty you want to order.

2. To add another item, click the Add Row button.

3. Click the Add to Cart button.

Order by SKUConfiguration
You can set up Order by SKU to be available to everyone, or to only specific customer
groups.

To enable Order by SKU in customer accounts:

1. On the Admin menu, select System> Configuration. Then in the panel on the left, under
Sales, select Sales. Then, click to expand the Order by SKU Settings section.

Order by SKU Settings

2. In the upper-left corner, set the Current Configuration Scope to your website.

3. Set Enable Order by SKU in my Account on Frontend to one of the following:

http://merch.docs.magento.com/ee/user_guide/Magento_Enterprise_Edition_User_Guide.html#configuration/sales/sales.html%23Order_by_SKU_Settings
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Yes, for Everyone The Order by SKU tab appears on the My Account page for all
logged in customers.

Yes, for Specified
Customer Groups

The field for specifying Customer Group(s) appears once you
select the option. The Order by SKU tab appears on the My
Account page only for logged in customers who belong to the
specified Customer Group(s).

No The Order by SKU tab does not appear in the customer
account.

4. When complete, click the Save Config button.

Order by SKU

735Magento Enterprise Edition User Guide, Version 1.14.2.1



Order by SKU CHAPTER 49:  Assisted Shopping

736 Magento Enterprise Edition User Guide, Version 1.14.2.1

Order by SKU from Admin
From the Admin, Order by SKU is always available and does not require configuration. An
administrator can specify individual SKU values or load a .csv file with a list of SKUs.
Products can be added by SKUs from Create New Order and the Shopping Cart.

Items Ordered

To add products by SKU to an order:

1. On the Admin menu, select Sales > Orders. In the list, click to open the order in edit
mode.

2. At the top of the order, click the Edit button.

3. In the Items Ordered section, click the Add Products by SKU button.

4. Click Add Products by SKU button. Then, do the following:

5. In the Add to Order by SKU section, use either of the following methods:

Method 1: Enter Products Individually

1. Enter the SKU and Qty of the item to be ordered.

2. To add another, click the Add button.

Method 2: Upload Products from a CSV File

1. Prepare a csv file with the order data. The file can be created in a spreadsheet with the
columns “sku” and “qty.” Then, save the data as a csv file.

2. Click the Choose File button. Then, select the csv file that you prepared with the
order data.

3. When complete, click the Add to Order button.

To add products by SKU to a shopping cart:

1. On the Admin menu, select Customers > Manage Customers.

2. Find the customer in the list, and click to open the record in edit mode.

3. Click the Manage Shopping Cart button.
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4. Click to expand the Add to Shopping Cart by SKU section. Then, follow the same process
to add the items to the cart.

Add to Shopping Cart by SKU

UploadOrders by SKU
To upload order data by SKU, the header row must contain “sku” and “qty.” Any other
columns are ignored. Then, save the data as a .csv file.

Order by SKU Data to Upload

Files with SKUs are processed according the following rules:

l A row where the SKU value is empty is ignored.

l A row where the SKU value is not empty, and the QTY value is empty, invalid, or equal
to “0,” is processed and the corresponding product is placed in the “Products requiring
attention” section.
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Troubleshooting
If some products cannot be added on any reason (out of stock, require configuring, or some
other reason), then they are listed in a separate section as “Products requiring attention.”
The problem might be as simple as mistake in the SKU. Correct the problem, and try to
add the products again. If product addition fails again, the products still remain listed in
the Products Requiring Attention section. You can continue with the order or shopping cart
assistance. The Products Requiring Attention section is stored for the duration of the
session. If you delete the failed products listed, the section disappears.

The following conditions might prevent a product from being added successfully. The
corresponding SKUs appear in the “Products requiring attention” section.

l A product is composite (a product of configurable, grouped, bundle, gift card types or a
product with custom options). These products can be added after configuring them.

l No product with a specified SKU is found in the catalog. The product cannot be added.

l A product is assigned to another website. The product cannot be added.

l A product is disabled or out of stock (in this case a product cannot be added to a
shopping cart, but can be added to an order).
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Create a Customer Account
Customers usually create their own accounts from your store. However, you can also create
customer accounts directly from the Admin, which is useful when customers order by
phone.

To create a new customer account:

1. On the Admin menu, select Customers > Manage Customers.

2. Click the Add New button.

3. In the Associate to Website list, select one of the following:

l Admin

l Main Website

You can associate a customer with the Admin website to require that orders are placed only
from the store Admin. Customers associated with the Admin website cannot log in to their
accounts from the store.

4. Assign the customer to a Customer Group.

5. Complete the remaining customer information.

Account Information
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6. In the Password Management section, do one of the following

l Manually assign a password.

l Select the Send auto-generated password checkbox. The new password is generated
after the customer information is saved.

Password Management

7. When complete, click the Save Customer button.

To add a new address to a customer account:

1. On the Admin menu, select Customers > Manage Customers. Then, click to open the
customer record.

2. In the panel on the left, select Addresses. Then, do the following:

a. To add a new address, click the Add New Address and complete the information.

b. To assign a Default Address check either the Default Billing Address or Default
Shipping Address as needed.

3. When complete, click the Save Customer button.
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FIELD DESCRIPTION

Associate toWebsite Identifies the website associated with the customer account.

Group Identifies the customer group to which the customer belongs.
Select the checkbox to disable automatic group change based on
VAT.

Prefix If used, the prefix that is associated with the customers name.
For example: Mr, Mrs. or Dr.

First Name The customer's first name.

Middle Name / Initial The customer's middle name ormiddle initial.

Last Name The customer's last name.

Suffix If used, the suffix that is associated with the customer's name.
For example: Jr.,Sr., or III.

Email The customer's email address.

Date of Birth The customer's date of birth.

Tax / VAT Number The customer's Tax or Value Added Tax number, if applicable.

Gender Identifies the customer's gender as Male or Female.

SendWelcome Email Select the checkbox if you want the system to send the
customer a welcome email message.

Send From If you havemultiple stores, select the store from which the
welcomemessage will be sent.

Field Descriptions
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Update a Customer Account
The panel on the left of the Customer Information page includes information about
customer activity, such as when the customer last logged in and out, addresses, order
statistics, recent orders, shopping cart contents, product reviews, newsletter subscriptions,
and so on.

Customer Information
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To view customer information:

1. On the Admin menu, select Customers > Manage Customers.

The Manage Customers page lists all customers who have opened an account with your
store or were added by the administrator .

Manage Customers Page

2. Click the Edit link to open a customer record.
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Manage Customer Activities
The Customer's Current Activities section of the sales order gives you a snapshot of items
in the shopping cart, wishlists, gift registries, as well as other activities.

l Wishlists

l Gift Options

l Gift Registries

l Reward Points

l Invitations

Wishlists
From the Admin, the items from all customer wishlists appear on all pages where Wishlist
items are usually available, such as when creating a new order or managing shopping cart
pages. The detail from all existing wishes is included, even if multiple wishlists are
disabled.

Wishlist Items in Customer Order
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Gift Options
Gift options can be added to orders that are created from the Admin. When creating the
order, the gift options for each order item can be added using the Gift Options link
displayed under product name in the Items Ordered block. When you click the link, a pop-
up window opens, where gift wrapping and/or a gift message can be added. If gift
wrapping is selected for a product, its price is displayed under the product name.

Gift options for the entire order are available in the Gift Options block of the Create New
Order page. The gift wrapping and the printed card prices for the order and separate items
are represented as individual lines in the order totals.

Gift options from original orders are not preserved for reorders.

Gift Registries
The store administrator has access to gift registry records to monitor them, make changes,
share gift registries, or delete them by request of the gift registry owner. You can add items
from the shopping cart to a gift registry while the customer is on the phone.

Manage Customer Gift Registry
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To view a customer’s gift registry:

1. On the Admin menu, select Customers > Manage Customers. Then in the list, click to
open the customer record.

2. In the panel on the left, select Gift Registry.

3. Click the gift registry you want to see.

To manage items in a customer’s gift registry:

1. From the customer's gift registry list, click to open the gift registry you want to manage.

2. To add items from the customer’s shopping cart, do the following:

a. In the Shopping Cart Items section, locate the item that is to be added to the gift
registry, and select the checkbox.

b. Set the Actions control to “Add to Gift Registry.” Then, click the Submit button.

Shopping Cart Items

3. To change quantities in the gift registry, enter the new quantity in the Gift Registry Items
section, and click the Update Items and Qtys button.

Gift Registry Items

4. To delete an item do the following:

a. Make either of the following changes:

l Set Requested Quantity to zero.

l In the list of gift registry items, set the Actions control to “Remove Item.”

b. Click the Update Items and Qty's button.
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To share a customer’s gift registry:

1. From the customer's gift registry list, click to open the gift registry you want to manage.

2. In the Sharing Information section, do the following:

a. In the Emails field, enter the email addresses provided by the gift registry owner.
Separate each email address with a comma.

b. Set Send From to the store view that is used to send email invitations to gift registry
participants.

c. (Optional) Enter a Message to include in the standard email that is sent to gift
registry participants.

Gift Registry Sharing Information

3. When complete, click the Share Gift Registry button.

Recipients will receive an email invitation with a link to the gift registry.

To delete a customer’s gift registry:

1. From the customer's gift registry list, click to open the gift registry you want to manage.

2. Click the Delete Registry button to permanently delete the gift registry.

Important! This action cannot be reversed.
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Reward Points
Reward point balances can be managed by admin users per customer. If enabled for the
storefront, customers can view the details of their points balance from the Reward Points
tab in their account dashboard. It displays the balance, current exchange rate, maximum
and minimum limits, subscription status (with ability to edit), and (if enabled) balance
history. There is also a link to the Rewards Points landing page.

To apply reward points to a customer balance:

1. On the Admin menu, select Customers > Manage Customers.

2. Click to open the customer record. Then, in the panel on the left, select Reward Points.

From this view, the admin user can view and edit (add to or subtract from) the customer’s
points balance per website, and edit the customer’s email notification status. Additionally,
this view includes a detailed history of each accrual, redemption, and expiration of points,
including timestamp, exchange rate, and reason for balance change.

Invitations
Invitations can be associated with private sales and events, and are designed to invite
people to register for an account with your store. From the Admin, you can view invitations
and send new ones, as well. If a recipient responds to the invitation and opens an account,
the customer is assigned to the referring customer group.

The status of each invitation, the date sent, and the related customer group is shown. If an
invitation is sent to multiple recipients, a separate record is created for each.

Manage Invitations
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To create a new invitation:

1. On the Admin menu, select Customers > Invitations.

2. In the upper-right corner, click the Add Invitations link. Then, do the following:

a. In the first box, Enter Each Email on a New Line. There is no limit to the number of
recipients.

b. In the Message box, enter the text of the message.

Invitation Information

3. Set Send From to the store view that is associated with the event.

4. Set Invitee Group to the customer group that is associated with the event. The customer
group of the person who is putting on the event is typically assigned to any invitee who
opens an account with the store.

This setting overrides the invitation configuration. If the invitee email address is already
associated with a store account, but assigned to a different customer group, the invitation
will not be sent. To learn more, see Event Invitation Configuration.

5. When complete, click the Save button.

The invitation is sent and the record appears in the Manage Invitations list.
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To resend invitations:

1. In the Manage Invitations list, select the checkbox of each invitation that you want to
resend.

2. Set the Actions control to "Send Selected."

3. Click the Submit button.

To view past invitations:

1. Click to open any record in the Manage Invitations list.

View Invitation

2. To view the page that is linked to the invitation, click the Invitation URL link.
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Invitation Page

To view the invitation history:

In the panel on the left, select Status History.

Status History
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Persistent Shopping Cart
A persistent shopping cart keeps track of unpurchased items which are left in the cart, and
saves the information for the customer’s next visit. Customers who are “remembered” can
have the contents of their shopping carts restored the next time they visit your store.

Using a persistent shopping cart can help reduce the number of abandoned shopping carts
and increase sales. It is important to understand that the persistent shopping cart does not
expose sensitive account information at any time. While the persistent shopping cart is
use, both registered customers and guest shoppers are required to either log in to an
existing account or create a new account before going through checkout. For guest
shoppers, a persistent shopping cart is the only way to retrieve information from a previous
session.

Types of Cookies
To use the persistent shopping cart, the customer’s browser must be set to allow cookies.
During operation, the following cookies are used:

Session Cookie

A short-term session cookie exists for the duration of a single visit to your site,
and expires when the customer leaves, or after a set period of time.

Persistent Cookie

A long-term persistent cookie continues in existence after the end of the
session, and saves a record of the customers’ shopping contents for future
reference.
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Persistent Cart Workflow
When Persistent Shopping Cart is enabled, the workflow depends on the values of the
“Enable Remember Me” and “Clear Persistence on Log Out” settings, the customer’s
decision to select or clear the “Remember Me” checkbox, and when the persistent cookie is
cleared.

When a persistent cookie is applied, a Not %Jane Smith%? link appears in the page header,
to give the customer the ability to terminate the persistent session and start working as a
guest, or log in as a different customer. The system retains a record of the shopping cart
contents, even if the customer later uses different devices to shop in your store. For
example, a customer can add an item to the shopping cart from a laptop, edit the cart
contents from a desktop computer, add more items from a mobile device, and complete the
checkout process from a tablet.

There is a separate independent persistent cookie for each browser. If the customer uses
multiple browsers while visiting your store during a single, persistent session, any changes
made in one browser will be reflected in any other browser when the page is refreshed.
While the persistent shopping cart is enabled, your store creates and maintains a separate
persistent cookie for each browser that is used by a customer to log in or create an account.

An Open Session on a Shared Computer

Jane is finishing up her holiday shopping with a persistent session, and adds a present for
John to her cart, as well as something for her mother. Then she goes to the kitchen for
somemilk and cookies.

John sits down at the computer to do some quick shopping while Jane’s in the kitchen.
Without noticing the “Not %Jane%” link at the top of the page, he finds a nice present for
Jane and adds it to the cart. When he goes to checkout and logs in as himself, both the
items in Jane’s cart are added to his cart. John’s in such a hurry that he doesn’t notice the
additional item during Order Review, and submits the order. Jane’s cart is now empty,
and John bought presents for both Jane and her mother.

Jane brings John somemilk and cookies, and asks, “What’s up?” He says, “Oh, nothing.”
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Remember Me
The “Remember Me” checkbox on the Login page lets customers choose to save the contents
of their shopping carts.

Yes If “RememberMe” is selected, a persistent
cookie is created, and the contents of the
shopping cart is saved for the customer’s next
logged-in session.

No If “RememberMe” is not selected or cleared, a
persistent cookie is not created, and the shopping
cart information is not saved for the next
customer’s logged-in session.

Continue Persistence After Logout (No)

No When the customer logs in, the persistent cookie
is invoked, in addition to the session cookie
which is already in use.

No When the customer logs out, the session cookie
is deleted, but the persistent cookie remains in
effect. The next time the customer logs in, the
cart items will be restored, or added to any new
items which have been placed in the cart.

No If the customer does not log out, but the session
cookie expires, the persistent cookie remains in
effect.

Clear Persistence on Logout (Yes)

Yes When the customer logs in, the persistent cookie
is invoked, in addition to the session cookie
which is already in use.

Yes When the customer logs out, both cookies are
deleted.

Yes If the customer does not log out, but the session
cookie expires, the persistent cookie remains in
effect.
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SETTINGS EFFECT

Enable RememberMe = “No”
Clear Persistence on LogOut = any
value

The Rememberme checkbox is not available on the
login and registration page. The persistent cookie is not
used.

Enable RememberMe = “Yes”
Clear Persistence on LogOut = any
value
RememberMe (not selected)

The session cookie is applied as usual; the persistent
cookie is not used.

Enable RememberMe = “Yes”
Clear Persistence on LogOut =
“Yes”
RememberMe = “Yes”

When a customer logs in, both cookies are applied.
When a customer logs out, both cookies are deleted. If
a customer does not log in, but the session cookie
expires, the persistent cookie is still used. Apart from
logging out, the persistent cookie is deleted when its
lifetime runs out or when the customer clicks the Not
%Jane Smith% link.

Enable RememberMe = “Yes”
Clear Persistence on LogOut = “No”
RememberMe = “Yes”

When a customer logs in, both cookies are applied.
When a customer logs out, the session cookie is
deleted, the persistent session continues. The
persistent cookie is deleted when its lifetime runs out or
when the customer clicks the Not %Jane Smith% link.

Setting Combinations
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Persistent Cart Configuration
During the setup of a persistent shopping cart, you can specify the lifetime of the cookies,
and which options you want to make available for various customer activities.

To set up a persistent shopping cart:

1. On the Admin menu, select System > Configuration.

2. In the panel on the left, under Customers, select Persistent Shopping Cart. Then, click to
expand the General Options section.

3. To enable the persistent shopping cart and to display additional configuration options, set
Enable Persistence to “Yes.”

General Options

4. Do the following:

a. Set Persistence Lifetime (seconds) to the length of time that you want the persistent
cookie to last. The default value 31,536,000 seconds is equal to one year, and is the
maximum time allowed.

b. Set Enable “Remember Me” to one of the following:

Yes Displays the “Remember Me” checkbox on the Login page of your store,
so customers can choose to save their shopping cart information.

No Persistence can still be enabled, but customers are not given the option
to choose if they want to save their information.

c. To preselect the “Remember Me” checkbox, set Remember Me Default Value to “Yes.”
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d. Set Clear Persistence on Log Out to one of the following:

Yes Clears the cart when a registered customer logs out.

No Saves the cart when a registered customer logs out.

If the session cookie expires while the customer is still logged in, the persistent cookie
remains in use.

e. Set Persist Shopping Cart to one of the following:

Yes If the session cookie expires, the persistent cookie is preserved. If a guest
shopper later logs in or creates a new account, the shopping cart is
restored.

No The shopping cart is not preserved after the session cookie expires.

f. Enter your preference for the following persistence settings:

l Wishlist

l Recently Ordered Items

l Currently Compared Products

l Comparison History

l Recently Viewed Products

l Customer Group Membership and Segmentation

5. When complete, click the Save Config button.

757Magento Enterprise Edition User Guide, Version 1.14.2.1



Persistent Shopping Cart CHAPTER 49:  Assisted Shopping

Notes

758 Magento Enterprise Edition User Guide, Version 1.14.2.1



759Magento Enterprise Edition User Guide, Version 1.14.2.1

CHAPTER 50:

Order Fulfillment
When an order is placed, a sales order is created as a temporary record of the
transaction. In the Orders list, sales orders are shown with a status of "Pending," and
can be canceled at any time until the payment is processed. After payment confirmed,
the order can be invoiced and shipped.

Topics in this chapter:

l Order Workflow

l Order Status

l Invoice an Order

l Ship an Order

l Archive Orders

Place Order
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Order Workflow

Order Workflow
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Order Status
All orders have an order status that is associated with a stage in the order processing
workflow. You can see the status of an order by clicking the control at the top of the Status
column.

Order Status

Your store has a set of predefined order status and order state settings. The state describes
the position of an order in the workflow.

ORDER STATUS ORDER STATE

Canceled
Canceled Ogone
Closed
Complete
DeclinedOgone
OnHold
Payment Review
Pending
Pending Ogone
Pending Payment
Pending PayPal
ProcessedOgone Payment
Processing
Processing Ogone Payment
Suspected Fraud
Waiting Authorization

New
Pending Payment
Processing
Complete
Closed
Canceled
OnHold
Payment Review
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Custom Order Status
In addition to the preset order status values, you can create custom order status values of
your own, assign order statuses to order states, and set a default order status for order
states. For example, you might need a custom order status for orders, such as “packaging”
or “backordered,” or for a status that is specific to your needs. You can create a descriptive
name for the custom status, and assign it to the associated order state in the workflow.

Only default custom order status values are used in the order workflow. Custom status values
that are not set as default are available only in the comments section of the order.

List of Order Statuses

To create a custom order status:

1. On the Admin menu, select System > Order Statuses.

2. In the upper-right corner, click the Create New Status button.

3. In the Order Status Information section, do the following:

a. Enter a Status Code. This value is for internal use only. The first character must be a
letter (a-z), and the rest can be any combination of letters and numbers (0-9). You can
use the underscore character instead of a space.

b. Enter a Status Label to identify the status setting in both the Admin and store.

4. In the Store View Specific Labels section, enter any labels that you need for different store
views and languages.

5. When complete, click the Save Status button.

The new order status now appears in the Order Statuses list.
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To assign an order status to a state:

1. On the Order Statuses page, click the Assign Status to State button.

2. In the Assignment Information section, do the following:

a. Select the Order Status that you want to assign. They are listed by status label.

b. Select the Order State that represents where the order status belongs in the workflow.

c. To make this status the default for the order state, select the Use Order Status as
Default checkbox.

Assign Status to State

3. When complete, click the Save Status Assignment button.

To edit an existing order status:

1. On the Order Statuses page, click to open the status record in edit mode.

2. Update the status labels as needed.

3. When complete, click the Save Status button.

To remove an order status from an assigned state:

1. On the Order Statuses page, find the order status record that you want to unassign.

2. In the Action column on the far right of the row, click the Unassign link.

A message appears at the top of the workspace that the order status has been unassigned.
Although the order status label still appears in the list, it is no longer assigned to a state.
Order statuses cannot be deleted.

A status cannot be unassigned from a state if the status is currently in use. An error message
similar to the following appears: Status "Test" cannot be unassigned. It is used in 3 payment
method configuration(s): Check / Money order [Admin, Main Website, Private SalesWebsite]

763Magento Enterprise Edition User Guide, Version 1.14.2.1



Invoice an Order CHAPTER 50:  Order Fulfillment

764 Magento Enterprise Edition User Guide, Version 1.14.2.1

Invoice an Order
An invoice is a record of the receipt of payment for an order. Creating an invoice for an
order converts the temporary sales order into a permanent record of the order, which
cannot be canceled. A new invoice page looks similar to a completed order page, with some
additional fields that can be edited. Every activity that is related to an order is noted in the
Comments section of the invoice.

Multiple invoices can be created for a single order, and each can include as many or as few
of the purchased products that you specify. Invoices can be generated for a single order, or
for a batch of orders. The payment method determines which invoicing options can be used
for the order. For payment methods with Payment Action set to “Authorize and Capture,”
the Invoice button does not appear.

Before an invoice can be printed, the invoice must first be generated for the order. To view
or print the PDF, you must have a PDF reader. You can download Adobe Reader at no
charge.

To invoice an order:

1. On the Admin menu, select Sales > Orders.

2. In the Status column of the row with the Pending order, click View.

3. Click the Invoice button and scroll down to the Shipping Information if you would like to
add a tracking number.

4. Click the Add Tracking Number button and do the following:

a. Select a shipping Carrier.

b. The Title is entered automatically when you select the carrier. You can edit the title, if
needed.

c. Enter the Tracking Number for the order.

5. If your items are ready to ship, select the Create Shipment checkbox to also create a
packing slip for the shipment.

6. Under the Invoice History menu, in the Invoice Comments section, complete the comments
as needed. Then, in the Invoice Totals section, select the Append Comments checkbox to
add the comments to the invoice.

7. Select the Email Copy of Invoice checkbox to send a copy of the invoice to your customer.

8. Do one of the following:

http://www.adobe.com/products/reader.html
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l Click the Submit Invoice button to process the invoice and capture the sale.

l If your store requires that you ship before invoicing, click the Ship button, complete the
shipping information and submit your shipment. When that is complete, finish the
invoicing steps.

To print an invoice:

1. On the Admin menu, select Sales > Invoices.

2. In the Invoices list, find the invoice that you want to print. Click the checkbox in the first
column to select the invoice. To print multiple invoices, check the checkbox of each invoice
to be printed.

3. In the Actions list box, select PDF Invoices. Then, click the Submit button to generate the
PDF and display the document in a new window.

4. To view the invoice from the Invoice list, click the View link on the far right of the row. To
print the invoice, click the Print button.

5. After the file has been downloaded and saved to your computer, you can open and print
the document with Adobe Reader.

PAYMENT ACTION DESCRIPTION

Capture Online Upon invoice submission, the system captures the payment
from the third-party payment gateway. You have the ability to
create a credit memo and void the invoice.

Capture Offline Upon invoice submission, the system does not capture the
payment. It is assumed that the payment is captured directly
through the gateway, and you no longer have the option to
capture this payment throughMagento. You have the ability to
create a credit memo, but you do not have the option to void the
invoice. (Even though the order used an online payment, the
invoice is essentially an offline invoice.)

Not Capture When the invoice is submitted, the system does not capture the
payment. It is assumed that you will capture the payment
throughMagento at a later date. There is a Capture button in the
completed invoice. Before capturing, you are able to cancel the
invoice. After capturing you are able to create a credit memo and
void the invoice.

Payment Actions

Do not use “Not Capture” unless you are certain that the payment will be captured by Magento
at a later date. You do not get paid until the payment is captured.
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Ship an Order
The invoice for a single order, or for a batch of orders, can be generated from the Admin.
However, some payment methods generate the invoice automatically when payment is
authorized and captured. The payment method determines which invoicing options can be
used for the order.

The shipment record contains a detailed history of the fulfillment process associated with
the order. Partial shipments can be made until the order is fulfilled.

You can easily create shipping labels for new and existing orders from the Admin of your
store. To create shipping labels, you must first set up your shipping carrier account to
support labels. To learn more, see: Shipping Labels.

To generate an invoice with packing slip:

1. On the Admin menu, select Sales > Orders.

2. In the Orders list, select the checkbox of the order to be invoiced. Then, do the following:

a. In the Action column, click View.

b. In the upper-right corner, click the Invoice button. The new invoice page looks similar
to a completed order page, with additional fields that can be edited.

The Invoice button does not appear for orders placed with the “Authorize and Capture”
payment action.

3. If the items are ready to ship, you can create a packing slip for the shipment at the same
time you create the invoice. To create a packing slip, do the following:

a. Select the Create Shipment checkbox in the Shipping Information section.

b. To include a tracking number, click the Add Tracking Number button and enter the
Carrier, Title, and Number.

c. In the Items to Invoice section, you can specify if the invoice is for the entire order, or
for specific items or quantities.

4. If an online payment method was used for the order, select the appropriate option from the
Amount list box.

5. To notify customers by email when an invoice is generated, do the following:

a. Select the Email Copy of Invoice checkbox.

b. Enter any comments you would like to include in the Invoice Comments field. To
include the comments in the notification email, select the Append Comments
checkbox.
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c. To send a copy of the invoice email to yourself, enter your email address in the Send
Invoice Email Copy To field. The status of an invoice email appears next to the
invoice number of the completed invoice as either sent or not sent.

6. When complete, click the Submit Invoice button at the bottom of the page. The status of
the order changes from "Pending" to "Complete."

To view the shipment detail:

1. On the Admin menu, select Sales > Shipments.

2. Find the shipment in the list, and click to open the record.

Packing Slips
A packing slip is a sales document that accompanies shipments sent from your store, and
lists each item included in the package. You can print a packing slip for a single order, or
print multiple packing slips as a batch, or group. However, before a packing slip can be
printed, it must first be created for the order.

Packing Slip

To view or print the PDF, you must have a PDF reader. You can download Adobe Reader at no
charge.
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To print packing slips:

1. On the Admin menu, select Sales > Shipments.

Method 1: Print Single Packing Slip from Shipment

1. In the Shipments list, open the record that needs a packing slip.

2. In the upper-right corner of the shipment page, click the Print button. Look for the
download indicator in the lower-left corner of your browser window.

Method 2: Print Multiple Packing Slips

1. In the Shipments list, select the checkbox of each shipment record that needs a
packing slip.

2. In the upper-right corner, set the Actions control to “PDFpackingslips” and click the
Submit button.

Printing Multiple Packing Slips

2. Do one of the following:

l To save the document, click the Save button. Then, follow the prompts to save the file
to your computer.When the download is complete, open the PDF in Adobe Reader, and
print the document.

l To view the document in Adobe Reader, click the Open button. From here, you can
either print the packing slip or save it to your computer.
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Archive Orders
Your store can be configured to archive orders, invoices, shipments, and credit memos after
a set number of days. Archiving orders on a regular basis improved performance and keeps
your workspace free of unnecessary information, so you can focus on current orders.
Invoices, shipments, and credit memos are archived separately from orders, and can be
accessed any time. You can move orders and their associated documents to the archive, or
restore them to their previous state. Archived orders are not deleted and are still available
from the Admin. Archives can also be exported to a CSV file and opened in Excel. When
enabled, the “Archive” command appears in the Sales menu.

Orders, Invoices, Shipments, Credit Memos Archiving

To configure the order archive:

1. On the Admin menu, select System > Configuration.

2. In the Configuration panel on the left, under Sales, select Sales.

3. Click to expand the Orders, Invoices, Shipments, Credit Memos Archiving section. Then,
follow the steps below.

a. Set Enabling Archiving to “Yes.”

If you later decide to turn archiving off, all archived orders will be restored to the previous
state.

b. Set Archive Orders Purchased to the number of days to wait before an order is
archived. By default, this waiting period is set to thirty days.

c. In the Order Statuses to be Archive list, select the order status settings you want to
use to identify the orders to be archived. To select multiple items, hold the Ctrl key
down and click each item. Repeat to deselect any item.

4. When finished, click Save Config to save the changes.
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To view the archives:

1. On the Admin menu, select Sales > Archive. This option is available only when archiving
is enabled. Then, click to open any of the following archives:

l Orders

l Invoices

l Shipments

l Credit Memos

2. Inspect all archived documents from the list on the archives page. You can also click to
open any of the archived document. You can also select multiple documents, and apply
any of the following actions:

l Cancel

l Hold

l Unhold

l Print

l Move to Orders Management

To manually archive documents:

1. On the Admin menu, select Sales. Then, select the type of document you want to archive
from the following:

l Orders

l Invoices

l Shipments

l Credit Memos

2. In the list, select the checkbox of each item you want to archive.

3. In the upper-right corner, set Actions to “Move to Archive.”

4. Click Submit to archive the selected documents.
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To restore archived documents:

1. On the Admin menu, select Sales > Archive. Then, select the type of document you want
to restore.

2. To select all visible documents, in the upper-left corner, click Select Visible. Otherwise,
manually select the checkbox of each document you want to restore.

3. In the upper-right, set Action to “Move to Orders Management.”

4. Click the Submit button to restore the documents.

To export archives to CSV/Excel:

1. On the Admin menu, select Sales > Archive, then, select the type of document you want
to export.

2. In the upper-right menu, set Export to: to one of the following:

l CSV

l Excel

3. Click the Export button to export the archive.
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CHAPTER 51:

Return Merchandise Authorization
A return merchandise authorization (RMA) is granted to the purchaser of a product
who has requested to return it for a refund or replacement. Typically the customer
contacts the merchant to request a refund. If approved, a unique RMA number is
assigned to identify the returned product. In the configuration, you can either enable
RMA for all products, or allow RMA for only certain products.

RMAs can be issued for Simple, Grouped, Configurable, and Bundle product types.
However, RMAs are not available for virtual products, downloadable products, and gift
cards.

Topics in this chapter:

l RMA Workflow

l RMA Configuration

l Managing RMA Requests

l Guest RMA Requests

l Return Shipments

l RMA Item Attributes
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RMA Workflow
1. A customer requests an RMA. Logged in customers and guests can request RMAs. You can

also make a request for an RMA from the Admin.

2. After considering the request, you can authorize it partially, completely, or cancel the
request. If you authorize the return and agree to pay for the return shipment, you can
create a shipment order with a supported carrier from the Admin.

3. The customer returns the merchandise.

4. You receive and approve the return partially or completely, or cancel.

RMA Workflow
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RMA Configuration
RMA requests are always available from the Admin, unless they has been disabled in the
configuration. Customers can submit requests for RMAs only if it is set up in the
configuration.

Availability for RMA for separate items can be configured using the Enable RMA system
attribute. This system attribute is available for simple, grouped, configurable, and bundle
products.

The Enable RMA attribute is available on the General tab of the product view. By default, it
is set to Use Config and configuration settings are applied. If you set it to No, the product
will not appear in the list of items available for return, in both frontend and backend
returns. Changes to the Enable RMA attribute apply to products in existing orders, as well.

Enable RMA for Product

To configure RMAs:

1. On the Admin menu, select System > Configuration.

2. In the upper-left corner, set Current Configuration Scope to the website where the
configuration applies.

3. In the panel on the left, under Sales, select Sales.

4. Click to expand the RMA Settings section.

RMA Settings

5. Complete the fields as described below.

6. When complete, click the Save Config button.

If all items in the order are configured as not available for return, an RMA cannot be created for
the order from either the store or Admin.

775Magento Enterprise Edition User Guide, Version 1.14.2.1

http://merch.docs.magento.com/ee/user_guide/Magento_Enterprise_Edition_User_Guide.html#configuration/sales/sales.html%23RMA_Settings


RMA Configuration CHAPTER 51:  Return Merchandise Authorization

776 Magento Enterprise Edition User Guide, Version 1.14.2.1

RMAEmail Configuration
You can configure Magento to send email notifications to a customer at different stages of
RMA processing. There are four sections to complete, but the process is essentially the
same. Enable the email, and select the sender and template for each.

To enable and configure RMA email notifications:

1. On the Admin menu, select System > Configuration.

2. If applicable, set Current Configuration Scope to the website where the configuration
applies.

3. In the panel on the left, under Sales, select Sales Emails.

4. Click to expand the RMA section, and complete the fields as needed.

RMA

5. Click to expand the RMA Authorization section, and complete the fields as needed.

RMA Authorization

6. Click to expand the RMA Admin Comments section. Then, complete the fields as needed
for email that is sent when the administrator adds a comment to an RMA.

http://merch.docs.magento.com/ee/user_guide/Magento_Enterprise_Edition_User_Guide.html#configuration/sales/sales-emails.html%23RMA
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RMA Admin Comments

7. Click to expand the RMA Customer Comments section. Then, complete the fields as
needed to configure the email that is sent when a customer adds a comment to an RMA.

RMA Customer Comments

8. When complete, click the Save Config button.
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Shipping Methods for Returns
Magento Enterprise Edition has advanced integration with UPS, USPS, DHL, and FedEx
that can be used for return products shipments. If you authorize a return, you can create a
shipment order in a shipping carrier system and print a shipping label from the RMA
management section of the Admin.

Enable for RMA

To enable shipping methods to be used for RMA:

1. On the Admin menu, select System > Configuration.

2. Set Current Configuration Scope to the applicable website.

3. In the panel on the left, under Sales, select Shipping Methods.

4. Click to expand the section for each carrier that you plan to use for RMAs. Then, do the
following:

5. Set Enabled for RMA to “Yes.”

6. When complete, click the Save Config button.

Using shipping integration requires that store addresses and shipping methods to be
configured correctly. To learn more, see: Shipping Labels.

RMA shipping expenses are not included in the Shipping reports.
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Managing RMA Requests
According to the RMA logic in Magento, you can change the status values of items in the
RMA request, and the status of the request changes correspondingly.

To ensure that RMAs work correctly, do not issue refunds without completing a corresponding
RMA request. Otherwise, the available quantities of the products might be counted incorrectly.

Manage RMA

To manage an RMA request:

1. On the Admin menu, do one of the following:

l Select Sales > RMA > Manage RMA.

l Select Sales > Orders. Open the order, and select the RMA tab.

l Select Customers > Manage Customers. Open the customer record, and select the RMA
tab.

An RMA request is placed.

2. Do one of the following:

Option 1: Reject the Return

Click the Close button on the RMA page. The RMA status is now “Closed.”
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Option 2: Approve the Return

1. In the panel on the left of the RMA page, select RMA Items. Then, do the following:

a. For the rejected items, set Status to “Denied.”

b. For the pre-approved items, specify the quantity of the product, you have preapproved
in the Authorized Qty field, and set their Status to “Authorized.”

2. When complete, click the Save button.

The status is now “Partially Authorized, ” (if there are some items in Denied or Pending
Status), or “Authorized” (if all items are authorized). In this case the options for creating
the shipping label for the back shipment appear on the General Information tab. When you
create a shipping label, the customer can print it from the RMA view page on the frontend.

At this point, the customer is expected to send the return items back to you. If you agree to
pay for the shipment, you can create a shipping label from the RMA page.

3. You receive the returned items. On the RMA Items tab of the RMA page, specify the
quantity you have received for each product, change its Status to “Return Received.” Then,
click the Save button.

The new status of the RMA request depends on the correlation between the authorized and
received quantities:

l If Returned Qty is equal to Authorized Qty for all authorized products, the RMA request
status becomes “Return Received.”

l If, for some authorized products, Returned Qty is less than Authorized Qty, the return
request status becomes “Return Partially Received.”

Now you can decide how the return can be resolved. At this point, you have the following
options:

Action Request RMA status.

Reject On the RMA page, click the Close button. The status is now “Closed.”

Approve The RMA is approved.

4. In the panel on the left of the RMA page select RMA Items. Then, do the following:

a. For the rejected items, set Status to “Denied.”

b. For the approved items, specify the quantity of the product, you have approved in the
Approved Qty field, select the way the return will be resolved in the Resolution field,
and set their Status to “Approved.”

You may need to select different resolution options for one product. For example, you
authorized the return of 10 chairs. When they arrived, you saw that they are really
damaged and you approve the return. But you have only 2 chairs left in stock, so you
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can exchange only 2 chairs, and refund the rest. In this case, you can add more lines
for the product, using Split Line link in the Action column, and then in each row set
different Approved Qty and Resolution.

5. Click the Save button. The order is now “Processed and Closed,” (if all items are either in
“Approved” or “Denied” status) or “Partially Approved” (if at least one product return was
Approved, but still there are items with Authorized status) or “Partially Rejected” (if all
returned products were rejected, but there are still products for which Returned Qty is less
than Authorized Qty).

Managing the return resolutions (refund or exchange) is not handled through an RMA.
Depending on the resolutions you have selected for the approved RMA items, you may
need to use one of the following action resolutions,

RESOLUTION DESCRIPTION

Exchange You can create a credit memo for the original order (having selected to
refund to store credit and excluded the shipping costs from the refund),
and create a new one for the exchange items.
Alternatively, if the products you send in exchange are identical to those
that were originally ordered, you can simply send the exchange products
to the customer, outside of Magento. But in this case the shipment cost
will not be included in the Shipment report in Magento.

Refund Refund Create a credit memo for the refunded items in the original order.
You need to decide whether the shipping charges for the original order
will be refunded.
You can refund the original payment method or refund to store credit.

Action Resolution
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Guest RMARequests
Magento Enterprise Edition includes a link in the footer that can be used by guests to
manage their orders and returns. The link appears in the footer only during a guest session.

To submit a request for a return:

1. In the footer of the store, click the Orders and Returns link.

Orders and Returns

2. Complete the form as follows:

l Order ID

l Billing Last Name (as it is specified in the order billing address)

l Find Order By: The possible values are Email Address and ZIP Code

l Email Address/Billing ZIP Code: Depends on the selection in the Find Order By field

Then, click the Continue button.

3. When the completed order appears, click the Return link in the upper-right corner.

Return

4. Complete the remaining information in the same way as a request made from a customer
account.
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Creating a Return Shipment
When the RMA request reaches the Authorized status, the options for creating a shipping
label for the back shipment appear on the General Information tab.

If the return shipment is managed by the customer, the tracking number (or numbers) of
the shipment to the RMA request can be added from the store. Tracking numbers that
added from the store are is visible in the Admin.

Shipping Label Workflow
When you create a shipping label, Magento connects to the shipping carrier web services,
creates a shipment order at the shipping carrier side, and receives the shipping label and
the tracking number. In the shipment order, the customer shipping address (from the
original order) is used as sender address, and the store address is used as receiver address.
The store address is taken from the RMA configuration.

Shipping labels for a single shipment can be created multiple times. When you create a
new shipping label, the old shipping label and tracking numbers are deleted and replaced
with new ones. To learn more, see: Shipping Labels.

To create a shipping label:

1. Click the Create Shipping Label button. The Packages pop-up window appears.

2. In the Packages pop-up window, do the following:

a. Select the packages and distribute shipped items between packages. The information
about packages (type, size) and its contents (which products go to which packages) is
required in order to generate a shipping label.

b. After you create the packages and click OK. Magento connects to the shipping carrier’s
web services, creates a separate shipping order in the carrier’s system for each package,
and receives the shipping labels and the tracking numbers.

If you click Cancel from the Packages window, a shipping label is not created.

After you create a shipping label for the return shipment, the customer can print it
from the RMA view page of the customer account.

To view a shipping label:

Click the Print Shipping Label button to download and view the PDF file for the shipping
label.

To view packages configuration:

Click the Show Packages button next to the Print Shipping Label button.
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RMA Item Attributes
There are four system attributes related to RMAs: Resolution, Item Condition, Reason to
Return and Other. These fields are completed by the customer who requests an RMA, and
can be later edited from the Admin. If you want customers to include other information,
you can create additional item attributes. You can also change the existing options for the
system attributes. To learn more about working with attributes, see: Managing Attributes.

Manage RMA Items Attributes

To manage RMA item attributes:

1. On the Admin menu, select Sales > RMA > RMA Item Attributes.

2. Complete the Attribute Properties as described in the Field Descriptions section below.

3. In the Frontend Properties section, do the following:

a. If you want the attribute to be included in the fields that the customer completes, set
Show on Frontend to “Yes.”

b. To determine the order in which this property is listed with others, enter a number in
the Sort Order field. A value of zero has the highest priority.

c. Unless you have a customized form, accept the Forms to Use in default value of
“Default EAV Form.”
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Attribute Properties

4. In the panel on the left, select Manage Labels / Options. Then for each store view, enter a
label to identify the field during data entry.

Manage Titles (Size, Color, etc.)

5. When complete, click the Save Attribute button.

ATTRIBUTE DESCRIPTION

Resolution The quantity of the product items that a customer wants to
return. This field does not appear for complex products with
multiple options. The customer specifies the quantity to return for
each simple product in the Item field.

Item Condition Describes the condition of the returned item. Options include:
Unopened
Opened
Damaged

Reason to Return By default, the following values are available: Options include:
Wrong Color
Wrong Size
Out of Order
Other
If Other is selected, an additional text field appears to explain the
reason for the return.

RMA System Attributes
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ATTRIBUTE DESCRIPTION

Desired Resolution Indicates the way the customer wants to resolve the situation.
Options include:
Exchange
Refund
Store Credit

RMA System Attributes (cont.)

ATTRIBUTE SCOPE DESCRIPTION

Attribute Code Global (Required) A unique identifier for internal use. The
code can include a combination of lowercase
letters (a-z) and numbers (0-9), but must begin
with a letter. The Attribute Code cannot include
any special characters or spaces, although an
underscore (_) can be used to indicate a space.

Input Type Global Determines the input type that is used for data
entry in the store. Options include:
Text Field
Text Area
Dropdown
Image File

Default Value Website The initial value that appears in the field, to assist
the customer in data entry.

Input Validation Global To perform a validation check on the data, choose
the data type that applies to the value entered in
the field. Options include:
None
Alphanumeric
Numeric Only
AlphaOnly
URL
Email

Minimum Text Length Global Determines theminimum number of characters
that can be entered in the field.

Field Descriptions
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ATTRIBUTE SCOPE DESCRIPTION

Maximum Text Length Global Determines themaximum number of characters
that can be entered in the field.

Values Required Website Determines if a valuemust be entered into the
field before the RMA request can be saved.
Options include: Yes / No

Input/Output Filter Global Options include:
None
Strip HTML Tags
Escape HTMLEntries

Field Descriptions (cont.)
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CHAPTER 52:

Store Credit & Refunds
Store credit is an amount to be restored to a customer account. Store credit can be used
by customers to pay for purchases, and by administrators as cash refunds. Gift card
balances can be credited to the customer’s account, instead of using the gift card code
for future purchases.

After an order has been paid for and invoiced, all of the order, or a portion of it, can be
refunded by issuing a credit memo. A credit memo differs from a refund because the
amount of the credit is restored to the customer’s account where it can be applied to
future purchases, rather than returned to the customer as cash. In some cases, a refund
can be given at the same time that a credit memo is issued, just as payment can be
made at the time of invoicing. The amount of store credit in a customer’s account can
be managed from Admin.

Topics in this chapter:

l Product Return Workflow

l Store Credit Setup

l Manage Customer Credit

l Paying with Store Credit

l Create Credit Memo

l Adjustment Fees



Product Return Workflow CHAPTER 52:  Store Credit & Refunds

790 Magento Enterprise Edition User Guide, Version 1.14.2.1

Product Return Workflow

Product Return Workflow



CHAPTER 52:  Store Credit & Refunds Store Credit Configuration

Store Credit Configuration
The store credit configuration control automatic refunds, the display of credit in customers’
accounts, and the templates used for transactional email related to credit.updates.

Store Credit Options

To set up store credit:

1. On the Admin menu, select System > Configuration. In the panel on the left, under
Customers, select Customer Configuration.

2. Click to expand the Store Credit Options section.

3. Complete the setting as needed, as described below.

4. When complete, click Save Config button.
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Manage Customer Credit
The store administrator can view and edit the credit balance of a customer at any time.

Customer Store Credit

Store Credit Balance
The first section on this page shows the current credit balance. If customer accounts are
shared on the global level, this section will show the customer's balance for each website.

Store Credit Balance

Update Balance
The second section enables you to update the balance of the customer. The Update Balance
field is where the change in balance should be entered. The amount here can be positive or
negative, and will add to or subtract from the existing balance, respectively.

If customer accounts are shared across multiple websites, select the scope of the balance to
be updated. Additionally, there is a checkbox that enables you to send the Store Credit
Update email to the customer, notifying them of the balance change. Clear the checkbox
and select the Store View to determine from which store view the email will be sent.
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Balance History
The third section shows the balance history, timestamp, a description of the action, and
the balance change. For some actions there is additional information available, such as the
order number on which store credit was applied. You can use the sort and filter controls to
find records, and apply actions to any credit record in the list.

Balance History

Pay with Store Credit
The customer must be logged in during checkout to pay with store credit. During the
Payment Information step of the checkout process, a “Use Store Credit” checkbox appears
above the payment methods, with the balance in parentheses. If the available balance is
greater than the order grand total, the enabled payment methods disappear when the
checkbox is selected. During Order Review, the amount of store credit applied to the order
appears with the order totals, and is subtracted from the grand total. The customer’s store
credit balance is adjusted when the order is placed.

Orders paid with store credit cannot be refunded. Credit memos will not be available. To
refund such an order, it must be canceled and the balance manually increased in the
customer’s account. If an order is partially paid with store credit, the amount paid with
store credit cannot be refunded. Again, the amount must be manually be added to the
customer’s account.

To view a credit balance:

1. On the Admin menu, select Customers > Manage Customers.

2. In the list, click to open a customer record in edit mode.

3. In the panel on the left, select Store Credit.

To refund to store credit:

On the New Credit Memo page, enter either a full or partial amount of the refund to be
applied to the customer’s store credit.
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Create a Credit Memo
A credit memo is a document that lists the amount that is owed to the customer. The
amount can be applied toward a purchase, or refunded to the customer. You can print a
credit memo for a single order, or for multiple orders as a batch, or group. Before a credit
memo can be printed, it must first be generated for the order.

Credit Memo

To create a credit memo:

1. On the Admin menu, select Sales > Orders.

2. Find the order in the list, and click to open the order.

3. In the upper right corner, click the Credit Memo button. (The button appears only if an
invoice has been generated for the order.)

The New Credit Memo page looks similar to the completed order page, with an Items to
Refund section that lists each item from the invoice.

If an online payment method was used, you will not be able to edit these fields.

4. If the Stock Options configuration is set to “Decrease Stock When Order is Placed,” do one
of the following:

l If the product is to be returned to inventory, select the Return to Stock checkbox.

l If the product will not be returned to inventory, leave the checkbox blank.

The Return to Stock checkbox appears only if inventory Stock Options is set to “Decrease
Stock When Order Is Placed.”
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Return to Stock

5. Complete the following:

a. In the Qty to Refund box, type the number of items to be returned and press the Enter
key to record the change. The Update Qty’s button appears. Make sure to set the Qty
to Refund of any items not to be refunded to zero.

b. Click the Update Qty’s button to recalculate the total. (The amount to be credited
cannot exceed the maximum quantity that is available for refund.)

c. In the Refund Totals section, complete the following options, as applicable:

Refund Shipping Enter the amount to be refunded from the shipping fee. This field
initially displays the total shipping amount from the order that is
available for refund. It is equal to the full Shipping Amount from the
order minus the Shipping Refund, which is the amount that has
already been refunded. Like the quantity, the amount can be
reduced, but not increased.

Make sure to set Items to Refund Qty to zero to refund only the
shipping amount. If you skip this, the entire order will be refunded.

Adjustment Refund Enter a value to be added to the total amount refunded as an
additional refund that does not apply to any particular part of the
order (shipping, items, or tax). The amount entered cannot raise the
Total Refund higher than the Paid Amount.

Adjustment Fee Enter a value to be subtracted from the total amount refunded. This
amount is not subtracted from a specific section of the order such
as shipping, items, or tax.

6. In the Refund Totals section, do the following:
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a. If the purchase was made using store credit, select the Refund to Store Credit
checkbox, to credit the amount back to the customer’s account balance.

b. To add a comment, type the text in the Credit Memo Comments box.

c. To send an email notification to the customer, select the Email Copy of Credit Memo
checkbox.

d. If you want to include the comments you have entered, check the Append Comments
checkbox.

e. To receive a copy of the credit memo notification, enter your email address in the
Send Invoice Email Copy To field.

The status of a credit memo notification appears in the completed credit memo next to
the credit memo number.

Refund Totals

7. To complete the process and generate the credit memo, select one of the following refund
option buttons, depending on the capabilities of the payment gateway:

RefundOffline If the payment gateway does not support online refunds, the store
administrator must log in to the gateway merchant account and transfer
the funds to the customer account.

RefundOnline If the payment gateway supports online refunds, the amount will be
automatically credited to the customer account.
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To print a credit memo:

To view or print the PDF, you must have a PDF reader. You can download Adobe Reader at
no charge.

1. On the Admin menu, select Sales > Credit Memos.

Selected Credit Memo with Action

2. In the Credit Memo list, find the credit memo(s) that you want to print. Then, do one of
the following:

l In the list of shipments, click the View link at the right of the credit memo record. Then,
click the Print button to print the PDF document.

l To print a single credit memo, click to select the checkbox in the first column of the row.

l To print multiple credit memos, select the checkbox for each to be printed.

3. In the Credit Memo list, set the Actions list to “PDF Credit Memos” and click the Submit
button.

4. When prompted, do one of the following:

l To save the document, click Save. Then, follow the prompts to save the file to your
computer.When the download is complete, open the PDF in Adobe Reader, and print
the document.

l To view the document, click Open. The printed-ready PDF credit memo opens in Adobe
Reader. From here, you can either print the credit memo or save it to your hard disk.
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Credit Memo

Adjustment Fees
When you create a credit memo for a partial order, the refund for the gift wrapping and/or
gift option is included to the first credit memo created for the order. To exclude these costs
from the amount to be refunded, the total of these costs should be specified in the
Adjustment Fee field located above the Grand Total value in the credit memo.

Adjustment Fee
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CHAPTER 53:

Sales Document Setup
Your store generates invoices, packing slips, and credit memos in both HTML and PDF
formats. Before your store goes live, make sure to update these documents with your
logo and store address. You can customize the address format, and also include the
Order ID for reference.

Topics in this chapter:

l Logo Requirements

l Adding Reference IDs

l PDF Invoice with High-Resolution Logo
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PDF Logo Requirements
The logo that appears on PDF print-outs can be a high-resolution, 300 dpi image, but must
be a specific size. However, the size of the logo that appears in the HTML print view version
of sales documents is determined by your theme.

One way to resize your logo to fit the required size is to create a new, blank image with the
correct dimensions.Then, paste your logo image and resize it to fit the height. With most
image editing programs, you can preserve the aspect ratio by holding down the shift key as
you resize the image. The following image is a 200px by 50px .png file with a transparent
background, (represented by the checkerboard pattern). The same image is used for the
high-resolution image on the PDF invoice, but is saved as a 300 dpi jpg.

To set up your sales documents:

1. On the Admin menu, select System > Configuration.

2. In the panel on the left, under Sales, select Sales.

3. Click to expand the Invoice and Packing Slip Design section, and do the following:

Invoice and Packing Slip Design
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a. To upload the Logo for PDF Print-outs, click the Browse button. Then, select the logo
that you have prepared and click Open. The path to the file appears in the text box.

b. To upload the Logo for HTML Print View, click the Browse button. Then, select the
logo that you have prepared and click Open. The path to the file appears in the text
box.

4. Enter your address as you want it to appear on invoices and packing slips.

5. When complete, click the Save Config button.

For reference, a small and slightly distorted version of the uploaded image appears before
each field.

To replace an image:

1. Click the Browse button and select the new logo.

2. Select the Delete Image checkbox for the image you want to replace.

3. Click the Save Config button.

FORMAT REQUIREMENTS

PDF

File Format jpg (jpeg), png, tif (tiff)

Image Size 200 pixels wide x 50 pixels high

Resolution 300 dpi recommended

HTML

File Format jpg (jpeg), png,gif

Image Size Determined by theme.

Resolution 72 or 96 dpi

Image Formats
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Add Reference IDs to Header
The order ID and customer IP address can be included in the header of sales documents
that accompany an order. Follow the instructions below to include either, or both of these
identifiers for reference in the header of invoices, shipment packing slips, and credit
memos.

To show the Order ID:

1. On the Admin menu, select System > Configuration.

2. In the Configuration panel on the left, under Sales, select PDF Print-outs.

3. To include the order ID in the header of each document, click to expand each section. Then,
set Display Order ID in Header to “Yes” for each of the following:

l Invoice

l Shipment

l Credit Memo

4. When complete, click the Save Config button.

PDF Print-outs
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To show the customer IP address:

1. On the Admin menu, select System > Configuration.

2. In the panel on the left, under Sales, select Sales.

3. Click to expand the General section.

4. To show the IP address of the computer that was used to place the order, set Hide
Customer IP to “No.”

General

5. When complete, click the Save Config button.
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PDF Invoice with High-Resolution Logo
This print-ready invoice has a high-resolution, 300 dpi logo that reproduces well with the
text on the page.

PDF Invoice with High-Resolution Logo
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Basic Payment Methods

PayPal Payment Solutions

Magento Secure Payment Bridge
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Payment Services
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CHAPTER 54:

Basic Payment Methods
Magento Enterprise Edition supports a wide variety of payment methods, services, and
gateways that you can offer for your customers’ convenience. In addition to the
payment methods in this guide, other solutions can be downloaded from Magento
Connect.

Topics in this chapter:

l Merchant Location

l Bank Transfer Payment

l Cash On Delivery

l Check / Money Order

l Purchase Order

l Zero Subtotal Checkout

l Saved Credit Card
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Merchant Location
Setting the merchant location is the first step to configure any payment method.

To set the merchant location country:

1. On the Admin menu, select System > Configuration.

2. In the panel on the left, under Sales, select Payment Methods.

3. In the upper-right corner, set Current Configuration Scope as needed.

4. In the Merchant Location section, set Merchant Country to your country.

Merchant Location

5. When complete, click the Save Config button.

Bank Transfer Payment
Magento Enterprise Edition lets you accept payments transferred directly from customers’
bank accounts to your merchant bank account.

Bank Transfer Payment
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To set up bank transfer payments:

1. On the Admin menu, select System > Configuration.

2. In the panel on the left, under Sales, select Payment Methods. Click to expand the Bank
Transfer Payment section. Then, do the following:

a. To activate this payment method, set Enabled to “Yes.”

b. Enter a Title to identify this payment method during checkout.

c. Set New Order Status to “Pending” until payment is authorized.

d. Set Payment from Applicable Countries to one of the following:

All Allowed
Countries

Customers from all countries specified in your store
configuration can use this payment method.

Specific Countries Select each country in the Payment from Specific Countries list
where customers can make purchases from your store.

e. Enter the Instructions your customers must follow to set up a bank transfer.
Depending on the country where your bank is located and your bank’s requirements,
you might need to include the following information:

l Bank account name

l Bank account number

l Bank routing code

l Bank name

l Bank address

f. Set Minimum Order Total and Maximum Order Total to the amounts required to
qualify to use this payment method.

An order qualifies if the total falls between, or exactly matches, the minimum or maximum
total values.

3. Enter a Sort Order number to determine the position of Bank Transfer in the list of
payment methods during checkout. (0 = first, 1 = second, 2 = third, and so on.)

4. When finished, click the Save Config button.
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Cash On Delivery
Magento Enterprise Edition allows you to accept COD payments from your customers.
With a cash on delivery payment, the customer pays at the time of delivery. The customer
pays the order amount to the shipping carrier, who sends a check to you. Shipping carriers
typically charge an extra fee for COD service. You can account for this fee in your shipping
and handling charges.

Cash On Delivery Payment

To set up cash on delivery payments:

1. On the Admin menu, select System > Configuration.

2. In the panel on the left, under Sales, select Payment Methods. Click to expand the Cash on
Delivery Payments section. Then, do the following:

a. To activate this payment method, set Enabled to “Yes.”

b. Enter a Title to identify this payment method during checkout.

c. Set New Order Status to “Pending” until receipt of payment is confirmed.

d. Set Payment from Applicable Countries to one of the following:

All Allowed
Countries

Customers from all countries specified in your store
configuration can use this payment method.

Specific Countries Select each country in the Payment from Specific Countries list
where customers can make purchases from your store.
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e. Enter Instructions for making a Cash On Delivery payment.

f. Set Minimum Order Total and Maximum Order Total to the order amounts which are
required to qualify for this payment method.

An order qualifies if the total is between, or matches, the minimum or maximum order total.

g. Enter a Sort Order number to determine the sequence in which Cash On Delivery is
listed with other payment methods during checkout. (0 = first, 1 = second, 2 = third,
and so on.)

3. When complete, click the Save Config button.

Check / Money Order
Magento Enterprise Edition allows you to accept payments by either check or money order.
The Check / Money Order payment method is enabled for your story by default.

Check / Money Order

To set up payment by check or money order:

1. On the Admin menu, select System > Configuration.

2. In the panel on the left, under Sales, select Payment Methods. Click to expand Check /
Money Order, and do the following:
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a. To activate this payment method, set Enabled to “Yes.”

b. Enter a Title to identify this payment method during checkout.

c. Set New Order Status to "Pending” until receipt of payment is confirmed.

d. Set Payment from Applicable Countries to one of the following:

All Allowed
Countries

Customers from all countries specified in your store
configuration can use this payment method.

Specific Countries Select each country in the Payment from Specific Countries list
where customers can make purchases from your store.

e. In the Make Check Payable To field, enter the name of the party to whom the check
must be payable.

f. In the Send Check To field, enter the street address where the checks are mailed.

g. Set Minimum Order Total and Maximum Order Total to the order amounts required to
qualify for this payment method.

An order qualifies if the total falls between, or exactly matches, the minimum or maximum
total values.

h. Enter a Sort Order number to determine the position of Check / Money Order in the
list of payment methods that is shown during checkout. (0 = first, 1 = second, 2 =
third, and so on.)

3. When finished, click the Save Config button.
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Purchase Order
A purchase order (PO) allows commercial customers to pay for purchases with prior
authorization by referencing the PO number. During checkout, the customer is prompted to
enter the purchase order number as the method of payment.

Customers who are representatives of other companies can use the Magento Purchase Order
payment method to buy products and assign a corresponding purchase order number
generated in their accounting system to the sales order generated in Magento.

For example, your customer represents the company that sells computers and needs to buy
some monitors from your store. In their accounting system, the customer creates a
purchase order which is assigned a unique PO number. The customer places an order in
your store using the Purchase Order payment method and references the PO number from
their accounting system. All order-related documents, including the order confirmation
email, invoice, shipment, and credit memo, will have the PO number on them. The
company accounting department can now reference the PO number entered on the Magento
sales order so that they can track the order.

When the customer receives your invoice, they process the payment in their accounts
payable system. You should always establish the credit worthiness of a customer before
accepting payment by purchase order.

Purchase Order
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To set up payment by purchase order:

1. On the Admin menu, select System > Configuration.

2. In the panel on the left, under Sales, select Payment Methods. Click to expand the
Purchase Order section. Then, do the following:

a. To activate this payment method, set Enabled to “Yes.”

b. Enter a Title to identify this payment method during checkout.

c. Set New Order Status to “Pending” until payment is authorized.

d. Set Payment from Applicable Countries to one of the following:

All Allowed
Countries

Customers from all countries specified in your store
configuration can use this payment method.

Specific Countries Select each country in the Payment from Specific Countries list
where customers can make purchases from your store.

e. Set Minimum Order Total and Maximum Order Total to the amounts required to
qualify for this payment method.

An order qualifies if the total falls between, or exactly matches, the minimum or maximum
total values.

f. Enter a Sort Order number to determine the position of Purchase Order in the list of
payment methods during checkout. (0 = first, 1 = second, 2 = third, and so on.)

3. When finished, click the Save Config button.
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Zero Subtotal Checkout
Zero Subtotal Checkout is only available for orders created from the Admin, and can be
used for orders with a subtotal of zero. This situation might occur when a discount covers
the entire price of the purchase, and there is no additional charge for shipping. To save
time, these orders can be set to invoice automatically.

Unlike other payment methods for which you can set order amount filters, this method
contains an intrinsic order amount filter, so that the method appears only when the
subtotal equals zero. Zero Subtotal Checkout can be used when:

l The product that the customer adds to the shopping cart is of the Downloadable or the
Virtual product type and its price equals zero.

l The price of a simple product is zero and the Free Shipping method is available.

l A coupon code that covers the full price of products and shipping is applied in the
shopping cart.

l A gift card is applied to the shopping cart and it fully covers the order amount including
shipping. During the checkout of an order covered by a gift card, the customer will still
have to select the "No Information Required" payment method in the Payment
Information section of the Checkout page.

The payment method is available if taxes are configured so that they are applied to the
products in the shopping cart after the discount is applied.
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To set up Zero Subtotal Checkout:

1. On the Admin menu, select System > Configuration.

2. In the panel on the left, under Sales, select Payment Methods. Click to expand the Zero
Subtotal Checkout section. Then, do the following:

Zero Subtotal Checkout

a. Enter a Title to identify this payment method during checkout.

b. Set Enabled to “Yes” to activate this payment method.

c. Set New Order Status to one of the following:

Pending (Default) The order is waiting for authorization.

Processing Payment has been authorized, and the transaction is being
processed.

d. Set Automatically Invoice All Items to “Yes” if you want to automatically invoice all
items with a zero balance.

e. Set Payment from Applicable Countries to one of the following:

All Allowed
Countries

Customers from all countries specified in your store
configuration can use this payment method.

Specific Countries Select each country in the Payment from Specific Countries list
where customers can make purchases from your store.

f. Enter a Sort Order number to determine the position of Zero Subtotal Checkout in the
list of payment methods during checkout. (0 = first, 1 = second, 2 = third, and so on.)

3. When finished, click the Save Config button.
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Saved Credit Cards
This option enables you to take credit cards and to process them offline. This method is
useful when you have a card terminal in a brick and mortar store or have access to a virtual
terminal. This payment method is enabled by default in the sample data. When accepting
payment by credit card, make sure that you have an active security certificate for your
store.

Important! Saving customer card data is discouraged unless absolutely necessary. Even
though the data is encrypted it still poses a security risk to hold this information. The Saved
Credit Cards payment method is not PCI compliant.

Saved CC

To set up the Saved Credit Cards:

1. On the Admin menu, select System > Configuration.

2. In the panel on the left under Sales, select Payment Methods.

3. In the upper-right corner, set Current Configuration Scope to the applicable website or
store view for the configuration.

4. Click to expand the Saved CC section.

5. Complete each field in this section, using the following field descriptions for reference.

6. When complete, click the Save Config button.
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Notes
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CHAPTER 55:

PayPal Payment Solutions
PayPal is a global leader in online payments and a fast and secure way for your
customers to pay online. With PayPal and Magento Enterprise Edition, you can accept
payments from all major debit and credit cards, and PayPal account holders. Since
customers don’t even need a PayPal account to pay with PayPal, both you and your
customers can get extra convenience without extra effort.

The PayPal payment methods that are available in Magento, and the method names,
are different depending on merchant location. For country-specific PayPal methods, see
the list at the end of this chapter. The two PayPal payment methods that can be used
all over the world are Express Checkout and PayPal Payments Standard.

PayPal payment methods are mutually exclusive, with the exception of PayPal Express
Checkout. You cannot have more than one method enabled at a time. PayPal Express
Checkout can be used with other PayPal payment methods except PayPal Payments
Standard. PayPal Payments Standard cannot be enabled simultaneously with any other
method, including Express Checkout.
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PayPal Express Checkout
With PayPal Express Checkout enabled, customers can click the “Checkout with PayPal”
button to make a secure payment from the PayPal site. You can use Express Checkout as a
standalone solution, or in combination with one of the other solutions.

All-In-One Solutions
PayPal offers a variety of PCI-compliant solutions to meet the needs of your growing
business.

PayPal Payments Advanced

(Includes Express Checkout) PayPal Payments Advanced offers your customers a secure
checkout experience without leaving your site. Flexible templates and a low monthly fee
make this an ideal choice for merchants who want to create a more customized checkout
experience.

PayPal Payments Pro

PayPal Payments Pro brings you all the benefits of a merchant account and payment
gateway in one, plus the ability to create your own, fully customized checkout experience.

l PayPal Payments Pro Hosted Solution (Includes Express Checkout)

l PayPal Payments Pro Payflow Edition (Includes Express Checkout) (UK only)

PayPal Payments Standard

PayPal Payments Standard is the easiest way to accept payments online. You can offer
your customers the convenience of payment by credit card and PayPal by simply adding a
checkout button to your site. During checkout, customers are redirected to PayPal to
complete the payment part of the checkout process. There are no lengthy applications to
complete, or monthly charges to set up in advance. When you make your first sale, PayPal
will guide you through the process of setting up your account.

Payment Gateways
PayPal offers a choice of two payment gateway solutions for your business. You can let
PayPal host your checkout on its secure payment site, or you can take control of the entire
payment experience with a completely customizable solution.

PayPal Payflow Pro

PayPal Payflow Pro is a fully customizable payment gateway that can be used with any
Internet merchant account to process credit card transactions online. Payflow Pro can also
be used to process PayPal Express Checkout transactions.
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PayPal Payflow Link

PayPal Payflow Link is a hosted payment gateway with an embedded checkout that keeps
customers on your site. It’s the fast and easy way to add transaction processing to your
site.

PayPal Access Card
The PayPal Access Card is like a debit card that can be used to spend or withdraw money
from the PayPal balance of the cardholder. It can be used to make purchases online, or
anywhere else that MasterCard is accepted. It’s like having your PayPal account in your
wallet.

PayPal Access also streamlines the process of opening an account with your store. When
customers with PayPal Access register with your store, their address and contact
information is read directly from their PayPal account.

PayPal Business Account
PayPal payment methods that are integrated with Magento require the merchant to have a
PayPal business account and/or a PayPal Payflow account. The type of PayPal account that
is required is specified in the description of each method.

Customers who make purchases using Express Checkout and the Express Checkout for
Payflow Pro must have buyer accounts with PayPal to pay for their purchases. PayPal
Payments Standard (and Website Payments Standard) can work either directly or through a
buyer account, if the PayPal Account Optional parameter is enabled in the Premier or
Business account of the merchant. By default, this parameter is enabled and customers can
choose to enter their credit card information and the billing and shipping addresses and
pay the order amount, or to create a buyer account with PayPal and then pay the order
amount. When the parameter is disabled, the customer must create a buyer account with
PayPal before paying for the order.

Website Payments Pro, Website Payments Pro Payflow Edition, Payflow Pro Gateway, and
Payflow Link require the customer to enter credit card information during checkout.
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PayPal Payments Advanced
PayPal Payments Advanced lets your customers pay by debit or credit card without leaving
your site, and includes an embedded checkout page that can be customized to create a
seamless and secure checkout experience.

Checkout Workflow
With PayPal Payments Advanced, your customer stays on your site during the checkout
process. The customer selects the PayPal Payments Advanced payment method on the
Payment Information checkout step and clicks Continue.

The Order Review step appears, with the Pay Now button, instead of the Place Order
button. After the customer clicks the Pay Now button, a PayPal-hosted form opens in the
customer’s browser. The customer specifies the card information and clicks Verify Card. If
the transaction is successful, the customer is redirected to the order confirmation page.

The form also includes the Pay with PayPal button, which redirects the customer to the PayPal
site, where payment can be made with PayPal Express Checkout.

If the transaction fails, an error message appears on the checkout page and the customer is
directed to repeat the checkout process. These issues are managed by PayPal.

Order Workflow
Processing orders with PayPal Payments Advanced is the same as processing any regular
order with PayPal. An invoice, shipment, and credit memo (online/offline refund) can be
created. Multiple online refunds are not available for the PayPal Payments Advanced
payment method.

With PayPal Payments Advanced, an order is created in the Admin when a customer clicks
the Place Order button. The order status can be any of the following, depending on the
response from PayPal:

ORDER STATUS DESCRIPTION

Processing The transaction was successful.

Pending Payment The system did not receive any response from PayPal.

Canceled The transaction was not successful for some reason.

Suspected Fraud The transaction did not pass some of the PayPal fraud filters; the
system receives the response from PayPal that the transaction
is under review by Fraud Service. Fraud filters aremanaged from
your PayPal merchant account.

https://manager.paypal.com/
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Merchant Requirements
PayPal Business Account

If youmanagemultiple Magento websites, youmust have a separate PayPal
merchant account for each.

Setting Up PayPal Payments Advanced
For step-by-step configuration instructions, see PayPal Payments Advanced in the Magento
Enterprise Editiononline user guide.

Setting Up PayPal Payments Advanced
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PayPal Payments Pro
PayPal Payments Pro brings you all the benefits of a merchant account and payment
gateway in one, plus the ability to create your own, fully customized checkout experience.
PayPal Express Checkout is automatically enabled with PayPal Payments Pro, so you can
tap into more than 110 million active PayPal users.

PayPal Payments Pro supports Magento Secure Payment Bridge, 3D Secure, Cardholder
Verification Value (CVV), and can be used to create orders directly from the Admin of your
store. Supported credit cards include Visa, MasterCard, Discover, American Express,
Switch/Maestro, and Solo.

Checkout Workflow
After customers add products to their shopping carts, they can go to checkout by clicking
the Proceed to Checkout button. In the Payment Information checkout section, they select
the PayPal Direct Payment option, and enter the credit card information.

l PayPal Payments Pro lets your customer stay on your site during the checkout process.

l PayPal Express Checkout redirects your customer to the PayPal site to complete the
transaction.

Order Workflow
If the payment action selected in the configuration is set to “Authorize,” only a sales order
of the Processing status is created in Magento. In this case, the amount of money to be
authorized is pending approval. With PayPal Payments Pro, you can process the payment
online from either the Admin of your store, or from your PayPal merchant account.

When checking out products from the shopping cart to multiple addresses simultaneously,
customers can choose to pay with Website Payments Pro.

At the customer’s request, the store administrator can also create an order from the Admin,
and place it through the Website Payments Pro payment method.

An order can be voided online at any time until the order amount is fully invoiced. If
required, the order can be partially invoiced online for a specified quantity of products. For
each partial invoice submitted through the PayPal payment system, a separate transaction
record with a unique ID and of the Capture transaction type will become available on the
Transaction tab, and a separate invoice document will be created on the Invoices tab. The
payment transaction of the type “Authorization” is closed only after the full order amount
is captured.
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When capturing the payment transaction, PayPal transfers the order amount from the
buyer’s balance, bank account or credit card to the merchant’s account. If for any reason
the customer returns the purchased products and claims a refund, as with order amount
capturing and invoice creation, you can create an online refund either from the Admin or
from your PayPal merchant account.

Make sure that instant payment notifications are enabled in your PayPal merchant account. An
invoice is created in Magento only after an instant payment notification message is delivered to
Magento from PayPal. Based on these notifications, you can receive detailed payment
information on each transaction from PayPal after you click the Fetch button on the Transaction
page of an order.

If the payment method has been set to “Sale,” both a sales order and an invoice are created.

Requirements
PayPal Business Account (with Direct Payments Activated)

Setting Up PayPal Payments Pro
For step-by-step configuration instructions, see PayPal Payments Pro in the Magento
Enterprise Edition online user guide.

Setting Up PayPal Payment Pro
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PayPal Payments Standard
For merchants outside the US, this method is called PayPal Website Payments Standard.

PayPal Payments Standard is the easiest way to accept payments online. PayPal Payments
Standard offers your customers a one-step method to pay for an order by redirecting them
to PayPal to complete the transaction. You can offer your customers the convenience of
payment both by credit card and PayPal by simply adding a checkout button to your store.
With PayPal Payments Standard, you can swipe credit cards on mobile devices. There is no
monthly fee, and you can get paid on eBay. Supported credit cards include Visa,
MasterCard, Discover, and American Express. In addition, customers can pay directly from
their personal PayPal accounts. PayPal Payments Standard is available in all countries on
the PayPal worldwide reference list.

Checkout Workflow
If you enable the PayPal Account Optional setting in your merchant Premier or Business
account, the customer can pay directly with a credit card, without requiring a PayPal
account. If you disable this setting, the customer is required to create an account with
PayPal to pay the order amount. This setting is enabled by default.

During checkout, the customer is redirected to the PayPal site to complete the transaction.
PayPal Payments Standard is a one-step process for customers whose credit card
information is up-to-date in their personal PayPal accounts. All the customer needs to do
is click the “Pay Now” button to complete the purchase.

Merchant Requirements
PayPal Business Account

https://www.paypal.com/webapps/mpp/how-to-sell-online
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Setting Up PayPal Payments Standard

PayPal Payments Standard cannot be enabled simultaneously with any other PayPal method,
including Express Checkout. If you change payment solutions, the one you used previously is
disabled.

For step-by-step configuration instructions, see PayPal Payments Standard in the online
user guide.

Setting Up PayPal Payments Standard
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PayPal Express Checkout
PayPal Express Checkout helps boost sales by giving your customers the ability to pay by
credit card or from the security of their personal PayPal accounts. During checkout, the
customer is redirected to the secure PayPal site to complete the payment information. The
customer is then returned to your store to complete the remainder of the checkout process.
Choosing Express Checkout adds the familiar PayPal button to your store, which has been
reported to increase sales.

You can have two PayPal solutions active at the same time: Express Checkout, plus any All-In-
One solution. If you enable a different solution, the one used previously is deactivated.

Check out with PayPal

Customer Workflow
Customers with current PayPal accounts can make a purchase in a single step, by clicking
the “Check out with PayPal” button. Express Checkout can be added as a standalone, or
added to an existing PayPal solution. If you already accept credit cards online, you can
offer Express Checkout as an additional option to attract new customers who prefer to pay
with PayPal. PayPal Express Checkout can be used as a standalone, or in combination with
one of PayPal’s All-In-One solutions.

With Express Checkout, the customer is redirected to the PayPal site to complete the
transaction. Unlike other payment methods, PayPal Express Checkout allows the customer
to check out at the beginning of the usual checkout workflow.

With PayPal Express Checkout enabled, the “Check out with PayPal” button appears on the
product page, and in the shopping cart and mini shopping cart. Clicking the button
redirects the customer to the PayPal website to review the purchase information.
Customers must log in to their PayPal accounts to complete the transaction. The payment
system uses the customer’s billing and shipping information from the customer’s PayPal
account. The customer is then redirected back to the Magento Review Order page.
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Alternatively, if you have set up your PayPal Express Checkout Advanced settings to skip
the order review step, the customer can pay for the order on the PayPal site by clicking the
“Pay Now” button. After the customer places the order, the payment information is
submitted to PayPal and the payment transaction is settled.

If the customer uses the one-page checkout and selects the Express Checkout payment
method, the customer is redirected to PayPal during the Payment Review process, just
before the sales order is submitted.

Express Checkout is not available for orders shipped to multiple addresses.

Requirements
Merchant: Personal PayPal Account

Customer: Personal PayPal Account

Setting Up PayPal Express Checkout
For step-by-step configuration instructions, see PayPal Express Checkout in the online user
guide.

Setting Up PayPal Express Checkout
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Process Overview:
Step 1: Configure Your PayPal Account
Step 2: Complete the Required Settings
Step 3: Complete the Basic Settings
Step 4: Complete the Advanced Settings

Step 1: Configure Your PayPal Account

1. Before you begin, you must configure your PayPal merchant account on the PayPal website.

a. Log in to your PayPal Advanced account at manager.paypal.com.

b. Go to Service Settings > Hosted Checkout Pages > Set Up, and make the following
settings:

AVS No

CSC No

Enable Secure Token Yes

c. Save the settings.

2. PayPal recommends that you set up an additional user on your account. To set up an
additional user, do the following:

a. Go to manager.paypal.com and log in to your account.

b. Follow the instructions to set up an additional user.

c. Save the changes.

Step 2: Complete the Required Settings

1. On the Admin menu, select System > Configuration.

2. In the Configuration panel on the left, under Sales, select Payment Methods.

3. If your Magento installation has multiple websites, stores or views, set the Current
Configuration Scope box in the upper-left corner to the target configuration.

4. In the Merchant Location section, select the Merchant Country where your business is
located.

https://manager.paypal.com/
https://manager.paypal.com/
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Merchant Location

5. If necessary, click to expand the PayPal Express Checkout section. Then, click the
Configure button.

PayPal Express Checkout

6. Under Required PayPal Settings, in the Express Checkout section, complete the following:

a. Enter the Email Address that is associated with your PayPal merchant account.

Important! Email addresses are case sensitive. To receive payment, the email address
you enter must match the email address specified in your PayPal merchant account.

b. Set API Authentication Methods to one of the following:

l API Signature

l API Certificate

c. If necessary, click the Get Credentials from PayPal button. Then, complete the
following:

l API Username

l API Password

l API Signature

d. If you are using credentials from your sandbox account, set Sandbox Mode to “Yes.”

If necessary, click the Sandbox Credentials button and follow the instructions to set
up your testing environment.

e. If your system uses a proxy server to establish the connection between Magento and
the PayPal payment system, set API Uses Proxy to “Yes.” Then,, complete the
following:

l Proxy Host

l Proxy Port

7. When these sections are complete, set Enable this Solution to “Yes.”
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8. To offer financing through PayPal to your customers, see PayPal Credit to learn more.

You have now completed the Required PayPal Settings. At this point, you can either
continue with the Basic and Advanced Settings, or click the Save Config button. You can
return later fine-tune the configuration.

PayPal Express Checkout Required Settings

Step 3: Complete the Basic Settings

1. If your store has multiple views, make sure to set the Current Configuration Scope box in
the upper-left corner to the view where these settings apply.

2. In the Basic Settings - PayPal Express Checkout section, complete the following:

a. Enter a Title to identify this payment method during checkout. It is recommended to
set the title to “PayPal” for each store view.

b. If you offer multiple payment methods, enter a number in the Sort Order field to
determine the sequence in which PayPal Payments Standard is listed with the other
methods. Payment methods appear in ascending order based on the Sort Order value.

c. Set Payment Action to one of the following:

Authorization Approves the purchase, but puts a hold on the funds.
The amount is not withdrawn until it is “captured” by
the merchant.
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Sale The amount of the purchase is authorized and
immediately withdrawn from the customer’s account.

Order Represents an agreement between the PayPal payment
system and the merchant, which enables the merchant
to capture one or more amounts up to the “ordered”
total from the customer’s buyer account, over a
maximum of 29 days.

The amount of the order is not immediately captured
nor authorized in the customer’s balance, bank account,
or credit card at PayPal. After the funds are “ordered,”
the merchant can capture them at any time during the
following 29 days. Capturing of the order amount can
be done only from the Magento backend, by creating one
or more invoices.

d. If Payment Action is set to “Order,” complete the following fields:

Authorization Honor
Period (days)

Defines how long the primary authorization stays valid.
The value should be equal to the corresponding value in
your PayPal merchant account. The default value in
your PayPal merchant account is 3. To increase this
number you need to contact PayPal. The authorization
becomes invalid at 11:49 p.m., U.S. Pacific Time, of the
last day.

Order Valid Period (days) Defines how long the order remains valid. When the
order becomes invalid, you can no longer create invoices
for it. Specify the value equal to the Order Valid Period
value in your PayPal merchant account. The default
value in your PayPal merchant account is 29. To change
this number, you need to contact PayPal.

Number of Child
Authorizations

Defines the maximum number of authorizations for one
order; that is, the maximum number of the online
partial invoices you can create for one order. The
number in this field should be equal to the
corresponding setting in your PayPal merchant account.
The default number of child authorizations in your
PayPal account is 1. To increase this number, you need
to contact PayPal.

e. To display the “Check out with PayPal” button on the product page, set Display on
Product Details Page to “Yes.”
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PayPal Express Checkout Basic Settings

Step 4: Complete the Advanced Settings

1. At the bottom of the Basic Settings section, click to expand Advanced Settings. Then,
complete the following:

a. Set Payment Applicable From to one of the following:

All Allowed Countries Accepts payment from the countries already specified in
your configuration.

Specific Countries Accepts payments from only the countries you specify.
Hold the Ctrl key down and in the Payment Applicable
From list, click each country where you accept payment.

b. Set Debug Mode to “Yes” to write communications with the payment system into the
log file. The log file for PayPal Payments Advanced is payments_payflow_
advanced.log.

In accordance with PCI Data Security Standards, credit card information is not recorded in
the log file.

c. To enable host authenticity verification, set Enable SSL Verification to “Yes.”

d. To display a full summary of the customer’s order by line item from the PayPal site,
set Transfer Cart Line Items to “Yes.”

To include up to ten shipping options in the summary, set Transfer Shipping Options
to “Yes.” (This option appears only if line items are set to transfer.)

e. To determine the type of image used for the PayPal acceptance button, set Shortcut
Button Flavor to one of the following:

Dynamic (Recommended) Displays an image that can be
dynamically changed from the PayPal server.
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Static Displays a specific image that cannot be dynamically
changed.

f. To allow customers without PayPal accounts to make a purchases with this method,
set Enable PayPal Guest Checkout to “Yes.”

g. Set Require Customer’s Billing Address to one of the following:

Yes Requires the customer’s billing address for all
purchases.

No Does not require the customer’s billing address for any
purchases.

For Virtual Quotes Only Requires the customer’s billing address for virtual
quotes only.

h. To specify whether the customer can sign a billing agreement with your store in the
PayPal payment system when there are no active billing agreements available in the
customer account, set Billing Agreement Signup to one of the following:

Auto The customer can either sign a billing agreement during
the Express Checkout flow or use another method of
payment.

Ask Customer The customer can decide whether to sign a billing
agreement during the Express Checkout flow.

Never The customer cannot sign a billing agreement during
the Express Checkout flow.

The store owner needs to apply to PayPal Merchant Technical Support to enable billing
agreements. The Billing Agreement Signup parameter must be enabled only after PayPal
confirms that billing agreements are enabled for your merchant account.

i. To allow the customer to complete the transaction from the PayPal site without
returning to your Magento store for Order Review, set Skip Order Review Step to
“Yes.”
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PayPal Express Checkout Advanced Settings

2. Complete the following sections as needed for your store:

PayPal Billing Agreement Settings

A billing agreement is a sales agreement between the merchant and customer that has been
authorized by PayPal for use with multiple orders. During the checkout process, the Billing
Agreement payment option appears only for customers who have already entered into a
billing agreement with your company. After PayPal authorizes the agreement, the payment
system issues a unique reference ID to identify each order that is associated with the
agreement. Similar to a purchase order, there is no limit to the number of billing
agreements a customer can set up with your company.

1. To make billing agreements available to your customers, click to expand the PayPal
Billing Agreement Settings section.
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PayPal Billing Agreement Settings

2. Set Enabled to “Yes.” Then, do the following:

a. Enter a Title to identify the PayPal Billing Agreement method during checkout.

b. If you offer multiple payment methods, enter a number in the Sort Order field to
determine the sequence in which Billing Agreement appears when listed with
other payment methods during checkout.

c. Set Payment Action to one of the following:

Authorization Approves the purchase, but puts a hold on the
funds. The amount is not withdrawn until it is
“captured” by the merchant.

Sale The amount of the purchase is authorized and
immediately withdrawn from the customer’s
account.

d. Set Payment Applicable From to one of the following:

All Allowed Countries Accepts payment from the countries already
specified in your configuration.

Specific Countries Accepts payments from only the countries you
specify. Hold the Ctrl key down and in the
Payment Applicable From list, click each country
where you accept payment.

e. To record communications with the payment system in the log file, set Debug
Mode to “Yes.”

The log file is stored on the server and is accessible only to developers. In accordance
with PCI Data Security Standards, credit card information is not recorded in the log file.
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f. To enable SSL verification, set Enable SSL verification to “Yes.”

g. To display a summary of each line item in the customer’s order on your PayPal
payments page, set Transfer Cart Line Items to “Yes.”

h. To allow customers to initiate a billing agreement from the dashboard of their
customer account, set Allow in Billing Agreement Wizard to “Yes.”

Settlement Report Settings

1. Click to expand the Settlement Report Settings section.

PayPal Settlement Report Settings

2. If you have signed up for PayPal’s Secure FTP Server, enter the following SFTP login
credentials:

l Login

l Password

3. To run test reports before “going live” with Express Checkout on your site, set
Sandbox Mode to “Yes.”

4. Enter the Custom Endpoint Hostname or IP Address. By default, the value is:
reports.paypal.com

5. Enter the Custom Path where reports are saved. By default, the value is:
/ppreports/outgoing

6. To generate reports according to a schedule, under Scheduled Fetching, make the
following settings:

a. Set Enable Automatic Fetching to “Yes.”

b. Set Schedule to one of the following:
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l Daily

l Every 3 Days

l Every 7 Days

l Every 10 Days

l Every 14 Days

l Every 30 Days

l Every 40 Days

PayPal retains each report for forty-five days.

c. Set Time of Day to the hour, minute, and second when you want the reports to
be generated.

Frontend Experience Settings

The frontend experience settings give you the opportunity to choose which PayPal logos
appear on your site, and to customize the appearance of your PayPal merchant pages.

1. Click to expand the Frontend Experience Settings section.

PayPal Frontend Experience Settings

2. Select the PayPal Product Logo that you want to appear in the PayPal block in your
store. The PayPal logos are available in four styles and two sizes. Options include:

l No Logo

l We Prefer PayPal (150 x 60 or 150 x 40)

l Now Accepting PayPal (150 x 60 or 150 x 40)

l Payments by PayPal (150 x 60 or 150 x 40)

l Shop Now Using PayPal (150 x 60 or 150 x 40)

3. To customize the appearance of your PayPal merchant pages, do the following:

a. Enter the name of the Page Style that you want to apply to your PayPal
merchant pages. Options include:
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paypal Uses the PayPal page style.

primary Uses the page style that you identified as the
“primary” style in your account profile.

your_custom_value Uses a custom payment page style, which is
specified in your account profile.

b. In the Header Image URL field, enter the URL of the image that you want to
appear in the upper-left corner of the payment page. The maximum file size is
750 pixels wide by 90 pixels high.

PayPal recommends that the image be located on a secure (https) server. Otherwise,
the customer’s browser may warn that “the page contains both secure and nonsecure
items.”

c. Enter the six-character hexadecimal code, without the “#” symbol, for each of the
following:

Header Background
Color

Background color for the checkout page header.

Header Border Color 2-pixel border around the header.

Page Background Color Background color for the checkout page and
around the header and payment form.

3. When complete, click the Save Config button.

Save Customer Billing Address
The complete billing address of the customer can be saved when the customer pays with
PayPal Express Checkout. The billing address can be retrieved from PayPal, and edited by
the customer.

Billing and Shipping Address Workflow
When customers pay with PayPal Express Checkout, they are redirected to PayPal. After
logging in to PayPal and reviewing the payment information, they return to the Order
Review page of your store, where they can choose the shipping method, edit the billing and
shipping addresses, and place the order.

Alternatively, if you have set up your PayPal Express Checkout Advanced settings to skip
the order review step, the customer can pay for the order on the PayPal site by clicking the
Pay Now button.
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l If a billing address cannot be retrieved from PayPal because of the configuration, or any
other reason, the shipping address is used for the billing address on the Order Review
page. The customer can edit the address as needed.

l If a customer leaves the billing and shipping addresses without changes, the Place
Order button is enabled when the customer selects the shipping method.

The Place Order button is disabled if the customer edits the billing or shipping address.
The customer must click the Update Order Data button first. The system will update the
information, including the available shipping methods, and the Place Order button will be
enabled.

After the customer clicks Place Order, Magento creates the order, and PayPal performs the
related transaction(s). The billing and shipping addresses are saved in the order.

To save the customer billing address:
Make sure that the functionality is enabled in your PayPal merchant account. Contact
PayPal technical support for more information.

1. On the Admin menu, select System > Configuration.

2. In the panel on the left, under Sales, select Payment Methods.

3. Under PayPal Express Checkout, click the Configure link, and do the following:

a. In the Basic Settings section under Advanced Settings, Set Require Customer’s
Billing Address to “Yes.”

Advanced Settings
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b. To request the customer’s billing address only for orders with downloadable and/or
virtual products, set Require Customer’s Billing Address to “For Virtual Quotes
Only.”

4. Click the Save Config button.

ManagingOrder Transactions
Magento includes the option to use the Order payment action for PayPal Express Checkout
purchases. When a customer submits an order with the Order payment action set, the
funds on the customer’s card are authorized. If the authorization times out before you
capture the payment, the authorization is voided, and a new authorization and capture are
initiated when you create an invoice. Only the amount equal to the invoice total is
authorized and captured. The maximum number of authorizations allowed for a single
order, and the length of time that the authorization and order remain valid is determined
by your PayPal merchant account settings. These parameters must be specified in the
Magento Admin, as well. The order is captured from the Magento Admin when the invoice
is generated.

The Order transaction might be appropriate to use in the following scenarios:

l Backorders, in which available items are sent immediately, and the remaining part of
the order is sent when available; this may include more than two shipments.

l Split orders, such as when ordered items are sent in more than one shipment, perhaps
to different addresses, and you want to collect a payment for each shipment.

l Drop shipments, which are shipments from other vendors for which you accept the
payment.

Using the Order payment action does not affect the checkout process.

Payment Action Set to “Order”
When the customer submits an order using PayPal Express Checkout, with the Order
payment action set, the order (with Processing status) is created in the Admin. Two
transactions are created for the order: one with type “Order,” and one with type,
“Authorization.”

The funds on the customer’s account are put on hold, and can be captured only from the
Admin by creating an online invoice. When you create an online invoice, Magento
determines if the number of days that have passed since the first authorization exceeds the
Order Valid Period value. An online invoice cannot be created for the order if the valid
period has expired.

If the order is valid, Magento determines whether the first authorization is valid, and
compares the number of days since the Authorization Honor Period value. If the
authorization is valid, the necessary sum is captured, and the rest is left on hold. The
number of captures is not limited. The authorization is voided when no longer valid. A new
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authorization and capture are created, but for the invoice total, rather than the order total.
From this moment, each time you create an online invoice for the order, a new
authorization and capture is initiated for only the invoice total.

Also, Magento will determine whether the number of the conducted captures is equal to the
Number of Child Authorizations value each time. If the number specified there is already
reached, creating online invoices for the order will not be possible.

PayPal Credit
For US merchants, the PayPal Credit service is included as a PayPal Express Checkout
option. PayPal Credit, formerly Bill Me Later) offers your customers access to financing, so
they can buy now and pay later, at no additional cost to you. You are not charged when
customers choose PayPal Credit, and pay only your normal PayPal transaction fee.

PayPal Credit (Bill Me Later) Button

You can also use free, ready-made banner ads and display a prominent PayPal Credit
button during checkout, to remind your customers as they shop that financing is available.
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PayPal Credit Banner Sizes

According to an August 2013 Forrester Consulting study commissioned by PayPal, PayPal
Credit (Bill Me Later) can increase sales up to 18%, with about one-third resulting from the
six months’ same-as-cash payment option. To learn more, visit the PayPal site.

Before you configure PayPal Credit for your store, make sure it is enabled in your PayPal
account .

Billing Agreements
To simplify the checkout process, customers can enter into a billing agreement with PayPal,
as the payment servoce provider. During checkout, the customer chooses the billing
agreement as the payment method. The payment system verifies the billing agreement by
its unique number, and charges the customer's account. It is no longer necessary for the
customer to enter payment information for each purchase.

Customer Account Workflow
Customers can create billing agreements by signing in to their customer accounts, selecting
the billing agreement payment method, and initiating the Billing Agreement process.
When a billing agreement is created, it is submitted to the PayPal payment system and
recorded in the customer account, along with reference information. There is no limit to the
number of billing agreements a customer can create. The customer can also cancel some, or
all of the billing agreements on the Billing Agreement page of the customer account. The
status of each billing agreement is shown as either “Active” or “Canceled.” When a billing
agreement is canceled, it cannot be reactivated.

https://www.paypal.com/webapps/mpp/promotional-financing
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When checking out products from the shopping cart, a customer who has already entered
into a billing agreement with PayPal can choose the PayPal Billing Agreement payment
method in the Payment Information section of the checkout page, and select the billing
agreement reference ID from the list. When the customer places the order, the billing
agreement reference ID and sales order payment details are transferred to the PayPal
payment system. After the payment system confirms the payment, a sales order is created
in Magento.

Order Workflow
If the customer purchasing items from the web store does not yet have a billing agreement
with PayPal, she or he can choose the PayPal Express Checkout method of payment, select
the Sign a billing agreement to streamline further purchases with PayPal checkbox, and be
redirected to the PayPal payment system where the customer payment information is
available and the billing agreement can be signed. After a billing agreement with the store
is signed, the customer is redirected back to the Magento frontend, where an order is
placed. A corresponding record appears in the billing agreements list.

Additionally, the customer who has no billing agreements in the customer account can also
sign a billing agreement from the mini shopping cart or from a product view page by
clicking the Check out with PayPal button, that is, by using the PayPal Express Checkout
payment method. This opens a dialog box that gives the customer the option to sign a
billing agreement with the PayPal payment system. If the customer cancels creating a
billing agreement, the order is created through the normal PayPal payment process.

If the customer has one or more billing agreements, the customer can still create a new
billing agreement from the customer's account, but will not be able to sign a new billing
agreement using the PayPal Express Checkout payment method.

When the customer signs a billing agreement during the order checkout, PayPal creates a
payment transaction through the PayPal Express Checkout payment method selected by
the customer (that is, a sales order is created in Magento), and a billing agreement
reference ID which is sent to the customer and the store. The currently created order is not
related to the billing agreement that is signed. Related billing agreement-order records are
created in Magento the next time that the customer selects this billing agreement as a
payment method and places an order.

Sales Order Workflow
On a customer’s request, the store administrator can create a sales order and after filling in
all required information for order currency, items, billing and shipping addresses, she or he
needs to select the PayPal Billing Agreement payment method and specify the reference
number for a specific billing agreement. When the order is submitted, the billing agreement
reference ID is transferred to the PayPal payment system and, if the payment is authorized,
an order is created in Magento.
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PayPal Billing Agreement Settings

Managing Billing Agreements
Billing agreements can be managed from both the Customer and Sales sections of the
Admin menu.

Sales Management
The list of all billing agreements for all customers is available under Sales > Billing
Agreements. Here, the store administrator can filter the records by the customer or billing
agreement information including billing agreement reference ID, status, and creation date.
A specific record provides general information about the selected billing agreement and
about all sales orders that relate to it. The store administrator can view, cancel, or delete a
customer’s billing agreements in the Sales Management area. Billing agreements can be
canceled or deleted by clicking the corresponding buttons located in the upper right part of
the Billing Agreement page. An already canceled billing agreement can only be deleted by
the store administrator.

Customer Management
Billing agreements created by a single customer can be seen on the Billing Agreements tab
of the customer account page in the backend (Customers > Manage Customers). From
here, the store administrator can open a required billing agreement to view its general
information and sales orders relating to it, cancel a billing agreement, or delete it.
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Settlement Reports
The PayPal Settlement report provides the store administrator with the information about
each transaction that affects the settlement of funds.

Before generating settlement reports, the store administrator needs to contact the PayPal
Merchant Technical Services for creating an SFTP user account, enabling settlement reports
generation, and enabling SFTP at PayPal business account.

After configuring and enabling settlement reports in the PayPal merchant account, Magento
will start generating reports during the following twenty-four hours. The list of available
settlement reports can be viewed from the Admin.

To view settlement reports:

1. On the Admin menu, select Reports > Sales > PayPal Settlement Reports.

2. To fetch the most recent updates, click the Fetch Updates button in the upper-right corner.

The system connects to the PayPal SFTP server to fetch the reports. When the process is
complete, a message appears with the number of reports fetched. The report includes the
following information for each transaction:

FIELD DESCRIPTION

Report Date The date when the settlement report was generated.

Merchant Account The encryptedmerchant account number generated by PayPal.

Transaction ID The identification of a transaction of themoney moving event.
Transaction ID is generated by PayPal and cannot be changed
by themerchant.

Invoice ID The identification of an invoice generated within Magento. The
field can be populated with either an invoice ID sent with the
capture request or with the value of the invoice ID (if any) from
the authorizing transaction.

PayPal Reference ID The identification of a related, pre-existing transaction or event.

Event Code The code assigned to the transaction according to the event that
has initiated it. Among these can be website payments standard
payment, express or direct checkout API, pre-approved
payment, subscription payment, and so on.

Settlement Report
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FIELD DESCRIPTION

Initiation Date The date and time the transaction was initiated.

Completion Date The date and time the transaction was completed.

Gross Amount The amount of the payment between the two parties and before
fees.

Fee Amount The amount of fee associated with the settlement. All
transaction fees are included in this amount. Fees are never
amortized across several transactions.

Settlement Report (cont.)

FIELD DESCRIPTION

PayPal Reference ID Type One of the following reference codes:
Order ID
Transaction ID
Subscription ID

Preapproved Payment ID Options include:

Custom The text entered by themerchant
on the transaction in PayPal.

Transaction Debit or Credit The direction of money
movement of gross amount.

Fee Debit or Credit The direction of money
movement for fee.

Field Descriptions
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PayPal Payflow Pro
PayPal Payflow Pro gateway, formerly known as Verisign, is a payment method available
for customers of the USA, Canada, Australia, and New Zealand. Similar to other PayPal
payment methods that are provided in Magento, PayPal Payflow Pro Gateway requires that
the store owner have a merchant account at PayPal. The PayPal Payflow Pro gateway links
the merchant account at PayPal and the merchant’s website, and acts both as a gateway
and a merchant account. With PayPal Payflow Pro Gateway, payments are processed
directly on the merchant websites and customers are not redirected to PayPal. Unlike other
PayPal payment methods, the pricing for using the Payflow Pro Gateway method of
payment is fixed no matter how many transactions are submitted. That is, merchants pay
a fixed monthly fee plus a fixed fee for each transaction regardless of their number.

PayPal Payflow Pro does not require customers to have buyer accounts at PayPal; but
depending on the merchant country, customers may use their PayPal buyer accounts for
paying through the gateway.

Customers can enter their credit card information during checkout, without leaving the
store checkout page and without using PayPal hosted forms. Additionally, payments are
accepted through PayPal Payflow Pro at the time an order is placed.

Customer Workflow
When customers proceed to the checkout, they are required to enter their billing and/or
shipping addresses, and the shipping method. In the Payment Information section, they
can select the Payflow Pro payment method, enter the type of credit card, its number,
expiration date, and the card verification number. Customers are not redirected to the
PayPal website when they choose to pay with Payflow Pro Gateway. Depending on the
payment action selected in the configuration of the payment method, either a sales order or
a sales order and an invoice is created.

Order Workflow
Orders paid with Payflow Pro Gateway can be processed online only from Magento. Here,
you can submit an online invoice and as a result a corresponding transaction and an
invoice will be created. Regarding order amount refunds, you can also submit them online
from the created invoice.

Partial invoices are not available when using the Payflow Pro Gateway payment method. The Qty
to Invoice field is unavailable for editing. The partial refund is unavailable as well.

You can view all Payflow Pro Gateway transactions in your PayPal business account.
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PayPal Payflow Link
PayPal Payflow Link passes the card information entered by the customer to PayPal. The
information is never stored in Magento system. PayPal PayFlow Link is available for
merchants in the United States and Canada only, and requires a Payflow merchant
account. Customers are not required to have a PayPal account to use this method. PayFlow
Link cannot be used for orders created from the Admin.

Customer Workflow
The store customer selects the PayFlow Link payment method on the Payment Information
checkout step and clicks Continue. The Order Review step appears, where the Pay Now
button is available instead of the usual Place Order button. After the customer clicks Pay
Now, the PayPal-hosted form, where the credit card information can be entered, loads in
the checkout page. The customer specifies the card information and clicks Pay Now. If the
transaction is successful, the customer is redirected to the order confirmation page.

The form also contains the Cancel Payment link. Clicking it redirects the customer to the
Payment Information step of the checkout, where the payment method is selected. If the
transaction fails on any reason, an error message appears on the checkout page and the
customer is directed to repeat the checkout process. These situations are handled on the
PayPal side.

Order Workflow
Processing an order with PayFlow Link is the same as processing an order with PayPal. An
invoice, shipment, and credit memo (online/offline refund) can be created. Multiple online
refunds are not supported.

When a customer clicks the Pay Now button, an order is created with a “Pending Payment”
status. After the customer enters the card information and clicks the Pay Now button from
the PayPal site, the status of the order changes, depending on the response the system
receives from PayPal. If the customer clicks the Cancel Payment link, the order status
changes to Canceled. A new order is created when the customer proceeds to checkout.

ORDER STATUS DESCRIPTION

Processing The transaction was successful.

Pending Payment The system did not receive any response from PayPal.

Canceled The transaction was not successful for some reason.

Suspected Fraud The transaction did not pass some of the PayPal fraud filters; the
system receives the response from PayPal that the transaction
is under review by Fraud Service. Fraud filters aremanaged from
your PayPal merchant account.

https://manager.paypal.com/
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PayPal Fraud Management Filters
Magento Enterprise Edition includes support for PayPal fraud management filters (FMFs),
available for owners of Website Payments Pro PayPal accounts. It works for orders that are
paid using PayPal Express Checkout or PayPal Website Payments Pro.

PayPal FMFs make it easier for merchants to detect and respond to fraudulent
transactions. FMFs can be configured to flag, hold for review, or deny riskier payments.
Magento order status values are changed according to these settings. This section describes
the processing of suspected fraudulent orders for different filter action settings.

You can manage your fraud filters in your PayPalmerchant account.

ACTION DESCRIPTION

Review If you set the filter action to “Review,” the suspected order
receives the status ”Payment Review” when the order is placed.
You can review the order and approve, or cancel the payment in
the Admin, or on the PayPal side.
To deny the payment from the Admin, click the Deny Payment
button in the upper-right corner of the page. The order status
changes to “Canceled,” the transaction is reverted, and funds are
released on the customer’s account. The corresponding
information is added in the Comments History section of the
order view.
When you click the Accept Payment or the Deny Payment
buttons, no new transactions for the order are created.
If you change the status of the transaction on the PayPal site,
youmust click the Get Payment Update button in the upper-right
corner of the Order page in theMagento Admin to apply the
changes. If you click Accept Payment or Deny Payment, the
changes made at the PayPal site are applied.

Deny If you set the filter action to “Deny,” the suspected order cannot
be placed by the customer, because the corresponding
transaction is rejected by PayPal.

Flag If you set the filter action to “Flag,” the suspected order gets the
status ”Processing” when it is placed. The corresponding
transaction is marked with a “flag” in the list of themerchant
account transactions.

Filter Actions
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PayPal Solutions by Country
COUNTRY PAYPAL PAYMENT SOLUTION

United States PayPal Payments Advanced (Includes Express Checkout)
PayPal Payments Pro (Includes Express Checkout)
PayPal Payments Standard+
PayPal Payflow Pro (Includes Express Checkout)
PayPal Payflow Link (Includes Express Checkout)
PayPal Express Checkout

Canada PayPal Payments Pro (Includes Express Checkout)
PayPal Payments Standard
PayPal Payflow Pro
PayPal Payflow Link (Includes Express Checkout)
PayPal Express Checkout

Australia PayPal Payments Standard
PayPal Payflow Pro
PayPal Payments Pro Hosted Solution
PayPal Express Checkout

United Kingdom PayPal Express Checkout
PayPal Payments Standard
PayPal Payments Pro Payflow Edition (Includes Express
Checkout)
PayPal Payments Pro Hosted Solution

Japan PayPal Express Checkout
PayPal Payments Standard
PayPal Website Payments Plus (PayPal Payments Pro Hosted
Solution)

France PayPal Express Checkout
PayPal Payments Standard
PayPal Integral Evolution (PayPal Payments Pro Hosted
Solution)

Italy PayPal Express Checkout
PayPal Payments Standard
PayPal Pro (PayPal Payments Pro Hosted Solution)
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COUNTRY PAYPAL PAYMENT SOLUTION

Spain PayPal Express Checkout
PayPal Payments Standard
PayPal Pasarela integral (PayPal Payments Pro Hosted
Solution)

Hong Kong PayPal Express Checkout
PayPal Payments Standard
PayPal Payments Pro Hosted Solution

New Zealand PayPal Express Checkout
PayPal Payments Standard
PayPal Payflow Pro

Others PayPal Express Checkout
PayPal Payments Standard
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CHAPTER 56:

Magento Secure Payment Bridge
Magento Secure Payment Bridge is a PA-DSS certified payment application that helps
merchants meet PCI compliance. Magento Secure Payment Bridge is included with a
subscription to Magento Enterprise Edition, and is installed separately. Magento
Secure Payment Bridge is a perfect way to keep all customer-to-merchant information
interchange working via a separate PA-DSS compliant application, eliminating the need
to make your Magento installation itself PA-DSS compliant. This enables you to make
updates with new marketing, merchandising and content management features to the
core Magento eCommerce application without having to go through PCI compliance
reassessment of the entire Magento eCommerce platform.

All sensitive credit card data that is received from customers during the checkout
process is put into the token in Magento Secure Payment Bridge and is stored there,
encrypted, until the payment system returns the successful result of a payment
transaction. After the transaction is completed, the payment data within Magento
Secure Payment Bridge is cleaned from the token, which remains in the database
during a specific period of time. With Magento Payment Bridge, no sensitive credit card
data is passed over or stored in Magento, which guarantees the security of customers’
credit card data.

Topics in this chapter:

l Supported Payment Services

l Payment Bridge Setup

l Gateway Setup (When Required)

l Gateway Setup (When Optional)

l Version Comparison
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Supported Payment Services
Magento Payment Bridge supports the following payment services:

l Cardinal Centinel 3D Secure Credit Card Validation

l Kount Fraud Detection Service

Cardinal Centinel 3DSecure
Cardinal Centinel 3D Secure credit card validation can be used for the following payment
methods, if they are configured to use Magento Secure Payment Bridge:

l Authorize.Net

l PayPal Payments Pro

l PayPal Payments Pro Payflow Edition (UK only)

l PayPal Payflow Pro

Sage Pay Direct and Ogone Direct Link payment gateways use their own 3D secure credit card
validation services, which are configured during the payment gateway configuration in the
Payment Bridge application.

Cardinal Centinel 3D Secure credit card validation payment service is enabled and
configured in Magento Secure Payment Bridge. To use the service, you must first have an
account set up in the Cardinal Centinel system.
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Kount Fraud Detection Service
Kount Fraud Detection service is enabled and configured in Magento Secure Payment
Bridge. When the service is enabled, it is used for all payments managed by Payment
Bridge.

Before using Kount Fraud Detection, you must set up an account in the Kount system. The
set of rules for credit card validation is created in the Kount agent web console. For each
transaction, the Kount system sends one of the following responses about the transaction
status:

l Approve

l Review

l Escalate

l Decline

If a Review or Escalate response is received, the transaction is marked with a “Suspected
Fraud” comment in the Magento Admin Panel. This comment is displayed in the
Comments History section on the Order View page of the corresponding order, which you
can view by navigating to Sales > Orders. If Kount declines the transaction, the
corresponding order is not created in Magento and the transaction is not completed. In all
other cases the status of a transaction assigned by Kount does not influence the transaction
itself; it serves only as an indicator for the merchant.
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Payment Bridge Configuration
Before enabling the Payment Bridge functionality in the Magento backend configuration,
your Magento Payment Bridge administrator must create a merchant account and
configure payment gateways in the Magento Payment Bridge payment application. The
Magento Payment Bridge administrator provides the merchant with the merchant account
information required for the authorization by the Payment Bridge.

For each payment method that uses Payment Bridge, the configuration consists of the
following steps, which can be completed in any order:

l Enable/disable and configure the method in Payment Bridge (via SSH client). Payment
gateway credentials are required for this configuration. For more information, see the
Magento Payment Bridge PA-DSS Implementation Guide.

l Enable/disable and configure the payment method in the Magento Admin.

To enable and configure Payment Bridge:

1. On the Admin menu, select System > Configuration.

2. You can either leave Current Configuration Scope set to “Default Config,” or select your
website. It is recommended that you enable and configure Payment Bridge on the global
level if your business logic allows.

3. In the panel on the left under Sales, select Payment Methods. Click to expand the Payment
Bridge section, and do the following:

Payment Bridge

a. Set Enabled to “Yes.”

To enable Payment Bridge, it must be installed and configured with the merchant account
and required payment gateways. If you need help, contact your Magento Payment Bridge
administrator to complete the necessary configuration.

b. In the Merchant Code field, enter the merchant ID that was specified by the Magento
Payment Bridge administrator when the merchant account was created.

http://merch.docs.magento.com/ee/user_guide/Magento_Enterprise_Edition_User_Guide.html#configuration/sales/payment-methods.html%23Payment_Bridge
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After the Magento Payment Bridge administrator creates a merchant account, the
merchant code, merchant key, and data transfer key are provided to the merchant.

c. Enter the Merchant Key. The merchant key was either entered by the Magento
Payment Bridge administrator, or automatically generated by the payment application
when the merchant account was created. The merchant key is a unique code that helps
secure the connection to the Payment Bridge.

d. In the Gateway Basic URL field, enter the URL that connects to the Payment Bridge
payment application.

e. Enter the Data Transfer Key. The data transfer key was generated when the Payment
Bridge merchant account was created. The data transfer key encrypts any data that is
transferred between the merchant and Magento Payment Bridge.

f. (Default Config only) Enter the Magento Unique Identifier for the current Magento
instance. The Magento Unique Identifier field is used if there are several instances of
Magento using the same Payment Bridge merchant account.

It is essential to assign identifiers to websites that are powered by different Magento
instances and use saved payment methods, such as Authorize.Net CIM.

g. In the Debug field, specify whether data messages that are sent to the payment
system and received from it are written into the system log file.

4. When complete, click the Save Config button.

You can now configure payment methods to use Payment Bridge.

Gateway Setup (WhenRequired)
For all payment methods that work only if Magento Secure Payment Bridge is enabled and
configured, the options which should be configured in the Magento Admin are largely the
same, although the set of available options may differ. The following example shows how to
configure Braintree for Magento Secure Payment Bridge.

To enable and configure Braintree:

1. On the Admin menu, select System > Configuration.

2. In the upper-left corner, set Current Configuration Scope to the applicable website. If you
don't have additional websites, you can accept the “Default Config” setting.

3. In the panel on the left under Sales, select Payment Methods.

4. Click to expand the Braintree section, and do the following:
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Braintree

a. Set Enabled to “Yes.”

b. In the Title field, enter the name that appears to the customer in the Payment
Information section during checkout.

c. Set Payment Action to the way you want payments to be authorized by Braintree. The
following options are available:

Authorization Funds on the customer’s card are only authorized on the
Braintree system, and only the order is created in the backend
of your store. You can later create an invoice and conduct the
capturing.

Sale Funds on the customer’s card are authorized and captured on
the Braintree side, and as a result an order and an invoice are
created in the backend of your store.

d. To enable Braintree to securely store sensitive customer information, set Enable Vault
to “Yes.”

Information stored in the vault could include the token generated by Magento Secure
Payment Bridge that is used to charge customers, customer address information, and
so on.

After a credit card profile is saved, Magento Secure Payment Bridge stores the first four and
last six digits of the card number, and generated the tokens that are used to charge
customers.

e. Enter a number in the Sort Order field to determine the sequence in which this
payment method is listed iwth others during checkout.

5. When complete, click the Save Config button.
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Gateway Setup (WhenOptional)
The configuration process is similar for payment methods that can be used either with
Magento Secure Payment Bridge or directly with payment gateways, although the set of
options may differ. The following example shows how to configure Authorize.Net for
Magento Secure Payment Bridge.

To enable and configure Authorize.Net:

1. On the Admin menu, select System > Configuration.

2. In the upper-left corner, set Current Configuration Scope to the applicable website. If you
don't have additional websites, you can accept the “Default Config” setting.

3. In the panel on the left under Sales, select Payment Methods.

4. Click to expand the Authorize.Net section, and do the following:

Use Via Payment Bridge

a. Set Enabled to “Yes.”

b. Set Use via Payment Bridge to “Yes.”

c. Make any other configuration settings that are needed.

5. When complete, click the Save Config button.

For payment methods that can work with or without Magento Secure Payment Bridge, the set of
options available for configuring might differ, depending on your choice concerning payment
bridge usage. For example, for Authorize.Net, 3D Secure Card Validation is available only if the
Magento Secure Payment Bridge is not used. Customer Information Manager is available only
when Magento Secure Payment Bridge is used.
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Payment Bridge Version Comparison
If you currently use Magento Enterprise Edition 1.13.0.2, it is recommended that you
upgrade to Magento Secure Payment Bridge (v. 1.11.31.0). If you plan to upgrade to newer
versions of Magento Enterprise Edition, you should upgrade Magento Secure Payment
Bridge at the same time.

EE 1.13.0.2 and later

PAYMENT METHOD
Partial
Capture*

Full Refund
from Invoice

Partial Refund
from Invoice*

Partial Refund
from Order

PayPal Solutions

Payflow Pro Yes Yes Yes Yes

Website Payments Pro
Payflow Edition

Yes Yes Yes Yes

Website Payments Pro Yes Yes Yes Yes

Other Gateways

Authorize.Net Yes Yes Yes Yes

Braintree No Yes Yes Yes

CyberSource No Yes No No

DIBS No Yes Yes Yes

eWAY Direct Yes Yes Yes Yes

First Data Global
Gateway

No Yes No No

Ogone DirectLink Yes Yes Yes Yes

Paybox Direct No No No Yes

Payone.de No Yes No No

PSiGate No Yes Yes Yes

SagePay Direct Yes Yes Yes Yes

Worldpay Yes Yes Yes Yes

* Same as offline
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Prior to EE 1.13.0.2

PAYMENT METHOD
Partial
Capture*

Full Refund
from
Invoice

Partial Refund
from Invoice*

Partial Refund
from Order

PayPal Solutions

Payflow Pro No Yes No No

Website Payments Pro
Payflow Edition

Yes Yes Yes Yes

Other Gateways

Authorize.Net No Yes Yes Yes

Braintree No Yes Yes Yes

CyberSource No Yes No No

DIBS No Yes Yes Yes

eWAY Direct No No No Yes

First Data Global
Gateway

No Yes No No

Ogone DirectLink Yes Yes Yes Yes

Paybox Direct No No No Yes

Payone.de No Yes No No

PSiGate No Yes Yes Yes

SagePay Direct Yes Yes Yes Yes

Worldpay No Yes Yes Yes

* Same as offline
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CHAPTER 57:

Payment Gateways
Payment gateways make it possible for you to accept credit card payments directly
from your store. Magento Enterprise Edition supports a wide range of payment
gateways that offer merchant services in all parts of the world.

Checkout Payment Information
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Integrated Solutions
Magento Secure Payment Bridge supports the following payment methods, which are
integrated with external payment gateways. Some of the methods can be used with, or
without, Magento Secure Payment Bridge. Most of the methods listed are available “out-of-
the-box” for Magento Enterprise Edition, and can be used with Magento Secure Payment
Bridge when installed, enabled, and properly configured.

Worldwide

PayPal

With PayPal’s deep integration with Magento, you can easily accept credit cards and
PayPal payments using PayPal, all while keeping customers on your site. Already have a
merchant account? Add PayPal Express checkout to increase conversion.

Authorize.Net

Authorize.Net includes free fraud tools, free customer support, a free website seal, and the
ability to accept multi-channel payments: online, mail order/telephone order, retail and
mobile. Trusted by 300,000 customers. Authorize.Net CIM works with Magento Secure
Payment Bridge.

CyberSource

CyberSource, a wholly-owned subsidiary of Visa Inc., is a payment management company.
Over 330,000 businesses worldwide use CyberSource to process online payments,
streamline fraud management, and simplify payment security.

First Data

Fast, convenient, and secure. With over forty years of industry leading experience Express
Merchant Processing Solutions (EMPS) powered by First Data helps millions of businesses
like yours bring safe, easy, cost-effective payments to their customers with affordable
support, regardless of size.

WorldPay

WorldPay operates in forty countries, and is a major global leader in payment processing.
They pioneered online payments for small and medium sized businesses and process
millions of online payments every day.
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North America

PSiGate

PSiGate is a full-service Canadian provider of electronic payment processing services. They
deliver a secure interface for your website so you can accept credit card and Interac Online
payments with reliable, real-time transaction processing. They ensure maximum
performance while taking into account power, security, disaster tolerance and bandwidth
requirements.

Braintree

Braintree helps online businesses process credit card payments by providing a merchant
account, payment gateway, recurring billing and credit card storage. The company is
disrupting the payments industry by providing elegant tools for developers coupled with
white-glove support.

Europe

DIBSPayment Services

DIBS Payment Services is the leading independent provider of functional, secure and
innovative payment services for Internet commerce in the Nordic countries. DIBS handles
more than 13,000 customer transactions daily in seventeen countries.

Ogone

Ogone Payment Services delivers non-face-to-face businesses the payment solutions
platform, added value opportunities and technology advancements that become essential
for the way payments are performed, managed and secured today.

Paybox Direct

Paybox Services provides merchant accounts and eCommerce payment services for
merchants in Europe.

PAYONE.de

PAYONE is a leading payment service provider in Germany. Featuring processing of
national and international payments and outsourcing of monetary transactions, the
payment-Platform Finance Gate makes processes fully automated with the highest
performance standards and security in mind. PAYONE requires the base currency to be
euros.

Sage Pay Direct

Sage Pay is the UK’s largest independent payment service provider, processing millions of
secure payments every month for over 33,000 businesses, from startups through to major
online, consumer, and business brands.
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Oceania

eWAYDirect

Focusing on high-level standards in technology, innovations and customer care, eWay has
become Australia’s award-winning payment gateway. eWAY specializes in delivering
successful eCommerce payment gateway services to thousands of merchants.

Testing Credentials
When testing the configuration of a payment gateway, use the following credentials for test
transactions.

Visa: 4111111111111111

MasterCard: 5555555555554444

American Express: 378282246310005

Expiration Date: Any future date

CVV/CVC: 123 or 000
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Authorize.Net
Authorize.Net gives merchants the ability to accept credit card and payments through the
Authorize.Net payment gateway. It processes the credit card information entered during
checkout, and creates a transaction either for the payment authorization or for the payment
authorization and a capture of the funds, depending on the configuration.

Authorize.Net can be used to pay for purchases made from the storefront or for orders
placed from the Admin. Orders that use the Authorize.Net payment method can be
processed from your store's Admin and also from the Authorize.Net merchant
account.Based on the response that Magento receives from Authorize.Net, an order is
created in Magento with an assigned Authorize.Net transaction number.

Capture Workflow
Authorize.Net does not accept partial invoices from Magento. The Qty to Invoice field
cannot be edited on the New Invoice for Order page. When an invoice is captured online, a
corresponding document with status of “Paid” is created and appears in the list of Invoices.
In addition, a Capture transaction is added to the list of Transactions.

You can partially capture the order amount from the Authorize.Net merchant account.
However, Authorize.Net does not allow for the remaining amount to be captured. In the
case of a partial capture from Authorize.Net, no invoice or transaction is created in
Magento for the order.

To find an order:

1. On the Admin menu, select Sales > Orders.

2. In the list, click to open the order.

3. On the order detail page, click the Invoice button.

PAYMENT ACTION DESCRIPTION

Capture Online When an invoice is submitted, the system captures the payment
amount through the external payment gateway. In this case, an
invoice and a transaction of the “Capture” type are added to the
order detail page. If a payment is captured online, you can later
create an online credit memo from the invoice, if required.

A payment capture transaction can be voided only from your
Authorize.Net merchant account.

Payment Actions
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PAYMENT ACTION DESCRIPTION

Capture Offline When an invoice is submitted using this option, the does not
capture the payment, and only an offline invoice is created in
Magento. It is assumed that the payment will be captured directly
through the payment gateway, and you do not have the option to
capture the payment online throughMagento.

If the invoice is captured online, you cannot create an online
refund from Magento.

Not Capture When an invoice is submitted using this option, Magento does
not capture the payment, and no corresponding transaction is
created in the Authorize.Net merchant account. However, it is
assumed that you will capture the payment online through
Magento at a later date. Therefore, the Capture button is
available in the completed invoice, which has a status
temporarily set to “Pending.”

The order can be canceled at any time before the payment is
captured. After the payment has been captured, a credit memo
must be generated to cancel the order.

Payment Actions (cont.)
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Authorize.Net Configuration
The Authorize.Net payment gateway gives you the ability to accept credit card and
electronic check payments in USD, quickly and inexpensively.

Authorize.Net
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Step 1: Open an Authorize.Net Merchant Account

The first step is to establish an Authorize.Net merchant account. As you go through the
process, take note of the following information, which you will need to complete the
configuration:

l API Login ID

l Transaction Key

To learn more about opening an Authorize.Net merchant account, visit their site at
www.authorize.net.

Step 2: Configure Authorize.Net for Your Store

1. On the Admin menu, select System > Configuration.

2. In the panel on the left, under Sales, select Payment Methods.

3. Click to expand the Authorize.Net section. Then, do the following:

a. To activate Authorize.Net, set Enabled to “Yes.”

b. Set Payment Action to one of the following:

Authorize Only When an order is submitted, Authorize.Net validates and
authorizes the transaction. You must then, log in to your
Authorize.Net merchant account to capture the transaction.

Authorize and
Capture

The payment is authorized and captured on the Authorize.Net
site, and your store generates an order and invoice.

c. Enter the API Login ID for your Authorize.Net merchant account.

d. If using Authorize.Net with Magento Secure Payment Bridge, set Use via Payment
Bridge to “Yes.”

e. Enter an appropriate Title to identify Authorize.Net during the checkout process.

f. Enter the Transaction Key for your Authorize.Net merchant account.

g. Set the default New Order Status to one of the following:

l Processing

l Processed Ogone Payment

h. Verify the Gateway URL to the Authorize.Net server.

i. Set Test Mode to one of the following:

http://www.authotize.net/
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Yes When you are ready to test the configuration and process test
transactions.

No When you are ready to "go live" with the Authorize.Net payment
method.

j. Select the Accepted Currency for the store.

k. Set Debug to “Yes” to record the details of all exchanges between the store and the
payment system in a log file.

In accordance with PCI Data Security Standards, credit card information is not recorded in
the log file.

l. If you want to email the customer when the order is processed, set Email Customer to
“Yes.”

m. Enter your store’s email address in the Merchant’s Email field.

n. In the Credit Card Types list, select each credit card which can be used with this
payment method. Accepted credit card types include:

l American Express

l Visa

l MasterCard

l Discover

l Other (approved by Authorize.Net)

o. To require customers to enter a card verification value (CVV), set Credit Card
Verification to “Yes.”

p. Set Payment from Applicable Countries to one of the following:

All Allowed
Countries

Customers from all countries specified in your store
configuration can use this payment method.

Specific Countries Select each country in the Payment from Specific Countries
list where customers can make purchases from your store.

q. Enter the Minimum Order Total and Maximum Order Total for Authorize.Net
transactions. To qualify, the order total must exactly match the minimum or
maximum threshold, or fall somewhere in between.

r. Enter a Sort Order number to determine the position of Authorize.Net in the list of
payment methods during checkout. (0 = first, 1 = second, 2 = third, and so on.)

s. To permit the authorization of partial orders processed by Authorize.Net, set Allow
Partial Authorization to “Yes.”
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t. For an additional layer of fraud protection for your transactions, set Enable 3D
Secure Card Validation on Frontend to “Yes.” To learn more, see 3D Secure Credit
Card Validation.

4. When finished, click the Save Config button.

Partial Authorization with Authorize.Net
Authorize.Net gives you the ability to accept multiple credit cards as payment for a single
order. If there isn’t enough remaining balance on a single card to cover the purchase, the
amount can be distributed across multiple cards. Up to five credit cards can be used to pay
for a single order.

Customer Workflow
During the checkout process, the customer selects Authorize.Net, enters the card
information, and proceeds to Order Review. When the customer clicks the Place Order
button, the request is sent to Authorize.Net. If the amount available on the card is not
enough to cover the order total, the following message appears:

The amount on your credit card is insufficient to complete your purchase. The available
amount has been put on hold. To complete your purchase, click Continue and specify
additional credit card number. To cancel the purchase and release the amount on hold, click
Cancel.

If the customer chooses to continue, the Payment Information checkout step reappears,
and the customer is prompted to enter another credit card. The information about the
previously used credit cards appears as well.

If the customer clicks the Cancel button, all authorizations are reversed. The customer can
then choose another payment method to complete the purchase. If the customer closes the
browser window, the authorizations remain active until they expire. The term of each
authorization depends on the bank that issued the credit card. An order is created only
after the total amount of the order is captured.
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Partial Authorization During Checkout

If the customer reaches the limit of five cards that can be used for one order, the following
message appears during Order Review:

You have reached themaximum number of credit cards that can be used for the payment.

When the customer clicks the OK button, the Payment Information checkout step
reappears, with the following message:

You have reached themaximum number of credit cards that can be used for one payment.
The available amounts on all used cards were insufficient to complete payment. The
payment has been canceled and amounts on hold have been released.

The system sends a request to Authorize.Net to void all authorizations of this payment.
The customer can now choose another payment method, or try a different credit card.

During partial authorization, the bank might reject the transaction, For example, the daily
limit for the card might be exceeded. In this case, Authorize.Net sends the appropriate
response to Magento and the following message appears:

Your credit card has been declined. Click Continue to specify another credit card to complete
your purchase. Click Cancel to release the amount on hold and select another payment
method.
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If the customer decides to reverse the payment and clicks Cancel, the payment is reversed,
and a request is sent to Authorize.Net to release the amounts on hold from the previously
entered cards. The customer can then select another payment method. If the customer
chooses to continue, the Payment Information checkout step reappears, and the customer
is prompted to enter another credit card.

Before the order is placed, the customer can click the Cancel button from the Payment
Information step to reverse all authorizations and release all amounts.

If the customer changes any order information after having started the partial
authorization process, an error will occur when the order is submitted. In such a case, all
authorizations are released, and the customer is redirected to the Payment Information
checkout step.

Admin Workflow
Partial authorization can be applied to new orders and recorders from the Admin. After you
choose the Authorize.Net payment method, enter the card information, and click the
Submit Order button, the request is sent to Authorize.Net. If the amount on the card is not
enough to cover the order, the available funds are put on hold, and the partial
authorization is triggered. A message appears on the Create New Order page, asking if you
want to continue. If you choose to continue, the system displays the information about the
previously used credit cards, and prompts you to enter another credit card. If you click the
Cancel button, all authorizations are reversed.

If you close the browser window during the partial authorization process, the
authorizations remain active until they expire. The term of authorization depends on the
bank that issued the credit card.

If payment is not complete, you can click the Cancel button in the upper-right corner.
Magento then sends a request to Authorize.Net to void the authorization for all cards that
were entered during the process, and the amounts on hold are released. If the payment
gateway is not able to void authorization for some transactions, the order is canceled by
the system only.

Do not change any order information after the partial authorization process begins.
Otherwise, an error occur when you submit the order, and all authorizations are released
automatically.
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Refund Workflow
When processing a refund for an order that was paid as an Authorize.Net partial
authorization, Magento refunds the correct captured amount to each card. The process is
managed by the system, and requires no action on your part.

When initiating an online invoice or refund, and some authorizations fail, the system
proceeds with the remaining authorizations, but does not generate the invoice or refund.
After all authorizations have been processed, information about the successful
authorizations, as well as any that failed, appears in the header of the order. The same
information is added to the order comments section of the order.

The administrator is then prompted to process the failed authorizations manually, by
creating an offline invoice or offline refund in Magento.

For a partial refund, the amounts are refunded to the cards from which they originated, in
the order of authorization. The amount captured from the first card is the first to be
refunded. In this order, it is possible for the amount reversed on the last card to be less
than what was captured during the partial authorization process. In this case the
transaction for the card remains open, and can be closed in the next partial refund.

Magento stores only the last four digits of the credit card number. For a period of 120 days
after the payment, Authorize.Net allows merchant systems to submit a refund using the
last four digits of the credit card. After 120 days have passed, you cannot process an online
refund for an order that was paid with Authorize.Net.

Because American Express does not support authorization reversals, it is not possible to
create an online refund for any purchases paid for with this method. In such a case, you
can create an offline refund, and settle the situation by releasing the customer’s funds
through the appropriate merchant account, outside of the Magento system.

Partial Authorization Setup
Partial authorization can be activated in the Authorize.Net configuration at either the
global, or website level.

To enable partial authorization:

1. On the Admin menu, select System > Configuration.

2. In the upper-left, set Current Configuration Scope as needed. To use partial authorization
at the global level, accept the “Default Config” setting.

3. In the panel on the left under Sales, select Payment Methods. Then, click to expand the
Authorize.Net section.
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Allow Partial Authorization

4. Set Allow Partial Authorization to “Yes.”

5. When complete, click the Save Config button.

Direct Post
Magento incorporates the Direct Post method for payments made through Authorize.Net.
When payments are made using the Direct Post Method, the Authorize.Net gateway
handles all steps in the transaction process, such as payment data collection, data
submission, and response to the customer, while the customer remains in your store.

Checkout Using Authorize.Net Direct Post

Admin Workflow
Authorize.Net Direct Post can be used with orders created from the Admin as well as from
the store. When creating an order, you can select it in the Payment Method section of the
order. After the option is selected, the credit card data entry fields appear. If the
transaction fails, an error message appears, and you can select another payment method or
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try again with another card.

The order process is similar to the standard order workflow. As with other orders, and
invoice, shipment, and credit memo can be created.

Customer Workflow
When enabled, the customer can select Authorize.Net Direct Post in the Payment
Information section during checkout. During Order Review, the customer is prompted to
enter the credit card information. After verifying the card information, the customer clicks
the Place Order button.

If the transaction is successful, the customer is redirected to the order confirmation page. If
the transaction fails, an error message appears. The customer can then select another
payment method or try Authorize.Net Direct Post with a different credit card.

Authorize.net Direct Post

Step 1: Enable Direct Post

1. On the Admin menu, select System > Configuration.

2. In the panel on the left, under Sales, select Payment Methods.
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3. Set Current Configuration Scope to the website where the configuration is to be applied.
To apply the configuration globally, accept the “Default Config” setting.

4. Click to expand the Authorize.Net Direct Post section. Then, do the following:

a. Set Enabled to “Yes.”

b. Set Payment Action to one of the following:

Authorize Only Funds on the customer's card are only authorized at the
side of the Authorize.Net system and only an order is
created in the backend of your store. You can later create
an invoice and conduct the capturing.

Authorize and Capture Funds on the customer's card are authorized and
captured at Authorize.Net side, and as a result an order
and an invoice are created in the backend of your store.

c. Enter a Title to identify the Authorize.Net Direct Post payment method during
checkout.

Step 2: Enter Your Credentials

1. Enter the following credentials for your Authorize.Net account:

l API Login ID

l Transaction Key

2. In the Merchant MD5 field, enter the hash value from your Authorize.Net merchant
Account. The value is located on the Authorize.Net website at Account > Settings >
Security Settings > MD5-Hash.

3. Set New Order Status to one of the following:

l Processed Ogone Payment

l Processing

4. To operate temporarily in a test environment, set Test Mode to “Yes.” When you are ready
to process live transactions, set Test Mode to “No.”

5. Enter the Gateway URL that establishes the connect to the Authorize.Net server. The
default value is:

https://secure.authorize.net/gateway/transact.dll

If you have received a temporary URL for test transactions, don’t forget to restore the
original URL when you are ready to process live transactions.
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Step 3: Complete Payment and Notification Information

1. Verify that Accepted Currency is set to “US Dollar.”

2. To save messages transmitted between your store and the Authorize.Net Direct Post
system, set Debug to “Yes.”

3. To set the notification options, do the following:

a. If you want Authorize.Net to send an order confirmation notification to the customer,
set Email Customer to “Yes.”

b. In the Merchant’s Email field, enter the email address where you want to receive
notification of orders placed with Direct Post. Leave blank if you do not want to
receive notification.

4. To complete the payment options, do the following:

a. In the Credit Card Types list, select each credit card that is accepted in your store.

b. To require customers to enter a card verification value (CVV), set Credit Card
Verification to “Yes.”

c. Set Payment from Applicable Countries to one fo the following:

All Allowed
Countries

Customers from all countries specified in your store
configuration can use this payment method.

Specific Countries Select each country in the Payment from Specific Countries
list where customers can make purchases from your store.

d. Enter the Minimum Order Total and Maximum Order Total for Directd Post
transactions. To qualify, the order total must exactly match the minimum or
maximum threshold, or fall somewhere in between.

e. Enter a Sort Order number to determine the position of Direct Post in the list of
payment methods during checkout. (0 = first, 1 = second, 2 = third, and so on.)

5. When complete, click the Save Config button.

Customer InformationManager
Authorize.Net Customer Information Manager (CIM) is an additional option that is
available to Magento installations that process transactions through Magento Secure
Payment Bridge.

Customer Information Manager gives you the ability to securely save and manage
customers’ credit card information, either from the storefront or Admin. In addition, you
can reuse the card information, which includes the credit card number, type, and
expiration date, every time you check out with Authorize.Net. Authorize.Net also stores the
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shipping and billing addresses that are used with each credit card. You can view the
information in the Customer Information Manager section of your merchant account on the
Authorize.Net website.

Payment and order processing with CIM is similar to the standard workflow for
Authorize.Net payments, including partial refunds. Online refunds can be created from the
Invoice page. CIM restrictions include:

l 3D Secure Credit Card Validation is not available for the Authorize.Net payment method
when CIM is enabled.

l Partial authorization, partial invoicing, and balance response are not available for the
Authorize.Net payment method when CIM is enabled.

Customer Workflow
When Authorize.Net CIM is enabled and configured, the shopper’s experience is as follows:

l When a logged-in customer uses Authorize.Net for the first time, the customer is
prompted to enter credit card information, which is saved after the order is placed. The
customer is informed that credit card information will be securely saved, but no
confirmation is required.

l A logged in customer can view, delete, and add new cards to the saved profiles in the
My Account section of the My Credit Cards tab.

On the My Credit Cards tab the information about credit cards used for checkout is stored
and can be managed. A customer can reuse the saved card information, or enter a new card
for each subsequent checkout with Authorize.Net. The CCV value is not saved and must be
re-entered.
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My Credit Card Profiles

Admin Workflow
All CIM capabilities are available for orders created from the store Admin. When a credit
card is used for the first time, the information is saved in the customer’s profile. Previously
saved credit card information can be used for subsequent orders. However, CCV values are
not saved and must be re-entered. The credit card information of each customer can be
found at: Customers > Manage Customers. See the Credit Cards tab of the Customer
Information page.

Balance Response Workflow
If the customer chooses Authorize.Net and uses one of the supported debit, prepaid, or a
gift cards, the information about the balance and the amount put on hold or captured for
this card is available for viewing. The balances appear in the customer's account
dashboard, under My Account > My Orders. In the Payment Method block, see the
Remaining Balance and Processed Amount fields.

The following credit card information is displayed:

l Credit Card Type

l Credit Card Number (only the last four digits of the card number are stored and
displayed in Magento)

l Processed Amount

l Remaining Balance (if available)
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Customer's Card Information During Checkout

The same information is also shown in the Payment Method section of transactional emails
messages that are sent to the customer when an order is created, on the invoice, shipping
notice, and credit memo. If the customer pays for the order with more than one credit card,
by partial authorization, the information is included for each card that is used to make the
payment. Similarly, the balance and the amount put on hold appear in the Payment
Information block of the order view in the Admin.

Sometimes the balance information is not available, as might occur if the card issuer
doesn’t return the remaining balance to the customer's card. This typically occurs when the
customer's card is a credit card. In such a case, the Remaining Balance field does not
appear in the Admin or storefront.

CIM Configuration
Authorize.Net CIM can be enabled at either the global or website level from the Admin.
When configured globally, CIM is available to all customers of all websites in your Magento
installation. If CIM is enabled only for a certain website, CIM is available only to customers
who have registered on the website. To be able to use CIM with Authorize.Net, you must
have:

l A merchant account with CIM supported and enabled in the Authorize.Net payment
gateway

l Magento Secure Payment Bridge enabled and configured

Important!Magento Payment Bridge stores only general information about credit cards, such
as credit card type. All sensitive information is stored by the Authorize.Net gateway. To learn
more, see: Payment Data Tokenization.

http://www.authorize.net/solutions/merchantsolutions/merchantservices/cim/
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Authorize.Net with CIM enabled can be used by customers who are logged in to their
accounts, as well as guest shoppers. Guest shoppers’ credit card information is not saved.

Payment and Order Processing with CIM Enabled

Process Overview:
Step 1: Configure Authorize.Net for Payment Bridge
Step 2: Configure and Enable Payment Bridge

Step 1: Configure Authorize.Net for Payment Bridge

Use an SSH client to configure Authorize.Net for Magento Secure Payment Bridge. If
Authorize.Net is already configured in Payment Bridge, then you need only to enable CIM.
There is no need to re-enter the credentials. To learn more, see: Magento Secure Payment
Bridge.

Step 2: Configure and Enable Payment Bridge

1. On the Admin menu, select System > Configuration.

2. In the panel on the left, under Sales, select Payment Methods.

3. Click to expand the Authorize.Net section.

4. Set Use via Payment Bridge to “Yes.”

This option is available only if the payment method is configured to work with Payment
Bridge.
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Authorize.net

5. When complete, click the Save Config button.

Additional Requirements
Because MasterCard and Discover modified their rules for processing debit, prepaid, and
gift cards, Authorize.Net now requires merchants to add the following functionality to be in
compliance with the new requirements:

l Balance response transactions

l Partial authorization transactions

l Authorization reversals

Merchants are required to provide support for authorization reversals only. Although no
longer required, partial authorizations and balance responses are considered to be best
practices, and Authorize.Net strongly recommends that merchants provide support for all
three requirements.

Magento Enterprise Edition includes all three options, which are available for the
Authorize.Net payment method. The following types of debit, prepaid, and gift cards are
supported:

l MasterCard

l Discover

l Diners Club

l JCB

l Visa

l American Express (supporting only partial authorization and balance response
transactions)

Balance response transactions, partial authorizations, and authorization reversals are
provided for all merchants, regardless of location. Magento triggers the new functionality
during the order creation process, and receives the appropriate response from
Authorize.Net. The gateway receives a response from the bank to either approve or reject the
new features.

Important! Balance response transactions, partial authorizations, and authorization reversals
are available only if Authorize.Net is not configured to use Magento Secure Payment Bridge.
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CHAPTER 58:

Payment Services
The following services provide enhanced security and payment processing services for
your store.

Enhanced Security
3D Secure Credit Card Validation

3D Secure Credit Card Validation provides an additional layer of protection against
fraudulent charges and chargebacks for sales. The service is available only for eligible
payment gateways, and must be enabled in the gateway configuration.

Cardinal Centinel 3D Secure

Cardinal Centinel 3D secure credit card validation payment service is enabled and
configured in the Magento Secure Payment Bridge.

PayPal Fraud Management Filters

Magento Enterprise Edition includes support for PayPal fraud management filters
(FMFs), available for owners of Website Payments Pro PayPal accounts. It can be used
with orders that are paid with either PayPal Express Checkout or Website Payments
Pro.

Kount Fraud Detection Service

Kount Fraud Detection service is enabled and configured in Magento Secure Payment
Bridge, and is used for all transactions managed by Magento Secure Payment Bridge.
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3D Secure Credit Card Validation
Magento Enterprise Edition includes the option to use 3D Secure authentication for
payment transactions made with Authorize.Net. Cardinal Centinel® is the company that
provides the 3D Secure Credit Card Validation service.

Important! If Authorize.Net is configured to work with Magento Secure Payment Bridge. 3D
Secure and Customer Information Manager (CIM) cannot be enabled simultaneously. To learn
more, see: Customer Information Manager (Saved Credit Card).

Customer Workflow
During the checkout process, the customer selects the Authorize.Net payment method,
enters the credit card information, and clicks the Continue button. During Order Review,
the bank that issued the credit card displays a form to verify the customer’s identity.
Depending on the bank’s requirements, the customer might be required to enter a secret
code, log in to an account, or complete another activity.

At checkout, the customer is prompted to enter a secret code that is assigned to the card,
which is then used to confirm the identity of the cardholder. The bank also provides
additional data elements to confirm the cardholder’s identity. The service provider arranges
the communication between the banks and payment systems. 3D Secure authentication
can be used for orders placed from the store, or from the Admin. To learn more about the
3D Secure protocol, search by “Verified by Visa,” “MasterCard SecureCode,” and “J/Secure.”

3D Secure Authentication for Customer
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After submitting the form, the customer is returned to Order Review. The customer clicks
the Place Order button. If the authentication succeeds, the customer proceeds to the order
confirmation page. If the authentication fails for any reason, an error message appears and
the customer can select another payment method or try again with Authorize.Net.

Admin Workflow
When creating an order from the Admin that uses 3D Secure with Authorize.Net, a form
appears with the fields to enter the credit card information, and a Start/Reset Validation
button.

3D Secure Authentication from the Admin

After you complete the credit card information, and click the Start/Reset Validation button,
the bank that issued the credit card displays a form to verify the customer's identity.
Depending on the bank’s requirements, you might be required to enter a secret code, log in
to an account, or complete another activity on behalf of the customer. If successful, a
message indicates that the transaction has been validated, and you can proceed with the
order.
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3DSecure Configuration
If Authorized.Net is configured to work with Magento Secure Payment Bridge, the 3D
Secure configuration takes place from the Payment Bridge console. Otherwise, the
configuration is managed from the store Admin.

Process Overview:
Step 1: Complete the 3D Secure Configuration
Step 2: Enable 3D Secure for Authorize.Net

Step 1: Complete the 3D Secure Configuration

1. On the Admin menu, select System > Configuration.

2. In the panel on the left, under Sales, select Payment Services.

3. To apply the configuration at the website level, set Current Configuration Scope in the
upper-left corner, as needed. To apply the configuration at the global level, accept the
“Default Config” setting.

4. Click to expand the 3D Secure Credit Card Validation section. Then, do the following:

3D Secure Credit Card Validation

a. Enter the following credentials that are required to connect to the Cardinal Centinel
system:

l Processor ID

l Merchant ID

l Password

b. To test 3D Secure Validation before going live in the store, set Test Mode to “Yes.”

c. To save a log file of all interactions between your server and the Cardinal Centinel
system, set Debug Mode to “Yes.”

5. When complete, click the Save Config button.
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Step 2: Enable 3D Secure for Authorize.Net

1. On the Admin menu, select System > Configuration.

2. In the panel on the left, under Sales, select Payment Methods.

3. To apply the configuration at the website level, set Current Configuration Scope in the
upper-left corner as needed. To apply the configuration at the global level, accept the
“Default Config” setting.

4. Click to expand the Authorize.Net section. Then, scroll down to the 3D Secure section.
Then, do the following:

Authorize.net

a. Set Enable 3D Secure Card Validation on Frontend to “Yes.”

If you are use Magento Secure Payment Bridge, you can ignore the additional settings.

b. In the Severe 3D Secure Card Validation field, specify if you want severe validation
to be applied to credit card purchases made through the Centinel system. Severe
validation removes merchant liability for any chargebacks that may occur.

c. In the Centinel API URL field, enter the URL that was provided by Cardinal Centinel
to establish the connection with their system.

5. When complete, click the Save Config button.
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CHAPTER 59:

Basic Shipping Methods
Magento Enterprise Edition supports a wide range of shipping methods and carriers. In
this chapter you will learn how to set up and use your store’s basic shipping methods.

Topics in this chapter:

l Shipping Settings

l Flat Rate

l Free Shipping

l Table Rates

l Online Rates

l Dimensional Weight

Before you proceed, make sure that you have completed the Shipping Settings to establish
the point of origin for your store, and your preference for handling orders shipped to
multiple addresses.
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Shipping Settings
The Shipping Settings establish the point of origin for all shipments made from your store
or warehouse, and your preference for managing orders that are shipped to multiple
addresses. The point of origin determines the tax rate that is used for products sold from
the store.

Origin

To establish the point of origin:

1. On the Admin menu, select System > Configuration.

2. In the Configuration panel on the left, under Sales, select Shipping Settings.

3. If applicable, set Current Configuration Scope to the store where the configuration
applies.

4. Click to expand the Origin section.

5. Complete the fields for each part of your point-of-origin address. If you need more room for
the street address, use both address lines.

6. When complete, click the Save Config button.
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To configure shipments to multiple addresses:

1. On the Shipping Settings page, click to expand the Options section. Then, do the
following:

Options

a. To allow items from a single order to be shipping to multiple addresses, set Allow
Shipping to Multiple Addresses to “Yes.”

b. To limit the quantity of a single item that can be shipping to multiple addresses, enter
the number in the Maximum Qty Allowed for Shipping to Multiple Addresses field.

2. When complete, click the Save Config button.
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Flat Rate
Flat rate is a fixed, predefined charge that can be applied per item, or per shipment. Flat
rate is a simple solution, especially when used with the flat-rate packaging that is available
from some carriers.

Flat Rate

To set up flat rate shipping:

1. On the Admin menu, select System > Configuration. In the panel on the left, under Sales,
select Shipping Methods.

2. Click to expand the Flat Rate section. Then, do the following:

a. Set Enabled to “Yes.”

Flat Rate appears as an option in the Estimate Shipping and Tax section of the
shopping cart, and also in the Shipping section during checkout.

b. Enter a descriptive Title for this shipping method. The default is “Flat Rate.”

c. Enter a Method Name that appears next to the calculated rate in the shopping cart.
The default method name is “Fixed.” If you charge a handling fee, you can change the
Method Name to “Plus Handling” or something else that is suitable.

d. To describe how flat rate shipping can be used, set Type to one of the following:
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None Disables the payment type. The Flat Rate option is listed in the
cart, but with a rate of zero, which is the same as free shipping.

Per Order Charges a single flat rate for the entire order.

Per Item Charges a single flat rate for each item. The rate is multiplied by
the number of items in the cart, regardless of whether there are
multiple quantities of the same, or of different items.

e. Enter the Price to be charged for the flat rate fee.

f. If charging a handling fee, set Calculate Handling Fee to one of the following:

l Fixed

l Percent

Then, enter the Handling Fee rate according to the method used to calculate the fee.
For example, if the fee is calculating based on a percentage, enter 0.06 for 6 percent. If
using a fixed amount calculation, enter the fee as a decimal.

g. In the Displayed Error Message box, type the message that appears if this method
becomes unavailable.

h. Set Ship to Applicable Countries to one of the following:

All Allowed
Countries

Customers from all countries specified in your store
configuration can use this shipping method.

Specific Countries After choosing this option, the Ship to Specific Countries list
appears. Select each country in the list where this shipping
method can be used.

i. Enter a Sort Order number to determine the position of Flat Rate in the list of
shipping methods during checkout. (0 = first, 1 = second, 2 = third, and so on.)

3. When complete, click the Save Config button.
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Free Shipping
Free shipping is one of the most effective promotions you can offer. It can be based on a
minimum purchase, or set up as a shopping cart price rule that applies when a set of
conditions is met. If both apply to the same order, the configuration setting will take
precedence over the shopping cart rule. Check your shipping carrier configuration for any
additional settings that might be required for free shipping.

Free Shipping

To set up free shipping:

1. On the Admin menu, select System > Configuration. In the panel on the left, under Sales,
select Shipping Methods.

2. Click to expand the Free Shipping section. Then, do the following:

a. Set Enabled to “Yes.”

b. Enter a Title for this shipping method that will be displayed during checkout.

c. Enter a descriptive Method Name to identify this shipping method.

d. Enter the Minimum Order Amount to qualify for free shipping.

To use Free Shipping with Table Rates, enter a Minimum Order Amount so high that it
is never met. This prevents Free Shipping from going into effect, unless it is triggered
by a price rule.

e. In the Displayed Error Message box, type the message to appear if this method
becomes unavailable.

f. Set Ship to Applicable Countries to one of the following:
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All Allowed
Countries

Customers from all countries specified in your store
configuration can use this shipping method.

Specific Countries After choosing this option, the Ship to Specific Countries list
appears. Select each country in the list where this shipping
method can be used.

g. Set Show Method if Not Applicable to one of the following:

Yes Always shows the Free Shipping method, even when not
applicable.

No Shows the Free Shipping method only when applicable.

h. Enter a Sort Order number to determine the position of Free Shipping in the list of
shipping methods during checkout. (0 = first, 1 = second, 2 = third, and so on.)

3. When complete, click the Save Config button.

4. Make sure that you complete any configuration that is required for each carrier you plan to
use with free shipping. For example, assuming that your UPS configuration is otherwise
complete, make the following settings to enable and configure free shipping:

a. From the Shipping Methods configuration, click to expand the UPS section.

b. In the UPS section, set Free Method to “Ground.”

c. To require a minimum order for free shipping, set Free Shipping with Minimum Order
Amount to “Enable.”

d. Enter the required amount in the Minimum Order Amount for Free Shipping field.

5. When complete, click the Save Config button.
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Table Rates
The table rate shipping method lets you set up a table to calculate shipping rates for a
combination of conditions. The shipping rate can be based on the following:

l Weight v. Destination

l Price v. Destination

l # of Items v. Destination

For example, if your warehouse is located in Los Angeles, it costs less to ship to San Diego
than to Vermont. You can use table rate shipping to pass the savings on to your customer.

Example 1: Price v. Destination

This example uses the Price v. Destination condition to create a set of three different
shipping rates based on the amount of the order subtotal for the continental United States,
Alaska, and Hawaii. The asterisk (*) is a wildcard that represents all values.

COUNTRY Region / State
ZIP / Postal
Code

Order Subtotal
(and above) Shipping Price

USA * * 0 15

USA * * 50 10

USA * * 100 5

USA AK * 0 20

USA AK * 50 15

USA AK * 100 10

USA HI * 0 20

USA HI * 50 15

USA HI * 100 10
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Example 2: Restrict Free Shipping to the Continental United States

You can use table rates to limit free shipping to only the continental United States, while
excluding Alaska and Hawaii.

1. Create a tablerates.csv file that includes all the state destinations to which you are willing
to provide free shipping.

2. Complete the table rate configuration with the following settings:

SETTING VALUE

Condition Price v. Destination

Method Name Free Shipping

Ship to Applicable Countries Specific Countries

Ship to Specific Countries Select only United States

Show method if not applicable No

3. Set Current Configuration Scope to the main website. Then, click the Import button to
import the tablesrates.csv file.

Table Rate in Shopping Cart
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Setting Up Table Rates
The data that is used to calculate the rate is prepared in a spreadsheet and imported into
your store. When the customer requests a quote, the results appear in the shipping
estimate section of the shopping cart.

Only one set of table rate data can be active at a time.

Process Overview:
Step 1: Complete the Default Settings
Step 2: Prepare the Table Rate Data
Step 3: Import the Table Rate Data

Step 1: Complete the Default Settings

The first step is to complete the default settings for table rates. You can complete this step
without changing the scope of the configuration.

1. On the Admin menu, select System > Configuration.

2. In the Configuration panel on the left, under Sales, select Shipping Methods.

3. Click to expand the Table Rates section. Then, do the following:

Table Rates
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a. Set Enabled to “Yes.”

b. Enter a Title for the section of table rates that appears during checkout. (The default
title is “Best Way.”)

c. Enter the Method Name that appears next to the calculated rate in the shopping cart.

d. Set Condition to one of the following calculation methods:

l Weight v. Destination

l Price v. Destination

l # of Items v. Destination

e. For orders that include virtual products, set Include Virtual Products in Price
Calculation to “Yes” if you want to be able to include the virtual product(s) in the
calculation.

Because virtual products—such as services—have no weight, they cannot change the
result of a calculation that is based on the Weight v. Destination condition. However,
virtual products can change the result of a calculation that is based on either the Price
v. Destination or # of Items vs Destination condition.

f. If charging a handling fee, set Calculate Handling Fee to one of the following:

l Fixed

l Percent

Then, enter the Handling Fee rate according to the method used to calculate the fee.

If the handling fee is based on a percent, enter the whole number without the percent
sign.

g. In the Displayed Error Message box, type the message that appears when this
method is not available.

h. Set Ship to Applicable Countries to one of the following:

All Allowed
Countries

Customers from all countries specified in your store
configuration can use this shipping method.

Specific Countries After choosing this option, the Ship to Specific Countries list
appears. Select each country in the list where this shipping
method can be used.

i. Enter a Sort Order number to determine where table rates appear in the list of
shipping methods during checkout. (0 = first, 1 = second, 2 = third, and so on.)

4. When complete, click the Save Config button.
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Step 2: Prepare the Table Rate Data

1. In the upper-left corner, set Current Configuration Scope to the “Main Website,” or any
other website where you want the configuration to apply.

Export and Import options appear in the Table Rates section, with “Use Default”
checkboxes to the right of each option. To change any of the current settings, clear the “Use
Default” checkbox next to the field.

2. If you want to change the Condition, clear the Use Default checkbox. Then, select another
option.

3. Click the Export CSV button. Then, save the tablerates.csv file to your computer.

Export CSV

4. Open the file in Excel, or any other spreadsheet program.

5. Complete the table with appropriate values for the shipping calculation condition being
used.

l You can use an asterisk (*) as a wildcard to represent all possible values in any
category.

l The Country column must contain a valid three-character code for each row.

Weight vs. Destination

6. When complete, save the tablerates.csv file.
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Step 3: Import the Table Rate Data

1. Return to the Table Rates section of your store configuration.

2. In the upper-left corner, set Current Configuration Scope to the website where this
method will be used.

3. Next to the Import field, click the Choose File button. Select your completed
tablerates.csv file, and import the rates.

Import Table Rates

4. When complete, click the Save Config button. Then, go through the payment process with
different addresses to make sure the shipping and handling rates are correct.

Online Rates
Magento offers dynamic retrieval of rates from various shipping providers. Most shipping
providers require that you open an account to use online rates. Consult your shipping
provider to learn how to obtain API credentials.

To enable and configure these shipping methods, expand the appropriate tabs (UPS, USPS,
FedEx, or DHL) and configure the settings. The configuration of this method is similar to
the configuration of a Flat Rate. The exact options depend on the service provider. To learn
more, contact the specific provider.
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Dimensional Weight
Dimensional weight, sometimes called volumetric weight, is a common industry practice
that bases the transportation price on a combination of weight and package volume. In
simple terms, dimensional weight is used to determine the shipping rate based on the
amount of space a package occupies in the cargo area of the carrier. Dimensional weight is
typically used when a package is relatively light compared to its size.

All major carriers now apply dimensional weight to some shipments. However, the manner
in which dimensional weight pricing is applied varies from one carrier to another.

l DHL

l FedEx

l UPS

l USPS

We recommend that you become familiar with the method used by each carrier to
determine and apply dimensional weight. If your company has a high volume of
shipments, even a slight difference in shipping price can translate to thousands of dollars
over the course of a year.

Magento’s native shipping configuration does not include support for dimensional weight.
However, WebShopApps has developed a Dimensional Shipping extension that manages
rates for FedEx, UPS, and USPS. WebShopApps is a Magento Technology Partner.

http://www.dhl.com/en/tools/volumetric_weight_express.html
http://www.fedex.com/br_english/rates/dimweight.html
http://www.ups.com/content/us/en/resources/ship/packaging/dim_weight.html?WT.mc_id=VAN701060#Determine+Dimensional+Weight
https://www.usps.com/ship/dimensional-weight-popup.htm
http://partners.magento.com/partner_locator/partner_details.aspx?id=89655&backUrl=%2fpartner_locator%2fsearch.aspx%3ff0%3dTypes%2bof%2bPartners%26f0v0%3dTechnology%2bPartner
http://www.webshopapps.com/us/shipping/dimensional-shipping.html
http://partners.magento.com/partner_locator/search.aspx?f0=Types+of+Partners&f0v0=Technology+Partner
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Shipping Carriers
If you have a commercial account with a supported carrier, you can offer your
customers the convenience of choosing that carrier during checkout. The rates are
automatically downloaded, so you do not need to look up the information.

Before you can offer your customers a selection of shipping carriers, you must first
complete the shipping settings to establish the point of origin for your store. Then,
complete the configuration for each carrier service that you want to offer. The
configuration options vary for each carrier. However, all require that you first open a
shipping account with the carrier, and enter your account number or user ID, and the
gateway URL to their system into the configuration of your store.

See Magento Connect for additional shipping services for your Magento Enterprise
Edition installation.

UPS

United Parcel Service offers domestic and international shipping services by land and
air to more than 220 countries.

USPS

The United States Postal Service is the independent postal service of United States
government. USPS offers domestic and international shipping services by land and air.

FedEx

Offers domestic and international shipping services by land and air to more than 220
countries.

DHL

Offers integrated international services and tailored, customer-focused solutions for
managing and transporting letters, goods and information.
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UPS
United Parcel Service offers domestic and international shipping services by land and air to
more than 220 countries.

UPS
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Process Overview:
Step 1: Open a UPS Shipping Account
Step 2: Enable UPS for Your Store
Step 3: Complete the Container Description
Step 4: Set Up Handling Fees
Step 5: Specify AllowedMethods and Applicable Countries

Step 1: Open a UPS Shipping Account

To offer this shipping method to your customers, first open an account with UPS.

Step 2: Enable UPS for Your Store

1. On the Admin menu, select System > Configuration.

2. In the Configuration panel on the left, under Sales, click Shipping Methods.

3. Click to expand the UPS section.

4. Set Enabled to “Yes.”

5. For a standard UPS account, set UPS Type to “United Parcel Service.” Then in the Gateway
URL field, enter the URL that is used to calculate UPS shipping rates. This field is preset
by default, and normally does not need to be changed.

To generate shipping labels, UPS Type must be set to “United Parcel XML.”

6. For a UPS XML account, do the following:

a. Set UPS Type to “United Parcel Service XML.”

b. Enter the following UPS credentials:

l User ID

l Access License Number

l Password

c. Set Mode to “Live” to send data to UPS over a secure connection.

d. Verify the Gateway XML URL that is required to send requests by XML file.

e. Set Order of Shipment to the region where the shipment originates.

f. If you have special rates with UPS, set Enable Negotiated Rates to “Yes.” Then, enter
the six-digit Shipper Number assigned to you by UPS.
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Step 3: Complete the Container Description

1. In the Title field, type the name of this shipping option that appears during checkout. By
default, this field is set to “United Parcel Service.”

2. Set Packages Request Type to one of the following:

l Use origin weight (few requests)

l Divide to equal weight (one request)

UPS now uses dimensional weight to determine some shipping rates.

3. In the Container field, specify the typical packaging type that is used for shipment.

4. Set Destination Type to one of the following:

Residential Most of your shipments are business to consumer (B2C1).

Commercial Most of your shipments are business to business (B2B2).

Define
Automatically

UPS determines the destination type as either residential or
commercial, and uses the appropriate rate from the merchant’s UPS
account during checkout.

5. Set Weight Unit to the system you use to measure product weight. The weight system
supported by UPS varies by country. If in doubt, ask UPS which weight system you should
use. Options include:

l LBS

l KGS

6. Set Pickup Method to one of the following:

l Regular Daily Pickup

l On Call Air

l One Time Pickup

l Letter Center

l Customer Counter

7. Enter the Maximum Package Weight allowed by the carrier.

8. Enter the Minimum Package Weight allowed by the carrier.

1Business to Consumer: Business transactions between a business entity and a consumer.
2Business to Business: A type of business transaction between two business entities that are not the final
consumers of the goods or services.
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Step 4: Set Up Handling Fees

1. Set Calculate Handling Fee to one of the following methods:

l Fixed

l Percent

2. To determine how the handling fee is applied, set Handling Applied to one of the
following:

l Per Order

l Per Package

3. Enter the amount of the Handling Fee to be charged. To enter a percentage, use the
decimal format. For example, enter 0.25 for 25%.

Step 5: Specify Allowed Methods and Applicable Countries

1. In the Allowed Methods list, select each method offered to your customers. The methods
appear under UPS during checkout. (Hold the Ctrl key down to select multiple options).

2. Set Free Method to the UPS service you want to use for offers of free shipping. Then, do one
of the following:

l Set Free Shipping with Minimum Order Amount to “Enable.” Then, enter the Minimum
Order Amount for Free Shipping.

l Set Free Shipping with Minimum Order Amount to “Disable.”

3. In the Displayed Error Message box, type the message customers see if UPS shipping
becomes unavailable.

4. Set Ship to Applicable Countries to one of the following:

All Allowed
Countries

Customers from all countries specified in your store configuration
can use this shipping method.

Specific Countries After choosing this option, the Ship to Specific Countries list
appears. Select each country in the list where this shipping method
can be used.

5. To create a log file with the details of UPS shipments made from your store, set Debug to
“Yes.”
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6. Set Show Method if Not Applicable to one of the following:

Yes To list all UPS shipping methods to customers, regardless of their
availability.

No To list only the methods which are available to customers.

7. In the Sort Order field, type a numeric value to determine the order in which UPS appears
when listed with other shipping methods during checkout. The number with the highest
priority is 0, which puts it at the top of the list.

8. When complete, click the Save Config button.
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USPS
The United States Postal Service is the independent postal service of United States
government, offering domestic and international shipping services by land and air.

USPS
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Process Overview:
Step 1: Open a USPS Shipping Account
Step 2: Enable USPS for Your Store
Step 3: Complete the Container Description
Step 4: Specify AllowedMethods and Applicable Countries

Step 1: Open a USPS Shipping Account

1. Open a USPS Web Tools account. After you complete the registration process, you will
receive your User ID and a URL to the USPS test server.

2. You can skip the testing phase, and contact their Internet Customer Care Center to request
immediate activation to the production server. The ICCC will validate your store, and send
you the URL to the production server.

To learn more about USPS Web Tools, see their Ecommerce API Technical Guides.

Step 2: Enable USPS for Your Store

1. On the Admin menu, select System > Configuration.

2. In the Configuration panel on the left, under Sales, click Shipping Methods.

3. Click to expand the USPS section. Then, do the following:

a. Set Enabled to "Yes."

b. The Gateway URL is needed to access USPS shipping rates. The field is preset by
default, and normally does not need to be changed.

c. Enter a Title for this shipping method that will appear during checkout.

d. Enter the User ID for your USPS account.

Step 3: Complete the Container Description

1. Set Container to the type of packaging usually used to ship products ordered for your
store. Options include:

l Variable

l Flat-Rate Box

l Flat-Rate Envelope

l Rectangular

l Non-Rectangular

2. Set the Size of the typical package shipped from your store. Options include:

https://secure.shippingapis.com/registration/
http://uspstechsupport@esecurecare.net/
https://www.usps.com/business/webtools-technical-guides.htm
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l Regular

l Large

l Oversize

3. Set Machinable to one of the following:

Yes If your typical package can be processed by a machine.

No If your typical package must be processed manually.

Step 4: Specify Allowed Methods and Applicable Countries

1. In the Allowed Methods list, select each USPS offered to your customers. The methods will
appear under USPS during checkout. (Hold the Ctrl key down to select multiple options).
Then, do the following:

a. Set the Free Method list to the method you want to use for free shipping. You may
also select None.

b. Set the Free Shipping with Minimum Order Amount to one of the following:

Enable Provides free shipping for orders that meet the minimum
monetary amount specified. Then in the field below, enter the
Minimum Order Amount for Free Shipping.

Disable Does not provide free shipping based on minimum order
amount.

2. The Displayed Error Message text box is preset with a default message. You can either
leave this message or you can type the message you want your customers to see if USPS
shipping becomes unavailable.

3. Set Ship to Applicable Countries to one of the following:

All Allowed
Countries

Customers from all countries specified in your store configuration
can use this shipping method.

Specific Countries After choosing this option, the Ship to Specific Countries list
appears. Select each country in the list where this shipping method
can be used.

4. Set Show Method if Not Applicable to one of the following:

Yes Lists all available USPS shipping methods during checkout, including those
that don’t apply to the shipment.

No Lists only the USPS shipping methods that are applicable to the shipment.
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5. Set Debug to “Yes” to create a log file with the details of all USPS activity related to your
store.

6. In the Sort Order field, enter a numeric value to determine the order in which USPS
shipping method appears in the list with other shipping methods during checkout. The
highest value is zero, which puts it at the top of the list.

7. When complete, click the Save Config button.
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FedEx
FedEx is one of the world’s largest shipping service companies, providing air, freight, and
ground shipping services with several levels of priorities.

FedEx
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Process Overview:
Step 1: Register for FedEx Web Services Production
Step 2: Enable FedEx for Your Store
Step 3: Complete Package Description and Handling Fee
Step 4: Specify AllowedMethods and Applicable Countries

Step 1: Register for FedEx Web Services Production

You must create a FedEx merchant account and register for FedEx Web Services Production
Access. After creating a FedEx account, read through the production account information
page, then click the Obtain Production Key link at the bottom of the page to register and
obtain a key.

Make sure to copy or write down the authentication key. You will need it to set up FedEx in your
Magento shipping settings.

Step 2: Enable FedEx for Your Store

1. On the Admin menu, select System > Configurations. Then in the Configuration panel on
the left, under Sales, select Shipping Methods.

2. Click to expand the FedEx section, and do the following:

a. To activate the FedEx shipping method, set Enabled for Checkout to "Yes."

b. Set Enabled for RMA to "Yes" or "No" depending on whether or not you want to use
this shipping method for returns.

c. Enter an appropriate Title to identify this shipping method during checkout.

d. Enter the following information from your FedEx account:

l Account ID

l Meter Number

l Key

l Password

e. If you have set up a FedEx sandbox and want to work in the testing environment, set
Sandbox Mode to "Yes."

Remember to set Sandbox Mode to "No" when you are ready to offer FedEx as a shipping
method to your customers.

https://www.fedex.com/login/web/jsp/logon.jsp?TYPE=33554432&REALMOID=06-00047ebe-e235-1f50-a0ab-0e650affb0c4&GUID=&SMAUTHREASON=0&METHOD=GET&SMAGENTNAME=-SM-OpHyFGH8DMj4DjL7QkUcaKvAJVFKOiFfZ6KRIwgidFMO8Dsr%2bC2PSJIr8eaAQQFW&TARGET=-SM-HTTPS%3a%2f%2fwww%2efedex%2ecom%2flogin%2fredirect%3fTARGET%3dHTTPS-%3A-%2F-%2Fwww%2efedex%2ecom-%2Fwpor-%2Fweb-%2Fjsp-%2Fdrclinks%2ejsp-%3Flinks-%3Dwss-%2Fproduction%2ehtml
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Step 3: Complete Package Description and Handle Fee

1. Select the Packages Request Type.

2. Select the type of Packaging typically used to ship products from your store. Options
include:

l FedEx Envelope

l FedEx Pak

l FedEx Box

l FedEx Tube

l FedEx 10kg Box

l FedEx 25kg Box

l Your Packaging

3. Set Dropoff to the pick-up method that will be used for delivery. Options include:

Regular Pickup If you have a high volume of shipments, it can be cost effective to
make arrangements with FedEx for regular pickups.

Request Courier You must call and request a FedEx courier to pick-up shipments.

Drop Box You must drop off shipments at your nearby FedEx drop box.

Business Service
Center

You must drop off shipments at your local FedEx business service
center.

Station You must drop off shipments at your local FedEx station.

4. Enter the Maximum Package Weight allowed for FedEx shipments. The default FedEx
maximum weight is 150 lbs. Please consult your shipping carrier for more information. We
recommend using the default value, unless you have made special arrangements with
FedEx.

FedEx now uses dimensional weight to determine some shipping rates.

5. An optional handling fee can be added to the amount charged by FedEx, which is not t
visible during checkout. If you want to charge a handling fee, do the following:

a. Set Calculate Handling Fee to one of the following:

l Fixed Fee

l Percentage

b. In the Handling Applied list, choose one of the following methods for managing
handling fees:
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l Per Order

l Per Package

c. Enter the Handling Fee as either a fixed amount or percentage, depending on the
method of calculation.

6. Set Residential Delivery to one of the following, depending on whether you sell Business-
to-Consumer (B2C1) or Business-to-Business (B2B2).

Yes For B2C residential deliveries.

No For B2B residential deliveries.

Step 4: Specify Allowed Methods and Applicable Countries

1. Set Allowed Methods to each method of shipment that you want to offer. When choosing
methods, take into consideration your FedEx account, the frequency and size of your
shipments, and if you allow international shipments. You can offer as many or as few
methods as you want.

2. To set up free shipping through FedEx, do the following:

a. Set Free Method to any shipping method that you want to offer your customers at no
charge. You may also select None. This is similar to Free Shipping, however it is listed
in the FedEx section, so customers will know exactly which method is being used for
their order.

b. The Free Shipping with Minimum Order Amount option allows you to offer free
FedEx shipping for orders that meet a minimum amount.

Enable Lets you set the minimum amount for orders to qualify for free
shipping.If an order does not meet the minimum amount,
FedEx Free Shipping will still appear as an option,however it
will be set to an amount determined by FedEx.

Disable Does not let you set a minimum amount for orders to qualify
for free shipping.

c. If you choose "Enable," enter the minimum order amount in the Minimum Order
Amount for Free Shipping.

d. The Displayed Error Message text box is preset with a default message. You can leave
this as is or edit as needed.

e. Set Ship to Applicable Countries to one of the following:

1Business to Consumer: Business transactions between a business entity and a consumer.
2Business to Business: A type of business transaction between two business entities that are not the final
consumers of the goods or services.
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All Allowed
Countries

Customers from all countries specified in your store
configuration can use this shipping method.

Specific Countries After choosing this option, the Ship to Specific Countries list
appears. Select each country in the list where this shipping
method can be used.

f. Set Debug to "Yes" or "No."

g. Set Show Method if Not Applicable to one of the following:

Yes To list all UPS shipping methods to customers, regardless of their
availability.

No To list only the methods which are available to customers.

h. Enter a Sort Order numeric value to determine the sequence in which UPS appears
when listed with other shipping methods during checkout. The number with the
highest priority is 0, which puts it at the top of the list.

3. When the configuration is complete, click the Save Config button.
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DHL
DHL offers integrated international services and tailored, customer-focused solutions for
managing and transporting letters, goods and information.

DHL
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Process Overview:
Step 1: Enable DHL for Your Store
Step 2: Complete Package Description and Handling Fee
Step 3: Specify Allowed ShippingMethods
Step 4: Specify Applicable Countries

Step 1: Enable DHL for Your Store

1. On the Admin menu, select System > Configuration.

2. In the panel on the left, under Sales, select Shipping Methods.

3. Click to expand the DHL section. Then, do the following:

a. Set Enabled for Checkout to "Yes."

b. In the Title field, type a name that will be used to refer to this shipping method
during checkout.

c. In most cases, you can accept the default Gateway URL. However, if DHL has given
you an alternate URL, enter the value in this field.

d. Use the credentials provided by DHL to complete the following fields:

l Access ID

l Password

l Account Number

Step 2: Complete Package Description and Handling Fee

1. In the Content Type list, select the option that best describes the type of package you ship:

l Documents

l Non documents

2. The handling fee is optional, and appears as an additional charge that is added to the
DHL shipping cost. If you want to include a handling fee, do the following:

a. In the Calculate Handling Fee list, select the method you want to use to calculate
handling fees:

l Fixed

l Percentage
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b. In the Handling Applied list, select how you want the handling fees applied:

l Per Order

l Per Package

c. In the Handling Fee field, enter the amount to be charged, based on the method you
have chosen to calculate the amount. For example, if the charge is based on a fixed
fee, enter the amount as a decimal, such as: 4.90. However, if the handling fee is
based on a percentage of the order, enter the amount as a percentage. For example, if
you are charging six percent of the order, enter the value as: .06.

3. To allow the total order weight to be broken up to ensure an accurate calculation of
shipping charges, .set Divide Order Weight to "Yes." Then, set theWeight Unit of the
package to one of the following:

l Pounds

l Kilograms

4. Set the Size of the package to one of the following:

l Regular

l Specific

If you are using Specific, enter the Height, Depth, and Width of the package. Specify these
numbers in centimeters.

Step 3: Specify Allowed Shipping Methods

1. In the Allowed Methods list, select each shipment method that you support. (Hold the
Ctrl key down to select multiple options.)

To display the correct list of shipping methods, you must first specify the Country of
Origin in Shipping Settings.

2. Enter the Ready Time in hours after submission, that it takes for a package to be ready to
ship.

3. Edit the Displayed Error Message as needed. This message appears when a selected
method is unavailable.

4. In the Free Method list, select the shipping method you prefer to use for offers of free
shipping. Then, set the Free Shipping with Minimum Order Amount to one of the
following:

Enable If offering Free Shipping with Minimum Order, enter the Minimum
Order Amount for Free Shipping.

Disable Does not apply free DHL shipping to any orders.
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This is similar to the standard Free Shipping method, but appears in the DHL section so
customers know which method is used for their order.

5. Enter the Minimum Order Amount for Free Shipping that must be met for a package to
qualify.

Step 4: Specify Applicable Countries

1. Set Ship to Applicable Countries to one of the following:

All Allowed
Countries

Customers from all countries specified in your store configuration
can use this shipping method.

Specific Countries After choosing this option, the Ship to Specific Countries list
appears. Select each country in the list where this shipping method
can be used.

2. Set Show Method if Not Applicable to one of the following:

Yes Displays all options,even if not applicable to the order.

No Displays only applicable options.

3. In the Sort Order field, type a numeric value to determine the sequence in which DHL
appears when listed with other shipping methods during checkout.

4. To create a log file with the details of DHL shipments made from your store, set Debug to
“Yes.”

5. When complete, click the Save Config button to save your changes.
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Package Type by Carrier
The following tables list the shipping methods and supported package types for U.S. and
international shipments, by carrier.

l Custom packaging has been added to each shipping method of each shipping carrier.

l Shipping methods are divided into U.S. and International. Those that are marked as
“U.S.” are for US domestic shipments only. Those that are marked as "International" can
be those shipped from the U.S. to other countries, from other countries to the U.S. and
within countries other than the U.S. FedEx does not offer domestic shipments for
countries other than the U.S. at this time. USPS offers shipments from the U.S. only for
both domestic and international.

l For international shipping, available package types sometimes depend on the country of
origin (U.S. or other). If a shipment originates outside of the U.S., the available package
types are filtered according to the types that are acceptable. For shipments that
originate in countries other than the U.S., the full list of package types available for the
selected shipping carrier is provided.

FedEx (U.S.)

SHIPPING METHOD PACKAGE TYPE

FedEx First Overnight FedEx Envelope
FedEx Pak
FedEx Box
FedEx Tube
Your Packaging

FedEx Priority Overnight (same as above)

FedEx Standard Overnight (same as above)

FedEx 2Day (same as above)

FedEx Express Saver FedEx Envelope

FedEx Pak

Your Packaging

FedEx Ground
FedEx HomeDelivery
FedEx SmartPost

Your Packaging

Shipping Methods
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FedEx (International)

SHIPPING METHOD PACKAGE TYPE

FedEx International First FedEx Envelope
FedEx Pak
FedEx Box
FedEx Tube
Your Packaging

FedEx International Priority FedEx Envelope
FedEx Pak
FedEx Box
FedEx 10 kg Box
FedEx 25 kg Box
FedEx Tube
Your Packaging

FedEx International Ground Your Packaging

FedEx Europe First Priority FedEx Envelope
FedEx Pak
FedEx 10 kg Box
FedEx 25 kg Box
Your Packaging

Shipping Methods

UPS (U.S.)

SHIPPING METHOD PACKAGE TYPE

UPS Next Day Air Early AM Small Express Box
Medium Express Box
Large Express Box
UPS Express Tube
UPS Pak
UPS Letter
Your Packaging

UPS 2nd Day Air (same as above)

Shipping Methods
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SHIPPING METHOD PACKAGE TYPE

UPS Next Day Air (same as above)

UPS 2nd Day Air AM (same as above)

UPS 3Day Select Your Packaging

UPS Ground Your Packaging

Shipping Methods (cont.)

UPS (International)

SHIPPING METHOD PACKAGE TYPE

UPSWorldwide Express Small Express Box
Medium Express Box
Large Express Tube
UPS Express Tube
UPS 10 kg Box
UPS 25 kg Box
UPS Pak
UPS Letter
Customer Packaging

UPSWorldwide Express Plus (same as above)

UPSWorldwide Saver (same as above)

UPSWorldwide Expedited (same as above)

UPSWorldwide Expedited Small Express Box
Medium Express Box
Large Express Tube
UPS Express Tube
UPS 10 kg Box
UPS 25 kg Box
UPS Pak
Customer Packaging

Shipping Methods
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USPS (International)

SHIPPING METHOD PACKAGE TYPE

Express Mail® International
Flat Rate Envelope

Express Mail International Flat Rate Envelope

Express Mail Flat Rate
Envelop Hold for Pickup

Express Mail International Flat Rate Envelope

Priority Mail International
Large Flat Rate Box

Priority Mail International Medium Flat Rate Box

Priority Mail International
Small Flat Rate Box

Priority Mail International Small Flat Rate Box

Priority Mail International
Flat Rate Envelope

Priority Mail International Flat Rate Envelope

Global Express Guaranteed
(GXG)

Large Package/Non-Rectangular (Regular andMedium)
Variable

USPS GXGEnvelopes Large Package/Rectangular (Regular andMedium)
Large Package/Non-Rectangular (Regular andMedium)
Variable

Express Mail International (same as above)

Priority Mail International (same as above)

First-Class Mail
International Package

(same as above)

Shipping Methods

DHL (International)

SHIPPING METHOD PACKAGE TYPE

Express Package

Express International Letter

Shipping Methods
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Notes
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CHAPTER 61:

Shipping Labels
Magento Enterprise Edition includes a high level of integration with major shipping
carriers, which gives you access to carrier shipping systems to track orders, create
shipping labels, and more. Shipping labels can be created for regular shipments and
products with return merchandise authorization. In addition to the information
provided by the shipping carrier, the label also includes the Magento order number,
number of the package, and the total quantity of packages for the Magento shipment.

Topics in this chapter:

l Shipping Label Setup

l Creating Shipping Labels

l Package Configuration

USPS Priority Shipping Label
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Shipping Label Workflow
Shipping labels can be produced at the time a shipment is created, or later. Shipping labels
are stored in PDF format and downloaded to your computer. Depending on your browser
settings, you can open the file at once and print the labels. Each shipping label appears on
a separate page in the PDF file.

Create Shipping Label
When you create a shipping label, Magento prompts you for information about packaging
you want to use (type, size, etc.) and which products go with which package. When you
finish, Magento connects to the shipping carrier web-services, creates an order in its
system, and receives the shipping and tracking number(s) for the shipment.

After the shipping label is generated, the new shipment is saved and the label can be
printed. If the shipping label cannot be created due to problems with connection or any
other reason, the shipment is not created.

Tracking Number
Magento receives the tracking numbers related to the shipment when labels are generated.
and inserts the numbers into the Shipping and Tracking Information section. If you
generate the same shipping labels multiple times, the original tracking numbers are
preserved.

Returned Merchandise
The logic for tracking numbers differs when shipping labels are created for merchandise
returns from RMA managing pages. In this case, old tracking numbers are replaced with
new ones.
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Shipping Label Configuration
The following settings must be made at the product level, as well as in the configuration of
each carrier. All carriers require that you open an account. It is recommended that you
complete the configuration in your store for each carrier that you plan to use.

To configure shipping labels:

1. On the Admin menu, select Catalog > Manage Products.

2. The Country of Manufacture field is required for each product that is shipped
internationally by USPS and FedEx, Update the field for each product record, as needed.

Country of Manufacture

3. When complete, click the Save button.

If you have many products that need to be updated with the same information, do the
following:

a. In the Manage Products list, select the checkbox of each product that needs to be
updated. For example, all products that are manufactured in China.

b. Set the Actions control to “Update Attributes,” and click the Submit button.

c. In the Update Attributes form, find the Country of Manufacture field and select the
Change checkbox. Then, select the country from the list and click the Save button.

4. On the Admin menu, select System > Configuration. Then, do the following:

a. In the panel on the left, under Sales, select Shipping Settings. Click to expand the
Origin section, and verify that the following fields are complete:

Street Address The street address of the place from which shipments
are sent. For example, the location of your company or
warehouse. This field is required for shipping labels.

Street Address Line 2 Any additional address information, such as the floor,
entrance and so on. We strongly recommend that you
use this field.
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Origin

b. In the Configuration panel under Sales, select Shipping Methods. Click to expand the
USPS section, and verify that the following fields are complete:

Secure Gateway URL You do not need to configure this field, it is pre-
populated by Magento.

Password The password is provided by USPS, and gives you access
to their system through Web Services.

Length, Width

Height, Girth

The default dimensions of the package. To make these
fields appear, set Size to “Large.”

c. Click to expand the FedEx section, and verify that the following fields are complete:

l Meter Number

l Key

l Password

This information is provided by the carrier, and is required to gain access to their
system through Web Services.

d. In the Configuration panel under General, select Store Information. Verify that the
fields in this section are complete. If you have multiple stores, and the contact
information differs from the default, set Current Configuration Scope to the store
view and verify that the information is complete. If any of this information is missing,
an error message will appear when you try to print shipping labels.

Store Name The name of the store or store view.

Store Contact Telephone The telephone number of the primary contact for the
store or store view.

Country The country where your store is based.

VAT Number If applicable the Value Added Tax number of your store.
(Not required for stores based in the U.S.)

Store Contact Address The street address of the primary contact for the store or
store view.

http://merch.docs.magento.com/ee/user_guide/Magento_Enterprise_Edition_User_Guide.html#configuration/sales/shipping-settings.html%23Origin
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Store Information

5. When complete, click the Save Config button.

CARRIER REQUIREMENTS

USPS Requires a USPS account.

UPS Requires a UPS account. Shipping labels are available only for
shipments that originate in the U.S. Specific credentials are required for
stores outside the US.

FedEx Requires a FedEx account. For stores outside of the U.S., shipping
labels are supported for international shipments only. FedEx does not
allow domestic shipments that originate outside of the U.S

DHL Requires a DHL account. Shipping labels are supported only for
shipments that originate in the U.S.

Carrier Requirements

937Magento Enterprise Edition User Guide, Version 1.14.2.1

http://merch.docs.magento.com/ee/user_guide/Magento_Enterprise_Edition_User_Guide.html#configuration/general/general.html%23Store_Information


Creating Shipping Labels CHAPTER 61:  Shipping Labels

938 Magento Enterprise Edition User Guide, Version 1.14.2.1

Creating Shipping Labels
You can easily create shipping labels for new and existing orders from the Admin of your
store. To create shipping labels, you must first set up your shipping carrier account to
support labels. Then, follow the prompts to enter a description of the package and its
contents. Magento contacts the shipping carrier, creates an order in the carrier’s system,
and receives a shipping label and tracking number for the shipment.

An individual order is created for each package shipped. A single shipment with multiple
packages receives multiple shipping labels.

Process Overview:
Step 1: Contact Your Shipping Carriers
Step 2: Update the Configuration for Each Carrier
Step 3: Create Shipping Labels
Step 4: Print Shipping Labels

Step 1: Contact Your Shipping Carriers

Before you begin, make sure that your shipping accounts are set up to process labels. Some
carriers might charge an additional fee to add shipping labels to your account.

1. Contact each carrier that you use to activate shipping labels for your store.

2. Follow the instructions provided by each carrier to add shipping label support to your
account.

FedEx Contact FedEx Web Services regarding their label evaluation process.

USPS Contact uspstechsupport@esecurecare.net to request that API Signature
Confirmation V3 be enabled for your live USPS API Access account.

UPS Contact UPS to confirm your account type supports shipping labels. To
generate shipping labels, you must use the UPS XML option.

DHL Contact the DHL Resource Center to learn more about their services or
send an inquiry through their Contact Center.

Step 2: Update the Configuration for Each Carrier

1. Make sure that your Store Information is complete.

2. Follow the instructions below for each carrier account that has been activated for label
printing.

http://www.fedex.com/us/web-services/index.html
mailto:uspstechsupport@esecurecare.net
http://www.ups.com/?Site=Corporate&cookie=us_en_home&setCookie=yes
http://www.dhl-usa.com/en/contact_center.html
http://www.dhl-usa.com/en/contact_center.html
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UPS Configuration

United Parcel Service ships both domestically and internationally. However, shipping
labels can be generated only for shipments that originate within the United States.

1. On the Admin menu, select System > Configuration.

2. In the panel on the left, under Sales, select Shipping Methods.

3. Click to expand the UPS section. Then, verify that your UPS Shipper Number is correct.
Your Shipper Number appears only when United Parcel Service XML is enabled.

4. When complete, click the Save Config button.

USPS Configuration

The United States Postal Service ships both domestically and internationally.

1. On the Admin menu, select System > Configuration.

2. In the Configuration panel on the left, under Sales, select Shipping Methods.

3. Click to expand the USPS section. Then, do the following:

a. Verify that the Secure Gateway URL is entered. The correct URL should be entered
automatically.

b. Enter the Password provided to you by USPS.

c. Set Size to “Large.” Then, enter the following dimensions:

l Length

l Width

l Height

l Girth

4. When complete, click the Save Config button.

939Magento Enterprise Edition User Guide, Version 1.14.2.1



Creating Shipping Labels CHAPTER 61:  Shipping Labels

940 Magento Enterprise Edition User Guide, Version 1.14.2.1

FedEx Configuration

FedEx ships domestically and internationally. Stores located outside the United States can
create FedEx labels for international shipments only.

1. On the Admin menu, select System > Configuration.

2. In the panel on the left, under sales, select Shipping Methods.

3. Click to expand the FedEx section. Then, make sure that the following FedEx credentials
are correct:

l Meter Number

l Key

l Password

4. When complete, click the Save Config button.

DHL Configuration

DHL provides international shipping services.

1. On the Admin menu, select System > Configuration.

2. In the panel on the left, under sales, select Shipping Methods.

3. Click to expand the DHL section. Then, do the following:

a. Verify that the Gateway URL is entered. The correct URL should be entered
automatically.

b. Make sure that the following credentials are complete:

l Access ID

l Password

l Account Number

4. When complete, click the Save Config button.
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Step 3: Create Shipping Labels

Process Overview:
Method 1: Create Label for New Shipment
Method 2: Create Label for Existing Shipment

Method 1: Create Label for New Shipment

1. On the Admin menu, select Sales > Orders.

2. Find the order in the list, and click to open the record. The status of the order must be
either “Pending” or “Processing.”

3. In the upper-right corner, click the Ship button. Then, confirm the shipping
information according to carrier requirements.

4. In the lower-right corner, select the Create Shipping Label checkbox. Click the
Submit Shipment button, and do the following:

a. To add products from the order to the package, click the Add Products button.
The Quantity column shows the maximum number of products that are available
for the package.

b. Select the check box of each product to be added to the package and enter the
Quantity of each. Then, click the Add Selected Product(s) to Package button.

l To add a new package, click the Add Package button.

l To delete a package, click the Delete Package button.

If you use a package type other than the default, or require a signature, the cost of
shipping might differ from what you have charged the customer. Any difference in the
cost of shipping is not reflected in your store.

5. When complete, click OK.

l If you need to cancel an order, click the Cancel button. A shipping label will not be
created, and the Create Shipping Label checkbox is cleared.

6. Magento now connects to the shipping carrier system, submits the order, and receives
a shipping label and tracking number for each package.

l If the label is successfully created, the shipment is submitted, the tracking number
appears in the form, and the label is ready to print.

l If the carrier cannot create the label due to the problems with connection, or for any
other reason, the shipment is not processed.
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Method 2: Create Label for Existing Shipment

1. On the Admin menu, select Sales > Orders.

2. Find the order in the list and click to open the Shipping form. Then, do the following:

a. In the Shipping and Tracking Information section, click the Create Shipping
Label button.

b. Distribute the ordered product(s) to the appropriate package(s), and click OK.

c. To review the package information, click the Show Packages button.

Magento connects to the shipping carrier system, submits an order, and receives a
shipping label and a tracking number.

If a shipping label for this shipment already exists in the system, it is replaced with a
new one. However, existing tracking numbers are not replaced. Any new tracking
number is added to the existing one.

Step 4: Print Shipping Labels

Shipping labels are generated in PDF format, and can be printed from the Admin. Each
label includes the order number and package number.

Because an individual shipment order for each package is created, multiple shipping labels
might be received for a single shipment.

Process Overview:
Method 1: Print Label from Shipment Form
Method 2: Print Labels for Multiple Orders
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Method 1: Print Label from Shipment Form

1. On the Admin menu, do one of the following:

l Select Sales > Orders. Find the order in the list, and click to open the record. In the
Order View panel on the left, select Shipments. Then, click to open the shipment
record.

l Select Sales > Shipments. Find the order in the list, and click to open the record.

2. To download the PDF file, go to the Shipping and Tracking section of the form and
click the Print Shipping Label button. Depending on your browser settings, the
shipping labels can be viewed and printed directly from the PDF file.

The Print Shipping Label button appears only after the carrier has generated labels for the
shipment. If the button is missing, click the Create Shipping Label button. The button
will appear after Magento receives the label from the carrier.

Method 2: Print Labels for Multiple Orders

1. On the Admin menu, do one of the following:

l Select Sales > Orders.

l Select Sales > Shipments.

2. In the list, select the checkbox of each order that has shipping labels to be printed.

3. In the upper-right corner, set the Actions control to "Print Shipping Labels."

4. Click the Submit button.

A complete set of shipping labels is printed for each shipment that is related to the
selected orders.

SETTING DESCRIPTION

Type Package types differ by carrier andmethod. The default package
type for each carrier is initially selected.
USPS does not require the package type for domestic
shipments.

Customs Value (International shipments only) The declared value or sales price
of the contents of an international shipment.

Total Weight The total weight of all products added to the package is
calculated automatically. The value can also be changed
manually, and entered as pounds or kilograms.

Required Carrier Configuration Settings
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SETTING DESCRIPTION

Length, Width, Height (Optional) The package dimensions are used for custom
packages only. You can specify themeasurements units as
inches or centimeters.

Not Required No confirmation of delivery is sent to the
store by the shipping carrier.

No Signature A delivery confirmation without the
signature of the recipient is sent to the
store by the shipping carrier.

Signature Required The shipping carrier obtains the
signature of the recipient and provides
the store with a printed copy.

Direct (FedEx Only) FedEx obtains a signature
from someone at the delivery address. If
no one is available to sign for the
package, the carrier tries to deliver the
package at another time.

Indirect (FedEx Residential Deliveries Only)
FedEx obtains the signature of
someone, possibly a neighbor or building
manager, at the delivery address. The
recipient can leave a signed FedEx door
tag to authorize the package to be left
without anyone present to sign for it.

Contents (USPS Only) Select one of the following
descriptions of the package:
Gift
Documents
Commercial Sample
ReturnedGoods
Merchandise
Other

Explanation (USPS Only) A detailed description of
the package contents.

Adult Required The shipping carrier obtains the
signature of an adult recipient and
provides the store with a printed copy.

Required Carrier Configuration Settings (cont.)
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Package Configuration
The Create Packages window appears when you choose to create a shipping label. You can
start configuring the first package at once.

Create Packages

To configure a package:

1. Complete the fields as described below.

If you select the non-default value in the Type field or choose to require a signature
confirmation, the price of a shipment may differ from the one you charged to the customer.

2. To view a list of shipped products and add them to the package, click the Add Products
button.

The Qty column is pre-populated with the maximum available quantity to add (for the
Package 1 this number is equal to the total shipped quantity of the product).

3. Specify the products and quantities. To add the products to the package, click the Add
Selected Product(s) to Package button in the header of the grid. The products are added to
the package.

l To add a new package, click the Add Package button in the window header. You can
add several packages, and edit them simultaneously.

l To delete a package, click the Delete Package button.

After products have been added to the package, the quantity cannot be edited directly.

To increase the quantity:

1. Click the Add Selection button.

2. Enter the additional quantity.

The number is added to the previous quantity of the product in the package.
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To decrease the quantity:

1. Delete the product from the package.

2. Click the Add Selection button.

3. Enter the new, smaller value.

After you distribute all products, the total number of the packages you are going to use
equals the number of the last package in the list. The OK button is disabled until all
shipped items are distributed between packages and all necessary information is specified.

4. When complete, click the OK button to generate the labels.

If you need to stop the process, click the Cancel button. The packages are not saved, and
the shipping label creation is canceled.

FIELD DESCRIPTION

Type Specifies the type of a package. Select one of the predefined
values. Available package types are different for each shipping
carrier.
When the Create Packages pop-up window opens, the default
package for the shipping carrier appears in the Type field. If you
select a package that is not designed by a shipping carrier, you
must enter the dimensions of the package.
For shipping labels created for DHL, FedEx, and UPS
shipments, the “Type of Goods” field is set to “Merchandise.” For
USPS, the Type field reflects the value from the Contents field in
the Create Packages window.

Total Weight The total weight of a package. The field is pre-populated with the
total weight of products in a package. The unit of measurement
can be set to either pounds or kilograms.

Length The length of a package, integer and floating point numbers. The
field is enabled if the custom package type is used. The unit of
measurement can be set to either inches or centimeters.

Field Descriptions
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FIELD DESCRIPTION

Width The width of a package, integer and floating point numbers. The
field is enabled if the custom package type is used. The
measurement units can be specified using the drop-downmenu
next to the Height field; select between inches and centimeters.

Height The height of a package, integer and floating point numbers. The
field is enabled if the custom package type is used. The
measurement units can be specified using the drop-downmenu
next to the Height field; select between inches and centimeters.

Signature Confirmation Defines delivery confirmation. Options include:

Not Required No delivery confirmation letter is sent to
you.

No Signature A delivery confirmation letter without a
recipient’s signature is sent to you.

Signature Required The shipping carrier obtains the
recipient’s signature and provides you
with its printed copy.

Adult Required The shipping carrier obtains the adult
recipient’s signature and provides you
with its printed copy.

Direct (FedEx only) FedEx obtains a signature from
someone at the delivery address and
reattempts delivery if no one is available
to sign for the package.

Indirect (FedEx
only)

FedEx obtains a signature in one of three
ways: (1) from someone at the delivery
address; (2) from a neighbor, building
manager or other person at a neighboring
address; or (3) the recipient can leave a
signed FedEx Door Tag authorizing
release of the package without anyone
present. Available for residential
deliveries only.
The options may vary slightly for
different shippingmethods. For themost
up to date information refer to shipping
carrier’s resources.

Field Descriptions (cont.)
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FIELD DESCRIPTION

Contents (Available for USPS shipments only) Description of the package
contents. Options include:
Gift
Documents
Commercial Sample
ReturnedGoods
Merchandise
Other

Explanation (USPS shipments only) Detailed description of the package
content.

Field Descriptions (cont.)
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CHAPTER 62:

Managing Taxes
Magento provides a variety of options for defining taxes that can be accessed by
selecting the Sales menu and then the Tax option. Tax classes are used to define “tax
rules.” Tax rules are defined as a combination of a Product Class, a Customer Class and
a Tax Zone and Rate, as described in this chapter.

Each type of customer can be assigned a customer class when you define them, and
each product is assigned a tax class. Magento analyzes the shopping cart of each
customer and calculates the appropriate tax according to the class of the customer, the
class of the products in the shopping cart, and the region (as defined by the customer’s
shipping address, billing address or shipping origin).

Magento also supports the calculation of Value-Added Tax (VAT) for business-to-
business transactions in the European Union.

Topics in this chapter:

l General Tax Settings

l Tax Classes

l Tax Zones & Rates

l Tax Rules

l Cross-Border Price Consistency

l Fixed Product Tax (FPT)

l Compound Taxes

l Value Added Tax (VAT)
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General Tax Settings
The following instructions take you through the basic tax setup for your store. Before
setting up your taxes, make sure that you are familiar with the tax requirements of your
locale. Then, you can complete the tax configuration as needed for your store.

Tax Configuration

Admin permissions can be set to restrict access to tax resources, based on the business
“need to know.” To create an Admin role with access to tax settings, select both the
Sales/Tax and System/Tax resources. If setting up a website for a region that differs from
your default shipping point of origin, you must also allow access to the System/Shipping
resources for the role, because the shipping settings determine the store tax rate used for
catalog prices.

Process Overview:
Step 1: Set Up Tax Classes
Step 2: Complete the Calculation Settings
Step 3: Complete the Display Settings
Step 4: Complete the Fixed Product Tax Settings

To complete the general tax configuration:

1. On the Admin menu, select System > Configuration.

2. In the panel on the left, under Sales, select Tax. Then, follow the steps below.

3. When complete, click the Save Config button.

http://merch.docs.magento.com/ee/user_guide/Magento_Enterprise_Edition_User_Guide.html#configuration/sales/tax.html
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Step 1: Set Up Tax Classes

1. Click to expand the Tax Classes section.

Tax Classes

2. Set Tax Class for Shipping to the appropriate class. The default classes are:

l Taxable Goods

l Shipping

l Tax Exempt

3. Set Tax Class for Gift Options to the appropriate class. The default classes are the same.

Step 2: Complete the Calculation Settings

1. Click to expand the Calculation Settings section. Then, do the following:

Calculation Settings

a. In the Tax Calculation Method Based On field, select whether the tax is based on the
price of each unit, or on the “row total” (that is, the total for a line item in the order,
accounting for any discounts).

b. In the Tax Calculation Based On field, select whether the tax is calculated based on
the customer’s shipping address, billing address, or your store’s shipping origin.
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c. In the Catalog Prices field, specify whether the catalog prices of items include tax or
exclude tax.

d. In the Shipping Prices field, select whether the shipping amounts include tax or
exclude tax.

e. In the Apply Customer Tax field, select whether tax is applied to the original or
discounted price.

f. In the Apply Discount on Prices field, select whether any discounts applied include
the tax or exclude it.

g. In the Apply Tax On field, select whether tax is applied to custom prices or to original
prices.

h. In the Enable Cross Border Trade field, select “Yes” to use consistent pricing across
different tax rates, or select “No” to vary the price by tax rate.

Important! If cross-border trade is enabled, the profit margin changes by tax rate. Profit is
determined by the formula (Revenue - CustomerVAT - CostOfGoodsSold). To enable
cross-border trade, you must set prices to include tax.

2. Click to expand the Default Tax Destination Calculation section. Then, specify which
country is used by Magento as the default for tax calculations.

Default Tax Destination Calculation

Step 3: Complete the Price Display Settings

Important! Some combinations of settings related to a price display that both includes and
excludes tax can be confusing to the customer. To avoid triggering a warning message, see the
recommended settings.

1. Click to expand the Price Display Settings section Then, do the following:

Price Display Settings

http://merch.docs.magento.com/ee/user_guide/Magento_Enterprise_Edition_User_Guide.html#configuration/sales/tax.html%23Default_Tax_Destination_Calculation
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a. Set Display Product Prices in Catalog to one of the following:

l Excluding Tax

l Including Tax

l Including and Excluding Tax

If you set the Display Product Prices field to “Including Tax,” the tax appears only if
there is a tax rule that matches the tax origin, or if Magento detects that the customer
address matches the tax rule. This can happen after a customer creates an account,
logs in, or uses the Tax and Shipping estimation tool in the cart.

b. Set Display Shipping Prices to one of the following:

l Excluding Tax

l Including Tax

l Including and Excluding Tax

2. Click to expand the Shopping Cart Display Settings section.

For each section listed, chose how you want taxes and prices to be shown for products in a
shopping cart, according to the requirements of your store and locale.

Shopping Cart Display Settings

3. Click to expand the Orders, Invoices, Credit Memos Display Settings section. Then, select
how prices and taxes are displayed in orders, invoices, and credit memos.

Orders, Invoices, Credit Memos Display Settings
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Step 4: Complete the Fixed Product Tax Settings

1. Click to expand the Fixed Product Taxes section.

2. Specify the behavior of fixed tax per product, such as the European DEEE/WEEE (Waste
Electrical and Electronic Equipment) tax, as required.

Fixed Product Taxes

Tax Classes
Magento analyzes the shopping cart of each customer and calculates the appropriate tax
according to the class of the customer, the class of the products in the shopping cart, and
the region (as defined by the customer’s shipping address, billing address or shipping
origin).

Every product and customer is assigned a tax class. Tax classes, in turn, are used to define
tax rules. Tax rules are a combination of a customer tax class, product tax class, and tax
rates. The two basic types of tax classes are:

l Product Tax Classes

l Customer Tax Classes

Product Tax Classes
Create product tax classes and assign products to them by product type. For example, food
might not be taxed (or might be taxed at a different rate). If your store charges an
additional tax on shipping, you should designate the product tax class for shipping.

Product Tax Classes
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To define a product tax class:

1. On the Admin menu, select Sales > Tax > Product Tax Class.

2. In the upper-right corner, click the Add New button.

Product Tax Class Information

3. Enter a Class Name for this tax class.

You can apply a tax class to a product by editing the product and choosing the appropriate
option on the Prices tab.

4. When complete, click the Save Class button.

Shipping Tax Class
A separate product class can be set up for shipping. Then, you must identify it in the
configuration as the tax class that is used for shipping.

Step 1: Set Up a Product Tax Class for Shipping

1. On the Admin menu, select Sales > Tax > Product Tax Class.

2. In the upper-right corner, click the Add New button.

3. Enter a Class Name for the new tax class. For example, “Shipping.”

Product Tax Class for Shipping

4. When complete, click the Save Class button.

Step 2: Configure the Shipping Tax Class

1. On the Admin menu, select System > Configuration.

2. In the panel on the left, under Sales, select Tax.

3. Click to expand the Tax Classes section.

4. Set Tax Class for Shipping to the class you created for shipping.
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Tax Classes

5. When complete, click the Save Config button.

Customer Tax Classes
You can create the customer tax classes you need, and then assign them to customer
groups. For example, in some jurisdictions, wholesale transactions are not taxed, but retail
transactions are. Members of the Wholesale Customer group can be associated with the
Wholesale tax class.

Customer Tax Classes

To define a customer tax class:

1. On the Admin menu, select Sales > Tax > Customer Tax Classes.

2. In the upper-right corner, click the Add New button.

Customer Tax Class Information

3. Enter a Class Name for this tax class.

4. When complete, click the Save Class button.
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To apply a tax class to a customer group:

1. On the Admin menu, select Customers > Customer Groups.

Customer Groups

2. Do one of the following:

l To create a new group, click the Add New Customer Group button.

l To edit an existing group, click to open the group in edit mode.

3. If creating a new group, enter a unique Group Name that is less than 32 characters.

4. Select the Tax Class that applies to the group.

Group Information

5. When complete, click the Save Customer Group button.
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Tax Zones & Rates
Tax rates are generally applicable to transactions that take place in specific geographical
areas. The Tax Zones and Rates tool enables you to specify the tax rate for each
geographical area for which you collect and remit taxes. Because you give each tax zone
and rate specification a unique identifier, you can have multiple tax rates for a given
geographic area (for example, for places that do not tax food or medicine but tax other
products). When numerous taxes must be defined, you can simplify the process by
importing the tax data from a spreadsheet. Select Sales > Tax > Import/Export Tax Rates.

Manage Tax Zones & Rates

To define tax zones and rates:

1. On the Admin menu, select Sales > Tax > Manage Tax Zones & Rates.

2. In the upper-right corner, click the Add New Tax Rate button.

Tax Rate Information

3. In the Tax Rate Information section, do the following:
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a. In the Tax Identifier field, enter a unique name for this tax. Do not use spaces. This
identifier is not shown in the store if the Tax Titles section is completed, as described
below.

b. Select the location of the Country and State. (Starting in EE 1.13.1, you can use the
wildcard character * for State.)

c. Do one of the following:

l If you want the ZIP or postal code represented as an individual code, set Zip/Post is
Range, to “No.” Then, enter the Zip/Post Code.

l If you want the ZIP or postal code represented as a range, set Zip/Post is Range to
“Yes.” Then, enter the Range From and Range To values.

The wildcard character * can be used to represent all values. For example, 90* means all
ZIP codes from 90000 through 90999.

d. In the Rate Percent field, enter the percentage of tax.

4. In the Tax Titles section, enter a name of this tax for each store view.

Tax Titles

5. When complete, click the Save Rate button.
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Importing and Exporting Tax Rates
If you have nexuses in several states and ship a large volume of product, you might
consider downloading a tax rate by ZIP code data set. The rates can then be imported into
Magento. In the following example, we import a set of California tax rates that was
downloaded from the Avalara website. Avalara provides tax rate tables that can be
downloaded at no charge for every ZIP code in the United States. Avalara is a Magento
Technology Partner.

Import / Export Tax Rates

Step 1: Export the Magento Tax Rate Data

1. On the Admin menu, select Sales > Tax > Import / Export Tax Rates.

2. Click the Export Tax Rates button. When prompted, click Save. Then, open the exported
file in OpenOffice Calc.

Export Tax Rates

http://partners.magento.com/partner_locator/partner_details.aspx?id=89646&backUrl=%2fpartner_locator%2fsearch.aspx%3ff0%3dTypes%2bof%2bPartners%26f0v0%3dTechnology%2bPartner
http://www.avalara.com/products/taxrates/
http://partners.magento.com/partner_locator/search.aspx?f0=Types+of+Partners&f0v0=Technology+Partner
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3. In a second instance of OpenOffice Calc, open the new tax rate data, so you can see both,
side by side. The basic Magento tax rate data includes the following columns:

l Code

l Country

l State

l Zip/Post Code

l Rate

Exported Tax Rate Data

4. In the new tax rate data, take note of any additional tax rate data that you might need to
set up in your store before the data is imported. For example, the tax rate data for
California also includes:

l TaxRegionName

l CombinedRate

l StateRate

l CountyRate

l CityRate

l SpecialRate

If you need to import additional tax zones and rates, you must first define them from the
Admin of your store, and update the tax rules as needed. Then, export the data, and open
the file in OpenOffice Calc, so it can be used for reference. However, to keep this example
simple, we will import only the standard tax rate columns.
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Step 2: Prepare the Import Data

You now have two spreadsheets open, side by side. One with the Magento export file
structure, and the other with the new tax rate data that you want to import.

1. To create a place to work in the spreadsheet with the new data, insert as many blank
columns at the far left as needed. Then, use cut and paste to rearrange the columns so they
match the order of the Magento export data.

2. Rename the column headers to match the Magento export data.

3. Delete any columns that have no data. Otherwise, the structure of the import file should
match the original Magento export data.

4. Before saving the file, scroll down and make sure that the tax rate columns contain only
numeric data. Any text found in a tax rate column will prevent the data from being
imported.

5. Save the prepared data as a .CSV file. When prompted, verify that a comma is used a Field
delimiter, and double quotes as the Text delimiter. Then, click OK.

Magento requires all text strings to be enclosed in double quotes. Because Microsoft Excel
removes the double quotes, we recommend that you use OpenOffice Calc instead.

Step 3: Import the Tax Rates

1. On the Admin menu, select Sales > Tax > Import / Export Tax Rates.

2. Click the Browse button, and select the .CSV tax rate file that you prepared to import.
Then, click the Import Tax Rates button.

It might take several minutes to import the data. When the process is complete, the
message, "The tax rate has been imported" appears. If you receive an error message, correct
the problem in the data and try again.

Import Tax Rates

3. On the Admin menu, select Sales > Tax > Manage Tax Zones & Rates. The new data
appears in the list. Use the page controls to view the new tax rates.
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Imported Tax Rates

4. Run some text transactions in your store with customers from different ZIP codes to make
sure that the new tax rates work correctly.
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Tax Rules
Tax management rules put all the taxation elements together: product tax classes,
customer tax classes, and tax zones and rates. Each tax rule consists of a customer tax
class, a product tax class, and a tax rate.

Manage Tax Rules

To define tax rules:

1. On the Admin menu, select Sales > Tax > Manage Tax Rules.

2. In the upper-right corner, click the Add New Tax Rule button. Then, do the following:

Tax Rule Information

a. Enter a Name for the rule.

b. Select a Customer Tax Class. To select multiple options, hold the Ctrl key down and
click each item.
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c. Select a Product Tax Class.

d. Select the Tax Rate.

This rule applies the tax rate to customers in the selected customer tax class and to
products in the selected product tax class.

e. In the Priority field, enter a number to indicate the priority of this tax, when more
than one tax applies. If two tax rules with the same priority apply, then the taxes are
added together. If two taxes with different priority settings apply, then the taxes are
compounded.

3. In the Sort Order field, enter a number to indicate the order in which tax rules are
displayed on the Manage Tax Rules page.

4. If you want taxes to be calculated off the order subtotal, select the Calculate off Subtotal
Only checkbox.

5. When complete, click the Save Rule button.

FIELD DESCRIPTION

Name Enter a name for this tax rule tomake it easy to identify.

Customer Tax Class Select the customer tax class associated with this rule.

Product Tax Class Select the product tax class associated with this rule.

Tax Rate Select the tax rate that applis to this rule.

Priority Enter a number to indicate the priority of this tax, whenmore than
one tax applies. Lower numbers have higher priority. If two tax
rules with the same priority apply then the taxes are added
together. If two taxes with a different priority apply then the taxes
are compounded. When taxes are compounded, the first priority
tax is calculated on the subtotal amount, and then the second
priority tax is calculated on the subtotal plus the first priority tax
amount.

Calculate off Subtotal Only Select this checkbox for taxes to be calculated based on the
subtotal of the order. This means that for this tax rule, tax applies
only to the subtotal of the order.

Sort Order Specify the order in which tax rules are displayed on theManage
Tax Rules page. Lower numbers have higher sort order in the list.

Field Descriptions
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EUPlace of Supply
European Union (EU) merchants must report their digital goods sold by quarter to each
member country. Digital goods are taxed based on the customer's billing address. The law
requires merchants to run a tax report and identify the relevant tax amounts for digital
goods, as opposed to physical goods.

Merchants must report all digital goods sold by EU member countries on a quarterly basis
to a central tax administration, along with payment due for tax collected during the period.

Merchants who have not yet reached the threshold (50k/100k Euro of annual business)
must continue to report physical goods sold to the EU states where they have registered
VAT numbers.

Merchants who are audited for taxes paid for digital goods, must provide two pieces of
supporting information to establish the customer place of residence.

l The customer’s billing address and a record of a successful payment transaction can be
used to establish the customer place of residence. (Payment is accepted only if the
billing address matches payment provider information.)

l The information can also be captured directly from the data store in the Magento
database tables.

To collect digital goods tax information:

1. Load the tax rates for all EU member countries.

2. Create a digital goods product tax class.

3. Assign all your digital goods to the digital goods product tax class.

4. Create tax rules for your physical goods, using physical product tax classes, and associate
them with the appropriate tax rates.

5. Create tax rules for your digital goods, using use the product tax class for digital goods,
and associate them with the appropriate tax rates for EU member countries.

6. Run the tax report for the appropriate period, and collect the required digital goods
information.

7. Export the tax amounts that are related to the tax rates for the digital goods product tax
class.

See also:

European Commission Taxation and Customs Union

EU 1015 Place of Supply Changes

http://ec.europa.eu/taxation_customs/taxation/vat/how_vat_works/vat_on_services/index_en.htm
http://www2.deloitte.com/global/en/pages/tax/articles/eu-2015-place-of-supply-changes-overview.html
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Fixed Product Tax
Some tax jurisdictions have a fixed tax that must be added to certain types of products.
Magento lets you set up a fixed product tax (FPT) to use in tax calculations. For example,
in some countries FPT can be used to set up a Waste Electrical and Electronic Equipment
Directive (WEEE) tax, also known as "ecological tax" or "eco tax," that is collected on
certain types of electronics to offset the cost of recycling. This tax is a fixed amount, rather
than a percentage of the product price.

Fixed product taxes apply at the item level, based on the product. In some jurisdictions the
FPT tax is subject to an additional % tax calculation. Your tax jurisdiction might also have
rules about the display of product prices, either with or without tax. Be sure that you
understand the requirements, and set your FPT display options accordingly.

We recommend that you exercise caution when quoting FPT prices in email, because of
possible differences in price display, depending on how the Display Prices in Sales Modules
and Display Prices in Email options are configured. For example, if you show Order Review
prices without FPT, customers who buy items with the associated FPT will see a total that
includes the FPT tax amount, although it is not included in the itemized entry for the
amount.

Important!Quoting FPT prices in email might cause abandoned carts if your customers see an
order total that does not match what they expect based on an itemized list of products in the
order.
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FPT DISPLAY SETTING AND ASSOCIATED CALCULATION

Not Taxed Excluding FPT Treats FPT as a separate row in the cart
and includes the value of FPT in the
appropriate tax calculations.

Including FPT FPT is added to the base price of an item
but is not included in tax- rule-based
calculations.

Excluding FPT,
FPT Description,
Final Price

Item prices are shownwithout FPT, FPT
amount, and with FPT included. FPT is
not included in tax-rule-based
calculations.

Taxed Excluding FPT Treats FPT as a separate row in the cart
and includes the value of FPT in the
appropriate tax calculations.

Including FPT FPT is included in the price of an item,
and no change to tax calculations is
required.

Excluding FPT,
FPT Description,
Final Price

Item prices are shownwithout FPT, FPT
amount, and with FPT included. FPT is
included in tax-rule-based calculations.

FPT Price Settings

Fixed Product Tax Configuration
The following instructions show how to set up a fixed product tax for your store. An “eco
tax” is an example of how you might used FPT. After setting the scope for the tax and the
countries and states where the tax applies, and depending on the options you choose, the
input fields can change to accommodate the local requirements.

Process Overview:
Step 1: Enable the FPT Tax
Step 2: Create an FPT Attribute
Step 3: Add the FPT to an Attribute Set
Step 4: Apply the FPT to Products
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Step 1: Enable the FPT Tax

1. On the Admin menu, select System > Configuration. Then in the panel on the left, under
Sales, select Tax.

2. Click to expand the Fixed Product Taxes section.

Fixed Product Taxes

3. Set Enable FPT to “Yes.”

4. Set the price display for each component of your site to one of the following options:

l Including FPT only

l Including FPT and FPT description

l Excluding FPT, FPT description, final price

l Excluding FPT

a. Set Display Prices in Product Lists.

b. Set Display Prices on Product View Page.

c. Set Display Prices in Sales Modules.

d. Set Display Prices in Emails.

5. To apply discounts to the FPT amount, set Apply Discounts to FPT to “Yes.”

6. To determine how FTP tax is calculated, set FPT Tax Configuration to one of the following:

Not Taxed Select this option if your taxing jurisdiction does not tax FPT. (For
example,California.)

Taxed Select this option if your taxing jurisdiction does tax FPT. (For
example, Canada.)

Loaded and
Displayed with
Tax

Click this option if FPT is added to the order total before applying
tax. (For example, EU countries.)

7. Set Include FPT in Subtotal to one of the following:
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Yes Includes FPT in the shopping cart subtotal.

No FPT is not included in the subtotal, and is placed after the subtotal in the
shopping cart.

8. When complete, click the Save Config button.

Step 2: Create an FPT Attribute

1. On the Admin menu, select Catalog > Attributes > Manage Attributes.

2. In the upper-right corner, click the Add New Attribute button. Then, do the following:

Fixed Product Tax

a. In the Attribute Code field, specify a unique identifier for this attribute. Do not use
spaces or special characters. However, you can use hyphens or underscores. The
maximum length is 30 characters.

b. Set Scope to indicate where in your Magento installation the attribute will be
available.

c. Set Catalog Input Type for Store Owner to “Fixed Product Tax.”

d. Set Apply To to one of the following:
All Product Types Makes the FPT attribute available for all product types.

Selected Product
Types

If you select this option, select each product type in the list
that will use the attribute.

3. In the panel on the left, select Manage Label / Options. Then, enter a label to identify the
field. If you enter one label for the Admin, it will be used for the other views.

Manage Label / Options

4. When complete, click the Save Attribute button.
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Step 3: Add the FPT Attribute to an Attribute Set

1. On the Admin menu, select Catalog > Attributes > Manage Attribute Sets.

2. Open the attribute set that needs the FPT attribute.

3. Drag the FPT attribute from the list of Unassigned Attributes on the right to the Groups
list. The group folders correspond to sections in the Product Information panel. You can
place the attribute wherever you want it to appear.

Edit Attribute Set

4. When complete, click the Save Attribute Set button.

Step 4: Apply the FPT to Products

1. On the Admin menu, select Catalog > Manage Products.

2. Find the product that needs the FPT and open it in edit mode.

3. In the product information, find the FPT field that you added to the attribute set. Then, do
the following:
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Product Information with FPT Field

4. Click the Add Tax button. Then, do the following:

a. Select the Country/State where the FPT applies.

b. Enter the amount in the Tax field.

c. To add more FPT taxes, click the Add Tax button and repeat the process.

FPT Tax

5. When complete, click the Save button.
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Compound Taxes
For compound taxes, the total cost of a product or service is taxed at one rate, and then the
total of that amount, including the first tax amount, is taxed a second time. Compound
tax is also known as stacked tax.

Compound taxes use different tax rule priorities. If two tax rules with the same priority
apply then the taxes are added together. If two taxes with a different priority apply then
the taxes are compounded. When taxes are compounded, the first priority tax is calculated
on the subtotal amount, and then the second priority tax is calculated on the subtotal plus
the first priority tax amount. Lower numbers have higher priority.

Important! In order for compound taxes to work correctly do not select the Calculate off
subtotal only check box when you set up your tax rules that apply to compound taxes. This
check box overrides the compounding calculation and cannot be used in conjunction with
compound taxes.

Example 1: Regular Two-Tax Calcuation

For example, in a regular tax calculation involving two tax rules, each rule is applied
separately to the product subtotal, and the taxes are added together to calculate the total
tax, which is then added to the product subtotal to calculate the grand total:

$50.00
+   $50.00
$100.00

Product Price
Product Price
Subtotal

$5.00
+    $10.00

$15.00

Subtotal x 1st tax rate 5%
Subtotal x 2nd tax rate 20%
Total Taxes

$100.00
+   $15.00
$115.00

Subtotal
Total Taxes
Grand Total

Regular Two-Tax Calculation
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Example 2: Compound Tax Calculation

With compound taxes, the first tax is added to the product subtotal, and the second tax is
applied to that total:

$50.00
+   $50.00
$100.00

Product Price
Product Price
Subtotal

$5.00
+    $10.50

$15.50

Subtotal x 1st tax rate 5%
[Subtotal + (Subtotal x 1st rate)] x 2nd tax rate: $105 x 10%
Total Taxes

$100.00
+   $15.50
$115.50

Subtotal
Total Taxes
Grand Total

Compound Tax Calculation

To set up compound taxes:

1. Set up all the tax rates that will be used in your compound tax rule. See: Tax Zones &
Rates.

2. Set up the first tax rule for compounding. For the first tax rule, be sure that you set a
higher priority than you will set for the next tax rule, which will be compounded on top of
this first tax rule. Lower numbers are used for higher priority. Use 0 for the highest priority.
See: Tax Rules.

3. Set up the second tax rule for compounding. For the second rule, be sure that you set a
lower priority (use a higher number) than you set for the first tax rule.
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Cross-Border Price Consistency
Cross-border trade (also referred to as price consistency) supports European Union (EU)
and other merchants who want to maintain consistent prices for customers whose tax rates
are different than the store tax rate.

Merchants operating across regions and geographies can show their customers a single
price by including the tax in the price of the product. Pricing is clean and uncluttered
regardless of tax structures and rates that vary from country to country.

Important!When cross-border trade is enabled, your profit margin changes by tax rate. Profit is
determined by the formula: (Revenue - CustomerVAT - CostOfGoodsSold).

To enable cross-border price consistency:

1. On the Admin menu, select System > Configuration.

2. In the panel on the left, under Sales, select Tax.

3. Click to expand the Calculation Settings section. Then, do the following:

Calculation Settings

a. Set Catalog Prices to “Including Tax.”

b. To enable cross-border price consistency, set Enable Cross Border Trade to “Yes.”

4. When complete, click the Save Config button.
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CHAPTER 63:

Value Added Tax (VAT)
Some countries charge a value added tax, or VAT, on goods and services. There can be
different VAT rates depending on which stage you as a merchant are at in the
manufacture or distribution of the products, materials, or services that you sell to your
customers. In this case you may need to use more than one VAT rate in your store for
tax calculation purposes.

Topics in this chapter:

l Value Added Tax Setup

l VAT Validation
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Value Added Tax Setup
The following instructions include a sample procedure to set up a 20% VAT in the U.K. for
sales to retail customers. For other tax rates and countries, follow the general procedure but
enter specific information that corresponds to your country, VAT rate, customer types, and
so on.

Before proceeding, make sure to find out which rules and regulations apply to VAT in your area.

In certain business-to-business transactions, VAT is not assessed. Magento can validate a
customer’s VAT ID to ensure that VAT is assessed (or not assessed) properly. To learn
more, see: VAT Validation.

Process Overview:
Step 1: Set Up Customer Tax Classes
Step 2: Set Up Product Tax Classes
Step 3: Set Up Tax Zones and Rates
Step 4: Set Up Tax Rules
Step 5: Apply Tax Classes to Products

Step 1: Set Up Customer Tax Classes

1. On the Admin menu, select Sales > Tax > Customer Tax Classes.

2. Ensure that there is a customer tax class that is appropriate to use with the VAT. For this
example, ensure that there is a customer tax class named Retail Customer. If Retail
Customer does not exist, click the Add New button and add it.

Step 2: Set Up Product Tax Classes

1. On the Admin menu, select Sales > Tax > Product Tax Classes.

2. Click the Add New button and create three new classes:

l VAT Standard

l VAT Reduced

l VAT Zero

3. Click the Save Class button for each new class that you add.

Step 3: Set Up Tax Zones and Rates

1. On the Admin menu, select Sales > Tax > Manage Tax Zones & Rates.

For this example you can remove the U.S. tax rates, or leave them as they are.
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2. Click the Add New Tax Rate button. Add new rates as follows:

NEW TAX RATE SETTINGS

VAT Standard Tax Identifier: VAT Standard

Country and State: United Kingdom

Rate Percent: 20.00

VAT Reduced Tax Identifier: VAT Reduced

Country and State: United Kingdom

Rate Percent: 5.00

3. Click the Save Rate button for each rate.

Step 4: Set Up Tax Rules

A tax rule is a combination of a customer tax class, a product tax class, and a tax rate.

1. On the Admin menu, select Sales > Tax > Manage Tax Rules.

2. Add new tax rules as follows:

NEW TAX RULE SETTINGS

VAT Standard Name: VAT Standard

Customer Tax Class: Retail Customer

Product Tax Class: VAT Standard

Tax Rate: VAT Standard Rate

VAT Reduced Name: VAT Reduced

Customer Tax Class: Retail Customer

Product Tax Class: VAT Reduced

Tax Rate: VAT Reduced Rate

3. Click the Save Rule button for each rate.
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Step 5: Apply Tax Classes to Products

1. On the Admin menu, select Catalog > Manage Products.

2. Open a product from your catalog in edit mode.

3. On the General page, find the Tax Class field. Then, select the VAT Class that applies to
the product.

4. When complete, click the Save button.

VAT ID Validation
VAT ID Validation automatically calculates the required tax for B2B transactions that take
place within the European Union (EU), based on the merchant and customer locale.
Magento performs VAT ID validation using the web services of the European Commission
server.

VAT-related tax rules do not influence other tax rules, and do not prevent the application of
other tax rules. Only one tax rule can be applied at a given time.

l VAT is charged if the merchant and customer are located in the same EU country.

l VAT is not charged if the merchant and customer are located in different EU countries,
and both parties are EU-registered business entities.

The store administrator creates more than one default customer group that can be
automatically assigned to the customer during account creation, address creation or
update, and checkout. The result is that different tax rules are used for intra-country
(domestic) and intra-EU sales.

Important: If you sell virtual or downloadable products, which by their nature do not require
shipping, the VAT rate of a customer’s location country should be used for both intra-union and
domestic sales. You must create additional individual tax rules for product tax classes that
correspond to the virtual products.

Customer Registration Workflow
If VAT ID Validation is enabled, after registration each customer is proposed to enter the
VAT ID number. However only those who are registered VAT customers are expected to fill
this field.

After a customer specifies the VAT number and other address fields, and chooses to save,
the system saves the address and sends the VAT ID validation request to the European
Commission server. According to the results of the validation, one of the default groups is
assigned to a customer. This group can be changed if a customer or an administrator

http://ec.europa.eu/taxation_customs/vies/
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changes the VAT ID of the default address or changes the whole default address. The group
can be temporarily changed (group change will be emulated) in some cases during one-
page checkout.

If enabled, you can override VAT ID Validation for individual customers by selecting the
checkbox on the Customer Information page.

Checkout Workflow
If a customer’s VAT validation is performed during checkout, the VAT request identifier
and VAT request date are saved in the Comments History section of the order.

The system behavior concerned with the VAT ID validation and the customer group change
during the checkout depends on how the Validate on Each Transaction and the Disable
Automatic Group Change settings are configured. This section describes the
implementation of the VAT ID Validation functionality for the checkout on the frontend.

In case a customer uses Google Express Checkout, PayPal Express Checkout or another
external checkout method, when the checkout is performed completely on the side of the
external payment gateway, the Validate on Each Transaction setting cannot be applied.
Thus the customer group cannot change during checkout.
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Setting Up VAT IDValidation
Before you set up VAT ID Validation, see the example of minimal tax rule requirements.

Process Overview:
Step 1: Create the VAT-Related Customer Groups
Step 2: Create the VAT-Related Classes, Rates and Rules
Step 3: Enable and Configure VAT ID Validation
Step 4: Set your VAT ID and Location Country
Step 5: Verify the List of EU Member Countries

Step 1: Create the VAT-Related Customer Groups

VAT ID Validation automatically assigns customers to one of the following default
customer groups, according to VAT ID validation results:

l Domestic

l Intra-EU

l Invalid VAT ID

l Validation error

You can create new customer groups to be used with VAT ID Validation, or use existing
groups if they comply with your business logic. When configuring VAT ID Validation, you
must assign each of the created customer groups as a default for customers with
appropriate VAT ID validation results.

Step 2: Create the VAT-Related Classes, Rates, and Rules

Magento uses tax rules to apply the appropriate value-added tax. Each tax rule is defined
by the following:

l Customer Tax Classes

l Product Tax Classes

l Tax Rates

To use the VAT ID Validation effectively, you must create the appropriate tax rules, based
on customer and product tax classes, and tax rate.
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Step 3: Enable and Configure VAT ID Validation

1. On the Admin menu, select System > Configuration.

2. In the panel on the left, under Customers, select Customer Configuration.

3. Set Current Configuration Scope to “Default Config,” or the applicable store view.

4. Click to expand the Create New Account Options section.

5. Set Enable Automatic Assignment to Customer Group to “Yes.” Then complete the fields
as described below.

6. When complete, click the Save Config button.

Create New Account Options

http://merch.docs.magento.com/ee/user_guide/Magento_Enterprise_Edition_User_Guide.html#configuration/customers/customer-configuration.html%23Create_New_Account_Options
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Step 4: Set Your VAT ID and Location Country

1. On the Admin menu, select System > Configuration.

2. In the panel on the left, under General, select General.

3. Set Current Configuration Scope to the applicable store view.

4. Click to expand the Store Information section. Then, do the following:

Store Information

a. Select your Country.

b. Enter your VAT Number. Then, click the Validate VAT Number button. The result
appears immediately.

If your VAT number is valid, then in addition to the validation result for each
customer, the validation server sends to Magento the VAT request identifier and VAT
request date. If a customer’s VAT validation is performed during checkout, the VAT
request identifier and VAT request date are saved in the Comments History section of
the Order.

5. When complete, click the Save Config button.
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Step 5: Verify the List of EU Member Countries

1. On the Admin menu, select System > Configuration.

2. Set Current Configuration Scope to the applicable store view.

3. Click to expand the Countries Options section.

Countries Options

4. In the European Union Countries list, verify that each member country of the EU is
selected.

5. When complete, click the Save Config button.
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CHAPTER 63:  Value Added Tax (VAT) VAT ID Validation

Example: Minimal Tax Rules Required for VAT ID Validation

TAX RULE #1

Customer Tax Class l A class for domestic customers

l A class for customers with invalid VAT ID

l A class for customers, for whom VAT ID validation failed

Product Tax Class A class for products of all types, except downloadable and
virtual.

Tax Rate VAT rate of themerchant’s country.

TAX RULE #2

Customer Tax Class A class for intra-union customers.

Product Tax Class A class for products of all types, except downloadable and
virtual.

Tax Rate VAT rates for all EU countries, except merchant’s country.
Currently this rate is 0%.

TAX RULE #3

Required to Sell Downloadable or Virtual Products

Customer Tax Class l A class for domestic customers

l A class for customers with invalid VAT ID

l A class for customers, for whom VAT ID validation failed

Product Tax Class A class for downloadable and virtual products.

Tax Rate VAT rate of themerchant’s country.

TAX RULE #4

Required to Sell Downloadable or Virtual Products

Customer Tax Class A class for intra-union customers.

Product Tax Class A class for downloadable and virtual products.

Tax Rate VAT rates for all EU countries, except merchant’s country.
Currently this rate is 0%.
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Managing Customer Groups
A customer group, which should be assigned to a customer according to the validation
results, can differ from the customer group that is currently assigned to the customer. The
system displays suggested groups that the administrator can confirm or reject the current
order. If the administrator confirms, the group change is emulated for the current order and
the corresponding VAT rate is applied (if the corresponding tax rule is configured in the
system). The actual customer group of a customer is not changed.

If a new customer account is added when an order is created, and an administrator
confirms the customer group that corresponds to the VAT ID validation results, after the
order is created, the customer account is saved in the system, and the customer group that
was used to create the order is assigned to the customer.

Customer Address Workflow
When an administrator adds a new default address with a VAT ID to the account of a new
or existing customer, or changes the VAT ID of the existing default address, the system
validates the VAT ID and assigns the appropriate customer group to the customer. The
validation is performed after the Save or Save and Continue button is clicked.

Order Creation Workflow
When an order is created from the Admin, VAT ID validation is not performed
automatically. To validate the VAT ID of the customer address, an administrator must
click the Validate VAT Number button in the Billing Address or Shipping Address section
of the Create New Order page. After the validation, the administrator receives a pop-up
notification of the validation results.

Validating Customer VAT ID at Order Creation
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Automatic Customer Group Changes
When VAT ID Validation is enabled, the group that a customer is assigned to must be
changed manually from the Admin. The system automatically and permanently changes a
customer group in the following situations:

l The VAT ID of the customer’s default address or the whole default address changes.

l The customer group change was emulated during the checkout for a registered customer
who had no previously saved address, or for a customer who registered during checkout.

To disable automatic group change for a customer:

1. On the Admin menu, select Customers > Manage Customers.

2. Open the customer record in edit mode.

3. Just below the Group field, select the Disable Automatic Group Change Based on VAT ID
checkbox.

Important! The setting does not influence the emulation of the customer group change during
checkout.

To set the default automatic group change behavior:

The configuration setting is made on the global level, and applies to new customers and
those whose records are available in the system when VAT ID Validation is enabled for the
first time.

1. On the Admin menu, select System > Configuration.

2. In the panel on the left, under Customers, select Customer Configuration.

3. Click to expand the Create New Account Options section.
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Create New Account Options

4. Set Default Value for Disable Automatic Group Changes Based on VAT ID as needed.

5. When complete, click the Save Config button.

Disabling Automatic Group Change on Customer Level

VAT IDCustomer Address Attribute
The customer VAT ID value is stored in the vat_id customer address attribute. The
default label of this attribute is VAT number. The VAT number field is always present in all
shipping and billing customer addresses when viewed from the Admin, but it not

http://merch.docs.magento.com/ee/user_guide/Magento_Enterprise_Edition_User_Guide.html#configuration/customers/customer-configuration.html%23Create_New_Account_Options
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mandatory. The field can be configured to appear in the storefront by setting the the Show
VAT Number in Frontend field in the Create New Account Options section of Customer
Configuration.

For customers not from EU countries, consider storing the VAT number (if any), in the existing
Tax/VAT Number customer attribute to avoid any possibility of customer group change (whether
persistent or emulation during checkout). It is recommended that you rename the Tax/VAT
Number customer attribute to avoid confusion with the new VAT Number customer address
attribute that is used for the VAT ID Validation functionality.

Show VAT Number
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Notes
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CHAPTER 64:

Quick Reference
Configuration Options
Some tax settings have a choice of options that determines the way the tax is
calculated and presented to the customer. To learn more, see: International Tax
Configurations.

Tax Calculation Methods
Tax calculation method options include Unit Price, Row Total, and Total. The
following table explains how rounding (to two digits) is handled for different settings.

SETTING CALCULATION AND DISPLAY

Unit Price Magento calculates the tax for each item and displays prices
tax-inclusive. To calculate the tax total, Magento rounds the
tax for each item, and then adds them together.

Row Total Magento calculates the tax for each line. To calculate the
tax total, Magento rounds the tax for each line item and then
adds them together.

Total Magento calculates the tax for each item and adds those tax
values to calculate the total unrounded tax amount for the
order. Magento then applies the specified roundingmode to
the total tax to determine the total tax for the order.
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Catalog Prices With or Without Tax
The possible display fields vary depending on the calculation method and whether the
catalog prices include or exclude taxes. Display fields have two-decimal precision in
normal computations. Some combinations of price settings display prices that both include
and exclude tax. When both appear on the same line item, it can be confusing to
customers, and triggers a warning.

SETTING CALCULATION AND DISPLAY

Excluding Tax Using this setting, the base item price is used as it is entered
and the tax calculationmethods are applied.

Including Tax Using this setting, the base item price excluding tax is
calculated first. This value is used as the base price, and the tax
calculationmethods are applied.

Important! Changes have been made from earlier versions for EU merchants or other VAT
merchants who display prices including tax and operate in several countries with multiple store
views. If you load prices with more than two digits of precision, Magento automatically rounds all
prices to two digits to ensure that a consistent price is presented to buyers.

Shipping Prices With or Without Tax
SETTING DISPLAY CALCULATION

Excluding Tax Appears without tax. Normal calculation. Shipping is
added to cart total, typically
displayed as a separate item.

Including Tax Can be tax inclusive, or tax
can be displayed
separately.

Shipping is treated as another
item in cart with taxes, using the
same calculations.

Tax Amounts as Line Items
To display two different tax amounts as separate line items, such as GST and PST for Canadian
stores, youmust set different priorities for the related tax rules. However, in previous tax
calculations, taxes with different priorities would automatically be compounded. To correctly
display separate tax amounts without an incorrect compounding of the tax amounts, you can set
different priorities, and also select the Calculate off subtotal only checkbox. This produces
correctly calculated tax amounts that appear as separate line items.
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International Tax Configurations

TAX OPTION RECOMMENDED SETTING

Load catalog prices Excluding tax

FPT No, because FPT is not taxed.

Tax based on Shipping origin

Tax Calculation On total

Tax shipping? No

Apply Discount Before tax

Comment All tax zones are the same priority; ideally, a zone for state and
one or more zones for zip code lookup.

US

TAX OPTION RECOMMENDED SETTING

Load catalog prices Excluding tax

FPT Yes, including FPT and description

Tax based on Shipping address

Tax Calculation On total

Tax shipping? Yes

Apply Discount Before tax, discount on prices, including tax.

Comment For merchants marking up supplier invoices (including VAT).

UK B2C

TAX OPTION RECOMMENDED SETTING

Load catalog prices Excluding tax

FPT Yes, including FPT and description

Tax based on Shipping address

Tax Calculation On item

UK B2B
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TAX OPTION RECOMMENDED SETTING

Tax shipping? Yes

Apply Discount Before tax, discount on prices, including tax.

Comment For B2B merchants to provide simpler VAT supply chain
considerations. Tax calculation on row is also valid; however,
check with your taxing jurisdiction. Setup assumes amerchant is
in the supply chain and that goods sold are used by other vendors
for VAT rebates and so on. This makes it easy to discern tax by
item for faster rebate generation. Note that some jurisdictions
require different rounding strategies not currently supported by
Magento, and that not all jurisdictions allow item or row level tax.

UK B2B (cont.)

TAX OPTION RECOMMENDED SETTING

Load catalog prices Excluding tax

FPT Yes, including FPT, description, and apply tax to FPT.

Tax based on Shipping origin

Tax Calculation On total

Tax shipping? Yes

Apply Discount Before tax

Comment Merchants located in a GST/PST province (Montreal) should
create one tax rule and show a combined tax amount.
Be sure to consult a qualified tax authority if you have any
questions. For information about the tax requirements of specific
provinces, see the following:
RevenuQuébec
Government of Saskatchewan
Manitoba Information for Vendors

Canada
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US: Tax Configuration Recommendations
Tax Classes
SETTING RECOMMENDED SETTING

Tax Class for Shipping None

Tax Class for Gift Options Taxable Goods

Calculation Settings
SETTING RECOMMENDED SETTING

Tax CalculationMethod Based
On

Total

Tax Calculation BasedOn Shipping Origin

Catalog Prices Excluding Tax

Shipping Prices Excluding Tax

Apply Customer Tax After Discount

Apply Discount on Prices Excluding Tax

Default Tax Destination Calculation
SETTING RECOMMENDED SETTING

Default Country United States

Default State State where business is located.

Default Post Code The postal code that is used in your tax zones.

Price Display Settings

SETTING RECOMMENDED SETTING

Display Product Prices in
Catalog

Excluding Tax

Display Shipping Prices Excluding Tax
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Shopping Cart Display Settings
SETTING RECOMMENDED SETTING

Display Prices Excluding Tax

Display Subtotal Excluding Tax

Display Shipping Amount Excluding Tax

Display Gift Wrapping Prices Excluding Tax

Display Printed Card Prices Excluding Tax

Include Tax in Grand Total Yes

Display Full Tax Summary Yes

Display Zero Tax Subtotal Yes

Orders, Invoices, Credit Memos, Display Settings
SETTING RECOMMENDED SETTING

Display Prices Excluding Tax

Display Subtotal Excluding Tax

Display Shipping Amount Excluding Tax

Display Gift Wrapping Prices Excluding Tax

Display Printed Card Prices Excluding Tax

Include Tax in Grand Total Yes

Display Full Tax Summary Yes

Display Zero Tax Subtotal Yes

Fixed Product Taxes
SETTING RECOMMENDED SETTING

Enable FPT No, except in California.
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Canada: Example Tax Configuration
The following example shows how to set up GST tax rates for Canada and PST tax rates for
Saskatchewan, with tax rules that calculate and display the two tax rates. Because this is
an example configuration, be sure to verify the correct tax rates and rules for your tax
jurisdictions. When setting up taxes, set the store scope to apply the configuration to all
applicable stores and websites.

l Fixed product tax is included for relevant goods as a product attribute.

l In Quebec, PST is referred to as TVQ. If you need to set up a rate for Quebec, make sure
to use TVQ as the identifier.

Step 1: Complete Tax Calculation Settings

1. On the Admin menu, select System > Configuration. Then in the panel on the left, under
Sales, select Tax.

2. Click to expand each section, and complete the following settings:

FIELD RECOMMENDED SETTING

Tax CalculationMethod Based
On

Total

Tax Calculation BasedOn Shipping Address

Catalog Prices Excluding Tax

Shipping Prices Excluding Tax

Apply Customer Tax After Discount

Apply Discount on Prices Excluding Tax

Apply Tax On Custom Price (if available)

Tax Calculation Settings

FIELD RECOMMENDED SETTING

Tax Class for Shipping Shipping (shipping is taxed)

Tax Classes

FIELD RECOMMENDED SETTING

Default Country Canada

Default Tax Destination Calculation
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FIELD RECOMMENDED SETTING

Default State (as appropriate)

Default Postal Code * (asterisk)

Default Tax Destination Calculation (cont.)

FIELD RECOMMENDED SETTING

Include Tax in Grand Total Yes

Display Full Tax Summary Yes

Display Zero in Tax Subtotal Yes

Shopping Cart Display Settings

FIELD RECOMMENDED SETTING

Enable FPT Yes

All FPT Display Settings Including FPT and FPT description

Apply Discounts to FPT No

Apply Tax to FPT Yes

Include FPT in Subtotal No

Fixed Product Taxes

Step 2: Set Up Canadian Goods & Services Tax (GST)

To print the GST number on invoices and other sales documents, include it in the name of
the applicable tax rates. The GST will appear as part of the GST amount on any order
summary.

FIELD RECOMMENDED SETTING

Tax Identifier Canada-GST

Country Canada

State * (asterisk)

Zip/Post is Range No

Manage Tax Zones & Rates
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FIELD RECOMMENDED SETTING

Zip/Post Code * (asterisk)

Rate Percent 5.0000

Manage Tax Zones & Rates (cont.)

Step 3: Set Up Canadian Provincial Sales Tax (PST)

Set up another tax rate for the applicable province.

FIELD RECOMMENDED SETTING

Tax Identifier Canada-SK-PST

Country Canada

State Saskatchewan

Zip/Post is Range No

Zip/Post Code * (asterisk)

Rate Percent 5.0000

Tax Rate Information

Step 4: Create a GST Tax Rule

To avoid compounding the tax and to correctly display the calculated tax as separate line
items for GST and PST, you must set different priorities for each rule, and select the
“Calculate off subtotal only” checkbox. Each tax appears as a separate line item, but the
tax amounts are not compounded.

FIELD RECOMMENDED SETTING

Name Retail-Canada-GST

Customer Tax Class Retail Customer

Product Tax Class Taxable Goods
Shipping

Tax Rate Canada-GST

Priority 0

Tax Rule Information
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FIELD RECOMMENDED SETTING

Calculate off subtotal only Select this checkbox.

Sort Order 0

Tax Rule Information (cont.)

Step 5: Create a PST Tax Rule for Saskatchewan

For this tax rule, make sure to set the priority to 0 and select the "Calculate off subtotal
only" checkbox. Each tax appears as a separate line item, but the tax amounts are not
compounded.

FIELD RECOMMENDED SETTING

Name Retail-Canada-PST

Customer Tax Class Retail Customer

Product Tax Class Taxable Goods
Shipping

Tax Rate Canada-SK-PT

Priority 1

Calculate off subtotal only Select this checkbox.

Sort Order 0

Tax Rule Information

Step 6: Save and Test the Results

1. When complete, click the Save Config button.

2. Return to your storefront, and create a sample order to test the results.
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EU: Example Tax Configuration
The following example depicts a store based in France that sells > 100k Euros in France
and > 100k Euros in Germany.

l Tax calculations are managed at the website level.

l Currency conversion and tax display options are controlled individually at the store
view level, (Click the Use Website checkbox to override the default).

l By setting the default tax country you can dynamically show the correct tax for the
jurisdiction.

l Fixed product tax is included for relevant goods as a product attribute.

l It might be necessary to edit the catalog to ensure that it shows up in the correct
category/website/store view.

Step 1: Create Three New Product Tax Classes

For this example, it is assumed that multiple VAT-Reduced product tax classes are not
needed.

1. Create a VAT-Standard product tax class.

2. Create a VAT-Reduced product tax class.

3. Create a VAT-Free product tax class.

Step 2: Create New Tax Rates for France and Germany

Create the following tax rates:

TAX RATE SETTING

France-StandardVAT Country: France

State/Region: *

ZIP/Postal Code: *

Rate: 20%

France-ReducedVAT Country: France

State/Region: *

Tax Rates
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TAX RATE SETTING

ZIP/Postal Code: *

Rate: 5%

Germany-StandardVAT Country: Germany

State/Region: *

ZIP/Postal Code: *

Rate: 19%

Germany-ReducedVAT Country: Germany

State/Region: *

ZIP/Postal Code: *

Rate: 7%

Tax Rates (cont.)

Step 3: Manage Tax Rules for the New Rules

Create the following tax rules:

TAX RULE SETTING

Retail-France-
StandardVAT

Customer Class: Retail Customer

Tax Class: VAT-Standard

Tax Rate: France-StandardVAT

Priority: 0

Sort Order: 0

Retail-France-
ReducedVAT

Customer Class: Retail Customer

Tax Class: VAT Reduced

Tax Rate: France-ReducedVAT

Tax Rules
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TAX RULE SETTING

Priority: 0

Sort Order: 0

Retail-Germany-
StandardVAT

Customer Class: Retail Customer

Tax Class: VAT-Standard

Tax Rate: Germany-StandardVAT

Priority: 0

Sort Order: 0

Retail-Germany-
ReducedVAT

Customer Class: Retail Customer

Tax Class: VAT-Reduced

Tax Rate: Germany-ReducedVAT

Priority: 0

Sort Order: 0

Tax Rules (cont.)

Step 4: Set Up a Store View for Germany

1. In the upper-left corner of the Admin, click the Manage Stores link.

2. Under the default website, create a store view for Germany. Then, do the following:

a. On the Admin menu, select System > Configuration. In the upper-left corner, set
Default Config to the French store.

b. On the General page, click to expand the Countries Options section, and set the
default country to “France.”

c. Complete the locale options as needed.

3. In the upper-left corner, set Current Configuration Scope to the German website. Then, do
the folloiwng:

a. On the General page, click to expand Countries Options, and set the default country
to “Germany.”

b. Complete the locale options as needed.
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Step 5: Configure General Tax Settings for France

Complete the following General tax settings:

FIELD RECOMMENDED SETTING

Tax Class for Shipping Shipping (shipping is taxed)

Tax CalculationMethod
BasedOn

Total

Tax Calculation BasedOn Shipping Address

Catalog Prices Including Tax

Shipping Prices Including Tax

Apply Customer Tax After Discount

Apply Discount on Prices Including Tax

Apply Tax On Customer Price if available

Default Country France

Default State

Default Postal Code * (asterisk)

Include Tax in Grand Total Yes

Enable FPT Yes

All FPT Display Settings Including FPT and FPT description

Apply Discounts to FPT No

Apply Tax to FPT Yes

Include FPT in Subtotal Yes

General Tax Settings
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Step 6: Configure Settings for Germany

1. On the Admin menu, select System > Configuration.

2. In the panel on the left, under Sales, select Tax. Then, do the following:

a. In the upper-right corner, set Current Configuration Scope to the German store.

b. To t he right of the Default Country field, clear the Use Website checkbox. Then, set
Default Country to “Germany.”

c. To the right of the Default State field, clear the Use Website checkbox. Then, set
Default State to “*.”

d. To the right of the Default Post Code field, select the Use Website checkbox. Then, set
Default Post Code to “*.”

3. When complete, click the Save Config button to save the settings.

Default Tax Destination Calculation
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Warning Messages
Some combinations of tax-related options might be confusing to customers and trigger a
warning. These conditions might occur when the tax calculation method is set to “Row” or
“Total,” and the customer is presented with prices that both exclude and include tax, or a
tax on an item basis in the cart. Because the tax calculation is rounded, the amount that
appears in the cart might differ from the amount that a customer expects to pay.

Shopping Cart Line Item that Includes and Excludes Tax

If your tax calculation is based on a problematic configuration, the following warnings
appear:
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Calculation Settings
Use the following tables for reference when configuring tax calculation settings:

Tax Calculation Method Based On: Excluding Tax

PRICE DISPLAY UNIT PRICE ROW TOTAL TOTAL

Tax Class for
Shipping

Shipping (is taxed)

Excluding tax OK OK OK

Including tax OK OK OK

Including and
Excluding tax

OK OK Warning

Tax Excluded

Catalog Prices: Including Tax

PRICE DISPLAY UNIT PRICE ROW TOTAL TOTAL

Excluding tax OK OK OK

Including tax OK OK OK

Including and
Excluding tax

OK Warning Warning

Tax Included

Calculation Settings
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Discount Settings
We strongly recommend that you use the following settings to avoid issues when
configuring taxes in relation to discounts.

FIELD RECOMMENDED SETTING

Apply Customer Tax After Discount

Apply Discount on Prices US and Canada Excluding Tax

EU Including Tax

Recommended Settings

Calculation Settings
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CHAPTER 65:

Currency Rates
Magento Enterprise Edition gives you the ability to accept currencies from more than
two hundred countries around the world. When a store supports multiple currencies, a
Currency Chooser appears in the header of every page after the rates are updated.

Currency Chooser

If you accept payment in multiple currencies, make sure to monitor the currency rate
settings, because any fluctuation can affect your profit margin.

Currency symbols appear in product prices and sales documents such as orders and
invoices. You can customize the currency symbols as needed, and also set the display of
the price separately for each store or view.

Topics in this chapter include:

l Currency Setup

l Currency Symbols

l Updating Currency Rates



Currency Configuration CHAPTER 65:  Currency Rates

1016 Magento Enterprise Edition User Guide, Version 1.14.2.1

Currency Configuration
Before setting up individual currency rates, you must first specify which currencies you
accept, and the currency used to display prices in your store.

Step 1: Choose the Currencies You Accept

1. On the Admin menu, select System > Configuration.

2. In the panel on the left, under General, select Currency Setup.

3. Click to expand the Currency Options section. Then, do the following:

a. Set Base Currency to the primary currency that you use for online transactions.

b. Set Default Display Currency to the currency that you use to display pricing in your
store.

c. In the Allowed Currencies list, select all currencies that you accept as payment in
your store. Make sure that you also select your primary currency. (To select multiple
currencies, hold down the Ctrl key and click each option.)

Currency Options

4. To define the scope of the base currency configuration, do the following:

a. In the panel on the left, under Catalog, select Catalog. Then, click to expand the Price
section.

b. Set Catalog Price Scope to define the scope of the base currency configuration as
either global, or limited to the website.
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Price

5. When complete, click the Save Config button.

Step 2: Configure the Import Connection

1. In the panel on the left under General, select Currency Setup.

2. Click to expand theWebserviceX section.

3. In the Connection Timeout in Seconds field, enter the number of seconds of inactivity to
allow before the connection times out.

WebserviceX

Step 3: Configure the Scheduled Import Settings

1. Continuing with Currency Setup, click to expand the Scheduled Import Settings section.

2. To automatically update currency rates, set Enabled to "Yes." Then, do the following:

a. Set Service to the rate provider. The default value is “Webservicex.”

b. Set Start Time to the hour, minute, and second that the rates will be updated
according to the schedule.

c. To determine how often the rates are updated, set Frequency to one of the following:

l Daily

l Weekly

l Monthy

d. In the Error Email Recipient field, enter the email address of the person who is to
receive email notification if an error occurs during the import process. To enter
multiple email addresses, separate each with a comma.

e. Set Error Email Sender to the store contact that appears as the sender of the error
notification.

f. Set Error Email Template to the email template used for the error notification.
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3. When complete, click the Save Config button.

Scheduled Import Settings

Currency Symbols
Manage Currency Symbols gives you the ability to customize the symbol associated with
each currency that is accepted as payment in your store.

Manage Currency Symbols

To customize currency symbols:

1. On the Admin menu, select System > Manage Currency > Symbols.

Each enabled currency for your store appears in the Currency list.

2. Enter a custom symbol for each currency you want to use, or select the Use Standard
checkbox to the right of each currency.

3. To override the default symbol, clear the Use Standard checkbox. Then, enter the symbol
you want to use.

It is not possible to change the alignment of the currency symbol from left to right.

4. When complete, click the Save Currency Symbols button.

Updating Currency Rates
Currency rates can be set manually, or be imported into the store. To ensure that your store
has the most current rates, you can configure the currency rates to be updated
automatically on schedule.
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Before importing currency rates, complete the Currency Setup to specify the currencies that
you accept, and to set up the import connection and schedule.

Importing Currency Rates

To manually update a currency rate:

1. On the Admin menu, select System > Manage Currency Rates.

2. Click the rate you want to change, and type the new value.

3. When complete, click the Save Currency Rates button.

To import currency rates:

1. On the Admin menu, select System > Manage Currency Rates.

2. Set Import Service to the currency rate provider. WebserviceX is the default provider.

3. Click the Import button.

The updated rates appear in the Manage Currency Rates list. If the rates have changed
since the last update, the old rate appears below for reference.

4. When complete, click the Save Currency Rates button.

A message appears when the updated rates have been saved.

To import currency rates on schedule:

1. Make sure that Cron is enabled for your store.

2. Complete the Currency Setup to specify the currencies that you accept, and to set up the
import connection and schedule.

3. To verify that the rates are imported on schedule, check the Manage Currency Rates list.
Then, wait for the duration of the frequency setting established for the schedule, and check
the rates again.
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Notes
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CHAPTER 66:

Managing Email Templates
Email templates define the layout, content, and formatting of automated messages
sent from your store. They are called transactional emails1 because each one is
associated with a specific type of transaction, or event.

Magento includes a set of responsive email templates that are triggered by a variety of
events that take place during the operation of your store. Each template is optimized
for any screen size, and can be viewed from the desktop, as well as on tablets and
smartphones. You will find a variety of prepared email templates related to customer
activities, sales, product alerts, admin actions, and system messages that you can
customize to reflect your brand.

Topics in this chapter:

l Supported Email Clients

l Template Layout and Styles

l Preparing Your Email Logo

l Magento Upgrades

l Transactional Email Configuration

l Email Template Setup

l Customizing Email Templates

l Email Template Reference

1An automated email message that is sent in response to a specific event or transaction.
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Supported Email Clients
A wide range of technologies is supported by the various email clients and services
available today. Although they do not all follow the same standards, and there is some
variation in the way email messages are rendered, we have found the following services to
be compatible with Magento Enterprise Edition.

Desktop Clients
OPERATING SYSTEM CLIENTS SUPPORTED

OS X 10.8 AppleMail 6

OS X 10.7 Outlook 2011
Outlook 2013

Windows 8 Outlook 2010

Windows 7 Outlook 2007
Outlook 2003

Mobile Clients
OPERATING SYSTEM CLIENTS SUPPORTED

Android 4.2, “Jelly Bean” Native email app

Android 2.3, “Gingerbread” Native email app

Gmail App (Android 4.2) Native email app

Blackberry 5 OS Native email app

IOS 8 iPhone 6
iPhone 6 Plus

IOS 7 iPad (Retina)
iPadMini
iPhone 5s

Mail on these devices:

IOS 6 iPhone 5
iPhone 4s
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Web Clients
EMAIL APPLICATION BROWSERS SUPPORTED*

AOLMail Chrome
Internet Explorer
Firefox

Gmail Chrome
Internet Explorer
Firefox

Yahoo! Mail Chrome
Internet Explorer
Firefox

Outlook.com Chrome
Internet Explorer

* The latest version of each browser was used for testing.
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Template Layout and Styles
Magento Enterprise Edition has a set of responsive templates that define the header, body,
and footer of all automated email messages that are sent from your store. The content, or
body section, is combined with the header and footer to create each message. You can set
up the header and footer one time, and then use them for every message.

Inline and Non-Inline Styles
Email templates are written in HTML, and are associated with the locale. The CSS files that
provide the formatting instructions are stored separately, and reside on the server.

Many email clients do not support CSS formatting instructions that are stored separately
from the email message. For this reason, the non_inline_styles variable has been
added to the header of each message, to convert the external CSS styles to local, inline
styles. The variable points to the CSS file on the server that provides the styles that are
needed to format the template. The styles are then converted to inline styles, and copied to
the <styles> tag of each message.

When you examine the header template code, you will find the markup tag with the non_
inline_styles variable just after the <body> tag.

<body>

{{var non_inline_styles}}

<!-- Begin wrapper table -->

When customizing transactional email templates from the Admin, you can enter any
additional CSS styles that you need directly into the Template Styles box. They will be
included when the non_inline_styles are converted.
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Preparing Your Email Logo
To ensure that your logo renders well on high-resolution devices, the uploaded image
should be at least twice the size of the dimensions that are specified in the header template.
Be careful to preserve the aspect ratio1 of the logo, so the height and width resize
proportionally.

Logo with Transparent Background

Supported File Formats
Logos can be saved as any of the following file types. Logos with transparent backgrounds
can be saved as either .gif or .png files.

l jpg / jpeg

l gif

l png

Image Size
To make the most of the limited vertical space in the header, the logo should be cropped to
eliminate any wasted space above or below the image. As a general rule, you can make an
image smaller than the original, but not larger without losing resolution. If possible, the
original artwork should be at least as large as the uploaded file. Taking a small image and
doubling its size in a photo editor does not improve the resolution.

For example, in the default header template, the display dimensions of the logo are 168
pixels wide by 48 pixels high. To increase the resolution of the image, the image that is
uploaded must be at least twice the size.

DIMENSIONS 1 X (DISPLAY SIZE) 2 X (IMAGE SIZE) 2.5 X (IMAGE SIZE)

Width: 168 px 336 px 420 px

Height: 48 px 96 px 120 px

1The proportional relationship between the width and height of an image.
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If the original artwork was created as a vector, rather than a bitmap, it can be scaled up or
down to the dimensions needed without losing resolution. The image can then be saved in
one of the supported bitmap image formats. If the original logo artwork is a bitmap, the
original should be at least twice the display size.

Magento Upgrades
If you have upgraded from an earlier version of Magento Enterprise Edition, you can use an
email client to view each transactional email template that is generated by your store.
Verify that the logo, fonts, and styles render correctly.

Email templates that were created with earlier versions of Magento will not have the non_
inline_styles variable, and will not be responsive. However, most can be used as they
are.

To take advantage of the high-resolution display that is available on many devices, email
logos are now uploaded at twice their display size. If you intend to use the responsive email
templates, you should upload a higher resolution logo.

It is not necessary to reconfigure your email logo for use with custom templates that were
created with earlier versions of Magento.

Transactional Email Configuration
The configuration for transactional email templates is designed to support multiple
devices. The email logo that is uploaded is designed to render well on high-resolution
displays. The configuration specifies the header and footer templates that are used for all
transactional email messages sent within the scope of the configuration. To support the
requirements of many email clients, a variable has been added that is used to convert
external CSS styles to inline styles. The name of the external CSS file that it references is
specified in the configuration.

Transactional Emails

http://merch.docs.magento.com/ee/user_guide/Magento_Enterprise_Edition_User_Guide.html#configuration/general/design.html%23Transactional_Emails
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To configure transactional email templates:

1. On the Admin menu, select System > Configuration.

2. In the panel on the left, under General, select Design.

3. If needed, set Current Configuration Scope in the upper-left corner to the website, store, or
store view where the configuration applies.

4. Click to expand the Transactional Emails section. Then, do the following:

Step 1: Upload Your Logo

1. To upload your prepared Logo Image, click the Browse button. Find the file on your
computer, and click to copy the path to the field.

2. In the Logo Image Alt field, enter the alternate text to identify the image.

If you uploaded a logo image, enter the Logo Width and Logo Height in pixels. Enter each
value as a number, without the “px” abbreviation. These values refer to the display
dimensions of the logo in the header, and not to the actual size of the image.

Step 2: Select the Header and Footer Templates

If you have custom header and footer templates for your store, or for different stores, you
can specify which templates should be used for each, according to the scope of the
configuration.

1. Select the Email Header Template to be used for all transactional email messages.

2. Select the Email Footer Template to be used for all transactional email messages.

Step 3: Identify the CSS File(s)

In the Non-inline CSS File(s) field, enter the name of each CSS file that is needed to
format the content of your transactional email messages. Separate the names of mutiple
files with a comma. On the server, the CSS files reside in the following location:

[magento install dir]/skin/frontend/[package]/[theme]/css/
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Email Template Setup
After creating a customized version of a template, remember to update your system
configuration so the correct template is used for each message. You can access the template
configuration from the System Configuration menu, or by clicking the link at the top of the
template when open in edit mode.

Sales Email Configuration

Method 1: Link to Configuration

This method is convenient to use when you finish customizing a template. With the
template open in edit mode, simply click the link at the top of the Template Information
section to jump to the configuration settings for the template.

Link to Template Configuration Settings

Method 2: Navigate to the Configuration

This is a convenient method when you have many customized templates that need to be
added to the configuration.

http://merch.docs.magento.com/ee/user_guide/Magento_Enterprise_Edition_User_Guide.html#configuration/sales/sales-emails.html
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To configure sales email templates:

1. On the Admin menu, select System > Configuration.

2. In the panel on the left under Sales, select Sales Emails. Then, select the appropriate
template for the following sections:

Order Order Comments

Invoice Invoice Comments

Shipment Shipment Comments

Credit Memo Credit Memo Comments

RMA RMA Admin Comments

RMA Customer Comments

RMA Authorization

Order

3. When complete, click the Save Config button.

1029Magento Enterprise Edition User Guide, Version 1.14.2.1

http://merch.docs.magento.com/ee/user_guide/Magento_Enterprise_Edition_User_Guide.html#configuration/sales/sales-emails.html%23Order


Customizing Email Templates CHAPTER 66:  Managing Email Templates

1030 Magento Enterprise Edition User Guide, Version 1.14.2.1

To configure customer email templates:

1. On the Admin menu, select System > Configuration.

2. In the panel on the left under Customer, select Customer Configuration. Then, select the
appropriate template for the following sections:

l Create New Account Options

l Password Options

l Store Credit Options

Store Credit Options

3. When complete, click the Save Config button.

Customizing Email Templates
Magento includes a default email template for the body section of each message that is
sent by the system. Each template with the body content is combined with the header and
footer templates to create the complete message. The content is formatted with HTML and
CSS, and can be easily edited, and customized by adding variables and widgets.

The default templates already include your logo and store information and can be used as
they are, without further customization. As a best practice, you should view each default
email template and verify any changes you make before sending them to customers.

When a custom template is ready to be used, make sure to update your system
configuration, so the custom template will be used instead of the default template. Email
templates can be customized for each website, store, or store view. For detailed
instructions, see the following topics:

l Header Template

l Footer Template

l Content Templates

http://merch.docs.magento.com/ee/user_guide/Magento_Enterprise_Edition_User_Guide.html#configuration/customers/customer-configuration.html%23Store_Credit_Options
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Header Template
The default header includes your email logo that is linked to your store. You can easily
insert variables to add store contact information to the header. To make more extensive
changes requires a working knowledge of both HTML and CSS. On the server, the header
template is located at:

[Magento install dir]/app/locale/en_US/template/email/html/header

Step 1: Load the Template

1. On the Admin menu, select System > Transactional Emails.

2. Click the Add New Template button. Then, do the following:

a. Set Template to “Email - Header.”

b. Set Locale to the language of the email recipients.

3. Click the Load Template button.

Choosing the Email - Header Template

Step 2: Customize the Template

When working in the template code, be careful not to overwrite anything that is enclosed in
double braces.

1. In the Template Name field, enter a name for your custom header.

2. In the Template Content box, modify the HTML as needed.
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Template Information

3. To insert a variable, position the cursor in the code where you want the variable to appear,
and click the Insert Variable button. Then, do the following:

a. In the list of Store Contact Information variables, click the variable that you want to
insert.

You are not limited to the variables in this list, although they are the ones most often
included in the header. You can actually type the code for any system variable directly
into the template.

b. Click the Preview Template button. Then, make any adjustments to the template that
are needed.

Insert Variable

4. When complete, click the Save Template button.

Your custom header now appears in the list of Transactional Email templates.
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Custom Header Template

Step 3: Update the Configuration

1. On the Admin menu, select System > Configuration.

2. If necessary, set the Current Configuration Scope to the website, store, or store view where
the header will be used.

3. In the panel on the left, under General, select Design.

4. Click to expand the Transactional Emails section, and do the following:

a. If the header is for a specific view, clear the Use Website checkbox that is next to the
Email Header Template field.

b. Set Email Header Template to the name of the custom header that you just created.

Transactional Emails

5. When complete, click the Save Config button.
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VARIABLE MARKUP TAG

Base Unsecure URL {{config path="web/unsecure/base_url"}}

Base Secure URL {{config path="web/secure/base_url"}}

General Contact Name {{config path="trans_email/ident_general/name"}}

General Contact Email {{config path="trans_email/ident_general/email"}}

Sales Representative
Contact Name

{{config path="trans_email/ident_sales/name"}}

Sales Representative
Contact Email

{{config path="trans_email/ident_sales/email"}}

Custom1Contact Name {{config path="trans_email/ident_custom1/name"}}

Custom1Contact Email {{config path="trans_email/ident_custom1/email"}}

Custom2Contact Name {{config path="trans_email/ident_custom2/name"}}

Custom2Contact Email {{config path="trans_email/ident_custom2/email"}}

Store Name {{config path="general/store_information/name"}}

Store Contact Telephone {{config path="general/store_information/phone"}}

Store Contact Address {{config path="general/store_information/address"}}

Store Contact Information Variables

Footer Template
The footer contains the closing and signature line of the email message. You can change the
closing to fit your style, and add additional information, such as the company name and
address below your name. More extensive changes requires a working knowledge of both
HTML and CSS. On the server, you will find the footer template in the following location:

[Magento install dir]/app/locale/en_US/template/email/html/header.html

Step 1: Load the Template

1. On the Admin menu, select System > Transactional Emails.

2. Click the Add New Template button. Then, do the following:
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a. Set Template to “Email - Footer.”

b. Set Locale to the language of the email recipients.

3. Click the Load Template button.

Choosing the Email - Footer Template

Step 2: Customize the Template

When working in the template code, be careful not to overwrite anything that is enclosed in
double braces.

1. In the Template Name field, enter a name for your custom footer.

2. In the Template Content box, modify the HTML as needed.

Footer Template Information

3. To insert a variable, position the cursor in the code where you want the variable to appear,
and click the Insert Variable button. Then, do the following:
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a. In the list of Store Contact Information variables, click the variable that you want to
insert.

b. When you’re done, click the Preview Template button to verity the code. Then, make
any adjustments to the template that are needed.

Insert Variable

4. When the template is finalized, click the Save Template button.

Your custom footer now appears in the list of Transactional Email templates.

Custom Footer Template

Step 3: Update the Configuration

1. On the Admin menu, select System > Configuration.

2. If necessary, set the Current Configuration Scope to the website, store, or store view where
the header will be used.

3. In the panel on the left, under General, select Design.

4. Click to expand the Transactional Emails section, and do the following:
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a. If the header is for a specific view, clear the Use Website checkbox that is next to the
Email Footer Template field.

b. Set Email Footer Template to the name of the custom footer that you just created.

Transactional Emails

5. When complete, click the Save Config button.

Message Templates
The process of customizing the main body of each message is the same as the customizing
the header or footer. The only difference is that there are many templates, listed in
alphabetical order. You can use the templates as they are, or customize the most important
messages first, such as messages related to customer accounts, and customer activities. For
a complete list, see the Email Template Reference at the end of this section.

Step 1: Choose a Default Template

1. On the Admin menu, select System > Transactional Emails.

2. Click the Add New Template button.

3. In the Template list, select a default template from the list of predefined templates.

Load Default Template

4. If necessary, set the Locale to the store language.

5. Click the Load Template button.
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The path to the configuration settings for each default template appears at the top of the
Template Information section. You can click this link later when you are ready to update
the configuration with the name of the new template.

Template Information

Step 2: Customize the Content

1. In the Template Information section, do the following:

a. Enter a Template Name for the new email template.

b. In the Template Subject field, type the text that you want to appear in the Subject
line of the message.

c. For a better view of the content and variables in the message, click the Convert to
Plain Text button. When prompted to confirm, click OK.

d. To restore the HTML, click the Return HTML Version button.

e. Edit the Template Content as needed.

2. (Optional) To insert a variable, do the following:

a. Position the cursor in the text where you want the variable to appear.

b. Click the Insert Variable button.
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The list includes the standard Store Contact Information variables, and an additional
list of variables that are specific to the template.

c. In the list of available variables, click the variable you want to insert into the
template.

When a variable is selected, the markup tag that is associated with the variable is
inserted at the cursor position in the code.

Insert Variable

3. When complete, click the Save Template button.

4. Make sure to Preview the template code, and verify that the template is customer-ready.

Step 3: Update Your Configuration

1. Before the template can be used, the configuration must be updated with the name of the
new template. Do one of the following:

l Click the link at the top of the Template Information section to jump to the
configuration settings for the template.

l On the Admin menu, select System > Configuration. Then in the panel on the left,
under Sales, select Sales Emails.
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Sales Email Configuration

2. Update the templates as needed for each email.

3. When complete, click the Save Config button.

http://merch.docs.magento.com/ee/user_guide/Magento_Enterprise_Edition_User_Guide.html#configuration/sales/sales-emails.html
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Email Templates
Customer Account

New Account
New Account Confirmation Key
New Account Confirmed
Forgot Password
Remind Password

Customer Activity
Contact Form
Customer Invitation
Send Product to a Friend
ShareWishlist
Gift Card Account Sent from Edit Page
Gift Card Accounts Generated from Gift
Card
Gift Registry Owner Notification
Gift Registry Sharing
Gift Registry Update
Reward Points Balance Update
Reward Points Expiry Warning

Newsletters
Newsletter Subscription Confirmation
Newsletter Subscription Success
Newsletter Unsubscription Success

Admin Activity
Forgot Admin Password
Currency UpdateWarnings
Import Failed / Export Failed
Email - Footer
Email - Header
Rule Reminder

System Notifications
Log CleanupWarnings
File History Clean Failed
Token Status Change
SitemapGenerateWarnings

Product Alerts
Product Alerts Cron Error
Product Price Alert
Product Stock Alert

Order Fulfillment
New Order
New Order for Guest
Order Update
Order Update for Guest
Payment Failed
New Invoice
New Invoice for Guest
Invoice Update
Invoice Update for Guest
New Shipment
New Shipment for Guest
Shipment Update
Shipment Update for Guest
New Credit Memo
New Credit Memo for Guest
Credit MemoUpdate
Credit MemoUpdate for Guest
Store Credit Update
New RMA
New RMA for Guest
RMA Admin Comments
RMA Admin Comments for Guest
RMA Authorization
RMA Authorization for Guest
RMA Customer Comments
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CHAPTER 67:

Managing Data Transfer
The Import/Export tool gives you the ability to manage multiple customer and product
records in a single operation. If you have a large catalog of products, you will find it
much easier to export the data, edit the data in a spreadsheet, and then import the
data back into your store.

The CSV file format separates each data element by a comma, and is used as the
standard for data exchange operations. All spreadsheet and database applications
support the CSV file format. If you are working with a Mac, you should save the data in
the CSV (Windows) format.

Topics in this chapter:

l Working with CSV Files

l Importing Data

l Exporting Data

l Scheduled Import / Export



Working with CSV Files CHAPTER 67:  Managing Data Transfer

1044 Magento Enterprise Edition User Guide, Version 1.14.2.1

Working with CSV Files
CSV files have a specific structure that must match the database. Each column heading
must exactly match the Attribute Code of the attribute that is represented by the column.
To ensure that the column headings can be read by Magento, first export the data from
your store as a CSV file. You can then edit the data and re-import it into Magento.

Important!We recommend that you use a program that supports UTF-8 encoding to edit CSV
files, such asNotepad++ orOpenOffice Calc. Microsoft Excel inserts additional characters into
the column header of the CSV file, which can prevent the data from being imported back into
Magento.

Product CSV Structure
The catalog products CSV file contains information about products and the relationships
between them. The table has the following structure:

Exported Product CSV in OpenOffice Calc

The first row of the table contains the names of the columns, there are two types of the
names, as shown in the following table. Other rows contain attributes values, service data,
and complex data. If a row contains the value in the SKU column, then this row the rows
below it describe the product. Each new SKU value begins the description of the next
product.

Each category is entered as a path, with a forward slash (/) between each level. For
example: Furniture/Living Room. Do not include the Root Category in the path.

During import, if a row that contains the SKU value is found to be invalid, then the row,
and all other rows with data for that product cannot be imported.

The minimal valid table contains only the SKU column. It can be used to delete entries
from the database. There is no limit to the number of the columns in the table. Columns
that do not contain data are ignored.

http://notepad-plus-plus.org/
https://www.openoffice.org/
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Exported Product CSV in Notepad++

_<name> The names of the service columns and complex data columns.
Service columns contain entity properties, which are not
attributes. For example, columns with website or product type
information are service columns. The underscore as first
character is used to distinguish these columns from the attribute
column names.

<attribute name> The names of the columns with values of both system-created
attributes and attributes created by the store administrator.

Product Column Names

Customer CSV Structure
The customers CSV file contains customer information from the database, and has the
following structure:

Exported Customer CSV in OpenOffice Calc

The first row of the table contains the names of the attribute columns (which are the same
as attribute codes). There are two types of column names, as shown in the following table.
Other rows contain attribute values, service data, and complex data. Each row with non-
empty values in the email and _website columns starts the description of the
subsequent customer. Each row can represent customer data with or without address data,
or the address data only. In case a row contains only the address data, values in the
columns, related to the customer profile, will be ignored and may be empty.
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To add or replace more than one address for a customer, in the import file add a row for
each new address with empty customer data and the new or updated address data below
the customer data row.

Exported Customer CSV in Notepad++

_<name> The names of the service columns, and complex data columns.
Service columns contain entity properties, which are not
attributes. For example, columns with website or store
information are service columns. The underscore as first
character is used to distinguish these columns from the other
attributes names.
The _address_default_billing and the _address_
default_shipping columns are the default billing and
shipping addresses flags. If the address in the row is the default
billing and/or shipping address of the client, the _address_
default_billing and/or _address_default_shipping
columns in this row will have a value of “1.”

<attribute name> The names of the columns with values of both system-created
attributes, and attributes created by the store administrator.

Customer Column Names

Import
Importing is available for all product types, except bundle, gift card, and downloadable
products. You can import customer data, product data, and product images.

File Validation
During the file validation process, all attribute values are checked for conformance with the
required data type (decimal, integer, varchar, text, datetime). Complex data, service data,
and attributes with values from a defined set (such as a drop-down or multiple select), are
checked to ensure their values exist in the defined sets.

For new entities, the presence of the required attribute values is checked. For existing
entities, the presence of required attributes values is not checked, but if a required value is
specified, it is validated by the attribute type.
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To import customer or product data:

1. On the Admin menu, select System > Import/Export > Import. Then, do the following:

Import Settings

a. Set Entity Type to one of the following:

l Products

l Customers

b. Set Import Behavior to the way you want complex data to be managed if imported
records already exist in the database.

l Complex data for products includes categories, websites, custom options, tier prices,
related products, up-sells, cross-sells, and associated products data.

l Complex data for customers includes addresses.

c. Choose one of the following options:

Append Complex
Data

The new complex data will be added to the existing complex
data for the existing entries in the database.

Replace Existing
Complex Data

The existing complex data for the existing entities will be
replaced.

Delete Entities If entities that are imported already exist in the database, they
will be deleted from the database.

d. At the Select File to Import field, click the Choose File button. Then, select the CSV
file that you have prepared for import.

2. Click the Check Data button in the upper-right corner of the page. The system validates the
file. If the file is valid, the corresponding message and the Import button appear. If some of
the rows in the imported file are not valid and cannot be imported, the corresponding
information is included to the message, but you can proceed with importing. The invalid
rows will be skipped.

3. If needed, make corrections to the CSV file.

4. Click the Import button to import the data into the database.
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Importing Product Images
Multiple product images of each type can be imported into Magento, and associated with
the correct product. The path and file name of each product image is entered in the CSV
file, but the actual image files must be uploaded to the media/import directory on the
server.

Magento maintains product images in a directory structure that is organized
alphabetically. When you export product data to a CSV file, you can see the alphabetized
path before the file name of each image. However, when you import images, you typically
don’t need to specify a path, because Magento can manage it automatically. Usually, the
only thing you need to do is enter a forward slash before the file name of each image that is
to be imported.

Review the steps in the import method that you want to use, and run through the process
with a few products. After you understand how it works, you’ll feel confident importing
large quantities of images.

Important!We recommend that you use a program that supports UTF-8 encoding to edit CSV
files, such asNotepad++ orOpenOffice Calc. Microsoft Excel inserts additional characters into
the column header of the CSV file, which can prevent the data from being imported back into
Magento.

Method 1: Import Images to Default Path

The easiest way to import product images is to use Dataflow, and let Magento create and
manage the directory structure. For complete instructions, see Dataflow.

http://notepad-plus-plus.org/
https://www.openoffice.org/


CHAPTER 67:  Managing Data Transfer Import

Method 2: Import Images to Specific Path

1. To import image files into a specific path, create the required directory structure in the
media/import folder as follows:

a. Create the parent folder, named for the first character of the image file name.

b. Create a subfolder, named for the second character of the image file name. For
example, the import path for filename.jpg would be as follows:

[magento installation folder]/media/import/f/i/filename.jpg

c. Set the following permissions for all image folders and files:

Image Folders: 0777

Image Files: 0666 (or greater)

To set the appropriate permissions, change directories to the media/import folder,
and enter the following from the command line:

find . -type d -exec chmod 777 {} \;

find . -type f -exec chmod 666 {} \;

2. In the CSV file, the image path and file name must be entered in the image, small_
image, and media_image columns for the correct SKU, according to image type. If you
prefer, you can use the same image for each type.

a. In the appropriate column, enter the relative path to each image in the following
format:

/f/i/filename.jpg

Important!Use only lowercase characters in the image path and file name of any image to
be imported.

b. Make sure that the correct SKU is entered on each row that has an image file.

3. Complete the standard process to import product data.
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Import Guidelines

New Entities

Entities are added with the attribute values specified in the CSV file.

If there is no value, or there is a non-valid value, for a required attribute with no default
value set, then the entity (the corresponding row or rows) cannot be imported.

If there is no value, or there is a non-valid value, for a required attribute with the
default value set, then the entity (the corresponding row or rows) is imported, and the
default value is set for the attribute.

If the complex data is not valid, then the entity (the corresponding row or rows)
cannot be imported.

Existing Entities

For attributes that are not complex data, the values from the import file, including the
empty values for the non-required attributes, replace the existing values.

If there is no value, or there is a non-valid value, for a required attribute, then the
existing value is not replaced.

If the complex data for the entity is invalid, the entity (the corresponding row or rows)
cannot be imported, except the case, when Delete Entities was selected in the
Import Behavior drop-downmenu.
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Complex Data
If an attribute that is specified in the import file already exists, and its value is derived
from a defined set of values, the following applies:

If the value is not already included in the defined set of values, the row can be
imported and a default value, if defined, is set for the attribute.

If the value is already included in the defined set, the corresponding row cannot be
imported.

If an attribute name is specified in the import file but is not yet defined in the system, it is
not created, and its values are not imported.

Invalid Files

A file cannot be imported if all rows are invalid.

A non-existing service data or complex data name is specified in the import file, such
as a columnwith a “_<non-existing name>” heading.
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Export
The best way to become familiar with the structure of your database is to export the data
and open it in a spreadsheet. Once you become familiar with the process, you’ll find that it
is an efficient way to manage large amounts of information.

All product types except gift cards can be exported.

To export customer or product data:

1. On the Admin menu, select System > Import/Export > Export.

2. In the Export Settings section, specify the following:

a. Set Entity Type to one of the following:

l Customers

l Products

b. Accept the default Export File Format of “CSV.”

Export Settings

3. In the Entity Attributes section, you can include or exclude data to be exported according
to the entity attribute values.

l To include records with specific attribute values, set the required values of the attributes
in the Filter column.

l To omit an attribute from the export, select the Skip checkbox at the beginning of the
row.



CHAPTER 67:  Managing Data Transfer Dataflow

Export Customers Based on Attribute Value

4. Scroll down and click the Continue button in the lower-right corner of the page. Look for
the download prompt in the lower-right corner of your browser.

The CSV file that is generated can be edited and imported back into your store. Or, it can be
used for mailing or other application.

Dataflow
Magento Dataflow is a data exchange framework that can be used by both merchants and
developers. The basic Dataflow tool includes preconfigured profiles that make it easy to
import and export product and customer data. The profiles can be used as they are, or be
modified to meet your needs. You can create additional profiles for operations that are
performed on a regular basis. For more sophisticated applications, Advanced Profiles can be
defined in XML to perform custom data exchange operations.

The following instructions show how to use Dataflow profiles to export all product data,
and import new product images.

Step 1: Export All Products

1. Before you begin, make sure that all changes to the product data have been saved.

2. On the Admin menu, select System > Import/Export > Dataflow - Profiles.

3. In the list of profiles, select Export All Products.

4. In the panel on the left, click Run Profile.

5. To begin the process, click the Run Profile in Popup button.
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6. Wait a few moments for the profile to begin execution. The length of time it takes to
complete the process depends on the size of the database. Do not close the window.

7. When the process is complete,you can find the exported CSV file in the following location
on the server:

[magento-install-dir]/var/export/export_all_products.csv

Here’s how the exported data file looks from the command line of the server:

Exported CSV File from Command Line

8. Use an SFTP utility to download the export_all_products.csv file from the server to your
desktop.

Downloaded File

9. Then, open the file in any editor that supports UTF-8 encoding, such as Notepad++ or
OpenOffice Calc. To open the CSV file in OpenOffice Calc,specify a comma as the separator,
and double quotes as the text delimiter.

http://notepad-plus-plus.org/
https://www.openoffice.org/
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Text Import Separator Options

The CSV data appears in the spreadsheet as rows of product records organized into
columns of attributes, with the Attribute Code in the header of each column.

Exported Product Data in OpenOffice Calc

Step 2: Copy Images to the Server

The CSV file contains a path to each product image, but the actual image files must be
uploaded to the server. To make the images available to import, place them in the
media/import directory.

[magento-install-dir]/media/import

Use your SFTP utility to copy the product images that you want to import to the
media/import folder.
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Copy Images to media/import Folder

Step 3: Edit the CSV File

1. Edit the data as needed.

2. Save your changes to the CSV file.

For this example, we will add three new images to SKU #hdb005. Because this is the only
product record that we’re going to update, the others can be deleted from the CSV file.

Currently, this product has only one image that is used for the base image, small image,
and thumbnail. Because we’re going to now offer this product in three colors, we need to
upload an image for each color, and replace the image that’s currently assigned to the
product. Because this is a simple product, we can later use Custom Options to add an
option for each color.

Magento creates a directory structure of product image files that is organized
alphabetically. You can see that path before each image file name in the CSV data.
However, when you import images, you must never include that path before the file name.
The only thing you have to do is to enter a forward slash before the file name of each image
that you want to import. Magento takes care of the rest. For this example, we need to add
the three image files that were uploaded to the media/import folder.

/hdb005_HOTP_600.jpg

/hdb005_MARM

/hdb005_SALM_600.jpg

In the data, we will replace the original image file name, and add the other two image file
references on separate blank lines. just below the original row. You must also enter the SKU
on each additional line, to associate the images with the product.
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Update the CSV File with the Import Data

Step 4: Import Products

1. On the Admin menu, select System > Import/Export > Dataflow - Profiles.

2. In the list of profiles, select Import All Products.

This general-purpose profile that can be used to import or update any number or product
records.

3. In the panel on the left, select Upload File.

4. Because we’re uploading only one file, click the Browse button for File 1. Then, find the file
on your computer and click to select it. The path to the file appears in the input box.

5. Click the Save and Continue Edit button.

6. In the panel on the left, select Run Profile.

7. Select the CSV file that you edited. If there are several files in the list, make sure to select
the right one. Then, click the Run Profile in Popup button.

8. Wait a few moments for the profile to begin the import process. Do not close the window or
interrupt the process. Look for the “Finished Profile Execution” message at the bottom of
the list when the import process is complete. If you receive an error message, correct the
problem in the CSV file, and try again.

Step 5: Update the Index

Usually the index needs to be updated after changes are made to product data. If you
receive a message that the indexes are out of date, click the link and update the index.
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Scheduled Import/Export
Scheduled imports and exports can be run on a daily, weekly or monthly basis. The files to
be imported or exported can be located on local Magento servers, or on remote FTP servers.
Scheduled Import/Export is implemented by default, and does not require additional
configuration. All scheduled imports and exports are managed by the Cron job scheduler.

To access the scheduled import/export:

1. On the Admin menu, select System > Import/Export > Scheduled Import/Export.

Scheduled Import/Export

2. To create a new scheduled import or export job, click the Add Scheduled Import or Add
Scheduled Export button. After saving the record, a new scheduled import or export is
added to the list on the Scheduled Import/Export page.

3. After each scheduled import and export operation, a copy of the import or export file is
placed in the var/log/import_export/%Y%/%m%/%d%/ directory on the Magento local
server.

The details of each import/export operation are not written to a log, but if an error occurs,
you will receive an Import or Export Failed email, which contains the error description.

After each import job, a reindex operation is performed automatically.
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Scheduled Import
The Scheduled Import process is similar to the manual Import process, with respect to the
available import file format and types of import entities:

l The import file should be in .CSV format

l You can import product and customer data

The advantage of using Scheduled Import is that you can import a data file multiple times
automatically, after specifying the import parameters, and schedule only once.

The details of each import operation are not written to a log, but in case of failure you will
receive an Import Failed email, with a description of the error. The result of the last
scheduled import job is shown in the Last Outcome column on the Scheduled
Import/Export page.

After each import operation, a copy of the import file is placed in the var/log/import_
export/%Y%/%m%/%d%/ directory on the server where Magento is deployed. The
timestamp, the marker of the imported entity (products or customers), and the type of the
operation (in this case, import) are added to the import file name.

After each scheduled import job, a reindex operation is performed automatically. On the
frontend, changes in the descriptions and other text information are reflected after the
updated data goes to the database, and the changes in prices are reflected only after the
reindex operation.

Process Overview
Step 1: Complete the Import Settings
Step 2: Complete the Import File Information
Step 3: Configure the Import Failed Emails

To create a scheduled import:

1. On the Admin menu select System > Import/Export.

2. In the upper-right corner, click the Add Scheduled Import button. Then, do the following:
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Step 1: Complete the Import Settings

1. Enter a Name for the scheduled import.

2. Enter a brief Description that explains the purpose of the import, and how it is to be used.

3. Set Entity Type to one of the following:

l Products

l Customers

4. Set Import Behavior to one of the following:

Append Complex
Data

Adds new complex data to the existing complex data for existing
entries in the database. This is the default value.

Replace Existing
Complex Data

Writes over existing complex for existing entities in the database.

Delete Entities Deletes existing entries in the database.

5. Set Start Time to the hour, minute, and second that the import is scheduled to begin.

6. Set Frequency to one of the following:

l Daily

l Weekly

l Monthly

7. To activate the scheduled import, set Status to “Enabled.”

Import Settings
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Step 2: Complete the Import File Information

1. Set Server Type to one of the following:

Local Server Imports the data from the same server where Magento is
installed.

Remote FTP Imports the data from a remote server.

Import File Information

2. Enter the File Directory where the import file originates.

l For Local Server, enter a relative within the Magento installation. For example,
var/import.

l For Remote FTP server, enter the full URL and path to the import folder on the remote
server.

3. Enter the File Name to be imported.

4. For a Remote FTP connection, do the following:

a. In the FTP Host [:Port] field, enter the domain name or IP address of the remote FTP
server where the import file directory is located.

b. Enter the following FTP credentials for the remote server:

l User Name

l Password

c. Set File Mode to one of the following formats:

l Binary

l ASCII

d. Set Passive Mode to one of the following:

Yes The server determines which port is used for the data channel. This
setting is generally used if the server has a firewall.

No The client determines both the port and the data channel.
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Step 3: Configure the Import Failed Emails

1. Set Failed Email Receiver to the store contact who is to receive notification if an error
occurs during the import.

2. Set Failed Email Sender to the store contact that appears as the sender of the notification.

3. Set Failed Email Template to the template that is used for the notification.

4. In the Send Failed Email Copy To field, enter the email address of anyone who is to
receive a copy of the notification. Separate multiple email addresses with a comma.

5. Set Failed Email Copy Method to one of the following:

Bcc Sends a blind courtesy copy of the failed import notification.
The name and address of the recipient is included in the
original email distribution, but hidden from view.

Separate Email Sends a copy of the failed import notification as a separate
email.

Import Failed Emails

6. When complete, click the Save button.

The new scheduled import job is added to the list on the Scheduled Import/Export page.
From this page it can be run immediately for testing and edited. The import file is
validated before the execution of each import job.
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FIELD DESCRIPTION

IMPORT SETTINGS

Name The name of the import. Helps you to distinguish it if many
different scheduled imports are created.

Description (Optional) You can enter an additional description.

Entity Type Defines the data to be imported. Options include: Products /
Customers.

Import Behavior Defines how complex data will be handled if entities, which are
being imported, already exist in the database. Complex data for
products include categories, websites, custom options, tier
prices, related products, up-sells, cross-sells, and associated
products data. Complex data for customers include addresses.
The following variants of handling the complex data are available:

Append Complex
Data

The new complex data will be added to
the existing complex data for the already
existing entries in the database. This is
the default value.

Replace Existing
Complex Data

The existing complex data for the
already-existing entities will be replaced.

Delete Entities If entities which are being imported
already exist in the database, they will
be deleted from the database.

Start Time Set the start hour, minutes, and seconds of the import.

Frequency Define how often the import will be run. Options include:
Daily/Weekly/Monthly.

On Error Define the system behavior in case errors are found during file
validation. Options include:

Stop Import The file is not imported if any errors are
found during validation. This is the
default value.

Continue
Processing

In case errors are found during
validation, but importing is possible, the
file is imported.

Field Descriptions
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FIELD DESCRIPTION

Status The import is enabled by default. You can suspend it by setting
the Status to Disabled.

IMPORT FILE INFORMATION

Server Type You can import from a file located on the same server where
Magento is deployed (select Local Server) or from the remote
FTP server (select Remote FTP). If you select Remote FTP,
additional options for credentials and file transfer settings appear.

File Directory Specify the directory where the import file is located. If Server
Type is set to Local Server, specify the path relative to the
Magento installation directory. For example, var/import.

File Name Specify the name of the import file.

FTP Host[:Port] (Appears if Server Type is set to Remote FTP) Specify the FTP
host domain name or IP address of the FTP server where the
import file directory is located.

User Name (Appears if Server Type is set to Remote FTP) Specify the user
name for accessing the remote FTP server.

Password (Appears if Server Type is set to Remote FTP) Specify the
password for accessing the remote FTP server.

File Mode (Appears if Server Type is set to Remote FTP) Defines the file
mode, in which the file will be transferred from the remote FTP.
Select Binary or ASCII.

PassiveMode (Appears if Server Type is set to Remote FTP) Defines whether
the file is transferred from the remote FTP in passivemode.
Options include:

Yes The server determines which port is used for the
data channel. This setting is generally used if the
server has a firewall.

No The client determines both the port and the data
channel.

Field Descriptions (cont.)
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FIELD DESCRIPTION

IMPORT FAILED EMAILS

Failed Email Receiver Specify the email address to which an email notification (failed
import email) is sent if the import fails.

Failed Email Sender Specify the email address that is used as the sender for the
import failed email.

Failed Email Template Select a template for the import failed email. By default, only the
Import Failed (Default Template from Locale option is available.
Custom templates can be created under System > Transactional
Emails.

Send Failed Email Copy
To

The email address to which a copy of import failed email is sent.

Send Failed Email Copy
Method

Select the copy sendingmethod for the import failed email.

Field Descriptions (cont.)
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Scheduled Export
Scheduled Export is similar to manual Export, with respect to the available export file
format and types of entities that can be exported:

l You can export to .CSV format

l You can export product and customer data

The advantage of using Scheduled Export is that you can export data multiple times
automatically, after specifying the export parameters, and schedule only once

Add Scheduled Export

The details of each export are not written to a log, but in case of failure you will receive an
Export Failed email, which contains the error description. The result of the last export job
appears in the Last Outcome column on the Scheduled Import/Export page.

After each export, the export file is placed in the user-defined location, and a copy of the
file is placed in the var/log/import_export/%Y/%m/%d/ directory on the server where
Magento is deployed. The timestamp and the marker of the exported entity (products or
customers) and type of the operation (in this case, export) are added to the export file
name.

Process Overview
Step 1: Complete the Export Settings
Step 2: Complete the Export File Information
Step 3: Configure the Export Failed Emails
Step 4: Choose the Entity Attributes

To create a scheduled export:

1. On the Admin menu, select System > Import/Export > Scheduled Import/Export.

2. In the upper-right corner, click the Add Scheduled Export button. Then, do the following:
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Step 1: Complete the Export Settings

1. Enter a Name for the scheduled export.

2. Enter a brief Description that explains the purpose of the export, and how it is to be used.

3. Set Entity Type to one of the following:

l Products

l Customers

The Entity Attributes section at the bottom of the page is updated to reflect the selected
Entity Type.

4. Accept “CSV” as the default File Format.

5. Set Start Time to the hour, minute, and second that the export is scheduled to begin.

6. Set Frequency to one of the following:

l Daily

l Weekly

l Monthly

7. To activate the scheduled export, set Status to “Enabled.”

Export Settings

Step 2: Complete the Export File Information

1. Set Server Type to one of the following:

Local Server To save the export file on the same server where Magento is
installed.

Remote FTP To save the export file on a remote server.
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Export File Information

2. Enter the File Directory where the export file is to be saved as follow:.

l For Local Server, enter a relative path within the Magento installation. For example,
var/export.

l For Remote FTP server, enter the full URL and path to the target folder on the
destination server.

3. For a Remote FTP connection, do the following:

a. In the FTP Host [:Port] field, enter the domain name or IP address of the remote FTP
server where the export file directory is located.

b. Enter the following FTP credentials for the remote server:

l User Name

l Password

c. Set File Mode to one of the following formats:

l Binary

l ASCII

d. Set Passive Mode to one of the following:

Yes The server determines which port is used for the data channel. This
setting is generally used if the server has a firewall.

No The client determines both the port and the data channel.

Remote FTP Settings
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Step 3: Configure the Export Failed Emails

1. Set Failed Email Receiver to the store contact who is to receive notification if an error
occurs during the export.

2. Set Failed Email Sender to the store contact that appears as the sender of the notification.

3. Set Failed Email Template to the template that is used for the notification.

4. In the Send Failed Email Copy To field, enter the email address of anyone who is to
receive a copy of the notification. Separate multiple email addresses with a comma.

5. Set Failed Email Copy Method to one of the following:

Bcc Sends a blind courtesy copy. The name and address of the
recipient is included in the original email distribution, but is
hidden from view.

Separate Email Sends the copy as a separate email.

Export Failed Emails

Step 4: Choose the Entity Attributes

1. In the Entity Attributes section, choose the attributes that you want to include in the
export data.

l To filter export data by attributes value, enter the attribute value in the Filter column.

l To exclude products or customers with certain attribute values, enter the values of the
attributes that you want to exclude, and select the checkbox in the Skip column.

2. When complete, click the Save button.

The new scheduled export job is added to the list on the Scheduled Import/Export page.
From this page it can be run immediately, for testing, and edited.
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FIELD DESCRIPTION

EXPORT SETTINGS

Name The name of the export. Helps you to distinguish it if many
different scheduled exports are created.

Description (Optional) A description of the scheduled export.

Entity Type Identifies the data to be exported. After the selection is made, the
Entity Attributes appear below. Options include: Products
/Customers.

File Format Select the format of the export file. Currently only the .CSV
option is available.

Start Time Set the start hour, minutes, and seconds of the export.

Frequency Define how often the export job will be executed. Options
include:Daily/Weekly/Monthly.

Status A new scheduled export is enabled by default. You can suspend
it by setting Status to Disabled. Options include:
Enabled/Disabled.

EXPORT SETTINGS INFORMATION

Server Type Determines the location of the export file. Options include:

Local Server Places the export file on the
same server whereMagento is
deployed.

Remote FTP Places the export file on a
remote server. Additional options
for credentials and file transfer
settings appear.

File Directory Specify the directory where the export file is placed. In case
Server Type is set to Local Server, specify the relative to
Magento installation path. For example, var/export.

FTP Host[:Port] (Visible if Server Type is set to Remote FTP) Specify the FTP
host domain name or IP address of the FTP server where the
export file directory is located.

Field Descriptions
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FIELD DESCRIPTION

User Name (Visible if Server Type is set to Remote FTP) Specify the user
name for accessing the remote FTP server.

Password (Visible if Server Type is set to Remote FTP) Specify the
password for accessing the remote FTP server.

File Mode (Visible if Server Type is set to Remote FTP) Defines the file
mode in which the file will be transferred to the remote FTP.
Select Binary or ASCII.

PassiveMode (Visible if Server Type is set to Remote FTP) Determines how
the port is established for the connection. Options include:

Yes The server determines the port to be used for the
data channel. This setting is generally used if the
server has a firewall.

No The client determines both the port and the data
channel.

EXPORT FAILED EMAILS

Failed Email Receiver Specify the email address to which an email notification (export
failed email) is sent if the export fails.

Failed Email Sender Specify the email address that is used as export failed email
sender.

Failed Email Template Select a template for the failed export email. By default, only the
Export Failed (Default Template from Locale) option is available.

Send Failed Email Copy
To

The email address to which a copy of the failed export email is
sent.

Send Failed Email Copy
Method

Specify the copy sendingmethod for the export failed email.

Field Descriptions (cont.)
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Managing Scheduled Jobs
You can view and manage all existing scheduled imports/exports on the Scheduled
Import/Export page. All existing scheduled import/export jobs appear in the list. The Last
Outcome column shows the result of the last job. If the import or export has not been run
yet, it has the value “Pending.”

After each scheduled import and export operation copies of import and export files are
placed in the var/log/import_export/%Y/%m/%d/ directory. If History Cleaning is enabled,
the older files are automatically deleted.

To access scheduled imports/exports:

1. On the Admin menu, select System > Import/Export > Scheduled Import/Export.

2. To run the scheduled import/export immediately, in the Action column, click Run.

3. To edit the scheduled import/export, in the Action column, click Edit, or click the
import/export job in list.

4. To delete scheduled imports/exports, do the following:

a. Select the checkbox of each scheduled import/export job to be deleted.

b. Set the Actions control to “Delete.”

c. Click the Submit button.

d. When prompted to conform, click OK.

5. To change status of scheduled imports/exports:

a. Select the checkbox of each record to be changed.

b. Set the Actions control to “Change Status.” Then, set the Status control to the setting
you want to apply to the selected records.

c. Click the Submit button to update the records.

To configure file history cleaning:

1. On the Admin menu, select System > Configuration.

2. Because this task takes place on a global level, make sure Current Configuration Scope in
the upper-right corner is set to “Default Config.”

3. In the Configuration panel on the left, under Advanced, select System.

4. Click to expand the Scheduled Import/Export File History Cleaning section.
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Scheduled Import/Export File History Cleaning

5. Complete the fields in this section, using the following field descriptions for reference.

6. When complete, click the Save Config button.

1073Magento Enterprise Edition User Guide, Version 1.14.2.1

http://merch.docs.magento.com/ee/user_guide/Magento_Enterprise_Edition_User_Guide.html#configuration/advanced/system.html%23Scheduled_Import/Export_File_History_Cleaning


Scheduled Import/Export CHAPTER 67:  Managing Data Transfer

Notes

1074 Magento Enterprise Edition User Guide, Version 1.14.2.1



1075Magento Enterprise Edition User Guide, Version 1.14.2.1

CHAPTER 68:

Reports
Magento Enterprise Edition provides a wide selection of reports to keep you current on
everything from the contents of your customers’ shopping carts to the tags they use.
Report data can be viewed online or downloaded as a CSV or XML data file. The main
types of reports are Sales, Invitations, Products, Customers, Tags, Reviews, and Search
Terms.

Topics in this chapter:

l Dashboard

l Running Reports

l Refreshing Report Statistics

l Available Reports
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Dashboard
The dashboard is usually the first page that appears when you log in to the Admin, and
gives an overview of sales and customer activity.

The blocks on the left provide a snapshot of lifetime sales, average order amount, the last
five orders, and search terms. The graph depicts the orders and amounts for the selected
date range. You can use the tabs above the graph to toggle between the two views.

Topics in this section include:

l Snapshot Reports

l Dashboard Setup

Dashboard
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Snapshot Reports
The tabs at the bottom of the Dashboard provide quick reports about your best-selling and
most viewed products, new customers and those who have purchased the most.

Bestsellers

Lists your best-selling products, showing the price and quantity ordered.

Most Viewed Products

Lists the most recently viewed products and the number of times viewed.

New Customers

Lists recently registered customers.

Customers

Lists the customers who have ordered the most during the specified range of time.

Dashboard Setup
By default, the dashboard is the startup page for the Admin. However, if you prefer, you
can change the configuration to display a different page when you log in. You can also set
the starting dates used in dashboard reports, and disable the display of the charts section.

To set the date range:

Set Select Range to one of the following:

l Last 24 Hours

l Last 7 Days

l Current Month

l YTD

l 2YTD

To set the starting dates:

1. On the Admin menu, select System > Configuration.

2. In the panel on the left, under General, select Reports.

3. Click to expand the Dashboard section, do the following:
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a. Set Year-To-Date Starts to the month and year that the current year began.

b. Set Current Month Starts to the current month.

Dashboard

To change the Admin startup page:

1. On the Admin menu, select System > Configuration. Then in the Configuration panel on
the left, under Advanced, select Admin.

2. In the Admin UI section, set Startup Page to the page you want to first appear when you
log in to the Admin.

3. Click the Save Config button to save the setting.

Startup Page

To turn off real-time data:

If you have a lot of data to process, the performance of the Dashboard can be improved by
turning off the display of real time data.

1. On the Admin menu, select System > Configuration. Then in the Configuration panel on
the left, under Sales, select Sales.

2. Click to expand the Dashboard section. Then, set Use Aggregated Data (beta) to “Yes.”

Dashboard

http://merch.docs.magento.com/ee/user_guide/Magento_Enterprise_Edition_User_Guide.html#configuration/general/reports.html%23Dashboard
http://merch.docs.magento.com/ee/user_guide/Magento_Enterprise_Edition_User_Guide.html#configuration/advanced/admin.html%23Startup_Page
http://merch.docs.magento.com/ee/user_guide/Magento_Enterprise_Edition_User_Guide.html#configuration/sales/sales.html%23Use_Aggregated_Data
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To disable charts:

1. On the Admin menu, select System > Configuration. Then in the Configuration panel on
the left, under Advanced, select Admin.

Dashboard

2. In the Dashboard section, set Enable Charts to “No.”

3. When complete, click the Save Config button.

A message on the Dashboard indicates that the chart is now disabled.

Running Reports
Magento provides a variety of reports that you can access at any time. To see the reports
that you can generate in Magento, from the Reports menu, select a type of report and then
select a specific report of that type. Some report pages have filter controls that enable you
to narrow the scope of the report.

When you are finished making filter selections, click Show Report (or Refresh, for some
reports) to generate the report.

Reports
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Orders Report
The Orders report includes real-time data, and can include orders of any status during a
specific period of time.

To run the Orders report:

1. On the Admin menu, select Reports > Sales > Orders. Then, do the following:

a. A message indicates the last time the report statistics were refreshed. If necessary,
click the link to refresh the statistics.

b. Set Show Report for to the website, store, or store view that you want to include in
the report.

c. Set Match Period To to one of the following:

l Order Created Date

l Order Updated Date

d. To determine how the report data is aggregated by row, set Period to one of the
following:

l Day

l Month

l Year

e. To include activity during a specfic period, click the calendar icon and select the

From and To dates.

f. Do one of the following:

l To include all orders, set Order Status to “Any.”

l To include only orders with a specific status, set Order Status to “Specified.” Then,
select each order status that you want to include in the report.

g. To omit any empty rows from the report, set Empty Rows to “No.”

h. To show actual, rather than projected values, set Show Actual Values to “Yes.”

2. When ready to run the report, click the Show Report button.
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Orders Report by Month

To export report data:

1. Set the Export to control to one of the following:

l CSV

l Excel XML

2. Click the Export button. Then, look for the download file in the lower-left corner of your
browser window.
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FILTER CONTROL DESCRIPTION

Show Report For Determines the store view or website(s) to be included in the
report.

Match Period To Enables you to select which records to report on, based on either
the order creation date or the order modified date.

Period Enables you to aggregate the report data into rows for each day,
month, or year within your report From and To dates.

From and To Determines the start and end dates covered by the report.

Order Status For Order Status, select Any to include all orders, or select
Specified to select one or more order status values from a list.

Empty Rows Enables you to select whether to include date period rows that
have no data.

Show Actual Values Enables you to select whether to display actual (Yes) or projected
(No) values. Projected values are based on estimates of amounts
to be paid.

Field Descriptions
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Refreshing Report Statistics
To reduce performance impact when generating sales reports, Magento calculates and
stores the statistics that are needed for each report. When you generate a report, the report
uses the stored statistics, rather than recalculate the statistics for each report.

To include the most recent data, the sales report statistics must be refreshed manually
before the report is generated.

Report Statistics

To refresh sales report statistics:

1. On the Admin menu, select Reports > Refresh Statistics.

2. In the list, select the checkbox of each report that needs to be refreshed.

3. Set the Actions control to one of the following:

l Refresh Lifetime Statistics

l Refresh Statistics for the Last Day

4. When complete, click the Submit button.

Available Reports

REPORT DESCRIPTION

Total Ordered Reports > Sales > Orders
Shows orders for the specified time period.

Order Taxes Reports > Sales > Tax
Shows taxes charged for orders in the specified time period;
grouped by tax rate.

Total Invoiced vs. Paid Reports > Sales > Invoiced

Report Descriptions
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REPORT DESCRIPTION

Shows amounts paid and unpaid for invoiced orders in the
specified time period.

Total Shipped Reports > Sales > Shipping
Shows orders shipped in the specified time period, grouped by
carrier/method; includes shipping charge amounts.

Total Refunded Reports > Sales > Refunds
Shows refunds applied to orders in the specified time period.

Coupons Usage Reports > Sales > Coupons
Shows coupons used for orders in the specified time period,
grouped by coupon code.

PayPal Settlement Reports > Sales > PayPal Settlement Reports
Shows PayPal settlements for the specified time period. Click
Fetch Updates to retrieve data from PayPal.

Products in Carts Reports > Shopping Cart > Products in carts
Shows products that are currently in shopping carts.

Abandoned Carts Reports > Shopping Cart > Abandoned Carts
Shows shopping carts that were started but then abandoned.
Enables you to contact customers to offer incentives to turn an
abandoned cart into a conversion.

Products Bestsellers Reports > Products > Bestsellers
Shows the products that were sold in the highest quantity in the
specified time period.

Products Ordered Reports > Products > Products Ordered
Shows all products that were ordered in the specified time period.

Most Viewed Reports > Products > Most Viewed
Shows the products that were viewed themost times in the
specified time period.

Low Stock Reports > Products > Low Stock
Shows the products whose stock levels are low.

Downloads Reports > Products > Downloads

Report Descriptions (cont.)
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REPORT DESCRIPTION

Shows the number of purchases and downloads for each
downloadable product.

New Accounts Reports > Customers > New Accounts
Shows the new accounts that were created during the specified
time period.

Customers by Orders
Total

Reports > Customers > Customers by orders total
Shows the customers listed in descending order of total order
amount.

Customers by Number of
Orders

Reports > Customers > Customers by number of orders
Shows the customers listed in descending order of number of
orders placed.

Customers Reviews Reports > Reviews > Customers Reviews
Shows the customers listed in descending order of number of
reviews contributed.

Products Reviews Reports > Reviews > Products Reviews
Shows the products listed in descending order of number of
reviews.

Customers Tags Reports > Tags > Customers
Shows the customers listed with the number of tags each one
has created.

Products Tags Reports > Tags > Products
Shows the number of unique tags and total number of tags
created for each product.

Popular Tags Reports > Tags > Popular
Shows the number of times each tag has been applied.

Search Terms Reports > Search Terms
Shows terms submitted with the search tool.If Hits are high, but
the Results are low, you should review product names and
descriptions so you can promote products related to the term.

Report Descriptions (cont.)
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CHAPTER 69:

Admin Permissions
Magento uses roles and permissions to create different levels of access to the Admin.
When your store is first set up, you receive a set of login credentials for the
Administrator role, with full permissions. However, you can restrict the level of
permissions on a “need to know” basis for other people who work on your site. For
example, a designer can be given access to only the Design tools, but not to areas with
customer and order information.

In addition, you can further restrict Admin access to only a specific site, or set of sites
and their associated data. If you have multiple brands or business units with separate
stores on the same Magento installation, you can provide Admin access to each of your
business units but hide and protect their data from other Admin users.

If an Admin user’s access is restricted to a specific set of websites and/or stores, the
websites and stores for which they are not authorized will either not appear or be
grayed-out as inactive. Only the sales and other data for allowed websites and stores is
shown.

Topics in this chapter:

l Creating New Users

l Custom Roles

l REST Roles

l Unlocking Accounts
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Creating New Users
When your store is first installed, your login credentials have with full administrative
access. As a best practice, one of the first things you should do is to create another user
account with full Administrator permissions. That way, you can use one account for your
everyday Administrative activities, and reserve the other as a “Super Admin” account in
case you forget your regular credentials or they somehow become otherwise unusable.

If there are others on your team, or service providers who need access, you can create a
separate user account for each, and assign a restricted role. To limit the websites or stores
that admin users can access when they log in, you must first create a role with limited
scope and resources. Then, you can assign the role to a specific user account. Admin users
assigned to a restricted role can see and change data only for websites or stores that are
associated with the role. They cannot change any global settings or data.

Step 1: Create a New User

1. On the Admin menu, select System > Permissions > Users.

2. Click the Add New User button.

3. In the Account Information section, do the following:

Account Information

a. Enter the User Name for account.

The User Name should be easy to remember. It is not case-sensitive. For example, if
your user name is “John,” you can also log in as “john.”

b. Complete the following information:

l First Name

l Last Name

l Email address

This email address must be different from the one that is associated with your
original Admin account.
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c. Assign a Password to the account.

The password should be seven or more characters long, and include both letters and
numbers.

d. In the Password Confirmation box, repeat the password to make sure it was entered
correctly.

4. Set This Account is to “Active.”

Step 2: Define the Role

1. In the User Information panel on the left, click User Role. Then, in the list of Roles, select
Administrators. (Initially, it will be the only role available.)

Add New User Role

2. When complete, click the Save User button.

You now have two accounts with Administrator access.
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Custom Roles
To give someone restricted access, the first step is to create a role with the appropriate level
of permissions. After the role is created, you will add the new user, set up the login
credentials, and assign the role to the user account. After the role is established, you can
create new Administrator users at any time, and assign the restricted role to grant the user
limited access to the following resources:

l Price Resources

l Promotion Resources

l Product Resources

Add New Role

Step 1: Define the Role

1. On the Admin menu, select System > Permissions > Roles. Then in the upper-left corner,
click the Add New Role button.

2. In the Role Information section, enter a descriptive Role Name.

Role Name

3. In the panel on the left, select Role Resources.
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4. In the Role Scope section, set Role Scopes to “Custom.” Then, select the checkbox of each
website and view to which you want to grant permission.

Role Scopes

5. In the Roles Resources section, select the checkbox of each Admin Resource that you want
to grant those with the role permission to access.

Important! Be sure to disable access to the Permissions tool if you are limiting access for a
given role. Otherwise, users with this role will be able to modify their own restrictions.

Role Resources, Collapsed View

6. (Optional) In the panel on the left, select Role Users. Then, assign additional
Administrator user accounts to the new role.

7. When complete, click the Save Role button. The role now appears in the list.

Step 2: Add the New User

1. On the Admin menu, select System > Permissions > Users.

2. Click the Add New User button.

3. In the Account Information section, do the following:
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Account Information

a. Assign a User Name to the account.

The User Name should be easy to remember. It is not case-sensitive. For example, if
your user name is “john,” you can also log in as “John.”

b. Complete the following information:

l First Name

l Last Name

l Email address

c. Assign a Password to the account.

The password should be at least seven characters long, and include letters and
numbers.

d. In the Password Confirmation field, type the password again to make sure it was
entered correctly.

e. Set This Account is to “Active.”

4. In the User Information panel on the left, click User Role. Then, in the list of Roles, select
the option for the role you want to assign to the new user.

New User Role

5. When complete, click the Save User button.
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Price Resources

PERMISSION RESTRICTIONS

Read WhenRead permission is granted for the product status, the Admin user
cannot change the value of the Status product attribute. When creating a
new product, the Status field is unavailable for editing and is set to
Disabled.

Edit When the Edit permission is given for the product status, the Admin user
can change the values of the Status product attribute.

Product Status Permissions

PERMISSION RESTRICTIONS

Read When the Read permission is given for the price, the Admin user can
view, but cannot edit, the product price-related fields. When creating a
new product, the Price attribute (or Amount, in case of a gift card product)
is unavailable for editing and set to the default value, and creating
recurring profiles is unavailable.
When adding custom options, or associated products for a configurable
product, or links for downloadable products, the prices are unavailable for
editing and are set to zero, the Price Type field is unavailable for editing
and set to Fixed.

Edit When Edit permission is given for the product price, the Admin user has
full access to all price-related fields.
When access to product management is granted, but neither Read nor
Edit permissions for product price are specified, all price-related fields
and columns are hidden, andmanagement of recurring profiles is
unavailable. The Admin user can still create new products and add
custom options, associated products, and links for downloadable
products. In this case, the price fields and price columns in the grids are
hidden and are set to the default or zero value. The price and total
columns are hidden on theManage Products page, the Category
Products tab of the Category view, and the customer’s shopping cart
view in the Admin Panel.

Price Permissions
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Promotion Resources
For promotions management resources, you can grant read/edit access rights to the
following resources:

l Catalog Price Rules

l Shopping Cart Price Rules

l Automated Email Reminder Rules

Read and Edit permissions for Catalog Price Rules, Shopping Cart Price Rules, and
Automated Email Reminder Rules are set up and applied in the same way. When only
Read permission is granted for a resource (such as for catalog price rules or shopping cart
rules), the Admin user can view only the existing rules. No fields can be edited, and all
management buttons are hidden When Edit permission is granted for a given resource, the
Admin user has complete access to the resource.

To grant Read permission only;

1. Follow the instructions to create a custom role.

2. In the Roles Resources section, select the Resource checkbox, and clear the Edit checkbox.

PERMISSION RESTRICTIONS

Read The user can view the existing rules, but all fields are unavailable for
editing and themanagement buttons are hidden. For example, on the
Price Rules page, the Apply Rule and Add New Rule buttons are hidden;
on the Edit Rule page, only the Back button is available.

Edit The user has the complete access to the subsection, including all fields
and buttons.

Promotional Rule Permissions
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Product Resources
For product management, you can grant the following access rights:

l Product Status Permissions

l Product Price Permissions

l Access Without Permissions

When an Admin user with Read Product Price permissions creates a new product, the
product price is set to the default value.

To set the default price:

1. On the Admin menu, select System > Configuration. Then in the panel on the left, under
Catalog, select Catalog.

2. In the upper-right corner, make sure that Current Configuration Scope is set to "Default
Config."

3. Click to expand the Price section, and do the following:

4. Enter the Default Product Price.

If the default price is not set, it is considered equal to zero. As a result, a user with Edit access
rights for product status and Read access rights for product prices can create products which will
appear in the store with a price of zero.

5. When complete, click the Save Config button.

PERMISSION RESTRICTIONS

Read The Status field of the products is unavailable for editing. When creating
a product, the field is unavailable for editing and is set to Disabled.
Performingmass Status change on the Products page is unavailable.

Edit The Status field of the products is available for editing by the backend
user.

Product Status Permissions
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PERMISSION RESTRICTIONS

Read When editing existing products or performingmass change of attributes
values, all fields on the Prices tab are displayed, but are unavailable for
editing.
When creating a new product, the Price field on the Prices tab is
unavailable for editing, and is set to the default value. All other price
related fields on this tab (Special Price, Special Price From/To Date, Tier
Price; if MAP is enabled, all MAP related settings) are not displayed. For
gift card products, the Amount field on the Prices tab is unavailable for
editing and is set equal to the default price value. All other amount-related
fields (Allow Open Amount, Open Amount Min Value, Open Amount Max
Value) are not displayed.
Management of recurring profiles is unavailable. When creating a new
product, the Enable Recurring Profile attribute is set to No and is
unavailable for editing.
When adding custom options, or associated products for configurable
products, or links for downloadable products, the Price field is
unavailable for editing and is set to zero, and the Price Type field is
unavailable for editing and is set to Fixed.

Edit The admin user has the right to access and change all price-related fields
and columns of the product management section.

No Permission All price related fields and columns are hidden.
On the Prices tab, for both new and existing products, the Price, Special
Price, Tier Price, Cost (if applied), Special Price From Date, Special
Price To Date attributes, and all MAP-related settings are hidden. For
new products the Price is set to the default value. The same logic applies
to the Amounts and the Allow Open Amount, Open Amount Min Value,
andOpen Amount Max Value fields for the gift card products.
For both new and existing products, the Enable Recurring Profile field is
displayed, but is unavailable for editing. For the existing products, all
other fields related to the product profile are hidden. For new products the
Enable Recurring Profile field is set to No.
On the Related Products, Up-sells, Cross-sells tabs of the product view,
the Price column in the grids is not displayed.
On the Custom Options tab, Associated Products tab of the product
view, the Price and Price Type columns in the grids are not displayed.
When adding a new custom option or a new associated product for a
configurable product, the Price and Price Type fields are hidden. For new
entries, the Price is set to zero, and the Price Type is set to Fixed.

Product Price Permissions
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PERMISSION RESTRICTIONS

On the Downloadable Information tab for downloadable products, the
Price column is hidden. For the new rows the Price is set to zero.
On theManage Products and Category Products pages (Categories >
Manage Categories > Category Products tab), the Price columns in the
grids are hidden.
In the customer’s shopping cart views (accessible from the Customer’s
page), the Price, Total and Subtotal columns are hidden.
Admin users without Read or Edit permissions can still see product
option prices when configuring products for customers’ shopping carts.

Product Price Permissions (cont.)

RESTRoles
The REST API defines a set of functions that developers can use to perform requests and
receive responses. To learn more about REST permissions, see: Web Services.

Unlocking Admin Accounts
For the security of your business, user accounts are locked after six failed attempts to log in
to the Admin. The account can be unlocked by any other user with full Administrator
permissions.

To unlock an admin account:

1. On the Admin menu, select System > Permissions > Locked.

Any locked user accounts appear in the list.

2. In the list, select the checkbox of the locked account.

3. In the upper-right corner, set the Actions control to “Unlock.”

4. Click the Submit button to unlock the user account.
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CHAPTER 70:

Security
Maintaining a secure environment for the operation of your store is of utmost
importance to the success of your business. In this chapter , you will learn how to
manage Admin sessions and credentials; implement CAPTCHA; and manage website
restrictions, encryption, hashing, and events logging.

Topics in this chapter:

l Magento Security Best Practices

l Security Configuration

l CAPTCHA

l Website Restrictions

l Session Validation

l Browser Capabilities Detection

l Encryption & Hashing
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SOLUTION SERIES:

Magento Security Best Practices
All eCommerce sites are attractive targets to hackers because of the personal and payment
information that is required to complete a sale. Even if the system does not directly process
credit card transactions, a compromised site might reroute customers to a false page, or
alter an order before it is transmitted to the payment processor.

A compromised site can have long-term consequences for both customers and merchants.
Customers might suffer financial loss and identify theft, while merchants can face damage
to their reputations, loss of merchandise, higher processing fees, revoked privileges with
financial institutions, and the threat of lawsuits.

This guide outlines a multifaceted approach to improve the security of your Magento
installation. Although there is no single way to eliminate all security risks, there are many
things that you can do to make your site a less attractive target. It is crucial for hosting
providers, system integrators, and merchants to work together to establish and maintain a
secure environment, implement methods for early detection, and determine a plan of action
in the event of a breach.

Make sure to stop by ourMagento Security Center, and sign up for the Security Alert Registry
to receive notification from our security team of any emerging issues and solutions.

Start Right

Work with reliable hosting providers and solution integrators. When evaluating their
qualifications, ask about their approach to security. Verify that they have a secure software
development life cycle in accord with industry standards such as The Open Web
Application Security Project (OWASP), and that they test their code for security issues.

If you are starting a new site, consider launching the entire site over HTTPs. Taking the
lead on this issue, Google now uses HTTPs as a ranking factor.

For an existing installation, plan to upgrade the entire site to run over to a securely
encrypted, HTTPs channel. Although you will need to create redirects from HTTP to
HTTPs, the effort will future-proof your site. We recommend that you plan to make this
change sooner, rather than later.

Protect the Environment

Protecting the environment is the most critical aspect of ensuring the security of your store.
Keep all software on the server up to date, and apply security patches as recommended.
This applies not only to Magento, but to any other software that is installed on the server,
including database software and other websites that use the same server. Any system is
only as secure as the weakest link.

http://magento.com/security
http://magento.com/security
https://www.owasp.org/index.php/About_OWASP
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Make sure that the server operating system is secure. Work with your hosting
provider to ensure that there is no unnecessary software running on the server.

Use only secure communications protocol (SSH/SFTP/HTTPS) tomanage files, and
disable FTP.

Use strong, long, and unique passwords, and change them periodically.

Keep the system up to date, and immediately install patches when new security
issues are discovered.

Closely monitor any issues that are reported for software components used by your
Magento installation, including the operating system, MySQL database, PHP, Redis
(if used), Apache or Nginx, Memcached, Solr, and any other components in your
specific configuration.

Server Environment

Automate the deployment process, if possible, and use private keys for data transfer.

Limit access to theMagento Admin by updating the whitelist with the IP address of
each computer that is authorized to use the Admin andMagento Connect
downloader. For examples of how to whitelist IP addresses, see: Secure Your
Magento Admin.

Do not install extensions directly on a production server.
To disable theMagento Connect downloader on the production site, either remove or
block access to the /downloader directory. You can also use the samewhitelisting
methods.

Use two-factor authorization for Admin logins. There are several extensions available
that provide additional security by requiring an additional passcode that is generated
on your phone, or a token from a special device.

Review your server for “development leftovers.” Make sure there are no accessible
log files, publicly visible .git directories, tunnels to execute SQL helper scripts,
database dumps, phpinfo files,or any other unprotected files that are not required, and
that might be used in an attack.

Limit outgoing connections to only those that are required, such as for a payment
integration.

Use aWeb Application Firewall to analyze traffic and discover suspicious patterns,
such as credit card information being sent to an attacker.

Advanced Techniques
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Make sure that all applications running on the server are secure.

Avoid running other software on the same server as Magento, especially if it is
accessible from the Internet. Vulnerabilities in blog applications such as Wordpress
can expose private information fromMagento. Install such software on a separate
server or virtual machine.

Keep all software up to date, and apply patches as recommended.

Server Applications

Make sure that the computer that is used to access theMagento Admin is secure.

Keep your antivirus software up to date, and use amalware scanner. Do not install
any unknown programs, or click suspicious links.

Use a strong password to log in to the computer, and change it periodically. Use a
passwordmanager such as LastPass, 1Password, or Dashlane to create and
manage secure, unique passwords.

Do not save FTP passwords in FTP programs, because they are often harvested by
malware and used to infect servers.

Delete user accounts for employees or contractors who no longer work with you. A
large number of intrusions can be attributed to insider knowledge.

Admin Desktop Environment

Protect Magento

Your effort to protect your Magento installation starts with the initial setup, and continues
with the security-related configuration settings, password management, and ongoing
maintenance.

https://lastpass.com/
https://agilebits.com/onepassword
https://www.dashlane.com/
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Use the latest version of Magento to ensure that your installation includes themost
recent security enhancements.
If for any reason you cannot upgrade to the latest version, make sure to install all
security patches as recommended by Magento. AlthoughMagento issues security
patches to fix major issues, new product releases include additional improvements to
help secure the site.

Use a unique, custom Admin URL instead of the default “admin” or the often-used
“backend,” Although it will not directly protect your site from a determined attacker, it
can reduce exposure to scripts that try to break into every Magento site. (Never leave
your valuables in plain sight.)

Check with your hosting provider before implementing a custom Admin URL. Some
hosting providers require a standard URL to meet firewall protection rules.

Block access to any development, staging, or testing systems. Use IP whitelisting
and .htaccess password protection. When compromised, such systems can produce
a data leak or be used to attack the production system.

Use the correct file permissions. CoreMagento and directory files should be set to
read only, including app/etc/local.xml files.

Use a strong password for theMagento Admin. To learnmore, see: Creating a strong
password.

Take advantage of Magento’s security-related configuration settings for Advanced
Admin Security, Password Options, and CAPTCHA.

Your Magento Installation

Don’t be Taken for a Ride

Install extensions only from trusted sources. Never use paid extensions that are
published on torrent or other sites. If possible, review extensions for security issues
before installing them.

Do not click suspicious links, or open suspicious email.

Do not disclose the password to your server or to theMagento Admin, unless you are
required to do so.
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Be Prepared!

Develop a disaster recovery/business continuity plan. Even a basic plan will help you
get back on track in the event of a problem.

Ensure that your server and database are automatically backed up to external
location. A typical setup requires daily incremental backups, with a full backup on a
weekly basis. Make sure to test the backup regularly to verify that it can be restored.

For a large site, simple text file dumps of the database take an unacceptable amount
of time to restore. Work with your hosting provider to deploy a professional database
backup solution.

Monitor for Signs of Attack

If your system is not immediately patched after a major security breach, there is a high
probability that your site is already compromised. Complete a security review periodically
to check for signs of attack, and also when contacted by customers with security-related
concerns.

Check periodically for unauthorized Admin users.

(Magento Enterprise only) Check the Admin Actions Log for suspicious activity.

Use automated log review tools such as Apache Scalp.

Work with your hosting provider to review server logs for suspicious activity, and to
implement an Intrusion Detection System (IDS) on your network.

Use a file and data integrity checking tool such as TripWire to receive notification of
any potential malware installation.

Monitor all system logins (FTP, SSH) for unexpected activity, uploads, or
commands.

Security Review

http://merch.docs.magento.com/ee/user_guide/Magento_Enterprise_Edition_User_Guide.html#system-operations/admin-actions-log.html
https://code.google.com/p/apache-scalp/
http://www.tripwire.com/
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Follow Your Disaster Recovery Plan

In the event of a compromise, work with your internal IT security team if available, or
hosting provider, and system integrator to determine the scope of the attack. Taking into
consideration the type of compromise and the size of the store. Then, adjust the following
recommendations to your business needs.

1. Block access to the site, so the attacker cannot remove evidence or steal more information.

2. Backup the current site, which will include evidence of the installed malware or
compromised files.

3. Try to determine the scope of the attack. Was credit card information accessed? What
information was stolen? How much time has elapsed since the compromise? Was the
information encrypted? Typically you can expect the following types of attack:

Defacing of Site Site access is compromised, but often the payments
information is not. User accounts might be compromised.

Botnetting Your site becomes part of a botnet that sends spam email.
Although data is probably not compromised, your server is
blacklisted by spam filters which prevents email that you
send to customers from being delivered.

Direct Attack on Server Data is compromised, backdoors and malware are installed,
and the site no longer works. Payment information—
provided that it is not stored on the server— is probably safe.

Silent Card Capture In this most disastrous attack, intruders install hidden
malware or card capture software, or possibly modify the
checkout process to collect and send out credit card data.
Such attacks can go unnoticed for extended periods of time,
and result in major compromise of customer accounts and
financial information.

4. Try to find the attack vector to determine how the site was compromised, and when.
Review server log files and file changes. Note that sometimes there are multiple different
attacks on the same system.

5. If possible, wipe and reinstall everything. In case of virtual hosting, create a new instance.
Malware might be hidden in an unsuspected location, just waiting to restore itself. Remove
all unnecessary files. Then, reinstall all required files from a known, clean source such as
files from your own version control system, or the original distribution files from
magento.com.

6. Apply all the latest security patches necessary.

7. Reset all credentials, including the database, file access, payment and shipping
integrations, web services, and Admin login.
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8. If payment information was compromised, it might be necessary to inform your payment
processor.

9. Inform your customers about the attack and the type of information affected. If payment
information was compromised, they should look for unauthorized transactions. If personal
information, including email addresses was compromised, they might be targeted with
phishing attacks or spam.
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Security Configuration
The security settings give you the ability to control the lifetime of user sessions, timeouts,
and passwords; and and whether to allow your Magento store to run in a frame. (This
setting can prevent clickjacking.) In addition you can add a secret key to URLs, and
determine the case sensitivity of login credentials.

For security reasons Magento strongly recommends against running your store in a frame.

Security

To configure Admin security:

1. On the Admin menu, select System > Configuration.

2. In the panel on the left, under Advanced, select Admin.

3. Click to expand the Security section, and do the following:

a. To append a secret key to the Admin URL to protect against exploits, set Add Secret
Key to URLs to “Yes.”

b. To require the characters in login credentials to match case of those that are saved in
the system, set Login in Case Sensitive to “Yes.”

c. In the Session Lifetime (seconds) field, enter the number of seconds before a user
session expires.

d. To prevent “clickjacking,” we recommend that you set the following fields to “Only
from same domain.”

l Allow Magento Backend to run in frame

l Allow Magento Frontend to run in frame
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e. In the Maximum Login Failures to Lockout Account field, enter the number of times
Admin users can try to log in before their accounts are locked.

f. In the Lockout Time (minutes) field, enter the number of minutes an Admin account
is locked before the user can try to log in again.

g. In the Password Lifetime (days) field, enter the number of days an Admin password
can be used before it expires.

h. If you want to require Admin users to change their passwords before they expire, set
Password Change to “Forced.”

4. In the panel on the left, under Advanced, select System.

5. Click to expand the CSRF protection section. Then, set Add Secret Key to Url to “Yes.”

CSRF Protection

6. When complete, click the Save Config button.

http://merch.docs.magento.com/ee/user_guide/Magento_Enterprise_Edition_User_Guide.html#configuration/advanced/system.html%23CSRF_Protection
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CAPTCHA
CAPTCHA is an acronym for “Completely Automated Public Turing test to tell Computers
and Humans Apart.” A CAPTCHA is a visual device that ensures that a human being,
rather than a computer, is interacting with the site. CAPTCHA can be used for both the
Admin and customers.

l Admin CAPTCHA

l Customer CAPTCHA

Users can reload the displayed CAPTCHA by clicking the Reload icon in the upper right
corner of the image. The number of reloads is not limited.

The Magento CAPTCHA was implemented using a Zend Framework module, and is fully
configurable.

CAPTCHA in Customer Login
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Admin CAPTCHA
For an extra level of security, you can add a CAPTCHA to the Admin Login page.
Administrator users can reload the displayed CAPTCHA by clicking the Reload icon in the
upper-right corner of the image. The number of reloads is not limited.

Admin CAPTCHA

To configure CAPTCHA for the Admin:

1. On the Admin menu, select System > Configuration.

2. In the upper-right corner, set Current Configuration Scope to "Default."

3. In the panel on the left, under Advanced, select Admin.

4. Click to expand the CAPTCHA section, and do the following:

CAPTCHA

http://merch.docs.magento.com/ee/user_guide/Magento_Enterprise_Edition_User_Guide.html#configuration/advanced/admin.html%23CAPTCHA
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a. To use a CAPTCHA on the Admin Login page, set Enable CAPTCHA in Admin to
“Yes.”

b. Enter the name of the Font to be used for the CAPTCHA symbols. Default font:
LinLibertine

To add your own font, the font file must reside in the same directory as your Magento
instance, and be declared in the config.xml file, which is stored at:

app/code/core/Mage/Captcha/etc/

c. Select the Forms where the CAPTCHA is to be used. Options include:

l Admin Login

l Admin Forgot Password

d. Set Displaying Mode to determine how the CAPTCHA is used.

Always CAPTCHA is always required to log in the Admin.

After number of
attempts to login

When selected displays the Number of Unsuccessful Attempts
to Login field. Enter the number of login attempts allowed. A
value of 0 (zero) is similar to setting Displaying Mode to
Always. This option does not cover the Forgot Password form. If
CAPTCHA is enabled and set to be appear on this form, then it
is always included on the form.

e. Enter the Number of Unsuccessful Attempts to Login before the CAPTCHA appears.
If set to zero, the CAPTCHA is always used.

f. In the CAPTCHA Timeout (minutes) field, enter the number of minutes before the
CAPTCHA expires. When the CAPTCHA expires, the user must reload the page.

g. Enter the Number of Symbols used in the CAPTCHA, up to eight. For a variable
number of symbols that changes with each CAPTCHA, enter a range, such as 5-8.

h. In the Symbols Used in CAPTCHA field, specify the symbols that can be used in the
CAPTCHA. Only letters (a-z and A-Z) and numbers (0-9) are allowed. The default set
of characters does not include similar symbols such as I or 1. For best results, use
symbols that users can readily identify.

i. To require that users enter the upper-and lowercase characters exactly as shown set
Case Sensitive to “Yes.”

5. When complete, click the Save Config button.
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Customer CAPTCHA
CAPTCHA can be required to log in to a customer account, or be configured to appear after
several unsuccessful attempts. It can also be used for other forms in the storefront.

CAPTCHA

To configure CAPTCHA for customers:

1. On the Admin menu, select System > Configuration.

2. Set Current Configuration Scope to the website where you want the configuration to
apply.

3. In the panel on the left, under Customers, select Customer Configuration. Click to expand
the CAPTCHA section, and do the following:

a. To use a CAPTCHA for customer logins, set Enable CAPTCHA on Frontend to “Yes.”

b. Enter the name of the Font to be used for the CAPTCHA symbols. Default font:
LinLibertine

To add your own font, the font file must reside in the same directory as your Magento
instance, and be declared in the config.xml file, which is stored at:

app/code/core/Mage/Captcha/etc/

c. Choose the Forms where CAPTCHA is to be used. Options include:

http://merch.docs.magento.com/ee/user_guide/Magento_Enterprise_Edition_User_Guide.html#configuration/customers/customer-configuration.html%23CAPTCHA
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l Create User

l Login

l Forgot Password

l Checkout as Guest

l Register during Checkout

d. Set Displaying Mode to determine how the CAPTCHA is used.

Always CAPTCHA is always required to access the selected form(s).

After number of
attempts to login

Enter the number of login attempts before the
CAPTCHA appears. A value of 0 (zero) is similar to “Always.”
When selected, the number of unsuccessful login attempts
appears.

This option does not apply to the Forgot Password form, which
always display the CAPTCHA, if enabled,

e. Enter the Number of Unsuccessful Attempts to Login before the CAPTCHA appears.
If set to zero, the CAPTCHA is always used.

f. In the CAPTCHA Timeout (minutes) field, enter the number of minutes before the
CAPTCHA expires. When the CAPTCHA expires, the user must reload the page to
generate a new CAPTCHA.

g. Enter the Number of Symbols in the CAPTCHA, up to eight. For a variable number of
symbols that change with each CAPTCHA, enter a range such as 5-8.

h. In the Symbols Used in CAPTCHA field, specify the symbols that can be used in the
CAPTCHA. Only letters (a-z and A-Z) and numbers (0-9) are allowed. The default set
of characters does not include similar symbols such as I or 1. For best results, use
symbols that users can readily identify.

i. To require that the user enter the upper-and lowercase characters exactly as shown set
Case Sensitive to “Yes.”

4. When complete, click the Save Config button.
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Website Restrictions
Website restrictions give you the ability to either shut down access to a storefront
completely while performing maintenance, or restrict access to private sale or B2B sites by
requiring customers to log in. Website restrictions affect only the storefront, so you can
continue to work in the Admin.

Closed for Maintenance
To temporarily close your website while performing maintenance, set website restrictions to
“website closed,” and redirect visitors to a landing page of your choice.

Website Restrictions

To close for maintenance:

1. On the Admin menu, select System > Configuration. In the panel on the left, under
General, select General.

2. Click to expand theWebsite Restrictions section, and do the following:.

a. Set Access Restriction to “Yes.”

b. Set Restriction Mode to “Website Closed.”

c. Choose the Landing Page that you want to appear while the site is closed.

You can use a custom “Closed for Maintenance” CMS page, or the default “503 Services
Unavailable” page.

d. To let search engine bots and spiders know that the site is temporarily offline, set
HTTP Response to “503 Services Unavailable.”

3. When complete, click the Save Config button.

Private Sales
A similar procedure is used to restrict access to a private sale event, or to a members only
or B2B website. To learn more, see: Private Sale Website Restrictions.

http://merch.docs.magento.com/ee/user_guide/Magento_Enterprise_Edition_User_Guide.html#configuration/general/general.html%23Website_Restrictions
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Session Validation
Magento Enterprise allows you to validate session variables as a protective measure against
possible session fixation attacks, or attempts to poison or hijack user sessions. The Session
Validation Settings determine how session variables are validated during each store visit,
and if the session ID is included in the URL of the store.

The validation checks to see that visitors are who they say they are by comparing the value
in the validation variables against the session data that is already stored in $_SESSION
data for the user. Validation fails if the information is not transmitted as expected, and the
corresponding variable is empty. Depending on the session validation settings, if a session
variable fails the validation process, the client session immediately terminates.

Enabling all of the validation variables can help prevent attacks, but might also impact the
performance of the server. By default, all session variable validation is disabled. We
recommend that you experiment with the settings to find the best combination for your
Magento installation. Activating all of the validation variables might prove to be unduly
restrictive, and prevent access to customers who have Internet connections that pass
through a proxy server, or that originate from behind a firewall. To learn more about
session variables and their use, see the system administration documentation for your
Linux system.

To configure the Session Validation Settings:

1. On the Admin menu, select System > Configuration. In the panel on the left under
General, select Web.

2. Click to expand the Session Validation Settings section. Then, do the following:

Session Validation Settings

a. To verify that the IP address of a request matches what is stored in the $_SESSION
variable, set Validate REMOTE_ADDR to “Yes.”

b. To verify that the proxy address of an incoming request matches what is stored in the
$_SESSION variable, set Validate HTTP_VIA to “Yes.”

c. To verify that the forwarded-for address of a request matches what is stored in the $_
SESSION variable, set Validate HTTP_X_FORWARDED_FOR to “Yes.”
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d. To verify that the browser or device that is used to access the store during a session
matches what is stored in the $_SESSION variable, set Validate HTTP_USER_AGENT
to “Yes.”

e. If you want a user to stay logged in while switching between stores, set Use SID on
Frontend to “Yes.”

If including SID with analytics, you must configure your analytics software to filter the
SID from URLs, so the page visit counts are correct.

3. When complete, click the Save Config button.

Browser Capabilities Detection
As with most websites and applications on the Internet today, Magento requires that the
visitor’s browser allow both cookies and JavaScript for full operations.

Occasionally a user’s browser might be set to the highest privacy setting which disallows
both cookies and JavaScript. Your store can be configured to test the browser capabilities of
each visitor, and to respond if the settings need to be changed.

If the browser’s privacy settings disallow cookies, you can configure the system to
automatically redirect them to the “CMS No Cookies Page, ” which explains how to make
the recommended settings with most browsers.

If the browser’s privacy settings disallow JavaScript, you can configure the system to
display the following message above the header of every page:

JavaScript Disabled Notice

To configure browser capabilities detection:

1. On the Admin menu, select System > Configuration.

2. In the panel on the left under General, select Web.

3. Click to expand the Browser Configuration Detection section. Then, do the following:

a. If you want to display instructions that explain how to configure the browser to allow
cookies, set Redirect to CMS-page if Cookies are Disabled to “Yes.”

b. If you want to display a banner above the header when JavaScript is disabled in the
user’s browser, set Show Notice if JavaScript is Disabled to “Yes.”
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Browser Capabilities Detection

4. When complete, click the Save Config button.

Encryption & Hashing
Magento Enterprise Edition hashes all data that does not require decryption by using a
strong SHA-256 hashing algorithm instead of the previously used MD5. Legacy passwords
will be hashed using the new algorithm whenever they are entered by customers, and all
new passwords will be hashed using the SHA-256 algorithm.

Magento Enterprise Edition also encrypts all data that does require decryption by using an
industry-standard AES-256 algorithm. This includes credit card data and integration
(payment and shipping modules) passwords.

Changing the Database Key
Magento Enterprise Edition provides a tool to change the database key that is used for data
encryption and decryption. This database key was generated when Magento was originally
installed in your production environment. The key should be changed if the old key is ever
compromised, as well as on a regular basis to improve security. When the key is changed,
all legacy data is re-encoded using the new key.

Step 1: Make the File Writable

To make key change possible, the following file must be writable:

/opt/home_trials/baron/app/etc/local.xml

Step 2: Change the Encoding Key

1. On the Admin menu, select System > Manage Encryption Key.

New Encryption Key

2. Do one of the following:
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l To generate a new key, set Auto-generate a Key to “Yes.”

l Set Auto-generate a Key to “No.” Then, enter the key that you want to use in the New
Key field.

3. When complete, click the Change Encryption Key button.

The encryption key is changed and all previous data is encoded with the new key. The new
encryption key appears for reference.

Write down the new key and keep it in a safe place. It will be required to decrypt the data,
if any problems occur with your files.
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CHAPTER 71:

Index Management
Indexing is how Magento transforms data such as products, categories, and so on, to
improve the performance of your web store. As data changes, the transformed data
must be updated—or reindexed. Magento has very sophisticated architecture that stores
merchant data (including catalog data, prices, users, stores, and so on) in many
database tables. To optimize storefront performance, Magento accumulates data into
special tables using indexers.

For example, suppose you change the price of an item from $4.99 to $3.99. Magento
must reindex the price change to display it on your store. Without indexing, Magento
would have to calculate the price of every product on the fly—taking into account
shopping cart price rules, bundle pricing, discounts, tier pricing, and so on. Loading
the price for a product would take a long time, possibly resulting in cart abandonment.

Topics in this chapter:

l Accessing Index Management

l Index Configuration

l Manual Reindexing

l Automatic Reindexing

l Index Scheduling
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Accessing Index Management
The Index Management tool can be accessed from the System menu, or by clicking the link
in the message that appears at the top of the workspace when indexes are out of date.

Index Management

Index Management

To access Index Management:

1. On the Admin menu, select System > Index Management.

Index Management has a slightly different presentation, depending on your configuration:

l If you use Solr search engine for full-text catalog.

l If you use Flat catalog product options.

2. Any indexer with a checkbox next to its name can be managed manually. The other
indexers update automatically according to your Magento cron job. The default mode for
each indexer is set in the system configuration.
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COLUMN DESCRIPTION

Index The name of the indexer.

Description A description of the indexer.

Mode Applies only to the indicated indexers. Most of the indicated
indexers are set to Update on Save, whichmeans a reindex is
required when a change is saved.

Status Displays one of the following:

Reindex Required A change has beenmade that requires
reindexing. If a checkbox and Reindex
Required link appears, can be reindexed
manually.

Ready The index is up-to-date.

Scheduled Reindexing is scheduled to take place.

Running Reindexing is currently running.

The following options apply only to the automatic indexers:

Scheduled Reindexing is required but hasn't run yet
according to your Magento cron job.

Running Rreindexing is required and is either
running or in the queue.

Outdated Indicates reindexing is required but there
is an issue preventing it from running. If
this state persists, submit a bug report.

Update Required Applies only to the indicated indexers. Indicates whether or not
youmust manually reindex. (The value in theMode column
indicates whether the indexer must bemanually updated.)

Updated At Displays the date and time an index was last manually updated,
or Never if the index has never beenmanually updated.

Action Indexers that require manual updating display a Reindex Data
link. Click the link to reindex only that option.

Column Descriptions
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Index Configuration
The default mode for each indexer is set in the system configuration. For most indexers, the
default mode can be overridden from the Index Management page.

For example, to schedule the category flat catalog and the category flat product index using
your Magento cron job and to immediately reindex everything else, choose the following
options:

Category Flat Index: Updates when scheduled.

Product Flat Index: Updates when scheduled.

All other indexers: Updates on Save.

To configure indexing options:

1. On the Admin menu, select System > Configuration. In the panel on the left, under
Advanced, select Index Management.

2. Click to expand Index Options. Then, set each index to one of the following:

Update on Save Immediately performs a partial reindex when an item
changes.

Update When Scheduled Updates the index according to your Magento cron job.

Index Options

3. When complete, click the Save Config button.
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INDEXER TYPE CONFIGURABLE?

Catalog Category/Product
Index

No Configure only partial reindexing frequency.

Category URLRewrite Yes Also configure partial reindexing frequency.

Product URLRewrite Yes Also configure partial reindexing frequency.

Redirect URLRewrite No Configure only partial reindexing frequency.

Category Flat Index Yes Also configure partial reindexing frequency.

Product Flat Index Yes Also configure partial reindexing frequency.

Price and Stock Index No Configure only partial reindexing frequency.

Category Permissions No Category permissions indexing occurs
automatically and is not configurable.

Configuration by Indexer Type
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Manual Reindexing
Indexers that require manual updates have a checkbox in the first column next to their
name (Product Attributes, Tag Aggregation Data, and, optionally, Catalog Search Index).
The following figure shows an example of one index that requires a full reindex (Product
Attributes), an index that requires a partial reindex (Catalog Search Index), and an index
that is up-to-date (Tag Aggregation Data).

l If the Status column indicates “Reindex Required,” and the Update Required column
indicates “No,” only a partial index is produced when you index manually.

l If the Status column indicates “Reindex Required,” and the Update Required column
indicates “Yes,” a full index is produced when you index manually.

Index States

Index States

To reindex manually:

1. On the Admin menu, select System > Index Management.

2. Select the checkbox of each item to be reindexed.

3. Set Actions to “Reindex Data.”

4. Click the Submit button.
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Automatic Indexing
Magento reindexes automatically whenever one or more items are changed. Actions that
trigger reindexing include price changes, creating catalog or shopping cart price rules,
adding new categories, and so on). Reindexing is performed as a background process, and
your store remains accessible during the processes.

Indexing byMultiple Users
To avoid problems when multiple Admin users update objects that trigger automatic
reindexing, set all indexers to run as cron jobs. Otherwise, every time an object is saved,
any affected objects with interdependencies might cause a deadlock. Symptoms of a
deadlock include high CPU usage and MySQL errors. As a best practice, schedule indexing
as a cron job to prevent deadlocks from occurring.

IndexModes
The default mode for each indexer is specified in the system configuration. By default,
indexers that require manual updating are set to “Update on Save,” which means
reindexing occurs after a change is made from the Admin. The other option is to manually
reindex every time a change is made. (For example, if you change product attributes in the
Admin, you must manually update the Product Attributes index.) If you ever need to
override the default index mode, you can use the Action control.

To change the index mode:

1. On the Admin menu, select System > Index Management.

2. Select the checkbox of each indexer you want to change.

3. Set Actions to “Change Index Mode.” Then, set Index Mode to one of the following:

l Update on Save

l Manual Update

4. Click the Submit button to apply the change to each selected indexer.

1127Magento Enterprise Edition User Guide, Version 1.14.2.1



Automatic Indexing CHAPTER 71:  Index Management

1128 Magento Enterprise Edition User Guide, Version 1.14.2.1

Events that Trigger Reindexing

INDEX TYPE REINDEXING EVENT

Product Prices Add customer group
Change configuration settings

Flat catalog1 product data Add store
Add store group
Add, edit, or delete attribute (for searching and filtering)

Flat catalog category data Add store
Add store group
Add, edit, or delete attribute (for searching and filtering)

Catalog category/product
index

Add, edit, or delete products (single, mass, and import)
Change product-to-category relations
Add, edit, or delete categories
Add or delete stores
Delete store groups
Delete websites

Catalog search index Add, edit, or delete products (single, mass, and import)
Add or delete stores
Delete store groups
Delete websites

Stock status index Change inventory configuration settings.

Category permissions
index

Add store, add store group, add or delete or update attribute (for
searching and filtering)

Reindexing Triggers

1 The flat product and category indexers also influence how catalog and shopping cart price rules are indexed.
If you have a large number of SKUs (about 500,000 or more), you will notice a dramatic improvement in
indexing time for price rules. To take advantage of this improvement, you must enable Use Flat Catalog
Product.
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Index Actions and Controls

ACTION RESULT TO CONTROL

Creating a new store, new
customer group, or any
action listed in “Actions
that Cause a Full
Reindex.”

Full reindex Full reindexing is performed on
the schedule determined by your
Magento cron job. In a few cases,
full reindexingmust be performed
manually.

Bulk loading of items in the
following ways:

l Magento import/export

l Direct SQL query

l Any other method that
directly adds, changes,
or deletes data.

Partial reindex (only
changed items are
reindexed)

At the frequency determined by
your Magento cron job.

Changing scope (for
example, from global to
website)

Partial reindex (only
changed items are
reindexed)

At the frequency determined by
your Magento cron job.

Index Actions

Events that Trigger Full Reindexing

INDEXER EVENT

Catalog Category Flat
Indexer

Create a new web store
Create a new web store view
Create, or delete an attribute that is any of the following:

l Searchable or visible in advanced search

l Filterable

l Filterable in search

l Used for sorting

Change an existing attribute to be any of the preceding.
Enable flat category frontend options

Catalog Product Flat
Indexer

Create a new web store
Create a new web store view

Full Reindex Triggers
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INDEXER EVENT

Create, or delete an attribute that is any of the following:

l Searchable or visible in advanced search

l Filterable

l Filterable in search

l Used for sorting

Change an existing attribute to be any of the preceding.
Enable flat category frontend options

Stock status indexer When the following Catalog Inventory options changes in the
system configuration:

Stock Options Display Out of Stock Products

Product Stock
Options

Manage Stock

Price Indexer Adding a new customer group.
When any of the following Catalog Inventory options changes in
the system configuration:

Stock Options Display Out of Stock Products

Product Stock
Options

Manage Stock

Price Catalog Price Scope

Category or Product
Indexer

Create or delete a store view
Delete a store
Delete a website

Full Reindex Triggers (cont.)



CHAPTER 71:  Index Management Index Scheduling

Index Scheduling
For most indexers, you can use one of two scheduling methods:

Method 1: Immediate Partial Reindex

A partial index displays the results immediately in the store. We recommend that you use
immediate partial reindexing unless many items are being updated by multiple users at
the same time. If in doubt, you can check the system resource utilization using top, or a
similar command.

Method 2: Cron Job

It is recommended that you set up a cron job to manage index scheduling for stores with a
high traffic load, or if many items are updated at the same time by multiple users. To learn
more, see: How to Set Up a Cron Job.

Index Cleanup
Each time the partial reindexing job runs, a record is created in the Magento database to
indicate the status of the job. These records can be used for troubleshooting in case a job
fails. However, the “success” records take up space in the database, and should be removed
periodically.

The Index Management page gives you the ability to clean up the index by removing the
“success” records that occur during a partial index. The process can take anywhere from a
few seconds to a few minutes, depending on the number of records. We recommend that
you clean the index once per day during off-peak hours.

Cleaning the index has a negligible effect on server performance, and no effect on customers in
the store.

To schedule index cleanup:

1. On the Admin menu, select System > Configuration. In the panel on the left, under
Advanced, select Index Management.

2. Click to expand Index Clean Schedule. Then, do the following:

Index Clean Schedule
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a. Set Enable Scheduled Cleanup to “Yes.”

b. Set the Start Time to the hour, minute, and second.

c. Set Frequency to one of the following:

l Daily

l Weekly

l Monthly

3. When complete, click the Save Config button.
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CHAPTER 72:

Cache Storage
Using Magento’s cache management system is an easy way to improve the performance
of your site. The Cache Storage Management page shows the status of each primary
cache and its associated tag. Whenever one of the caches needs to be refreshed, a notice
appears at the top of the workspace to guide you through the process.

There are separate command buttons to flush the Magento-specific cache, and the more
all-inclusive cache storage. In addition, there are command buttons to flush the catalog
product images cache and JavaScript/CSS cache.

On the server, the default location for the primary Magento cache is var/cache. As an
alternative to using the Cache Management tool, the contents of each cache can be
manually deleted from the server.

Topics in this chapter:

l Clearing Caches

l Full-Page Cache
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Clearing Caches
After clearing a cache, always refresh your browser to make sure that it uses the most recent
files.

Cache Storage Management

To refresh specific caches:

1. Do one of the following:

l Click the Cache Management link in the message at above the workspace.

l On the Admin menu, select System > Cache Management.

The status of each cache that needs to be refreshed appears in yellow and marked,
“Invalidated.”
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Cache Refresh Needed

2. Do one of the following:

l For each cache that needs to be refreshed, click the checkbox at the beginning of the row.

l To select a group, click one of the selection options above the list.

3. Set Actions to “Refresh,” and click the Submit button.

Refreshing Multiple Caches
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To flush the product image cache:

1. From the Cache Storage Management page, under Additional Cache Management, click the
Flush Catalog Images Cache button.

The message, “Image cache was cleaned” appears at the top of the workspace.

2. Make sure to also clear the cache of your browser.

To flush the JavaScript/CSS cache:

1. From the Cache Storage Management page, under Additional Cache Management, click the
Flush JavaScript/CSS Cache button.

The message, “The JavaScript/CSS cache has been cleaned” appears at the top of the
workspace.

2. Clear the cache of your browser.

BUTTON DESCRIPTION

FlushMagento Cache Removes all items in the default Magento cache (var/cache),
according to their associatedMagento tags.

Flush Cache Storage Removes all items from the cache, regardless of Magento tag. If
your system uses an alternate cache location, any cached files
used by other applications are removed in the process.

Flush Catalog Images
Cache

Removes all automatically resized and watermarked catalog
images that are stored at: media/catalog/product/cache.
If recently uploaded images aren't reflected in the catalog, try
flushing the catalog and refreshing your browser.

Flush JavaScript/CSS
Cache

Removes themerged copy of JavaScript and CSS files from the
cache. If recent changes to the style sheet or JavaScript aren't
reflected in the store, try flushing the JavaScript/CSS cache and
refreshing your browser.

Buttons
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TYPE DESCRIPTION

Configuration System andmodule configuration files.
Associated tag: CONFIG

System: config.xml, local.xml

Module: config.xml

Layouts Page layout building instructions.
Associated tag: LAYOUT_GENERAL_CACHE_TAG

Blocks HTMLOutput The HTML that is associated with page blocks.
Associated tag: BLOCK_HTML

Translations Language translation files.
Associated tag: TRANSLATE

Collections Data Files that contain data that is the result of a query.
Associated tag: COLLECTION_DATA

EAV Types and Attributes Attribute entities, types, and values.
Associated tag: EAV

WebServices
Configuration

Web Services definition files (api.xml)
Associated tag: CONFIG_API

WebServices
Configuration

Web Services definition files (api2.xml)
Associated tag: CONFIG_API2

Page Full page cache.
Associated tag: FPC

Cache Types
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BUTTON DESCRIPTION

Flush Catalog Images
Cache

Removes all automatically resized and watermarked catalog
images that are stored at: media/catalog/product/cache.
If recently uploaded images aren't reflected in the catalog, try
flushing the catalog and refreshing your browser.

Flush Swatch Images
Cache

Removes pregenerated swatch image files.

Flush JavaScript/CSS
Cache

Removes themerged copy of JavaScript and CSS files from the
cache. If recent changes to the style sheet or JavaScript aren't
reflected in the store, try flushing the JavaScript/CSS cache and
refreshing your browser.

Re-build Visual
Merchandiser categories

Rebuilds the categories.

Additional Cache Management

Full-Page Cache
Magento Enterprise Edition uses full-page caching on the server to quickly display
category, product, and CMS pages.

Topics in this section include:

l Types of Page Visits

l Page Cache Setup

l Page Cache Actions

Full-page caching improves response time and reduces the load on the server. Without
caching, each page might need to run blocks of code and retrieve information from the
database. However, with full-page caching enabled, a fully-generated page can be read
directly from the cache.
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Types of Page Visits
Cached content can be used to process the requests from similar types of visits. As a result,
pages shown to a casual visitor might differ from those shown to a customer. For the
purposes of caching, each visit is one of three types:

Non-sessioned

During a non-sessioned visit, a shopper views pages, but does not interact with the store.
The system caches the content of each page viewed, and serves them to other non-sessioned
shoppers.

Sessioned

During a sessioned visit, shoppers who interact with the store—through activities such as
comparing products or adding products to the shopping cart—are assigned a session ID.
Cached pages that are generated during the session are used only by that shopper during
the session.

Customer

Customer sessions are created for those who have registered for an account with your store
and shop while logged in to their accounts. During the session, customers can be presented
with special offers, promotions, and prices that are based on the customer group to which
they are assigned.
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Page Cache Configuration
The default configuration settings for the page cache can be used “as is” or changed as
needed. The site administrator can determine how deeply site content is cached for each
page.

Full-page caching is enabled by default and can be used as needed. It’s generally a good
idea to disable page caching while a site is in development, and enable it when the site goes
live. After making content changes to products, CMS pages or blocks, you can refresh the
page cache to update the content.

To change the cache configuration:

1. On the Admin menu, select System > Configuration. Then in the panel on the left under
Advanced, select System.

2. Click to expand the Full Page Cache Settings section, and do the following:

Full Page Cache Settings

a. Set Max Allowed Page Depth to the maximum number of layered navigation filters or
parameters to be cached per page.

b. If you want to cache pages for only the default currency, set Enable Cache for Not
Default Currencies to “No.”

c. Enter the Max. Cache Size in megabytes.

3. Click the Save Config button to save your settings.

http://merch.docs.magento.com/ee/user_guide/Magento_Enterprise_Edition_User_Guide.html#configuration/advanced/system.html%23Full_Page_Cache_Settings
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Page Cache Auto-Generation
Magento pages are typically cached when the page is visited for the first time. However,
when a site first goes live, or after making a large number of content changes, you might
want to force a full regeneration of the page cache. The entire website is crawled during the
auto-generation process, which creates more cached pages than would be produced by page
visits alone. Auto-generating the page cache ensures that each page in the site loads
quickly the first time, and every time thereafter.

Because the auto-generation process is resource intensive, it should be initiated during low-
traffic hours. It is recommended that you auto-generate the full-page cache only as needed,
and flush the Magento cache to trigger the process. Afterward, you can disable the auto-
generate process until the next time you want to regenerate the full page cache.

Step 1: Configure Page Cache Auto Generation

1. On the Admin menu, select System > Configuration. In the panel on the left under
Advanced, select System.

2. Click to expand the Full Page Cache Auto Generation section. Then, do the following:

Full-Page Cache Auto Generation

a. To regenerate the full-page cache, set Enable Page Cache Auto Generation to “Yes,”

b. In the Crawler Thread Number field, enter the number of parallel requests you want
to make during the process. Parallel requests can speed up the process, but require
more system resources. In most cases, it is recommended to use from one to five.

c. To avoid caching pages with currencies other than the default. set Generate Page
Cache for Not Default Currencies to “No.”

3. When complete, click the Save Config button.
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Step 2: Flush the Magento Cache

1. On the Admin menu, select System > Cache Management.

2. In the upper-right corner, click the Flush Magento Cache button.

Flush Magento Cache
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Page Cache Actions
If the content of a block on a cached page changes, the cached page is retrieved, the block
overwritten, and the updated page is saved back to the cache. The page cache can be built
gradually as pages are visited, or auto-generated for the entire site.

To manage cache operations:

1. On the Admin menu, select System > Cache Management.

Page Cache Actions

2. Under Cache Storage Management, select the Page Cache checkbox. In the upper-right, set
the Actions control to one of the following:

Enable Turns on page caching. By default, the page cache is enabled.

Disable Turns off page caching.

Refresh Clears the page cache. If Page Cache is enabled, new pages are added
to the cache as they are visited. If Full-Page Cache Auto Generation is
enabled, refreshing the page cache triggers the process.

3. Click the Submit button to apply the action.
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CHAPTER 73:

Alternate Media Storage
Magento Enterprise Edition gives you the option to store media files in a database on a
database server, or on a Content Delivery Network (CDN), as opposed to storing them
on the file system of the web server. The advantage of using alternate storage is that it
minimizes the effort required to synchronize media when multiple instances of the
system that are deployed on different servers that need access to the same images, CSS
files, and other media files.

Topics in this chapter:

l Media Storage Database Setup

l Media Storage CDN Setup



Media Storage Database Configuration CHAPTER 73:  Alternate Media Storage

1146 Magento Enterprise Edition User Guide, Version 1.14.2.1

Media Storage Database Configuration
By default, all images, compiled CSS files, and compiled JavaScript files of the Magento
instance are stored in the file system on the web server. You can choose to store these files
in a database on a database server. One advantage of this approach is the option of
automatic synchronization and reverse synchronization between the web server file system
and the database. You can use the default database to store media or create a new one. To
be able to use a newly created database as media storage, you must add information about
it and its access credentials to the local.xml file.

Database Workflow
When the customer opens the store page, its browser requests the HTML code and the
media specified in the HTML code from the Magento system. The system searches the
requested media in the file system and passes it to the browser, if it is found. If the system
does not find the media in the file system, it requests the media from the database
specified in the settings, places the media to the file system, and sends it to the customer’s
browser.

To get the files from the database to the file system on the web server a PHP script is used.
When the browser requests media from the web server, there are two alternatives for when a
PHP script is run:

l If web server rewrites are enabled in the Magento system and supported by the server,
the PHP script is run only when the requested media is not found in the web server file
system.

l If web server rewrites are disabled in the Magento system or not supported by the server,
the PHP script is run in any case, even when the required media exists in the file system
of the web server.

To use a database for media storage:

1. On the Admin menu, select System > Configuration. Then in the panel on the left, under
Advanced, select System.

2. This configuration takes place at the global level, so set Current Configuration Scope to
“Default Config.”

3. Click to expand the Storage Configuration for Media section. Then, do the following:
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Storage Configuration for Media

a. Set Media Storage to “Database.”

b. Set Select Media Database to the database you want to use.

c. Click the Synchronize button to transfer the existing media to the newly selected
database.

d. Enter the Environment Update Time in seconds.

4. When complete, click the Save Config button.

Media Storage CDN Configuration
Storing media files in a CDN is another alternative supported in Magento. There is no full
integration with a specific CDN, and you are responsible for choosing and configuring a
CDN on your own. After configuring the CDN, you must complete the configuration from
the Admin. The changes can be made at either the global or website level.

CDNWorkflow
When a CDN is selected as media storage, all paths to media on the web store pages are
changed to paths to the CDN. Retrieving media that is stored in a CDN works as follows:

l When a customer opens a page in the store, the browser addresses the CDN with the
request to acquire some media files, such as images.

l If the CDN does not yet have these images in its storage, it requests them from the
server, and provides images to the customer’s browser.

l If the CDN already has the required images in storage, it simply serves the requested
images to the customer's browser.

Important!When a CDN is used as media storage, JavaScript may not function properly if the
CDN is not in your subdomain. This is a browser security feature.
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To configure a content delivery network:

1. On the Admin menu, select System > Configuration. Then in the panel on the left, under
General, select Web.

2. Set the Current Configuration Scope as needed.

3. Click to expand the Unsecure section. Then, do the following:

Unsecure

a. Update the Base Media URL with the URL of the media files on the CDN.

b. Update the Base JavaScript URL with the URL of the JavaScript files on the CDN.

4. Click to expand the Secure section.

Secure

a. Update the Base Media URL with the URL of the media files on the CDN.

b. Update the Base JavaScript URL with the URL of the JavaScript files on the CDN.

5. When complete, click the Save Config button.

http://merch.docs.magento.com/ee/user_guide/Magento_Enterprise_Edition_User_Guide.html#configuration/general/web.html%23unsecure
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CHAPTER 74:

Installing Solr Search
Solr is not bundled with Magento and must be installed separately by your hosting firm
or system administrator. Although Magento does not provide support for configuring
Solr server we do provide Solr configuration and schema files to help your hosting firm
or system administrator with the initial server configuration. Please contact the
Magento Support team for assistance.

When you enable and configure Solr, quick search and advanced search are redirected
to the Solr server, although the results appear in the same way as they would if using
the default MySQL-based search.

During the installation process, you must specify the host name, port, and the
password to connect to the server where Solr search engine is installed. You will need to
complete the initial part of the configuration before fine-tuning the Solr features.

Topics in this chapter:

l Solr Server Configuration

l Solr Base File Setup

For more technical information, see: How to Install and Configure the Solr Search
Engine With Magento Enterprise Edition (EE) 1.x

http://devdocs.magento.com/guides/m1x/other/ht_magento-solr.html
http://devdocs.magento.com/guides/m1x/other/ht_magento-solr.html


Solr Server Configuration CHAPTER 74:  Installing Solr Search

1150 Magento Enterprise Edition User Guide, Version 1.14.2.1

Solr Server Configuration
A number of parameters must be set up in the Magento Admin to establish the connection
to the Solr search engine. Solr can be installed either on the same server as Magento, or on
a different server. The following instructions show how to enable Solr and complete the
server-side of the Solr configuration.

For more technical information, see: How to Install and Configure the Solr Search Engine
With Magento Enterprise Edition (EE) 1.x

Solr Catalog Search (Server Settings)

To enable Solr:

1. On the Admin menu, select System > Configuration. Then in the panel on the left, under
Catalog, select Catalog.

2. Click to expand the Catalog Search section.

3. Set Search Engine to “Solr.” When the Solr options appear, do the following:

a. Enter the fully-qualified Solr Server Hostname or IP address.

b. Enter the number of the port that is assigned to be the Solr Server Port.

c. Enter the Solr Server Password.

http://devdocs.magento.com/guides/m1x/other/ht_magento-solr.html
http://devdocs.magento.com/guides/m1x/other/ht_magento-solr.html
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d. In the Solr Server Timeout field, enter the number of seconds of inactivity that can
pass before the connection times out.

e. For a standard Solr installation, you can accept the default Solr Server Path. For a
custom deployment, enter the installation path.

f. Set Indexation Mode to one of the following:

Final commit (Default) Offers better performance than a partial
commit, and users see the results immediately. Indexing
begins after all unneeded data is removed and new data
is added.

Partial commit As content is gradually reindexed, users see only the
indexed results. All content is removed after reindexing.

Engine autocommit Content is put into the index queue but is not
committed. To use autocommit, you must configure Solr
to commit at regular intervals (for example, every 5
minutes) or when a certain number of uncommitted
items is reached.

g. To verify the installation, click the Text Connection button.

4. When complete, click the Save Config button.

5. When the initial Solr installation is complete, complete the feature configuration to take
full advantage of the capabilities of Solr.

Solr Base File Setup
Solr includes the following base files that must be completed for every language used in the
system. Solr supports search functionality for twenty languages. Solr calls the fields for the
language used by the current store.

BASE FILES DESCRIPTION

protwords.txt Protected words. Use a protected word file to prevent the
stemmer algorithm from reducing two unrelated words to the
same base word.

spellings.txt Definitions of misspelled words.

stopwords.txt Words that stop the search (have nomeaning for search).

synonym.txt Synonyms for every language.

Solr Base Files
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CHAPTER 75:

Content Staging
Content staging websites are hidden websites that can only be accessed through a
password-protected URL. A content staging site can have the same domain as your live
store, or a separate domain, but it runs on the same Magento installation and database
as the live site.

Content staging websites should never be used for code or development work.

Topics in this chapter:

l Staging Site Configuration

l Creating a Staging Site

l Merging Content

l Managing Content Staging
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Staging Site Configuration
The configuration determines the point of entry to the staging site and its landing page.

To configure a content staging website:

1. On the Admin menu, select System > Configuration. Then in the panel on the left, under
General, select General.

2. Click to expand the Staging Websites section. Then, do the following:

Staging Websites

a. Set Automatically Create Entry Points for Staging Websites to one of the following:

Yes Generates entry points automatically for a staging website that is hosted
on the same domain as the Magento installation.

No For staging websites that are hosted on a separate domain.

b. In the Folder Name for Entry Points field, enter the name of the folder where the
automatically-generated entry points are saved.

c. Set Close Website During Merge or Rollback to one of the following:

No The site(s) can be accessed as usual.

Close Entire
Frontend

(Recommended) All sites are restricted.

Close Only
Relevant Websites

Access is restricted only to the site(s) involved in the merge or
rollback activity.

d. Choose the CMS Landing Page that you want to appear is the site is closed during a
merge or rollback activity.

3. When complete, click the Save Config button.
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Creating a Staging Site
Magento Enterprise Edition allows you to create as many staging websites as required. You
can also create Staging Websites based on other Staging Websites. This allows more people
to work on different parts of the new content. The content can be merged to the beta
Website, fully tested and reviewed, and finally merged to the production (live) Website.

Content Staging Workflow
From the Admin, a staging website is accessed in the same way as a normal website. You
can create, edit, and delete content and products in exactly the same way. However,
because it uses the same database as the live store, any products deleted from a staging
site are deleted from the live store, as well. Set the configuration scope as you work to
determine whether you’re working on the staging site or the live site.

When your changes are approved, you can merge the staging website with the live website
and do not have to re-enter data or configuration changes. During the merge, all the
content assigned to the staging website is assigned to the live website, and all attributes on
the staging website/store view level are copied to the matching live website/store view. All
mapping and content selection details can be controlled by the administrator, so only the
content and content types you want will be merged. Additionally, during merging, a
rollback (backup) can be created.

To create a new content staging website:

1. On the Admin menu, select System > Content Staging > Staging Websites.

This page lists all existing Staging Websites.

2. In the upper-right corner, click the Add Staging Website button. Then, do the following:

Staging Website Settings

a. Set Source Website to one of existing websites. Then, click the Continue button.

b. Complete the Staging Website section, using these field descriptions for reference.
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Staging Website

3. In the Select Original Website Content to be Copied to the Staging Website section, select
the checkbox of each type of content to be copied to the staging website.

Select Original Website Content to be Copied to the Staging Website

4. In the Select Original Website Store Views to be Copied to the Staging Website, select the
checkbox of each store view that is to be copied to the staging website.

Select Original Website Store Views to be Copied to Staging

5. When complete, click the Create button to save your settings. You will be redirected to the
Staging Websites list.

After the staging site is set up, you can edit content, and assign it to the Staging site, or
change attributes at the Website or Store View level. You can also change the Label and
Frontend Restriction options. A record of all changes to the site, such as creation, merge, or
rollback, can be viewed on the Event History tab.

Important!Never delete a product from acontent stagingwebsite, because it will be deleted
from the live site, aswell. To removea product from acontent stagingwebsite, simplydisable it.
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FIELD DESCRIPTION

MasterWebsite Code The name assigned to the staging environment, for internal
reference.

StagingWebsite Code Unique website code of the StagingWebsite. This field will be
pre-populated with and automatically generated code, although
you have the ability to modify the value.

StagingWebsite Name Name of the StagingWebsite. This field will be pre-populated
with and automatically generated name, although you have the
ability to modify the value.

Frontend Restriction Controls how the frontend of the StagingWebsite can be
accessed. Options include:

Not accessible Disables access to the entire staging
frontend.

Accessible The staging site is open and can be
accessed by anyone that knows the
URL.

Require HTTP
Authentication

The staging site will show a username
and password prompt on access, which
can be configured below.

HTTP Login The user name required for HTTP Authentication.

HTTP Password The password required for HTTP Authentication.

Field Descriptions

1157Magento Enterprise Edition User Guide, Version 1.14.2.1



Merging Content CHAPTER 75:  Content Staging

1158 Magento Enterprise Edition User Guide, Version 1.14.2.1

Merging Content
After making all the necessary content changes on the staging website you can merge or
schedule merging of the staging website to another website. For a scheduled merge to be
applied, the Magento cron job must be running on the server.

Only one backup can be created for each website per merge. Backups are created in the
database and require significant database space. Because backups are not updated when
Magento is updated, any table structure that changes during an update cannot be restored
from a backup.

To merge or schedule a merging:

1. On the Admin menu, select System > Content Staging > Staging Websites.

2. In the list, click the the staging website that you want to merge.

3. Click the Merge button to open the mapping configuration page.

4. In the top section, define the mapping of the websites and store views. This controls which
staging website is merged to which live website, and which staging store view is merged to
which live store view.

a. Select the To Website, which is the target website. The To website can be either the
source website, or another website.

b. Click Add New Store View Map.

c. Select the From and To Store Views. Each option can be selected only once.

d. Repeat this process to add maps for all store views that need to be merged.

5. Select the Create a backup checkbox to create a backup of the live site before merging.

6. In the list, select all items that you want to merge from the staging to the live website.

7. Click Merge Now or specify a date and time and click Schedule Merge.
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Rolling BackMerged Content
If you have selected to create a backup when merging a website, a backup of the target
website is created just before the merge. The backup contains only the tables that are
related to the content staging merge, and is not a backup of the entire site.

To roll back content:

1. On the Admin menu, select System > Content Staging > Backups.

2. Find the backup in the list that you want to roll back, and open the record.

3. In the panel on the left, select Rollback. Then, choose the items that you want to restore.
You can only select the items which are available.

4. Click the Rollback button. After the website is restored, you will be redirected to the backup
grid.

Items are available for rollback only if the table versions of the backup and original Website
match. If they do not match, the rollback is not possible with Magento functionality. It can be
carefully performed using manual database administration tools, however this is not
recommended. The table version might change when an upgrade of the Magento system also
changes the structure of some of the tables.

Rollback can be used either to restore content if an error is noticed after a merge, or to
restore to a previous site version when the staging site is used for seasonal or temporary
website changes.

TAB DESCRIPTION

BackupGeneral Info Displays the basic backup information. Table Prefix is the prefix
used for backup tables of this website in the database.

Rollback History Displays events associated with this backup.

Rollback Contains the list of items which are available for rollback.

Website Backup Information
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Managing a Staging Site
Content staging is a very powerful tool, but requires caution to use it effectively. An
important thing to understand is that the staging website it is not a separate beta website
with a separate database. It is another website in the store that is hidden. Thus, creating
and deleting content, such as products, requires special attention.

Important!Never delete products from a content staging website, because theywill bedeleted
from the live site, aswell. To removea product from acontent stagingwebsite, simplydisable it.

To remove products from a staging website:

1. On the Admin menu, select Catalog > Manage Products.

2. Click to open the product in edit mode. Then, do one of the following:

l In the panel on the left, select Websites. Then uncheck the staging website that you
want to disassociate from the product.

l Set Choose Store View to the staging website. Then, on the General tab, set Status to
“Disabled.”

3. When complete, click the Save button.

This product is removed from the staging website, but still exists in the production site,
until a merge is performed.

4. Follow the instructions to merge the staging website into the production website.

The product is now unassigned or disabled in the staging website, as well as in the
production website. The product can be safely deleted, as it is no longer used.

To create a product on a staging website:

1. On the Admin menu, select Catalog > Manage Products.

2. In the upper-right corner, click the Add Product button. Then, do the following:

a. Create the product as usual.

b. In the panel on the left, select Websites. Then, assign the product only to the staging
website.

c. When complete, click the Save button.

3. Merge the Staging Website into the production Website by following the instructions.

The product is now available in both the staging and production websites. Similar steps
should be taken when working with other types of content.
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To change the staging environment settings:

1. On the Admin menu, select System > Content Staging > Staging Websites.

2. Find the site in the list, and click to open the record in edit mode.

3. Make the necessary changes, and click the Save button.

UpgradingMagento
When using a staging website, take special care when upgrading Magento. Upgrades
modify the staging website, but not the backups. In some cases, especially if the upgrade
modifies content tables, an upgrade can render the backup unusable. It is recommended
that you upgrade Magento either before you work on a staging website, or after a merge has
been completed, confirmed, and no rollback is expected.

1161Magento Enterprise Edition User Guide, Version 1.14.2.1



Managing a Staging Site CHAPTER 75:  Content Staging

Notes

1162 Magento Enterprise Edition User Guide, Version 1.14.2.1



1163Magento Enterprise Edition User Guide, Version 1.14.2.1

CHAPTER 76:

Magento Connect
Magento Connect is the marketplace for Magento extensions. There are hundreds of
extensions and themes from all over the world. Magento out-of-the-box supports a few
of the most popular ones. However, community members are developing and
publishing new extensions in order to extend Magento with various new features.

In this chapter:

l Installing Extensions

Magento Connect

http://www.magentocommerce.com/magento-connect/
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Installing Extensions
Many extensions are available on Magento Connect, and the installation process varies for
each. Some extensions require additional configuration after the installation. Please read
the documentation provided by the extension developer for specific instructions. The
following instructions outline the general process. Before installing any extension, always
backup your store.

To back up your store:

1. On the Admin menu, select System > Magento Connect > Magento Connect Manager.

2. Select the Create Backup checkbox and select the backup type.

The backup is created automatically, and is listed under System > Tools > Backups.

To install an extension:

1. Go to Magento Connect.

2. Use the filters to browse through the available extensions.

3. On the page of the extension you want to install, do the following:

a. If the extension is available for sale, click the Get Extension button. Then, follow the
prompts to purchase the extension.

b. Click the Get Extension Key key button.

c. Click the link to read the license agreement, and if you agree to the terms, select the
checkbox.

An extension key similar to this appears: magento-core/Mage_xxxx. The key is a
special link that Magento needs to install the extension to your store.

d. Click Select to select the key, and press Ctrl + C to copy it to the clipboard.

4. Log in to your store Admin, and do the following:

a. On the Admin menu, select System > Magento Connect > Magento Connect
Manager.

b. When prompted, enter your Admin User Name and Password. Then, click the Log In
button.

http://www.magentocommerce.com/magento-connect/
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Log In to Magento Connect Manager

c. In the Install New Extensions section, paste the Extension Key.

d. Click the Install button and wait for the installation to complete.

5. You can now return to your store Admin and use the extension.

Look for new options in the related section of the Admin. For example, a payment
extension will appear in System > Configuration > Sales > Payment Methods.

1165Magento Enterprise Edition User Guide, Version 1.14.2.1



Installing Extensions CHAPTER 76:  Magento Connect

Notes

1166 Magento Enterprise Edition User Guide, Version 1.14.2.1



1167Magento Enterprise Edition User Guide, Version 1.14.2.1

CHAPTER 77:

Web Services
Web services share information across networks using standards-based technologies.
Information from your store can be shared with other Web-based services to help create
a more integrated set of tools for your business.

Web services retrieve information from your store using an application programming
interface, the Magento Core API. The Magento Core API includes all the parameters for
data requests that other web services need to access information from your store.

Topics in this chapter:

l Magento Core API Settings

l Activating Web Services



Magento Core API Settings CHAPTER 77:  Web Services

1168 Magento Enterprise Edition User Guide, Version 1.14.2.1

Magento Core API Settings
The Magento Core API supports both SOAP and XML RPC protocols. The API is
permission-based, and allows access to the Customer, Catalog, and Order modules of your
store.

The WSDL (Web Services Description Language) definition that you create for your
Magento Enterprise Edition API solution ism by default, WS-I compliant. This makes it
possible to use tools that require a WS-I complaint WSDL definition for API integration. No
additional settings are required. Use the following endpoint URL for all WSI-I APIs, and
replace {site_url} with the store domain.

http://{site_url}/api/wsi_soap/?wsdl

WS-I Endpoint URL

To change the general settings:
By default, the API default character set is UTF-8, and the timeout for client sessions is
3600 seconds. You can change the default settings through the system configuration of the
store.

1. On the Admin menu, select System > Configuration. Then in the panel on the left under
Services, select Magento Core API.

2. Click to expand the General Settings section. Then, do the following:

General Settings

a. Enter the name of the Default Response Charset that you want to use.

b. Enter the length of the Client Session Timeout in seconds.

c. To enableWS-I Compliance, select “Yes.”

d. To enable theWSDL Cache, select “Yes.”

3. When complete, click the Save Config button.

http://www.ws-i.org/
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Activating Web Services
Web Services give you the ability to grant permission to third-party applications to access
your store data for the purpose of integration.

Step 1: Create a Web Service Role

1. On the Admin menu, select System > Web Services > SOAP/XML-RPC Roles.

2. Click the Add New Role button.

3. In the Role Information section, enter a Role Name such as “API.”

4. In the panel on the left, select Role Resources. Then do one of the following:

l To enable full access, set Resource Access to “All.”

l To provide limited access to data, set Resource Access to “Custom.” Then, select the
checkbox of each resource that is available to this role.

l By default, when a area is selected, full access is granted. However, you can specify the
actions that a person is allowed to take. Specific types of access are listed under many of
the resource links, so it is easy to determine exactly what a user is allowed to do with
the resource.

5. When complete, click the Save Role button.

Step 2: Create a Web Service User

1. On the Admin menu, select Web Services > SOAP/XML-RPC-Users.

2. Click the Add New User button.

3. Complete the following fields:

l User Name

l First Name

l Last Name

l Email

4. In the API Key field, type in a verification key, or password. This is the access credentials
that third-party web services will use to access your Magento store.
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Web Service User

5. To confirm, re-enter the key in the API Key Confirmation field.

6. In the panel on the left, select User Role. Then, select a role for the user.

7. When complete, click the Save User button.

Step 3: Add Custom Scripts to Your Store

Some third-party web services rely on snippets of JavaScript code to gather data. Some web
services require you to insert code in the HTML <head> section, while others require the
code to be in the HTML footer, below the closing </body> tag.
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CHAPTER 78:

System Tools
The system tools give developers, system administrators, and support engineers easy
access to routine system processes and reports.

Topics in this chapter:

l Admin Actions Log

l System Error Logging

l Backups & Rollback

l Patches

l Compilation

l Cron

l Magento Test Framework

l Database Repair Tool

l Support Tools
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Admin Actions Log
Logging of administrator actions enables you to track of backend activities. For most
events, the available information includes the action, the name of the user who performed
it, whether it was a success or failure, and the ID of the object on which the action was
performed. Additionally the IP and date are always logged.

In addition, you can control how long the log entries are stored and how often they are
archived. The Admin Actions archive lists the CSV log files that are stored on the server
at: var/admin_logs. By default, the file name includes the current date in ISO format: 
yyyyMMddHH.csv.

Log archiving requires a cron job to be set up.

Admin Actions Log

To set up the Admin Actions Log:

1. On the Admin menu, select System > Configuration. Then in the panel on the left under
Advanced, select Admin.

2. Click to expand the Admin Actions Logging section, and do the following:

l To enable admin logging, select the checkbox of each module.

l To disable admin logging, clear the checkbox of each module.
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Admin Actions Logging

3. When complete, click the Save Config button.

To set up Admin Actions Log Archiving:

1. On the Admin menu, select System > Configuration. Then in the panel on the left under
Admin, select System.

2. Click to expand the Admin Actions Log Archiving section, and do the following:

a. In the Log Entry Lifetime, Days field, enter the number of days that you want to keep
the log entries in the database befor they are removed.

b. Set Log Archiving Frequency to one of the following:

l Daily

l Weekly

l Monthly

Admin Actions Log ArchivingAdmin Actions Log Archiving

3. When complete, click the Save Config button.
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Admin Actions Log Report
The Admin Actions Log report includes every activity that has taken place during the
lifetime specified for log entries. Report columns include a timestamp, action group and
action taken, username, result, and name of the affected module. If applicable, the Item_id
column displays the ID of an affected item, such as customer ID, order ID, or product ID.

The log data can be exported to CSV or XML format using the Export control at the top of
the report.

To view the Admin Actions Log Report:

1. On the Admin menu, select System > Admin Actions Log > Report.

2. To view the Admin User Data for any log entry, click the View link.

Log Entry Admin User Data

To export the report:

1. Before exporting the data, use the list controls to filter and sort the data that you want to
include.

2. Set the Export to control to one of the following formats:

l CSV

l Excel XML

3. Click the Export button.

To archive the log:

1. On the Admin menu, select System > Admin Logging > Archive.

2. Click the file name to download the archived file.
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System Error Logging
Magento can be configured to generate both a system and exception log to report on errors
that occur. The files are generated if an error occurs, and are saved in the following location
on the server, relative to your Magento installation:

{{base_dir}}/var/log

Step 1: Enable the System Log

1. On the Admin menu, select System > Configuration. In the panel on the left under
Advanced, select Developer.

2. Click to expand the Log Settingssection, and do the following:

Log SettingsLog Settings

a. To generate a system log file, set Enabled to “Yes.”

b. In the System Log File Name field, enter the name of the log file. The default value is:
system.log.

c. In the Exceptions Log File Name field, enter the name of the exception log. The
default value is: exception.log.

3. When complete, click the Save Config button.

Step 2: Configure the log:

1. Continuing in the Advanced section of the configuration, select System.

2. Click to expand the Log section, and do the following:
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Log

3. Set Enable Log to one of the following:

Yes The system log is enabled.

No The system log is not enabled. When disabled, the following features
become unavailable for guests or customers who are not logged in to
their accounts:

Recently Viewed Products

Compare Products

Customers Segments

Visitors Only The system log is enabled only when visitors and customers who are
not logged in to their accounts are shopping.

4. In the Save Log, Days field, enter the number of days that the system log is retained.

5. To periodically clean the system log, set Enable Log Cleaning to “Yes.” Then, do the
following:

a. To set the Start Time, select the hour, minute, and second that the system log
cleaning should begin.

b. Set Frequency to one of the following:

l Daily

l Weekly

l Monthly

6. To send email notification of the log cleaning with a list of all the warnings, do the
following:

a. In the Error Email Recipient field, enter the email address of the person who is to be
notified when the system log is cleaned. For multiple recipients, separate each address
with a comma.

b. Set Error Email Sender to the store contact that appears as the sender of the message.
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c. Set Error Email Template to the template that is used for the log cleanup notification.
The default template is: Log cleanup Warnings.

7. When complete, click the Save Config button.
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Server Backups & Rollback
Magento Enterprise Edition gives you the ability to back up different parts of the system—
such as the database, file system, or both—and to rollback automatically. Files are
compressed using the .gz and .tgz formats.

Topics covered in this section include:

l Creating a Backup

l Rolling Back Changes

Best Practices

Restrict Access to Backup Tools

Access to the Backups and Rollback management tool can be restricted by configuring user
permissions for backup and rollback resources. To restrict access, leave the corresponding
checkbox unselected. If you need to grant access to the rollback resources, you must grant
access to backup resources as well.

Backup Before Installing Extensions and Updates

Always perform a backup before installing an extension or updating Magento. Magento
Connect Manager (MCM) includes a backup option that you can use before installing an
extension or upgrading to a new release.
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Creating a Backup
Database backup files are compressed using the .gz format. For the system backups and
database and media backups, the .tgz format is used. Backup files are stored in the
var/backups directory in your Magento file system. The files that are stored in the
/var/cache, /var/log, /var/session and /var/report folders are excluded from the backup.

Create a Backup

To create a backup:

1. On the Admin menu, select System > Tools > Backups.

2. Click one of the following buttons, depending on the backup type you need to create:

System Backup Creates a complete backup of the database and the file system. On
the next step you will have the possibility to choose whether to
include the media folder to the backup.

Database and
Media Backup

Creates a backup of the database and the media folder.

Database Backup Creates a backup of the database.

3. To put the store into maintenance mode during the backup, select the checkbox. After the
backup is created, maintenance mode is turned off automatically.

4. If you are creating a system backup, select the Include Media folder to System Backup
checkbox if you want to include the media folder. When prompted, confirm the action.

Records of all created backups are listed on the Backups page. Deleting a record deletes the
archive file as well.
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To backup from Magento Connect Manager

1. On the Admin menu, select System > Magento Connect > Magento Connect Manager.

2. Select the Create Backup checkbox and select the backup type.

3. Proceed with an extension installation or Magento update. The backup is created
automatically and available at System > Tools > Backups.

Rolling Back Changes

Important!Use the Rollback with caution. Customers who are in the process of checking out
when you start the rollback may not be able to complete the process.

To roll back the whole system or the database:

1. On the Admin menu, select System > Tools > Backups.

2. On the Backups page, find the backup you want. Then in the Action column, click the
Rollback link.

All changes made since the backup was created are lost after the rollback.

3. Confirm the rollback. When prompted, enter your Admin Password. Then, choose whether
you want to put your store into the maintenance mode during the roll back. When restoring
file system or database and media files you can choose to use the FTP connection.

After the rollback, you are redirected to the Admin login page.

4. Refresh all cache types and rebuild required indexes.
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SOLUTION SERIES:

Installing Magento Patches
Magento recently launched several patches to correct vulnerabilities in the system. It is
recommended that you upgrade your store to the latest version of Magento, and install any
security-related patches as soon as they become available.

Make sure to stop by ourMagento Security Center, and sign up for the Security Alert Registry
to receive direct notification from our security team of any emerging issues and solutions.

Because of the variation in hosting environments and access to the server, there is no “one
size fits all” way to install a patch. This article describes three methods to install a patch,
and also how to revert a patch.

l Use SSH

l Run a Script

l Upload Pre-Patched Files

l Revert an Installed Patch

If your hosting provider doesn’t provide SSH access to the server, try one of the other
methods. Although the focus of this article is on security patches, the same methods can be
used to install any Magento patch.

Step 1: Back Up Your Magento Installation

Always back up your Magento installation before installing a patch. To learn more, see: Creating
a Backup

Step 2: Download the Patch

Magento Enterprise users can download patches from the dashboard of their Magento
account.

Step 3: Disable the Compiler

If your store is compiled, make sure to disable compilation before installing a patch. After
installing a patch, test the store thoroughly. Then, run the compiler again. Your store must
be recompiled for the patch to take effect.
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Step 4: Install the Patch

Method 1: Use SSH

Secure Shell (SSH) is the recommended way to install a patch. If you don’t know how to
set up SSH, contact your hosting provider. For detailed instructions, see: Installing
Patches with SSH.

1. Upload the patch files to the root of your [magento] installation folder.

2. If the store is compiled, make sure the compiler is disabled.

3. In the SSH console, run the following commands according to the patch extension:

sh patch_file_name.sh

.sh extension

patch --p0<patch_file_name.patch

.patch extension

4. Use either of the following methods to verify that the patch was installed:

l Download or view the file: app/etc/applied.patches.list.

applied.patches.list

l From the command line, run the patch file with the --list argument for a report of all
patch installations.

--list argument

Method 2: Run a Script

The following example shows how to install the SUPEE_5344.sh patch. Make sure to
replace the patch name in the example with the name of the patch file to be installed.

1. Upload the patch files to the root of your [magento] installation folder.

2. If the store is compiled, make sure the compiler is disabled.
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3. From your desktop, do the following:

a. Use a text editor to create a file named patch.php that contains the following script.

<?php

print("<PRE>");

passthru("/bin/bash PATCH_SUPEE-5344.sh");

print("</PRE>");

echo "Done";

?>

b. Upload the patch.php file to the root of your [magento] installation folder.

4. Run the script from your browser.

http://www.[yourstore.com]/patch.php

Then, look for the following message:

Checking if patch can be applied/reverted successfully...
Patch was applied/reverted successfully.
Done

5. After the patch is successfully installed, delete the patch.php file from your server.

If you receive the following error, either ask your hosting provider to install the missing
tools, or try one of the other methods.

“Error! Some required system tools, that are utilized in this sh script, are not installed; Tool
(s) “patch” is (are) missed, please install it(them).

6. Refresh your cache from the Magento Admin, Don’t forget to refresh your OPcode or APC
cache as well.

7. If your store is compiled, rerun the compiler.

Method 3: Upload Pre-Patched Files

1. Download your Magento installation to your local machine.

2. Apply the patch locally.

3. Upload the updated files to your server.
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Reverting an Installed Patch

Occasionally it is necessary to uninstall a patch. The command to revert a patch is
essentially the same as the command that is used to install a patch, but with the addition
of the -R flag.

1. Before you begin, make sure that you have appropriate permissions to the Magento
installation directory on the server. If the directory is owned by a web server user such as
apache or root, change to the appropriate user to ensure that you have the necessary
permissions. For example:

su - apache

Then when prompted, enter the password.

2. Change to your magento installation folder.

3. On the command line, enter the following command to revert the patch:

sh patch_file_name.sh -R
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Installing Patches with SSH
Whenever a patch is released to fix an issue in the code, a notice is sent directly to your
Admin Inbox. If the update is security related, the incoming message is color-coded red,
and marked as a “Critical Update.”

Make sure to stop by ourMagento Security Center, and sign up for the Security Alert Registry
to receive direct notification from our security team of any emerging issues and solutions.

The following instructions explain how to download and install a patch, starting with a
notice that appears in your Admin Inbox. The example takes place on a Windows system,
and uses the WinSCP utility to upload patch files to the server, and Putty to access the
server from the command line. You can download both utilities at no charge. If you are a
Mac user, you can access the command line with Terminal.

If this is the first time you have installed a patch, we recommend that you complete the
optional steps to create a backup copy of your store and install a patch as a test run. If you
have experience installing patches, you can take the fast track and skip the optional steps.
For advanced instructions, see the following articles in the Magento developer
documentation: 

How to Apply and Revert Magento Patches

Recommended File System Ownership and Privileges

Before you begin...
To install a patch, you must have a user name and password to access the server. In
addition to your own login credentials, you might also need the apache password. If you
don’t have these credentials, contact the person who set up your server.

Incoming Message of Critical Importance
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Process Overview:
Step 1:   Download the Patch
Step 2:   Set the Necessary Permissions
Step 3:   Create a Backup of theMagento Folder (Optional)
Step 4:   Upload the Patch
Step 5:   Install the Patch on the Backup (Optional)
Step 6:   Install the Patch to Your Store
Step 7:   A Little Housekeeping (Optional)
Step 8:   Look for Signs of Unauthorized Access
Step 9:   Clear theMagento Cache
Step 10: Recompile the Store (Only if compiled)
Step 11: Restart the Server

Step 1: Download the Patch

1. When you receive the message in your Inbox, click the Read details link to open the
account login page. Then, log in to your account.

2. In the panel on the left, select Downloads. Click to expand the Magento Enterprise
Edition section. Then, click Support Patches.

Your Magento Account

3. In the list, find the patch that you want to install. Then, click to expand the section.

https://www.magentocommerce.com/products/customer/account/login
http://merch.docs.magento.com/ee/user_guide/Magento_Enterprise_Edition_User_Guide.html#magento/magento-account.html
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Magento Enterprise Edition Patches

4. Find the patch for the specific version of Magento Enterprise that’s installed on your
server, and click the Download button. If you don’t know which version of Magento
Enterprise is installed on your server, you can find it in the footer of the Admin.

Magento Version in Footer

a. Click the Download button. Then, look for the downloaded file in the lower-left corner
of your browser.

Show Downloads Folder

b. Click the down arrow next to the downloaded file name to display the menu. Then,
select Show in folder. The patch is saved to the Download folder of your desktop
computer.

Downloaded Patch Files
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Step 2: Set the Necessary Permissions

For a live store, permissions are locked down to prevent unauthorized access. However, you
must change the permissions of the contents of the Magento installation folder before you
can install the patch. In the following instructions, Putty is used to access the command
line and change the permissions.

1. Click the Start button in the lower-left corner of your desktop, and launch Putty. When
prompted, enter the Host Name or IP Address of your store, and click the Open button.

2. Servers have different directory structures, and the path to your Magento installation folder
is most likely different from the one shown in the examples. Depending on your server, the
path to your Magento installation folder might be one of the following:

SERVER PATH

Ubuntu /var/www/magento

CentOS /var/www/html/magento

From the command line, use the Change Directory command to navigate to your Magento
installation folder. In this example, Magento is installed on a CentOS server, and the
Magento installation folder is located three levels below the html folder.

cd /var/www/html/stores/ee/magento

3. List the directory to check the permission status of the magento folder. To install a patch,
you must temporarily change the folder permissions. After the patch is installed, you can
restore the appropriate permissions to your live store.

ls -l

The second column shows the current permission settings for the contents of the magento
folder. It includes a combination of read only, read/write, and execute permissions,
depending on the type of folder or file. Take note of the owner and group in the next two
columns. You might not need this information, but it’s good to know. In this example,
each folder and file is owned by the apache user and belongs to the root group.
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Recommended Permissions for a Live Store

4. To install a patch, you must change the permissions to allow the necessary files to be
copied and overwritten, and to make it possible for the script to execute. Enter the
following commands to change the permissions of the directories and files in the folder.
Then, list the directory.

To save time, copy each command from the example, and press the mouse button to paste it
into the command line.

find . -type d -exec chmod 700 {} \;

find . -type f -exec chmod 600 {} \;

ls -l

Open Up Permissions

If your Magento installation is on a shared virtual server, you might need to begin each
command as a sudo super administrator:

sudo find . -type d -exec chmod 700 {} \;

sudo find . -type f -exec chmod 600 {} \;

sudo ls -l
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The first column in the directory listing shows the updated permission settings. After the
patch is installed, you will restore the recommended permissions to your store.

Updated Permissions

Step 3: Create a Backup of the Magento Folder (Optional)

1. Use the Change Directory command, followed by two dots, to move up one level in the
directory tree. Then, list the directory so you can see the magento folder.

cd ..

ls -l

2. Enter the following command to create a new folder called backup.

mkdir backup

ls -l

a. If you get a “Permission denied” message, add sudo to the beginning of the Make
Directory command. Then, list the directory to see the folder that you created.

sudo mkdir backup

sudo ls -l

b. The backup folder must have the same owner and group as the magento folder. If
not, use the Change Owner command to change the ownership of the backup folder
and its contents.
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In this command, the backup folder is assigned to the apache user and root group,
and followed by a single dot. (Don’t forget to use sudo if you need super administrator
access.)

chown -hR apache:root backup .

ls -l

c. Enter the “Who am I” command to make sure that you are logged in as the correct
owner.

whoami

d. If you are not logged in as the apache user, enter the following command. When
prompted, enter the password for the apache user account.

su - apache

Notice that the prompt has changed. You are now in the bash folder of the apache
user. While you’re logged in as the apache user, you won’t need to use sudo for super
administrator access.

3. Use the Change Directory command to return to the location of your magento and backup
folders. List the directory to see where you are. Then, check to see who you are.

cd /var/www/html/stores/ee

ls -l

whoami

Backup Folder with Correct Owner and Group

4. Copy the contents of the magento folder to the backup folder.

cp -r magento/* backup
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5. Wait for the process to complete and for the system prompt to return. Then, take a look at
the contents of the backup folder to make sure the files were copied.

cd backup

ls -l

cd ..

6. Because you’ll be working with the backup folder for awhile, it’s a good idea to restore the
original permissions to your magento folder before continuing.

Enter the following commands to restore the recommended permissions to the magento
folder. Then, list the directory to verify that the permissions are restored.

To save time, copy each command from the example, and press the mouse button to paste it
into the command line.

ls -l

cd magento

find . -type d -exec chmod 500 {} \;

find . -type f -exec chmod 400 {} \;

find var/ -type f -exec chmod 600 {} \;

find media/ -type f -exec chmod 600 {} \;

find var/ -type d -exec chmod 700 {} \;

find media/ -type d -exec chmod 700 {} \;

ls -l

Lock Down Permissions
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Locked Down Permissions

Step 4: Upload the Patch

1. To avoid permission problems when you upload the patch from your desktop, create a
folder for the patch that has no restrictive permissions. From Putty, navigate back to the
level of the magento and backup folders. Then, make a new folder called patch, and
change the permissions of the folder to 777.

cd ..

ls -l

mkdir patch

chmod 777 patch

ls -l

You now have three folders with very different permissions. The patch folder is wide open
with read, write and execute permissions. For this limited purpose, it’s OK.

Folders with Different Permissions

2. Return to your desktop, and launch WinSCP, or a similar tool. Then, log in to the server.
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3. In the right pane, navigate on the server to the location of the patch folder.

4. In the left pane, navigate to your Downloads folder, and find the patch file that you
downloaded. Drag it over to the right pane, and drop it on the patch folder.

Upload the Patch File

Step 5: Install the Patch to the Backup (Optional)

1. Return to Putty in the directory where the patch, backup, and magento folders are
located. Change directories into the patch folder, and list a directory to verify that the
patch file is there. Then, copy the patch file up one level. (Just remember—two dots up,
one dot down.)

cd patch

ls -l

cp PATCH_SUPEE-5344_EE_1.14.1.0_v1-2015-02-10-04-20-13.sh ..

cd ..

ls -l

Now the patch file is at the same level as the backup and magento folders, where it can be
easily accessed.

Patch File Uploaded and Ready to Go
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2. Because the temporary patch folder has served its purpose, enter the following command
to remove it from the server:

rm -rf patch

ls -l

3. Copy the patch file to the backup folder. Then, change directories to the backup folder,
and list the directory. You should see the patch file in the directory.

cp PATCH_SUPEE-5344_EE_1.14.1.0_v1-2015-02-10-04-20-13.sh backup

cd backup

ls -l

4. To install the patch, use the appropriate syntax for the type of patch, and substitute the
file name of the patch to be installed. There are two command formats, depending on the
patch file name extension. To avoid typos, copy the patch file name from Putty, and paste
it into Notepad. Then, add the required command syntax, paste it into the command line,
and press Enter.

EXTENSION COMMAND SYNTAX

.sh sh [patch_filename.sh]

.patch patch –p0 < [patch_filename.patch]

sh PATCH_SUPEE-5344_EE_1.14.1.0_v1-2015-02-10-04-20-13.sh

The following message appears if the installation succeeds:

Patch was applied/reverted successfully.

If the patch is already installed on your computer, an error message appears. You don’t
need to install it again.

So that’s really all there is to it. It might seem rather anticlimactic after so much
preparation, but it’s important to understand the process before you apply the patch to
your store.
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5. The next step is to change directories to the magento folder, and reset the permissions so
the patch can be copied and installed to your live store. Then, you will copy the patch file
to the magento folder.

cd ..

ls -l

cd magento

find . -type d -exec chmod 700 {} \;

find . -type f -exec chmod 600 {} \;

cd ..

cp PATCH_SUPEE-5344_EE_1.14.1.0_v1-2015-02-10-04-20-13.sh magento

cd magento

ls -l

Step 6: Install the Patch to Your Store

1. From your magento folder, enter the appropriate command to install the patch, and press
Enter.

EXTENSION COMMAND SYNTAX

.sh sh [patch_filename.sh]

.patch patch –p0 < [patch_filename.patch]

To avoid typos, copy the name of the patch file from your Downloads folder and paste it into
Notepad. Complete the required command syntax, and copy it to the clipboard. Then, press the
mouse button to paste it into the command line.

sh PATCH_SUPEE-5344_EE_1.14.1.0_v1-2015-02-10-04-20-13.sh

2. When the process is complete, remove the patch file from the magento folder.

rm PATCH_SUPEE-5344_EE_1.14.1.0_v1-2015-02-10-04-20-13.sh
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3. Enter the following commands to lock down permissions to the magento folder.

find . -type d -exec chmod 500 {} \;

find . -type f -exec chmod 400 {} \;

find var/ -type f -exec chmod 600 {} \;

find media/ -type f -exec chmod 600 {} \;

find var/ -type d -exec chmod 700 {} \;

find media/ -type d -exec chmod 700 {} \;

ls -l

Lock Down Permissions

Step 7: A Little Housekeeping (Optional)

Enter the following commands to remove the backup folder and patch file from your
server.

cd ..

ls -l

rm -rf backup

rm PATCH_SUPEE-5344_EE_1.14.1.0_v1-2015-02-10-04-20-13.sh

ls -l

Step 8: Look for Signs of Unauthorized Access (For security-related
issues)

1. Log in to the Admin of your store. Then on the Admin menu, select System > Users and
do the following:

a. Verify that there are no unauthorized user accounts in the list.

b. If you find an unknown user account in the list, click to open the account. Then, click
the Delete User button.

2. On the Admin menu, select System > Admin Actions Log. Then, do the following:

a. Check the IP Address column for anything unfamiliar. To see the full URL, mouse
over the address.

b. Check the Username column for any unfamiliar users.

c. To find specific types of activities, set the filter at the top of the Action Group column
to the type of activity you want to examine.
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d. To see the full entry for any activity, click the View link at the end of the row. Then,
click the Back button to return to the list.

e. To export the log to a CSV file, click the Export button.

Admin Actions Log

To learn about more signs of unauthorized access, see: Critical Security Advisory. If you
suspect that your site is compromised, contact the security department of your hosting
company and request an audit.

Step 9: Clear the Magento Cache

1. On the Admin menu, select System > Cache Management.

2. Click the Flush Cache Storage button.

http://merch.docs.magento.com/ee/user_guide/Magento_Enterprise_Edition_User_Guide.html#system-operations/admin-actions-log.html
http://magento.com/security-patch
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Cache Storage Management

Step 10: Recompile the Store (Only if compiled)

If your store is compiled, you must recompile to incorporate the patch. If your store isn’t
compiled, you can skip this step.

1. On the Admin menu, select System > Tools > Compilation.

2. Click the Run Compilation Process button.
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Step 11: Gracefully Restart the Server

The final step is to restart the server to flush any remaining caches, such as the APC
and/or Zend OpCache. The following steps show how to gracefully restart the server
without disrupting pages from being served, or causing loss of data.

1. If your server has a control panel such as cPanel, look for the option to gracefully reboot
the server. On cPanel, select Home > System Reboot > Graceful Server Reboot.

a. The syntax to restart the server from the command line varies by operating system. To
find the version that is running on your server, enter the following:

cat /etc/issue

apachectl -k graceful

CentOS / Fedora / Redhat

apache2ctl graceful

Debian / Ubuntu

2. To end the session, close both the Putty and WinSCP windows.

If you have more than one server, make sure to install the patch on all Magento servers.

https://documentation.cpanel.net/display/ALD/System+Reboot#SystemReboot-GracefulReboot
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Compilation
The compiler is disabled by default. The first time you run the compiler, the status changes
to “Enabled.” A summary of the compilation state appears at the top, and includes the
status of the compiler and state of the compilation, the number of files compiled, and the
number of compiled scopes.

To run the compiler:

1. On the Admin menu, select System > Tools > Compilation.

2. Click the Run Compilation Process button.

To disable the compiler:
Click the Disable button.

Compilation Complete
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Cron
Magento performs some operations on schedule by periodically running a script. You can
control the execution and scheduling of Magento cron jobs from the Admin of your store.
Store operations that run according to a cron schedule include:

l Email (Transactional and any other email sent from the store.)

l Catalog Price Rules

l Newsletters

l Google Sitemap Generation

l Customer Alerts and Notifications

l Currency Rate Updates

l Log Cleanup

Make sure that the secure and unsecure base URLs for the store are set correctly, so the
URLs that are generated during cron operations are correct. To learn more, see: Setting Up
Cron Jobs.

To configure cron:

1. On the Admin menu, select System > Configuration. Then in the panel on the left under
Advanced, select System.

2. Click to expand the Cron section. Then enter the number of minutes for each of the
following:

Cron (Scheduled Tasks)

l Generate Schedules Every

l Schedule Ahead for

l Missed if not Run Within

l History Cleanup Every

l Success History Lifetime

l Failure History Lifetime

3. When complete, click the Save Config button.

http://devdocs.magento.com/guides/m1x/install/installing_install.html#install-cron
http://devdocs.magento.com/guides/m1x/install/installing_install.html#install-cron
http://merch.docs.magento.com/ee/user_guide/Magento_Enterprise_Edition_User_Guide.html#configuration/advanced/system.html%23Cron_Scheduled_Tasks
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Database Repair Tool
The Database Repair tool compares a corrupt database with a target database, and updates
the target so it has the same structure as the corrupt database. During the process,
Database Repair does the following:

l Adds missing tables, or repairs them so they have the same engine type and charset

l Adds missing fields or repairs them

l Removes inconsistent data from tables with broken foreign key references

l Adds missing foreign keys and indexes

A typical use case for this tool is to fix the database of an existing Magento installation
that has some of the errors mentioned above.

Database Repair Tool

Important! Do not use DBRepair on a production site without testing it first in a development
environment. Always back up the original database before using DBRepair.

Step 1: Restrict Access to Website

It is highly recommended that you restrict access to your website while repairing the
database. The following example restricts your Magento instance to your IP address
exclusively. Other visitors, including search spiders, will get the HTTP “503 Service
Unavailable” error.
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Step 2: Create a Rewrite Rule

1. Create a file called 503.php in your Magento installation root that contains the following
code:

<?php

header('HTTP/1.1 503 Service Unavailable');

header('Content-Type: text/plain; charset=UTF-8');

echo "503 Service Unavailable";

2. In .htaccess or in Apache server configuration, add the following rewrite rule.

If running in a cluster environment, uncomment the FileETag line. To learn more, see:
Configure ETags.

Replace the IP address xxx\.x\.x\.x (xxx.x.x.x) with your own IP address. (Be careful to
preserve the backslash and dot between the numbers.

#FileETag none

RewriteEngine On

RewriteCond %(REMOTE_ADDR) !^xxx\.x\.x\.x$

RewriteRule !503.php /503.php L

3. Save the .htaccess file or reload the Apache configuration. Your site will be down until
you restore the original state.

Step 3. Install the Database Repair Tool

1. To download the archived Magento Database Repair tool, do the following:

a. Log in to your Magento account. Then in the panel on the left, select Downloads.

b. Click to expand the Magento Enterprise Edition section. Then, click Extensions &
Tools.

c. Find the Database Repair Tool in the list, and click the Download button.

https://developer.yahoo.com/performance/rules.html#etags


CHAPTER 78:  System Tools Database Repair Tool

Database Repair Tool Download

2. To upload the file, do either of the following:

l Upload the archived file to your server, and extract it to any folder.

l Extract the archive. Then, upload the file, Repairdb.php to any folder on your server.

Step 4: Back Up and Clone Your Database

1. Back up your existing database that has the problem, so it can be restored in the event of a
problem. We’ll call it “database1.”

2. Clone “database1” as the new “database2” on the same server.

3. Create a new empty database, “database3.”

4. Do one of the following:

l Copy the entire Magento folder (without the cache and sessions) to a new location, and
install “database3.” Then, update the local.xml file with the database credentials.

l Since access to the site is restricted, you can update the database credentials to
“database3” for the current Magento instance. Then, clean the cache and launch
Magento. The new database will be installed automatically.

You now have “database2,” which is a clone of your original database, and a Magento
installation with the empty “database3.”

Step 5: Run Database Repair

1. Enter the following in the address bar of your browser to launch the Database Repair tool:

http://[your-domain]/[path-to-folder]/Repairdb.php
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2. Under Corrupted Database Connection, complete the following information for “database2:”
This information is the same as what is entered during the Configuration step of the
Magento Setup.

a. In the Host field, enter the server's fully qualified host name or IP address. If your
database server is on the same host as your web server, enter “localhost.”

b. Enter the following credentials for the MySQL database that has the problem:

l Database Name

l User Name

l User Password

c. If there are multiple instances of Magento that share the same database, enter the
Table Prefix.

3. Under Reference Database Connection, enter the database credentials for the empty
“database3.”

If using a Table Prefix, make sure that it is the same as the the prefix used for Database1.

4. Click Continue to diagnose the database and display the results.

Step 6: Examine the Results

Examine the results to see the changes that were made. If nothing was changed, there is no
need to fix the database.

Minor Changes
l If only the table charset changed, there is usually nothing to do—especially if the table
contains no text data.

Major Issues
l If the table engine changed from MyIsam to InnoDb, you will need the help of a
developer to investigate and resolve the problem.

l If a missing foreign key, field, or table was added, you will need the help of a developer
to investigate and resolve the problem.

Step 7: Perform the Repair

If you are satisfied with database repair report and need to fix your live database, you can
either switch your installation to “database2” (because it was repaired), or perform the
repair directly on the live database.
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Step 8: A Little Housekeeping

1. Remove the Database Repair file, Repairdb.php from your server.

2. Restore access to your website.

Support Tools
The Support Tools are designed to identify known issues in your system. They can be used
as a resource during the development and optimization processes, and as a diagnostic tool
to help our support team more quickly identify and resolve issues.

The topics included in this section are:

l System Backups

l System Reports

System Backups
The Manage System Backups page lists all the available system backups. The backups can
be filtered by status and date. The backup includes complete code and database dumps.

Generating a System Backup

To generate a system backup:

1. On the Admin menu, select System > Tools > Support > System Backups.

2. Click the New Backup button.

Backups take some time to process. While the backup is processing, it will appear in the
list with an “Incomplete” status.
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System Reports
The system reporting tool gives you the ability take periodic full, or partial, snapshots of
the system, and save them for future reference. You can compare performance settings
before and after code development cycles, or changes to server settings. The system
reporting tool can dramatically reduce the time spent preparing and submitting the
information required by Support to begin an investigation.

From the Manage System Reports page, you can view and download existing reports, delete
reports, and create new reports.

Manage System Reports

To access system reports:

1. On the Admin menu, select Tools > Support > System Reports.

2. To view a report, click the View link at the end of the row.

3. To download a report, click the Download link at the end of the row.

4. To create a new report, click the New Report button. Then, do the following:

a. In the list, select each report type that you want to include.

By default, all reports are selected.
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Generate System Report

b. Click the Create button to generate the report.

It might take a few minutes for the report to generate, depending on the report types
selected. When the report is ready, it appears at the top of the list with a timestamp
and description of its contents.

New System Report
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REPORT TYPE INFORMATION INCLUDED

General Magento Version
Data Count
Cache Status
Index Status
Compiler Status

Data Corrupted Categories Data
Duplicate Categories By URL Key
Duplicate Products By URL Key
Duplicate Products By SKU
Duplicate Orders By Increment ID
Duplicate Users By Email

Environment Environment Information
MySQL Status

Modules CustomModules List
DisabledModules List
All Modules List
CoreModules List
EnterpriseModules List

Configuration Configuration
Data from app/etc/enterprise.xml
Data from app/etc/local.xml
Data from app/etc/config.xml
ShippingMethods
Payment Methods
Payments Functionality Matrix

Rewrites Active Class Rewrites
Class Rewrite Conflicts
File Rewrites
Controller Rewrites
Router Rewrites

Files Modified Core Files
Applied Solutions List

System Reports
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REPORT TYPE INFORMATION INCLUDED

Patch Files List
Missing Core Files
New Files
Files Permissions

DB Tables Modified Core Tables
Missing Core Tables
New Tables
Missing DB Routines List
New DB Routines List
Missing DB Triggers List
New DB Triggers List
DB Tables Status
DB MyISAM Tables Status
DB Routines List
DB Triggers List

Logs Log Files
Top SystemMessages
Today's Top SystemMessages
Top ExceptionMessages
Today's Top ExceptionMessages

Attributes User Defined Eav Attributes
New Eav Attributes
Entity Types
All Eav Attributes
Category Eav Attributes
Product Eav Attributes
Customer Eav Attributes
Customer Address Eav Attribute
RMA Item Eav Attributes

Events Custom Global Events
Custom Admin Events
All Global Events
All Admin Events

System Reports (cont.)
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REPORT TYPE INFORMATION INCLUDED

Core Global Events
Core Admin Events
Enterprise Global Events
Enterprise Admin Events

Cron Cron Schedules by status code
Cron Schedules by job code
Errors in Cron Schedules Queue
Custom Global Cron Jobs
Custom Configurable Cron Jobs
Cron Schedules List
All Global Cron Jobs
All Configurable Cron Jobs
Core Global Cron Jobs
Core Configurable Cron Jobs
Enterprise Global Cron Jobs
Enterprise Configurable Cron Jobs

Design Design Themes Config
Adminhtml Themes List
Frontend Themes List
Install Themes List
Adminhtml Skins List
Frontend Skins List
Install Skins List

Stores Websites Tree
Websites List
Stores List
Store Views List

System Reports (cont.)
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APPENDIX A:

Release Notes
Magento Enterprise Edition 1.14.2.1
We are pleased to bring to you Magento Enterprise Edition, 1.14.2.1, which includes
several previously released security patches, performance updates, and new mobile app
development resources.

Important!Use Magento Enterprise 1.14.0 or later for all new installations and upgrades to
ensure that you have the latest fixes, features, and security updates.

Improvements and Fixes
l Addressed performance issue related to Google Tag Manager.

l Addressed performance issues related to logging module.

l Fixed an issue that caused content from a block saved in the HTML output cache to
be loaded into a CMS static block.

Magento Mobile SDK for Android
The Magento Mobile Software Development Kit (SDK) for Android includes a library of
Android resources that makes it faster and easier to create full-featured Magento mobile
applications. The SDK is available only to Enterprise Edition customers, and includes a
sample application that can be customized by merchants to accelerate development.
With this release, Enterprise Edition merchants can more easily create both iOS and
Android applications. The Mobile Software Development Kit is available for download
from the Partner Portal and from the dashboard of your Magento account.

SUPEE-6237 USPS API Patch
On May 31, 2015, USPS made changes to their API that impact international shipping
rate requests to and from Canada. As a result, some Canadian shipping rates are
returned incorrectly, and customers are unable to see all available shipping options.
The USPS API patch ensures that Canadian international shipping rates are returned
correctly, and that customers can see all available shipping options during checkout.
To learn more, see: USPS API Update – What You Need to Know by WebShopApps, a
Magento Partner.

http://enterprise.magento.com/
https://partners.magento.com/English?rdir=/files.aspx
http://www.webshopapps.com/blog/2015/06/usps-api-update-may-31st-2015-what-you-need-to-know/
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Security Patches

Stop by our newMagento Security Center, and sign up for the Security Alert Registry to
receive direct notification from our security team of any emerging issues and solutions.

SUPEE-6482 Patch Bundle
This patch bundle protects your Magento installation against several potential threats, one
of which is critical. The patch is a proactive, preventative measure, as there are no known
attacks at this time.

Cross-site Scripting Using Unvalidated Headers

PATCH DETAILS

Type: Cross-site Scripting/Cache Poisoning

CVSS Severity: 9.3 (Critical)

Known Attacks: None

Description: Unvalidated host header leaks into response and page. Because
the page can be cached, this leak poses a risk for all store
customers because any HTML or JavaScript code can be
injected. Such an exploit works only with specific server
configurations, and allows an attacker to intercept a session or
modify a page with fake credit card forms, etc.

Product(s) Affected: Magento EE prior to 1.14.2.1; All Magento CE prior to 1.9.2.1

Fixed In: EE 1.14.2.1 and CE 1.9.2.1

Reporter: Internal (ECG)

Autoloaded File Inclusion in Magento SOAP API

PATCH DETAILS

Type: Remote Code Execution (RCE)

CVSS Severity: 6.5 (Medium)

Known Attacks: None
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PATCH DETAILS

Description: Incorrect validation of an SOAP API request can cause code to
be autoloaded. With specific PHP versions or configuration
settings, the code can be loaded from a remote location. The
exploit requires the attacker to log in first with API credentials.

Product(s) Affected: Magento EE prior to 1.14.2.1; All Magento CE prior to 1.9.2.1

Fixed In: EE 1.14.2.1 and CE 1.9.2.1

Reporter: Egidio Danilo Romano

XSS in Gift Registry Search

PATCH DETAILS

Type: Cross-site Scripting (XSS)

CVSS Severity: 6.1 (Medium)

Known Attacks: None

Description: Cross-site scripting vulnerability through an unescaped search
parameter. The attack impacts registered users with the risk of
cookie theft and user impersonation.

Product(s) Affected: Magento EE prior to 1.14.2.1; All Magento CE prior to 1.9.2.1

Fixed In: EE 1.14.2.1 and CE 1.9.2.1

Reporter: Hannes Karlsson/Vaimo

SSRF Vulnerability in WSDL File

PATCH DETAILS

Type: Remote File Inclusion

CVSS Severity: 5.3 (Medium)

Known Attacks: None

Description: Incorrect encoding of API password canmake it possible for an
attacker to probe internal network resources and/or include
remote files.
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PATCH DETAILS

Product(s) Affected: Magento EE prior to 1.14.2.1; All Magento CE prior to 1.9.2.1

Fixed In: EE 1.14.2.1 and CE 1.9.2.1

Reporter: Matthew Barry

SUPEE-6285 Patch Bundle
This bundle provides protection against several types of security-related issues, including
information leaks, request forgeries, and cross-site scripting.

Customer Information Leak via RSS and Privilege Escalation

PATCH DETAILS

Type: Privilege Escalation / Insufficient Data Protection

CVSS Severity: 7.5 (high)

Known Attacks: None

Description: Improper check for authorized URL leads to customer
information leak (order information, order IDs, customer name).
The leaked information facilitates an attack on guest Order
Review, which exposes customer email, shipping and billing
address. In some areas, the same underlying issue can lead to
privilege escalation for Admin accounts.

Product(s) Affected: Magento EE prior to 1.14.2.1; Magento CE prior to 1.9.2.0

Fixed In: EE 1.14.2.1, CE 1.9.2.0

Reporter: Erik Wohllebe

Request Forgery in Magento Connect Leads to Code Execution

PATCH DETAILS

Type: Cross-site Request Forgery

CVSS Severity: 9.3 (Critical)

Known Attacks: None
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PATCH DETAILS

Description: Cross-site request forgery in Magento Connect Manager allows
an attacker to execute actions such as installing a remote
module that makes it possible to execute remote code. The
attack requires aMagento store administrator to be logged in to
Magento Connect Manager, and to click a link planted by the
attacker.

Product(s) Affected: Magento EE prior to 1.14.2.1; Magento CE prior to 1.9.2.0

Fixed In: EE 1.14.2.1, CE 1.9.2.0

Reporter: Nicolas Melendez

Cross-site Scripting in Wishlist

PATCH DETAILS

Type: Cross-site Scripting

CVSS Severity: 5.3 (Medium)

Known Attacks: None

Description: Makes it possible for an attacker to include an unescaped
customer namewhenWishlist messages are sent. By
manipulating the customer name, an attacker can use the store
to send spoofing or phishing emails.

Product(s) Affected: Magento EE prior to 1.14.2.1; Magento CE prior to 1.9.2.0

Fixed In: EE 1.14.2.1, CE 1.9.2.0

Reporter: Bastian Ike

Cross-site Scripting in Cart

PATCH DETAILS

Type: Cross-site Scripting (XSS)

CVSS Severity: 6.1 (Medium)

Known Attacks: None
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PATCH DETAILS

Description: The redirection link on an empty cart page uses non-validated
user input, whichmakes it possible to use URL parameters to
inject JavaScript code into the page.
Cookies and other information can be sent to the attacker, who
impersonates a customer.

Product(s) Affected: Magento EE prior to 1.14.2.1; Magento CE prior to 1.9.2.0

Fixed In: EE 1.14.2.1, CE 1.9.2.0

Reporter: Hannes Karlsson

Store Path Disclosure

PATCH DETAILS

Type: Information Leakage (Internal)

CVSS Severity: 5.3 (Medium)

Known Attacks: None

Description: Enables the attacker to directly access the URL of files that are
related toMagento Connect by producing an exception that
includes the server path. The exception is generated regardless
of the configuration settings that control the display of
exceptions.There is a low risk of attackers gaining a sufficient
understanding of the site structure to target an attack.

Product(s) Affected: Magento EE prior to 1.14.2.1; Magento CE prior to 1.9.2.0

Fixed In: EE 1.14.2.1, CE 1.9.2.0

Reporter: Ryan Satterfield

Permissions on Log Files too Broad

PATCH DETAILS

Type: Information Leakage (Internal)

CVSS Severity: 3.8 (Low)

Known Attacks: None
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PATCH DETAILS

Description: Log files are created with permission settings that are too broad,
that allows them to be read or altered by another user on the
same server. The risk of an internal information leak is low.

Product(s) Affected: Magento EE prior to 1.14.2.1; Magento CE prior to 1.9.2.0

Fixed In: EE 1.14.2.1, CE 1.9.2.0

Reporter: Ryan Satterfield

Cross-site Scripting in Admin

PATCH DETAILS

Type: Cross-site Scripting

CVSS Severity: 6.5 (Medium)

Known Attacks: None

Description: An attacker can inject JavaScript into the title of aWidget from
theMagento Admin. The code can be later executed when
another administrator opens theWidget page.
The risk requires the attacker to have administrator access to
the store. However, when executed, the attacker can take over
other administrator accounts.

Product(s) Affected: Magento EE prior to 1.14.2.1; Magento CE prior to 1.9.2.0

Fixed In: EE 1.14.2.1, CE 1.9.2.0

Reporter: Sasi Levi

Cross-site Scripting in Orders RSS

PATCH DETAILS

Type: Cross-site Scripting

CVSS Severity: 5.3 (Medium)

Known Attacks: None
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PATCH DETAILS

Description: Allows an attacker to include an unescaped customer name in
the New Orders RSS feed. By manipulating the customer name,
an attacker can inject incorrect or malicious data into the feed,
and expose the store to risk.

Product(s) Affected: Magento EE prior to 1.14.2.1; Magento CE prior to 1.9.2.0

Fixed In: EE 1.14.2.1, CE 1.9.2.0

Reporter: Bastian Ike

SUPEE-5994 Patch Bundle
This bundle includes protection against the following security-related issues:

Admin Path Disclosure

PATCH DETAILS

Type: Information Leakage (Internal)

CVSS Severity: 5.3 (Medium)

Known Attacks: None

Description: An attacker can force the Admin Login page to appear by directly
calling amodule, regardless of the URL.This exposes the Admin
URL on the page, andmakes it easier to initiate password
attacks.

Product(s) Affected: Magento EE prior to 1.14.2.1; Magento CE prior to 1.9.2.0

Fixed In: EE 1.14.2.1, CE 1.9.2.0

Reporter: Peter O'Callaghan

Customer Address Leak through Checkout

PATCH DETAILS

Type: Information Disclosure / Leakage (Confidential or Restricted)

CVSS Severity: 5.3 (Medium)

Known Attacks: None
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PATCH DETAILS

Description: Enables an attacker to obtain address information (name,
address, phone) from the address books of other store
customers.
During the checkout process, the attacker can gain access to an
arbitrary address book by entering a sequential ID. No payment
information is returned. The only requirement for the attacker is
to create an account in store, put any product into the cart, and
start the checkout process.
This attack can be fully automated, and a functional proof of
concept exists.

Product(s) Affected: Magento EE prior to 1.14.2.1; Magento CE prior to 1.9.2.0

Fixed In: EE 1.14.2.1, CE 1.9.2.0

Reporter: Erik Wohllebe

Customer Information Leak through Recurring Profile

PATCH DETAILS

Type: Information Disclosure / Leakage (Confidential or Restricted)

CVSS Severity: 5.3 (Medium)

Known Attacks: None

Description: Enables an attacker to obtain address (name, address, phone),
previous order (items, amounts) and payment method (payment
method, recurrence) information from the recurring payment
profiles of other customers.
The attacker creates an account with the store that has a
recurring profile. While viewing the recurring profile, the attacker
can request an arbitrary recurring profile using a sequential ID.
The information is then returned to the attacker.
This attack can be fully automated, and amanual proof of
concept exists.

Product(s) Affected: Magento EE prior to 1.14.2.1; Magento CE prior to 1.9.2.0

Fixed In: EE 1.14.2.1, CE 1.9.2.0

Reporter: Manuel Iglesias
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Local File Path Disclosure Using Media Cache

PATCH DETAILS

Type: Information Leakage (Internal)

CVSS Severity: 5.3 (Medium)

Known Attacks: None

Description: Attacker can use fictitious image URLs to generate exceptions
that expose internal server paths, regardless of settings.

Product(s) Affected: Magento EE prior to 1.14.2.1; Magento CE prior to 1.9.2.0

Fixed In: EE 1.14.2.1, CE 1.9.2.0

Reporter: OmarM

Cross-site Scripting (XSS) Using Magento Downloader

PATCH DETAILS

Type: Cross-site Scripting (XSS)

CVSS Severity: 8.2 (High)

Known Attacks: None

Description: Enables an attacker to execute JavaScript code within the
context of aMagento Connect Manager session. If the
administrator clicks amalicious link, the session can be stolen,
andmalicious extensions installed.

Product(s) Affected: Magento EE prior to 1.14.2.1; Magento CE prior to 1.9.2.0

Fixed In: EE 1.14.2.1, CE 1.9.2.0

Reporter: Robert Foggia / Trustwave

Spreadsheet Formula Injection

PATCH DETAILS

Type: Formula Injection

CVSS Severity: 6.1 (Medium)
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PATCH DETAILS

Known Attacks: None

Description: Attacker can provide input that executes a formula when
exported and opened in a spreadsheet such as Microsoft Excel.
The formula canmodify data, export personal data to another
site, or cause remote code execution. The spreadsheet usually
displays a warningmessage, which the user must dismiss for
the attack to succeed.

Product(s) Affected: Magento EE prior to 1.14.2.1; Magento CE prior to 1.9.2.0

Fixed In: EE 1.14.2.1, CE 1.9.2.0

Reporter: iSec Partners (external audit)

Cross-site Scripting Using Authorize.Net Direct Post Module

PATCH DETAILS

Type: Cross-Site Scripting (XSS)

CVSS Severity: 6.1 (Medium)

Known Attacks: None

Description: Enables an attacker to execute JavaScript in the context of a
customer session. If a customer clicks amalicious link, the
attacker can steal cookies and hijack the session, which can
expose personal information and compromise checkout.

Product(s) Affected: Magento EE prior to 1.14.2.1; Magento CE prior to 1.9.2.0

Fixed In: EE 1.14.2.1, CE 1.9.2.0

Reporter: Matthew Barry

Malicious Package Can Overwrite System Files

PATCH DETAILS

Type: Abuse of Functionality

CVSS Severity: 3.1 (Low)

Known Attacks: None

1225Magento Enterprise Edition User Guide, Version 1.14.2.1



APPENDIX A:  Release Notes

PATCH DETAILS

Description: Attacker can publish amalicious extension package. When the
package is installed by a customer, it can overwrite files on the
server. The attacker must first publish a package, and then
entice a customer to install it. The packagemight contain a
malicious load, as well.

Product(s) Affected: Magento EE prior to 1.14.2.1; Magento CE prior to 1.9.2.0

Fixed In: EE 1.14.2.1, CE 1.9.2.0

Reporter: iSec Partners (external audit)
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A

above the fold
The web page content that is immediately visible in the browser window; section of a
page that is displayed without the need to scroll.

Admin
The password-protected back office of your store where orders, catalog, content, and
configurations aremanaged.

alt text
The text that is displayed in place of an image when the user is unable to view the
image.

anchor text
The visible text that is anchored to another page or page section; the literal text of a
hyperlink.

API
Application Program Interface: A software interface that lets third-party applications
read and write to a system using programming language constructs or statements.

aspect ratio
The proportional relationship between the width and height of an image.

attribute
A characteristic or property of a product; anything that describes a product. Examples
of product attributes include color, size, weight, and price.

authorization
To give a service permission to perform certain actions or to access resources.

average inventory cost
Product price, less coupons or discounts, plus freight and applicable taxes. The
average is determined by adding the beginning cost of inventory eachmonth, plus the
ending cost of inventory for the last month of the period.



APPENDIX B:  Glossary

B

B2B
Business to Business: A type of business transaction between two business entities that
are not the final consumers of the goods or services.

B2C
Business to Consumer: Business transactions between a business entity and a consumer.

banner
Promotional graphics displayed either horizontally on the top of a web page or vertically on
the left or right margins. Website advertisements are often displayed as banners.

base currency
The primary form of currency used in store transactions.

base currency rate
The base currency rate is the default for your store.

batch processing
To perform a task or make a change tomultiple items all at once, without manual repetition.

bounce rate
The percentage of visitors to your site that leave without viewing any other pages.

brand
A unique identity that defines a particular product or group of products.

breadcrumb
A navigation aid that helps the user to keep track of their location within your store.

brick and mortar
A retail business with a permanent physical location, as opposed to being entirely virtual.

broken link
A hyperlink that fails to send the user to its intended web page.

C

callout
Sometimes used to describe an XML block of page layout code.

canonical URL
The canonical meta tag redirects search engines to the correct URL, when seemingly
duplicate content is encountered on the server.
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capture
The process of converting the authorized amount into a billable transaction. Transactions
cannot be captured until authorized, and authorizations cannot be captured until the goods
or services have been shipped.

cardholder
A person who opens a credit card account and is authorized tomake purchases.

cascading style sheet
Themarkup standard used to apply styles to HTML elements on the page.

category
A set of products that share particular characteristics or attributes.

CCV
Credit Card Verification code. (See CVV)

checkout process
The process of gathering the payment and shipping information that is necessary to
complete the purchase of items in the shopping cart. In the final step, the customer reviews
and places the order.

CMS
Content Management System: A software system that is used to create, edit, andmaintain
content on a website.

composite product
Any product type that offers customers a choice of options.

Content Delivery Network
A large distributed network of servers that specializes in the high performance delivery of
multi-media content.

content marketing
The art of promoting products or services by providing valuable information at no charge.

conversion
A marketing term that indicates a goal has been reached. If the goal is to sell a product,
conversion is reached when a visitor to your site becomes a buyer.

conversion rate
The percentage of visitors who are converted into buyers.

credit memo
A document issued by themerchant to a customer to write off an outstanding balance
because of overcharge, rebate, or return of goods.
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CSS
Cascading Style Sheets: A style sheet language that controls the appearance of HTML
documents; a way to control the appearance of text, graphics, lists, links, and all other
elements on a web page.

CSV
CommaSeparated Values: A type of file used to store data values which are separated
from each other by commas.

CVM
Card VerificationMethod: A way to verify the identity of the customer by confirming a 3-digit
or 4-digit credit card security code with the payment processor.

CVV
The Card Verification Value, also known as the Card Security Code, provides an additional
level of security for online transactions.

D

domain
The address of a website on the web; what the customer types in their browser address bar
to access the store.

domestic shipment
A shipment where the sender and recipient are in the same country, and no international
borders are crossed.

double opt-in
The process for subscribing email recipients by requiring them to take a secondary step to
confirm that they want to receive emails.

dynamic content
A web page that displays different content depending on the user request.

Dynamic Media URL
A link to an image that contains a relative reference to the file location in media storage.

E

EAV
Entity Attribute Value

evergreen content
Content with a long shelf life.
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F

FAQ
Frequently AskedQuestions.

favicon
Short for favorites icon; a 16x16 or 32x32 pixel icon associated with a website; is displayed
in the browser address bar and next to the site name in a bookmark list.

feed reader
Software that is used to read syndicated content from RSS feeds.

FOB
Freight On Board: A shipping term indicating who is responsible for paying transportation
charges.

frontend properties
Properties that determine the presentation and behavior of an attribute from the standpoint
of the customer in your store.

fulfillment
The process of managing customer shipments.

G

gateway
A transaction bridge between a customer and a payment processing service that is used to
transfer money between the customer and themerchant.

gross margin
The difference between the cost and price of a product.

H

handle
In programming, a name used to reference an object.

hierarchy
The orgnaization of websites, stores, and views in aMagento installation.

home page
The first home page a visitor sees when they access your website URL. Considered the
most important page on your website according to search engine indexing.

1231Magento Enterprise Edition User Guide, Version 1.14.2.1



APPENDIX B:  Glossary

HTML
HyperText Markup Language: A standard for tagging and structuring text, images, videos,
and other media on a web page.

I

international shipment
A shipment where the sender and recipient are in different countries, and international
borders are crossed.

invoice
A document that provides a detailed description of a purchase, including products
purchased, quantity, price, shipping cost, sales tax, and total.

J

JavaScript
A scripting language used with HTML to produce dynamic effects and interactions on web
pages.

JQuery
A popular JavaScript library that is often used to create dynamic and responsive effects.

K

keyword
A term or phrase used in a search to filter for content that is of significant importance to that
term or phrase.

L

LAMP
Linux / Apache / MySQL / PHP

landing page
A page on your site where a visitor arrives after clicking a link or advertisement.

layout
The visual and structural composition of a page.

layout update
A specific set of XML instructions that determines how the page is constructed.

link juice
The value and authority transferred from one web page to another via hyperlinks (or links).
Link juice affects a website’s page rank, a factor used to rank a search engine results page.
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liquid layout
A flexible approach to web design that specifies the size and position of elements as
percentages rather than as exact measurements in pixels.

load sequence
The order scripts are loaded intomemory. To work correctly, some scripts must be loaded
before others.

locale
A set of configurations that defines the user’s language, country, tax rate, and other
settings.

login
The process of signing into an online account.

M

markdown
The amount subtracted from the original price of a product.

markup
A percentage added to the cost of an item to determine the retail price.

media storage
A dedicated space on the content delivery network for your store's assets.

merchant account
An account with a bank or financial institution that makes it possible to accept credit card
transactions.

meta tags
Information in a web page that is not displayed on the page itself, but is used by search
engines to determine the page title, description, and page keywords.

N

navigation
The primary group of web page links that a customer uses to navigate around the website;
the navigation links to themost important categories or pages on an online store.

O

opt-in
The process by which a user consents to receiving emails from an online store.
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P

packing slip
A document that is usually included in a shipped package that describes the contents.
Packing slips do not include financial or account information.

path to purchase
The path a prospect follows that leads to a sale.

payment bridge
An application that helps merchants meet PCI- DSS requirements.

payment gateway
A service that charges your customers’ credit cards and sends the funds to your merchant
account, for deposit into your business bank account.

PCI
Payment Card Industry: Refers to debit and credit cards and their associated businesses.

privacy policy
A document that explains themerchant’s policies for handling customer information.

purchase order (PO)
A written sales contract between a buyer and seller that describes themerchandise or
service to be purchased from a vendor.

R

redirect
A method used to alert browsers and search engines that a page has beenmoved. 301
Redirect: Permanent change 302 Redirect: Temporary change

relative link
A hyperlink that includes only the address of the linked page that is relative to the linking
page, rather than the full URL.

return policy
A document that explains themerchant’s rules regarding the return of products by
customers.

robots.txt
A file placed on a website that tells search engine crawlers which pages not to index.

RSS feed
Really Simple Syndication: A technology that creates web content syndication and allows
web users to subscribe to product feeds, websites, and blogs.
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S

SaaS
Software as a Service: A software delivery model where the vendor provides the software
and hosting environment, and customers pay for the service by subscription or per use.

Sass/Compass
A CSS pre-compiler that provides organizable, reusable CSS.

security certificate
Information that is used by the SSL protocol to establish a secure connection.

SEO
Search Engine Optimization: The process of improving a website’s search engine rankings
in order to increase valued visitors.

SERP
Search Engine Results Page

settlement
Settlement occurs when the acquiring bank and the issuer exchange funds and the
proceeds are deposited into themerchant account.

shipping carrier
A company that transports packages. Common carriers include UPS, FedEx, DHL, and
USPS.

shopping cart
A grouping of products that the customer wishes to purchase at the end of their shopping
session.

sidebar
The right or left column of a two-column page layout.

sitemap
A page that provides search engines with an efficient, alternate route through your site.

SKU
Stock Keeping Unit: A number or code assigned to a product to identify the product,
options, price, andmanufacturer.

splash page
A promotional page with a product or advertisement; normally displayed before the home
page.
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SSL certificate
A validation and security mechanism that identifies themerchant and encrypts credit card
and other sensitive information.

static block
A fixed content block that can be displayed on various content pages in a store.

static content
Content that does not change frequently. See also dynamic content.

T

theme
A package that contains graphics and appearance information, and customizes the look
and feel of the store.

transactional email
A notification email sent to the customer when a transaction is processed.

transactional emails
An automated email message that is sent in response to a specific event or transaction.

U

URL
Uniform Resource Locator: The unique address of a page on the internet.

usability
Refers to the degree to which a product or service is easy to use by its customers.

V

Visual merchandising
A term used in retail to describe the art and science of floorplan development and themulti-
dimensional presentation of products.

W

widget
A prepared snippet of code that adds functionality and/or dynamic effects to your store.

WYSIWYG
What You See Is What YouGet: An editor that displays formatted text as it will appear in its
final published form.
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X

XML
Extensible Markup Language: A markup format derived from SGML that it used to format
information for publication and distribution.
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Editor Toolbar
Editing Tools

Editing Tools

Cut Copy

Paste Paste as Plain Text

Paste fromWord

Find Find and Replace

Undo Redo

Citation Abbreviation

Acronym Spellchecker (not
installed)
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Mark as Insertion Mark as Deletion

Styles and Fonts

Styles and Fonts

Styles Format

Font Family Font Size

Character Format

Character Format

Bold Italic

Underline Strikeout

Subscript Superscript
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Special Characters

Special Characters

Insert Symbol Insert Non-Breaking
Space

Insert Page Break

Color

Color

Select Text Color Select Background
Color

Paragraph Format

Paragraph Format

Left Justify Center

Right Justify Full Justify
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Outdent Indent

Blockquote

Coding Tools

Coding Tools

Remove Formatting CleanupMessy Code

Lists

Lists

Bulleted (Unordered)
List

Numbered (Ordered)
LIst

Rules

Rules

Insert Simple
Horizontal Rule

Insert Formatted
Horizontal Rule
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Links and Anchors

Links and Anchors

Insert/Edit Link Remove Link

Insert/Edit Anchor

Images and Media

Images and Media

Insert/Edit Image Insert Media

Tables

Tables

Insert/Modify Table Table Row Properties

Table Cell Properties
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Insert Row Above Insert Row Below

Remove Column Remove Row

Split Merged Table
Cells

Merge Table Cells

Layers

Layers

Insert New Layer Move Layer Forward

Move Layer Backward Toggle Absolute
Positioning

Variables, Attributes and Widgets

Variables, Attributes and Widgets

Insert Variable Insert/Edit Attributes

Insert Widget
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Workspace Preferences

Workspace Preferences

Toggle Fullscreen
Mode

Display Visual Control
Characters (On/Off)

Toggle Guidelines /
Invisible Elements

Set Typing Direction
Left-to-Right

Set Typing Direction
Right-to-Left

Help
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APPENDIX D:

Configuration Reference
This online reference has field descriptions for each section of the configuration. Drill
down through any section, and click a link to jump to the corresponding topic in the
user guide. Topics include:

l General

l Catalog

l Customers

l Sales

l Services

l Advanced

http://merch.docs.magento.com/ee/user_guide/Magento_Enterprise_Edition_User_Guide.html#configuration/general.html
http://merch.docs.magento.com/ee/user_guide/Magento_Enterprise_Edition_User_Guide.html#configuration/catalog.html
http://merch.docs.magento.com/ee/user_guide/Magento_Enterprise_Edition_User_Guide.html#configuration/customers.html
http://merch.docs.magento.com/ee/user_guide/Magento_Enterprise_Edition_User_Guide.html#configuration/sales.html
http://merch.docs.magento.com/ee/user_guide/Magento_Enterprise_Edition_User_Guide.html#configuration/services.html
http://merch.docs.magento.com/ee/user_guide/Magento_Enterprise_Edition_User_Guide.html#configuration/advanced.html
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1

1 Column Layout 648, 650

2

2 Columns

with Left Bar 648, 651

with Right Bar 648

3

3 Column Layout 649, 652

3D Secure Credit Card Validation 856,
882, 887-888

4

404 Page Not Found 571, 573

A

Abandoned carts 752

report 1084

About Us page 570

Access Level, page versions 586

Account

customer information 692

Magento 15

share 17

Actions

control 50, 54

Add

Banner 602

Exception, theme 678

New User 1091

Root Category 115

to Wishlist 443

Add to Category, Visual
Merchandiser 371

Additional Cache Management 362

Address

attributes 709

Book, customer 692

format 709

template 709

Address format 709

Address templates 709

Adjustment Fee 798

Admin 23, 41, 54

access 1087

account, unlock 1097

Actions Log 1172

CAPTCHA 1109

login 42

menu 47

Notifications 46

permissions 1087

role 1088

role, create 1089

role, custom 1090

security 1099, 1107

Startup Page 1078
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user 1088

user, create 1088

Admin URL, custom 81

Adobe Reader 768

Advanced Search 139, 287

Solr 295

Advocacy Tools 36

Allow

Adding to Cart 126

Browsing Category 126

cookies 752

Countries 61

Gift Message 271

Gift Receipt 459

HTML tags 140, 145

HTML Tags on Frontend 145

Printed Card 459

Allowed Currencies 1016

American Express 877

Analytics 26, 36

Anchor

category 115-116, 605

Android, email 1022

Antivirus software 84

Any, checkbox 55

AOV 30

Apache 10

API 37, 508, 1167

Core 1168

Key 1170

Append Complex Data 1047, 1060, 1063

Apple Mail 1022

Apply MAP, Smart Category 359-360

Approve product review 451

Archive 769

Admin actions 1173

As Low As, bundle product 171

Associated Product 158, 163

attribute

dropdown 203

swatch values 208

Attribute 129

address 709

advanced search 139

code 141

create 133

customer 704

delete 136

entities 1050

filterable 103

Google Shopping 508

group 138

information 135

input types 130

layered navigation 139

predefined 625

price 237

product 139

properties 133

quick search 139

set 129, 136, 160, 259

system 137

upload image 707

Attribute set

create 161

attributes

dropdown 204

Attributes, Smart Category 359
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Australia, PayPal solutions 852

Authorization reversals 886

Authorize.Net 866, 869, 871, 877

capture 869

CIM 881

Direct Post Method 878

payment bridge 861

refund 877

Auto Bill, recurring payment 265

Autogenerate

page cache 1143

Site Map 311

Automatic

redirect 325

refund 791

Automatic Sort, Visual Merchandiser 350, 352

Average order value 30

Average Orders 23

B

B2B Sites 489, 1114

Backend See also Admin

Backorders 239, 245

PayPal Express Checkout 842

Backup 1159

create 1164

delete 1179

during merge 1158

General Info 1159

permissions 1178

Backups, system 1207

Balance response 882-883, 886

Balance, customer account 699

Bank Transfer 808

banner 601

Banner

create 602

customer segments 428

Customer Segments 427

locations 603

price rule 607

rotator 604

Rotator 610

Base

currency 1018

image 195-196, 198

JavaScript URL 1148

media URL 1148

Base URL 78

Base URL Home page 573

Best Practices 309

Best Sellers 23

Bestsellers 1077

Beta website 1155

Bill Me Later, PayPal 843

Billing

agreement 692

agreement, PayPal Express Checkout 844

recurring payment 266-267

block

reference 597

product page 598

Block 595, 625

category 120, 122

create 596

ID, markup tag 632
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reference 605, 654-656

category 598

CMS pages 598

Blocks HTML Output, cache 1137

Blog, as Home Page 573

Blog, Magento 5

Braintree 867

payment bridge configuration 859

Brand loyalty 487

Breadcrumb trail 97

Breadcrumb Trail 573

Browsing Category 125

Bundle Product 153, 169

group price 235-237

Items 171

Business location 61

Buy X, Get Y Free 404

C

Cache 1133

configuration 1140

CSS files 1136, 1138

full page 1143

JavaScript 1136

module 1137

Storage Management 1133

system 1137

types 1137

Cache Management 221, 362

Callout 654

Canada

Example Tax Configuration 1001

Canada, PayPal solutions 852

Canadian tax 996

Cancel

order 733

Canceled, order status 761

Canonical meta tag 314, 321

CAPTCHA 1109

configuration, Admin 1110

configuration, store 1112

Capture

offline 870

online 869

Online 764

payment action

Offline 765

Cardholder data 84

Cardinal Centinel 888

Cardinal Centinel 3D Secure 856

Cart contents, retrieve 752

Cash On Delivery 810

Catalog 37

Category Link 610

Event Widget 491

Events 491-492

Events Carousel 610

flat 147

images 194

indexing 147

Input Type for Store Owner 134

menu 47

New Products List 610

Price Rules 341, 376

Product Link 610

Search 262

Catalog Prices, tax 996
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Category 95, 273

create 109

Description 119

Display Settings 120

Flat Index 1124

General Information 118

grayed out 109

hidden 117

ID 113

image 119

landing page 113, 122

levels 96

Levels 110

modify 114

name 119

page 120

path, in URL 314, 321

permissions 126

Permissions 125

Products 124

redirect 332

root 115

Search, disallow 128

tree 109

URL key 113

Category options, Visual Merchandiser 349

CCV 882

CDN 1147

JavaScript use 1147

media retrieval 1147

Certification 6

Channels 507

Check / Money Order 811

Checkbox 50

states 55

Checklist, store launch 12

Checkout process 32, 685

Terms and Conditions 717

Checkout with PayPal 828

Child authorizations, PayPal Express
Checkout 843

Chrome, email 1023

CIM 881

Clean history, scheduled jobs 1072

Clear cache 1134

Clone Category IDs, Smart Category 359-360

Clone Category IDs, Visual Merchandiser 373

Closed for Maintenance 1114

Closed, order status 761

Club, membership 487

CMS 27, 565

Block, category 121

Hierarchy Node Link 610

menu 49

Page Link 610

page redirect 335

Page Versioning 591

page, breadcrumbs 97

Pages 569, 574

Static Block 610

Widget 612

COD 810

Code

Pool, Gift Card 181, 187

Collections Data, cache 1137

Color

message importance 45
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Column 647

dimensions

layout 122

layout 654

sort 52

Combined Gift Card 181, 184

Comma-separated values 1043

Command line

server 1185

Community 36

Poll 432

Compare Products 140, 144, 433, 448

Comparison properties 140

Compilation 1201

Complete, order status 761, 767

compliance 83

Composite product 154

Compound tax 975

examples 975

Conditions, price rule 386

config.xml 1137

configurable

swatch 203

configurable product

swatch 203

Configurable Product 152

create 160

image 165

inventory 258

Manage Stock 258

configurable products 205

Configuration 1247

cache 1137

email addresses 65

search, default 294

security 1099, 1107

Consent, cookies 86

Consistent prices 977

Consulting 6

Contact Us 67

form 632-633

Contacts 67

container size, shipping 916

Content 565, 569

Area 603

Delivery Network 1147

management system 27

merge 1158

page 574

staging 1155, 1159

Conversion page 548

Conversion tracking 542

Convert to Plain Text 1038

Cookie

domain 88

full page cache 90

law 86

lifetime 88

persistent 752

Restriction Mode 85, 87

Restriction Notice 88

session 752

use, Magento 90

Cookie, Limit Sending By 435

Copy from Configurable 164

Copyright notice 668

Copyright Notice, change 645

Countdown ticker 488

1254 Magento Enterprise Edition User Guide, Version 1.14.2.1



Index

Countries Options 61

Coupon 30, 35, 396, 515, 731

code 416

Usage, report 1084

Create

New Attribute 260

order 730

Packages, shipping labels 945

Simple Associated Products 163

Store 71

Store View 71, 76

Website 70

Credentials, login 42

Credit 789

balance, update 792

balance, view 792

card 865

card data, secure 855

cards, multiple 877

history, show 791

memo 716, 769, 793-794

credit card

requirements 83

Credit Memo

Return to Stock 239

Critical, message 45

Cron 362, 1202

Cron job 147, 416, 1131, 1158

Cross-border trade 977

Cross-sells 277, 447

rules 410

CSS

cache 1136, 1138

email 1030

email templates 633, 1024

CSS Files 673

CSV file 769, 906, 1043, 1050, 1075, 1081

customer structure 1045

structure 1044

Currencies, page cache 1140

Currency 62

Import Rates 1019

rates 1018

Setup 1018

symbols 1018

Symbols 1018

to reward points 485

Current Configuration Scope 72-73

Custom

Design

Category 122

layout 123

Layout Update

product 270

Layout Update, category 123

Options 154, 278

redirect 335

scripts 1170

Theme 123, 270

URL 26

URL redirect 319

variable 625

Custom Order Status 762

Customer

account 36, 685, 739

configuration 686

dashboard 691

landing page 687

1255Magento Enterprise Edition User Guide, Version 1.14.2.1



Index

scope 686

VAT Validation 990

wishlists 445

address template 709

address, promotion 423

attribute

create 704

forms 708

balance, reward points 479

balance, update 793

billing address, PayPal Express Checkout 840

CSV structure 1045

engagement 27

group 422, 739

category permissions 125

create 701-702

edit 702

invitation 748

permissions 128

reward points 486

VAT 985

import 1046

journey 24-25

Order Status, RSS feed 517

password 690

promotion 423

retention 34

Reviews, report 1085

segment 30, 422

attribute 708

create 424

price rule 427

Service page 570

Support 64

Tags, report 1085

Customer Information Manager, Authorize.Net 881

customer name format 689

Customers 1077

by Number of Orders, report 1085

by Orders Total, report 1085

reports 1075

CyberSource 866

D

Dashboard 23, 36, 1076

charts 1079

configuration 1077

customer 691

menu 47

Data location 1058

Database

and Media Backup 1179

backup 1179

compression, backup 1179

key, change 1117

media storage 1146

Dataflow 1053

Date Created, Smart Category 359-360

Date Modified, Smart Category 359-360

Date, input type 130

Days of week 59

Default

Config 72

Country 61

Display Currency 1018

email template 1030

Store View 71
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Value 139

Default Pages 573

Default theme 675

Delete Entries, Import 1047

Demo 22

login 42

Magento 21

Design 27, 37, 639

custom, category 122

product 270

Desktop Environment, security 1102

Detach Category, Visual Merchandiser 365

Detach from Category, Visual Merchandiser 368

Developer Client Restrictions 679

Development environment 147-148

DHL 909, 924

shipping labels 937

shipping packages 931

DIBS Payment Services 867

Digital Goods, tax 968

Dimensional weight 908

Direct Post Method, Authorize.Net 878

Disaster Recovery Plan 1105

Discount 376, 815

quantity 228

Display

Actual Price 225

Gift Card Prices 459

Gift Wrapping Prices 459

in Suggested Terms 302

Mode, category 121

not required State 60

Product Prices

category permissions 125

Settings

Category 120

Store Demo Notice 644

Distributing newsletters 504

Documentation 4

Double opt-in 502

Download

links 176

samples 178

Download SKUs, Visual Merchandiser 354, 369

Downloadable Product 153

configure 179

create 174

Downloads, report 1085

Drag and Drop, Visual Merchandiser 366

Drill-down, price 105

Drop shipments, PayPal Express Checkout 842

Dropdown

attribute 161

input type 130

dropdown attributes 204

Duplicate

content 321

URL key 319

Dynamic

media URL 317

URL 313

values, bundle product 169

dynamic image swap 213

E

EAV 147

Types and Attributes, cache 1137
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eBook download 174

ECG 6

Eco tax 969

Ecommerce Tracking, Google Analytics 561

Ecosystem, Magento 7

Edit

permission, price rules 1094

permission, product 1095

Editor, WYSIWYG 577, 1239

electronic check 871

Email

a Friend 432, 434

a Friend, configure 434

addresses, configuration 65

addresses, domain 65

addresses, store 64

campaign 35

CSS file 1026

footer 1027, 1034

header 1026

header template 1031

logo 1025-1026

message templates 1037

Options 67

Reminder Rules 416

Reminder Rules, template 421

RMA 776

template 1024, 1030

template, configure 1021

template, default 1030

Email clients 1022

Email template 67

variables 625

email, browsers 1023

email, upgrades 1026

Empty, page layout 123, 649

Enable

Cookies 572

Qty Increments 258

Search Recommendations 295, 307

WYSIWYG Editor 140

Encryption 84, 1117

Enhanced Ecommerce, Google 553

Entity

Attributes 1052

Equalize

Price Ranges, layered navigation 106

Product Counts, layered navigation 106

EU Member Countries 988

EU Place of Supply 968

European Union

Example Tax Configuration 1005

Event

configuration 491

create 492

date, gift registry 472

edit 492

invitations 497

Selling restrictions 490

Widget 488, 611

event ticker 490

Events 487

log 1172

Evergreen content 565

eWAY Direct 868

Excel 769

XML 1081
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Exception

Package 670

Export 1052

Dataflow 1053

failed email 1058

product data 1052

product types 1052

reindex 1058

Scheduled 1066

Settings 1052

to, report 1081

Expressed consent, cookies 86

Extension

install 1164

social media 518

F

Facebook 7, 519

extensions 518

Open Graph 524

Facebook Configuration 523

Facebook, developers 523

Favicon 641

FedEx 909, 919

shipping labels 937

shipping packages 928

Fee failure, recurring payment 267

Feed reader 515

File

attachment, input type 707

compression, backup 1178

history, clean 1072

validation, import 1046

Filter

by Attribute 114

controls 53

Filterable

attribute 103, 145

Filters 50

Firefox, email 1023

Firewall 84

First Data Global Gateway 866

Fixed Product Tax 969

input type 130

Flat

catalog 147

setup 147-148

index 1124

Rate Shipping 898

Flush

Cache Storage 1136

Catalog Cache 1136

JavaScript cache 1136

JavaScript/CSS Cache 1136, 1138

Magento Cache 1136

product image cache 1136

Flush Swatch Image Cache 207

Flush Swatch Images Cache 221

Footer 603, 645, 665, 668

Footer, email 1034

Forms

attributes 708

Forum, Magento 5

FPT 969

attribute 972

configuration 971

in attribute set 973
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in product 973

France, PayPal solutions 852

Fraud Management Filters, PayPal 851

Free

demo 22

shipping 900

shipping, price rule 401

Frontend

properties 134

Restriction, staging 1157

FTP

calculations 969

Fulfillment 767

Full

page cache 1137, 1143

page cache, cookies 90

page cache, settings 1140

reindex 1129

G

[GLOBAL] 73

Gateway, payment 865

General

Contact 64-65

Product Information 260

Get Extension Key 1164

Gift

receipt 456

Gift Card 153, 181, 457

account 185

account, multiple 182

apply to order 731

balance 182, 699

configure 187

create 183

deactivate 183

email template 188

expiration date 189

lifetime 184

multiple 183

partial deduction 183

prices 184

redeem 182

refund 183, 798

status 182

transfer balance 699

type 184

Gift Message 456

module, disable 461

Gift Options

add 745

configure 459

entire order 458

individual item 458

product 271, 455

Tax configuration 459

taxes 460

Gift Registry 457

configure 467

create 469

event date 472

manage 745

Search 466, 476, 611

storefront 466

Widget 475

workflow 465
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Gift Wrapping 456

Design 462

price 745

product 271

refund 798

Global

attribute scope 161

search 50-51

Gmail 1022

Goods & Services Tax 1001

Google 529

Analytics 529

Analytics, cookies 87, 91

API for Shopping 508

Classic Analytics 560

Enhanced Ecommerce 553

Merchant Center 508, 529-530

Product Listing Ads 530

Reader 515

Shopping 530

Sitemap 529, 535

Tag Manager 542

Universal Analytics 551, 553

Webmaster Tools 536

Google API

Google Analytics 562

Google Merchant Center 560

Grid

filter 53

sort 52

View As 289

Grid, Product 98

Group price 235-237

group_price attribute 235-237

Grouped Product 152

create 157

GST 1001

Guest

retrieve cart contents 752

H

Handle 664

handling fee 916

Hashing 1117

Header 603, 665, 667

welcome message 643

Header template, email 1031

Help 4

Hero products, Visual Merchandiser 350

Hero Products, Visual Merchandiser 351

Hero Products, Visual Merchandiser | Default.EE 1-
14-1 | [107] 353

Hidden

category 109, 117

website 1155

Hierarchy 591

menu 591

Hold, order 733

Home page 570

New Products list 615

Home Page, default 573

Hong Kong, PayPal solutions 853

HTML

editor 577

email 1030

head 537

Head 665-666

in product description 145
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product descriptions 130

suffix 313

HTTP authentication, staging 1157

I

Image

cache, flush 1136

catalog, add 196

import 1048

placeholder 156, 178, 198

size 194

sort order 197

URL 579

watermarks 199

zoom 193

Image Label, Smart Category 359-360

Implementation 37

Implied consent, cookies 86

Import 1046

Behavior 1051

Currency Rates 1019

Dataflow 1053

failed email 1058

Failed Emails, scheduled 1065

File Information, scheduled 1064

file validation 1046

guidelines 1050

images 1048

Product Images 1053

reindex 1058

Scheduled 1059

Settings, scheduled 1063

table rates, shipping 907

Tax Rates 960, 962

in-line styles 1024

In Anchor, category 121

In Stock 247

Inbox, Admin 43

Include / Exclude Tax 1010

Include Gift Receipt 456

Include in

Advanced Search 287

Navigation Menu 117, 120

Incoming Messages 43

Index 1121

actions 1129

Clean Schedule 1131

cleanup 1131

configure 1124

Management 1122

modes 1127

Options 1124

schedule 1131

Indexing speed 147

Initial Fees, recurring payment 269

Input type

bundle product 171

customer attribute 706

file attachment 707

image upload 707

Input Validation 139

Insert image 579

Install

extension 1164

Magento 11, 42

patch 1185
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Installation

Security 1103

Integration 1167

Interface text, change 679

Internet Explorer

email 1023

Inventory 239, 241

configurable product 258

Configuration 241

Manage Stock 247

Invitation 497

configure 497

Reports 499

URL 750

Invitations

manage 748

reports 1075

resend 748

Invoice 714-715, 764, 766, 769

Comments 766

Invoiced

order, download product 179

IP Address, Limit Sending By 435

IP Anonymization, Google Analytics 552, 562

IP ddress 78

iPhone, email 1022

Is Active 119

Is Anchor 114, 116

Italy, PayPal solutions 852

Item Attributes, RMA 784

Iterative splitting, price navigation 105

J

Japan, PayPal solutions 852

JavaScript

cache 1136

JavaScript files 673

K

Knowledge base 4

Kount Fraud Detection Service 857

L

Label

price rule 387

shipping 938

LAMP 10-11

Landing page 301

Landing page, customer account 687

Language 73

Chooser 69

Language Pack, Add 74

layered navigation

swatch 205

Layered Navigation 102, 121, 139

filterable 103

Interval Division Limit 106

product count 102

Solr 300

Layered Price Navigation Step 121

layout

update 653

Layout

custom 123
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update 595, 664

Layout Update 614

banner 605

syntax 658, 661

widget 614, 618

Layouts

cache 1137

Left Column 603

Lifetime Sales 23

Light box 192

Like button, Facebook 519

Link

image 579

LinkedIn 7

Linux 10

List, Product 98

List, View As 289

Listing Sort By, category 121

Load sequence 664

local.xml 1137, 1146

Locale Options 59

Locale, language 74

localization

swatch 218

Log archive 1174

Log report 1174

Logic, Smart Category 361

Login

Admin 42

demo store 42

Magento account 15

Logo 667

header 640

Logo image, email 1025

Low Stock, report 1084

Loyalty program 36, 479

M

Madison Island 22

Magento

account 15

Connect 38, 508, 524, 669, 1163

Connect Manager, backup 1178

Connect, install extension 1164

Connect, Manager 1164

cookies 90

Core API 1167

Design Guide 639

Secure Payment Bridge 32, 824, 855, 859, 865

when required 859

Solutions Partners 37

upgrades, email 1026

Magento Connect 676

Magento Connect, Install Extension 74

Magento demo 22, 42

Magento Secure Payment Bridge 888

Setup 858

magnify image 193

Magnify image 193

Main menu 96

Main Menu

Categories 110

Maintenance 572

mode 572, 1114

Major, message 45

Manage

Attribute Sets 136
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Stock 241, 247, 258

Stores 70

Manufacturer's suggested retail price 231

Manufacturer, product 262

MAP (Minimum Advertised Price) 225, 231

Mark as Read 45

markup tag 582, 625, 631, 634

Mass Product Assignment, Visual
Merchandiser 369

Mass Product Assignment, Visual Merchandiser |
Default.EE 1-14-1 | [222] 374

Master Website Code 1157

MasterCard SecureCode 888

Match Period To, report 1082

Matched Expression 678

Maximal Depth 96

Maximal Depth, Top Navigation 110

Media

Image 195, 197

image, input type 130

retrieval, CDN 1147

Storage 579, 1147

Storage, database 1146

URL 317, 579

URL, markup tag 632

Media Storage

swatch 210

Members Only 487, 489, 1114

Membership 487

Memcached 11

Merchandising tools 30

Merchant level, PCI 84

Merchant solutions, PayPal 32

Merge

content 1158

mapping 1158

staging 1155

Message

importance 45

InBox 43

Messages, Admin 43

Meta

Description, product 263

Information 26, 263, 310

category 118

Description 310

Keywords 118, 310

page 574

product 156

Title 310

Information, product 178

Information, Title 263

Keywords, product 263

tag, canonical 321

Millennium Generation

customer segment 426

Mini Shopping Cart Widget 611, 622

Minimum Advertised Price 231

Miscellaneous

HTML 668

Scripts 537

Misspelled words

redirect 301

Solr 299

Mobile

devices, matched expression 678

menu 47
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theme, install 677

Moderate, product reviews 451

Money Order 811

Most Viewed

Products 1077

report 1084

Most Viewed Items 23

Move to Bottom, Visual Merchandiser 368

Move to Top, Visual Merchandiser 367-368

MSRP (Manufacturer's Suggested Retail Price) 225,
231

Multiple

addresses, shipping 897

Select, input type 130

Music download 174

My

Account 15

Applications, customer 692

Orders 692

Product Reviews, customer 692

Tags, customer 692

My Wishlists Link 445

MySQL 10, 293

Fulltext Search 294

N

name and address options 689

Navigation 117

menu 112, 120, 591

properties 139

top 96

New

Accounts, report 1085

Customers 1077

order state 761

Products list 515, 610, 616

Store 71

New Zealand, PayPal solutions 853

Newsletter 35, 501

configuration 502

problems 505

Queue 504

reports 505

templates 503

Next page link 100

Nginx 10

No

checkbox 55

layout updates 123

Node 592-593

Non-inline CSS 633, 1024

Non-sessioned visit 1139

non_inline_styles 1024

Not

Capture, payment action 765

Visible Individually 262

Not Capture 870

Notice, message 45

Notifications, Admin 46

Number of Results, Search Term 305

O

Offline, invoice 877

Offline, refund 877

Ogone DirectLink 867

On Gesture, display price 225

On Hold, order status 732, 761
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Onepage Checkout 717

Online rates 907

online refund 877

Operators, Smart Category 361

Opt-in 502

Oracle 10

order

archive 769

cancel 733

wishlist information 744

Order 714, 761, 764, 766

by SKU 611

cancel 715

create 730

credit memo 716

fulfillment 38

gift options 458

invoice 715

review 717

shipment 715

status 761-762

submit 714

update 732

Order by SKU 620, 692, 734, 736-737

order processing 32

Order Taxes, report 1083

Orders

report 1080

Orders and Returns 611

Origin, point of 896

Out of Stock 244, 246-247, 249, 254

Outlook 1022-1023

Owner, page version 586

P

PA-DSS compliance 32, 855

Package

pricing 230

type, by carrier 928

Package, design 670

Packing slip 766-767

page 583, 587

Page 569

cache, configure 1140

configuration 665

create 574

session, customer 1139

Translate 588

visit, type 1139

Page cache 1137

Page Footer 668

Page Hierarchy 591

configuration 592

Page Layout 123, 270, 601, 647, 650

examples 650

product 270

Page Not Found 571

Page View Tracking, Google Analytics 560

Pages

Default 573

Pagination 100

controls 50, 52, 289

links 289

Parent

category 123

Page Hierarchy 591
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Partial

order, refund 798

refund 793

reindex 1129

Partial authorization 877, 882, 886

Partial invoices 869, 882

Partial payment

workflow 874

Partial refund 877

partners, Magento 6

password

secure 84

Passwords, customer 690

Patch

install 1185

Patch, revert 1184

Pay Now button, PayPal 826

Pay with store credit 793

Paybox Direct 867

payment

action 860

actions 765

gateways 820

multiple cards 877

options 32

Payment

Action, Order 842

gateways 37, 865

methods 37

partial 877

received 714

Review, order status 761

services 37

Payment actions 869

Payment Bridge, Magento Secure 32, 855, 865

configuration 861

gateway configuration 861

Payment Card Industry (PCI) 84

Payment Gateway 868

Testing 868

Payment Methods

Authorize.Net 878

BankTransfer Payment 808

Cash on Delivery 810

Check / Money Order 811

Purchase Order 813

Zero Subtotal Checkout 815

Payment Services 887

PAYONE 867

PayPal 819, 866

Bill Me Later 843

business account 821

Express Checkout 819-820, 828

Billing Agreements 844

Express Checkout, Order Transactions 842

Express Checkout, save billing address 840

Fraud Management Filters 851, 887

merchant solutions 32

Payflow Link 850

Payflow Pro 849

Payments Advanced 822

Payments Standard 826

Settlement Report 847, 1084

solutions 852

PayPal Access 821

PCI Compliance 84

PDF

credit memo 794
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invoice 764

PDF Printouts 802

Pending

order status 714, 761, 767

order, download product 179

Payment, order status 761

PayPal, order status 761

Reviews 451

Tags

moderate 441

Percona 10

Permanent

(301) 328

Redirect 325, 336

Permissions

admin 1087

backup 1178

category 125

custom 1090

page versions 586

rollback 1178

Server, recommended 1197

Persistent

cookie 752

shopping cart 752

PHP 10

PHP script

database media storage 1146

Physical Gift Card 181, 184

Place Order 714

Placeholder image 198

PO 813

Poll 432-433

Manager 436

pop-ups, allow 679

Popular Search Terms 290

Popular Tags 432, 439

report 1085

Postal code, optional 61

Prelaunch checklist 12

Previous page link 100

Price 223-224

adjustment 164

attributes 237

display 1018

display on gesture 225

drill-down 105

input type 130

Minimum Advertised Price (MAP) 231

navigation 102, 105

package 230

permissions 1093, 1096

printed gift card

price 745

product group 235-237

Range, bundle product 169

resources 1093

Special 227

Tier 228

View, bundle product 169

Price consistency 977

Price Rule

Banner 607

Catalog 376, 382

condition, attributes 144

coupon 396

customer segment 427

permissions 1094
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promotions 404, 406

Reward Points 486

Shopping Cart 384

Price Type

Fixed 279

Percentage 279

Print

credit memo 794

shipping labels 934

Priority

duplicate URL keys 320

Privacy

policy 85, 89, 571

Private Sales 487, 489, 1114

invitations 497

Private, Access Level 586

Processing, order status 714, 761

Product

Bundle 169

catalog 37

Configurable 160

create 151

data, export 1052

Description

HTML 145

Downloadable 153

Enable RMA 775

file structure 1044

Flat Index 1124

Gift Card 181

Group Price 235-237

Grouped 157

image cache 1136

image, zoom 193

images 156, 178, 191-192, 196

import 1046

Information 259, 422

Custom Options 278

Design 270

Inventory 241

Prices 223

list 114, 145

by category 633

markup tag 633

new 633

name 261

price, permissions 1096

promotion 423

ratings 36

Redirect 329

Relationship Rules 410

relationships 274, 276-277

return workflow 790

reviews 36, 451

guest 451

moderate 451

report 1085

Simple 154

status, permissions 1093, 1095

suggestions 30

thumbnails 192

type

export 1052

Virtual 166

Product Alerts

configuration 255

run settings 257

Product Bestsellers, report 1084
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Product Images

Import 1053

product list

swatch 206

Product List 98

product page

swatch 206

Product Search, Visual Merchandiser 370

Product Stock Options 241

Product tag

by Admin 440

Product View Page, visible on 145

Products

in Carts, report 1084

Ordered, report 1084

reports 1075

Tags, report 1085

Profiles, Dataflow 1053

promotion_desecription, variable 420

promotion_name, variable 419

Promotions 341

banners 601

Banners 607

Price Rules 404

resources 1094

Protected words, Solr 1151

Protected, Access Level 586

Provincial Sales Tax 1001

PSiGate 867

PST 1001

Public, Access Level 586

Publish

page 577

Publish Revision

permission 586

Purchase Order 813

Q

QR code 396

Quantity

Discount 228

Increments 230, 245, 258

Quick Search 286

attributes 144

Solr 295

Quick Simple Product Creation 163

R

Rating, product 453

Read

permission, price rules 1094

permission, product 1095

Rebuild on category save, Visual Merchandiser 363

Rebuild on product save, Visual Merchandiser 362

Rebuild Smart Categories 362

Recently Compared Products 611

Recently Viewed Products 450, 611

Recommendations

search terms 301

Record selection 50

Recurring Profile 264

customer account 692

Redeem

gift card 184, 699

reward points 479
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Redindex

after export 1058

Redirect

category 332

custom 335

misspelled words 301

product 329

Search Term 305

type 328, 336

URL 323

Redis 11

Refresh

cache 1134

report data 1083

statistics 1083

Refund 789, 793, 795

Authorize.Net 877

manual update 793

partial 793

reward points 479

to store credit 793

Registered customers

customer segment 427

Regular price 224

Reindex 1126

events 1128

full 1129

manual 1126

partial 1129

required 1126

Related

Banners 381, 391

Products 274, 447

rules 410

Search Terms 304

Release Notes 11

Remember Me, shopping cart 752, 754

Remove Products, Visual Merchandiser 375

Reorders

gift options 745

Replace

Complex Data 1047

Existing Data 1060, 1063

Report 1079, 1083

export 1081

invitation 499

newsletter 505

snapshots 23

statistics, refresh 1083

types 1075

wishlist 446

Reports, menu 49

Request Path, rediect 326

Resend invitation 748

Resource Access, Custom 1169

responsive theme 675

REST roles 1097

Return HTML Version 1038

Return Merchandise Authorization 34, 716, 773

Return to Stock 794

Revert Patch 1184

Reviews 433

reports 1075

Reviews and Ratings 451

Reward Points 479, 571

configure 480

customer group 486

exchange rates 484

1272 Magento Enterprise Edition User Guide, Version 1.14.2.1



Index

manage 748

Price Rule 486

priority 484

product review 451

redeem 479

to currency 485

Rewrite, indexer type 1125

Right Column 603

RMA 34, 716, 773

configuration 775

email 776

Item Attributes 784

product 775

shipping 778

system attribute 785

robots.txt 535, 538

Role

custom 1090

Resources 1091

scope 1091

Rollback 1180

content 1159

create 1155

History 1159

merge 1159

resources 1178

Root

category 71, 109, 115

Rotation Mode, banner 606

RSS feed 36, 515

Run settings, product alerts 257

S

[STORE] 73

Sage Pay Direct 867

Sales

channels 507

email 65

email templates 1028

information, promotion 423

menu 47

order 715, 730

reports 1075

Representative 64

Sample

page 570

Samples

download 178

Save Positions, Visual Merchandiser 369

Schedule

merge 1158

recurring payment 267

reindex 1131

Scheduled

import 1059

Import/Export 1058

job, run 1072

Scheduled Jobs, cron 1202

Scope 72, 141

Customer account 686

global attribute 161

settings 73

Scope, Visual Merchandiser 364

Scripts

custom 1170
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Seach

Visual Merchandiser 369

search

tools, storefront 285

Search

Admin 51

configure 293-294

default 294

global 51

index, Solr 295

quick 286

Recommendations 306

Suggestions 296, 300

weight 144

Solr 299

Weighted 298

Search engine

friendly URLs 313

optimization 26, 309

Search results 289

count 295

Solr 299

Search Terms 301

add 302

Number of Results 305

related 304

report 1085

reports 1075

Seasonal changes, rollback 1159

Secure URLs 79-80

Security 84, 1099, 1107

credit card data 855

session variables 1115

systems 84

Security certificate 78

Security, best practices 1100

Select

All 54

Visible 54

Selection, records 50

Selling restriction, events 490

Send Printed Card 458

Sender Email 65

SEO 26, 309

SERP 263

Server 572

backup 1178

rollback 1178

Server Environment, security 1101

Server Permissions, recommended 1197

Service Unavailable 572

503 Service Unavailable 572

Session

cookie 88, 752

customer 1139

ID 1139

Session variables 1115

Sessioned visit 1139

Set Product as New from/to Date 261

Settlement Report, PayPal Express Checkout 847

SFTP

user account, PayPal 847

SHA-256 1117

Share account, Magento 17

Ship

Bundle Items 173

order 714

Shipment 715, 766, 769
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Shipping

bundle product 171

carriers 909, 919, 924

Dimensional weight 908

labels 938

multiple addresses 897

options 32

packages 928

packing slip 767

rates

import 902

online 907

refund 794

RMA 778

Shipping Labels 32, 933

configure 935

create 934

tracking number 934

Shipping Methods 38, 895, 898, 900, 902, 919,
924

Shipping Prices, tax 996

Shipping Settings 63, 896

Shop By 102

Shopping

assistance 723, 739, 742

cart

thumbnails 158

history 35

tools 431

Shopping Cart

persistent 752

price rule 384, 396, 404, 406, 479

promotion 423

thumbnails 164, 201

Show Actual Values, report 1080, 1082

Sidebar, block reference 654

Simple Product 152

create 154

Sitemap 26, 311, 535

Skin folder 672

SKU 260-261

dynamic, bundle product 170

in price rules 382

multiple 382

use of 160

SKUs, download 354, 372

Slider 192

jQuery 604

Small Image 194-195, 197

Smart Category Rule 145

Smart Category Rules 356

Smart Category, rebuild 362

Social

marketing 518

shopping 443

Software download 174

Solr 293, 295

Base Files 1151

configure 300

install 295, 1150

language support 1151

layered navigation 300

Solutions Partners, Magento 37

Sort 50

attributes 144

controls 52

product list 121

Sort By 289
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Sort Options, Visual Merchandiser 365, 368

Spain, PayPal solutions 853

Spam 502

Special Price 225, 227

Special Products, RSS feed 517

Spelling, Solr 1151

Split orders, PayPal Express Checkout 842

SSL 10, 78

Staging Website 27, 1155, 1158

catalog 1160

code 1157

configure 1154

create 1155

database use 1160

disable product 1160

Startup Page

Admin 1078

State is required for 60

States Options 60

Static Block 614

category page 113

Static URL 313

Status

change 54

product 260, 262

Stock Availability 244, 246-247

catalog page 253

Configurable Product 258

product page 251

scenarios 250

Stock, Manage 241

Stop words, Solr 1151

Storage

configuration, media 1146

Store

code, in URL 313

credit 34

customer account 699

gift card balance 699

credit, configuration 791

credit, pay with 793

URL 42

Store Contact Information, variables 1034

Store Demo Notice 644

Store Hierarchy 70

product 156

Store Information 57-58

Store Launch 12

Store URL, markup tag 632

Storefront

CAPTCHA 1109

Storefronts, Visual Mechandiser 364, 368

Stores, multiple 69

Subcategory 109-110, 117

Subdomain, CDN 1147

Submit

Virtual Merchandiser 369

Submit order 714

Subscription

purchase by 264

Success page 548

Suggestions

Search Terms 301

Solr 296

Super Products Attributes Configuration 164

Support 17

Support tools 1207

1276 Magento Enterprise Edition User Guide, Version 1.14.2.1



Index

Support Tools

System Backups 1207

System Reports 1208

Surveys 433, 436

Suspected Fraud, order status 761

swatch 160, 203

add values 208

attribute values 208

configuration 205

dimensions 206

dynamic image swap 213

image cache 221

image labels 212

images 209

layered navigation 205

localization 218

text label 204

upload images 210

upload to product 212

swatches 204

swatches folder, Media Storage 210

Switch Accounts 19

Synchronization 1146

Syndicated content 515

Synonym For 302, 305

Synonyms

search terms 301

Solr 1151

Syntax

layout update 658

System

attribute 137, 785

backup 1179

menu 49

notifications 45

passwords 84

requirements 11

System backups 1207

System Reports 1208

System Requirements 10

System Tools 1171

T

Table Rate, shipping 902

Tag

cloud 290

products, Admin 440

Tag Manager, Google 542

Tags

moderate 441

product 439

RSS feed 515

reports 1075

Target Path, redirect 326, 328

Targeted promotion 30, 422

Tax 38, 951

Calculation Settings 1011

Calculation Settings, configure 953

class

gift options 460

VAT 985

Class 956

customer group 702

Customer group 958-959

Gift options 459

Class, configure 953

Class, price 225
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Compound 975

configuration 952

Digital Goods 968

Discount Settings 1010, 1012

Display Settings, configure 954

gift options 460

rates

VAT 985

Rates 960

Rounding 995

rules

VAT 985

Rules 966

Warning Messages 1010

Zones 960

Tax as line item 996

Tax Calculation Methods 995

Tax Class, Shipping 957

Tax Class, VAT 1005

Tax Rates

Import 962

Tax, Quick Reference 995

Technical support 5

Template

email reminder 421

layout update, widget 612

tag 632-633

variables 625

Templates, transactional email 1037

Temporary (302) 328

Temporary redirect 336

Terms and Conditions 717

Text

Area, input type 130

editor 577

Field, input type 130

theme 676

default 675

responsive 675

Theme 27

change 669

Package 670

Theme files 672

Third-party

applications 37, 1169

Thumbnail 195-196, 201

gallery 192

Image

category 119

Smart Category 360-361

Thumbnail Label
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